Communications Systems and Networks:Table of Contents

 To access the contents, click the chapter and section titles.

Communications Systems and Networks
(Imprint: M & T Books)
(Publisher: IDG Books Worldwide, Inc.)
Author: Ray Horak
ISBN: 1558514856

Foreword
Dedication

Chapter 1—Communications Systems and Networks
Chapter 2—Fundamentals of the Technology: Concepts and Definitions
Fundamental Definitions
Dedicated, Switched, and Virtual Circuits
Dedicated Circuits
Switched Circuits
Virtual Circuits
Two-Wire versus Four-Wire Circuits
Two-Wire Circuits
Four-Wire Circuits
Bandwidth
Carrier
Hertz (Hz)
Baud
Bits per Second (bps)
Transmission Facilities
Analog versus Digital
Analog
Digital
Analog versus Digital Transmission: Which is Better?
Analog Advantages
Digital Advantages
Amplifiers versus Repeaters
Amplifiers (Analog)
Repeaters (Digital)
The Conversion Process: Digital to Analog (D to A) and Analog to Digital (A to D)
Digital to Analog: Modems
Analog to Digital: Codecs
MULTIPLEXERS (MUXs or MUXes)
Frequency Division Multiplexing (FDM)
Time Division Multiplexing (TDM)
Statistical Time Division Multiplexing (STDM)
Wavelength Division Multiplexing (WDM)
Inverse Multiplexers
Data Over Voice and Voice Over Data
Switches and Switching: The Fundamentals (and then some)
Circuit Switching
Packet Switching
Frame Switching (Frame Relay)
Cell Switching
Photonic Switches
Signaling and Control
References

Chapter 3—Fundamentals of Transmission Systems: Technologies and Applications
Frequency Spectrum
Selection Criteria
Transmission Characteristics
Propagation Delay and Response Time
Security
Mechanical Strength
Physical Dimensions
Cost
Twisted Pair: An Introduction to Telephone Wire
The Twisting Process
Gauge
Configuration
Bandwidth
Error Performance
Distance
Security
Cost
Applications
Shielded Copper
Applications
Coaxial Cable
Configuration
Gauge
Bandwidth
Error Performance
Distance
Security
Cost
Applications
Microwave Radio
Configuration
Bandwidth
Error Performance
Distance
Security
Cost
Regulation
Applications
Satellite Radio
Geostationary Satellites
Uplink
Downlink
Broadcast
Configuration
Bandwidth
Error Performance
Distance
Propagation Delay and Response Time
Security
Cost
Regulation
Applications
Infrared
Fiber Optics
Configuration
Analog or Digital?
Bandwidth
Error Performance
Distance
Security
Cost
Durability
Applications: Bandwidth-Intensive
Hybrid Transmission Systems
References

Chapter 4—Voice Communications Systems: PBX, ACD, Centrex, and KTS
Key Telephone Systems (KTSs)
1A1 and 1A2 KTSs
Electronic KTS
Hybrid Key Systems
Private Branch Exchanges (PBXs)
PBX Components
Switching Matrix
Trunk Interfaces
System Configuration and Capacity
PBX Enhancements and Trends
Centrex
Centrex Features
Centrex Advantages
Centrex Disadvantages
Centrex CPE
Centrex Applications
Centrex Trends and Futures
Automatic Call Distributors (ACDs)
ACD Enhancements and Trends
Computer Telephony Integration (CTI)
Technology, Standards and Specifications
Forums and Consortia
Applications
Future
References

Chapter 5—Messaging Systems: Facsimile, Voice Processing and Electronic Mail
Facsimile (Fax) Systems
The Technology
Fax Applications
The Future of Fax
Voice Processing Systems
The Technology
Applications
Voice Processing Developments and Futures
Electronic Mail (e-mail)
The Technology
Features
Applications
Future
References

Chapter 6—Public Switched Telephone Network (PSTN)
Network Characteristics
Voice (Primarily)
Switched (and Dedicated)
Analog (and Digital)
Interconnected!
Wired (and Wireless)
Numbering Plan Administration (NPA)
Domains
Functional Domains
Regulatory Domains
Rates and Tariffs
Carrier Domains and Network Topology
Signaling and Control: An Expanded View
In-Band Signaling and Control
Out-Of-Band Signaling and Control
Common Channel Signaling and Control (CCS)
Network Services
Access Services
Dedicated Transport Services
Value-Added Services
Portability
Equal Access: Another Special Issue
References
General References

Chapter 7—Fundamentals of Data Communications
Functional Domains
Data Terminal Equipment (DTE)
Data Communications Equipment (DCE)
Communications Software
Networks
Switches
DCE: AN EXPANDED VIEW
Modems
Codecs
Terminal Adapters (TAs) and NT-Xs
CSUs and DSUs
Front-End Processors (FEPs)
Protocol Basics
Line Set-Up/Connectivity
Transmission Mode: Transmission Method
Code Sets
Data Format
Error Control: Data Transmission Integrity
Forward Error Correction (FEC)
Data Compression
Asynchronous Data Link Control (DLC) Protocols
Bit- versus Byte-Oriented Synchronous Protocols
High-Level Data Link Control (HDLC)
Network Architectures
Layered Operations Models
Security
Physical security
Authentication
Authorization
Port Security
Transmission Security
Encryption
Firewalls
References

Chapter 8—Conventional Public Data Networks (PDNs)
Evolution of Data Networking
The Voice Model
Data Over Voice Networks
Data Networking Over the WAN (and MAN): Digital Data Networking
Dataphone Digital Service (DDS)
Switched 56 Kbps
Digital Carrier Systems and Networks: T-carrier
T-carrier Concept
Channelized T-carrier
Unchannelized T-carrier
Encoding
Framing
Hardware
Channel Service Units (CSUs) and Digital Service Units (DSUs)
Variations on the Theme: E-carrier and J-carrier
Fractional T1
T-carrier Applications
T-carrier Developments and Futures
Digital 800 Services
X.25 Packet Switching
The Concept of Packet Switching
Packet Switching Standards
Packet Switching Applications and Futures
Standard Interfaces and Channel Types
ISDN Equipment
ISDN Characteristics And Benefits
ISDN Characteristics and Drawbacks
ISDN Standards
ISDN Applications
International ISDN: Variations on the Theme
Broadband Data Networking
Frame Switching (Frame Relay)
Cell Switching
References

Chapter 9—Local Area Networks: Connectivity and Internetworking
LANs Defined
LAN Applications and Benefits
Media Alternatives
Topology: Physical and Logical Configurations
Baseband versus Broadband
Media Access Control
LAN Equipment
Network Interface Cards (NICs)
Bridges
Hubs and Switches
Routers
Gateways
LAN Segmentation
LAN Operating Systems
LAN Internetworking
WANs
High-Level Internetworking Protocols
Virtual LANs (VLANs)
Remote LAN Access
LAN Standards and Standards Bodies
Life in the Fast LAN: The Need for Speed
100Base-T, or Fast Ethernet
Iso-Ethernet (Isochronous Ethernet Integrated Services)
100VG-AnyLAN
FDDI (Fiber Distributed Data Interface)
ATM (Asynchronous Transfer Mode)
FireWire
Nonstandard LANs
References

Chapter 10—Broadband Network Infrastructure
Local Loop Technologies
Asymmetric Digital Subscriber Line (ADSL)
High Bit-Rate Digital Subscriber Line (HDSL)
Wireless Local Loop (WLL)
Hybrid Local Loops
SONET/SDH
SONET Standards Development
SONET/SDH Transmission Hierarchy
SONET/SDH Topology
Paths, Tributaries and Channels
Sonet Frame Format
SONET/SDH Hardware
Advantages of SONET
Applications of SONET/SDH
References

Chapter 11—Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs
Frame Relay
Frame Relay Defined
Frame Relay Standards
Frame Relay Access
Frame Relay Network
Frame Relay Equipment
Frame Relay Protocol: Frame Structure
Local Management Interface (LMI) Protocol
Congestion Management
Frame Relay Costs
Frame Relay Advantages and Disadvantages
Frame Relay Applications
Switched Multimegabit Data Service (SMDS)
SMDS Defined
SMDS Standards
SMDS Access
SMDS Network
SMDS Protocols: Segmentation and Reassembly and Cell Structure
SMDS Costs
SMDS Advantages
SMDS Disadvantages
SMDS Applications
Asynchronous Transfer Mode (ATM)
ATM Defined
ATM Standards
ATM Access
ATM Network and Equipment
ATM Protocols and Cell Structure
ATM Performance: Quality of Service (QoS)
ATM Advantages
ATM Disadvantages
ATM Costs
ATM Applications
Broadband ISDN (B-ISDN)
Broadband ISDN (B-ISDN Defined)
B-ISDN Access
B-ISDN Services
B-ISDN Equipment
B-ISDN Costs
B-ISDN Advantages
B-ISDN Disadvantages
B-ISDN Applications
Advanced Intelligent Networks (AINs)
AIN Defined
Service Creation Environment (SCE)
AIN Architecture
AIN Services
AIN Futures
References

Chapter 12—Wireless Networking: Voice and Data
Wireless Defined
Standards and Regulation
Advantages and Disadvantages of Wireless
The Cell Concept: Frequency Reuse
Digital versus Analog
Multiplexing and Access Techniques
Frequency Division Multiple Access (FDMA)
Time Division Multiple Access (TDMA)
Code Division Multiple Access (CDMA)
Switched Mobile Radio (SMR)/Trunk Mobile Radio (TMR)
Enhanced Switched Mobile Radio (ESMR)
Paging
Paging Networks
Paging Equipment
Paging Applications
Paging Developments
International Paging
Cordless Telephony And Wireless Office Telecommunications Systems (WOTS)
Cordless Telephony Standards
Cellular Radio
Cellular Standards
Cellular Data Communications
Wireless Data Networks: Packet Radio
Wireless LANs
Wireless LANs: Applications and Futures
Wireless Local Loop (WLL)
WLL Field Trials and Implementations
Personal Communications Services (PCS)
PCS Networks
PCS Equipment
PCS Services and Applications
Low-Earth Orbiting Satellites (LEOs)
Personal Digital Assistants (PDAs)
PDA Equipment
PDA Networking
PDA Functions and Applications
PDA Advantages and Disadvantages
PDA Futures: Gadgets in Search of a Market?
References

Chapter 13—The Internet (the Net) Environment
The Internet Defined
Internet Physical Topology
Internet Standards, Administration, and Regulation
Internet Network
User Equipment Requirements
Internet Access
Internet Service Providers (ISPs)
Public Access Providers
Direct Connections
CATV Access
Internet Access Costs
Dialup Access
Dedicated Access
Network Domains
Internet Protocols
Transmission Control Protocol (TCP) and Internet Protocol (IP)
Internet Applications
E-mail
File Transfer
BBSs
Library Catalogs
Realtime Applications
Online Banking
Video Broadcasting
Radio Broadcasting
Internet Telephony
Remote Messaging
World Wide Web (the Web)
Web Sites and Home Pages
Universal Resource Locators (URLs)
WWW Standards
WWW Applications
Search Mechanisms and Browsers
Intranets
Internet Security
Security Risks and Countermeasures
Misuse and Content
Internet Oddities, Screwball Applications, and Some Really Good Ideas
Author’s Explanations
References

Chapter 14—Video and Multimedia Networking
Video Communications Defined and Evolved
Video Basics
Analog TV Standards
Digital TV
High Definition TV (HDTV)
Bandwidth and Compression
Video Standards
Px64
JPEG
MPEG
Video Equipment
WAN Video Networks
LAN-Based Video Networks
Videoconferencing
Multimedia
Software: Focus on Collaboration
LAN Networking
MAN Networking
WAN Networking
The Internet
Multimedia Standards
The Future of Video and Multimedia
Telemedicine
References

Chapter 15—Convergence: Information Superhighway or Superhypeway?
Definition
Applications
Network Technologies
Terminal Technologies
Driving Forces on the Superhighway
Deregulation and Competition
Applications
Technology
Providers of the Toll Roads
Telecommunications Networks
Data Communications Networks
CATV Networks
Wireless Networks
Electric Power Utilities
The Internet
The Converged Network
I-Way Issues
Standards
Regulation
Taxation
Assignment and Portability of Logical Addresses
Interconnectivity
One Potato, Two Potato, Three Potatoe, Four…
Content is the Key
The Feeding Frenzy: Satisfaction or Acid Indigestion?
Repaving the Information Superhighway
In Other News
References

Chapter 16—Regulation: Issues Without Answers
Telecommunications Act of 1996
Lines of Business
Mergers and Acquisitions
Rules and Implementation
Rates and Tariffs
The Internet
Number Portability
Re-Landscaping: Reorganizations and Mergers
AT&T
SBC/Pacific Telesis
Bell Atlantic/NYNEX
Future of the FCC
So, What This Means to Me Is…?
References
Appendix A
Index


Communications Systems and Networks:Foreword

Table of Contents

FOREWORD

This book is more than a reference.

Of course, it will come in handy to many professionals who need to bone up instantly on the capabilities or interface requirements of a particular communication technology. For them, Ray Horak gets to the point quickly every time and seems to anticipate the questions that arise in your mind as you unravel each subject.

But it’s not just about protocols and layers. It’s about is context. And it’s not a coincidence that that’s the name of Ray’s corporation.

Putting a network into context means putting it into the real world and explaining what some typical uses and challenges might be. The original framers of the Internet had no idea some college student would want to use it to make cheap international phones calls. But once you and I understand that, we can better provide solutions for our ourselves and others.

The Handbook of Communications Systems and Networks provides a political context, too, in its exploration of the regulatory environment. There is even a thought-provoking look into the future with the unrealized capabilities of B-ISDN and AINS.

As a technology reporter on television and radio, I have known Ray as both a colleague and an interview subject. In TV parlance, he’s a great sound bite. It’s gratifying to see him apply his broad understanding and rare communications skills to such a complex and moving target.

Context is what it’s all about.

Richard Hart

Host of the Discovery Channel's The Next Step and C|net's C|net Central

Why This Book is For You

[T]he intellectual treatment of any datum, any experience, any subject, is determined by the nature of our questions, and only carried out in the answers.

—Susanne K. Langer, Philosophy in a New Key (1942)

Communications Systems and Networks anticipates virtually every question you might have about the fundamentals of communications systems and networks. The answers both address the origins and describe the evolutionary paths of the concepts and underlying technologies. Sufficient technical detail is provided for thorough understanding of communcations technologies and their meaningful application. Those who wonder how and why networks work will find that this book answers those questions in a plain-English and commonsense way.

Communications Systems and Networks begins with discussion of fundamental concepts of voice, data, video systems, and networks in both the wired and wireless world and guides the reader through the complexities of networks and networking, from the most basic to the most complex, from the mature to the developing, from the practical to the still conceptual. Communications Systems and Networks is absolutely unique in the breadth of subjects covered and manner in which they are presented. The technologies and their applications of voice, data, video systems, and networks are set in the context of standards and regulation. Costs and cost issues involving the technologies are compared and contrasted. The reader will find this book to flow very logically and smoothly, weaving something of a story in the process, punctuated with reallife examples and endowed with a sense of humor.

This book is intended for several distinct types of readers. Those who are new to the world of voice, data, and video 0communications, and those who have a need to understand communications systems and networks in context, will find Communications Systems and Networks to be an essential part of that learning experience. Those more experienced will find that this book provides a comprehensive update of older technologies, and that it explains new and emerging technologies with unusual clarity and purpose. Executives, managers and communications professionals of every description will find Communications Systems and Networks to be an invaluable reference well into the future of the networked world.

Through this book, you will:

• Learn the fundamental concepts of circuits, multiplexers, switches, signaling, and control, and other essential network devices and processes.
• Grasp the fundamentals of transmission systems from analog to digital, from twisted-pair through fiber optics, and from wired through wireless.
• Discover the significant changes taking place in the world of voice systems and networks, including computer telephony integration.
• Understand the separate messaging technologies of facsimile, voice processing, and email, as well as the present and future of integrated messaging.
• Comprehend the basics of data communications protocols, including line setup, coding schemes, asynchronous versus synchronous, and error detection and correction.
• Explore the evolution of digital and data networking, from DDS and X.25, through, T-carrier, ISDN, SMDS, Frame Relay, ATM and B-ISDN.
• Gain a thorough understanding of LANs and LAN Internetworking.
• Discover the infrastructure issues and technology shifts leading to SONET/SDH and fiber/coax/copper/wireless hybrid transport.
• Compare and contrast the options for wireless data networking in the LAN, MAN and WAN domains.
• Develop a thorough understanding of the Internet and World Wide Web, including the applications they serve, the issues they raise, and the risks they present.
• Determine the status of video and multimedia communications for application in a practical business context.
• Track the development of network convergence, with an eye toward interactive applications.
• Gain a sense of the fundamental changes taking place in regulation, with focus on the impact of the Telecommunications Act of 1996.

Table of Contents


Communications Systems and Networks:Dedication

Table of Contents

Dedication

To Margaret, without whose love, support, dedication, patience, and friendship this book would never have been possible. Margaret, I love you truly and always will be by your side.

To Mark Miller, who read my course manual, saw a book in it, and ensured its technical integrity. Mark, thank you for your true friendship and unswerving support.

To my mother, Maxine Horak Winslow, who instilled in me a love of books and learning and taught me the art of listening. Thanks, Mom, you were right—I never learned anything by talking.

To my father, Adolph Alois Horak, who left this earth all too soon. Dad, I miss you very much and hope to have made you proud of me in some small way.

Acknowledgments

A friend may well be reckoned the masterpiece of nature.

–Ralph Waldo Emerson

I owe a great deal to a a great many true friends who freely gave of their knowledge, expertise, time, effort, and technical resources to make this book a reality.

This book began in 1995 as a course manual for Fundamentals of Networking and Data Communications, sponsored by Network World as a cornerstone of its Technical Seminar series. Bill Reinstein of Network World, with the encouragement of Mark Miller of Diginet Corporation, had the courage to depart from his highly successful model and sponsor a series of seminars on fundamentals. The result was a seminar designed to introduce datacom and the underlying network technologies to a new generation of communications professionals.

Mark Miller, further, saw a book in that manual. Paul Farrell, Vice President and Associate Publisher of M&T Books, agreed and was willing to take on a first-time author. Debra Williams Cauley, Acquisition's Editor, worked tirelessly to edit the manuscript and graphics, coordinating the many pieces and processes to turn it into a book.

As consulting editor, Mark Miller was invaluable, applying his considerable knowledge and skill to ensure its technical integrity at every level. Rick Luhmann, as technical editor, provided guidance across a wide range of technologies and applications; his skill and experience as an author and editor also enhanced the style and flow.

A number of individuals provided me with free and easy access to their technical libraries: John Bray, Don Hiatt, Dr. Heather Hudson, Rick Luhmann, Jeff Owen, and Gerry Ryan. In particular, I owe a great debt of gratitude to Dr. Hudson, Director of the Telecommunications Program at the McLaren College of Business, University of San Francisco. Dr. Hudson offered me a position as Adjunct Faculty and supported me with unrestricted access to her substantial library.

Ron Andersen is a great friend who provided me with a home-away-from-home during portions of my research and was always supportive in every way. My children, Brenna and Barrett, understood that they couldn’t visit their father while he was working on the book during the summer of 1996, despite the fact that we miss each sorely.

Most of all, I am forever indebted to Margaret Blanford. Her love and devotion translated into long hours of graphics development for both the original course manual and this book. Her common sense, level-headedness, cheerful attitude, good nature, and wonderful sense of humor kept this author on the right track.

Margaret’s daughter, Kristin Goodman, helped with the graphics, in addition to keeping us on our toes. Finally, thanks to Max, the brave and fierce wiener dog, who kept me safe, loved me unconditionally, and provided considerable comic relief.

I get by with a little help from my friends.

–The Beatles

Tools, Etc.

Word Processor Software: Word for Windows 6.0; Microsoft

Graphics Software: PowerPoint 4.0; Microsoft

Clipart: NetDraw 3.0; Network World

Foreword by the Consulting Editor

Most of the time, being first has a certain thrill–whether that is winning a softball tournament, being first in line for movie tickets, or getting to sit up front in an airplane. But when you get to be first at two times simultaneously, that’s even better. And for me, that’s the fortunate position that I have–getting to have the first word in a new book, with the new book being the first of a new series, the Networking Technologies Library from M&T Books.

The landscape of telecommunications technologies is changing at an ever-increasing pace. Computing power is increasing so rapidly that the obsolescence of some platforms is now measured in months, not years. On the communications front, new technologies, such as frame relay and ATM, have replaced leased circuits, such as T1 lines, that were projected to last many years.

These changes fall into the “good news–bad news” category of stories. The good news is that the price performance of both computing and communications has dramatically improved in the last few years. The bad news is the with these technology advances, the challenges given to network managers have increased in direct proportion. As a result, most of us have to run pretty hard just to keep up.

To address this dilemma, we at M&T Books are launching a new series, called the Networking Technologies Library, which is designed to present solutions to these challenges that network administrators, designers and managers face. We are excited about the new series, and trust that you, our readers, will share our enthusiasm.

To launch the new series, we asked Ray Horak to develop Communication Systems and Networks, which is a concise, yet complete discussion of the technologies that will shape our business communication strategies into the 21st century. I have known Ray for many years. He is a respected veteran and consultant in the industry. Undoubtedly many of you have read his journal articles or research reports, or attended his excellent seminars. This book attempts to capture his vast experience in printed form–the only thing missing is his deep Texas accent!

Our hope is that through this book, and others in the series which are planned, that your journey into this exciting industry will have fewer memory shortages and no packet retransmissions. Hang on–your first ride into the 21st century of data networking will be a thriller!

Mark A. Miller

mark@diginet.com

September 1996

Table of Contents


Communications Systems and Networks:Appendix A: Acronyms and Abbreviations

Table of Contents

Appendix A

Acronyms and Abbreviations

AAL
ATM Adaption Layer
AAV
Alternative Access Vendor
ABR
Available Bit Rate
ACD
Automatic Call Distributor
ADM
Add/Drop Multiplexer
ADML
Asymmetric Digital Microcell Link
ADPCM
Adaptive Differential Pulse Code Modulation
ADSL
Asymmetric Digital Subscriber Line
AIN
Advanced Intelligent Network
AM
Amplitude Modulation
AMPS
Advanced Mobile Phone System
ANSI
American National Standards Institute
AP
Adjunct Processor
APPN
Advanced Peer-to-Peer Networking
ARCnet
Attached Resource Computer Network
ARPANET
Advanced Research Projects Agency Network
ARS
Automatic Route Selection
ASCII
American Standard Code for Information Interchange
ATM
Asynchronous Transfer Mode
B-ISDN
Broadband ISDN
BBS
Bulletin Board System
Bc
Committed Burst Size
BCS
Binary Synchronous Communications
Be
Excess Burst Size
BECN
Backward Explicit Congestion Notification
Bellcore
Bell Communications Research
BFT
Binary File Transfer
BOC
Bell Operating Company
bps
Bits Per Second
BRI
Basic Rate Interface
BSS
Broadband Switching System
C/R
Command/Response
CAI
Common Air Interface
CAP
Competitive Access Provider
CAPI
Common ISDN API
CATV
Community Antenna TV
CBDS
Connectionless Broadband Data Service
CBR
Constant Bit Rate
CCIR
Consultative Committee on International Radiocommunications
CCITT
Consultative Committee on International Telegraphy and Telephony
CDDI
Cable Distributed Data Interface
CDMA
Code Division Multiple Access
CDPD
Circuit Digital Packet Data
CDR
Call Detail Recording
CDV
Cell Delay Variability
Centrex
Central Exchange
CER
Cell Error Ratio
CERT
Computer Emergency Response Team
CIF
Common Intermediate Format
CIR
Committed Information Rate
CLNP
Connectionless Network Protocol
CLP
Cell Loss Priority
CLR
Cell Loss Ratio
CMR
Cell Misinsertion Rate
CPE
Customer Premise Equipment
CRC
Cyclic Redundancy Check
CS
Convergence Sublayer
CSMA
Carrier Sense Multiple Access
CSMA/CA
Carrier Sense Multiple Access/Collission Avoid
CSMA/CD
Carrier Sense Multiple Access/Collission Detect
CSTA
Computer Supported Telephony Applications
CSU
Channel Service Unit
CT
Cordless Telephony
CTD
Cell Transfer Delay
CTI
Computer Telephony Integration
DACS
Digital Access Cross-Connect System
DAMA
Demand-Assigned Multiple Access
DARPANET
Defense Advanced Research Projects Agency Network
DBS
Direct Broadcast Satellite
DCCS
Digital Access Cross-Connect System
DCE
Data Communications Equipment
DCT
Discrete Cosine Transform
DDS
Digital Dataphone Service
DE
Discard Eligibility
DECT
Digital European Cordless Telecommunications
DES
Data Encryption Standard
DID
Direct Inward Dialing
DISA
Direct Inward System Access
DLC
Digital Loop Carrier
DLCI
Data Line Connection Identifier
DPCM
Differential Pulse Code Modulation
DPF
Data Private Facility
DQDB
Distributed Queue Dual Bus
DSA
Digital Switched Access
DSI
Digital Speech Interpolation
DSMA
Digital Sense Multiple Access
DSS
Direct Satellite System
DSU
Digital Service Unit
DTE
Data Terminal Equipment
DXI
Data Exchange Interface
EA
Address Field Extension
EBCDIC
Extended Binary Coded Decimal Interchange Code
ECC
Electronic Common Control
ECMA
European Computer Manufacturers Association
ECN
Explicit Congestion Notification
ECSA
Exchange Carriers Standards Association
ECTF
Enterprise Computer Telephony Forum
EIA
Electronic Industries Association
EKTS
Electronic Key Telephone System
EMI
Electromagnetic Interference
EPABX
Electronic Private Automatic Branch Exchange
ERMES
European Radio Message System
ESF
Extended Superframe
ESMR
Enhanced Switched Mobile Radio
ETSI
European Telecommunications Standards Institute
FCC
Federal Communications Commission
FCS
Frame Check Sequence
FDD
Frequency Division Duplex
FDDI
Fiber Distributed Data Interface
FDM
Frequency Division Multiplexer
FDMA
Frequency Division Multiple Access
FDX
Full Duplex
FEC
Forward Error Correction
FECN
Forward Explicit Congestion Notification
FEP
Front-End Processor
FEX
Foreign Exchange
FM
Frequency Modulation
FOD
Fax-on-Demand
fps
Frames per Second
FRAD
Frame Relay Assembler/Disassembler
FRND
Frame Relay Network Device
FTP
File Transfer Protocol
FTTC
Fiber-to-the-Curb
FTTN
Fiber-to-the-Neighborhood
FX
Foreign Exchange
GEO
Geosynchronous Earth Orbiting
GFC
Generic Flow Control
GII
Global Information Infrastructure
GSM
Global System for Mobile Communications
HAN
Home Area Network
HDLC
High-Level Data Link Control
HDSL
High Bit Rate Digital Subscriber Line
HDTV
High-Definition TV
HDX
Half Duplex
HEC
Header Error Control
HPPI
High Performance Parallel Interface
HTML
Hypertext Markup Language
HTTP
Hypertext Transport Protocol
Hz
Hertz
IAB
Internet Architecture Board
IANA
Internet Assigned Numbers Authority
ICF
Interexchange Compatibility Forum
ICN
Implicit Congestion Notification
IEC
Interexchange Carrier
IEC
International Electrotechnical Commission
IEEE
Institute of Electrical and Electronics Engineers
IETF
Internet Engineering Task Force
IN
Intelligent Network
IP
Intelligent Peripheral
IP
Internet Protocol
IPX
Internet Packet Exchange
IRC
International Record Carrier
IRTF
Internet Research Task Force
ISDN
Integrated Services Digital Network
ISO
International Standards Organization
ISOC
Internet Society
ISP
Internet Service Provider
ISSI
Inter-Switching System Interface
ITU
International Telecommunications Union
IVR
Interactive Voice Response
IXC
Interexchange Carrier
JDC
Japanese Digital Cellular
JPEG
Joint Photographic Experts Group
JTACS
Japanese Total Access Communications Systems
KTS
Key Telephone System
LAN
Local Area Network
LAPB
Link Access Protocol-B
LAPD
Link Access Protocol-D
LATA
Local Access and Transport Area
LCR
Least Cost Routing
LEC
Local Exchange Carrier
LED
Light Emitting Diode
LEO
Low-Earth Orbiting
LMDS
Local Multipoint Distribution Services
LMI
Local Management Interface
LOH
Line Overhead
LRC
Longitudinal Redundancy Check
MAC
Media Access Control
MAE
MERIT Access Exchange
MAN
Metropolitan Area Network
MAU
Media Access Unit
MCTD
Mean Cell Transfer Delay
MCU
Multi-Point Control Unit
MDP
Motorola Data Protocol
MEO
Middle Earth Orbiting
MFJ
Modified Final Judgement
MHS
Message Handling Service
MILNET
Military Network
MIME
Multipurpose Internet Mail Extension
MOD
Music-on-Demand
MPEG
Motion Picture Experts Group
MTS
Message Telecommunications Service
MTSO
Mobile Traffic Switching Office
MTSX
Mobile Traffic Switching Exchange
MVIP
Multi-Vendor Integration Protocol
N-AMPS
Narrowband-AMPS
NAP
Network Access Point
NIC
Network Information Center (NIC) Internet Registery
NIC
Network Interface Card
NII
National Information Infrastructure
NNI
Network-to-Network Interface
NOS
Network Operating System
NREN
National Research and Education Network
NSFNET
National Science Foundation Network
NT
Network Termination
NTSC
National Television Standards Committee
NTU
Network Termination Unit
OC
Optical Carrier
OCC
Other Common Carrier
OPX
Off Premise Extension
OSI
Open Systems Integration
OSPF
Open Shortest Path First
PABX
Private Automatic Branch Exchange
PAD
Packet Assembler/Disassembler
PAL
Phase Alternate Line
PAM
Pulse Amplitude Modulation
PBX
Private Branch Exchange
PCM
Pulse Code Modulation
PCMCIA
Personal Computer Memory Card Industry Association
PCN
Personal Communication Network
PCS
Personal Communication Services
PDA
Personal Digital Assistant
PDU
Protocol Data Unit
PHY
Physical Layer
PM
Phase Modulation
PM
Physical Medium
POCSAG
Post Office Code Standardization Advisory Group
POH
Path Overhead
POP
Point of Presence
PPO
Private Paging Operator
PPP
Point-to-Point Protocol
PRI
Primary Rate Interface
PSC
Public Service Commission
PSK
Phase Shift Keying
PSTN
Public Switched Telephone Network
PTI
Payload Type Identifier
PUC
Public Utility Commission
PVC
Permanent Virtual Circuit
QCIF
Quarter-CIF
QoS
Quality of Service
QPSX
Queued Packet Synchronous Exchange
RACE
Research for Advanced Communications in Europe
RBOC
Regional Bell Operating Company
RCC
Radio Common Carrier
RD-LAP
Radio Data-Link Access Protocol
RFI
Radio Frequency Interference
RHC
Regional Holding Company
RIP
Routing Information Protocol
S-HTTP
Secure HyperText Transport Protocol
SAA
Systems Application Architecture
SAR
Segmentation and Reassembly
SAT
Subscriber Access Terminal
SATAN
Security Administrator Tool for Analyzing Networks
SCE
Service Creation Environment
SCP
Signal Control Point
SCSA
Signal Computing System Architecture
SDH
Synchronous Digital Hierarchy
SDLC
Synchronous Data Link Control
SDN
Software-Defined Network
SDSL
Symmetrical Digital Subscriber Line
SECAM
Systeme Electronique Couleur Aven Memoire
SECBR
Severely Errored Cell Block Ratio
Sesame
Secure European Systems for Applications in a Multivendor Environment
SIG
SMDS Interest Group
SIM
Subscriber Identification Module
SIP
SMDS Interface Protocol
SLIP
Serial Line Interface Protocol
SMDR
Station Message Detail Recording
SMDS
Switched Multimegabit Data Service
SMR
Switched Mobile Radio
SMS
Service Management System
SMTP
Simple Mail Transport Protocol
SNA
Systems Network Architecture
SNI
Subscriber Network Interface
SOH
Section Overhead
SONET
Synchronous Optical Network
SPE
Synchronous Payload Envelope
SPX
Sequenced Packet Exchange
SRP
Source Routing Protocol
SRT
Source Routing Transparent
SS7
Signaling System 7
SSL
Secure Socket Layer
SSP
Service Switching Point
STDM
Statistical Time Division Multiplexer
STP
Shielded Twisted Pair
STP
Signal Transfer Point
STP
Spanning Tree Protocol
STS
Synchronous Transport Signal
SVC
Switched Virtual Circuit
SxS
Step-by-Step
T
Measurement Interval
T-Carrier
Trunk Carrier
TA
Terminal Adapter
TACS
Total Access Communications Systems
TAPI
Telephony Application Programming Interface
TASI
Time Assigned Speech Interpolation
Tc
Committed Rate Measurement Interval
TC
Transmission Convergence
TCP
Transmission Control Protocol
TDD
Time Division Duplex
TDM
Time Division Multiplexer
TDMA
Time Division Multiple Access
TE
Terminal Equipment
TMR
Trunk Mobile Radio
TOH
Transport Overhead
TSAPI
Telephony Services Application Programming Interface
UNI
Universal Network Interface
UNI
User Network Interface
UNICODE
Universal Code
URL
Universal Service Locator
USDC
United States Digital Cellular
UTP
Unshielded Twisted Pair
VBR
Variable Bit Rate
VC
Virtual Channel
VCI
Virtual Channel Identifier
VDSL
Very High Data Rate Subscriber Line
VLAN
Virtual
VOD
Video-on-Demand
VP
Virtual Path
VPI
Virtual Path Identifier
VPN
Virtual Private Network
VRC
Vertical Redundancy Check
VSAT
Very Small Aperture Terminal
VT
Virtual Tributary
WAIS
Wide Area Information Service
WAN
Wide Area Network
WARC
World Administrative Radio Conferences
WATS
Wide Area Telecommunication Service
WDM
Wavelength Division Multiplexer
WLL
Wireless Local Loop
WOTS
Wireless Office Telecommunication Systems
WWW
World Wide Web
XBar
Crossbar
XNS
Xerox Networking System

Table of Contents


Communications Systems and Networks:Index

Table of Contents

Index

Each term in the index is listed in full form, with the standard acronym or abbreviation immediately following. Note that Appendix A lists the same terms in alphabetical order, by acronym. The page number(s) in bold indicate the fullest definition(s) of each term, or the most significant treatment(s) of each subject.

1Base5, 231
10Base2, 51, 230
10Base5, 51, 230
10BaseT, 231, 236, 254
10Broadband36, 236
100BaseT, 236, 254, 255, 316
100VG-AnyLAN, 250, 253, 254, 255, 316
500, 148
800, 147
Digital, 203
802.1, 243, 253
802.2, 253, 256
802.3, 234, 253, 254
802.4, 253, 258
802.5, 234, 253
802.6, 253, 293, 295
802.7, 253
802.8, 253
802.9, 253
802.10, 253
802.11, 253, 333, 353
802.12, 253, 255
900/976, 148

A

AAL Type 1, 311
AAL Type 2, 311
AAL Type 3/4, 311
AAL Type 5, 312
Above 890 Decision, 456
Access Control Field, 299
Access Rate, 290
Adaptive Differential Pulse Code Modulation (ADPCM), 196
Address Field, 289
Address Field Extension (EA), 289
Adjunct Processor (AP), 322
Advanced Intelligent Network (AIN), 320
Architecture, 321
Futures, 325
Services, 323
Advanced Mobile Phone System (AMPS), 337, 347, 348, 351
Advanced Peer-to-Peer Networking (APPN), 250
Advanced Research Projects Agency Network (ARPANET), 35, 247, 249, 369
Alternative Access Vendor (AAV), see Competitive Access Provider
American National Standards Institute (ANSI), 131, 193, 253, 268, 269, 284 290
American Standard Code for Information Interchange (ASCII), 170
Amplifier, 23
Analog, 17
Archie, 388
Aspect Ratio, 403
Asymmetric Digital Microcell Link (ADML), 267
Asymmetric Digital Subscriber Line (ADSL), 262, 375
Asynchronous, 161, 166, 175
Asynchronous Transfer Mode (ATM), 86, 223, 245, 248, 250, 251, 257, 278, 292, 300, 302, 317, 413, 418, 432
Access, 305
ATM Reference Model, 309
Cell Structure, 307
LANs, 316
Protocols, 307
Quality of Service (QoS)
Standards, 304
Attached Resource Computer Network (ARCnet), 258
Attenuation, 22
ATM Forum, 304
ATM Layer, 310
ATM Reference Model, 309
Audiotex, 112
Authentication, 182, 393
Authorization, 183, 394
Automatic Call Distributor (ACD), 72, 79, 92
Automatic Route Selection (ARS), 78
Available Bit Rate (ABR), 311

B

Backward Explicit Congestion Notification (BECN), 289
Bandwidth, 16, 47, 51, 54, 58, 67, 406
Baseband LAN, 237
Baud, 17
Baudot, 169
Bellcore ,127, 265, 267, 268, 269, 294, 295, 321, 464
Bell Operating Company (BOC), 138
Bell Telephone Laboratories, 402
Binary File Transfer (BFT), 108
Binary Synchronous Communications (BSC), 176, 210
Bits Per Second (bps), 17
Bridge, 242, 297
Broadband, 17, 261
Broadband ISDN, 270, 278, 302, 303, 304, 316
Access, 317
Services, 317
Broadband LAN, 236
Broadband Switching System (BSS), 306, 307
Browser, 387
Bulletin Board System (BBS), 381
Burst Excess Size (Be), 289

C

Cable Distributed Data Interface (CDDI), 231, 232, 256
Call Blocking, 324
Call Completion Service, 324
Call Detail Recording (CDR), see Station Message Detail Recording
Call Pickup Service, 323
Caller Name, 324
Carrier, 16
Carrier Sense Multiple Access (CSMA), 234, 240, 253, 352
Carterphone, 133, 426, 456
CCIR, 131
CCITT, 131, 212
Cell Delay Variability (CDV), 313
Cell Error Ratio (CER), 313
Cell Loss Priority (CLP), 309
Cell Loss Ratio (CLR), 313
Cell Misinsertion Rate (CMR), 313
Cell Transfer Delay (CTD), 313
Cellular Radio, 346
Censorship, 441
Central Office, 129
Centrex, 87, 343
CERN, 385, 388
Channel, 11
Channel Bank, 199
Channel Service Unit (CSU), 163, 199
Chrominance, 404
Circuit, 10
Dedicated, 12, 145
Four-Wire, 15
Switched, 13
Two-Wire, 14
Virtual, 14
Circuit Digital Packet Data (CDPD), 351
Client/Server, 116, 247
Clipper, 392
Coaxial Cable, 50, 230, 402
Code Division Multiple Access, (CDMA), 339, 357
Codec, 25, 410,
Color-Space Conversion, 407
Command/Response (C/R), 289
Committed Burst Size (Bc), 289, 290
Committed Information Rate (CIR), 289, 290
Committed Rate Measurement Interval (Tc), 289
Common Air Interface (CAI), 345
Common Intermediate Format (CIF), 408
Common ISDN API (CAPI), 98
Communications Act of 1934, 455
Communications Act of 1962, 456
Communications Decency Act, 457, 463
Community Antenna TV (CATV), 239, 264, 376, 402, 410, 431, 433, 435, 457
Compaction Encoding, 407
Competition, 426
Competitive Access Provider (CAP), 141, 264, 375
Compression, 21, 175, 406, 409
Interframe, 407
Lossless, 406
Lossy, 406
Computer Emergency Response Team (CERT), 392, 395
Computer Security Service, 323
Computer Supported Telephony Applications (CSTA), 97
Computer Telephony Integration (CTI), 95
Concentrator, 276
Connectionless, 294
Connectionless Broadband Data Service (CBDS), 294
Connectionless Network Protocol (CLNP), 351
Connection-Oriented, 208, 295, 302
Consent Decree, 455
Constant Bit Rate (CBR), 311
Content, 443
Control Plane, 312
Convergence, 423
Convergence Sublayer (CS), 310
Cordless Telephony, 343
Cordless Telephony Generation 1 (CT1), 344
Cordless Telephony Generation 1+ (CT1+), 344
Cordless Telephony Generation 2 (CT2), 345
Cordless Telephony Generation 2+ (CT2+), 345
Cordless Telephony Generation 3 (CT3), 345
Customer Premise Equipment (CPE), 73, 306, 307
Cyclic Redundancy Check (CRC), 174, 208, 240

D

Data Communications Equipment (DCE), 156, 306
Data Encryption Standard (DES), 392
Data Exchange Interface (DXI), 297, 305
Data Line Connection Identifier (DLCI), 289
Data Private Facility (DPF), 392
Data Terminal Equipment (DTE), 156, 306
Datagram, 207
Defense Advanced Research Projects Agency Network (DARPANET), 367
Demand-Assigned Multiple Access (DAMA), 336
Demarcation Point, 137
Deregulation, 426
Differential Pulse Code Modulation (DPCM), 196
Digital, 19
Digital Access Cross-Connect System (DACS, DCCS), 201, 277
Digital Dataphone Service (DDS), 188, 248, 251, 284, 292
Digital European Cordless Telecommunications (DECT), 345, 354
Digital Loop Carrier (DLC), 277, 192
Digital Sense Multiple Access (DSMA), 352
Digital Service Unit (DSU), 164, 199, 291, 297
Digital Speech Interpolation (DSI), 196, 338
Digital Switched Access (DSA), see Switched 56
Diode Laser, 63
Direct Broadcast Satellite (DBS), 410, 436
Direct Satellite System (DSS), see Direct Broadcast Satellite
Direct Inward Dialing (DID), 80
Direct Inward System Access (DISA), 81
Discard Eligibility (DE), 289, 291
Discrete Cosine Transform (DCT), 407
Distance-Delivered Learning, 428
Distributed Queue Dual Bus (DQDB), 253, 293, 296, 298
Distribution Services, 318
Domsat Decision, 456

E

E-Carrier, 193, 201
Echo Checking, 173
Electromagnetic Interference (EMI), 22
Electric Power Utilities, 437
Electronic Industries Association (EIA), 269, 404
E-mail, 115, 368, 381
Encoding, 194
Encryption, 184, 392, 410
Enhanced Call Return, 324
Enhanced Call Routing, 324
Enhanced Switched Mobile Radio (ESMR), 341
Enterprise Computer Telephony Forum (ECTF), 99
Equal Access, 151
Error Control, 172, 208
Ethernet, 228, 230, 234, 236, 237, 244, 253, 254, 255, 413, 416
European Computer Manufacturers Association (ECMA), 252, 394
European Radio Message System (ERMES), 343
European Telecommunications Standards Institute (ETSI), 296, 307
Excess Burst Size (Be), 290
Exchange Carriers Standards Association (ECSA), 268, 269, 307
Explicit Congestion Notification (ECN), 291
Extended Binary Coded Decimal Interchange Code (EBCDIC), 169
Extended Superframe (ESF), 198

F

Facsimile, 104
Fax, 104
Fax-on-Demand (FOD), 106
Integrated Fax Messaging, 108
Federal Communications Commission (FCC), 132, 333, 340, 342, 346 396, 404, 455, 458, 467
Fiber Distributed Data Interface (FDDI), 232, 234, 237, 238, 250, 253, 256, 316, 413, 417
Fiber Optics, 61, 232, 237
Monomode, 65
Multimode, 64
Fiber-to-the-Curb (FTTC), 432
Fiber-to-the-Neighborhood (FTTN), 432
File Transfer Protocol (FTP), 380, 381
Filtering, 407
Find-Me Service, 323
Firewall 184, 394
FireWire, 257
Follow-Me Service, 323
Foreign Exchange (FEX, FX), 80, 145
Forward Error Correction (FEC), 172, 174
Forward Explicit Congestion Notification (FECN), 289
Frame Check Sequence (FCS), 174, 290
Frame Rate, 403
Frame Relay, 35, 223, 245, 248, 251, 278, 282, 290, 300, 303, 314, 412
Access, 284
Frame Structure, 288
Network, 285
Standards, 284
Frame Relay Assembler/Disassembler (FRAD), 248, 252, 283, 287, 289, 291
Frame Relay Network Device (FRND), 284, 378
Frame UNI, 306
Franchise Rights, 440
Frequency Allocation, 334
Frequency Division Duplex (FDD), 338, 348
Frequency Division Multiple Access (FDMA), 336, 348
Frequency Reuse, 335
Frequency Spectrum, 40
Front-End Processor (FEP), 164
Full Duplex (FDX), 166

G

G.707, 268
G.708, 268
G.709, 268
Gateway, 165
Generic Flow Control (GFC), 308
Global Information Infrastructure (GII), 423
Global System for Mobile Communications (GSM), 338, 349, 357
GOLAY, 341
Gopher, 388
Graham-Willis Act, 455
Grand Alliance, 406

H

H.221, 408
H.222, 408
H.231, 411
H.261, 408
H.310, 419
H.320, 408
H.323, 419
Half Duplex (HDX), 166
Header, 171
Header Error Control (HEC), 309
Hertz (Hz), 16
High Bit Rate Digital Subscriber Line (HDSL), 265
High-Definition TV (HDTV), 319, 405, 410
High-Level Data Link Control (HDLC), 178, 210, 246, 297
High Performance Parallel Interface (HPPI), 253
Home Area Network (HAN), 431
Home Page, 385, 387
Home Shopping, 429
Hub, 244
Hush-a-Phone, 455
Hypertext Markup Language (HTML), 380
Hypertext Transport Protocol (HTTP), 386

I

I.113, 304
I.121, 304, 316
I.122, 282
I.150, 304
I.211, 304
I.233, 284
I.311, 304
I.321, 304
I.327, 304
I.361, 304
I.362, 304
I.363, 304
I.370, 284
I.413, 304
I.432, 304
I.441, 220
I.515, 220
I.555, 304
I.610, 304
Implicit Congestion Notification (ICN), 291
Information Field, 290
Information Superhighway, 367, 423
Infrared, 61, 233, 354
Institute of Electrical and Electronics Engineers (IEEE), 228, 234, 252, 268, 269
Integrated Services Digital Network (ISDN), 212, 248, 251, 265, 284, 285, 302, 375, 378, 412, 415
B-Channel, 213
Basic Rate Interface, 213, 216,
Broadband, 213
D-Channel, 213
Equipment, 217
H-Channel, 213, 217,
Network Termination (NT), 218
Primary Rate Interface, 213, 216,
Standards, 220
Terminal Adapter (TA), 218, 248
Terminal Equipment (TE), 217
UNI, 212
Intelligent Network (IN), 320
Intelligent Peripheral (IP), 322
Intelligent Token, 393
Interactive Services, 318
Interactive Voice Response (IVR), 113
Interexchange Carrier (IEC, IXC), 140, 264
Interexchange Compatibility Forum (ICF), 268
International Electrotechnical Commission (IEC), 409
International Record Carrier (IRC), 142
International Standards Organization (ISO), 131, 252, 269, 409
International Telecommunications Union (ITU), 131, 198, 268, 269, 284, 302, 313, 316, 333, 341, 408, 409, 419, 455
Internet, 367, 419, 428, 433, 438,
Access, 374
Domains, 378
Network, 372
Physical Topology, 369
Protocols, 379
Regulation, 463
Security, 391
Standards, Administration, and Regulation, 371
Telephony, 383
Terminals, 373, 431
World Wide Web, 385
Internet Architecture Board (IAB), 371
Internet Assigned Numbers Authority (IANA), 372
Internet Engineering Task Force (IETF), 246, 305, 371, 394
Internet Research Task Force (IRTF), 372
Internet Service Provider (ISP), 265, 301, 372, 374, 383, 463
Internet Society (ISOC), 372
Inter-Switching System Interface (ISSI), 298
Intranet, 389, 370
IN-WATS, 147, 320
Iridium, 360
Isochronous, 167, 295
Isochronous Ethernet Integrated Services (Iso-Ethernet), 255, 413, 417

J

Japanese Digital Cellular (JDC), 349
Japanese Total Access Communications Systems (JTACS), 349
J-Carrier, 193, 201,
Joint Photographic Experts Group (JPEG), 409
Jughead, 388

K

Kerberos, 394
Key Telephone System (KTS), 72, 73, 343
Kingsbury Commitment, 455

L

LAPB, 210
LAPD, 283
Latency, 209
Least Cost Routing (LCR), 78
Light Emitting Diode (LED), 63
Line, 10, 145
Line Driver, 158
Line Overhead (LOH), 271, 275
Link, 10
Local Access and Transport Area (LATA), 139
Local Area Network (LAN), 227, 415
ATM, 316, 418
Baseband, 237
Bridge, 242
Broadband, 236
Bus, 234
CSMA, 234, 240
CSMA/CA, 241
CSMA/CD, 240, 253, 254
Gateway, 246
Hub, 244
Media Access Control (MAC), 237, 243
Media Access Unit (MAU), 242
Media Alternatives, 229
Multimedia, 416
Network Interface Card (NIC), 241
Network Operating System (NOS), 247
Remote LAN Access, 251, 264,
Ring, 234
Router, 245
Segmentation, 247
Standards, 252
Star, 235.
Switch, 244
Topology, 233
Virtual (VLAN), 250
Wireless, 232
Local Exchange Carrier (LEC), 137
Local Loop, 10
Local Management Interface (LMI), 290
Local Multipoint Distribution Services (LMDS), 267
Longitudinal Redundancy Check (LRC), 172
Luminance, 403

M

Macrocell, 336
Management Plane, 313
Mann-Elkins Act, 455
Mean Cell Transfer Delay (MCTD), 313
Measurement Interval (T), 291
Medium Access Control (MAC), 237, 295
MERIT Access Exchange (MAE), 370
MERIT Network, 370
Message Handling Service (MHS), 380
Message Mode, 311
Message Telecommunications Service (MTS), 146
Metropolitan Area Network (MAN), 253, 294
Microcell, 336
Microwave, 52
Military Network (MILNET), 369
Mobile Traffic Switching Exchange (MTSX), 347
Mobile Traffic Switching Office (MTSO), 347
Modem, 24, 158, 236, 351, 431
Modified Final Judgement (MFJ), 138, 426, 456
Modulation
Amplitude (AM), 18, 159, 336,340
Frequency (FM), 18, 159, 340
Phase (PM, PSK), 18, 160, 336
Pulse Amplitude (PAM), 199
Pulse Code (PCM), 195
Mosaic, 389
Motion-JPEG, 409
Motion Picture Experts Group (MPEG), 409
MPEG 1, 409
MPEG 2, 409, 432
MPEG 3, 410
MPEG 4, 410
Motorola Data Protocol (MDP), 353
MTS/WATS Decision, 456
Multilocation Extension Dialing, 324
Multimedia, 415
LAN, 416
Servers, 415
Software, 416
Standards, 419
Multiplexer
Add/Drop (ADM), 277
Frequency Division (FDM), 26, 236, 337
Inverse, 30, 411
Statistical Time Division (STDM), 28, 200, 272
Terminating, 276
Time Division (TDM), 28
Wavelength Division (WDM), 30, 278
Multi-Point Control Unit (MCU), 411
Multipurpose Internet Mail Extension (MIME), 380
Multi-Vendor Integration Protocol (MVIP), 98
Music-on-Demand (MOD), 429

N

Narrowband, 17
Narrowband-AMPS (N-AMPS), 348
National Information Infrastructure (NII), 423
National Research and Education Network (NREN), 302
National Science Foundation Network (NSFNET), 369
National Television Standards Committee (NTSC), 404
Netscape Navigator, 389
Network Access Point (NAP), 370
Network Information Center (NIC) Internet Register, 378
Network Interface Card (NIC), 237, 241,
Network Termination Unit (NTU) 431
Network-to-Network Interface (NNI), 285, 305, 317
Nordic Mobile Telephone (NMT), 349
North American Numbering Plan (NANP), 127, 464
Number Portability, 150, 325, 442, 464
Numbering Plan Administration (NPA), 127
Nyquist Theorem, 195

O

Off Premise Extension (OPX), 146
Offered Load, 290
Omnibus Budget Reconciliation Act, 457
Open Shortest Path First (OSPF), 246
Optical Carrier (OC), 270, 271, 42
OSI Reference Model, 131, 180, 245, 247, 249, 252, 283,352
Other Common Carrier (OCC), 139

P

Packet Assembler/Disassembler (PAD), 210, 248, 252, 283
Packet Radio, 352
Packet Switching, 204
Access, 210
Error Control, 208
Hardware, 211
Interconnection, 210
Packet Structure, 206
Standards, 211
Paging, 341
Parity, 173
Part 15, 346
Part 68, 456
Password Protection, 393
Path Overhead (POH), 272, 275
Payload, 206, 272
Payload Type Identifier (PTI), 309
Permanent Virtual Circuit (PVC), 209, 286, 290
Personal Communications Services (PCS),142 150, 357, 432
Broadband, 358, 437
Narrowband, 358
Network, 357
Personal Computer Memory Card Industry Association (PCMCIA),343, 351, 361
Personal Digital Assistant (PDA), 361
Function, 362
Network, 362
Phase Alternate Line (PAL), 405
Physical Layer (PHY), 309
Physical Medium (PM), 309
Picocell, 336
Picturephone, 411
Pixel, 403
Pleisiochronous, 168
Point-to-Point Protocol (PPP), 246, 376, 380 ,
Post Office Code Standardization Advisory Group (POCSAG), 341, 343
Publishing, 429
Private Branch Exchange (PBX), 72, 75, 343
Private Paging Operator (PPO), 342
Propagation Delay, 43, 59
Protocol, 164
Protocol Data Unit (PDU), 294
Provider of Last Resort, 441
Public Service Commission (PSC), see Public Utility Commission
Public Switched Telephone Network (PSTN), 123
Public Utility Commission (PUC), 132, 455
Px64, 408

Q

Q.770, 220
Q.921, 221
Q.922, 284
Q.931, 220
Q.933, 284
Quality of Service (QoS), 313
Quantization, 407
Quarter-CIF (QCIF), 408
Queued Packet Synchronous Exchange (QPSX), 294

R

Radio Act of 1927, 455
Radio Common Carrier (RCC), 342
Radio Data-Link Access Protocol (RD-LAP), 353
Rates and Tariffs, 462
Receiver, 10
Regenerator, see Repeater
Regional Bell Operating Company (RBOC), 138
Regional Holding Company (RHC), 138
Regulation, 440, 453,
Repeater, 23, 244, 277
Research for Advanced Communications in Europe (RACE), 302, 333
Resolution, 403
Right-of-Way, 441, 462
Router, 245, 297
Routing Information Protocol (RIP), 246
RSA, 392

S

Satellite, 55
Geosynchronous Earth Orbiting (GEO), 55, 359
Low-Earth Orbiting (LEO), 56, 359
Middle Earth Orbiting (MEO), 359
Scaling, 407
Scanning, 403
SCC Decision, 456
Search Mechanism, 388
Second Computer Inquiry, 456
Section Overhead (SOH), 271, 275
Secure European Systems for Applications in a Multivendor Environment (Sesame), 394
Secure HyperText Transport Protocol (S-HTTP), 393
Secure Socket Layer (SSL), 392
Security, 182
Security Administrator Tool for Analyzing Networks (SATAN), 395
Segment Field, 299
Segment Header, 299
Segment Payload, 299
Segmentation and Reassembly (SAR), 310
Sequenced Packet Exchange/Internet Packet Exchange (SPX/IPX), 250
Serial Line Interface Protocol (SLIP), 246, 376, 380
Service Creation Environment (SCE), 321
Service Management System (SMS), 322
Service Switching Point (SSP), 322
Set-Top Box, 431
Severely Errored Cell Block Ratio (SECBR), 313
Signal Computing System Architecture (SCSA), 98
Signal Control Point (SCP), 322
Signal Transfer Point (STP), 322
Signaling and Control, 36, 142,213
Common Channel, 143, 320
In-Band, 143
Out of Band, 143
Signaling System 7 (SS7), 144, 219, 317, 322, 357
Simple Mail Transport Protocol (SMTP), 120, 380
Simplex, 165
Sine Wave, 18
SIP Relay, 297
SMDS Interest Group (SIG), 295
SMDS Interface Protocol (SIP), 297
Software-Defined Network (SDN), 149
Source Routing Protocol (SRP), 243
Source Routing Transparent (SRT), 243
Spanning Tree Protocol (STP), 243
Sparse Network, 320
Spread Spectrum, 232
Station Message Detail Recording (SMDR), 78
Store Locator Service, 324
Streaming Mode 311
Subscriber Access Terminal (SAT), 296
Subscriber Identification Module (SIM), 349
Subscriber Network Interface (SNI), 296, 297
Switch, 11
Access Tandem, 130
Cell, 36
Circuit, 31
Core, 307
Crossbar (XBar), 33
Edge, 307
Electronic Common Control (ECC), 34
Frame, 35, 287,
LAN, 244
Manual, 31
Packet, 35, 204,
Photonic, 36
Step-by-Step (SxS), 32
Tandem, 130
Switched 56, 190, 248, 251, 284
Switched Mobile Radio (SMR), 340
Switched Multimegabit Data Service (SMDS), 223, 245, 248, 251, 278, 292, 293, 303, 311, 314, 378, 413
Access, 296
Network, 297
Protocols, 298
Switched Virtual Circuit (SVC), 209, 286
Symmetrical Digital Subscriber Line (SDSL), 265
Synchronization, 404
Synchronous, 161, 167, 176
Synchronous Data Link Control (SDLC), 177
Synchronous Digital Hierarchy (SDH), see Synchronous Optical Network
Synchronous Optical Network (SONET), 250, 267, 294, 296, 298, 307, 314, 317, 372
Frame Format, 274
Topology, 272
Transmission Hierarchy, 270
Synchronous Payload Envelope (SPE), 271
Synchronous Transport Signal (STS), 271
Systeme Electronique Couleur Aven Memoire (SECAM), 405
Systems Network Architecture (SNA), 179, 247, 250, 289, 292

T

T.120, 411
T.30, 108
T.434, 108
T.606, 284
T.617, 284
T.618, 284
T.81, 408
T1.105, 268
T1.106, 268
T1.413, 262
Tariffs, see Rates and Tariffs
Taxation, 442
T-Carrier, 192, 248, 251, 284, 292, 296, 311, 378, 412
Channelized, 193
Encoding, 194
Fractional, 202
Framing, 197
Unchannelized, 194
Telecommunications Act of 1996, 140, 426, 457
Telecommuting, 251, 264
TeleMedicine, 420
Telephony Application Programming Interface (TAPI), 97
Telephony Services Application Programming Interface (TSAPI), 97
Television, 401, 428
Standards, 404
Telnet, 380
Terminal Adapter (TA), 162, 248, 252
Text, 172
Time Assigned Speech Interpolation (TASI), 196
Time Division Duplex (TDD), 339, 349
Time Division Multiple Access (TDMA), 338, 349, 357
Token Passing, 234, 237, 238, 239, 244, 253
Token Ring, 231, 234, 237, 238, 239, 250, 255
Total Access Communications Systems (TACS), 348
Trailer, 172
Transforms, 407
Transmission Control Protocol/Internet Protocol(TCP/IP), 247, 249,351,369, 376, 379
Transmission Convergence (TC), 310
Transmitter, 10
Transport Overhead (TOH), 271
Trunk, 11, 145, 146
Trunk Mobile Radio (TMR), see Switched Mobile Radio
Twinaxial Cable, 230
Twisted Pair, 45, 231
Shielded, 49, 231, 237, 314
Unshielded, 45, 231, 237, 307, 314

U

United States Digital Cellular (USDC), 349
Universal Code (UNICODE), 171
Universal Service, 458, 463
Universal Service Locator (URL), 386
User Network Interface (UNI), 284, 285, 290, 305
User Network Interface A (UNI A), 317
User Network Interface B (UNI B), 317
User Plane, 313

V

V.110, 221
V.120, 221
Variable Bit Rate (VBR), 311
Veronica, 388
Versit, 98
Vertical Redundancy Check (VRC), 173
Very High Data Rate Subscriber Line (VDSL), 263, 265
Very Small Aperture Terminal (VSAT), 58, 292, 314, 342, 410
Video, 401
Bandwidth, 406
Basics, 403
Compression, 406
LAN Networks, 413
Server, 411, 432
Standards, 407
WAN Networks, 412
Videoconferencing, 409, 410, 413, 428
PC-based Systems
Rollabout Systems, 414
Room Systems, 414
Videophone, 410, 411,
Video-on-Demand (VOD), 264, 428, 432
Virtual Channel (VC), 274, 311
Virtual Channel Identifier (VCI), 308
Virtual Path (VP), 273, 311
Virtual Path Identifier (VPI), 308
Virtual Private Network (VPN), 149, 320
Virtual Tributary (VT), 273
Voice Processing, 110

W

WATS, 146
Waveguide, 62
Whiteboard, 416
Wide Area Information Service (WAIS), 389
Wideband, 17
Wireless, 232, 142, 331, 433, 437,
Access Techniques, 336
Cell Concept, 335
Frequency Allocation, 334
Multiplexing, 336
Power Level, 334
Standards and Regulations, 333
Wireless LAN, 353
Wireless Local Loop (WLL), 142, 266, 354, 432
Wireless Office Telecommunication Systems (WOTS), 343
World Administrative Radio Conferences (WARC), 333
World Wide Web (WWW), 385

X

X.25, 35, 204, 245, 248, 250, 283, 311, 314, 342, 353
X.29, 211
X.3, 211
X.31, 212
X.32, 212
X.3T9-3, 253
X.3T9-5, 253
X.75, 211, 212
X.400, 118, 379
X.500, 118, 379
Xerox Networking System (XNS), 250

Table of Contents


Communications Systems and Networks:Communications Systems and Networks

Chapter 1
Communications Systems and Networks

I was a civil engineering student in Berlin. Berlin is a nice town and there were many opportunities for a student to spend his time in an agreeable manner, for instance with the nice girls. But instead of that we had to perform big and awful calculations.

—Konrad Zuse, 1910

Those of us who have been involved in communications technology for any number of years have witnessed a transformation that truly is revolutionary. The old voice network remained much the same from the late 1800s through the 1960s—Alexander Graham Bell would have recognized it clearly and understood it completely. Around the time of World War II, however, dramatically new technologies started to emerge. Radio systems appeared and the foundation for electronic computer systems was laid. Soon thereafter, serious computer systems emerged and the need to network them soon became obvious. Over time, the networks, themselves, gradually became computerized. During the 1940s, the groundwork also was laid for the development of fiber optics transmission systems, which have the ability to transport huge volumes of information over very long distances and with crystal clarity. Video communications systems began to emerge in the 1960s, although they did not become practical until the last few years.

The rate of development of the underlying system and network technologies gathered speed in the last 20 years to the point that it has become difficult for even the most technically astute to keep pace with the rate of change, much less the depth and breadth of its impact. Copper wires have yielded to glass fibers. Rather than information flowing through networks in continuous streams, it now moves in packets, frames, and cells—sometimes on a connectionless basis. Data rules, but data now includes voice data, video data, image data, and even multimedia data, in addition to data data. The networks not only connect computers, but they also have become networks of computers. Wired networks no longer are supplemented by wireless network technologies, but in many applications are now being challenged by them. Regulation has yielded to deregulation. Monopolistic companies have been torn apart in the interests of increased competition, only to be reformed when the regulators became convinced that the market was the best regulator. Competition has become rife in virtually ever sector of the communications world, bringing with it the inherent advantages of alternative choice, improved performance, greater creativity, enhanced technology, and lower cost. The Internet has been commercialized and now is available in virtually every corner of the world, supplanting more traditional means of communication and even threatening more traditional voice and data networks. Audio, images, animated images, and even video clips are attached to electronic mail, which didn’t even exist a few years ago. Voice network technologies are under development which can translate languages in realtime—as we speak.

This book delivers a comprehensive overview of a wide range of communications systems and networks, including voice, data, video, and multimedia. It provides a plain-English, commonsense basis for understanding system and network technologies, their origins and evolution, and the applications they serve. Further, it discusses the origin, evolution and nature of appropriate standards and standards issues. It also provides a view of the evolution and status of regulation, and examines a number of key regulatory issues that await resolution. From fundamental concepts through network convergence and the Information Superhighway, Communications Systems and Networks offers a single source of information for those who need to understand communications networking. Rather than bogging down in volts, amps, ohms, algorithms and the like, this book weaves a fabric of understanding through a complex set of technologies that underlie meaningful contemporary and future applications. Further, this book is, in effect, a language primer, providing what is in effect a short course in the vocabulary and syntax of the language of telecommunications—having read this book, you will be conversational in telecommunications techno-speak. Finally, you will understand how networks work, and why.

The first several chapters set the stage for understanding the fundamental nature of systems and networks. Chapter 2 offers a set of basic concepts and provides a set of definitions which apply, fairly universally, across all communications and networks. Chapter 3 details, compares, and contrasts traditional transmission systems, both wired and wireless, including twisted-pair, coaxial cable, microwave radio, satellite radio, infrared light, and fiber optics.

Chapter 4 is devoted to a discussion of communications systems that primarily support voice applications, although they increasingly support data and even video communications. It begins with an examination of the several generations of Private Branch Exchanges (PBXs), their capabilities and applications, as well as emerging trends. Chapter 4 also examines Key Telephone Systems (KTSs), Hybrid systems and Centrex, the old standby which has been reborn with something of a vengeance. Automatic Call Distributors (ACDs) are profiled and discussed as well. Chapter 4 concludes with an examination of Computer Telephony Integration (CTI), a recent development that promises to add tremendous value in the processing and management of voice calls.

Chapter 5 is dedicated to electronic messaging technologies and systems, including facsimile, voice processing, and electronic mail. Increasingly, these technologies are viewed as converging into a unified messaging system technology. Indeed, we see the beginnings of such unification in the Internet and the World Wide Web (WWW).

Chapter 6 is the initial treatment of networks, and the final, focused treatment of voice communications. Concentrating on the Public Switched Telephone Network (PSTN), it addresses the origin, evolution and contemporary nature of the traditional voice network. The underlying technologies, regulatory and standards domains, carrier/service provider domains and functional domains all are discussed. This chapter also defines the nature and specifics of signaling and control systems that manage and control the operation of the various network elements in order to ensure that the network functions as a whole. A wide variety of voice network services are defined and illustrated. Chapter 6 concludes with discussion of a number of critical PSTN issues, including numbering plan administration, portability and equal access.


Communications Systems and Networks:Communications Systems and Networks

Chapter 7 begins the discussion of data communications, addressing a number of basic concepts. Data terminal equipment, data communications equipment, communications software, and the network are explained as the various functional domains in a data communications network. Protocols are examined, both as a concept and in terms of certain specific, baseline examples. Additionally, a number of key elements of a data communications protocol are discussed, with specific examples being provided. Network architectures are examined, with concentration on layered operations models, most specifically that of the OSI (Open Systems Interconnection) model. Discussion follows of the various influential standards organizations, with security techniques and issues serving as the conclusion.

Chapter 8 centers on conventional digital and data networks, which are based on the voice network model. Dedicated and circuit-switched networks are discussed in the context of both private and public data networks. Specific data network options, presented in rough order of deployment, include DDS, Switched 56, T-carrier, Packet Switching, ISDN, and Digital 800. While several of these network options (T-carrier, Digital 800 and ISDN) also support voice and video communications, they are particularly distinguished in support of data communications in the realm of the wide area network.

Chapter 9 steps away from the traditional wide area network (WAN) to explore the world of the Local Area Network (LAN). Although the concept of a local area network was first formally expressed in 1973, such systems have grown like kudzu in the world of data communications. This chapter defines LANs in terms of fundamental dimensions such as acceptable transmission media, physical and logical topology, baseband versus broadband, and medium access control. LAN network and LAN internetworking devices are discussed, including hubs, bridges, routers and gateways. Network Operating Systems (NOSs) are presented in the context of the client/server model and the fundamentals of LAN internetworking are discussed, with emphasis on the Transmission Control Protocol/Internet Protocol (TCP/IP) protocol suite. Chapter 9 finishes with a discussion of recent developments including virtual LANs, remote LAN access, and high-speed LAN technologies and standards.

Chapters 10 and11 deal with broadband networking, the high-speed future of communications. Chapter 10 is dedicated to the discussion of the physical infrastructure being built in support of broadband networking. The initial focus is on recently developed local-loop technologies, including both wired and wireless alternatives to traditional twisted-pair. SONET fiber optic networks, perhaps the ultimate in broadband wireline networks, is presented in detail. Chapter 11 focuses on broadband packet, frame, and cell networks, in the form of frame relay, SMDS, and ATM. The future of broadband networking is projected through examination of the concepts of Broadband ISDN (B-ISDN) and Advanced Intelligent Networks (AINs).

Chapter 12 explores the world of wireless communications—not traditional wireless transmission systems such as microwave and satellite, but rather special network alternatives. Popular options examined include Trunk Mobile Radio (TMR), paging, cellular, packet radio and wireless LANs. PCS and Low-Earth Orbiting satellites (LEOs) provide a glimpse into the future, or at least a potential dimension of the future, of wireless communications.

Chapter 13 profiles the Internet, which may, in fact, be the first version of the ballyhooed Information Superhighway. The origins of the Internet are examined, and its basic nature and structure are profiled. Internet access options, equipment, and costs are examined, and issues of regulation and security discussed. At least a sample of the more interesting and legitimate applications are explored, most especially that of the World Wide Web (WWW).

Chapter 14 provides a view of the world of video and multimedia systems and networks. The addition of a visual dimension enhances communications to a very significant extent, although it places great demands on the supporting network. As video and multimedia networking is highly capacity-intensive and as broadband networks are by no means fully deployed, cost-effective applications remain few. However, the future beckons, and the future includes video and multimedia.

Chapter 15 addresses Convergence. As the networked world becomes increasingly deregulated and as users develop an ever-expanding appetite for ever-more exotic and capacity-intensive applications, a host of companies are vying to satisfy that hunger. Local Exchange Carriers (LECs), or local telephone companies, and IntereXchange Carriers (IXCs) are considered by many to be the logical providers. Yet, they are being challenged by Community Antenna TeleVision (CATV) providers, data carriers, electric power providers, Competitive Access Providers/Alternative Access Vendors (CAPs/AAVs) and others to deliver voice, data, video, entertainment and other services. The stakes are enormous in magnitude. The outcome will shape the future of the networked world. The status, the issues and the likely outcomes are explored in Chapter 15.

Chapter 16 rounds out the tour of the networked world with a profile of regulation, both domestic (U.S.) and international. The origins, evolution and current status of regulation are tracked through key legislative, judicial, and agency events. Current regulatory issues are discussed with emphasis on deregulation and privatization, most especially in the context of the Internet and convergence.

Each of the 16 chapters addresses a key area of telecommunications technology and applications, with an eye toward the development of meaningful and cost-effective solutions to legitimate communications requirements. Taken as a whole, this document is a discourse on the origins, current status and foreseeable future of the networked world.


Communications Systems and Networks:Fundamentals if the Technology: Concepts and Definitions

Chapter 2
Fundamentals of the Technology: Concepts and Definitions

I see no reason why intelligence may not be transmitted instantaneously by electricity.

Samuel Morse, 1832

Telecommunications can effectively be used to describe the transfer of information (communications) from a transmitter or sender to a receiver across a distance (tele), typically of quite some significance. Some form of electromagnetic energy is used to represent the data, usually through a physical medium, such as copper or glass wire. Additionally, some number of intermediate devices are involved in order to set up a path for the information transfer and to maintain adequate signal strength.

The information transfer must be at acceptable levels in terms of certain key criteria such as speed of connection, speed of information transfer, freedom from error, speed of response (two-way), and cost. The information can be voice, data, video, image, or some combination—in other words, multimedia. The information can be transmitted in its original, or native, form. Or it can be altered in some way to effect compatibility between the transmitting and receiving devices and/or with the various elements of the network. Examples include analog voice or video converted to a digital (data) bit stream, digitized voice or video converted to analog voice or video, and digital data converted to an analog format. Additionally, the information can be—and often is—compressed in order to improve the efficiency of information transfer through what is effectively some form of data shorthand.

The electromagnetic energy used to carry the data can be in the form of electricity, radio, or light. The medium used can include copper wire (e.g., twisted pair or coaxial cable); space or airwaves (e.g., microwave, satellite, cellular, or infrared); and glass or plastic wire (fiber-optic cable). In a network of any size that carries information across any significant distance, a combination of transmission media is typically involved. In fact, an intercontinental voice or data call might involve a combination of all such media.

Additionally, a wide variety of intermediate devices might be used to establish the connection and support the information transfer. Such devices may include an appropriate combination of switches, modems or codecs, controllers, bridges, routers, gateways, and so on.

This chapter examines a number of concepts and defines a fundamental set of elements that apply universally to communications networks. Distinctions are drawn among dedicated, switched, and virtual circuits, with two-wire and four-wire circuits defined and illustrated. The concept of bandwidth is explored in both analog and digital terms, with the advantages and disadvantages of each being explained. The concept of multiplexers is discussed in detail, with variations on the theme detailed and illustrated. Finally, this chapter explores the nature and evolution of various types of switches, including circuit, packet, frame and cell.

Fundamental Definitions

Developing a solid understanding of communications networking requires a grasp of several fundamental definitions. The following terms are significant and are applied fairly universally across all voice, data, video, and other system and network technologies:

Transmitter
The transmitter, also known as the sender or source, is the device that originates the information. Such devices include telephones, any variety of computer systems, and cameras in a videoconferencing application.
Receiver
The receiver, also known as the sink, is the device that receives the information. Again, such devices can include telephones and computers; in a videoconferencing application, the display device would be the receiver.
Circuit
A circuit is a communications path over an established medium, between two or more points from end to end, between transmitter and receiver. Circuit generally implies a logical connection over a physical line. Further, the term circuit is often used interchangeably with path, link, line, and channel, although such usage can be specific to the underlying technology, the context, and other factors. Circuits are either two-wire or four-wire, depending on the requirements of the specific application and therefore on the fundamental nature of the network.
Link
A link is a two-point segment of an end-to-end circuit (e.g., from terminal to switch, or from switch to switch). Link is sometimes used interchangeably with line or circuit. A circuit may consist of a single link, as often is the case between a host computer and a peripheral.
Line
The term line has several definitions, resulting in confusion. In a PBX environment, a station line refers to the connection between the PBX switch and the station user’s terminal equipment, whether it be an analog or digital, telephone or workstation. In rate and tariff terminology, it refers to a local loop connection from the telephone company Central Office (CO) switch to the user’s premises in support of premise equipment other than a switch; for example, a single-line residence or business set, a multiline set, or a key system common control unit. In any event, a line refers to a voice-grade circuit; in other words, a circuit serving a single physical location, with a single telephone number and generally supporting a single transmission. Internal to the telephone companies, line is used to describe the user side or local loop side of the connection. In other words, the line side is the side of the network to which users connect, while the trunk side involves the high-capacity trunks that interconnect the various telephone company switching centers.
Trunk
A trunk is a communications circuit that is available to be shared among multiple users on a pooled basis and with contention for trunk access managed by an intelligent switching device. Trunks connect switches. For example, tie trunks connect PBXs in a private, leased-line network, central office exchange trunks connect PBXs to telephone company central office exchanges, and interoffice trunks interconnect central office exchange switches. Trunk groups are groups of trunks serving the same special purpose; examples include WATS (Wide Area Telecommunications Service) and DID (Direct Inward Dial) trunk groups. Trunks are directional; they can be one-way outgoing (originating), one-way incoming (terminating), or two-way (combination).
Channel
In formal standards terms, a channel is a means of one-way connection between transmitter and receiver; therefore, it is a one-way circuit or path. In data processing terminology, particularly IBM, a channel is a high-speed connection between mainframe and peripheral. In common usage, a channel is a logical connection over a physical circuit to support a single conversation. A physical circuit can be treated in such a way as to support one or many logical conversations. Multichannel circuits are always four-wire—either physical or logical four-wire.
Switch
A switch is a device that establishes, maintains, and changes logical connections over physical circuits. Common examples of switches include PBXs and Central Office (CO) exchanges. Switching traditionally has been accomplished on a circuit basis, for the establishment of connections between circuits on demand and in support of voice and data communications. Packet, frame, and cell switching have recently evolved in more sophisticated networks, primarily in support of data and image transfer.


Communications Systems and Networks:Fundamentals if the Technology: Concepts and Definitions

Dedicated, Switched, and Virtual Circuits

Circuits can be provisioned on a dedicated, switched or virtual basis, depending on the nature of the application and the requirements of the user organization. Ultimately, issues of availability and cost-effectiveness determine the specific selection.

Dedicated Circuits

Dedicated circuits involve dedicated physical circuits that directly connect devices (e.g., PBXs and host computers) across a network (Figure 2.1). Such circuits are reserved for the use of a single user organization rather than being available to serve multiple users. Dedicated circuits offer the user the advantage of a high degree of availability and specified levels of capacity and quality; dedicated circuits can be specially conditioned to deliver specific levels of performance, whereas switched circuits cannot. Additionally, dedicated circuit costs are not usage-sensitive; that is, they can be used continuously and to their full capacity without additional costs. However, the reservation of a circuit for a specific customer has a deleterious effect on the network provider (carrier), as it is no longer available for use in support of the traffic of other users. Therefore, dedicated circuits tend to be rather expensive, with cost being sensitive to distance and capacity. Additionally, the process of determining the correct number, capacity, and points of termination of such circuits can be a difficult and lengthy design and configuration process; in response to the customer request, long lead times are often required for the carrier(s) to provision such a circuit. Finally, as dedicated circuits are susceptible to disruption, backup circuits are often required to ensure effective communications in the event of catastrophic failure or performance degradation. Traditionally, dedicated digital circuits have been used to connect large data centers that communicate intensively; similarly, many large end user organizations with multiple locations have used dedicated circuits to tie together multiple PBXs. In both cases, the advantages of assured availability, capacity and quality often outweigh considerations of configuration difficulty and risk of circuit failure.

Figure 2.1 Dedicated circuits between New York host computer and Seattle terminals.

Switched Circuits

Switched circuits are connected on a flexible basis through a circuit switch, such as a customer-owned PBX or a telephone company Central Office exchange, as illustrated in Figure 2.2. The switch serves as a concentration and contention device; therefore switched circuits are available to be shared, on demand, among multiple subscribers and applications, as required and as available. As a result, the network providers clearly realize significant operational efficiencies. The end users realize the advantages of flexibility and redundancy because the network can generally provide a connection between any two physical locations through multiple alternate routes.

Figure 2.2 Switched circuits between single-line sets through a Central Office switch.

In the voice world, all local, regional, and national networks are interconnected; however, a similar high level of interconnection typically is not provided in the data world. The costs of using switched circuits is sensitive to factors such as the distance between originating and terminating locations, duration of the communication, time of day (prime time vs. nonprime time), and day of the year (business day vs. weekend or holiday). Yet switched circuits offer great advantage where calls are of short duration, where specific locations communicate relatively infrequently, where network redundancy is important, and where network traffic cannot support the cost of dedicated circuits. By way of example, most voice calls are carried over switched circuits.

Virtual Circuits

Virtual circuits are logical, as opposed to physical, circuits, with virtual circuit connectivity being provided over high capacity, multichannel physical circuits, such as fiber optic cables. Virtual circuits are defined in software and made available as required and as available, with the physical path or circuit being defined and effectively guaranteed, perhaps on a priority basis. A virtual circuit transparently provides the same level of connectivity as a physical circuit; in other words, a virtual circuit provides connectivity as though it were a physical circuit. Such a physical circuit can often support many logical circuits, or logical connections. In the high-capacity, fiber optic backbone carrier networks, dedicated circuits are provided to users on a virtual basis; the capacity and other performance characteristics of the circuit behave as though the circuit were dedicated.

At this point, it is worth pausing to further define and contrast the terms transparent and virtual. Transparent means that a network element (e.g., hardware or software) exists but it appears to the user as though it does not. Virtual means that the network element does not exist but it appears to the user as though it does. In this context, a user would be provided access to a virtual circuit on a transparent basis.

It also is necessary to further define a logical circuit or channel, as opposed to one that is physical. A logical circuit refers to the entire range of network elements (e.g., physical circuits, buffers, switches, and control software) that support or manage a communication between a transmitter and receiver. A physical path may be in the form of copper wire (e.g., twisted pair or coaxial cable), radio (e.g., microwave or satellite), or glass or plastic fiber (fiber optic). In order to establish connectivity between transmitter and receiver, a physical path must be selected for the information transfer [2-1].

Two-Wire versus Four-Wire Circuits

Early telegraphy and telephony communication circuits were metallic one-wire, which proved satisfactory, even for two-way communications. Soon after the invention of the telephone, however, two-wire circuits were found to offer much better performance characteristics, due largely to their improved immunity from electrical interference. Four-wire offers still better performance, but at higher cost. Both two- and four-wire circuits are widely used, although the trend is clearly toward four-wire.


Communications Systems and Networks:Fundamentals if the Technology: Concepts and Definitions

Two-Wire Circuits

Two-wire circuits are those that carry information signals in both directions over the same physical link or path. Typically, such a circuit is provisioned through the use of a single twisted pair, copper wire connection. Within such a circuit, two wires are required to complete the electrical circuit and both wires carry the information. A typical example is a local loop connection between the Central Office or Central Exchange switching center and the individual single line or multiline residence or business terminal equipment, as depicted in Figure 2.3.

Figure 2.3. Two-wire, twisted pair, local loop connection between a Central Office Exchange and a single-line set or Key Telephone System (KTS).

Two-wire circuits typically cover short distance; for example, most two-wire local loops are shorter than 20,000 feet [2-2]. Additionally, the bandwidth or capacity of such a circuit is relatively low, and only a single conversation is accommodated. Finally, two-wire circuits, generally speaking, are analog in nature; therefore, quality is poor.

Four-Wire Circuits

According to the most basic definition, four-wire circuits are those that carry information signals in both directions over separate physical links or paths, and in support of simultaneous, two-way transmission. Traditionally, such a circuit was provisioned through the use of two copper-pairs, one for transmission (forward path) and one for reception (reverse path); such a circuit is known as physical four-wire. However, current technology accommodates four-wire transmission over a single physical link or path such as coaxial cable, microwave, satellite, or fiber optic cable. In other words, the circuit may be physical two-wire (or even physical one-wire) and logical four-wire, performing as a four-wire circuit but employing fewer than four wires.

Although the absolute cost of four-wire circuits is higher than that of two-wire circuits, they offer considerably improved performance. Four-wire circuits accommodate multiple, simultaneous communications in a two-way, or conversational mode. Additionally, such circuits offer greater bandwidth, or capacity, and are typically digital, rather than analog in nature—as a result, error performance is generally improved. Long haul circuits (traditionally defined as [ge]50 miles or 80 km) usually are four-wire [2-2]. Figure 2.4 illustrates typical examples of cost-effective applications of four-wire circuits, specifically to interconnect PBX, CO, and Tandem switches in a voice environment.

Figure 2.4 Four-wire, twisted pair trunk connections between a Central Office Exchange and a PBX and between a Tandem Office Exchange and Central Office Exchange.

Bandwidth

Bandwidth is a measure of the capacity of a circuit or channel. More specifically, bandwidth refers to the total frequency that is available on the carrier for the transmission of data; as opposed to overhead signaling and control information. There is a direct relationship between the bandwidth of a circuit or a channel and both its frequency and the difference between the minimum and maximum frequencies supported. While the information (data) signal does not occupy the total capacity of a circuit, it generally and ideally occupies most of it. The more information to be sent in a given period of time, the more bandwidth required.

Carrier

Carrier is a constant signal on a circuit that is at a certain frequency, or within a certain frequency range. The carrier can accommodate both an information-bearing signal and signaling and control information, which is used to coordinate and manage network operation.

Hertz (Hz)

Hertz, named after Heinrich Rudolf Hertz, the physicist who discovered radio waves, is the measurement of bandwidth over analog circuits. Hertz refers to the number of electromagnetic wave forms (signals or signal changes) transmitted per second. Although some applications operate in very low capacity environments, measured in Hz or hundreds of Hz, the frequencies generally are much higher. Hence, analog bandwidth typically is measured in kHz or kiloHertz (thousands of Hz), MHz or MegaHertz (millions of Hz), or GHz or GigaHertz (billions of Hz).

Baud

Baud is an old term that refers to the number of signal events (signals or signal changes) occurring per second over an analog circuit. Generally baud is used to describe the signaling rate of a modem for data transmission over an analog circuit, with the baud rate being roughly equivalent to Hertz. Baud rate and bps, often and incorrectly, are used interchangeably. The distinction will be discussed in more detail in Chapter 7.

Bits per Second (bps)

Bps is the measurement of bandwidth over digital circuits. It refers to the number of binary data bits that can be transmitted per second. Over an analog circuit, the sine wave can be manipulated to allow multiple bits to be transmitted at a given baud rate, even without the application of special compression techniques. A thousand (1,000) bps is a kilobit per second or Kbps, a million (1,000,000) bps is a megabit per second or Mbps, a billion (1,000,000,000) bps is a gigabit per second or Gbps, and a trillion (1,000,000,000,000) bps is a terabit per second or Tbps.

Transmission Facilities

In terms of bandwidth, and in contemporary digital context, transmission facilities can be categorized as narrowband, wideband or broadband.

Narrowband
A single channel ([le]64 Kbps) or some number of 64 Kbps channels (N × 64 Kbps), but less than wideband.
Wideband
Wideband is multichannel capacity that is between 1.544 Mbps and 45 Mbps according to U.S. standards (2.048 Mbps-34 Mbps according to European/international standards.)
Broadband
Broadband is multichannel capacity [ge]45 Mbps according to U.S. standards ([ge]34 Mbps according to European/international standards.)

Analog versus Digital

Along one dimension, communications can be classified in two categories, analog and digital. In the analog form of electronic communications, information is represented as a continuous electromagnetic wave form. Digital communications represents information in binary form (1s and 0s) through a series of discrete blips or pulses.


Communications Systems and Networks:Fundamentals if the Technology: Concepts and Definitions

Analog

Analog is best explained by examining the transmission of a natural form of information, such as sound or human speech, over an electrified copper wire. In its native form, human speech is an oscillatory disturbance in the air which varies in terms of its volume or power (amplitude) and its pitch or tone (frequency). As sound compression waves fall onto a transmitter, analogous (approximate) variations in electrical waveforms are created over an electrical circuit. Those waveforms maintain their various shapes across the wire until they fall on the receiver or speaker, which converts them back into their original form of variations in air pressure.

A similar, but more complicated, conversion process is employed to transmit video over networks. In its native form, video is a series of still images captured and transmitted in rapid succession in order to create the illusion of fluidity of motion; image information is reflected light waves. Analogous variations in electrical or radio waves are created in order to transmit the analog video image information signal over a network from a transmitter (TV station or CATV source) to a receiver (TV set), where an approximation (analog) of the original information is presented.

Information which is analog in its native form (voice and image) can vary continuously in terms of intensity (volume or brightness) and frequency (tone or color). Those variations in the native information stream are translated in an analog electrical network into variations in the amplitude and frequency of the carrier signal. In other words, the carrier signal is modulated (varied) in order to create an analog of the original information stream.

The electromagnetic sinusoidal wave form, or sine wave, can be varied in amplitude at a fixed frequency, using Amplitude Modulation (AM). Alternatively, the frequency of the sine wave can be varied at a constant amplitude, using Frequency Modulation (FM). Additionally, both frequency and amplitude can be modulated simultaneously in order to create an analog of the native signal, which generally varies along both parameters simultaneously. Finally, the position of the sine wave can appear to be manipulated, adding the third technique of Phase Modulation (also known as Phase Shift Keying or PSK). This provides additional benefits. These benefits will be discussed in Chapter 7.

Bandwidth, in the analog world, is measured in hertz (Hz). The available bandwidth for a particular signal is the difference between the highest and lowest frequencies supported. For example, a 3.3 kHz voice channel can be provided through a band-limiting filter supporting transmission at frequencies between 200 Hz and 3,500 Hz. Similarly, a 3.3 kHz channel is provided at frequencies between 7,000 Hz and 10,300 Hz. Passband refers to the upper and lower cutoff frequencies at which the filters operate [2-2].

Voice

A voice grade channel is approximately 4,000 Hz, or 4 kHz. Approximately 3.3 kHz (200 Hz to 3,500 Hz) is used for the voice signal itself. The remaining bandwidth is used for purposes of network signaling and control, and in order to maintain separation between information channels. While human speech transmission and reception encompasses a much wider range of frequencies, 3.3 kHz is considered to be quite satisfactory and is cost-effective. Band-limiting filters are used in carrier networks to constrain the amount of bandwidth provided for a voice application [2-2] and [2-3]. Figure 2.5 illustrates an analog local loop supporting voice communications.

Figure 2.5 Analog voice transmission over a two-wire local loop.

Video

A CATV video channel is approximately 6,000,000 Hz, or 6 MHz. Approximately 4.5 MHz is used for information transmission, while the balance is used for guard bands to separate the various adjacent channels riding the common, analog coaxial cable system.

Digital

While the natural world is analog in nature, computers (which are decidedly unnatural beings) are digital in nature. Computers process, store, and communicate information in binary form. That is to say that a unique combination of 1s and 0s has a specific meaning in a computer language. A bit (binary digit) is an individual 1 or 0. Multiple bits travel across a network in a digital bit stream.

Digital communications dates to telegraphy, in that the varying length of making and breaking an electrical circuit resulted in a series of dots and dashes which, in a particular combination, communicated a character or series of characters. Early mechanical computers used a similar concept for input and output; contemporary computer systems communicate in binary mode through variations in electrical voltage.

Digital signaling, in an electrical network, involves a signal which varies in voltage to represent one of two discrete and well-defined states: such as either a positive (+) voltage and a null, or zero (0), voltage (unipolar); or a positive (+) or a negative (-) voltage (bipolar). The receiver monitors the signal, at a specific frequency and for a specific duration (bit time) to determine the state of the signal. Various data transmission protocols employ different physical states of the signal, such as voltage level or voltage transition. Because of the discrete nature of each bit transmitted, the bit form is often referred to as a square wave. Digital devices (Figure 2.6) prefer digital transmission facilities.

Figure 2.6 Digital communications between terminal and mainframe.

Digital signaling in an optical network can involve either the pulsing on and off of a light stream, or a variation in the intensity of the light signal. Digital transmission over radio systems (e.g., microwave, cellular or satellite) can be accomplished by varying the amplitude of the signal.

In the digital world, bandwidth is measured in bits per second (bps). The amount of bandwidth required depends on the amount of raw data to be sent, the desired speed of transmission of that set of data, and issues of transmission cost. Additionally, data is routinely compressed by various means in order to enhance the efficiency of transmission and to reduce transmission costs. Additionally, analog voice commonly is converted to a digital bit stream, requiring a maximum of 64 Kbps for full fidelity or quality.

Analog versus Digital Transmission: Which is Better?

Although analog voice and video can be converted to digital, and digital data can be converted to analog, each format has its own advantages.


Communications Systems and Networks:Fundamentals if the Technology: Concepts and Definitions

Analog Advantages

Analog transmission offers advantages in the transmission of analog information. Additionally, it is more bandwidth-conservative and is widely available.

Analog Data

Analog has an advantage with respect to the transmission of information which is analog in its native form, such as voice, image and video. The process of transmission of such information is relatively straightforward in an analog format, whereas conversion to a digital bit stream requires conversion equipment. Such equipment adds cost, contributes additional points of failure, and can negatively affect the quality of the signal through the conversion process, itself. The impacts on analog and digital conversion are discussed fully in the examination of T-carrier (Chapter 8).

Bandwidth

A raw information stream consumes less bandwidth in analog form than in digital form. This is particularly evident in CATV transmission, where 50 or more analog channels routinely are provided over a single coaxial cable system. Without the application of compression techniques on the same cable system, only a few digital channels could be supported.

Presence

Finally, analog transmission systems are already in place, worldwide. The interconnection of those systems is routine and all aspects of the standards for are well understood and easily implemented. As the majority of network traffic is voice and as the vast majority of voice terminals are analog devices, voice communications largely depends on analog networks; conversion to digital networks would require expensive, wholesale conversion of such terminal equipment.

Digital Advantages

Digital transmission offers advantage in the transmission of digital information. Additionally, such data can be compressed effectively and relatively easily. Security of the data can be more readily ensured and the error performance of digital networks are much improved over their analog counterparts. Finally, the cost-effectiveness of such networks is improved by virtue of the greater bandwidth they provide, especially since they can be more easily upgraded and more effectively managed.

Digital Data

Just as it is better to transmit analog information in an analog format, it is better to transmit digital information in a digital format. Digital transmission certainly has the advantage where binary computer data is being transmitted. The equipment required to convert digital data to an analog format and send the digital bit streams over an analog network can be expensive, susceptible to failure, and can create errors in the information.

Compression

Digital data can be compressed relatively easily, thereby increasing the efficiency of transmission. As a result, substantial volumes of voice, data, video and image information can be transmitted using relatively little raw bandwidth.

Security

Digital systems offer better security. While analog systems offer some measure of security through the scrambling, or intertwining of several frequencies, scrambling is fairly simple to defeat. Digital information, on the other hand, can be encrypted to create the appearance of a single, pseudo-random bit stream. Thereby, the true meaning of individual bits, sets of bits, or the total bit stream cannot be determined without having the key to unlock the encryption algorithm employed.

Quality

Digital transmission offers improved error performance (quality) as compared to analog. This is due to the devices that boost the signal at periodic intervals in the transmission system in order to overcome the effects of attenuation. Additionally, digital networks deal more effectively with noise, which always is present in transmission networks.

Attenuation
Electromagnetic signals tend to weaken, or attenuate, over a distance; this is particularly true of electrical signals carried over twisted pair copper wire, due to the level of resistance in the wire. It is also particularly true of microwave radio and other terrestrial radio systems, due to matter in the air. Attenuation is sensitive to carrier frequency, with higher frequency signals attenuating more than lower frequency signals.
Noise
Signals also tend to pick up noise as they transverse the network. Again, this is particularly true of twisted pair, copper wire systems. Such wires tend to act as antennae and, therefore, absorb noise from outside sources of ElectroMagnetic Interference (EMI). Thus, the quality of the signal degenerates as it is distorted by the noise.

Cost

The cost of the computer components required in digital conversion and transmission has dropped considerably, while the ruggedness and reliability of those components has increased over the years.

Upgradability

Since digital networks are comprised of computer (digital) components, they are relatively easy to upgrade. Such upgrades can increase bandwidth, improve error performance, and enhance functionality. Some upgrades can be effected remotely over a network, eliminating the need to dispatch expensive technicians for that purpose.

Management

Generally speaking digital networks can be managed much more easily and effectively due to the fact that such networks consist of computerized components. Such components can sense their own level of performance, isolate and diagnose failures, initiate alarms, respond to queries, and respond to commands to correct any failure. Further, the cost of so enabling these components continues to drop.

Amplifiers versus Repeaters

As we have noted, electromagnetic energy attenuates over a distance through either a wire or the air. Therefore, it is necessary to place some sort of device at regular intervals in a network to overcome this phenomenon. These boosting units read a weak incoming signal and create a stronger outgoing signal until the signal reaches another boosting unit, and so on. Analog networks make use of devices known as amplifiers, while repeaters are employed in digital networks.


Communications Systems and Networks:Fundamentals if the Technology: Concepts and Definitions

Amplifiers (Analog)

The boosting devices in an analog network are known as amplifiers. Amplifiers boost, or amplify the weak incoming signal, much like an amplifier in a radio or TV. As it traverses the network the signal accumulates noise. Through every step of the transmission and through each amplifier, the noise is amplified along with the signal, creating the potential for significant accumulated noise at the receiving end of the transmission. The resulting signal-to-noise ratio can be unacceptable. Amplifiers typically are spaced every 18,000 feet or so in an analog network.

If you take a bale of hay and tie it to the tail of a mule and then strike a match and set the bale of hay on fire, and if you then compare the energy expended shortly thereafter by the mule with the energy expended by yourself in the striking of the match, you will understand the concept of amplification.

William Shockley, co-inventor of the transistor [2-4].

The impact of amplification on voice communications generally is tolerable, as humans are relatively intelligent receivers who can filter out the noise or, at least adjust to it. In the event of a truly garbled transmission, the human-to-human error detection and correction process simply involves a request for re-transmission. Should the quality of the connection be totally unacceptable, the connection can be terminated and re-established. Computer systems, however, are not so forgiving, and garbled data is of decidedly negative value.

Repeaters (Digital)

In a digital system, periodic amplifiers are replaced by regenerative repeaters, which regenerate the signal, rather than simply amplifying it. The repeater guesses the binary value (1 or 0) of the weak incoming signal based on its relative voltage level and regenerates a strong signal of the same value, without the noise. This process immensely enhances the signal quality. Repeaters are spaced at approximately the same intervals as amplifiers, although spacing is sensitive to the carrier frequency, which affects both transmission speed, or bandwidth provided, and the level of attenuation experienced.

The performance advantage of digital networks can be illustrated by comparing the error rate of amplifiers and regenerative repeaters. For example, a twisted-pair, analog network can be expected to yield an error rate on the order of 10-5. In other words, digital data sent across an analog network will suffer 1 errored bit for every 100,000 bits transmitted (Figure 2.7). The very same twisted-pair network, if digitized and equipped with repeaters, will yield an expected error rate of 10-7, or 1 errored bit in every 10,000,000. This is an improvement of two orders of magnitude. Digital fiber optic systems, currently considered to be the ultimate, yield error rates in the range of 10-11 to 10-14, or an error rate as low as 1 bit for every 100,000,000,000,000 transmitted—virtually perfect [2-3]!

Figure 2.7 Comparative error performance of analog vs. digital transmission over twisted pair.

The Conversion Process: Digital to Analog (D to A) and Analog to Digital (A to D)

Regardless of the relative merits of analog and digital transmission, both technologies are available. Local telephone loops, which connect the user premise to the central office exchange generally are analog, as are US cellular radio networks. High-capacity, backbone carrier transmission generally is digital. Therefore, analog-to-digital and digital-to-analog conversions routinely take place in the carrier-provided networks.

Digital to Analog: Modems

As local loops generally are analog, computer communications across such circuits is not possible without the assistance of a device to accomplish the digital-to-analog conversion. Of course, one might gain access to a more expensive digital circuit, by so specifying, if it is available.

The device which accomplishes D-to-A conversion is known as a modem. Modems MOdulate and DEModulate the analog sine wave represent digital bit streams across the analog local loop, reconstructing the digital signal on the receiving end through a process of A-to-D conversion (Figure 2.8). A variety of techniques are used to accomplish this process and are discussed in Chapter 7.

Figure 2.8 Modem: Digital-to-Analog Conversion.

Analog to Digital: Codecs

The reverse conversion process is necessary to send analog information across a digital circuit. This is often the case in the carrier networks, where huge volumes of analog voice are digitized and sent across high capacity, digital circuits. This requirement also exists where high capacity digital circuits connect premise-based, PBX voice systems to central office exchanges or to other PBXs, assuming that the PBXs or COs have not already performed the conversion. As video also is analog in its native form, a similar process must be employed to send video across a digital circuit.

The device that accomplishes the A-to-D conversion is known as a codec. Codecs COde an analog input into a digital (data) format on the transmit side of the connection, reversing the process, or DECoding the information, on the receive side, in order to reconstitute the analog signal (Figure 2.9).

Figure 2.9 Codec: Analog-to-Digital Conversion.

Encoding is the process of converting an analog information stream (e.g., voice or video) into a digital data stream. The voice or video signal is sampled at frequent intervals with each sample of amplitude then being expressed in terms of a binary (computer) value, which is usually a 4-bit or 8-bit byte. The reverse process of decoding takes place on the receiving end, resulting in recomposition of the information in its original form, or at least a reasonable approximation thereof.


Communications Systems and Networks:Fundamentals if the Technology: Concepts and Definitions

MULTIPLEXERS (MUXs or MUXes)

The term multiplex has its roots in the Latin words multi (many) and plex (fold). Multiplexers (MUXs) act as both concentrators and contention devices to allow multiple, relatively low-speed terminal devices to share a single, high-capacity circuit (physical path) between two points in a network. The benefit of multiplexers is that they allow carriers and end users to take advantage of the economies of scale. Just as a multilane highway can carry increased volumes of traffic in multiple lanes at higher speeds and at relatively low incremental cost, a high capacity circuit can carry multiple conversations in multiple channels at relatively low incremental cost.

The modern saying, “Time is Money,” is indeed most of all true when applied to telegraphic signalling; and many endeavours have been made, not only to transmit signals with celerity, but also to transmit more than one communication at the same time along the same wire. This has been successfully done in the duplex system—by which a message is sent from either end of the same wire simultaneously; in the diplex system—in which two messages can be sent simultaneously in one direction; and in the quadruplex system, which combines the two former methods, and by which it is possible to convey four signals along the same wire at the same moment. This last method was invented by Mr. Edison….

Wonders of the Universe. 1899. [2-5]

Contemporary multiplexers rely on four-wire circuits that permit multiple logical channels to be derived from a single physical circuit, and that permit high-speed transmission simultaneously in both directions. In this manner, multiple communications (either unidirectional or bidirectional) can be supported. Multiplexing is used commonly across all transmission media, including twisted pair, coaxial and fiber optic cables; and microwave, satellite and other radio systems.

Traditional multiplexing comes in several varieties, presented in chronological order of development and evolution. Included are Frequency Division Multiplexing (FDM), Time Division Multiplexing (TDM), and Statistical Time Division Multiplexing (STDM). Wavelength Division Multiplexing (WDM), although still in development, is discussed here in brief. WDM will be used in fiber optic cable systems.

Frequency Division Multiplexing (FDM)

Frequency Division Multiplexing (FDM) takes advantage of the fact that a single twisted pair, copper circuit can carry much more than the 4 kHz guaranteed for individual voice conversations. Even in the early days of vacuum tube technology, up to 96 kHz could be supported over a set of 2 copper pairs (a 4-wire circuit, with 2 wires in each direction), thereby enabling the carrying of up to 24 individual voice channels, separated by frequency bands [2-2]. In terms of a commonly understood analogy, multiple frequencies can be supported over a single, four-wire electrical circuit much as can multiple radio stations, and TV channels be supported over the airwaves through frequency separation.

Through a FDM MUX (Figure 2.10), conversation #1 might be supported over frequencies 0 Hz–4,000 Hz; conversation #2 over frequencies 4,000 Hz–8,000 Hz; conversation #3 over frequencies 8,000 Hz–12,000 Hz; and so on. Additionally, small slices of frequency are designated as subchannels, or guard bands, which separate the carrier channels used for information transmission. The guard bands serve to minimize the likelihood of interference between conversations riding in adjacent information channels over the same physical circuit.

Figure 2.10 Frequency Division Multiplexing (FDM) in a data communications application.

Frequency Division Multiplexers, however, typically are not particularly intelligent. Specific devices or groups of devices often are tuned to using designated frequency bands for communications. As noted in Figure 2.10, the bandwidth associated with those devices is unused if the communication is inactive for some reason, even though other devices could perhaps make effective use of it.

FDM served its purpose well, at the time, for long-haul voice transmission. Data communications over FDM, however, requires sets of special low-speed modems, one for each channel, with one set at each end of the facility. FDM currently is used in broadband Local Area Networks (LANs), which support multiple simultaneous transmissions. FDM also is used in cellular radio networks and in certain digitized voice applications. As we have noted, however, (all things being equal) digital generally is better. Digital is especially better when data traffic is involved, and this rapidly is becoming a data world.

Time Division Multiplexing (TDM)

Time Division Multiplexing (TDM) offers all of the advantages of digital transmission, namely improved bandwidth utilization, enhanced error performance, improved security and upgradeability.

At the transmitting end of the connection, the TDM scans the ports to which individual devices are attached, allocating each device port a channel, or time slot, for transmission of data. Device #1 transmits through Port #1 and over Time Slot #1, Device #2 transmits through Port #2 and over Time Slot #2, and so on, in a serial fashion. The transmitting TDM typically accepts an 8-bit set of data from each port and interleaves those sets of data into a single, composite digital output. As the MUX completes a scan of the ports and transmits a set of such data, it will separate one set of data from another by inserting some number (usually one) of framing bits, which serve to frame, or package the data set.

At the receiving end, the process is reversed, with the channels being identified serially and the individual conversations being transmitted by the MUX over individual ports to the individual, intended receiving terminal devices. Clearly, the MUXs must be carefully synchronized in time, so as to allow the receiving MUX to determine the proper separation of frames and channels of data.

The primary constraint of a basic TDM is one of static configuration. In other words, Channel #1 is always reserved for Port #1, over which Terminal #1 always transmits. Terminals which are idle, turned off, unplugged or on fire still are allocated valuable bandwidth, thereby having a deleterious effect on the cost-effectiveness of the facility (see Figure 2.11). As a result, TDMs are no longer held in favor.

Figure 2.11 Time Division Multiplexing (TDM) in a data communications application.


Communications Systems and Networks:Fundamentals if the Technology: Concepts and Definitions

Statistical Time Division Multiplexing (STDM)

Statistical Time Division Multiplexing (STDM) is much improved over TDM, as the MUXs are intelligent. STDMs, or Stat MUXs, offer the advantage of dynamic allocation of available channels and raw bandwidth. In other words, STDMs can allocate bandwidth, in the form of time slots, in consideration of the transmission requirements of individual devices serving specific applications (Figure 2.12). Further, an intelligent STDM can dynamically adapt to the nature and associated requirements of the load placed on it, and in consideration of the available capacity of the network.

Figure 2.12 Statistical Time Division Multiplexing (STDM) in a data communications application.

Stat muxes can recognize active versus inactive devices, as well as priority levels. Further, they can invoke flow control options that cause a transmitting terminal to cease transmission temporarily in the event that the MUX’s internal buffer, or temporary memory device, is full. Flow control also can be used to restrain low priority transmissions in favor of higher priority transmissions. Additionally, STDMs may offer the advantages of data compression, error detection and correction, and traffic statistics reporting

T/E-Carrier, which will be discussed in detail in a later chapter, relies on STDMs. The high-speed, four-wire digital circuit typically is divided into multiple time slots to carry multiple conversations. As an example, T-1 (US) provides 24 time slots to carry 24 conversations, each a maximum of 64 Kbps. E-1 (European) provides 30 time slots to carry 30 conversations

Additionally, the individual channels can be grouped to yield higher transmission rates (superrate) for an individual, bandwidth-intensive communication such as a videoconference. The individual channels also can be subdivided into lower speed (subrate) channels to accommodate many more, less bandwidth-intensive communications, such as low speed data. Additionally, many MUXs also allocate bandwidth on a priority basis, providing delay-sensitive traffic (e.g., realtime voice or video) with top priority in order to ensure that the resulting presentation of the data at the receiving end is of high quality.

Wavelength Division Multiplexing (WDM)

Although they are not yet in common usage, Wavelength Division Multiplexers (WDMs), allow multiple high speed channels to be supported over a single fiber optic transmission system. This is accomplished through the transmission of multiple frequencies (wave lengths) of light, much as multiple electrical frequencies can support multiple, simultaneous conversations in a FDM transmission system. For instance, multiple 2 Gpbs channels can be accommodated over a 8 Gbps fiber optic system through the use of four different frequencies of light.

Inverse Multiplexers

Inverse Multiplexers perform just the inverse (opposite or reverse) process as do traditional MUXs. In other words, they accommodate a single, high-bandwidth data stream by transmitting it over multiple, lower-bandwidth channels or circuits (Figure 2.13). The transmitting MUX segments the data stream on a consistent basis, while the receiving MUX reconstitutes the composite datastream. Clearly, the two devices must be synchronized carefully with each other and with the transmission characteristics of the individual paths and channels to minimize errors and delays. An individual communication might be spread over multiple switched circuits, dedicated circuits, or channels on multichannel circuits. For instance, a low-speed video conference at 128 Kbps might be sent over 2 separate 64 Kbps channels on an ISDN circuit.

Figure 2.13 Inverse Multiplexing in a videoconferencing application.

Data Over Voice and Voice Over Data

A large number of manufacturers now offer MUXs that allow data to be sent over voice lines and voice to be sent over data lines. For instance, a digital data circuit also can accommodate voice (for which it was not intended) through the use of a special MUX which digitizes the voice signal and transmits it over a data circuit; the reverse process takes place at the receiving end. The voice and data conversations share the same circuit, sequentially, rather than simultaneously. Bandwidth is allocated as appropriate, with priority provided to the delay-sensitive voice traffic.

While such an approach is somewhat unusual, it allows the user to take advantage of excess capacity on a dedicated circuit. It also can be used to support both voice and data communications over a single circuit-switched analog circuit. There is, of course, an investment required in the multiplexing equipment, although such equipment, increasingly, is quite affordable.

In the very recent past, several manufacturers have developed MUXs which allow voice to share excess capacity on a Frame Relay network. While the quality generally is not remarkable due to issues of data compression and delay, the voice conversation essentially is free.

Switches and Switching: The Fundamentals (and then some)

Switches serve to establish transmission paths between terminal devices (transmitters and receivers) on a flexible basis. They effectively serve as contention devices, managing contention between multiple transmit devices for access to shared circuits. In this manner, the usage and cost of expensive circuits can be optimized based on standard traffic engineering principles. Without switches, each device would require a direct, dedicated circuit to every other device. Such a full mesh network clearly is resource-intensive, impractical and even impossible, as early experience proved. This discussion of switches and switching is presented in chronological order of development, beginning with circuit switching and its evolution, and progressing through packet to frame and cell switching.

Circuit Switching

In the classic sense, circuit switching provides continuous and exclusive access between physical circuits for the duration of the conversation. Contemporary circuit switches provide continuous access to logical channels over high-capacity physical circuits for the duration of the conversation. While circuit switches originally were developed for voice communications, much data traffic currently also is switched in this fashion.


Communications Systems and Networks:Fundamentals if the Technology: Concepts and Definitions

Manual (Cordboard) Switches

These switches involved operators who manually established the desired connection at the request of the transmitting party. A unique physical and electrical connection was established, on a plug and jack basis (Figure 2.14), for the duration of the call. When either party disconnected, the operator was alerted and was responsible for manually disconnecting the circuit, which became available for other use. The size of such switches, the complexity of interconnecting long distance calls across multiple switches, and the labor intensity of this approach all contributed to their demise.

Figure 2.14 Manual Switching: Cordboard.

The term tip and ring came from the cordboard plug, which established a connection between both local loop pairs of wires. One set of wires was connected electrically through the tip of the plug, while the other set was connected through the ring, or seat of the plug. The first such switch was installed by the New Haven District Telephone Company in New Haven, Connecticut on January 28, 1878, at a cost of US$28.50. The system connected 21 subscribers who were referred to by name, rather than telephone number. As was typical in those days, the operators were young boys, most of them with experience as messengers and telegraph clerks—they soon proved to be boisterous and unreliable, and were replaced with women [2-6].

Step-by-Step (Sxs) Switches

The first such electro-mechanical switch was invented and patented in 1891 by Almon B. Strowger, a Kansas City undertaker who was frustrated with the behavior of the local telephone company operator. According to legend, the operator was directing Mr. Strowger’s calls to her husband, a competing undertaker. Building on earlier Bell system inventions, Strowger invented a system that would serve 99 subscribers. That patent served as the foundation for the company he founded, Automatic Electric Company, which later became the manufacturing subsidiary of General Telephone and Electric (GTE) [2-6].

SxS switches consist of large number of line finders to which groups of individual subscribers are assigned for dial tone. The transmitting party dials a series of numbers, originally with a rotary telephone terminal which causes the making and breaking of an electrical circuit. As noted in figure 2.15, those electrical pulses cause successive mechanical line selectors to click across contacts to set up the conversation path as the complete number is dialed [2-7].

While such switches are still in use (in 1986, approximately 38% of all U.S. switches were based on SxS), they clearly are not desirable, as they are slow, expensive, large, maintenance-intensive and capacity-limited [2-2].

Figure 2.15 Step-by-Step (SxS) Switching. Source: AG Communications Systems Corporation

Crossbar (XBar) Switches

The first common control switches, XBar switches are largely electromagnetic in nature. While the original concept was developed at Bell Telephone Laboratories (now Lucent Technologies), the Swedish Ericsson company accomplished much of the early development work. The first such switch installed in the United States was a central office exchange in Brooklyn, New York (1938) [2-6]. Such switches quickly became predominant.

In a XBar switch (Figure 2.16), a request for dial tone is recognized by a marker, which directs a sender to store the dialed digits. A translator is then directed to route the call, reserving a path through a switching matrix [2-2]. Once the call is connected, these various components are available to serve other calls. Compared to the SxS switch, the XBar had relatively few moving parts. XBar switches offered the advantages of increased intelligence, common control, greater speed of connection, smaller footprint, lower maintenance, and greater capacity.

Figure 2.16 Crossbar (XBar) switching. Source: AG Communications Systems Corporation

Electronic Common Control (ECC) Switches

ECC switches reflect the marriage of computer technology and telephony. While the first ECC switches were analog, contemporary switches are, in fact, fully digital. Voice conversations are digitized and switched over high-speed digital circuits, with all processes accomplished through programmed logic. ECC switches are microprocessor controlled, with the total processing power of such a switch often rivaling that of a general purpose, mainframe computer. The first ECC switch was developed, with the assistance of Western Electric, by AT&T Bell Laboratories, based on its invention of the transistor in 1948 and involving a development effort that began in earnest in the early 1950s. That first Electronic Switching System (ESS) CO was placed into service in Succasunna, New Jersey on May 30, 1965, connecting 200 subscribers. By 1974, there were 475 such offices in service, serving 5.6 million subscribers. The development effort was estimated to involve 4,000 man-years and a total cost of $500 million [2-6].

ECC switches (Figure 2.17), as compared to the previous generations of switching technology, offer the advantages of increased intelligence, greater speed of call set-up and overall call processing, and a still smaller footprint. Additionally, they offer lower maintenance costs and can, in fact, be monitored and managed from a remote location. Many contemporary ECC switches are unmanned in favor of control from a centralized Network Operations Center (NOC). ECC switches offer greater capacity, and on a scaleable basis— capacity can be increased through the addition of various system modules, or cabinets. As specialized, software-controlled computer systems, their functionality and feature content often can be upgraded through additional software and/or firmware. Such switches generally possess the ability to switch data and video, as well as voice. Finally, they interface with various application processors to further increase the range of services provided. Such application processors (applications) might include voice processors (e.g., voice mail and language translation) and fax servers (fax mail).

Figure 2.17 Electronic Common Control (ECC) switching. Source: AG Communications Systems Corporation

Packet Switching

First deployed in 1971, packet switching grew out of the United States Advanced Research Project Agency (ARPA) network. Commonly referred to as ARPAnet, the network was established to support interactive, asynchronous computer-to-computer communications between the defense and university communities.


Communications Systems and Networks:Fundamentals if the Technology: Concepts and Definitions

Rather than employing circuit switching, which is far too expensive for intensive, interactive computer communications, ARPAnet, and its successors such as the Internet, make use of packet switching. Packet switching involves the transmission of data in packets of fixed length across a shared network. Each packet is individually addressed, in order that the packet switches can route each packet over the most appropriate and available circuit. In this manner, packets offered to the network by large numbers of users can make use of the same switches and transmission facilities, thereby dramatically lowering the cost of data transmission to the individual user organization.

Traditional packet switching offers the advantage of being based on mature and stable technologies. Additionally, it is widely available on an international basis and is low in cost. Its disadvantages include the fact that it is intended to support only relatively low-speed data transmission. As the switches assume a 1960-vintage analog network environment of twisted pair, each switch is responsible for examining each individual packet for errors created in transmission. Further, each switch is responsible for resolving identified errors through a request for retransmission. These factors, in combination, result in unpredictable, variable levels of delay in packet transmission. Therefore, packet switching generally is considered to be unsuitable for stream-oriented communications such as real-time voice and video.

X.25 (an international standard packet switching interface which will be discussed in Chapter 8) offers great advantage in terms of its ability to support the connection of virtually any computer system through its ability to accomplish protocol conversion. This highly desirable feature classified X.25-based packet networks as the first value-added networks.

Frame Switching (Frame Relay)

A relative newcomer, frame relay was first offered commercially in 1992 by Wiltel (U.S.). Much like packet switching, each frame is addressed individually. Frame relay also makes use of special switches and a shared network of very high speed. Unlike packet switching, frame relay supports the transmission of virtually any computer data stream in its native form—frames are variable in length (up to 4,096 bytes). Rapidly gaining in popularity, frame relay is widely available in many highly developed nations. International frame relay service is also becoming widely available. Disadvantages include the fact that frame relay, like packet switching, is oriented towards data transmission. Further, transmission delays are variable and uncertain in duration. While increasingly satisfactory technologies have been added for support of voice and video, frame relay is not designed with those applications in mind.

Cell Switching

Clearly, cell switching is fundamental to the future of communications. Encompassing both Switched Multimegabit Data Service (SMDS) and Asynchronous Transfer Mode (ATM), data is organized into cells of fixed length (53 octets), shipped across very high speed facilities and switched through very high speed, specialized switches. While SMDS has proved to be very effective for data communications, ATM will be pervasive in the future.

ATM is primarily data-oriented, although it is ultimately intended to support voice and video as well. Standards are still being developed and availability is limited. Current disadvantages include its relatively high cost and data communications orientation.

Photonic Switches

Still in development, photonic switches are yet another dimension in the evolution of switch technology. Capable of supporting circuit-, packet- frame- and cell switching, photonic switches will eliminate the requirement for optoelectric conversion when connected to a fiber optic transmission system. Clearly, they also will offer advantages in terms of speed and error performance. While prototype photonic switches currently are in use in testbed environments, it likely will be a decade or so before they are commercially viable in CO applications; it is highly unlikely that they will find application in the PBX world, at least not in the foreseeable future.

Signaling and Control

Signaling and control comprises a set of functions which must take place within any network in order ensure that it operates smoothly. In this context, various elements within the network must identify themselves, communicate their status and pass instructions. Fundamental examples include on-hook and off-hook indication, dialtone provision, call routing control, busy signal, and billing instructions. Further examples include dialed digits, route availability, routing preference, carrier preference, and originating number or circuit [2-2].

In more sophisticated, contemporary networks, the responsibility for overall signaling and control functions resides within a separate common channel signaling (CCS) and control network. Such a sophisticated CCS network involves highly intelligent devices which are capable of monitoring and managing large numbers of lower order devices in the communications network which it controls. From a centralized Network Control Center (NCC), the network can be monitored, and faults or performance failures can be identified, diagnosed, and isolated. Finally, the lower order devices in the communications network oftentimes can be addressed and commanded to correct the condition.

References

[2-1] Doll, Dixon R. Data Communications: Facilities, Networks and Systems Design. NY: John Wiley & Sons. 1978.
[2-2] Engineering and Operations in the Bell System. NJ: Bell Telephone Laboratories, Inc. 1977.
[2-3] Bates, Bud. Introduction to T1/T3 Networking. Norwood MA: Artech House. 1992.
[2-4] Augarten, Stan. Bit by Bit. NY: Ticknor & Fields. 1984.
[2-5] Wonders of the Universe. NY: The Werner Company. 1899.
[2-6] Brooks, John. Telephone: The First Hundred Years. NY: Harper & Row, 1976.
[2-7] AG Communications Systems. Introduction to Telecommunications. AZ: AG Communications Systems Corporation, 1990.


Communications Systems and Networks:Fundamentals of Transmission Systems: Technologies and Applications

Chapter 3
Fundamentals of Transmission Systems: Technologies and Applications

It was early declared by Professor Morse, and by other distinguished investigators of the nature and powers of the electric current, that neither the ocean itself, nor the distance to be traversed, presented any insuperable obstacle to the laying of submerged oceanic lines from continent to continent, and the confident prophecy that such lines would eventually be undertaken was freely uttered and discussed in learned circles.

Our First Century or the One Hundred Great and Memorable Events in the History of Our Country during the One Hundred Years of its Existence, 1876

Information is of considerably increased value if it can be conveyed clearly to others. This is a basic principle that is well understood in this information age. The conveyance, or transmission, of information across a distance necessarily involves some form of transmission medium. In this chapter, the terms transmission medium, transmission system, and transmission facility will be used interchangeably, as indeed they are in the real world. The selection of physical transmission media which serve to transport that information is critical to its successful conveyance. In interactive communication, the medium can be critical to the message.

This section addresses all transmission media commonly used in traditional voice, data, video, and image networks, whether analog or digital in nature. Those media can be grouped into two distinctive categories, the first of which includes all wired media, also referred to as conducted, guided, or bounded media. The second category includes all traditional wireless media, also referred to as radiated, unguided, or unbounded.

Wired transmission systems employ physical media which are tangible. In other words, they can be seen, felt and perhaps even smelled and tasted (the last two options are not recommended, as the results might well be unpleasant). Also known as conducted systems, wired media generally employ a metallic or glass conductor which serves to conduct, or carry on, some form of electromagnetic energy. For example, twisted pair and coaxial cable systems conduct electrical energy, employing a copper medium; fiber optic systems conduct light, or optical, energy, generally using a glass conductor. The term guided media refers to the fact that the signal is contained within an enclosed physical path. Finally, bounded media refers to the fact that some form of shield, cladding, and/or insulation is employed to bind the signal within the core medium, thereby improving signal strength over a distance and enhancing the performance of the transmission system in the process. Twisted pair (both unshielded and shielded), coaxial and fiber optic cable systems fall into this category.

Wireless transmission systems do not make use of a physical conductor, or guide, to bind the signal. Therefore, they are also known as unguided or unbounded systems. Rather than relying on electrical energy, such systems generally make use of radio waves; hence the term radiated often is applied to wireless transmission. Finally, such systems employ electromagnetic energy in the form of radio or light waves that are transmitted and received across space, and are referred to as airwave systems.

Each specific transmission system is distinguished by unique properties, limitations (or lack thereof), and appropriate applications. The application to be supported, clearly, must be of primary consideration in designing a network and in selecting the transmission medium, assuming one has the freedom of choice. As the application must support users effectively, it places certain demands on the network and on the transmission medium.

Traditional transmission systems addressed in this chapter include twisted copper wire, coaxial cable, microwave, satellite, infrared and fiber optics. The order of discussion is roughly chronological. Cellular radio, packet wireless and other wireless networks and specific applications are discussed in Chapter 12.

Frequency Spectrum

While human voice frequencies mostly are in the range of 100 Hz to 8,000 Hz; the energy in the speech spectrum peaks at approximately 500 Hz, with most articulation being at higher frequencies. The human ear can distinguish signals as low as 20 Hz and as high as 20 kHz, and is most sensitive in the range of 1,000 Hz to 3,000 Hz. Public switched telephone networks, as we have discussed previously, provide reliable, raw, voice-grade bandwidth of 4 kHz; with 3,300 Hz (200 Hz to 3,500 Hz) usable for signal transmission. This range of frequencies provides a band of intelligibility which is considered to be good, although not complete. In an electrical cable system, the range of carrier frequencies depends on the nature of the medium and the requirements of the applications supported. For instance, twisted pair can support bandwidths of 10 Hz to 105 Hz, and coaxial cable of 106 Hz to 108 Hz. The actual range of frequencies supporting a given communication are known as a passband, which is accomplished through the use of band-limiting filters [3-1], [3-2], and [3-3].


Communications Systems and Networks:Fundamentals of Transmission Systems: Technologies and Applications

Frequency and wavelength are inversely related—as the frequency of the signal (number of cycles per second) increases, the wavelength (length of the electromagnetic waveform) of the signal decreases. In other words, the more waveforms per second, the shorter the length, or cycle, of each individual wave. Table 3.1 defines the frequency and wavelength of various types of radio and light-based communications systems as they relate to the electromagnetic spectrum [3-2], [3-3], and [3-4]. While higher frequency signals offer greater bandwidth, they also generally suffer to a greater extent from signal attenuation.

Table 3.1 Frequency Spectrum
Band Designation | Frequency Range | Wavelength | Usage
Audible | 20 Hz–20 kHz | >100 Km | Acoustics
Extremely/Very Low Frequency (ELF/VLF) Radio | 3 kHz–30 kHz | 100 Km–10 Km | Navigation, Weather, Submarine Communications
Low Frequency (LF) Radio | 30 kHz–300 kHz | 10 Km–1 Km | Navigation, Maritime Communications
Medium Frequency (MF) Radio | 300 kHz–3 MHz | 1 Km–100 m | Navigation, AM Radio
High Frequency (HF) Radio | 3 MHz–30 MHz | 100 m–10 m | Citizens Band (CB) Radio
Very High Frequency (VHF) Radio | 30 MHz–300 MHz | 10 m–1 m | Amateur (HAM) Radio, VHF TV, FM Radio
Ultra High Frequency (UHF) Radio | 300 MHz–3 GHz | 1 m–10 cm | Microwave, Satellite, UHF TV
Super High Frequency (SHF) Ratio | 3 GHz–30 GHz | 10 cm–1 cm | Microwave, Satellite
Extremely High Frequency (EHF) Radio | 30 GHz–300 GHz | 1 cm–.1 mm | Microwave, Satellite
Infrared Light | 103–105 GHz | 300µ–3µ | Infrared
Visible Light | 1013–1015 GHz | 1µ–.3µ | Fiber Optics
X-Rays | 1015–1018 GHz | 103µ–107 µ | N/A
Gamma and Cosmic Rays | >1018 GHz | <017 µ | N/A
k = Kilo = 1,000 (1 thousand)
M = Mega = 1,000,000 (1 million)
G = Giga = 1,000,000 (1 billion)
T = Tera = 1,000,000,000 (1 trillion)
cm = centimeter (1/100 meter)
mm = millimeter (1/1,000 meter)
µ = micron (1/1,000,000 meter)

Selection Criteria

The selection of the most effective transmission system for a given application must be made in the context of a number of key design considerations. Such considerations include general transmission characteristics such as bandwidth and error performance, both of which affect throughput. Additionally, one must consider the allowable distance between devices, as well as issues of propagation delay, security, mechanical strength, and physical dimensions. Finally, and perhaps most important of all, are issues of local availability and cost, including cost of acquisition, deployment, operation and maintenance, and upgrade or replacement.

Transmission Characteristics

The basic transmission characteristics of a given medium are of primary importance. Those characteristics include bandwidth, or capacity, error performance, and distance between network elements. These three dimensions of a transmission system, in combination, dictate effective throughput, the amount of information that can be put through the system.

Bandwidth, in this context, refers to the raw amount of bandwidth the medium supports. Error performance refers to the number or percentage of errors which are introduced in the process of transmission. Distance refers to the minimum and maximum spatial separation between devices over a link, in the context of a complete, end-to-end circuit. Clearly, any given transmission system increases in attractiveness to the extent that available bandwidth is greater, introduced errors are fewer, and the maximum distance between various network elements (e.g., amplifiers, repeaters, and antennae) is greater.

It should be noted that bandwidth, error performance, and distance are tightly interrelated. In a twisted pair network, for example, more raw bandwidth requires higher transmission frequencies. Higher frequencies attenuate (lose power) more rapidly than do lower frequencies. This fact results in more errors in transmission, unless the amplifiers/repeaters are spaced more closely together. For instance, a physical four-wire, digital T1 circuit typically is provisioned over twisted pair, providing bandwidth of 1.544 Mbps with excellent error performance through the placement of regenerative repeaters spaced approximately every 6,000 ft. A somewhat better grade of twisted pair can be deployed in a Local Area Network (LAN) to support transmission rates of 100 Mbps between a workstation and a LAN hub or switch, with excellent error performance as long as the device separation is [le]100 meters (some manufacturers back away from support at 20 meters). In either case, certain measures must be taken to avoid high levels of ambient noise, the gauge of the conductors must be considered, etc. While this comparison is simplified, it clearly demonstrates the close and direct relationship between bandwidth, distance, and error performance.


Communications Systems and Networks:Fundamentals of Transmission Systems: Technologies and Applications

Propagation Delay and Response Time

Propagation delay refers to the length of time required for a signal to travel from transmitter to receiver across a transmission system. While electromagnetic energy travels at roughly the speed of light (186,000 miles per second) the nature of the transmission system impact the level of propagation delay to a considerable extent. In other words, the total length of the circuit directly impacts the length of time it takes for the signal to reach the receiver. That circuit length can vary considerably in a switched network, as the specific circuit route will vary in length from call to call, depending on availability of individual links and switches. Dedicated networks offer the advantage of a reliable and consistent level of propagation delay. In either case, the level of delay is affected by the number of network elements (devices) in the network, as each device (e.g., amplifier, repeater, and switch) acts on the signal to perform certain processes, each of which takes at least a small amount of time. Clearly, the fewer devices involved in a network, the less delay imposed on the signal.

Perhaps propagation delay is best illustrated by satellite systems. Given the fact that the radio signals must travel approximately 22,300 miles up to the satellite and the same distance on the return leg, the resulting delay is approximately .25 seconds. Considering the amount of time required for processing on the satellite, as well as at the earth stations, the total delay for a one-way transmission is about .32 seconds. Therefore, the delay between signal origination and receipt of response is about .64 seconds, assuming that the response is immediate. Hence, highly interactive voice, data, and video applications are not effectively supported via two-way satellite communications.

Security

Security, in the context of transmission systems, addresses the protection of data from interception as it transverses the network. Clearly, increasing amounts of sensitive data are being transmitted across wide and metropolitan area networks, outside the protection of one’s own premises. Therefore, security is of greater concern than ever before and will heighten as nations and commercial enterprises seek to gain competitive advantage and as they apply ever more sophisticated means to do so. In hearings (May 1996) before the United States Senate, it was stated that 120 nations either have or are in the process of developing sophisticated computer espionage capabilities.

Further, it should be noted that airwave systems (e.g., microwave and satellite) are inherently not secure, as unauthorized entities can gain access to that data through the use of a properly tuned and placed antenna, without the necessity of tapping a physical circuit. Finally, and as we discussed in a previous chapter, digital systems are inherently more secure than are their analog counterparts by virtue of the fact that the data can effectively be encrypted, or encoded, in order to conceal its true meaning. Particularly in the case of data networking, it also is important that access to a remote system and the data resident on it be limited to authorized users; therefore, some method of authentication, must be employed in order to verify that the access request is legitimate and authentic.

Mechanical Strength

Mechanical strength applies most especially to wired systems. Twisted pair, coaxial, and fiber optic cables are manipulated physically as they are deployed and reconfigured. Clearly, each has certain physical limits to the amount of bending and twisting (flex strength) they can tolerate, as well as the amount of weight or longitudinal stress they can support (tensile strength), without breaking (break strength). Fiber optic cables are notoriously susceptible in this regard. Cables hung from poles expand and contract with changes in ambient temperature; while glass fiber optic cables expand and contract relatively little, twisted pair copper wire is more expansive [3-5].

The issue of mechanical strength also applies to airwave systems, as reflective dishes, antennae, and other devices used in microwave, satellite, and infrared technologies must be mounted securely to deal with wind and other forces of nature. Additionally, the towers, walls and roofs on which they are mounted must be constructed and braced properly in order to withstand such forces, and must flex as appropriate.

Physical Dimensions

The physical dimensions of a transmission system must be considered as well. This is especially true, once again, in the case of wired systems. Certainly, the sheer weight of a cable system must be considered as one attempts to deploy it effectively. Additionally, the bulk (diameter) of the cable is of importance, as conduit and raceway space often is at a premium. The physical dimensions of airwave systems also must be considered, as the size and weight of the reflective dish and mounting system (e.g., bracket and tower) may require support.

Cost

Cost issues abound in the selection of an appropriate transmission medium. Such issues include the cost of acquisition, deployment, operation, and maintenance (O&M), and upgrade or replacement. Without a lengthy discussion of each cost issue, it is particularly noteworthy to compare the costs of deployment of wired versus wireless media.

Wired transmission systems require that a right-of-way be secured, trenches be dug, holes be bored under streets, poles be planted, conduits and manholes be placed, cables be pulled and spliced, amplifiers or repeaters be placed, etc. Such costs, clearly, are not trivial. Wireless systems, on the other hand, require that right-of-way be secured, antennae be placed (perhaps in orbit), and so on. While it is difficult to make hard-and-fast generalizations, the deployment of wired systems certainly speaks to a set of cost issues which often can be more problematic. Further, wired systems tend to be more susceptible to the forces of man (e.g., cable-seeking backhoes and train derailments) and nature (e.g., earthquakes and floods) than do their wireless counterparts.


Communications Systems and Networks:Fundamentals of Transmission Systems: Technologies and Applications

Twisted Pair: An Introduction to Telephone Wire

Metallic wires were used almost exclusively in telecommunications networks for the first 80 years, certainly until the development of microwave and satellite radio communications systems. Initially, uninsulated iron telegraph wires were used, although copper was soon found to be a much more appropriate medium. The early metallic electrical circuits were one-wire, supporting two-way communications with each telephone connected to ground in order to complete the circuit. In 1881, John J. Carty, a young American Bell technician and one of the original operators, suggested the use of a second wire to complete the circuit and, thereby, to avoid the emanation of electrical noise from the earth ground. In certain contemporary applications, copper-covered steel, copper alloy, nickel- and/or gold-plated copper, and even aluminum metallic conductors are employed. The most common form of copper wire used in communications is that of twisted pair [3-6].

A twisted pair (Figure 3.1) involves two copper conductors, which generally are solid core, although stranded wire is used occasionally in some applications. Each conductor is separately insulated by polyethylene, polyvinyl chloride, flouropolymer resin (Category 5, or Cat 5), Teflon®, or some other low-smoke, fire retardant substance. The insulation separates the conductors, so that the electrical circuit is not shorted. This is accomplished by virtue of the two conductors, and serves to reduce electromagnetic emissions. Both conductors serve for signal transmission and reception. Because each conductor carries a similar electrical signal, twisted pair is considered to be a balanced medium [3-1] and [3-3].

Figure 3.1 Unshielded Twisted Pair (UTP) configuration.

The Twisting Process

The separately insulated conductors are twisted 90º at routine, specified intervals, hence the term twisted pair. This twisting process serves to improve the performance of the medium by containing the electromagnetic field within the pair. Thereby, the radiation of electromagnetic energy is reduced and the strength of the signal within the wire is improved over a distance. Clearly, this reduction of radiated energy also serves to minimize the impact on adjacent pairs in a multipair cable configuration. This is especially important in high-bandwidth applications, as higher frequency signals tend to lose power more rapidly over distance. Additionally, the radiated electromagnetic field tends to be greater at higher frequencies, impacting adjacent pairs to a greater extent. Generally speaking, the more twists per foot, the better the performance of the wire [3-1].

Gauge

Gauge is a measure of the thickness of the conductor. The thicker the wire, the less the resistance, the stronger the signal over a given distance, and the better the performance of the medium. Thicker wires also offer the advantage of greater break strength.

American Wire Gauge (AWG) is a commonly used standard measurement of gauge, although others are used outside the United States. The gauge numbers are retrogressive; in other words, the larger the number, the smaller the conductor. Originally known as Brown and Sharp (B&S) Gauge, the AWG number indicated the number of times the copper wire was drawn through the wire machine to reduce its diameter. As an example, a 24-gauge (AWG) wire has a diameter of .0201 in. (.511mm), a weight of 1.22 lbs./ft. (1.82 kg./km.), a maximum break strength of 12.69 lbs. (5.756 kg.) and D.C. resistance ohms of 25.7/1000ft. (84.2/km.). Twisted pair commonly employed in telephone company networks varies from 19 to 28-gauge, with the most common being 24-gauge. Table 3.2 provides an abbreviated comparison of the various UTP Categories [3-7].

Table 3.2 Unshielded Twisted Pair (UTP) categories, as defined by the Electrical Industry Association (EIA)
Category | Gauge (AWG) | Performance | Data
Cat 1 | Various | Undetermined | No
Cat 2 | 22 & 24 | Undetermined | No
Cat 3 | 22 & 24 | 16 MHz–10 Mbps | Yes
Cat 4 | Various | 16 Mbps | Yes
Cat 5 | Various | 100 Mbps | Yes

Configuration

In a single pair configuration, the pair of wires is enclosed in a sheath or jacket, also of polyethylene, polyvinyl chloride or Teflon. Oftentimes, multiple pairs are so bundled in order to minimize deployment costs associated with connecting multiple devices (e.g., electronic PBX or KTS telephone sets, data terminals, and modems) at a single workstation.

Larger number of pairs are bundled into large cables to serve departments, quadrants of a building, or floors of a high-rise office building—such cables may contain 25, 50, 100, 500 or more pairs. While twisted pair cables of up to 3,600 pairs are still used in outside plant applications, such continuing use is decidedly uncommon. In large cables, pairs are grouped into binder groups of 25 pairs for ease of connectivity management. Each binder group is wrapped (bound) with some sort of tape in order to separate it from other groups. Each pair within a binder group is color-coded for further ease of connectivity management. with the color codes being repeated within each binder group [3-5].

Bandwidth

The effective capacity of twisted pair cable depends on several factors, including the gauge of the conductor, the length of the circuit and the spacing of the amplifiers/repeaters. One must also recognize that a high-bandwidth (high frequency) application may cause interference with other conversations on other pairs in close proximity.


Communications Systems and Networks:Fundamentals of Transmission Systems: Technologies and Applications

While a voice grade circuit over twisted pair is guaranteed at 4 kHz, standard copper is capable of supporting much greater bandwidth. A single twisted pair, in a typical telephone installation, is capable of providing up to 250 kHz, or 1–4 Mbps compressed, assuming amplifier or repeater spacing every 2-3 km [3-1]. Additional examples follow:

• T1 connections (1.544 Mbps) are routinely provided over specially conditioned, four-wire twisted pair, with repeaters spaced at approximately 6,000 ft.
• Category 5 (CAT 5) copper, in a Local Area Network (LAN) environment, provides bandwidth of up to 100 Mbps over twisted pair at distances of [le]20 meters.
• Asymmetrical Digital Subscriber Loop (ADSL), a recently developed local loop technology, provides 6.144 Mbps in the downstream direction, as well as a 608 Kbps bidirectional channel—over a single two-wire, twisted pair local loop at distances [le]2 miles. Specifications also provide for even greater bandwidth, although over shorter distances.

Error Performance

Signal quality is always important, especially relative to data transmission. Twisted pair is especially susceptible to the impacts of outside interference, as the lightly insulated wires act as antennae and, thereby, absorb such errant signals. Potential sources of ElectroMagnetic Interference (EMI) include electric motors, radio transmissions and fluorescent light boxes. As transmission frequency increases, the error performance of copper degrades significantly with signal attenuation increasing approximately as the square root of frequency [3-8].

Distance

UTP is especially distance-limited. As distance between network elements increases, attenuation (signal loss) increases and quality decreases at a given frequency. Even low-speed (voice grade) analog voice transmissions require amplifiers spaced at least every 2 to 4 miles. As a result, local loops generally are 10,000 to 18,000 feet in length. As bandwidth increases, the carrier frequency increases, attenuation becomes more of a issue, and amplifiers/repeaters must be spaced more closely.

Security

UTP is inherently an insecure transmission medium. It is relatively simple to place physical taps on UTP. Additionally, the radiated energy is easily intercepted through the use of antennae or inductive coils, without the requirement for placement of a physical tap.

Cost

The acquisition, deployment and rearrangement costs of UTP are very low, at least in inside wire applications. In, high-capacity, long distance applications, such as inter-office trunking, however, the relative cost is very high, due to the requirements for trenching or boring, conduit placement, and splicing of large, multipair cables. Additionally, there are finite limits to the capacity and other performance characteristics of UTP, regardless of the inventiveness of technologists. Hence, the popularity of alternatives such as microwave and fiber-optic cable.

Applications

Generally speaking, UTP no longer is deployed in long-haul outside plant transmission systems, satellite, microwave and fiber optic cable are the media of choice in such applications. However, its low cost, coupled with recently developed methods of improving its performance, have increased its application in short-haul distribution systems. UTP is still the medium of choice in most inside wire applications. Current and continuing applications include the local loop, inside wire and cable, and terminal-to-LAN.

Shielded Copper

Shielded twisted pair (STP) differs from UTP in that a metallic shield or screen surrounds the pairs, which may or may not be twisted. As illustrated in Figure 3.2, the pairs can be individually shielded. A single shield can surround a cable containing multiple pairs or both techniques can be employed in tandem. The shield itself is made of aluminum, steel, or copper; is in the form of a metallic foil or woven mesh; and is electrically grounded. Although less effective, the shield sometimes is in the form of nickel and/or gold plating of the individual conductors.

Figure 3.2 Shielded Twisted Pair (STP) configuration.

Shielded copper offers the advantage of enhanced performance for reasons of reduced emissions and reduction of electromagnetic interference. Reduction of emissions offers the advantage of maintaining the strength of the signal through the confinement of the electromagnetic field within the conductor; in other words, signal loss is reduced. An additional benefit of this reduction of emissions is that high-frequency signals do not cause interference in adjacent pairs or cables. Immunity from interference is realized through the shielding process, which reflects electromagnetic noise from outside sources, such as electric motors, other cables and wires, and radio systems.

Shielded twisted pair, on the other hand, has several disadvantages. First, the raw cost of acquisition is greater as the medium is more expensive to produce. Second, the cost of deployment is greater as the additional weight of the shield makes it more difficult to deploy. Additionally, the electrical grounding of the shield requires more time and effort.

Applications

The additional cost of shielded copper limits its application to inside wire applications. Specifically, it generally is limited to application in high-noise environments. It also is deployed where high frequency signals are transmitted and there is concern about either distance performance or interference with adjacent pairs. Examples include LANs and image transmission.

Coaxial Cable

Coaxial cable (Figure 3.3) is a very robust shielded copper wire. The center conductor (much thicker than a twisted pair conductor) is surrounded by an outer shield/conductor which serves to greatly improve signal strength and integrity. The two conductors generally are separated by a layer of foam or solid insulation; the entire cable is then protected by a layer of dielectric (nonconductive) material, such as PVC or Teflon. The two conductors share a common axis, hence the term coaxial. Reportedly invented by AT&T Bell Telephone Laboratories in 1934, the first coaxial cable was placed into service in New York City in 1936. Such a cable was used in 1940 to televise in New York City the Republican National Convention in Philadelphia at which Wendell Wilke was nominated [3-6].

Figure 3.3 Coaxial cable configuration.


Communications Systems and Networks:Fundamentals of Transmission Systems: Technologies and Applications

Configuration

Coax cables traditionally consist of a single, two-conductor wire, with a center conductor and an outer shield/conductor, which is of solid metal. Sometimes braided or stranded metal is used. Twinaxial cables contain two such configurations within a single cable sheath. As the center conductor carries the carrier signal and the outer conductor generally is used for electrical grounding and is maintained at 0 volts, coax is described as an unbalanced medium. Coax connectivity can be extended through the use of twisted pair, with a BALUN (BALanced/UNbalanced) connector serving to accomplish the interface.

Gauge

The gauge of coax is thicker than twisted pair. While this increases the available bandwidth and increases the distance of transmission (less resistance), it also increases the cost. Traditional coax is quite thick, heavy and bulky of which Ethernet LAN coax (10Base5) is an example. ThinNet, or CheaperNet, (10Base2) coax is of much lesser dimensions, but offers less in terms of performance.

Bandwidth

The effective capacity of coaxial cable depends on several factors, including the gauge of the center conductor, the length of the circuit, and the spacing of amplifiers and other intermediate devices. The available bandwidth over coax is very significant, hence its use in high capacity applications, such as data and image transmission. As examples, the following are coax standards for Ethernet LANs, with 10Base5 involving more substantial cable, with a thicker center conductor than is the case with 10Base2:

• 10Base5 10 Mbps; Baseband (single channel); [le]500m
• 10Base2 10 Mbps; Baseband (single channel); [le]200m ([le]180 m, rounded up)

As in the case of UTP, 100 Mbps is possible over coax, and over longer distances with better error performance. In CATV and other applications, coax routinely supports transmission of multiple channels at an aggregate rate of 500 MHz.

Error Performance

Coax performs exceptionally well, due to the outer shielding. As a result, it is often used in data applications.

Distance

Coax is not so limited as UTP, although amplifiers or other intermediate devices must be used to extend high frequency transmissions over distances of any significance.

Security

Coax is inherently quite secure. It is relatively difficult to place physical taps on coax. Additionally, little energy is radiated.

Cost

The acquisition, deployment, and rearrangement costs of coax are very high, compared with UTP. In high capacity data applications, however, that cost is often outweighed by its positive performance characteristics.

Applications

Historically, coax was often used in telephone company interoffice trunking applications, as a superior option to twisted pair cables. However, that is no longer the case as satellite, microwave, and fiber optic cable are the media of contemporary choice in such applications. Yet, coax’s superior performance characteristics make it the favored medium in many short haul, bandwidth-intensive data applications. Current and continuing applications include LAN backbone, host-to-host, cabinet-to-cabinet (PBX & computer), host-to-peripheral (e.g., host-to-Front End Processor), and CATV.

Microwave Radio

Ah, here’s the problem—the keyboard and hard drive are fine. The trouble seems to be that your monitor is a microwave.

From the comic strip Bizarro by Dan Piraro

Microwave radio, a form of radio transmission which uses ultra-high frequencies, developed out of experiments with radar (radio detecting and ranging) during the period preceding World War II. The first primitive systems, used in military applications in the European and Pacific theaters, could handle up to 2,400 voice conversations over 5 channels. Developed by Harold T. Friis and his associates at Bell Laboratories, the first public demonstration was conducted between the West Street lab and Neshanic, New Jersey in October 1945 [3-6].

There are several frequency ranges assigned to microwave systems, all of which are in the GigaHertz (GHz) range; in other words, billions of cycles per second. The wavelength is in the millimeter range; that is to say that each cycle or wave is in the range of a millimeter, with billions of such cycles generated during a second of transmission. This very short wavelength gives rise to the term microwave. Such high frequency signals are especially susceptible to attenuation and, therefore must be amplified (analog) or repeated (digital) frequently. Therefore, if the transmit and receive microwave radio antennae are separated by a considerable distance, there must be intermediate antennae at periodic intervals in order to boost the signal.

In order to maximize the strength of such a high frequency signal and, therefore, to increase the distance of transmission at acceptable levels, the radio beams are highly focused. The transmit antenna is centered in a concave, reflective metal dish which serves to focus the radio beam with maximum effect on the receiving antenna, as illustrated in Figure 3.4. The receiving antenna, similarly, is centered in a concave metal dish, which serves to collect the maximum amount of incoming signal.

Figure 3.4 Point-to-point microwave.

The requirement to so tightly focus the signal clearly limits the application of microwave. It is a point-to-point, rather than a broadcast, transmission system. Additionally, each antenna must be within line of sight of the next antenna, as such high frequency radio waves will not pass through solid objects of any significance (buildings, mountains, or airplanes). Given the curvature of the earth, and the obvious problems of transmitting through it, microwave hops generally are limited to 50 miles (80 km.).


Communications Systems and Networks:Fundamentals of Transmission Systems: Technologies and Applications

While all the various microwave frequency bands suffer from these limitations, the higher frequencies suffer to a greater extent. Those higher frequencies, set aside for digital microwave in the United States, suffer more from environmental interference including dust, smog, agricultural haze, and precipitation. Table 3.3 lists examples of frequency bands set aside by the Federal Communications Commission for commercial microwave [3-9].

Table 3.3 Microwave frequency bands (U.S.)
U.S. Frequency Bands | Maximum Antenna Separation | Analog/Digital
4–6 GHz | 20–30 miles (32–48 km.) | Analog
10–12 GHz | 10–15 miles (16–24 km.) | Digital
18–23 GHz | 5–7 miles (8–11 km.) | Digital

The several frequency bands set aside for microwave are protected by regulatory authority in most countries and regions. Additionally, the placement of the antennae and the power level of transmission is regulated, with licenses granted to individual carriers and end users. However, difficulties have developed over time in certain areas (e.g., Europe and Asia) due to factors that include the small size of the individual nations; conflicting regulations, or the lack thereof; conflicting commercial and military applications; and unwillingness of national regulators to govern the use of radio frequencies on a coordinated, regional basis.

Configuration

Microwave radio consists of antennae centered within reflective dishes, that are attached to structures such as towers or buildings. Cables connect the antennae to the actual transmit/receive equipment.

Bandwidth

Microwave offers substantial bandwidth, often in excess of 6 Gbps. T1 (1.544 Mbps) capacity is routine, even in end user applications, with many private microwave networks operating at T3 (45 Mbps) rates.

Error Performance

Microwave, especially digital microwave, performs well in this regard, assuming proper design. However, such high frequency radio is particularly susceptible to environmental interference (e.g., precipitation, haze, smog, and smoke). Generally speaking, however, microwave performs well in this regard.

Distance

Microwave clearly is distance-limited, especially at the higher frequencies (see Table 3.2). This limitation can be mitigated through special and more complex arrays of antennae incorporating spatial diversity in order to collect more signal.

Security

As is the case with all radio systems, microwave is inherently not secure. Security must be imposed through encryption (scrambling) of the signal.

Cost

The acquisition, deployment and rearrangement costs of microwave can be high. However, it often compares very favorably with cabled systems, which require right-of-way, trenching, conduit, splicing, etc. Additionally, microwave is not affected by backhoe fade, as are cabled systems.

Regulation

Microwave, generally speaking, must be licensed on a case-by-case basis in order to avoid interference between adjacent systems; this process can be lengthy and costly. Additionally, local zoning ordinances and health and safety regulations may affect the placement of antennae.

Applications

Microwave originally was used for long haul voice and data communications. Competing long distance carriers, first in the United States, found microwave a most attractive alternative to cabled systems, due to the speed and low cost of deployment; where feasible, however, fiber optic technology is currently used in this regard. Contemporary applications include private networks, carrier bypass, temporary disaster recovery, interconnection of cellular radio switches, and as an alternative to cabled systems in consideration of difficult terrain.

Satellite Radio

Satellite radio, quite simply, is a nonterrestrial microwave transmission system utilizing a space relay station. The concept initially was offered in a letter published in Wireless World in February 1945 by Arthur C. Clarke, then a physicist at the British Interplanetary Society and since the author of 2001: A Space Odyssey and many other science fiction books. Since the launch of the Earlybird I satellite in 1965 proved the effectiveness of the concept of satellite communications, satellites have proved invaluable in extending the reach of voice, data, and video communications around the globe and into the most remote regions of the world. Exotic applications such as the Global Positioning System (GPS) would have been unthinkable without the benefit of satellites [3-10].

Geostationary Satellites

Contemporary satellite communications systems involve a satellite relay station which is launched into a geostationary, geosynchronous, or geostatic orbit, also known as a Clarke orbit. Such an orbit is approximately 22,237 miles (36,000 km.) above the equator (Figure 3.5). At that altitude and in an equatorial orbital slot, the satellite maintains its synchronization with the revolution of the earth. In other words, it maintains its relative position over the same spot of the earth’s surface. Consequently, transmit and receive earth stations (microwave dishes) can be pointed reliably at the satellite for communications purposes. Geosynchronous Earth Orbiting (GEO) satellites are also known as Fixed Satellite Systems (FSS).

Figure 3.5 Satellites in geostationary earth orbit.

The popularity of satellite communications has placed great demands on the international regulators (e.g., Intelsat) to manage and allocate available frequencies, as well as the limited number of orbital slots available for satellite positioning. As in the case of terrestrial microwave radio, there are a number of frequency bands assigned to satellite systems, most of which are in the MegaHertz (MHz) or GigaHertz (GHz) ranges. Due to the wide footprint, or area of coverage of a satellite, the frequencies must be carefully managed at national, regional and international levels. Generally speaking, geostationary satellites are positioned approximately 2º apart in order to minimize interference from adjacent satellites using overlapping frequencies [3-10].


Communications Systems and Networks:Fundamentals of Transmission Systems: Technologies and Applications

Although such high frequency signals are especially susceptible to attenuation in the atmosphere, they can propagate (travel) infinite distances in the vacuum of space with no signal loss. Attenuation can, however, be problematic within the few miles of atmosphere on the uplink and downlink segments. The uplink and downlink generally utilize different frequencies for transmission, so as to avoid interference between incoming and outgoing signals. As suggested in Table 3.5, the higher of the two frequencies is used for the uplink, as that signal is stronger and can better deal with atmospheric distortion. The lower frequency, used for the downlink, can better penetrate the earth’s atmosphere and electromagnetic field, which can act to bend the incoming signal much as light bends when entering a pool of water. Table 3.4 provides a set of example frequencies and spacecraft serving various applications, with LEO referring to Low-Earth Orbiting satellites.

Table 3.4 Sample satellite communication frequencies.
Frequency Range | Band Designation | Example Spacecraft
136–137 & 148 MHz | VHF | NOAA (LEO Weather)
400 MHz | UHF | Orbcomm
1610–1625.5 MHz |  |
2483.5–2500 MHz | L–band | Big LEOs
2310–2360 MHz | S–band | Civil Defense Radio
3700–4200 MHz |  |
5925–6425 MHz | C–band | Galaxy, Satcom, Telstar, Intelsat, etc.
4 GHz–6 GHz | C–band | Intelsat, Comsat, etc.
11.7–12.2 GHz |  |
14.0–14.5 GHz | Ku–band | Globalstar, etc.
20 GHz & 30 GHz | Ka–band | ACTS
Source: International Telecommunications Union (ITU); Comsat

Uplink

In order to maximize the strength of such a high frequency signal, as well as to direct the uplink transmission to a specific satellite, the uplink radio beams are highly focused. The transmit antenna is centered in a concave, reflective dish which serves to focus the radio beam, with maximum effect, on the receiving satellite antenna. The receiving antenna, similarly, is centered in a concave metal dish, which serves to collect the maximum amount of incoming signal. Table 3.5 provides example uplink and downlink frequencies, with mention of standard applications.

Table 3.5 Example uplink/downlink satellite frequencies.
Frequency Band | Uplink/Downlink Frequency Range | Example Application
C–band | 6 GHz/4 GHz | TV, Voice, Videoconferencing
Ku–band | 14 GHz/11 GHz | TV, DBS/DSS
Ka–band | 30 GHz/20 GHz | Mobile Voice

Downlink

Similarly, the downlink transmission is focused on a particular footprint, or area of coverage. Although a satellite can see roughly one-third of the earth’s surface from its vantage point, the signal would weaken so as to be unusable at the fringes of such a footprint, were the signal not tightly focused. Spot beams, even more tightly focused downlinks, serve specific applications over smaller regions.

Broadcast

The wide footprint of a satellite radio system allows a signal to be broadcast over a wide area. Thereby any number (theoretically an infinite number) of terrestrial antennae can receive the signal, more or less simultaneously. In this manner, satellites can serve a point-to-multipoint network requirement through a single uplink station and multiple downlink stations.

Recently, satellites have been developed which can serve a mesh network requirement, whereby each terrestrial site can communicate directly with any other site. Previously, all such communications were required to travel through a centralized site, known as a head end. Such a mesh network, of course, imposes an additional level of difficulty on the network in terms of management of the flow and direction of traffic.

Configuration

Satellite radio systems consist of antennae and reflective dishes, much as does terrestrial microwave. The dish serves to focus the signal from a transmitting antenna to a receiving antenna. The send/receive dishes which make up the earth segment are of varying sizes, depending on power levels and frequency bands. They generally are mounted on a tripod or other type of brace, which is anchored to the earth, pad or roof, or attached to a structure such as building. Cables connect the antennae to the actual transmit/receive equipment. The terrestrial antennae support a single frequency band (e.g., C–band, Ku–band or Ka–band). A hybrid satellite may support a number of bands for various applications, such as radio, TV, paging, voice, and data. The higher the frequency band, the smaller the possible size of the dish, as the higher frequency dishes can be designed for greater signal gain at a smaller size. Therefore, while C–band TV dishes tend to be rather large, Ku–band DBS (Direct Broadcast Satellite) TV dishes tend to be very small. Additionally, flat, passive, phased array dishes are being built in very small sizes and at very low cost for DBS TV and other applications. As a point of reference, the Intelsat I (1968) dishes were 30 meters in diameter.

The space segment dishes are mounted on a satellite, of course. The satellite can support multiple transmit/receive dishes, depending on the various frequencies which it employs to support various applications, and depending on whether it covers an entire footprint or divides the footprint into smaller areas of coverage through the use of more tightly focused spot beams. Satellite repeaters are in the form of transponders. The transponders accept the weak incoming signals, boost them, shift from the uplink to the downlink frequencies, and transmit the information to the earth stations. Contemporary satellites, such as Intelsat VI, commonly support as many as 46 transponders.


Communications Systems and Networks:Fundamentals of Transmission Systems: Technologies and Applications

VSATs

VSATs, or Very Small Aperture Terminals, are a breed of satellite system involving terrestrial dishes of very small diameter (aperture). Operating in the C–band and Ku–band, VSATs are digital and are designed primarily to support data communications on a point-to-multipoint basis for large private networks in applications such as retail inventory management and credit verification, and authorization. While some newer systems also support mesh networks and voice communications, they are unusual at this time. Bandwidth is in channel increments of 56/64 Kbps, generally up to an aggregate bandwidth of 1.544 Mbps. By far the largest concentration of users is in North America, claiming 68% of the market. According to Chuck Emmert of Telecom Applications Corp., Mobil Oil has an installed network of 5,000 sites and Shell Oil has a network of 3,000 sites [3-11].

Bandwidth

Satellites can support multiple transponders and, therefore, substantial bandwidth, with each transponder generally providing increments of [le]36 MHz. Each increment of bandwidth within a given frequency band is provided through a transponder. The amount of bandwidth, the number of frequency bands supported, the number of transponders, and the specific area of coverage all influence the size and power requirements of the satellite.

As in the case of other transmission systems, the higher frequency bands offer greater bandwidth, or capacity. C–band is the most limited, while Ka-band is the most attractive, in this sense, of the commercial satellite frequency bands. As a point of reference, Intelsat I could accommodate only 240 voice circuits, while Intelsat VI supported 120,000 voice circuits and 3 TV channels, with a total bandwidth of 3.46 GHz [3-12].

Error Performance

Satellite transmission is susceptible to environmental interference, particularly at frequencies above 20 GHz. Sunspots and other types of electromagnetic interference particularly impact satellite and microwave transmission. Additionally, some satellite frequency bands (e.g., C–band) compete with terrestrial microwave (see Tables 3.2 and 3.4), again illustrating the requirement for careful frequency management. As a result of these several factors, satellite transmission often requires rather extensive error detection and correction capabilities [3-13].

Distance

Satellite, generally speaking, is not considered to be distance-limited, as the signal largely travels through the vacuum of space. Further each signal travels approximately 22,300 miles in each direction, whether one is communicating across the street or across the country, and assuming that only a single satellite hop is required. However, additional power is required to serve areas which are far removed from the equator (e.g., New Zealand and South Africa), as the signals must travel through substantial atmosphere and as they are more likely to be reflected by the earth’s magnetic field at such a severe angle.

Propagation Delay and Response Time

GEOs, by virtue of their high orbital altitude, impose rather significant propagation delay on the signal and, therefore, doubly affect response time (see Figure 3.8). Given the fact that the radio signals must travel approximately 22,300 miles up to the satellite and the same distance on the return leg, the resulting delay is about 270 milliseconds (.27 seconds). Considering the amount of time required for processing on board the satellite, as well as at the earth stations, the total delay for a one-way transmission is about 320 milliseconds. Therefore, the delay between signal origination (transmission) and response is about 640 milliseconds (.64 seconds), assuming that the response is immediate and that only a single satellite hop is required. Hence, highly interactive voice, data, and video applications are not effectively supported via two-way satellite communications.

Security

As is the case with all microwave and other radio systems, satellite transmission is inherently not secure. Satellite transmission is especially vulnerable to interception, as the signal is broadcast over the entire area of the footprint. Therefore, the unauthorized user must know only the satellite and associated frequency range being employed. Security must be imposed through encryption (scrambling) of the signal.

Cost

The acquisition, deployment, and rearrangement costs of the space segment of satellite systems can be quite high (approximately US$200 million). However, the satellite can be shared by a large number of users, with each user perhaps connecting a large number of sites. As a result, satellite networks often compare very favorably with cabled systems or microwave systems for many point-to-multipoint applications. Cost elements include leasing capacity from a satellite provider (e.g., GE Americom, Hughes Communications Inc., and AT&T Skynet), as well as the acquisition cost of the terrestrial antennae. It should be noted that the acquisition cost of receive-only dishes is relatively low, while transmit/receive dishes are considerably more expensive. As is the case with microwave, satellite transmission is not affected by backhoe fade, as are cabled systems.

Regulation

The space segment of satellite communications is more or less carefully regulated by national, regional, and international bodies. Additionally, local zoning ordinances and health and safety regulations may affect the placement of terrestrial antennae. While satellite network technology is widely available in North America and other countries, it is not widely available to end users, worldwide. Many countries in Asia and Europe have not adopted open sky policies, in support of the incumbent carriers, commonly known as PTTs (Post, Telegraph and Telephone agencies) or TOs (Telecommunications Organizations).

Applications

Satellite applications are many, and increasing rapidly as the traditional voice and data services have been augmented with more exotic applications such as GPS and ATMS. Traditional international voice and data services have been supplanted, to a considerable extent, by submarine fiber optic cable systems.

Traditional, and still viable, applications include international voice and data, remote voice and data (e.g., island nations, isolated areas and sparsely populated areas), television and radio broadcast, maritime navigation, videoconferencing, inventory management & control (VSATs), disaster recovery and paging. More recent and emerging applications include air navigation, Global Positioning Systems (GPS), mobile voice & data (LEOs), Advanced Traffic Management Systems (ATMS), Direct Broadcast Satellite (DBS) TV, Integrated Digital Services Network (ISDN), interactive Television, and interactive multimedia.


Communications Systems and Networks:Fundamentals of Transmission Systems: Technologies and Applications

Infrared

Infrared light transmissions have existed for many years in something of a backwater in the world of transmission systems, their use having been limited to TV remote controls and wireless slide projector remote controls. However, they now are assuming a position of some, if still limited, importance. Infrared systems use the infrared light spectrum (TeraHertz, or THz, range) to send a focused light beam to a receiver, much as would a microwave system, although no reflective dish is used. Rather, a pair of lenses are used, with a focused lens employed in the transmitting device and a collective lens in the receiving device (Figure 3.6). Infrared is an airwave, rather that a conducted transmission system. Although generally used in short-haul transmission, they do offer substantial bandwidth, but with risks of interference.

Figure 3.6 Infrared transmission system.

Advantages include rapid deployment, especially as there are no licensing requirements as typically is the case with microwave. Additionally, infrared offers fairly substantial bandwidth of [le]6.312 Mbps ([le]T2, or T1 × 4) at relatively low cost. However, infrared systems require line-of-sight and suffer from environmental interference, as do microwave systems; error performance is in the range of 10-8 [3-14]. Additionally, infrared is distance limited, typically [le]2 miles. However, infrared often is an attractive alternative to leased lines or private cabled systems for building-to-building connectivity in a campus environment. Infrared transmission also is used in certain wireless LAN systems and is incorporated into some PDAs (Personal Digital Assistants).

Fiber Optics

The concept of using light waves for communications originally was trialed by Alexander Graham Bell, who in the late 1800s invented and experimented with the photophone, a system utilizing sunlight and mirrors for audio transmission. While his experiment was successful in transmitting very poor quality voice over very short distances, the technique was clearly impractical. During World War II, the Nazi military experimented with similar but more advanced systems, which also proved impractical [3-6].

During the 1940s, experiments with waveguides first were conducted, with both microwave radio and light. Waveguides are rigid, insulated pipes, which serve to contain the electromagnetic energy and channel it from end-to-end, while offering protection from outside interference. While significant transmission speeds can be realized through this process, it is generally impractical and, therefore, is seldom used.

Flexible glass wires offered much more potential as a transmission medium for light. The efforts of the American Optical Corporation resulted as early as the 1950s in optical fiber cable which could carry light signals a few feet. It was at Standard Telecommunications Laboratories in 1966 that Charles Kao and George Hockman developed the first practical conceptual breakthrough—the purity of the glass was the issue. During the early 1970s, the first practical fiber optic systems were developed. These systems were made possible by the manufacturing of pure glass fibers with a silica content high enough (few impurities) to permit the transmission of light over long distances with little loss. At roughly the same time, AT&T Bell Laboratories invented laser diodes, which serve as high speed transmit devices. Since that time, fiber optic development has progressed to the point that virtually all high speed networks are based on fiber optic technology. According to Corning Telecommunications Products [3.15], a major producer of fiber optic cables, demand was estimated at 14.5 million miles in 1995, an increase of 20% to 25% over the previous year.

Fiber optic transmission systems are opto-electric in nature. In other words, a combination of optical and electrical electromagnetic energy is involved. The signal originates as an electrical signal, which is translated into an optical signal, which subsequently is reconverted into an electrical signal at the receiving end.

Configuration

Fiber optic systems consist of light sources, cables and light detectors, as depicted in Figure 3.7. In a simple configuration, one of each is used. In a more complex configuration over longer distances, many such sets of elements are employed. Much as is the case in other transmission systems, long haul optical communications involves a number of regenerative repeaters. In a fiber optic system, repeaters are optoelectric devices. On the incoming side of the repeater, a light detector receives the optical signal, converts it into an electrical signal, boosts it, converts it into an optical signal, and places it onto a fiber, and so on. There may be many such optical repeaters in a long haul transmission system, although typically far fewer than would be required using other transmission media.

Figure 3.7 Fiber optic system, consisting of a light source, a glass fiber, and a light detector.

Light Sources

These are of two types, Light Emitting Diodes (LEDs) and Diode Lasers or (Semiconductor Lasers).

Light Emitting Diodes (LEDs) are common household semiconductor components, which are found in clocks, calculators, and a plethora of other devices. The LEDs used in fiber optic transmission are, of course, much more sophisticated. LEDs predominated in early fiber optic systems largely because of their much lower costs of acquisition and operation. However, they provide less bandwidth and generate infrared light waves that are capable of traveling only relatively short distances with acceptable error performance. LEDs have found continuing application in short haul transmission systems.

Diode Lasers are similar in structure to LEDs, although they are much more difficult and expensive to manufacture. They also are associated with more expensive and complex supporting electronics. They require cooling and consume more power than do LEDs. However, they offer much more bandwidth, as they can pulse on and off in a fraction of a nanosecond, one billionth of a second. Further, contemporary diode lasers create light frequencies which attenuate much less; hence, the signal can travel much farther without being repeated.


Communications Systems and Networks:Fundamentals of Transmission Systems: Technologies and Applications

Fiber-Optic Cables

While plastic wires are used in some specialized, low bandwidth, short haul applications (e.g., automobiles and airplanes), glass predominates. Generally speaking, fiber cables contain a large number of pairs of glass fibers, as the additional cost of redundancy is relatively low. Oftentimes, only a few of the fibers are active, with others being left dark for backup or future use. While current technology, although more expensive, allows two-way transmission over a single fiber, two fibers generally are used, with one transmitting in each direction.

The mass production of glass fiber employs several techniques, all of which take place in a vacuum environment. First, silica is heated to the point that it vaporizes. The ultra-pure glass vapor is then deposited on a designated surface to create a glass cylinder. That cylinder is then reheated and collapsed into a preform cylinder. The preform cylinder is reheated and drawn, in a process known as broomsticking, into fibers which can be as long as 10 km in length.

The light pulse travels down the center core of the glass fiber, which is especially pure. Surrounding the inner core is a layer of glass cladding, with a slightly different refractive index. The cladding serves to reflect the light waves back into the inner core. Surrounding the cladding is a layer of protective coating, such as Kevlar, which seals the cable and provides mechanical protection (Figure 3.8). Typically, multiple fibers are housed in a single sheath, which may be heavily armored. Glass optical fibers are of two basic types, multimode and monomode (or singlemode).

Figure 3.8 Glass fiber optic cable, side view, and cross section.

Multimode fiber is less expensive to produce, but performs less well, as the inner core is larger in diameter. As the light rays travel down the fiber, they spread out due to a phenomenon known as modal dispersion. Although reflected back into the inner core by the cladding, they travel different distances and, therefore, arrive at different times. As the distance of the circuit increases and the speed of transmission increases, the pulses of light tend to overrun each other in a phenomenon know as pulse dispersion. At that point, the light detector is unable to distinguish between the individual pulses. As a result, multimode fiber is relegated to applications involving relatively short distances and lower speeds of transmission (e.g., LANs and campus environments).

Monomode fiber has a thinner inner core; therefore, it performs better than does multimode fiber over longer distances at higher transmission rates. Although more costly, monomode fiber is used to advantage in long-haul, and especially in high bandwidth, applications [3-14].

Light Detectors

These are of several basic types, with the most common being PhotoINtrinsic diodes (PINs) and Avalanche PhotoDiodes (APDs). The light detectors serve to reverse the process accomplished by the light sources, converting optical energy back into electrical energy. APDs, although more expensive, are preferable, as they use a strong electric field to accelerate the electrons flowing in the semiconductor. This results in an avalanche of electrons. Therefore, a very weak incoming light pulse will create a much stronger electrical effect. Although more sensitive, APDs require more power and are more sensitive to ambient temperatures.

Analog or Digital?

Fiber optic systems can be either analog or digital in nature, although digital is much more common. Analog systems simply vary the intensity of the lightwave. Digital systems pulse on and off to represent 1s and 0s; differences in the length of the pulses can represent multiple 1s and 0s. As digital systems offer significant advantages, all long haul fiber systems used in carrier networks are digital. While significant amounts of analog fiber are being deployed by CATV providers for purposes of cable TV delivery, those systems are intended to be upgraded to digital technology when practical.

Bandwidth

Fiber offers by far the greatest bandwidth of any transmission system, often in excess of 2 Gbps in long haul carrier networks. Systems of 10 Gbps and 20 Gbps have been deployed, and 40 Gbps and 50 Gbps systems have been tested successfully on numerous occasions in laboratory environments. AT&T Bell Laboratories recently successfully tested 40 Gbps, error-free transmission at distances of 900 miles. The theoretical capacity of fiber is in the Terabit (Tbps) range, with current monomode fiber capacity being expandable to that level with the application of subsequent generations of electronics.

Error Performance

As fiber is dielectric (a nonconductor of direct electric current), it is not susceptible to EMI/RFI; neither does it emit EMI/RFI; The light signal will suffer from attenuation, although less so than other media. Such optical attenuation can be caused by scattering of the optical signal, bending in the fiber cable, translation of light energy to heat, and splices in the cable system. Error performance, depending on the compression scheme utilized, ranges between 10-9 and 10-14, one errored bit in every 100 trillion [3-16].

Distance

Monomode fiber optic systems routinely are capable of transmitting unrepeatered signals over distances in excess of 200 miles (322 km.). As a result, relatively few optical repeaters are required in a long-haul system, thereby reducing costs, and eliminating points of potential failure or performance degradation. In fact, tests have indicated that unrepeatered signals can travel distances of up to 8,000 miles (12,900 km.) Such systems employ a process of chemical amplification, achieved by chemically doping a section of the cable with erbium, a metallic rare earth element. When the laser pulse strikes that section of the cable, the chemical is excited and, in turn, amplifies the light pulse.


Communications Systems and Networks:Fundamentals of Transmission Systems: Technologies and Applications

Security

Fiber is intrinsically secure, as it is virtually impossible to place a physical tap without detection. As no light is radiated outside the cable, physical taps are the only means of signal interception. Additionally, the fiber system supports such a high volume of traffic that it is difficult to intercept and distinguish a single transmission from the tens of thousands of other transmissions that might ride the same cable system. The digital nature of most fiber, coupled with encryption techniques frequently used to protect transmission from interception, make fiber highly secure. In fact, a number of U.S. government agencies recently have lobbied Congress and the FCC to require that the carriers place physical taps on existing fiber optic systems in order to ease their ability to place wiretaps, assuming that an enabling court order is issued.

Cost

While the acquisition, deployment, and rearrangement costs of fiber are relatively high ([ge]130% of Cat 5 copper), the immense bandwidth can outweigh that cost in bandwidth-intensive applications. At Gbps speeds, a single set of fibers can carry huge volumes of digital transmissions over longer distances than alternative systems, thereby lowering the transport cost per bit and cost per conversation to fractions of a penny per minute.

Durability

While fiber certainly does not have the break strength of copper or coax, it does have the same tensile strength as steel of the same diameter. When covered by a protective jacket or armored, fiber can be treated fairly roughly without damage. Additionally, fiber is more resistant to temperature extremes and corrosion. However, and in consideration of the huge number of conversations supported over a typical fiber optic cable, a train derailment, earthquake or other traumatic event can have consequences of disruptive, and even catastrophic, proportions.

Applications: Bandwidth-Intensive

As one would expect, cost-effective applications for fiber optic transmission systems are those which are bandwidth-intensive. Such applications include backbone carrier networks, international submarine cables, backbone LANs (FDDI), interoffice trunking, computer-to-computer or cabinet-to-cabinet (e.g., mainframes and PBXs) distribution networks (e.g., CATV and Information Superhighway), and fiber to the desktop (e.g., CAD or Computer Aided Design).

Hybrid Transmission Systems

While each transmission medium/system has its own unique properties and applications, it is clear that digital fiber optic cable offers the most potential. As it also is costly and fragile, it, however, is not always the ideal approach. In fact, the most appropriate transmission medium depends of issues mentioned at the beginning of this chapter. Namely, those considerations include bandwidth, error performance, throughput, distance between elements, propagation delay, security, mechanical strength, physical dimensions, and a number of cost factors. In fact, a given long-haul conversation typically will traverse a number of transmission systems, perhaps both wired and wireless, and typically including twisted pair and fiber optics, at a minimum.

The true concept of a hybrid transmission system, however, generally involves a local loop connection deployed in a well-planned convergence scenario. Such a scenario involves a single provider, or multiple providers, developing a communications grid designed to deliver voice, data and entertainment information to the premise. Hybrid systems (Figure 3.9) usually are described as involving Fiber-to-the-Neighborhood (FTTN), Fiber-to-the-Curb (FTTC), or Fiber-to-the-Home (FTTH). Although conventional wisdom suggests that cost considerations will dictate that the last link of such a hybrid network involve either coaxial cable or twisted copper pair, various wireless technologies are currently challenging that concept.

Figure 3.9 Hybrid network: The convergence scenario.

While many of the traditional telephone carriers and CATV providers have made dramatic announcements about their plans to install fiber optic cable to the curb or even to the premise, their ardor has cooled as the economics of such an approach have become apparent. It is likely that fiber will be deployed to the neighborhood, with coaxial cable deployed to the premise. Additionally, it is likely that the telcos will extend the life of the embedded twisted pair cable as long as possible, through the use of new local loop technologies such as Asymmetric Digital Subscriber Loop (ADSL). In the future, it is possible that Wireless Local Loop (WLL) technology will seriously challenge the traditional wired approach.

References

[3-1] Engineering and Operations in the Bell System, NJ: Bell Telephone Laboratories, Inc., 1977.
[3-2] Keen, Peter G.W. and Cummins, J. Michael. Networks in Action. Belmont CA: Wadsworth Publishing Company. 1994.
[3-3] Gelber, Stan. Introduction to Data Communications Practical Approach. Horsham, PA: Professional Press Books. 1991.
[3-4] Sherman, Kenneth. Data Communications A Users Guide. Reston Publishing Company. 1981.
[3-5] Chiquoine, Walter A. and Hist, Elizabeth R. The Connectivity Management Handbook. Wilmington, DE: Transport Management Group, Inc., 1995.
[3-6] Brooks, John. Telephone The First Hundred Years. NY: Harper & Row. 1975.
[3-7] LAN Cable. Melville, NY: Underwriters Laboratories Inc. 1995.
[3-8] Doll, Dixon R. Data Communications Facilities, Networks, and Systems Design. NY: John Wiley & Sons. 1978.
[3-9] Bates, Bud. Introduction to T1/T3 Networking. Norwood MA: Artech House. 1992.
[3-10] Hudson, Heather E. Communications Satellites Their Development and Impact. NY: The Free Press, A Division of Macmillan, Inc. 1990.
[3-11] Schuerholz, Katherine A. VSATs An International Phenomenon. Via Satellite. December 1995.
[3-12] Held, Gilbert. Understanding Data Communications. Indiannapolis, IN: SAMS Publishing. 1994.
[3-13] Paetsch, Michael. Mobile Communications in the US and Europe: Regulation, Technology, and Markets. Norwood, MA: Artech House. 1993.
[3-14] Gasman, Lawrence. Manager’s Guide to the New Telecommunications Network. Norwood, MA: Artech House. 1988.
[3-15] Jones, Del. Corning: Productivity Soars While Customer Returns Plummet. USA Today. October 17, 1995.
[3-16] Sexton, Mike and Reid, Andy. Transmission Networking SONET and the Digital Hierarchy. Norwood, MA: Artech House. 1992.


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

Chapter 4
Voice Communications Systems: PBX, ACD, Centrex, and KTS

If you could make one good invention in the telegraph, you would secure an annual income…and then you could settle that on your wife and teach Visible Speech and experiment in telegraphy with an easy and undisturbed conscience.

Excerpt from a letter dated March 13, 1876, to Alexander Graham Bell from Gardiner Hubbard, Bell’s future father-in-law.

In the beginning, there were only telephone sets and wires between them. The first commercial sets, offered by the Bell Telephone Company in May 1877, consisted of a single piece of wood (black walnut or mahogany) with a single piece of equipment serving as both transmitter and receiver. Power was supplied by a permanent magnet contained within the device, rather than by a battery or external power source. Each telephone set was connected to another set directly through a private line, which generally was leased from Western Union. The first advertisements offered the use of two telephones, and a line connecting them, for $20 per year for social purposes and $40 per year for business; free maintenance was guaranteed. By the fall of 1877, over 600 telephones were in use. As the popularity of the invention grew, visions developed of rooms full of telephones and skies full of wires [4-1].

In order to improve the usefulness of the telephone device and in order to reduce the associated costs, circuit switches were developed. The first practical exchange switch was developed by George W. Coy of New Haven, Connecticut and was placed into service on January 28, 1878. This manual exchange, or cordboard, allowed the flexible interconnection of 21 subscribers. The number of exchanges grew quickly, although most of the initial installations were Western Union, rather than Bell; the Bell System network grew quickly and soon outpaced the networks of Western Union and other providers [4-1].

These first exchanges, which were housed in central offices, allowed circuits to be manually connected, on demand and as available. Through these central points of interconnection, each subscriber required only one terminal device and one wired connection. Central Office Exchanges (COs or COEs) handled all switching of calls, even calls across the hall or between employees in the same office were connected in this manner. When such exchanges were automated, it remained clear that this approach was less than ideal for serving businesses of any significance and with any appreciable number of terminal devices because of the following factors:

• Labor Intensity Manual switchboards were very labor intensive because operators were responsible for making and breaking all connections. The early SxS exchanges also were maintenance intensive, as were the XBar offices and the early ECC exchanges, although to successively lesser degrees.
• Capital Intensity Central office exchanges are expensive. The more subscribers connected and the more functions performed by the exchange, the larger and more costly it becomes. Additionally, the cost of connecting each telephone terminal to the exchange was considerable, as each local loop connection required an individual pair, in a multipair cable, either placed in conduits and trenches or suspended on series of poles.
• Personalized Service Quite simply, personalized service was not available. The telephone company operator was not able to handle the call as courteously and effectively as would be an employee of the user organization. Additionally, the telephone company was much more likely to misdirect calls.

Clearly, a better approach would be to extend a partition of the Central Office Exchange to the customer. The equipment could be rented by the customer, yielding additional revenue to the telephone company. Additionally, the cost of labor, cost of switch capital, and responsibility for connection errors could be shifted to the customer. Further, the customer’s operators could provide more effective and personalized service to both inbound and outbound callers. The equipment could also act as a contention device, allowing multiple calls to share a single, pooled set of local loop connections. This approach would considerably reduce the cost of cabling and the number of ports required to connect the local loops to the switch. The shift to the customer of the responsibility for switching calls would also relieve the telephone company of that burden, allowing the telephone company’s exchange switch to serve even more customers. Finally, internal (telephone-to-telephone) calls can be connected through the customer’s equipment, without having to connect them through Telco’s Central Office.

The first devices to accomplish this feat were Private Branch Exchanges (PBXs) in 1879. Key Telephone Systems (KTSs) did not arrive on the scene until 1938. Centrex, a central office-based solution was christened in the 1960s. Automatic Call Distributors (ACDs) appeared only recently, in the 1970s. Rather than exploring these systems in chronological order, I will begin this discussion with KTS, as it is in many ways the least complex. I will then progress through PBX, Centrex, and ACD systems. This chapter will conclude with Computer Telephony Integration (CTI), a concept that only very recently has translated into application software products which put system control in the hands of the user.


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

Originally, all Customer Premise Equipment (CPE) was owned by the telephone company and was rented to the end user. The CPE included every device that was connected to the network, including single-line telephones, KTS and PBX systems, and all telephone sets connected behind them. As answering machines and other peripheral devices appeared, they too were rented to the user by the telephone company. In concert, the regulators and telephone companies maintained that any privately-owned equipment could conceivably cause damage to the network switches and even to telephone company personnel by introducing uncontrolled levels of electrical current. Further, such devices might well be incompatible with the highly standardized network and, therefore, might cause uncontrollable disruption. Interestingly, even acoustically-coupled devices were banned, unless provided by Telco. After a series of lengthy legal battles (Chapter 16), the Federal Communications Commission (FCC) reversed that policy through the 1968 Carterphone decision. That decision allowed user ownership through a special interconnecting device, or coupler, which allowed interconnection but protected the network from damage. Currently, virtually all such equipment is customer-owned; in fact and with rare exception, the U.S. telephone companies are barred from owning such equipment. The rest of the world more recently has followed this lead, although there always are exceptions.

Key Telephone Systems (KTSs)

Key Telephone Systems (KTSs) are business communications systems intended for small businesses. Key telephone dates to the beginnings of telegraphy and telephony when mechanical keys were employed to open and close a circuit. The buttons on a key telephone set, used to mechanically open and close the line circuit, were also referred to as keys. While contemporary KTSs provide the same features as small PBXs, and while they also act as contention devices for network access, KTSs are not switches. They do not possess the intelligence to accept a call request from a user station, switch it through common equipment, and determine over which pooled circuit to connect it to the outside world. Rather, the end user must make the determination and select the appropriate facility (e.g., local circuit, WATS circuit or FX circuit) from a group of pooled facilities.

1A1 and 1A2 KTSs

As was the case with early PBXs, KTSs originally were electromechanical in nature. The common control unit, known as a Key Service Unit (KSU), and the key sets were hardwired. Early KTS feature content was limited to hold, intercom (highly limited), speaker phones (separate unit), and auto dialers (mechanical card dialers).

The first standard key system, known as the 1A, was a hardwired system developed by the Bell System and first marketed in 1938. The 1A1 KTS systems, first introduced in 1953, were truly hardwired as well, with components wired together to form a complete system. 1A1 systems added a few features, including line status lamps which lit steadily to indicate a line in use and flashed to indicate a line on hold. 1A2 systems, introduced in 1963, were modular to some extent, as hardwired circuit packs plugged into a pre-built chassis that included cable connectors for attaching station equipment [4-2]. Additionally, a limited number of enhanced features could be added through the addition of common control cards in the form of circuit packs. In either case, wiring between the KSU and the sets required labor-intensive home runs of expensive 25-pair or 50-pair cables between each device and the KSU.

Electronic KTS

Electronic KTSs entered the market in the 1970s, offering many of the same advantages of Electronic Common Control (ECC) as did contemporary PBXs, although they remained intended for a small business environment. Currently, few such systems are manufactured, having been replaced by Hybrid KTSs.

Hybrid Key Systems

Hybrid Key Systems have the unique ability to function as a Key System (direct circuit selection) or as a PBX (switched access to pooled facilities). Additionally, they can function as both, simultaneously, for separate work groups. Just as is the case with contemporary PBXs, Hybrids are digital systems comprising microprocessors, printed circuit boards, memory, software, and so on (see Figure 4.1). They can be upgraded and expanded, within finite limits. Cabling is reduced to that required of PBXs, i.e., 1-4 pair. Hybrid port capacities generally are limited to 256 ports, most of which can be configured as either station ports or trunk ports.

Figure 4.1 Hybrid key system configuration.

Electronic KTSs and Hybrids offer a relatively significant set of features—virtually everything a small business might require. Features include nonblocking switching matrix, call transfer, voice-over paging, authorization codes, ACD, SMDR, voice mail, call park, T/E-Carrier Interface, wireless sets, and display sets. As these features traditionally have been restricted to PBX systems, these will be discussed in some detail later in this chapter. Leading manufacturers include Lucent Technologies (nee AT&T), Nortel, Toshiba, Executone, Comdial and Inter-Tel [4-3].


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

Private Branch Exchanges (PBXs)

Clearly, a better approach would involve effectively moving a partition of the central office exchange to the customer premise, as portrayed in Figure 4.2. In this fashion, a Private Branch of the Exchange (PBX) would yield significant benefit to Telco and the user organization.

Figure 4.2 PBX vs. individual telephone set connections to a telephone company Central Office (CO) exchange.

The first PBX reportedly was placed into service in the Old Soldiers’ Home in Dayton, Ohio in 1879. While the first systems were little more than nonstandard modifications of telephone company central office switches, AT&T offered a standard PBX (No. 1 PBX) in 1902 [4-4]. PBXs evolved according to the same order as did other circuit switches, such as central office exchanges. As noted in Table 4.1, the following generally accepted designations evolved, as well.

Table 4.1 PBX Generations
Designation | Nature of Technology
Cordboard | Manual Switchboard
PBX | Electro-Mechanical
(Private Branch eXchange) | Step-by-Step (SxS)
PABX | Electro-Magnetic
(Private Automatic Branch eXchange | Crossbar (XBar)/Crossreed
EPABX | Electronic Common Control (ECC)
(Electronic Private Automatic | Analog/Digital
Branch eXchange) | Stored Program Control (SPC)

The terms PBX, PABX and EPABX often are used interchangeably. Contemporary PABXs generally can be characterized as being Electronic Common Control (ECC), Stored Program Control (SPC), and digital. Additionally, they accommodate data switching, as well as voice. PABXs vary from 10 stations to 10,000+ stations, or extensions, with the average being in the range of 200 stations. As noted in Table 4.2, U.S. market share leaders include Lucent Technologies (previously AT&T), Nortel, and Siemens Rolm [4-3]. The market continues to grow in terms of both lines shipped and revenues, with market leadership remaining fairly stable [4-5].

Table 4.2 1995 U.S. PBX market share (line shipments)
Vendor | Market Share (%)
AT&T (now Lucent) | 25.0
Nortel | 24.7
Siemens Rolm | 13.3
Mitel | 9.7
NEC | 8.5
Fujitsu | 6.0
Ericsson | 2.8
Intecom | 2.7
Hitachi | 2.5
Source: MultiMedia Telecommunications Association

PBX Components

Modern PBXs are specialized computer systems that include a circuit-switching matrix for the primary purpose of connecting voice calls, although many also handle a limited amount of data exceptionally well. PBXs serve large numbers of station sets, which may include fully-featured electronic terminals. They primarily serve voice terminals on a wired basis, although wireless appliqués often are available as an option. Otherwise, they are much like any other computer consisting of cabinets, shelves, printed circuit boards, power supplies. The primary physical and logical components (Figure 4.3) of a PBX include common control, switching matrix, trunk interfaces, line interfaces, and terminal equipment

Figure 4.3 PBX components, including common control, switching matrix, trunks and trunk interfaces, stations and line interfaces.

Common Control

Common Control is a common set of stored program logic that controls the activities of the system and all of its various elements. In reality, it consists of multiple microprocessors operating under a stored program, that is secured so as to be bulletproof, according to the manufacturers. As in any computer, the control processor consists of memory, input/output equipment, bulk memory equipment, and software.

The Central Processing Units (CPUs) control the operation of the system. They may be truly centralized, but generally are distributed among cabinets, shelves, or even cards (printed circuit boards), for purposes of effectiveness, efficiency, and survivability. The CPUs control functions such as call setup, call maintenance, call release, performance monitoring, system diagnostics, and storage of operational data for analysis and report presentation. Processor Redundancy is common in contemporary PBXs. Not only are the processing functions distributed amongst multiple microprocessors at the cabinet, shelf, and card levels, but many PBXs feature hot standby processors.


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

Since the systems are largely software controlled, they are relatively easy to upgrade. As new software is released, associated functions and features are released in the form of programmable functions; the system software can be upgraded as required. Additionally, bugs (program errors) can be fixed, with corrections perhaps even being downloaded over the network. Examples of the hundreds of such programmable functions and features include the following:

Automatic Route Selection (ARS) or Least Cost Routing (LCR)
is optional software which allows the user to program the system to route individual calls over the most appropriate selection of carrier and service offering. Routing factors typically might include the nature of the call; the Class of Service (COS); or level of privilege of the user; the time of day; and the day of the year (weekends and holidays). In this fashion, high-priority users with no calling restrictions (company president) are connected on a priority basis, even if a high-cost carrier and service offering were all that were available at the time. On the other hand, low priority users (clerks) are forced to queue for a low-cost facility. The system remembers their request and rings their telephones to alert them when that facility is available, and automatically connects the previously requested call.
Call Pick-up Groups
let users within the same work group answer calls for one another. This option can be invoked by authorized users by keying a code on the set keypad or by depressing a designated button on an electronic set.
Call Forward
lets a user either predefine or selectively and flexibly define an extension to which a call will be transferred in the event of a busy or no answer condition.
Conference Calling
, which can be set up either by the user or by the console attendant, makes use of a special conference bridge card in the system, which might support 8 or 16 parties to such a call.
Call Detail Recording (CDR) or Station Message Detail Recording (SMDR)
information provides detail on all incoming and outgoing calls (see Figure 4.4) so that the system administrator can develop network usage reports. Information typically includes the originating and terminating station, outgoing and incoming trunk or trunk group, time of connection, time of termination (or elapsed time), access code dialed (for instance, 9 for an outside line or 8 for a private line), telephone number dialed, and account code or authorization code used.

Figure 4.4 Example CDR outgoing call records.

Many contemporary PBXs contain adjunct software that allows the generation of a number of reports including usage costs by station, account code, department, and work group. This feature assists in cost and fraud control, as well as permitting costs to be charged to the customers’ clients. Becuase this software is limited in capability, most users prefer to acquire more substantial TeleManagement software residing on an adjunct computer, that accepts CDR output from a special PBX port, processes the data, and creates user-definable reports. Such software typically includes a number of other modules that share a common database for purposes of cost allocation, equipment inventory management, wire and cable management, and numerous other critical administrative functions. Leading manufacturers of such software include The Angeles Group (CA), IntegraTRAK (WA), and Stonehouse & Company (TX) [4-6].
Automatic Call Distribution (ACD)
software routes incoming calls to the most available and appropriate agent. Incoming call centers make extensive use of such specialized software to enhance customer service. Calls are answered by a frontend voice processor that lets users make menu selections. Calls are then queued by specialized agent group and routed to the next available agent. While such capability is often delivered through a specially equipped and partitioned PBX, the PBX can also be specially configured as a standalone ACD. More intensive applications typically make use of specialized ACDs, which function as highly intelligent switches for the processing of incoming calls. Such specially designed high-speed interfaces to the PBX allow the systems to function on an integrated, networked basis.
Universal Call Distribution (UCD)
is a standard feature of many PBXs. While it serves somewhat the same functions, it lacks the same level of intelligence. Therefore, it is much less capable than is ACD, although it is much less costly.

Switching Matrix

Contemporary PBXs employ Time Division Multiplexing (TDM) in both analog and digital systems. Through this process, multiple conversations are sampled, traveling sequentially over a single bus, or common physical path.


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

Trunk Interfaces

These are in the physical form of specialized circuit boards which serve to interface the PBX switch to trunks that in turn, connect it to other switches. Trunks can be one-way outgoing, one-way incoming or two-way (combination trunks). Often a PBX will employ all three variations in order to serve various, specific applications, to maximize system performance, and to ensure a minimum acceptable level of both incoming and outgoing network access. ISDN (Integrated Services Digital Network) offers dynamic call direction on a channel-by-channel basis that is much more flexible therefore, more cost-effective. ISDN will be discussed in detail in Chapter 8.

Trunks may be single-channel or multichannel. High-capacity, multichannel trunks support multiple conversations. Examples include E/T-carrier and ISDN Primary Rate Interface (PRI), also known as Primary Rate Access (PRA). Trunks of the same directional type that serve the same purpose are organized into trunk groups. The PBX will hunt for available trunks within a trunk group, based on a pre-determined, user-definable hunt sequence. Trunk interfaces provide access to the following specific types of trunks:

Central Office Exchange
trunks connect the PBX to the LEC exchange providing access to the local calling area and all other areas served by the local telephone company. They provide access to IXCs for long distance calling where the user organization has not made special arrangements for direct IXC access.
Interexchange
trunks provide direct access to an IXC, bypassing the LEC. Such trunks generally are intended only for long distance network access to geographic areas outside the LEC’s local calling area.
Foreign Exchange (FX or FEX)
trunks connect directly to a foreign central office exchange. They are used for cost-effective access to and from a distant geographic area where there exists a high concentration of traffic. For example, a user organization with a high concentration of traffic between its Dallas, Texas offices and the area immediately surrounding Denton, Texas might choose to avoid long distance calling charges by installing a FX trunk. That trunk is priced on a flat-rate basis, regardless of the level of outgoing traffic. In this fashion, the user organization avoids long distance charges to that area. Callers from the Denton area dial a local Denton telephone number that is associated with that FX trunk, similarly avoiding long distance. As a side benefit, the organization in Dallas creates the illusion of having established a local presence in Denton.
Direct Inward Dialing (DID)
trunks are for incoming traffic only. A special signaling and control arrangement exists between the PBX and CO. The CO passes the dialed station number of the destination address across the trunk to the PBX. With that information, an intelligent PBX with the proper software can route the call directly to the station, without the intervention of an attendant. DID numbers are rented from the service provider in groups (e.g., 50, 100, and 250). Each station is assigned a DID number that roughly corresponds to the internal station number. As a call is placed to a DID number, the CO recognizes it, and connects the call over a special DID trunk, passing the DID number in advance of the call. The PBX recognizes the DID number and processes the call automatically.
TIE
trunks connect directly to remote PBXs within the user network—in effect tying them together. Through the use of ARS/LCR software, the system routes calls between offices over a leased-line TIE trunk, avoiding toll charges in the process. Coordinated, abbreviated dialing plans, programmed within each PBX, cause the various PBX systems to interact on a networked basis, appearing to the user as though they were a single system. TIE trunks are sometimes referred to as nailed-up circuits, because they once were literally nailed-up on the central office wall and specially tagged in order to distinguish them from typical shared circuits.
WATS (Wide Area Telecommunications Service)
trunks allow for discounted long distance access in defined service areas.
INWATS
trunks serve INcoming WATS calls (1-800 and 1-888 in the United States and 0-800 and 0-500 in other countries). The costs are incurred by the called party, at a discounted cost per minute.
Direct Inward System Access (DISA)
trunks allow access (generally toll-free) to the PBX system and, subsequently, to connected resources (e-mail servers, voice processors, computer systems, and outgoing toll trunks) through the entry of authorization codes. While DID trunks are useful to authorized users, they often are the target of hackers, who seek access to the same resources. Therefore, the integrity of the organization, its toll network, various networked systems, and the resident databases can be compromised. DISA trunks should be avoided, and, where in place, they should be disconnected unless extreme security measures are in place.

Station Interfaces

Station interfaces are in the form of printed circuit boards which can support multiple stations of the same general type through multiple ports on a single interface card. For instance, analog line cards with analog ports support analog sets, in which case the signal is digitized within the PBX system. Digital line cards support digital terminal equipment, such as digital telephones and computer workstations.

Terminal Equipment

Because PBXs are designed primarily to support voice traffic, the user terminal equipment generally is in the form of a telephone set. Data terminals are often supported, as well.

Telephone Sets

PBXs support both dial and tone, single-line sets of a generic nature. They also support highly-functional programmable electronic sets that offer access to a number of system features. Although such sets are proprietary to the system manufacturer and are considerably more expensive, they let the station user invoke system features through depressing a single designated button. Proprietary electronic sets generally are digital, with the voice signal being digitized at the set, rather than at the station interface card in the PBX cabinet.


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

Integrated Voice/Data (IVD) Terminals

These terminals combine a highly functional feature phone with a computer workstation. For the most part, such terminals have been stunning failures, because they are expensive and impractical, and as generally are behind the curve of computer technology. More commonly, digital telephone sets offer an EIA-232-E standard, 25-pin computer connection port in order to allow a computer workstation and telephone set to share a common, twisted-pair link to the PBX. (EIA-232E also is known as RS-232 referring to Recommended Standard 232, which is identical in function to ITU-T standard V.24/V.28)

ISDN Sets

These sets provide a highly-functional ISDN connection to the desktop, through an ISDN-compatible PBX, connected to an ISDN circuit.

Attendant Consoles

These provide attendants with the ability to answer and extend incoming calls, provide operator assistance to outgoing callers, and establish conference calls. They often provide alarm indications in the event of a performance failure. When associated with a computer workstation, they often provide electronic directory information and other functionality through an enhanced user interface.

Administrative and Maintenance Terminals

These terminals are connected directly to a maintenance port on the system. Authorized users can access the system software for purposes including Moves, Adds, and Changes (MACs); Class of Service (COS) changes; ARS/LCR programming; requests for traffic and usage statistics; requests for status reports; and diagnostic testing and analysis.

System Configuration and Capacity

The capacity of the PBX must be considered carefully in order to ensure that the organization does not outgrow the system over a reasonable period of time. The system initially should be configured and installed to serve current and near-term requirements, as subsequent software and hardware additions are more costly. Additionally, the system should have the ability to grow to meet long-term needs, in terms of hardware, software and feature content. The following describes the capacity and configuration of PBXs.

Centralized or Distributed

PBXs generally are configured as a centralized system, with all cabinets and peripheral devices collocated for ease of administration. However, a large campus environment may best be served by a decentralized approach, with multiple intelligent cabinets located in campus quadrants and connected with high-capacity circuits. Very large organizations with multiple, distant locations may require the capability to network multiple PBXs over either a private, Tie line network or over a Virtual Private Network (VPN) [4-7].

Physical Capacity

Physical Capacity is the measure of the number of lines and trunks that can be supported through additional line and trunk cards and additional cabinets. Every system has a finite limitation to the number of cabinets and ports that it will support.

Traffic Capacity

Traffic Capacity is the measure of the number of simultaneous conversations that can be supported. This measurement is critical, especially when both voice and data are switched. The capacities of both the processors and the busses must be considered.

Blocking switches (see Figure 4.5), which are typical in a voice-only application, are engineered is such a way as to support a reasonable level of traffic, with some call attempts being blocked during periods of high activity. As the traffic characteristics of voice traffic are well understood and as voice is not particularly bandwidth-intensive, system capacity can be optimized to provide a high level of availability (grade of service) during even the peak busy hour, and at a reasonable cost.

Figure 4.5 Blocking PBX.

Nonblocking switches (Figure 4.6) provide a nonblocked (guaranteed) talk path for every terminal. There exists a 1:1 relationship between (line) ports and time slots. Especially critical in voice/data applications, this admittedly expensive approach ensures access to critical host computing resources within the organization. Access to trunks rarely is provided on a nonblocking basis, as such a high level of trunking adds significant cost in the form of trunk interfaces and the trunks, themselves.

Figure 4.6 Nonblocking switch.

Application Processors

Application Processors often are interfaced with PBXs over high-speed links in order to provide specialized functions such as voice processing, computer host access, e-mail, and facsimile. Generally speaking, the PBX manufacturer supports interfaces to either proprietary application processors or to those developed by third-parties with which there is a strong, strategic relationship. While this approach is limiting, it ensures that the systems and the interfaces between them is highly functional and remains so. The ability of the PBX to support such processors is of critical importance, as they add great value to the performance of the organization.


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

PBX Enhancements and Trends

The PBX increasingly is being positioned as a communications server for voice, data, video and image communications [4-3]. Some manufacturers are building such capabilities into the PBX itself. In October 1995, Lucent Technologies announced its Multimedia Communications eXchange (MMCX) server to support all customary PBX telephone features on multimedia calls. Such calls can involve voice, data, and video from any form of private or public network. The typical approach, however, involves high-speed interfaces to a variety of applications processors. This approach allows specialized processors, often developed by strategic partners, to perform their various functions to maximum advantage on the most effective platform, while also providing application integration through the PBX. The following PBX developments and trends exclude computer telephony integration, which will be discussed at the end of this chapter.

Reduced Instruction-Set Computing (RISC)

RISC processors provide for faster call processing through the use of a reduced set of operations commands, as compared to traditional CISC-based (Complex Instruction-Set Computing) processors. Although the set of executable commands is reduced, the increased speed of processing is thought by many manufacturers to enhance system performance. RISC-based processors increasingly are being incorporated into PBX system design, with Lucent Technology’s, Definity G3r, and GPT’s iSDX systems being notable in that regard [4-8].

PBX-to-Host-/LAN

This link lets users access computer applications through the PBX, sharing the same cable and wire plant as do the telephone terminals. Connectivity between the PBX and a host computer or LAN can be accomplished via such means as ISDN links or 10 Mbps Ethernet links [4-9].

Data Communications

PBX manufacturers have long supported modem pooling and low-speed data through terminal interfaces for data communications. Several manufacturers now support X.25 packet-switching interfaces. Although at considerable cost, Intecom and other manufacturers also support high speed connectivity, including Ethernet and FDDI. Additionally, a number of PBX manufacturers are developing interfaces for ATM (Asynchronous Transfer Mode), which clearly is the network technology of the future. No such interfaces have yet been offered commercially.

Wireless

Wireless communications are currently available for selected users through a special PBX wireless applications. Special PBX ports support wired connections to antennae distributed throughout a large office complex or campus. Selected users who require mobility can take advantage of special cordless telephones to communicate as they roam through the organization as long as they remain within the limited range of the antennae. Manufacturers of such applications include Ericsson and Motorola.

Fax Messaging

Fax messaging is supported by manufacturers such as Nortel (nee Northern Telecom) and Lucent Technologies. Through the voice processing system, prompts allow the transmission of a fax message, which is stored in a user-specific fax mailbox. The user can the access that fax message onscreen at a workstation, much as he would access a voice message from a telephone terminal.

Videoconferencing

PBX videoconferencing is offered by such manufacturers as Fujitsu, AT&T, Nortel, and Siemens Rolm [4-7] and [4-8]. At relatively low speeds over the PSTN, the circuit switched connections are often less costly than are dedicated videoconferencing links. Although generally based on international standards, the terminal equipment typically is proprietary, with the trend being towards more substantial standardization.

Asynchronous Transfer Mode (ATM)

ATM, which will be discussed in detail in Chapter 11, is being examined by PBX manufacturers for broadband communications within the confines of the system, itself. Additionally, ATM compatibility will be provided to the Wide Area Network (WAN). While ATM and PBX switching has been demonstrated in a mode of coexistence, ATM switching has yet to be incorporated into the PBX itself. As the future of ATM in the WAN is virtually assured, as ATM finds its way into the LAN world, and as manufacturers of LAN switches and hubs increase their capability to support voice and video, the PBX manufacturers increasingly will feel the pressure. At the very least, they likely will incorporate ATM switching matrices alongside the standard STM (Synchronous Transfer Mode) matrices currently used to handle voice. The yield likely will be a PBX/ATM router combination [4-10].

PC-Based PBXs

PC-Based PBXs are also known as dumb or programmable switches, have been around for a long time, but generally have not been well accepted. They typically consist of a dedicated 386 or 486 PC, program logic, a switching matrix card and a port expansion unit that provides 16 or more ports. Some systems (VCO Series/80 Open Programmable Switch) involve a switching matrix which is expandable to 4,000 ports. Traditionally, PCs have not been considered reliable enough for such a mission-critical application. Neither have general purpose computers been proved to be stunningly capable of switching calls or providing significant feature content. Those limitations appear to be lifting. Indeed, some strongly suggest that the PC, PC LAN, or Client/Server computer will be the PBX of the future. The low cost of such systems (approximately $200 per port) is a point in their favor, at least in the very small PBX market. Manufacturers include Amtelco, Dianatel, Excel, New Voice, Redcom, and Summa Four [4-11].

Security

Security is of increasing concern, as hackers have penetrated PBXs, Voice Processors (very easy) and other systems to gain unauthorized access to networks and various information resources such as critical databases. PBX, computer and peripheral manufacturers have enhanced security through enhanced software and hardware which can act on either a passive or active basis to deny or terminate such access or, at least, to recognize its occurrence and alert the system administrator of that fact [4-12]. While such products are widely available at reasonable cost, relatively few PBXs are properly protected. It is estimated that unauthorized network access via the PBX results in toll fraud of $2 to $4 billion in the United States alone [4-7].


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

Centrex

As a concept, Centrex (central exchange), is something of a step back in time, providing PBX-like features through special software loaded into the Central Office Exchange. Generally speaking, each Centrex station is generally connected to the central exchange via an individual twisted pair local loop (see Figure 4.7). While multichannel local loop connections are available, they require an expensive remote CO line shelf to be installed at the customer premise; therefore, multichannel access is cost-effective only in applications where there exist large numbers of users at a single site. All switching of calls is accomplished in the CO, which also serves all features to the users population.

Figure 4.7 Centrex CO with individual local loops to Centrex stations and with remote CO line shelf.

Centrex first was made available in the United States and Canada in the early 1960s, through SxS offices. In the United States, it was de-emphasized by AT&T and GTE in the 1970s, in favor of PBXs. This was largely to impending deregulation and divestiture, which took full effect on January 1, 1984. Modern Centrex became available in 1984 through the first generation of digital COs [4-13]. AT&T immediately reversed its position, developing sophisticated digital Centrex software for marketing to its former subsidiaries, the Bell Operating Companies (BOCs), as well as to the independent telephone companies. In addition to Lucent Technologies, Nortel and Siemens are notable manufacturers of Centrex COs [4-3].

Although most commonly provided by Local Exchange Carriers (LECs), Centrex service recently has been offered by IntereXchange Carriers (IXCs) and Competitive Access Providers (CAPs) as well. Although traditionally a U.S. domestic phenomenon, Centrex more recently has found market acceptance in the U.K., Europe, Japan and much of Asia. Centrex is attractive to the carriers, as it effectively competes against PBX technology provided by third parties. The great majority of CO Centrex systems installed in the United States are manufactured by Lucent Technologies (5ESS) and Nortel (DMS-100) [4-14].

Centrex Features

Centrex is capable of offering the same feature content as PBX technology. Indeed, the platform inherently is much more substantial in terms of traffic capacity, memory and virtually every respect. Ultimately, however, the carrier must consider the general market for such features, given an appropriate pricing strategy. Additionally, the impact of features on the switch must be considered in terms of memory, traffic, processor load, etc. Finally, the regulators all too often get involved in determining pricing, availability, impact on the rate base and other factors. Therefore, not all technically feasible Centrex features are available; certainly not on a consistent basis. In any event, Centrex features can include Direct Inward Dialing (DID), Automatic Route Selection (ARS)/Least Cost Routing (LCR), call pick-up groups, call forward, conference calling, Automatic Call Distribution (ACD), and Call Detail Recording (CDR). Centrex also generally is capable of data switching, which may effectively deliver CO-based LAN functionality. Additionally, the Centrex CO generally houses a voice processing system or provides remote access to one, thereby delivering highly effective voice mail and other related functionality [4-15] and [4-13].

The Centrex CO also may offer access to a large number of CLASS (Customer Local Access Signaling Services), which best can be described as advanced custom calling features. Such services might include Name Delivery, Calling Number Delivery, Calling Number Blocking, Continuous Redial/Repeat Dial/Automatic Recall, Distinctive Ringing, Call Return/Automatic Callback, Call Trace, Selective Call Screening, Selective Call Forwarding, Selective Call Rejection, and Anonymous Call Rejection [4-15].

Finally, Centrex offerings increasingly include customer rearrangement capability. This feature allows the user to manage its Centrex service as it might manage its own PBX. Through a computer terminal located on the customer premise, access is afforded to the switch database on a partitioned basis. Thereby, the system administrator can accomplish Moves, Adds and Changes (MACs); disconnect Centrex stations; change Class of Service (COS); file trouble reports and work orders and monitor their status; and perhaps even perform various system and network diagnostic tests. Leading providers are Bellcore with the CCRS system and CommTech Corporation, previously AT&T, with the Macstar system [4-16].


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

Centrex Advantages

Centrex is provided by the carrier and resides on a very robust computer platform which is an integral part of the network. As a result, Centrex offers a number of unique advantages, including reduction of investment and operating cost, and avoidance of responsibility for system acquisition and management. Additionally, system capacity generally is not an issue, and the systems often can be networked to great advantage.

As the capital investment in the switching platform and associated application processors is the responsibility of the carrier, the user avoids the financial pain and associated risks of acquiring what can be a very substantial capital asset. Generally speaking, however, the user remains responsible for the acquisition and of deployment associated station equipment and inside wire and cable systems. Additionally, the user organization avoids a host of operating responsibilities and related costs, as those burdens are shifted to the carrier. Such responsibilities can include system maintenance, system administration (MAC activity), system upgrade, insurance, physical space, physical and network security, power and redundancy.

As the risk of ownership is shifted to the carrier, issues of obsolescence and replacement are obviated. Further, COs are relatively unlimited in terms of port, memory and processor capacity; therefore, it is unlikely that a typical user organization might outgrow the system. This characteristic of Centrex can be extremely important to businesses that tend to expand and contract, perhaps on a seasonal basis. Rather than investing in a PBX switch which is sized to accommodate the maximum size of the organization, additional lines can be added as required and disconnected as that requirement relaxes, with the associated capacity and telephone numbers perhaps being reserved until such time as the requirement resurfaces.

Finally, Centrex allows the user organization to network a number of locations through the serving CO, without the requirement for leasing circuits to connect multiple PBX or Key systems. In fact, virtual Centrex can be provided by networking multiple Centrex COs of the same type; this approach offers the advantage of allowing multiple, distant offices to communicate as though they were collocated and served by a single switch.

Centrex Disadvantages

While Centrex offers a number of unique and very significant advantages over PBXs. there also exist clear disadvantages, including certain cost issues and considerations of control. In terms of the cost of the service, the recurring charges for the circuits and features continue forever, although special tariffs for very large customers can serve to mitigate this factor. Further, Subscriber Line Charges (SLC), also known as Customer Access Line Charges (CALC), apply to each local loop circuit or defined group of loops; as Centrex generally involves a separate local loop for each Centrex station, the typical Centrex user pays a higher price for local access than would a PBX user organization. Finally, rate stability has always been a Centrex issue, as all local rates may be subject to review and adjustment every few years. In many jurisdictions, rate stability plans have served to mitigate this concern, at least in the short term. PBX users, on the other hand, tend to be impacted to a lesser degree, as relatively few high-capacity circuits are shared on a pooled basis.

As we have noted, standard Centrex feature content is determined by the service provider based on market demand in consideration of the resources available in the serving CO switches and with the oversight of the state regulatory agencies. As the offered features are geared toward the average user, the overall feature set tends to be much less complete than is the case in a PBX environment. Therefore, user organizations with requirements for more exotic features may find Centrex to be unacceptable. Additionally, feature content and feature access may vary by carrier, regulatory jurisdiction, exchange CO, and switch origin (manufacturer and generic software load). Features such as ACD are unusual, while others, such as message waiting, are not well presented. Still other features, such as voice-over paging are not available at all. As a result, some users still place small PBXs, Hybrid KTSs, and other CPE (Customer Premise Equipment) systems on premise to interface the station equipment to the Centrex lines to extend more exotic features to select work groups.

Proprietary voice terminals (P-phones) generally are required, although the manufacturers finally have yielded to user pressure in the last few years and provided interfaces to nonproprietary sets. As P-phones are switch-specific, a multilocation company can face additional inventory costs associated with the requirement to stock multiple set types. User confusion also results, because users must deal with multiple set interfaces.

Perhaps the most significant disadvantage of Centrex revolve around issues of control, as the carriers and regulators determine the nature of the offerings. Special features require lengthy tariff approval processes, assuming that the user is successful in negotiating the support of the carrier and assuming that the regulators are sympathetic. Certainly, the user is dependent on the carrier for switch administration, maintenance, and enhancement. Considering that many LECs have a less-than-stunning reputation for responsiveness, this absolute level of dependency is of great concern to many companies.

Centrex CPE

The inherent cost and flexibility limitations of Centrex have given rise to a new breed of Centrex CPE which significantly enhances Centrex capabilities. Although the equipment must be matched carefully to the Centrex switch, such CPE includes Centrex-compatible electronic voice terminals (telephones), ACDs, voice processors, paging systems, attendant consoles, and message lamp controllers. Recently, set handlers, or mediation devices, have been developed which act as protocol converters to effect a proper interface between desired electronic station sets and the Centrex system.


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

Centrex Applications

Meaningful and cost-effective applications for Centrex are increasing, especially as the carriers respond to heightened competitive pressure. The carriers, clearly, are becoming more responsive to end users, are deploying more features on a more consistent basis, and are extending limited network management capabilities to the end user. Additionally, they increasingly are designing rates to attract smaller businesses. Typical applications include multilocation organizations within a single metropolitan area, seasonal businesses, and business which tend to locate only on a temporary basis (e.g., contractors). Additionally, the government and education markets, are heavy users of Centrex, due to capital and expense budget limitations and restrictions.

Centrex Trends and Futures

Centrex is anticipated to increase in popularity in most developed nations due to reasons that include increased competitive pressure, enhanced feature content, improved pricing, enhanced networking capability, ISDN availability, and broadband network access. Additionally, Centrex manufacturers and providers increasingly are applications focused, offering and developing capabilities that include enhanced data communications (e.g., CO-LAN), videoconferencing and integrated messaging. Centrex currently is growing at a rate of approximately 2.95%; most users (43%) are 1,000+ lines, although a significant number (35%) are in the range of 1 to 100 lines, with smaller users growing at the fastest rate (3.5%) [4-3].

Perhaps the most exciting development in Centrex deals with its potential to serve as a means of internetworking multiple PBXs of disparate origin. The city and county of San Francisco recently worked with Pacific Bell (Centrex), Siemens Rolm (PBX), and AT&T (PBX) to integrate Centrex and PBX systems through a series of Central Offices, which serve as protocol translators between the PBX systems and which also serve to integrate the Centrex and PBX users.

Automatic Call Distributors (ACDs)

ACDs function as incoming call switches, serving call center applications. As call centers are highly active, with relatively large numbers of callers queued for a much smaller number of agents, ACDs generally are nonblocking systems. Call centers may be specific to the user organization, but often are set up on a service bureau basis. A service bureau might answer calls for a large number of clients, on either a primary or an overflow basis, with specific software and scripting to support the individual client’s requirements.

The process, as depicted in Figure 4.8, typically involves a front-end voice processing system, which prompts the caller through a menu for call routing purposes. Calls then can be queued by agent group, and delivered to the first available agent in that group. Multiple call centers can be networked in a virtual call center configuration, with calls being routed to the call center in closest proximity to the caller in consideration of network costs. In the event that the closest call center’s queue length exceeds user-definable parameters, the call would then be served to the next nearest call center able to provide an acceptable level of service based on look-ahead routing.

Figure 4.8 Automatic Call Distributor (ACD).

A recent, and much improved alternative allows multiple call centers to be logically connected as portrayed in Figure 4.9. The first appropriate available agent in any of a number of call centers can be identified and reserved via ISDN technology; the call then is connected over an ISDN link.

Figure 4.9 Networked ACDs, connected via ISDN links.

Various techniques can be employed to route the call; options include tone input, calling number, or called number. Regardless of the technique, the process of customer-programmable call handling and routing is known variously by terms such as call vectoring and custom control routing. Once the call is accepted by a call center, the identification of the caller can be determined through several means, including a Personal Identification Number (PIN) or Automatic Number Identification (ANI). The identification number then can be matched against a computer database in order to deliver the caller’s profile to the agent in advance of the connection of the call, resulting in what is known as a screen pop. In this manner, the most available, appropriate and capable agent has access to full account information and, therefore, is able to provide the highest possible level of service. This capability is known as skills-based routing. In addition to agents working at formal call centers, remote agents or even agents-at-home can be networked to an ACD, often over ISDN connections. Service bureau call centers in the United States even make use of inmates in Federal prisons—apparently, they make extremely good employees, with few distractions and they seldom call in sick! The ACD commonly is interfaced to a PBX, as well, in order that calls can be transferred to other departments [4-17].

Benefits of ACD technology include increased productivity, as the agents are served incoming calls from a queue of waiting callers. Additionally, the incoming callers realize enhanced customer service, as they are directed to the call center with the shortest queue, where they are held in queue until an agent is available. While the holding time may be rather long, this approach is preferable to encountering busy conditions that would require repeated attempts to reach an agent. Additionally, more substantial ACDs provide rather substantial workforce management reporting, that allows the system administrator to view and determine trends in calling patterns, average queue lengths, average holding times and so on. Through the use of such a tool, management can better anticipate future incoming call loads and, therefore, can more accurately schedule the number of agents required to handle that load based on customer service objectives.

Customer service is enhanced further when the ACD supports skills-based routing. A credit card company, for instance, might capture the originating telephone number of the incoming caller or request that the caller enter his account number. Through matching that information to a database of customers, the company might determine that the caller holds a platinum card, prefers to deal with a Spanish-speaking agent, and has failed to make a payment with the past two billing cycles. Based on that information, the call might be directed to the closest call center with a readily available and multilingual agent who is capable of initiating collection action [4-18], [4-19], and [4-20].


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

Applications for ACDs in call center environments include reservations centers such as hotels, auto rental agencies, and airlines. Financial institutions such as stock brokers, commodities traders, and banks make heavy use of ACDs, as do ticket agencies.

Rockwell, the company that is credited with inventing the ACD business, still is a leading manufacturer of standalone ACD systems, competing with Aspect Telecommunications, Executone, NEC, and others. PBX manufacturers such as Lucent Technologies, Nortel, and Siemens Rolm recently have captured a majority share (71% in 1995) of the ACD market [4-21] and [4-22]. Some 38,000 systems currently are installed, with the vast majority (67.2%) being in the larger line sizes (500+ lines). The market for ACDs has increased from $285 million in 1987 to $905 million in 1995, and is forecast to be over $1 billion in 1997 [4-3].

ACD Enhancements and Trends

ACDs are no longer intended only for large, isolated incoming call center applications. In response to general organizational trends towards downsizing, ACDs now are highly cost-effective in relatively small configurations. In fact, a number of manufacturers offer such a capability resident on a PC. Additionally, organizations increasingly network call centers, as well as taking advantage of agents-at-home, remoting access to the ACD and associated databases via ISDN links. Further, skills-based routing often is employed to direct the incoming caller to the most capable and available agent, whether situated in the call center or working from home [4-23].

Call-back messaging, a relatively recent enhancement, allows the incoming caller to register his desire to be called back by an agent should the caller grow weary of waiting in queue. Once the queue has been satisfied and an agent becomes available, the system will call the customer back and connect him to an agent automatically.

Call blending, another recent development, allow calls centers to improve their cost-effectiveness by serving both incoming and outgoing calling functions. Through the use of a predictive dialer, the system monitors the status of incoming calls and the level of availability of the agent pool. The system will introduce outgoing calls when it determines that the level of incoming calls has dropped to the point where the quality of the service to incoming callers will not be affected adversely. The predictive dialer will search a database of customers to be called, dial the associated telephone number, detect when the call is answered, and connect the call to an available agent. Predictive dialer software logic may be contained within the ACD, or it may reside on a PC platform with a LAN connection to the ACD [4-24].

Computer Telephony Integration (CTI)

Computer Telephony Integration (CTI) can be defined as the true blending of telecommunications switching and computer processing power. Computers have long been used to program and manage PBXs, Hybrids, and Central Office Exchanges (COs). Yet the system interfaces were proprietary and were tightly linked, with one computer associated with one set of databases and programs residing on one switching system, one voice processor, etc. This was the world of “heavy metal”, which the hardware manufacturers ruled. During this period, users received only the features the manufacturers deemed worthy and presented in the fashion they felt appropriate.

More recently, it became clear that a single computer system can control and integrate multiple telephony devices, taking advantage of the programmed (and programmable) PC’s intelligence and the realtime call processing power of the telephony switch. A PBX, ACD, and voice processor can be integrated to provide a more effective set of solutions for the processing of incoming calls. Additionally, call blending can be achieved through the application of a predictive dialer in order to improve the productivity of the call center.

While users and third-party software developers have long coveted access to PBX, ACD, and CO exchange switches, the manufacturers had no real incentive to provide it on an open basis. Claiming the risk of potential corruption of the switch databases, their real reason was more one of erosion of their very lucrative market for application software. Over time, they did allow software developers access to expensive and difficult Application Programming Interfaces (APIs) which could be used to accomplish these feats. Recently, and under pressure from end users, they opened the systems to APIs developed and standardized by various industry groups. Those APIs are available at very low cost and are much easier to use. In fact, every major PBX vendor now is shipping products that include one or more API interfaces.

The concept evolved much as did computers and their applications, in general. The field initially was dominated by IBM, DEC, and other manufacturers of very substantial hardware with the clout to garner the attention of the PBX manufacturers. More recently, PC and client/server approaches have captured the market. CTI now is available even to the great unwashed masses of small- and medium-size businesses [4-25].

At a minimum, the concept of CTI involves the use of PCs to facilitate user access to PBX and Centrex switch features (e.g., call answer, call transfer, conference calling, call hold, and call hang-up) through a GUI (Graphic User Interface) on a workstation. Taken to the contemporary extreme, the concept involves stripping the switch of much of its intelligence, which is then placed in an adjunct computer system. The adjunct computers then effectively become the PBX or Centrex switch, while the switch becomes just that—a high-performance switching matrix. Additionally, users gain access to complex information and invoke complex features through a workstation. In other words, the PBX, ACD, or Centrex system is rendered dumb, or dumber (programmable). The adjunct computer contains all of the feature content, which is capable of customization, or even further application development, by a third party or by the user organization. The applications are written by service providers in accordance with interface standards or specifications. Those applications then are uploaded to the switch, which makes procedure calls to the adjunct computer controller, as required [4-26] [4-27].


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

As depicted in Figure 4.10, CTI is used in call center applications to effect enhanced functionality. Not only can the call be transferred and conferenced through computer keyboard and mouse commands, but the incoming call identification (calling number or PIN number) can be matched to a caller profile contained in a computer database. Through a screen pop, the caller’s profile is presented to the agent in advance of the call, improving customer service. Should the original agent need to transfer the call to another, the user profile and all other relevant data is transferred along with the voice call. This application was presented in greater detail in the previous discussion of Automatic Call Distributors (ACDs) [4-28].

Figure 4.10 CTI employed in conjunction with an ACD, in a call center environment. (Reprinted with permission from Call Center Magazine).

Technology, Standards and Specifications

The technology concept involves Electronic Common Control (ECC) switches, computer systems, and application software. The switches can be PBXs, electronic KTSs, Hybrids, ACDs, or Centrex COs. The application software is written by third-party developers in accordance with Application Programming Interfaces (APIs). Defined by the equipment manufacturers, such interfaces permit a great deal of flexibility, incorporating user-definable call handling parameters. The computers can be in the form of mainframes, midranges, or PCs; LAN and Client/Server configurations are commonplace. The first generation of APIs were IBM’s CallPath Systems Architecture (CSA), Digital Equipment Corporation’s Computer Integrated Telephony (CIT), and Hewlett-Packard’s Applied Computer Telephony (ACT), all of which still are widely used. Early implementations involved little more than switch-to-host request and status links. More recently, CTI has progressed to the point that it offers robust workstation-based intelligence. Other standards and specifications that have gained wide acceptance include CSTA, TSAPI, TAPI, MVIP, SCSA, and CAPI [4-7] and [4-29].

Computer Supported Telephony Applications (CSTA)

These applications developed by the European Computer Manufacturers Association (ECMA) were the first true open CTI development standard for link-level protocols. CSTA was improved and formally standardized on an international basis by the ITU-T, incorporating the U.S.-developed Switch-to-Computer Applications Interface (SCAI). CSTA is a full protocol stack, which requires an open system interface to a PBX, ACD, or Centrex CO exchange. CSTA is implemented by a growing number of manufacturers, including Alcatel, Comdial, Ericsson, Inter-Tel, Rolm Siemens and Tadiran. Closely aligned with CSTA are Lucent Technologies’ Adjunct/Switch Applications Interface (ASAI), and IBM’s CallPath Services Architecture (CSA).

Telephony Services Application Programming Interface (TSAPI)

Developed jointly by AT&T and Novell and released in March 1994, TSAPI, a specification strongly oriented toward PC platforms, is a lesser protocol stack that does not require that the switch manufacturer fully open the interface. Although a number of PBX manufacturers supported TSAPI, which runs on Novell Netware servers and other systems, the cost of TSAPI PBX drivers is quite high and, as a result, its widespread use has been discouraged. Additionally, many suggest that it is limited in capability and cumbersome to use. TSAPI has been criticized as being a CSTA translator for AT&T Definity switches and as a means of promoting AT&T’s and Novell’s interests. Release 2 (1995) extended the API to other PBXs and computer systems, including OS/2, Macintosh, UnixWare, and Windows NT [4-30] and [4-31].

Telephony Application Programming Interface (TAPI)

TAPI is specification developed jointly by Microsoft and Intel in response to the problems associated with TSAPI. As an integral part of Microsoft’s Windows Open Services Architecture (WOSA), TAPI is being shipped with every copy of Microsoft’s Windows 95 and Windows NT. The client software makes a call to a server-based database in order to match the caller number to his profile. As it primarily is workstation-based, TAPI involves limited additional cost to the user organization [4-32], [4-30], and [4-31].

Multi-Vendor Integration Protocol (MVIP)

Developed in September 1990, MVIP is an ad hoc standard developed by Natural MicroSystems and supported on a multinational, multivendor basis. MVIP provides a set of telephony hardware and software standards for integrating diverse telephony technologies network interfaces and applications in a single adjunct computer system. MVIP was designed to overcome the limited call handling capabilities of PC busses, providing the ability to connect multiple telephony cards in a single PC and handle 256 simultaneous calls over 8 MVIP busses of 2 Mbps each. Multi-Chassis MVIP (MC-MVIP) extends MVIP to allow the interconnection of resources in up to 20 PCs, thereby providing additional flexibility and scalability. High capacity MVIP (H-MVIP) is in the development stages.

A number of vendors have linked together to support MVIP through the Global Organization for MVIP (GO-MVIP). Well over 50 manufacturers, including Mitel, have announced support for MVIP, and well over 200 products exist. Compatible products include Lotus Phone Notes and Nortel’s H.320 Desktop Video.

Signal Computing System Architecture (SCSA)

Developed by Dialogic, SCSA is supported by more than 200 suppliers and developers. A LAN/Server-based architecture, it is hardware independent at the client, host and media processing systems levels. Originally developed to support TAPI, it currently is interoperable with both TAPI and TSAPI. SCSA’s SCbus (Signal Computing bus) allows the creation of up to 2,048 time slots per MVIP bus, thereby providing sufficient capacity for support of full-motion video and high-fidelity audio.

Common ISDN API (CAPI)

CAPI is an API developed in Germany for interfacing ISDN equipment to ISDN lines. Completed in 1990, CAPI is a well-established API which obviates some of the difficulties of interfacing such equipment to ISDN lines through NT-1/2’s and Terminal Adapters (TAs).


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

Forums and Consortia

There exist several forums and consortia that actively promote open system architectures and standard APIs for the development of CTI technologies and applications. In addition to the ECMA, they include the Enterprise Computer Telephony Forum (ECTF) and Versit.

Versit

Versit is a standards-based initiative promoted by Lucent Technologies, Apple Computer, Siemens Rolm, and IBM. Versit provides an open platform to developers in order to encourage the development of CTI applications. Based on Novell’s Telephony Services API (TSAPI), Versit’s first specification was released in 1996. Called the Versit Encyclopedia, it was available free via CD-ROM or through ten pounds of three-ring binders. Although time will tell, Versit has the weight of enough players of significance to make a real impact [4-33].

Enterprise Computer Telephony Forum (ECTF)

ECTF promotes interoperability and standard approaches to CTI. Members include Dialogic, Nortel, Hewlett-Packard, Digital Equipment, and Ericsson Business Networks.

Applications

Applications for CTI generally are limited to telephony-intensive call centers, often serving inbound and outbound call handling. Security Pacific Bank, for instance, installed a 24-hour customer service capability in 1988 at a cost of approximately $7 million. All information requests and branch functions were consolidated into a single service center, where 450 agents handle about 5 million calls a month. Prior to the CTI implementation, representatives were required to log on to three different systems in order to access multiple databases to handle a typical call. The CTI installation allowed a single workstation application interface to support customer queries, problem resolution, information trace and verification, establishment of new accounts, and so on. Additionally, they sell a variety of financial products through inbound and outbound sales programs. The systems runs on Tandem NonStop computer systems and Telephone Delivery System software from Early, Cloud & Company. Key benefits reported include extension of business hours to 24 hours a day, reduction of staff costs by 33%, simplified access to multiple host systems and databases, and improved service quality, and agent efficiency [4-27].

CTI application in an ACD environment offers the advantages of automation of screen pops, skills-based routing, interactive intelligent queuing, call center networking, unified messaging, and call blending. In a typical PBX environment, it offers the advantages of electronic directories, call logs and reminders, integrated message waiting notification (voice, electronic and fax mail), and dial-by-name. The end result is improved call handling and, ultimately, enhanced staff productivity.

A particularly notable application initiative is that of Tadiran, a PBX manufacturer, and Novell. The Tadiran PBX (Coral ISBX) includes an optional CoraLink CTI interface that supports up to four simultaneous server-based CTI applications. Coral’s CTI/OAI (Open Architecture Interface) interface is CSTA-compatible. The Tadiran/Novell relationship initially yielded the Coral Telephony Server, which enables TSAPI-based application development for the Coral system [4-34].

Future

It is clear that CTI has a bright future. Never before have third-party software developers and end users had the ability to write their own applications software to blend single-function devices into a high-performance, integrated solution set. As the PBX, ACD, voice processing, and CO manufacturers increasingly open their proprietary systems and as the APIs become increasingly platform-independent, CTI’s future will be ensured. Whether the switches ultimately will be rendered completely dumb remains to be seen and, in fact, is highly unlikely. Nonetheless, many of the applications will be developed on and delivered through software residing on an adjunct computer platform. Otherwise, the traditional PBX, Hybrid KTS, and Centrex CO risk being overwhelmed by the exotic and customized applications required by contemporary businesses.

The cost of CTI software has dropped from the original $15,000 to $20,000 per seat (agent position) in a mainframe implementation to only a few hundred dollars in a contemporary LAN-based client/server environment. In a telephony-intensive call center environment, this and other associated costs easily can be justified and recouped through improved agent productivity and enhanced customer service. BIS Strategic Decisions (Norwell, Massachusetts) estimates that CTI revenue was approximately $2 billion in 1993, and is expected to grow to $5.63 billion in 1997. According to Dataquest and The Aries Group/MPSG, market leaders include Lucent Technologies, Nortel and Siemens Rolm in the arena of telecom manufacturers; leading computer manufacturers include IBM, Digital Equipment Corporation (DEC) and Hewlett-Packard [4-3], [4-35], and [4.28].

A number of PBX manufacturers also have gotten into the game, developing their own service-provider software, albeit for their own switches. For instance, Comdial’s wideopen.office is a LAN-based CTI solution which is relatively uncomplicated and supports most operating systems. It also supports both the TSAPI and TAPI programming interfaces.

Dataquest further forecasts that, while only 558 new CTI systems were installed in 1992, that number grew to 9,311 in 1995 and will reach 502,000 in 1999. By that time, some 23 million agents will be added to the network each year at an average cost of $213 for software and links, compared to $609 in 1995 [4-3]. Given its low and rapidly dropping cost, in combination with the obvious benefits of customized user control, CTI saves money and makes sense [4-36].


Communications Systems and Networks:Voice Communications Systems: PBX, ACD, Centrx, and KTS

References

[4-1] Brooks, John. Telephone: The First Hundred Years. NY: Harper & Row, 1976.
[4-2] Rees, Diane and English, Michelle K. “Key and Hybrid Systems: Overview.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. March 1995.
[4-3] 1996 MultiMedia Telecommunications Market Review and Forecast. Washington D.C.: MultiMedia Telecommunications Association. 1996.
[4-4] Gasman, Lawrence. Manager’s Guide to the New Telecommunications Network. Norwood, MA: Artech House.1988.
[4-5] Sulkin, Allan. “PBX Market Perks Up.” Hinsdale, IL Business Communications Review. January 1995.
[4-6] Horak, Ray. “Telemanagement Systems and Software: Overview.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. January 1995.
[4-7] Costello, Richard A. and Rees, Dianne. “PBX Systems: Overview.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. June 1995.
[4-8] Sulkin, Allan. PBX System Technologies Overview. ACUTA Spring 1996 Seminar. PBX Technologies. March/April 1996.
[4-9] Liebowitz, Ed. “SRX’s Switch-to-Host Vision.” Teleconnect. November 1994.
[4-10] Kaufman, Harvey. “PBXs, Computers and the Trend Toward ATM.” Telecommunications. December, 1995.
[4-11] Warren, Stuart. “PC PBXs Compared.” Computer Telephony. November/December 1994.
[4-12] Rohde, David. “Northern Telecom to Bring Security, Savings back to PBXs.” Network World. May 1, 1995.
[4-13] Abrahams, John R. Manager’s Guide to CENTREX. Norwood, MA: Artech House. 1988.
[4-14] Horak, Ray. “PBX versus Centrex Comparison.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. January 1995.
[4-15] Costello, Richard A. “Centrex: Overview.” Datapro Communications Analyst. Delran NJ: Datapro Information Services Group. May 1996.
[4-16] Horak, Ray. “Centrex Management Systems.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. 1993.
[4-17] Doren, Donald van. “CTI: Moving Into High Gear.” TeleProfessional. February 1996.
[4-18] Bodin, Madeline. “ACD Features at Work.” Call Center. May 1995.
[4-19] Klenke, Maggie. “ACDs Get Skills-Based Routing.” Business Communications Review. July 1996.
[4-20] Klenke, Maggie. “ACDs Get Skills-Based Routing.” TeleProfessional. March 1996.
[4-21] Sulkin, Allan. “ACDs: Standalone vs. the PBX Vendors.” Business Communications Review. June 1995.
[4-22] Frydman, Isaac. “The Year of the ACD.” TeleProfessional. February 1996.
[4-23] Womack, Audrey Y. “Automatic Call Distribution Systems: Overview.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. June 1994.
[4-24] Dawson, Keith. “Out Of The Box, Onto The Phones.” Call Center. May 1995.
[4-25] Rudd, Susan. “Where Do CTI Applications Really Belong?” Business Communications Review. February 1996.
[4-26] Grigonis, Richard. “PBX Survival Techniques.” Computer Telephony. July 1995.
[4-27] Lau, Delina; Xue, Cindy; Paetamai, Poonpon; and Ghani, Muhammad Usman. Computer Telephony Integration. University of San Francisco. December 4, 1995.
[4-28] “Computers On Call: Computer-Telephony Integration (CTI).” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. December 1995.
[4-29] “Smart, Programmable Dumb-Switch Apps.” Computer Telephony. July 1995.
[4-30] King, Rachael. “CTI Up Close: Analyzing the API Angle.” Data Communications. October 1995.
[4-31] Taylor, Kieran. “Distributed PBXs: Big Benefits, Little Boxes.” Data Communications. October 1995.
[4-32] Burton, James. “CTI: The View from Windows 95 and NT.” Business Communications Review. January 1996.
[4-33] Thyfault, Mary E. “Telephony’s Turn in The Spotlight.” Information Week. March 11, 1996.
[4-34] Horak, Ray. “Tadiran Coral ISBX.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. November 1995
[4-35] Costello, Richard A. “Computer Telephony Integration (CTI): Overview.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. March 1996.
[4-36] Claypool, Loren. “Company Saves $465,000 per Year with Computer Telephony Integration System.” TeleProfessional. September 1995.


Communications Systems and Networks:Messaging Systems: Facsimile, Voice Processing and Electronic Mail

Chapter 5
Messaging Systems: Facsimile, Voice Processing and Electronic Mail

Press one for sales. Press two in a hopeless effort to get technical support. Press one for answers to questions you don’t have. Press two if you’re gullible and pessimistic. Press two if you’re willing to buy something just so you can talk to a human being.

From the comic strip Dilbert by Scott Adams

Electronic messaging systems offer a great advantage for certain applications compared with standard, data, video and image systems, and networks. While facsimile, voice processing, and e-mail systems each deal with information in a different native form, and while each serves its own unique purpose, they increasingly are being merged to deliver unified messaging.

While these technologies are very different in their basic characteristics and, certainly in their application, there are some commonalities. They all reside on a computer platform of some description and they all make use of analog and/or digital circuits, being of greatest advantage when the systems are networked. Perhaps most importantly, electronic messaging systems are characterized by their abilities to provide store-and-forward communications. In other words, the systems accept a message and store it in temporary memory in a user’s mailbox, where it may be accessed at a later time and perhaps be forwarded subsequently to another user.

Store-and-forward technology adds significant value, as it overcomes the requirement for realtime communication between people or machines. The specific benefits of store-and-forward technologies include the fact that differences in time zones are mitigated as the message can be created during business hours in one location, and accessed by the recipient during normal business hours at the distant location. Whether the parties are at opposite ends of the country or are separated by continents, communications can be effected on a non-realtime basis. Additionally, systems and messages can be accessed over the network from remote locations (e.g., field offices, hotels and client sites) on a 24-hour basis. Finally, the messages tend to be abbreviated, containing only the necessary information. This is especially true of voice mail, which replaces the normal human-to-human conversational mode of communications. As social animals, humans tend to socialize before getting down to the business at hand. We are much less likely to attend to interpersonal niceties via a machine-enabled, one-way communication.

While all of these devices initially were standalone systems based on proprietary standards, contemporary systems are computer-based messaging systems that are networked and are based on standards that ensure their ability to interoperate at some minimum level. Additionally, they often are accessed, or are accessible, through a PBX, KTS, Centrex, CO, or ACD system. They also increasingly are enhanced through the application of Computer Telephony Integration (CTI) technology. CTI allows the user to access a variety of messages through the switch from a LAN-attached PC workstation, using a single and intuitive Graphic User Interface (GUI). Finally, the separate technologies of facsimile, voice processing. and e-mail are being integrated to yield unified messaging systems to allow voice, text, image and even video messages to be blended, enhancing the composite effectiveness and impact of the individual messages.

Facsimile (Fax) Systems

Facsimile comes from the Latin fac simile, translated as make similar. Facsimile systems are unique as they transmit image information, rather than audio or data. Additionally, they generally are based on electrochemical processes at the receiving end. The first practical fax machine was built in 1837 by Edward Davy, who abandoned the invention shortly thereafter. The concept was revived in 1846 by Alexander Bain, a Scottish clockmaker. The Bain device was used commercially in the United States and England, where it competed with the Cooke-Wheatstone telegraph, which transmitted images through etching metal with a stylus. Facsimile was not widely deployed until the 1960s and 1970s, when the cost of the devices was lowered enough for the technology to find relatively significant market acceptance in commercial, education, and government applications. The low cost of current fax technology renders it cost-effective even for widespread consumer use.


Communications Systems and Networks:Messaging Systems: Facsimile, Voice Processing and Electronic Mail

The Technology

Facsimile transmission typically involves a pair of standalone fax transmitter/receivers with a built-in modems, with transmission generally taking place across the analog Public Switched Telephone Network (PSTN). The transmitting fax scans the image document, looking for dots of black and white (some systems will also support 256 levels of grayscale). Through the modem, these variations are translated into modulations of analog sine waves, over an analog network. The receiving device reads the analog sine waves through a modem. The temperature of the output device of the receiving fax machine is varied to cause the image to be reproduced on chemically treated paper. In other words, fax transmission generally is an analog technology that is electrothermochemical in nature.

Group I and II (Table 5.1) fax machines, the first generations, employed obsolete electrochemical processes. As they were based on international standards developed by the CCITT (now ITU-T), compatibility was achieved within each Group. Transmission was on an analog basis, with Group I machines using Frequency Modulation (FM)—1500 Hz white frequency and 2400 Hz black frequency. Group II machines employed Amplitude Modulation (AM) at 2100 Hz.

Table 5.1 Facsimile generations and characteristics
Generation (ITU-T Group) | Transmission Speed* (per page) | Compatibility | Resolution: Lines per Inch (LPI)
Group I | 4–6 Minutes | Group I | 100
Group II | 2–3 Minutes | Group II | 100
Group III | [lte]1 Minute | Groups I, II, and III | 200
Group IV | 3–4 Seconds | Groups I, II, III, and IV | 200–400
*Sensitive to density of image

Group III fax machines, which account for approximately 98% of all devices currently in use, conform to the above described electrothermochemical process, although plain-paper facsimile machines are essentially fax laser printers. Group III facsimile machines also are manufactured according ITU-T standards; thereby obviating issues of incompatibility. Alternatives to this standard description do exist, however. Group III devices transmit compressed digital data at 4800 to 9600 bps over analog lines through the use of an ITU-T standard modem protocol.

Group IV fax machines, which are highly specialized and relatively expensive fax computer systems, are designed to make use of digital circuits in order to speed the process and improve quality through compressed digital transmission at rates up to 64 Kbps. Group IV fax machines also are Group III-compatible and can be connected to analog circuits, as well. Table 5.1 provides a view of the characteristics of each ITU-T fax generation [5-1] [5-2].

Fax Boards and Fax Software (Group III/IV-compatible) are available for PCs and other computer systems. When sending a computer-based fax document, the fax software instructs the fax board to print the fax to a remote fax machine, rather than a printer. The computer fax board contains a fax modem, enabling any computer file to be transmitted to another similarly equipped computer or to a fax machine through fax emulation (imitation). The cost of such boards is quite reasonable, often less than $100. Fax software and fax boards often are included in a suite of application software packaged with a PC. WinFax and BitFax are included with Microsoft Windows, pre-packaged with most IBM-compatible PCs. Client/server versions include fax software resident on client workstations, with a relatively small number of fax boards residing on the fax server. The server may be a dedicated fax server or may be a partition of a file server. The fax software in the client workstations send the fax documents across a LAN to the fax server (see Figure 5.1), which queues them as required before transmission, thereby considerably reducing hardware and circuit costs [5-3], [5-4], and [5-5].

Figure 5.1 Facsimile transmission in a fax server environment.

There are however several drawbacks associated with these approaches. First, the transmitted documents either must exist as computer files or must be scanned and converted to computer files through the use of peripheral equipment. Second, the receiving fax computers must be left on and must be networked continuously in order to be accessible. Third, the process of fax receipt may interrupt other applications in progress at the receiving computer workstation. Finally, the received documents are memory-intensive image files, which must be converted to text files in order to be fully effective. Assuming a high-resolution fax at 400 lpi (lines per inch), a typical page of text requires approximately 50 KB. A single page of a graphic-intensive document can require many MBs of storage.


Communications Systems and Networks:Messaging Systems: Facsimile, Voice Processing and Electronic Mail

Fax-on-Demand (FOD)

Fax-on-Demand (FOD) is a relatively new integration of voice processing and facsimile. FOD involves a voice processing front-end that answers the call, prompts the caller to select a document from a menu of options, enter a return fax number, and enter a credit card number in order that a fax response might be sent and billed as appropriate. Some systems can automatically verify the credit card number on a machine-to-machine basis.

There are single-line FOD systems that work in combination with voice/fax/data modems. Such systems are capable of storing as many as 999 fax documents at a cost of less than $250. The port configuration of multiline FOD systems is as small as 2x2 (incoming x outgoing) and the cost is as low as US$3,000. They range as large as 24x24, handling approximately 2,000 calls per day and storing over 10,000 documents. The platform can be as small as a standalone 486 PC outfitted with fax cards, voice processing cards, and FOD software. The systems can be delivered on a turnkey basis, or the user can build one with a component toolkit. Octel, Active Voice, Applied Voice Technologies and other manufacturers of voice processing systems offer add-on FOD. FOD also can be integrated with a PABX system. There also exist combination, single-slot PC cards which can effect both FOD and voice processing. Once again, devices and their functions no longer can be categorized in discrete terms [5-6].

FOD systems generally can be characterized as including a voice processing front-end, which accepts tone input for purposes of document selection by menu option, and entry of return fax numbers and credit card numbers. FOD systems also may include broadcast capabilities that support outgoing fax transmission to large numbers of receivers through the entry of a distribution list. In larger applications, FOD systems are in the form of fax servers typically residing on dedicated computer platforms and accessible by multiple client workstations across a LAN.

As reported by InfoWorld, the Ontario (Canada) Jockey Club uses Octel’s Fax Mail Plus to communicate with suppliers to its three racetracks. Additionally, trainers and horse owners can dial into the system to request fax transmission of post positions and weekly schedules. Octel, primarily a manufacturer of voice processing systems, says that the automated system saves the Jockey Club $750 per month, including $325 in labor associated with manual fax transmission [5-7]. Novell reported that its client/server FOD system pays for itself every 30 business days. The system is used for technical support, training, and to fax product information. Octel uses a 24x24-port system (24 inbound and 24 outbound lines) to handle 1,700 calls a day and store 10,000 documents [5-8].

Fax Applications

Application of facsimile technology traditionally has focused on document transfer. A key advantage, of course, is that any document can be transmitted by fax. Whether the document is a letter, an invoice, a blueprint, or even a photograph, it can be transmitted successfully. Numerous sales-oriented enterprises now rely heavily on fax broadcast systems, in place of more traditional direct mail or other forms of advertising. In the case of time-sensitive sales, fax advertising can quickly position a product in front of large numbers of prospective buyers. Additionally, a faxed ad is more likely to garner the attention of the buyer than would a similar media ad or a direct mailer.

Recently, Fax-On-Demand (FOD) has been used successfully by a number of customer-service and telemarketing enterprises as a replacement for fulfilling information requests generated by direct mail and other forms of advertising. Network World, a leading communications network publication, encourages prospective attendees to view detailed descriptions of its seminar and conference offerings by accessing its FOD system. Becuase the FOD system is completely automated, Network World reports substantial savings in manpower and overall fulfillment costs. Perhaps most importantly, the information is faxed back to the prospect, received much more quickly and acted on more expeditiously than would be the case with more traditional means such as the U.S. Postal Service.

Integrated Fax Messaging is developing rapidly and promises to replace conventional fax systems during the next decade, at least in fax-intensive operations. Also referred to as Unified Fax Messaging, the technology has been standardized by the International Computer Fax Association (IFCA), an affiliate member of the Electronic Messaging Association. IFCA members such as Brooktrout Technology, Castelle, Delrina, FISK Communications, and GammaLink have developed systems based on ITU-T standards T.434. and T.30 [5-9].

T.434

T.434 is an industry standard for Binary File Transfer (BFT) that allows compliant facsimile devices to send any file type, reproducing the original quality at the receiving end. Additionally, the received document is in the form of a file that can be edited. T.434 provides for interoperability among binary file-transfer products from different manufacturers, allowing data files to be sent much as e-mail messages are sent—Fax-on-Demand essentially becomes File-on-Demand. The standard works with fax PCs, fax servers, and Group IV fax machines. Benefits of T.434 include increased throughput and reduced document storage requirements through data compression. Additionally, the specific file attributes (e.g., image format as in .EPS, .PCX, or .BMP files) are maintained. Also, the documents can be edited and annotated once received. In addition to working with computer-based facsimile systems, some standalone fax machines support the standard T.434 also has the potential for linking fax systems with photocopiers, scanners, e-mail gateways, and PCs; it may also allow integration with PBXs and voice mail systems.


Communications Systems and Networks:Messaging Systems: Facsimile, Voice Processing and Electronic Mail

T.30

T.30 is a Group III/IV-compatible standard for routing faxes to users via subaddresses or fax mailboxes. Message security is included, with only the cover page capable of being viewed. The routing can be accomplished in several ways, including DTMF, DID, OCR, and manual. Dual Tone MultiFrequency (DTMF) routing requires the sender to enter the appropriate fax extension via a telephone tonepad. Direct Inward Dialing (DID) routing requires a PBX and each fax extension is required to have a separate DID number. Optical Character Recognition (OCR) software, lets the server recognize the name or special identification of the intended recipient. OCR currently is more expensive and less reliable than are the other options. Manual routing is the most common approach, with an individual viewing only the cover page and then routing the fax as appropriate.

In a client/server computing environment, each LAN-connected client workstation is assigned a fax extension number. Inbound fax messages received by the fax server are then automatically routed to the appropriate workstation associated with the intended recipient. Through entry of the appropriate security password, the recipient then accesses the facsimile message. Assuming that the message is T.434-compliant, it can be edited and annotated by the recipient prior to either a fax response or forwarding to a user-definable distribution list. Companies such as Brooktrout have developed software that allows the server to recognize the dialed telephone number with the trailing subaddress. The fax can then be routed to a fax machine, another client workstation, or an e-mail address. Server software developed by companies such as Castelle enable the server automatically to determine whether to send the message via the PSTN or e-mail [5-10].

The Future of Fax

Rather than being replaced by e-mail and other forms of messaging technology, facsimile appears to have a long and prosperous future. Dependable, inexpensive, standardized and virtually ubiquitous, fax promises to continue its role as a valuable communications tool. While e-mail offers a number of advantages over fax, it is not widely available in developing countries. Further, facsimile is an inexpensive and highly-effective complement to other messaging systems.

As costs continue to drop and as PCs equipped with fax boards and software become more common, fax will penetrate virtually every small business and household. Fax servers will become commonplace in medium and large businesses. Fax-on-Demand (FOD) will challenge direct mail and will become used extensively in fulfillment of information requests generated by various, more traditional, forms of advertising.

Mobile fax will become commonplace, as more laptop computers are equipped with fax modems in the form of PCMCIA (Personal Computer Memory Card Industry Association) cards, also known as PC cards. The questionable trend toward PDAs (Personal Digital Assistants) may encourage mobile fax, as well [5-11] and [5-12].

Color fax is accomplished either by standalone color fax machines, special fax compression techniques, or computer fax techniques. Color fax machines, which began to appear commercially in 1995, will increase in popularity as dependable and affordable multifunction devices are developed. Such devices will take the form of combined faxes/printers/scanners/copiers. The technology exists today through interfaces between computers and color copiers, but is relatively expensive and non-standardized; as a result, its application is unusual. An exception is Windows 95 Color Link from Laser Today International. Priced at US$138 and residing on a Microsoft Windows 95 or Apple Macintosh platform with fax modem, the software allows the transmission and receipt of color faxes between similarly equipped computers.

Fax compression technology, through the use of special software, will become more common. InfoImaging Technologies, for instance, has developed 3D Fax Software which will compress any file at 100:1. The proprietary software, which must reside on both transmitter and receiver at a current cost of US$100-$200, can transmit up to 1 GByte (1GB) of data in 99 pages of dot patterns which are decompressed by the receiving system to yield the image in its original form. The faxed information (text, image, video or multimedia files or computer programs) also can be sent to a standard fax machine and then scanned into a computer where the software will act on it to restore the information to its native form. In this manner, a color photograph can be sent via a standard black and white fax machine, scanned into the computer and restored to its original color form [5-13]. Fax compression is becoming increasingly important as the average Fortune 500 company spends an average of US$13.6 million on fax-related network usage—40% of a company’s total long distance bill according to a 1995 Gallup/Pitney Bowes Fax Usage and Application Study. Due to differences in time zones, that figure goes up to as much as 75% for many companies doing business in Asia [5-14].

Major international carriers (AT&T, MCI, and Sprint) recently have developed various fax network offerings. AT&T offers International Advanced Fax which operates over high-quality digital circuits in the U.S. and to a small number of other countries. For a small set-up charge and monthly minimum, quality is improved and transmission time is reduced. Special rates are available for short-duration calls. MCI and Sprint have developed network-based FOD and fax store-and-forward systems [5-14] and [5-15].

Voice Processing Systems

Voice processing systems were developed and deployed on a closed trial (alpha test) basis in the early 1970s as a replacement for answering machines. In the United States, the AT&T Bell Operating Companies (BOCs) trialed CO-based systems. However, the impending MFJ forestalled their commercial deployment, as they were considered to be enhanced services, which the RBOCs were prohibited from offering.

The first commercial voice processing system was developed and marketed by VMX (since merged with Octel) around 1978. That system was a standalone voice mail system with an interface to the PBX, from which the call was forwarded in the event of a busy or no answer condition at the user station. Since that time, a number of manufacturers have entered the voice processing business, and the nature of the systems has changed considerably to include increased feature content, integrated messaging, PC platforms, application development toolkits, and networking.


Communications Systems and Networks:Messaging Systems: Facsimile, Voice Processing and Electronic Mail

The Technology

Voice processing systems are specialized computer systems consisting of ports, processors, an operating system, codecs, and storage. The computer platform typically is special-purpose, although it may be a general purpose computer with special application software. The operating system may be UNIX or some other industry standard, although it often is proprietary. Similarly the processors may be Intel or another industry standard, or they may be proprietary. The codecs serve to convert incoming analog signals to digital format, compressing the data in the process in order to conserve expensive system storage. Disk drives contain application programs and provide for storage of data, including digitized voice greetings, and incoming messages which are stored in individual mailboxes in the form of memory partitions. The amount of storage is sensitive to factors such as the number of mailboxes, the number of messages to be stores, the average message length, the nature of the analog-to-digital conversion process and compression rate, and the number of messages to be archived.

A customized voice greeting provides the calling party with options that are invoked through either DTMF selection or voice recognition; voice recognition is not common at this time. The subsequent voice input can be either analog or digital, depending on the nature of the connecting circuit. The voice processing system then digitizes and compresses the signal, as required, employing a proprietary code format and compression scheme.

Interface to a PBX, Hybrid PBX, ACD, or Central Office generally is required. In the case of a PBX, Hybrid or Central Office application, the voice processing system generally is accessed from the switch in the event of a busy or no-answer condition at the intended target station. Alternatively, the voice processing system can act as an Automated Attendant. The switch answers the call and forwards it to the voice processor, which allows the caller to access a department or station through interaction with an options menu and automated directory. The voice processor then signals the switch, instructing it to connect the call. Interface to a general purpose computer system is also commonplace. In such an application, the system allows database access, with the response being in the form of text-to-speech, which is synthesized.

Networking of voice processing systems (Figure 5.2) is fairly routine in large organizations, although it is generally limited to systems of the same origin (manufacturer) and generic software load. In a networked environment, multiple systems are connected via dedicated system ports; the nature of the network varies widely, although digital networks are preferred as the information is in data format. On a scheduled basis, the various systems will engage in a computer-to-computer dialogue, transferring messages to the systems on which reside the destination mailboxes.

Figure 5.2 Networked voice processing systems, with PBX, Centrex, and host interfaces.

Platforms for voice processing no longer are limited to proprietary hardware, although that is still the case with larger systems for intensive applications. Many smaller organizations and those with certain, specific applications currently make use of special software and voice cards (printed circuit boards) which reside on 486 PC platforms in a client/server environment. CallWare Technologies offers a Novell NetWare client/server application software package that includes an automated attendant, audiotex, customized mailboxes and tenant services. Such a CTI approach is highly functional and very cost-effective, although issues of reliability and database integrity cause lingering doubts as to the wisdom of placing such an applications suite on a general-purpose computer. Additionally, the voice message takes up substantial amounts of memory. In a recent Network World test, the CallWare software required 22 Kb of memory for each second of a voice message, yielding a 55 KB storage requirement for a typical 20-second message [5-16].

Interoperability standards recently have increased the power of voice processing through enabling the internetworking of systems. AMIS (Audio Messaging Interface Specification) enables the exchange of messages between unlike systems.

Applications

Applications for voice processing have increased dramatically with penetration having reached the point that it is virtually everywhere. Typical applications can be categorized as voice mail, audiotex, call processing, and database access [5-17] and [5-18].

Audiotex

Audiotex is a simple technology by today’s standards, allowing callers to select prerecorded messages from a menu. Essentially a voice bulletin board, audiotex generally is incorporated into a more substantial suite of voice processing applications such as call processing; with the audiotex feature perhaps allowing callers to select options on the telephone to gain information on hours of operation (Press 1), get directions to the company location (Press 2), gain access to recent press releases (Press 3), or determine the price of the stock at the close of the last trading day (Press 4).


Communications Systems and Networks:Messaging Systems: Facsimile, Voice Processing and Electronic Mail

Voice Mail

Voice mail, the most common application, involves the direction of the incoming call to a voice mailbox associated with a particular user or application. The incoming message is stored in the mailbox and the user is advised, using one of several techniques (e.g., message-waiting lamp indication and stuttered dial tone), of the fact that a message is waiting. When the user accesses the system and enters the proper command and password, the message is re-synthesized and played back, ultimately in analog audio form. Features may include personalized greeting, message broadcasting using a user-definable distribution list, message archiving, message forwarding, message annotation, automated call return, and access to a console attendant or alternative answering point.

In addition to what might be described as more legitimate applications, the future portends increased use of voice junk mail. Advertisers such as KMPS radio (Seattle, Washington) have built voice mail databases that allow them to broadcast advertisements to thousands of current and potential customers. While such use is aggravating to many voice mail recipients, they do, of course, have the option of calling the advertiser and requesting that they be removed from such a database. The carriers are particularly unhappy about such use, as it not only places great demands on the involved voice mail systems and the network, but also threatens to yield en masse cancellations of highly-profitable voice mail subscriptions. A more legitimate and common application is for school districts to notify parents of events such as their children’s absence from school, the mailing of report cards, the scheduling of sporting events and practice sessions, or schools closings/delays due to severe inclement weather [5-19].

Call Processing

Call processing applications involve the voice processing system as a front-end call processor to a PBX or ACD. The automated attendant feature of the system will answer the call and provide menu options which can be invoked through either DTMF input or voice recognition software. Features may include automated call routing, Automatic Number Identification (ANI), and Fax-on-Demand (FOD) access. Once the caller has selected a menu option, the call can be directed to the appropriate agent, extension, or computer resource. Should the system not be able to connect the call immediately, it can either be placed in queue or the caller can leave in voice mail a call-back message, rather than simply abandoning the call.

First Interstate Bank, for instance, provides a Day & Night Banking Center® that allows customers to access account information without human intervention. The caller is prompted to enter his account number, followed by a user-definable PIN. At that point, menu options include the account balance, last five checks posted, last three deposits posted, and so on. American Airlines provides toll-free access to its reservations centers, with the ACD being frontended by a voice processor that prompts the caller through options including domestic versus international reservations, AAdvantage Frequent Flyer Program status. Based on DTMF input, the caller is directed to the appropriate agent group or to an automated database access system.

Database Access: Interactive Voice Response (IVR)

In a database access application, the voice processing system acts as a front-end, although to general purpose computers on which reside appropriate databases (Figure 5.2). As a means of imposing a level of security to the transaction, various means of caller authentication can be employed. For instance, DTMF input of a Personal Identification Number (PIN) can be required for access or more unusual and expensive techniques such as voice recognition (recognition of voice commands) and voice print matching (verification of the caller’s identification by matching the characteristics of the voice input to a stored sample) can be involved before the caller is afforded access to the system. That information (bank or credit card account information) then is voice-synthesized for the benefit of the caller, yielding what is commonly known as Interactive Voice Response (IVR). Access to multiple databases often is served across a LAN. Features may include voice recognition, voice print matching, and text-to-speech capability. Reservations centers such as American Airlines and financial institutions such as First Interstate Bank make heavy use of such capabilities in order to reduce staffing levels and provide enhanced customer service. Further, carriers such as Bell Atlantic use voice recognition technology to provide automated access to local directory databases [5-20], [5-21], and [5-22].


Communications Systems and Networks:Messaging Systems: Facsimile, Voice Processing and Electronic Mail

Voice Processing Developments and Futures

The future of voice processing is very bright, indeed. While such systems initially were a North American phenomenon, they are now commonplace in Europe and are gaining greater acceptance in Asia and other regions. Specific technology futures include archival, multimedia/unified messaging, voice-to-text, voice-to-fax, and language translation.

Computer Telephony Integration (CTI) has had an impact on voice processing, and will continue to have an impact in the future. Some CTI application software allows the voice processor to actually process the call, connecting the caller to the target station without the involvement of the switch.

Archival technology has been developed to allow voice messages to be archived, either for an individual or for a work group, on an external archival system and in the form of digitized audio files. The technology is in its early stages and is not widely available. Currently, voice processing systems allow the user to archive a message within the system. Internal memory limits the number and length of messages that effectively can be saved in this fashion.

Multimedia messaging, also known as unified or integrated messaging, allows a compound document to be developed and networked. A voice message can be associated with a text or image document. For instance, a voice processor acting as a front-end might recognize a fax tone and store the fax along with the voice message. Subsequently, the target user can listen to the voice message while viewing the fax document.

Voice-to-text and voice-to-fax technologies have been demonstrated which will convert voice messages to text or fax messages, and vice versa. While the technology is in development stage, a number of commercially available products will convert text to speech for applications such as remote e-mail access from a telephone. Manufacturers include Digital Equipment Corporation (DEC), Berkeley Speech Technologies, Rhetorix, Dialogic, Natural MicroSystems, Active Voice, and Applied Voice Technology [5-23].

Speech recognition software allows the caller to speak commands to the voice processing system, rather than entering commands via the telephone tone pad. Although all but the most expensive systems currently are limited in vocabulary, such technology will become increasingly affordable and, therefore, prevalent in the foreseeable future. IBM, for instance, has developed speech recognition technology to the point that computer system vocabularies are in excess of 50,000 words [5-17] and [5-24].

Language translation systems also have been demonstrated which will accomplish language conversion. The technology, which also is in development, is planned for implementation by AT&T and other IXCs, replacing human translators currently providing such services.

Voice processing systems are destined to become even more commonplace, to the chagrin of many who bemoan the fact that they no longer can talk to a live human being. While users often hide behind voice mail in order to be more productive in the workplace, callers understandably get frustrated at their inability to reach them. Additionally, many systems are set up intentionally to defeat the caller’s attempts to reach any live person—this phenomenon is known as voice mail jail.

Electronic Mail (e-mail)

Once upon a time, letter writing was the way we communicated. Then came the telegraph, which was used sparingly—telegrams were expensive and rarely brought good news. Some 50 years later, the telephone arrived, and eventually became the primary means of communications. Federal Express and other courier services have become a routine means of sending written documents, to the point that we wonder how we ever got along with snail mail. Fax machines then became affordable and popular, allowing instantaneous transmission of documents. Now comes electronic mail (e-mail). Electronic mail (e-mail) is an application software system originally intended for textual messaging, but which now allows the attachment of other forms of information, including binary files, images, graphics and even digitized voice and video. Nonetheless, its primary use remains textual messaging (see Figure 5.3).

Figure 5.3 Electronic mail growth.

According to a 1995 Lou Harris survey of 505 chief information officers and senior executives, 62% of corporate employees, and 83% of government employees use e-mail. BIS Strategic Decisions estimates that the worldwide messaging market will grow from 45 million mailboxes in 1995 to 67 million in 1998 [5-25]. Others suggest that there already exist over 100 million e-mail addresses. It is estimated that well over 1 billion e-mail messages are sent monthly across the Internet, alone. For many of us, e-mail is the first thing we check at the start of the business day and the last tool we touch at day’s end. It has, indeed, become a fundamental mode of communications.

E-mail provides the ability to distribute information to large numbers of people, virtually instantaneously and very inexpensively. For instance, a 50-page document can be transmitted coast-to-coast in approximately 30 seconds using a high-speed modem. The cost of such a transmission is in the range of pennies rather than tens of dollars for overnight delivery via Federal Express or a similar service [5-26]. The dark side of e-mail, however, includes the fact that once the mouse is clicked, the message is sent and is irretrievable. Gone forever are the days when one dictated a sensitive letter and let it rest overnight in a desk drawer while emotions cooled so that it could be reread and edited in the light of brighter day. Getting darker, still, e-mail is a way for reckless employees to instantaneously expose company secrets, damage reputations, offend coworkers and create a host of legal problems [5-27].


Communications Systems and Networks:Messaging Systems: Facsimile, Voice Processing and Electronic Mail

The Technology

E-mail involves application software that resides on a computer platform of some description. E-mail was popularized as early as the 1970s, as part of the office automation concept. Typically residing on a midrange computer, early systems included IBM PROFS (PRofessional OFfice System), DEC DECmail (included in the All-in-One applications suite), and the Wang Office. The proliferation of PCs and PC LANs in the 1980s stimulated the growth of e-mail, which then became affordable and, therefore, accessible by a much larger community of potential users.

The contemporary e-mail network often is in the form of a dedicated server, to which client workstations gain access for messaging purposes—a client/server configuration. Clients, or user agents, are the workstations which create, transmit and receive the messages. They include software which effects compatibility with the server. Servers store messages and provide transport and directory services to the client. Various clients can be linked to a server through Application Programming Interfaces (APIs), messaging middleware (software which logically sits between client and server), and a driver package. Examples include Microsoft Messaging Application Programming Interface (MAPI) and Apple Computer Open Collaboration Environment (AOCE). Such APIs allow client applications such as word processing and spreadsheets to communicate with an e-mail server. In other cases, special drivers are required to access servers running such proprietary access protocols as DEC MailWorks 1.5 and MCIMail.

Servers may be in the form of a logically partitioned mainframe, mid-range, or PC computer platform. In large user organizations, the clients generally are LAN-attached. The server also may be provided on a service bureau basis, such as is provided by specialized carriers and online services including America Online, AT&T EasyLink, Australia Online, CompuServe, the Internet, MCI Mail, Prodigy, The Source, and The Well. Many client/server e-mail systems run equally effectively in several operating system environments, such as Windows, Macintosh, OS/2 and UNIX.

Networking

Although some e-mail networks are closed, most provide for Wide Area Networking (WAN networking) over a backbone, or centralized high-capacity network, in order to provide for message communications with the outside world. In any event, remote access generally is provided to employees, vendors, clients and others within the inner circle. Such islands are increasingly rare; servers typically support multiple protocols, with internetworking between disparate e-mail systems adding a great value to messaging technologies.

Protocols

Each e-mail network is governed by a set of protocols, which are the rules and conventions by which the network and component network elements, operate. Such protocols are embedded in the application software and the specific operating system (OS) or network operating system (NOS) which governs the manner in which the computer or computer network functions. Elements of the software that achieves compatibility between the client workstation and the server over the network generally resides on the client, as well as the server (Figure 5.4). E-mail protocols govern such characteristics as addressing conventions, routing instructions, message structure, and message transfer. Protocol examples include X.400, X.500, and various proprietary protocols [5-28].

Figure 5.4 Client/server e-mail, supporting multiple protocols.

X.400

X.400 is an ITU-T international protocol for e-mail document exchange. X.400 is compatible with the International Standards Organization (ISO) Open Systems Interconnection (OSI) model, functioning at Layer 7, the Application Layer. As depicted in Figure 5.5, X.400 allows disparate e-mail systems to interoperate at a minimal level, over either a X.25 packet nework or asynchronous dial-up circuits [5-29].

Figure 5.5 Networked e-mail (X.400).

X.500

X.500 is an international standard being developed jointly by the International Standards Organization (ISO) and ITU-T. X.500 provides for global directory services that theoretically allow network managers to store information about all users, machines, and applications in a distributed fashion. The current version of X.500 provides for directory replication functions that allow multiple copies of the directory information to be stored throughout the network, rather than residing on a centralized server. The current version also provides improved security through authentication access controls. Although X.500 has yet to be fully embraced by the software developers, Digital Equipment Corp., Isocor and others have incorporated X.500 into their proprietary e-mail products. A move currently is underway to place a X.500 directory on the Internet. Functioning like a telephone white pages, it would allow telephone and e-mail users to quickly find the addresses of other users, with certain security-oriented limitations [5-30], [5-31], [5-32], [5-33], and [5-34].

Proprietary protocols

Proprietary protocols include cc:Mail (Lotus Development), Lotus Notes (Lotus), Microsoft Mail (Microsoft), StreetTalk (Banyan Systems), BeyondMail (Banyan) and GroupWise (Novell). At the end of 1994 there were over 12 million users of the two most popular desktop e-mail systems, cc:Mail and Microsoft Mail; that is an increase of seven million over the previous year [5-35].

Through gateway technology, such as is in place on the Internet, mail systems that are not alike can interoperate. Gateway software acts as a protocol translator, or interpreter, converting from one native environment to another [5-36]. In this manner, cc:Mail and Microsoft Mail software can pass messages. Similarly, I was able to send drafts of this chapter and associated graphics from America Online to the publisher and editors; similarly, they were able to respond with edits until such time as the document was deemed satisfactory. To supplement this gateway process, various software available at no charge on the Internet was downloaded in order to preserve formatting (bold type, bullets, and left-justification).


Communications Systems and Networks:Messaging Systems: Facsimile, Voice Processing and Electronic Mail

Features

E-mail systems offer a growing number of features which commonly include time and date stamp, the ability to read, write, reply, and archive messages, as well as to attach or append files (text, binary, audio, video and image). Features also can include encryption for additional security, receipt confirmation, filtering (prioritizing), automated response and automated forwarding. The ability to build customized distribution lists allows a user to send a single message to large numbers of user mailboxes with the click of a mouse.

Applications

While e-mail traditionally has been text-oriented, it is now often appended with binary, audio, video and image files. Because the process of doing so is cumbersome and server-specific, true unified messaging has not been achieved. Nonetheless, e-mail has become essential for the conduct of business. Indeed, it is virtually universal, having found its way into personal use through online information services, connected via the Internet and mail gateways, which serve as protocol converters [5-37].

Future

Especially since the commercialization of the Internet, e-mail has become an indispensable tool in our professional and even in our personal lives. My daughter can attest to this fact, as she regularly sends e-mail requests for money from her college dormitory room. Future enhancements to, and issues surrounding, e-mail include unified messaging, remote access, and connectivity.

Unified messaging (Figure 5.6) extends across e-mail, voice mail, and fax technologies. E-mail messaging increasingly includes binary computer files, graphics files, image files, video files and even voice and audio files. While such attachments can be very bandwidth-intensive, they clearly enhance the effectiveness of the communication. As an admitted abuser of the Internet, I must confess to regularly sending multi-MB PowerPoint graphic files as e-mail attachments. While the ideal unified messaging system (providing a single mailbox for fax mail, e-mail, and voice mail) does not exist, the technology will develop to that point. More realistic is integrated messaging, which provides a single user interface in the form of a computer keyboard or telephone tonepad for accessing various mailboxes simultaneously in order to access multiple media on a coordinated basis [5-22], [5-38], and[5-39].

Figure 5.6 Unified messaging.

Remote access to e-mail also is increasingly popular. BIS estimates that over 10 million portable computers were in place in the United States. at the end of 1994 and that 4.6 million portables will be sold in 1995, an increase of 23% over 1994. Additionally, 5.1 million mobile professionals carry a laptop when they travel; two-thirds of those use that laptop for remote access to e-mail, even on a wireless basis [5-40].

Connectivity remains an issue, and likely will for some time. It is necessary that some minimum set of agreements be reached within the e-mail development community. Issues include commonality of header fields, end-to-end messaging services (priority transfer, confirmation notification, and security), addressing schemes, and management standards. For example, most LAN-based systems use SMTP (Simple Mail Transport Protocol) to pass e-mail to the Internet. Yet each SMTP gateway may deal with addressing schemes in a different way, causing conflicts during the process of message routing. Additionally, each e-mail system places different limitations on the size of file attachments. Finally, binary files typically get converted to text and then converted back to binary files on the receiving end, with the end result being a complete loss of formatting.

Junk mail plagues the e-mail community, just as it does the world of fax, voice mail, and regular mail. Advertisements, which once were considered a breach of e-mail etiquette, have become a fact of life on the Internet. Those of us who subscribe to technology magazines almost always are requested or even required to include our e-mail addresses in order that we can be deluged with junk mail from vendors. Perhaps the master of e-mail advertising is Promo Enterprises (Philadelphia, Pennsylvania), which sends electronic classified ads to 300,000+ mailboxes three times a week [5-41].


Communications Systems and Networks:Messaging Systems: Facsimile, Voice Processing and Electronic Mail

References

[5-1] Green, James Harry. The Irwin Handbook of Telecommunications. 2nd edition. Chicago, IL: Irwin Professional Publishing. 1992.
[5-2] Glossbrenner, Alfred and Emily. The Complete Modem Handbook. NY: MIS:Press. 1995.
[5-3] Grigonis, Richard. “Beyond Fax and Beyond.” Computer Telephony. August 1995.
[5-4] “How Network Fax Systems Work.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. November 1995.
[5-5] Coleman, Ken and Meley, Mimi. “Implementing Network Facsimile Successfully.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. February 1995.
[5-6] Warren, Stuart. “Fax Card Roundup.” Computer Telephony. August 1995.
[5-7] Lazar, Jerry. “The Truth About Fax.” Information Week. February 19, 1996.
[5-8] Bort, Julie. “Serve It Up with Fax On Demand.” InfoWorld. November 7, 1994.
[5-9] Cohen, Jodi. “New Standards Help Bridge Gap between Fax, Messaging Worlds.” Network World. November 14, 1994.
[5-10] “Evolution of the Fax.” Information Week. April 3, 1995.
[5-11] Hedtke, John. “Keep in Touch With Mobile Faxing.” Mobile Office. April 1995.
[5-12] Resnick, Rosalind. “Faxing From the Fast Lane.” Mobile Office. June 1995.
[5-13] Abate, Tom. “Fit to Fax.” San Francisco Examiner. May 19, 1995.
[5-14] Brennan, Tom. “Beware the Fax Beast.” Network World. November 27, 1995.
[5-15] Briere, Daniel D. and Kincaid, Caroline C. “Fax Networking Services: Overview.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. December 1994.
[5-16] Kalman, Steve. Beyond Voice Mail. Network World. August 7, 1995.
[5-17] Wolf, Robert. “A Primer to Using Voice Technologies.” TeleProfessional. March 1996.
[5-18] Radisich, Barbara Noble and Outlaw, Joe. “Voice Processing Systems: Overview.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. July 1995.
[5-19] Flash, Cynthia. “Press One for Voice Junk Mail.” San Francisco Examiner. November 19, 1995.
[5-20] Kinsey, Graeme. How Interactive Voice Response (IVR) Systems Can Boost Business Efficiency. Telecommunications. April 1995.
[5-21] Lenz, Mary. “IVR’s Role in The Help Desk.” Call Center. February 1995.
[5-22] Grigonis, Richard. “IVR—Complicated but Beautiful.” Computer Telephony. June 1995.
[5-23] Lenz, Mary. “Voice Processing Buyer’s Guide.” Call Center. March 1995.
[5-24] Foster, Peter and Schalk, Thomas B. Speech Recognition. NY: Telecom Library, Inc. 1993.
[5-25] Stahl, Stephanie. “Pumping Up Corporate E-Mail.” Information Week. June 12, 1995.
[5-26] Eager, Bill. “Online and the Bottom Line: E-Mail is Money.” Data Communications. March 21, 1996.
[5-27] McCune, Jenny C. “This Message is for You.” Beyond Computing. June 1996.
[5-28] Meier, Edwin E. and Meier, David C. “How to Avoid a Postal Career? Make Sure your E-Mail Works Well with your Network.” Communications Week. January 23, 1995.
[5-29] Myer, Ted. “Straight Talk about E-mail Connectivity.” Business Communications Review. July 1995.
[5-30] Schwartz, Jeffrey. “Is X.500 In Your Future?” Communications Week. June 17, 1996.
[5-31] Burkert, Debbie. “International X.500 Standard Makes Global Directory Searches Possible.” Network World. May 1, 1995.
[5-32] Gillooly, Caryn. “Finding the Way.” Information Week. January 1, 1996.
[5-33] Davis, Jessica. “X.500 Key to Internet Publishing, Commerce.” InfoWorld. November 27, 1995.
[5-34] Johnson, Johna Till. “An X.500 Method to Directory Madness.” Data Communications. May 21, 1995.
[5-35] McNamee, Giles W. “The Message Is the Medium.” Internetwork. October 1995.
[5-36] Delmonico, Dayna and Rist, Oliver. “It’s Not Your Father’s E-Mail Anymore.’” Communications Week. June 17, 1996.
[5-37] Baker, Richard H. Networking the Enterprise. NY: McGraw-Hill. 1994.
[5-38] Minifie, Tom. “Unified Messaging is a Key Productivity Aid in the Information Age.” Telemarketing & Call Center Solutions. May 1996.
[5-39] Snyder, Joel. “Roadblocks to E-mail Convergence.” Network World. November/December 1995.
[5-40] McCollum, Tim. “The Case for E-Mail.” Nation’s Business. May 1996.
[5-41] Crowder, Dave. “Junk E-mail Starting to Bulk Up Electronic Mailboxes.” USA Today. December 1, 1994.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

Chapter 6
Public Switched Telephone Network (PSTN)

Of the many wonderful scientific discoveries and inventions which have made the nineteenth century remarkable, certainly none is of more popular interest than the simple little piece of apparatus known as Bell’s articulating telephone. By this instrument it becomes possible to transmit ideas between far-distant places, not in the form of signs afterwards to be deciphered, but as actual articulations, an echo of those produced by the human voice at the point of transmission.

Wonders of the Universe, 1899

The old networks were designed around voice traffic, or Plain Old Telephone Service (POTS). Telegraphy was conducted over a separate, pre-existing network. As data, image, and video systems didn’t exist until many years later, there certainly was no requirement to network them. The characteristics of voice traffic were, and still are, well known and easily understood. Specifically, voice calls are occasional, short, bidirectional, continuous, and analog in their native form.

Voice calls typically are only occasional, as most humans have things other than talking on the telephone to occupy their personal and professional lives. Clearly there are exceptions, such as agents who work in call center environments as we examined in Chapter 4 during the discussion of ACDs. Human-to-human voice calls also tend to be short—three minutes or so, on average. Clearly, business calls tend to be short and to the point, while purely personal calls tend to be longer and more social. Additionally, some people (e.g., the author) tend to express themselves in very concise terms, while others (e.g., the author’s mother) tend to be very wordy. (The author begs the reader to hold this comment in confidence.) Voice processing, of course, tends to abbreviate voice communications as we noted in Chapter 5.

Clearly voice calls are conversational, or bidirectional, in nature. Further usage of the circuit is fairly constant, or potentially so. Regardless of the direction of the conversation (talking vs. listening) and the number and length of pauses in the conversation, the network is required to support the communication when it is active. In other words, voice is isochronous, or stream-oriented; the network must be available to accept, transport and deliver the communication when it is active. Finally, the native information is analog, rather than digital.

Analog transmission over copper twisted pair was quite suitable, and for many years this remained the case. Circuit switching also was quite suitable and still is, although it is giving way to other techniques (packet, frame, and cell switching). Manual switchboards eventually gave way to SxS, XBar, and ultimately, ECC switches. Switches were interconnected with other switches for longer distance connections, and so on. Contemporary networks, of course, are much more sophisticated, supporting huge volumes of voice, as well as data and even some level of video and image transmission. Analog has given way to digital, copper has yielded to fiber, and wires have given way to wireless communications in many applications.

As more people became comfortable with the telephone, more people subscribed to telephone service, which made the technology more useful. Businesses came to depend on telephony, and usage increased further. Costs began to drop, so that the technology became affordable, and usage increased even further. Long distance usage, which is highly profitable, began to increase, especially as rates were reduced.

Independent, privately-owned telephone companies sprang up all over the world, with thousands of them appearing in the United States; approximately 1,500 U.S. independents (non-Bell companies) still exist [6-1]. Around the turn of the 20th century, the Bell System had approximately 800,000 telephones in service, compared to about 600,000 for the independents [6-2]. In many cities and towns, there were multiple telephone companies operating in direct competition under franchises granted by the local government. In rural areas which were not commercially viable telephone cooperatives and municipally-owned telephone companies were formed, a number of which still exist.

Initially, these networks were isolated islands of local service; in other words, they were not interconnected. The telephone companies soon interconnected with each other and with the long distance network, usually under government/regulatory pressure. In the United States, the Bell System avoided providing interconnection, preferring to aggressively acquire the independent telephone companies and even acquiring a large block of stock in Western Union, its chief competitor. Under increasing pressure by the federal government under antitrust laws, Nathan C. Kingsbury, an AT&T vice-president, in December 1913 wrote a letter to the U.S. Attorney General to resolve various issues. Known as the Kingsbury Commitment, that letter committed AT&T to dispose of its holdings in Western Union, to purchase no more independent telephone companies without the approval of the Interstate Commerce Commission (ICC), and to make interconnection with the independent telephone companies. Eventually, standards were established to govern the nature and rules of interconnection. These standards are the responsibility of the ITU-T at the international level.

Many nations acquired or even confiscated the telephone networks from the private owners, forming Post, Telegraph and Telephone (PTT) agencies. The British government on January 12, 1912 assumed full control and ownership of the national telephone system, leaving the United States as the only major nation in which the network was privately owned. Eventually, access to telephone service was viewed as a basic human right in many industrialized nations. As a result, the concept of universal service was born; formed by an act of Congress in 1935, the Federal Communications Commission was chartered with accomplishing this goal. The motto (admittedly paraphrased) of the Bell System, for instance, became “universal service of the highest possible quality at the lowest possible cost.”

Governments have discovered that they cannot easily fund the capital-intensive upgrades their networks require and that they cannot effectively serve the communications needs of their constituents at reasonable cost. They also have come to recognize that the networks are immensely valuable assets that can be sold to fund various social programs. Therefore, the networks have been opened to competition in many nations. The networks also rapidly are being privatized, either completely or partially, with the government typically continuing to hold controlling interest for some period of time. As a result, service has become more universally available, the quality of service has improved, the range of services has increased and the overall cost to the user has dropped considerably.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

Network Characteristics

Each type of network can be described in terms of a number of key characteristics which define its basic nature and application. The Public Switched Telephone Network (PSTN) can be characterized as being designed for voice communications, primarily on a circuit-switched basis, with full interconnection between individual networks. The network is largely analog at the local loop level, digital at the backbone level, and is provisioned using wired facilities, for the most part.

Voice (Primarily)

The original network was designed to carry voice communications only. At the time, the only other form of telecommunications was telegraphy, which was the province of Western Union. The PSTN still exists primarily to support voice communications, although much data traffic also transverses the network. Image information can also be transported, as another form of data. Additionally, video traffic is supported through special videoconferencing equipment and interfaces of various types.

Switched (and Dedicated)

Contemporary voice networks are largely circuit switched, thereby providing great flexibility to the end users and significant economies to the carriers. Large organizations that communicate intensively between well-defined physical locations (headquarters, region and field locations) often employ dedicated circuits in order to mitigate network costs. Such dedicated circuits generally are leased from the carrier(s), making use of existing PSTN transmission facilities. In relatively rare instances, user organizations will deploy their own facilities, usually in the form of private microwave. In very rare instances, large end user organizations will purchase from the carriers a set of fiber optic facilities that can be used to connect the users' locations on a dedicated basis. Such optical fibers would be contained within a larger set of facilities deployed for the carriers own use and sold to the users on an as-available basis.

Analog (and Digital)

The traditional voice network was analog in nature and still is, in large part. The local loop connection terminating at the residence or business premise always is analog, unless arrangements have been made with the carrier for a digital circuit. Large user organizations often have digital connections in the form of T-carrier. ISDN, of course, is entirely digital, from end to end.

The internal telephone company networks and internetworks rapidly are being replaced with digital circuits for reasons which include improved bandwidth and bandwidth utilization, superior error performance and enhanced network management capabilities. This conversion process is largely complete in most major industrial nations and regions, including North America, Australia, New Zealand, Hong Kong, Japan, Singapore, and Western Europe. Developing nations and regions (The Philippines, Thailand, and Eastern/Central Europe) either are converting the PSTN to digital or are abandoning obsolete analog facilities in favor of constructing new digital networks.

Interconnected!

Complete interconnection between all local and long distance, and national and regional networks is fundamental to the PSTN. As discussed earlier, islands of telephony were interconnected many years ago in order that any subscriber might have the ability to connect to any other, subject to availability of transmission and switching capacity.

Wired (and Wireless)

While the traditional networks are largely wired (twisted pair, coax and fiber optic), a great deal of wireless technology is also employed. Wired networks generally perform better in terms of bandwidth, error rate, security and other dimensions, as discussed in Chapter 3. Fiber optic networks are particularly notable in these respects. While wired networks often are more difficult and costly to deploy and reconfigure, they are advantageous in the long term.

As wireless networks are plagued by limited radio spectrum, electromagnetic interference, lack of security, and other considerations, they generally are avoided in the architecture of the PSTNs of developed nations. Microwave, however, is used extensively in many networks, either as a primary means of connection where wired networks are impractical or as backup in the event of network overload or failure. Satellite communications also is used extensively for certain international communications and in order to provide access to island nations and remote areas. Wireless Local Loop (WLL) technology is still largely in the developmental stages, although it holds great promise.

Developing nations, however, make extensive use of satellite and microwave systems, and are deploying WLL aggressively. The advantages of wireless communications, as noted in Chapter 3, include rapid deployment and avoidance of certain issues of difficult terrain. As a result, the nation of India, for instance, is making extensive use of satellite communications to link thousands of remote villages. Similarly, remote towns in the outback of Australia are linked to the PSTN via satellite. Microwave is used extensively to link cities in island nations such as The Philippines and Malaysia.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

Numbering Plan Administration (NPA)

In order for any telephone to connect to any other telephone in the world, there must be in place a carefully developed and administered numbering plan. or logical addressing scheme. The ITU-T is responsible for numbering plan administration at the international level, with each nation or region having similar responsibility within its domain. For instance, Bellcore is responsible for the North American Numbering Plan (NANP), which was established in 1947 as a means of integrating the area code and central office exchange codes in the United States, Canada, and the Caribbean. Within each state in the United States, the dominant LEC (Local Exchange Carrier) read "BOC" administers the NANP [6-3].

The current international NPA convention specifies 12 digits, although the number of digits required for calling within a nation varies. In many cases, numbering schemes vary within the same country—for instance, six- and seven-digit telephone numbers co-exist in Australia during the period of transition to a full seven-digit convention. The ITU-T plans to implement a 15-digit international dialing scheme in 1996.

When dialing a telephone number, the user, in effect, is instructing the network to establish a connection between two physical addresses based on a logical address. Using a familiar example, the following logical addressing convention is followed establishing a connection originating from a physical address in Australia and terminating at another associated with this author’s business, The Context Corporation at 1500A East College Way, Suite 443, Mt. Vernon, WA, 98273 USA, at 0015.1.360.336.3448:

• 0015: 00 indicates that the call is international; 15 is the country code for the U.S.
• 1+ usually indicates that the call is crossing a Numbering Plan Area (NPA), or Area Code, boundary
• 360 indicates the NPA, or Area Code, which is a physical location—specifically, the area of western Washington surrounding the Greater Seattle metropolitan area and which happens to be in LATA 674.
• 336 indicates a specific Mt. Vernon central office exchange. These three digits are associated with an exchange which resides in a wire center, which may house several such exchanges.
• 3448 indicates the port and circuit ID, which is associated with a local loop, which, in turn, is associated with terminal equipment at The Context Corporation.

Through such a series of dialing steps, the logical address of The Context Corporation is translated, in steps, by the network in order to route the call to the intended party. Changes in the dialing scheme require changes in switch logic (COs and PABXs) in order that the switches can recognize the dialing pattern to be legitimate. The Context Corporation also has an 800 number, which the network translates into 360.336.3448 in order to route domestic calls on a toll-free basis.

Demand for telephone numbers has increased over the past few years as a result of the popularity of cellular telephones, fax machines, pagers and computer modems for access to the Internet—all of which require telephone numbers. As a result, the NPA has come under extreme pressure in the United States and internationally; hence the expansion of the international NPA dialing convention and the addition of 640 new area codes approved by the FCC in 1995 for use in the United States. The FCC currently expects another 88 existing area codes to be exhausted within the next ten years [6-4], [6-5], [6-6], [6-7], [6-8], [6-9], and [6-10]. The changes in the NPA have impacted the network to a considerable extent, as all network switches must be reprogrammed to recognize and honor dialing instructions under the new conventions.

In order to understand the implications of NPA changes, the difference between the old and new conventions must be understood. Traditionally, a U.S. area code was a three-digit, NNX number. In other words, the first and second digits were limited, while the third digit was not. Specifically, the first digit could be any number other than 1 or 0. Use of a 1 or 0 would confuse the network, which would interpret it as an instruction to provide access to an operator, connect a call across an area code boundary, or connect an international call. The second digit was required to be a 1 or 0, and the third digit could be any number. As the existing area codes were exhausted, the FCC opened the second position. Hence, The Context Corporation found itself removed from the Seattle 206 area code and established in the new 360 area code. For callers to reach the company, it was necessary that all involved switching devices be reprogrammed to recognize the validity of the new area code; thereby being able to process the call, rather than reject it. As a result, end users were required to make software changes in their CPE (PBX systems); the carriers also had to make software changes to all network switches. Not only were such software enhancements expensive, but some older switches could not be upgraded, thereby either denying access to the new number or requiring system replacements or peripheral equipment to be added to effect compatibility. The addition of 888 numbers to the In-WATS dialing convention will cause similar difficulties, as well as confusion for callers.

Domains

Perhaps the most effective initial means of examining the network is to consider the concept of domains, or spheres of influence. Specifically, the traditional voice network can be examined in terms of functional, regulatory, and carrier domains.

Functional Domains

Functional domains address the various functions performed in the PSTN. Customer premise equipment, switches, and transmission facilities all are physical elements of the PSTN, each performing specific functions, and all supported by a signaling and control system. At a higher level, the PSTN can be viewed in terms of its providing the functions of network access, transport, and service delivery.

Customer Premise Equipment (CPE)

CPE is the term used for send and receive equipment in the voice world. CPE generally is owned by the user, rather than rented from the telephone company, as was the case until the late 1960s. CPE includes voice terminals (telephone sets), key equipment, and PABXs.

Inside Wire and Cable

This includes all wires and cables inside the customer premise. Such wires and cables extend from the terminal equipment to the common equipment, such as a PBX or a Key Service Unit (KSU) in a Key System environment. Inside wire and cable extends to the demarcation point (demarc), which is the point of delineation between the customer premise and the carrier network.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

Switches

As was established in Chapter 2, switches are devices which establish connections over circuits or paths. In a traditional PSTN environment, such switches are circuit switches, which include Central Office Exchanges, tandem exchanges, access tandem exchanges, and International Gateway Facilities.

Central Offices (COs)

Also known as exchanges, COs typically are owned by the Local Exchange Carriers (LECs). COs provide local access services to end users via local loop connections and within a relatively small area of geography known as an exchange area. In other words, the CO lets a subscriber within that neighborhood to connect to another subscriber within that neighborhood. COs also provide a number of services, such as custom calling features (e.g., call waiting, call transfer and three-way calling) and Centrex. It also is through the CO that a subscriber typically gains access to the LEC metropolitan calling area, which does not involve a long distance (toll) charge. Finally, most subscribers also gain access to the various long distance networks through the CO, as well.

COs also are known as end offices, as they are at the terminal ends of the network. In other words, they are the first point of entry into the PSTN and they are the last point of exit. They also are known as Class 5 offices, the lowest class in the switching hierarchy. Manufacturers of COs include Lucent Technologies (5ESS); Nortel (DMS), which previously was Northern Telecom; Siemens (EWSD); and Ericsson (AXE).

Tandem Switches

These are network switches which serve in partnership with lesser switches, linking them together. Tandem switches typically serve to link together CO switches over dedicated interoffice trunks, forming a fully interconnected and toll-free metropolitan calling area in the process.

Access Tandem Switches

These switches act to connect the Local Exchange Carriers (telephone companies) to the Interexchange Carriers (long distance carriers), also over dedicated interoffice trunks, known as access trunks. It is in this manner that the local service providers typically are connected to the long distance providers.

International Gateway Facilities (IGFs)

These are the switches owned by the international carriers. Located at landing points on each end of the international connection, they provide connectivity between the international carriers, and the national and local carriers on each end.

Transmission Facilities

As was explored in Chapter 3, transmission facilities are the physical media and associated electronics which are used to provide the circuits in all domains of the PSTN. Oftentimes a combination of media is employed, perhaps including twisted pair, coaxial cable, microwave, satellite, infrared, and fiber optic cable.

Signaling and Control

These systems and networks are used to signal within the network and to control its operation. Examples include on-hook and off-hook indication, dial tone provision, call routing control, busy indication, and ringing.

Access

Access is best expressed as the local loop, the function of which is to provide access to the Wide Area Network (WAN). Access services extend from the customer premise to the LEC CO exchange, with the physical point of separation being known as a demarcation point or demarc. While generally provided by the LEC, access services increasingly are provided by competitors, such as IntereXchange Carriers (IXCs) and Competitive Access Providers (CAPs), also known as Alternative Access Providers (AAVs). Transmission facilities, switches, and signaling and control systems are all employed in an access environment.

Transport

Transport is information transportation over the PSTN. Transport is the responsibility of LECs, IXCs, and CAPs/AAVs, either individually or in concert, and depending on the geographic scope of the communication. Transmission facilities, switches, and signaling and control systems are all employed in a transport environment.

Services

Services include a wide variety of options provided by LECs, IXCs and CAPs/AAVs. Such services include various discounted calling plans, custom calling services, Centrex services, and toll-free (800/888) calling.

Regulatory Domains

There exists a complex set of domains that address regulatory and standards areas of responsibility. While it would be much simpler if these domains were discrete, there are overlapping domains with which one must contend:

International

Here regulation is largely nonexistent, although it is heavily influenced by the International Telecommunications Union-Telecommunication Standardization Sector (ITU-T), which is an agency of the United Nations (UN). Formed in 1865, as the Consultative Committee for International Telephone and Telegraph (CCITT), the ITU-T is responsible for setting standards recommendation intended to ensure the interconnectivity of national networks. The International Telecommunications Union-Radiocommunication (ITU-R), previously known as the Consultative Committee for International Radio (CCIR), is responsible for over-the-air communications. Intelsat and other consortia are responsible for allocating and managing satellite orbital slots.

The International Standards Organization (ISO) comprises a group of various national standards-setting organizations, including the American National Standards Institute (ANSI) from the United States. The ISO has great influence over international standards, and is best known for the development of the OSI (Open Systems Integration) Reference Model.

Regional

Regional authorities, although few in number, have the same responsibility within a more compact region. For example, DG XIII (Directorate General XIII) is responsible for such issues within the EC (European Community) of Western Europe. The EC has real authority in the areas of regulation and standards, establishing and enforcing policy matters such as network competition within a member nation’s network.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

National

National regulation is critical in most areas of the world, although less so in the case of the EC member nations, which have ceded a good deal of this privilege to the regional authority. For the most part, each nation has rules, regulations and standards which serve its requirements. Areas of influence often include such issues as competition, rates and tariffs, and radio frequency spectrum allocation. National authorities also determine the basis on which international carriers will be allowed to establish connections (landing points) in that nation for purposes of interconnection with the national network. Examples include The Federal Communications Commission (United States) and AUSTEL (Australia). New Zealand is most unusual in that the national network was entirely deregulated, with the regulator also being abolished; while no other nation has embraced that philosophy, the United States is considering abolishing the FCC.

State

State or province regulation is in place in many countries, such as the United States and Canada. Issues of intrastate competition, and rates and tariffs are managed at this level. State Public Utility Commissions (PUCs), also known as Public Service Commissions (PSCs) were formed in the United States beginning in 1937. In some cases, the state PUCs have taken the lead in terms of deregulation and competition. Illinois, for instance, for years and well before the federal Telecommunications Act of 1996, has allowed some level of competition within the local exchange. In Chicago, in specific, CAPs have been providing local and Centrex service in competition with the LECs.

Local

Local regulation enters the picture relative to local zoning ordinances which might dictate wireless tower placement and allowable height, CATV franchises, and cable right-of-way. In Milpitas, California, for instance, the local regulators demanded the right to levy franchise taxes against Pacific Bell when the LEC sought right-of-way permission to lay fiber optic cables to deliver CATV programming in competition with the incumbent CATV provider. PacBell refused to submit, arguing that it was regulated by state and federal governements rather than the local authorities. As a result, the Information Superhighway ground to a halt in Milpitas in 1994.

In some instances, local regulation predominates; Alaska and certain Scandinavian countries are unusual in that many of the LECs are municipally owned—commercial carriers had no interest in providing high-cost service in such sparsely populated areas.

Rates and Tariffs

Carriers traditionally have been required to file with the appropriate regulatory authority a set of tariffs, which describe the services which the carrier intends to offer in that domain; the rates which it proposes to charge for them; and the proposed obligations, rights and responsibilities of the both the carrier and the customer. The regulatory authority examines the tariff filing, holds public hearings on the proposal and renders a binding decision, which can be appealed by the carrier to the regulator or even through the judicial system [6-3].

The regulatory authority is in the form of a PUC (Public Utilities Commission) at the state level, with the authority to regulate intrastate issues. National regulation is the domain of the FCC, which has the responsibility to determine all interstate issues, including radio frequency allocation.

Regulators evaluate tariff filings and determine rate schedules based on a complex and varying set of considerations including allowable costs of service provisioning and support, which involves both capital investment and operating costs of the carrier. Particularly at the state level, an attempt is made to restrict rates to reasonable and affordable levels. At the same time, the regulator must permit the carrier a rate of return on investment (ROI) that is reasonable and which positions the company well to secure necessary funds for expansion and enhancement of its facilities through the capital (stock) and debt (bond) markets. Additionally, the regulators generally attempt to ensure that residential service is universally available at reasonable cost. As a result, business users traditionally have supported low residential rates through a complex set of cross-subsidies. Basic service rates for access services (local loops) generally are kept at low levels; enhanced services (e.g., voice mail, custom calling features and long distance) are considered to be optional and, therefore, are priced to yield more profit in support of basic services.

As the network monopolies were dismantled and the trend toward competition developed, the various regulators tended to focus on the incumbent and dominant carriers in their respective domains. Beginning with the Carterphone decision in 1968, carrying through the MFJ (Modified Final Judgement) in 1982 and continuing into the Telecommunications Act of 1996, the emphasis, therefore, has been on AT&T and the LECs. The intentions of the FCC and now the PUCs are to encourage competition by providing the new entrants with an advantage; once the incumbent carriers (AT&T and the LECs) have demonstrated that their positions are no longer dominant, the regulators relax restrictions on them in favor of allowing market forces to prevail. This intent has been demonstrated with respect in the IXC market, as the FCC gradually has relaxed its requirements of AT&T. This trend is expected to continue as a result of the Telecommunications Act of 1996, which will be discussed in detail in Chapter 16.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

Regulation traditionally has focused on voice network services, as they certainly are more basic and necessary than are data and other services, although this posture now can be argued and particularly so with the advent of the Internet. In fact, voice communications recently has become possible over the Internet through equipping a PC with a high-speed modem, speakers and microphone, and special software. Considered by many as a threat to the traditional PSTN and the concept of universal service, a number of interested parties recently have requested that the FCC examine the issue, with the intent that voice over the Internet be regulated or banned altogether. Interestingly, the major IXCs are not parties to this request. AT&T and others have taken strong positions as Internet service providers and intend to encourage its use. Voice over Frame Relay, an offering primarily intended for data communications, is possible as well, and increasingly is used where excess frame relay bandwidth is available. Although the cost of implementing voice over either the Internet or frame relay networks is a hindrance and although the quality of the voice communication generally is poor in either case, advances in technology promise to improve quality, lower cost and, therefore, threaten the PSTN. The Internet and frame relay will be discussed in length in subsequent chapters.

Local exchange competition, voice-over-the-Internet and voice-over-frame relay all threaten the concept of universal service, which has been a cornerstone of the PSTN since the formation of the FCC in 1934. In order to ensure the universal availability of voice service at affordable cost to the subscriber, a complex structure of settlements (subsidies) developed between IXCs and LECs. Thereby, a subscriber in a high-cost area such as Hackberry, Arizona could gain affordable network access, just as could a subscriber in New York despite the obvious cost differences in the carriers’ providing such service. Unless a universal service fund is established, with all carriers contributing, the concept of universal service may be relegated to a historical footnote.

Carrier Domains and Network Topology

Some years ago, and certainly previous to AT&T’s divestiture of the Bell Operating Companies in 1984, the network was relatively simple in terms of its ownership and topology. Each operating telephone company provided service in its franchised serving areas, and gained access to the AT&T long distance network on a fairly straightforward basis. Beginning in the late 1920s, the network was organized on a layered basis, with five levels of hierarchy, known as classes [6-3].

Class 5 offices are the local exchange offices, or central offices, serving end users through local loop connections. While the Class 5 offices were interconnected directly where high volumes of traffic flowed between them, they more commonly were interconnected via tandem switches. There exist approximately 19,000 Class 5 offices in the United States.
Class 4 offices were tandem toll centers, which served to interconnect Class 5 offices not directly connected. As the lowest class of toll center, these also served as the first point of entry to the long distance, or toll, network. Class 4 offices were interconnected within a relatively local toll network and provided access to higher order toll centers. In many instances, a Class 4 office also served as a Class 5 office; in other words, a hybrid switch served as both a central office and a tandem toll office, with the separate functions being provided through logical and physical partitioning within the switch. Approximately 1,500 tandem toll centers existed in North America prior to AT&T’s divestiture of the BOCs.
Class 3 offices, or primary toll centers, were higher-order toll centers, generally serving to connect Class 4 offices for intrastate toll calling. Class 4 offices typically served to interconnect independent telephone companies and BOCs. Approximately 200 such offices existed prior to divestiture.
Class 2 offices were known as sectional toll centers, which served to interconnect primary toll centers, largely for interstate calling within a geographic region such as the Northeast or the Southwest. There were approximately 67 sectional toll centers in the AT&T network prior to divestiture.
Class 1 offices, or regional toll centers, served to interconnect sectional toll centers in support of interregional calling. There were ten regional toll centers in place in the United States prior to divestiture; seven currently exist, with another two in Canada.

As illustrated in Figure 6.1, the offices were interconnected on a hierarchical basis, with end offices being at the bottom of the network food chain. As a user placed a long distance call, the network would examine and analyze the originating and destination telephone numbers and associated geographic areas. Based on that information, the network would process the call. Local long distance calls (e.g., within the San Francisco Bay area) would be handled either by directly connected Class 5 offices, or through a Class 4 tandem toll office. A coast-to-coast call, on the other hand, might involve all 5 classes of the hierarchy. For instance, a call from Turlock, CA to New York, NY originates in the Class 5 switch of Evans Telephone Company, an independent Telco company, and is handed to a nearby AT&T tandem toll center. The call then works its way up the hierarchy until it reaches the Class 1 regional toll center in San Francisco. High-capacity, coast-to-coast intertandem toll trunks carry the call to New York City, where it work its way down an abbreviated hierarchy and is delivered to the target number in Manhattan.

Figure 6.1 Traditional network hierarchy.

This approach was quite sensible in the days when AT&T dominated the local and long distance networks. As calls worked their way through the network, larger and larger volumes of traffic were aggregated by more and more capable switches and shipped over trunks of ever greater capacity, taking advantage of the economies of scale.

This network topology has been flattened over the years as the cost of transport over fiber optic facilities has dropped, the cost of switches has remained relatively flat, and competition has increased. As a result, there exist fewer, more intelligent and multifunction switches, interconnected by higher capacity transmission facilities in what is known as a sparse network configuration.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

Contemporary carrier and service provider domains can be categorized as local exchange, interexchange or national, and international. Competitive Access Providers (CAPs) are a relatively recent breed of carrier, typically focusing on the provisioning of direct access to the interexchange carrier through bypassing the local exchange carrier. Overlay carriers and wireless carriers also are relatively new entrants. While the domains can be segmented cleanly along these lines, changes in regulation are blurring the lines to a significant extent. This is particularly the case in the United States as a result of deregulation, culminating in the Telecommunications Act of 1996, which will be discussed in some detail in Chapter 16.

Customer Premise Equipment (CPE)

As was have noted, CPE is the terminal and switching equipment located on the customer premise. While such equipment, traditionally, was rented to the subscriber by the LEC, deregulation generally places the responsibility and privilege of ownership on the customer. Similarly, inside wire and cable generally is deregulated.

Demarcation Point (demarc)

This constitutes the boundary between the end user and carrier domains. In a residential environment, the demarc is in the form of a Network Interface Unit (NIU). NIUs include a protector, which serves to protect the premise wiring and equipment from aberrant voltages which might be induced by carrier power supplies, power utility transformers, or lightening strikes. Contemporary NIUs also are intelligent, allowing telephone company technicians or automatic test systems to regularly test the local loop from the central office to the customer premise. The NIU is located outside the residence, perhaps on an outside wall or in the garage, as the telephone company is not allowed to place equipment inside the premise under the terms of the MFJ.

In a business environment, the demarc is defined as being the closest logical and practical point within the customer domain. In a high-rise office building, for instance, it typically is defined as being a point of the entrance cable 12” from the inside wall. Newer entrance cable facilities involve a physical demarc, while older facilities typically are tagged by telephone company technicians in order to indicate a logical point of demarcation. From that point inward, the cable and wire system is the responsibility of the user and/or building owner, as appropriate.

Local Exchange Carriers (LECs)

LECs are franchised to provide local service, usually within the boundaries of a metropolitan area, state, or province. Their primary charter is to provide local voice services through a network of local loops and Central Offices (COs), which can be connected either directly or through a tandem switch, as depicted in Figure 6.2. The LECs also provide short-haul long distance service, Centrex, certain enhanced services such as voice mail, and various data services.

Figure 6.2 LEC metropolitan serving area, with COs interconnected directly and through a tandem switch.

The LEC landscape is dominated by the Bell Operating Companies (BOCs), which originally were wholly owned by the AT&T Bell System and which reported directly to AT&T general headquarters. Effective January 1, 1984, those 22 operating telephone companies were spun off from AT&T as a result of the Modified Final Judgement (MFJ). Also known as the Divestiture Decree, the MFJ was rendered by Judge Harold H. Greene of the Federal District Court in Washington, D.C. on January 8, 1982. The MFJ, in fact, was a negotiated settlement representing the culmination of the U.S. Justice Department’s long efforts to break up what it characterized as an oppressive monopoly. As a result, the BOCs were reorganized into seven Regional Bell Operating Companies (RBOCs), also known as Regional Holding Companies (RHCs) as noted in Table 6.1. Over time, several of the RBOCs (e.g., U.S. West) have fully absorbed the individual BOCs, creating a single entity with a centralized management structure. Cincinnati Bell and Southern New England Telephone (SNET) were not fully affected by the MFJ, as they were not wholly-owned subsidiaries of AT&T.

Table 6.1 Bell System operating company organizational structure, before and after the MFJ
Bell Operating Companies (BOCs), Predivestiture | Regional Bell Operating Companies (RBOCs), Postdivestiture
Illinois Bell | Ameritech (IL)
Indiana Bell |
Michigan Bell |
Ohio Bell |
Wisconsin Telephone |
Bell of Pennsylvania | Bell Atlantic (PA)
Diamond State Telephone |
The Chesapeake and Potomac Companies (DC, MD, VA & WV) |
New Jersey Bell |
South Central Bell | BellSouth (GA)
Southern Bell |
New England Telephone | NYNEX (NY)
New York Telephone |
Pacific Bell | Pacific Telesis (CA)
Nevada Bell |
Southwestern Bell | Southwestern Bell Corporation (TX)
Mountain Bell | US West (CO)
Northwestern Bell |
Pacific Northwest Bell |

In addition to causing AT&T to divest the BOCs, the MFJ effectively limited the BOCs to providing basic voice and data services within defined geographical areas, known as Local Access and Transport Areas (LATAs). These services included Intra-LATA toll service, also known as local long distance, within the confines of the 196 defined LATAs. Additionally, the BOCs and RBOCs were prevented from engaging in certain other activities such as manufacturing communications equipment, and providing enhanced services such as voice mail (the voice mail restriction was later lifted).

AT&T Long Lines, which became AT&T Communications, was restricted from providing Intra-LATA toll, as were MCI, Sprint, and the balance of the Other Common Carriers (OCCs). Those companies, which became known as Interexchange Carriers, were limited to providing long distance service on an InterLATA basis (across LATA boundaries). Further, AT&T was prevented from entering the local service business, although the OCCs were not limited in that respect.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

AT&T Technologies was formed of Western Electric, the manufacturing arm of AT&T, and AT&T Bell Telephone Laboratories (Bell Labs), the research and development organization. Of all the AT&T entities, only Bell Labs was allowed to retain the Bell name. The RBOCs, in consortium, formed Bell Communications Research (Bellcore) as a R&D entity. Bellcore continues to focus on the needs of its RBOC client/owners in terms of software R&D, standards development and other requirements. Under the terms of the MFJ, Bellcore is precluded from involvement in the physical sciences [6-11] and [6-12]. The RBOCs recently announced their intentions to divest Bellcore, as their individual interests no longer are compatible in a deregulated environment—in fact, they are now competitors.

In the United States, LECs traditionally had the exclusive rights to local and intraLATA markets, although this policy either eroded or was modified in many states; Connecticut, for instance, has allowed local exchange competition since July 1, 1994. The Telecommunications Act of 1996, which will be discussed in Chapter 16, has set the stage for complete and open competition for virtually all services. However, the distinctions remain valid at the time of this writing.

In addition to the RBOCs and their LEC subsidiaries, approximately 1,500 independent telephone companies exist, according to the United States Telephone Association. In fact, GTE is the fourth largest LEC in the United States, ranking behind BellSouth, Bell Atlantic, and Ameritech. Sprint, Southern New England Telephone, and ALLTEL are among the larger independents.

The Telecommunications Act of 1996 will change this landscape dramatically. Casting aside the MFJ, that act allows the IXCs to immediately begin competing with the LECs for local and intraLATA service. Similarly, the RBOCs can offer interLATA long distance service outside the states in which they operate as LECs. Once the RBOCs have satisfied certain local competition requirements, they will be allowed to offer interLATA toll services within their home states, as well.

InterEXchange Carriers (IXCs or IECs)

These are responsible for long-haul long distance connections across LATA boundaries. The IXCs networks are connected to the LECs through a point of presence (POP) which typically is in the form of a tandem switch. An InterLATA call originating in a LEC serving area is recognized as such and is passed to the IXC through an access tandem switch which, in turn, is connected to the POP via dedicated trunks leased from the LEC (Figure 6.3). Alternatively, the IXC may collogate the network termination equipment in the LEC exchange office, assuming that space is available and that secure physical separation can be established and maintained.

Figure 6.3 Interconnection between LEC and IXC via access tandem switch and via collocated termination equipment.

Increasingly, large users seek to gain direct access to the IXC POP, bypassing the LEC switching network in the process. Such a bypass arrangement typically is effected through a leased line provided by the LEC; alternatively the LEC can be completely bypassed through a direct link, which often is in the form of microwave provided by the IXC. IXCs also can be accessed through a CAP/AAV, which typically provides fiber optic cable connections directly from the customer premise to the IXC POPs, totally bypassing all LEC facilities.

IXCs, by definition, are facilities-based, or heavy, carriers. While they prefer to contract directly with large end users, they also often work through resellers (light carriers) and agents. Of the 400 or so heavy carriers, AT&T with 55.2% of the market, MCI with 17.4%, Sprint with 10.1% and LDDS WORLDCOM(previously Wiltel) with 4.7% are the largest, by far. Based on 1994 statistics from the FCC; the total size of market was $67.351 billion [6-2].

Competitive Access Providers (CAPs)

CAPs, also known as Alternative Access Vendors (AAVs) provide an alternative means of connection between large user organizations and IXCs, completely bypassing the LEC network in the process. CAPs deploy high-capacity, fiber optic facilities from IXC POPs to areas where there exist a high density of large user organizations (commercial office parks and urban business areas) as depicted in Figure 6.4. In many cases, the CAP will extend the fiber optic connection directly to the user’s CPE, such as a PBX.

Figure 6.4 End user access to IXC via CAP, bypassing the LEC.

There are numerous benefits of such an approach, including the fact that the performance characteristics of the fiber optic facilities are far superior to the traditional LEC copper local loop. Additionally, the CAP network automatically provides a measure of local loop redundancy—the CAP facilities are used for IXC access, while the LEC local loops can still be used for IXC access in the event of a failure in the CAP network. Further, the CAP’s fiber optic network generally is redundant, thereby minimizing the likelihood of a service-affecting network failure. As the fiber optic network also offers substantial bandwidth, the user organization typically can increase its level of access to the IXC much more quickly and easily than would be the case through a LEC connection. Call set-up time (speed of connection) also is improved, as the LEC CO, tandem switch and access tandem switch all are bypassed. Finally, the costs of IXC access often are much reduced as the CAP’s unregulated rates generally are highly competitive; additionally, Subscriber Line Charges (SLCs) are avoided.

CAPs/AAVs operate most especially in the United States, where they now provide Centrex service, local calling service, high speed data services, and certain enhanced services. CAPs operating in the United States include Metropolitan Fiber Systems (MFS), Electric Lightwave, and Teleport Communications Group (TCG) [6-1].

International Record Carriers (IRCs)

IRCs are carriers of record which provide communications transport services across national borders. Access to the IRC from the LEC or IXC domain is accomplished by connection to an International Gateway Facility (IGF) which connects to the IRC’s transmission network. Contemporary IRC transmission facilities are largely satellite and submarine fiber optic cables, the latter often being jointly owned through consortia. Examples of IRCs include AT&T, Cable & Wireless (C&W), HongKong Telecom International (HKTI), and MCI.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

Overlay Carriers

Overlay Carriers build networks which overlay the traditional PSTN. While such networks are unusual in highly developed countries, they are common in developing nations. In some countries of Eastern/Central Europe, for example, private carriers have been franchised to build overlay digital microwave networks to provide service to large government, education and commercial organizations. In such cases, the PSTN simply could not be upgraded quickly to provide satisfactory communications, which are considered vital to economic growth.

Wireless Carriers

While wireless traditionally has been limited to mobile radio, cellular telephony and wireless data networks, wireless carriers will soon challenge the LECs through Personal Communications (PCS) and Wireless Local Loop (WLL) technologies. The ability to bypass the incumbent telephone company on a wireless basis is a significant competitive threat. In a number of developing countries, however, PCS/WLL is likely to be the primary means by which the telephone companies extend their networks in order to provide more universal service. Examples abound in Asia and Central/Eastern Europe.

Signaling and Control: An Expanded View

In order for the network to function properly, the various components or of the network must have the capability to signal each other, indicating their status and condition. Typical status indications might include available (dial tone), unavailable (busy), and available (ringing signal).

Additionally, the devices must pass identification information, as well as certain instructions through the network, perhaps as far as to the receiving terminal. Such information and instructions might include originating number or circuit, and target number, based on dialed digits. Within the carrier network, such information includes route preference and route availability [6-3]. Additionally, it is necessary that the network determine and honor the end users’ designated IXC carrier in order that a long distance call can be handed-off to the carrier of choice.

Signaling and control systems and networks also are responsible for handling billing matters, perhaps querying centralized databases in the process. Billing options might include bill to originating number (DDD and WATS), bill to terminating number (INWATS or 1-800/1-888), bill to third number (third party) and bill to calling card, with verification of PIN against a database.

Finally, certain network management information is often passed over signaling and control links. Such information is used for remote monitoring, diagnostics, fault isolation, and network control. In this fashion, the network can be monitored from a centralized operations center, and faults or degradations in performance can be determined and isolated. Diagnostic routines can then be invoked in order to determine the specific nature of the difficulty. Finally, the network element in difficulty often can be instructed to resolve the problem, perhaps by resetting or reinitializing itself, or by disabling a failed port and activating a standby port.

In-Band Signaling and Control

In-band signaling and control functions take place over the same physical path as the conversation, and occupy the same frequency band. As the impact of simultaneous conversation and signaling is most unpleasant, it is seldom used in contemporary networks, with the exception of analog local loops.

By way of example, the author frequently calls long distance to talk with his son in East Texas. During those conversations, the young man has a habit of accidentally depressing the buttons on the tonepad with his chin. The resulting multifrequency tones, interpreted by the network as a priority instruction set, interfere with the conversation as they occupy the same range of frequencies at the same moment in time.

Out-Of-Band Signaling and Control

Out-of-band signaling and control, in the simplest analog application, takes place over frequencies separate from those that carry the information; therefore, there is no interference between the two functions. In a digital network, signaling and control occupies separate, designated time slots; once again, interference is not an issue. Out-of-band signaling and control is the standard approach in digital networks and, most certainly, in the internal carrier networks.

Common Channel Signaling and Control (CCS)

Common Channel Signaling and Control (CCS) systems are used by the carriers in order to carry large volumes of signaling and control information in support of high-traffic networks. CCS links are digital in nature and involve high-speed links that generally are fiber optic. The CCS network is, in fact, a highly robust subnetwork that supports the operations of the primary communications network. The CCS network often is in the form of a separate network which connects the various network switches to centralized computer systems of significant intelligence and on which reside very substantial databases. Through the use of centralized intelligence supported by carefully synchronized databases, the operations of an entire network can be controlled and its performance monitored, from end to end. While complicated and expensive to design and deploy, CCS networks are more effective and less costly than the alternative of placing lesser levels of intelligence in each of the various network switches, each of which would be required to perform redundant processes in complete harmony.

Signaling System 7 (SS7), the current version, was developed and is deployed based on ITU-T standards. Thereby, all carriers can achieve and manage interconnection on a standard basis (Figure 6.5). SS7 significantly speeds call setup and call completion processes. Additionally, SS7 is responsible for the delivery of many enhanced custom calling features often associated with ISDN. These CLASS (Customer Local Access Signaling Services) services include Caller ID, which recently has been enhanced in some areas as Name ID, including the name of the calling party as listed in the telephone directory. Other services include Selective Ringing (or Priority Ringing), Selective Call Forwarding, Call Block (or Call Screen), Repeat Dialing, Call Trace, and Automatic Call-Back (Call Return). In 1995, most RBOCs planned to have SS7 installed in at least 90% of their backbone networks [6-1].

Figure 6.5 Signaling System 7 (SS7) in support of LEC and IXC networks, interconnected.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

Network Services

Network services can be grouped into several categories which define their basic nature. Those categories include access services, dedicated services, switched services and virtual services.

Access Services

Access services are those services which provide circuit access to the network, generally to the LEC central office. They may be analog or digital, and single channel or multichannel. Access services include residential and business lines, and PBX trunks.

Residential lines

Residential lines are local loop connections between the residential premise and the central office exchange.

Business lines

Business lines are local loop connections between the business premise and the central office exchange. Business lines provide access to single line and multiline terminal sets, as well as to Key Telephone Systems (KTSs).

PBX trunks

PBX trunks are local loop connections between PBX switches and network switches. As noted in Chapter 4, PBX trunks may be incoming only, outgoing only, or bidirectional (combination). Trunk connections may be provisioned individually, although they more typically are provisioned on a high-capacity, multichannel basis. Trunks which serve specific purposes are grouped into trunk groups.

Dedicated Transport Services

Dedicated circuits, in the traditional sense, are leased-line circuits which are dedicated to a specific use by a specific user organization. Again, they may be either analog or digital, and either single channel or multichannel. Dedicated circuits typically are provided by the LEC on an intraLATA basis, although CAPs also provide such circuits to the extent that their facilities match user requirements. InterLATA leased lines currently must be provided by an IXC, typically with the LEC or CAP providing the local loop and connection to the IXC POP, and the IXC providing the InterLATA portion to the destination POP where the circuit interfaces with the LEC serving the distant location.

Foreign EXchange (FX or FEX)

Foreign EXchange (FX or FEX) lines or trunks connect the user premise more or less directly with a foreign exchange, that is with an exchange other than the local exchange which normally would provide local dial tone. FX circuits generally are billed at a given cost per mile or kilometer, or fraction thereof, rather than on a usage-sensitive basis. A user organization can lease a FX circuit from Dallas, TX to Denton, TX to support outgoing and incoming traffic between those general areas; the circuit terminates in Dallas CPE but has a Denton local telephone number.

Tie line/trunk

Tie line/trunk circuits, as described in Chapter 4, connect KTS/PABX systems together directly and across the PSTN, although without the involvement of switching processes. Between two PBX systems, for instance, the carrier(s) provide dedicated circuits which pass through wire centers housing network switches. The circuits bypass the switches, which are unnecessary in this context, yet take advantage of amplifiers or repeaters, multiplexers, and other systems embedded in the carrier network.

Off-Premise Extension (OPX)

Off-Premise Extension (OPX) circuits are dedicated PSTN circuits that connect a PBX or KTS system to an extension terminal which is off-premise. The terminal appears exactly as would an on-premise extension, providing the user with the same level of functionality. OPXs are unusual, as both the circuit and the special purpose system interface card are expensive. Additionally, and as contemporary users are not expected to be office-bound, voice mail, cellular telephony, page, and other technologies are adequate alternatives for most situations.

Switched Transport Services

Switched services include all typical local and long distance voice traffic, whether inbound or outbound. Specific services include DDD, WATS, Virtual WATS, In-WATS, 500, and 900/976. Deregulation, divestiture, and resulting competition served for many years to reduce the costs of these services, and very significantly. During the past year or so, however, the cost has increased slightly. Long distance charges, for instance have increased about 6% since January 1, 1995 [6-13].

Message Telecommunications Service (MTS)

Also known as Direct Distance Dialing (DDD), 1+ dialing, MTS involves long distance calls which are placed by the user on a dialed basis, rather than involving the intervention of an operator. Such calls generally are billed on the basis of a combination of distance, duration, and time of day. Discounts apply to long duration and off-peak calls. DDD calls may be short-haul IntraLATA (LEC), long haul InterLATA (IXC) or international in nature. While the last manual exchange in the US was converted to dial many years ago, operators must still act on long distance calls in some developing countries, particularly in the case of International DDD (IDDD).

Wide Area Telecommunications (WATS)

Much like DDD service, WATS is billed according to a variety of discount plans for large user organizations. WATS originally required special purpose outgoing trunks which were designated as having access to specific areas of the country according to mileage bands 1 to 5, which were presented as concentric areas of coverage. Band 1, for instance, provided intrastate coverage, while Bank 5 provided full national coverage. The greater the area of coverage, of course, the higher the cost of the WATS service. Traditional WATS was provided on a fulltime or a measured basis. Fulltime WATS could be characterized as all-you-can-eat WATS as it was billed at a flat rate, with no usage monitoring or billing. Measured WATS was billed on a flat rate for the first 10 or 20 hours of usage, with overtime charges applying to traffic over the threshold. Clearly, the process of analyzing traffic patterns and configuring an optimum WATS network, with overflow to DDD, could be a fairly complex process.

Banded WATS has been abandoned in favor of 1+ WATS, also known as Virtual WATS, enabled by increased network intelligence, and encouraged by increased competitive pressure. Virtual WATS simply involves a discounted billing arrangement involving a small monthly fee and discounted usage that is sensitive to calling volume and volume commitment. The traditional requirement for special purpose circuits no longer exists, as the originating circuit and user are identified by the billing systems, with the appropriate rating algorithm being applied at the time the bill is rendered.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

In-WATS

Also known as 800 Service, In-WATS is much like Virtual WATS, with the billing being reversed to the receiving party. In-WATS (1-800) service has become so popular in the US that the supply of numbers is exhausted. 1888 numbers will address this shortage; 877 and 876 numbers also are being considered, as is the expansion of 800 numbers to 8 digits [6-14], [6-15], [6-16], and [6-17]. In 1994, approximately 13 billion In-WATS calls were placed, yielding service revenues of approximately $9.49 billion, according to the MultiMedia Telecommunications Association. Although 1994 revenues are estimated to have increased approximately 16.6% over the previous year, compound growth is estimated in the range of 6.7% through 1998 [6-1]. Outside the United States, In-WATS service is known by various terms, including Freephone and Green Number, is accessed through various dialing conventions, including 0-800 and 0-500. The ITU-T plans to implement in 1997 a new numbering convention for International Freephone Service, which will involve dialing 800 + 8 digits.

In-WATS is an effective means of encouraging current and prospective customers to call, as they incur no toll charges. It also is a cost-effective means for employees who travel or who work at remote locations to access various company offices. With the billing reversed to the target number, the company is relieved of the cost of processing expense vouchers for telephone charges; further, the cost of the call is far less than is a call charged to a calling card.

In-WATS was the first instance of an intelligent network service. The In-WATS numbers (800 or 888) dialed are not real telephone numbers, at least not in the classic sense. That is to say that they do not conform to the standard numbering scheme, wherein a telephone number (logical address) relates directly to a physical location (physical address) based on a standard numbering convention. Rather, an 800 number can be directed literally to any location. In order to direct the call to the proper physical location, it is necessary that the network query a database of 800 numbers in order to translate that number into a conventional number associated with a specific physical location. Additionally, the database will advise the originating LEC as to how the call should be routed. In the case of an interLATA call, the call will be routed to the IXC with which the target user has an In-WATS relationship [6-18]. LECs also offer 800 services, currently limited to intraLATA calling. The total 800 services market in the United States was estimated at $10.1 billion for 1995 and is expected to reach $12.4 billion by 1998. The international Freephone market grew from $150 million in 1992 to approximately $502 million in 1994 [6-1].

500 numbers

Aa relatively new phenomenon in the United States, 500 numbers provide follow-me services. From a remote location, the subscriber may access the network logic in order to program (or reprogram) a priority sequence of numbers to which calls should be forwarded, with such a sequence perhaps including a cellular number. A single number can be used for both voice and fax, with facsimile routing being invoked through a special dialing instruction, such as * or #, after a voice prompt. 500 numbers soon will provide the capability to selectively forward calls received only from those who have knowledge of a Personal Identification Number (PIN). 500 numbers effectively offer the first set of capabilities promised by Personal Communications Services (PCS); one number can be retained for life, transportable across carriers, and carrier domains.

AT&T offered a similar service a few years ago in the form of 700 services. The service provided follow-me call forwarding, although only AT&T long distance subscribers could access a 700 number. No companies currently are marketing 700 services [6-19], [6-20], and [6-21].

900/976

900/976 services are information services which carry either a flat cost per call or a cost per minute which is the responsibility of the calling party. The revenues are divided among the sponsoring party receiving the call and the various carriers involved. Originally intended for applications such as telethons and informational services, 900/976 services have gained a bad reputation, as many providers of telephone sex and other questionable services make extensive use of them. Although they dropped significantly in 1992, revenues are estimated to have reached $722 million in 1995 [6-1].

Virtual Private Network (VPN) Services

Virtual Private Network (VPN) or Software-Defined Network (SDN) services are intended for use by very large user organizations. VPNs/SDNs create the effect of a private, leased line/trunk network, but without the associated design, deployment, cost and vulnerability issues. VPN services generally are arranged with an IXC, with the points of network termination (company locations) being identified, along with the level of bandwidth required for each. Dedicated circuits are established between each point of termination and the closest capable IXC POP. Internal to the carrier network, dedicated circuits are not established to interconnect the various customer locations (Figure 6.6). Rather, routing tables are established to route the traffic over specified high-capacity transmission facilities on a priority basis, thereby ensuring that the level of service provided is equivalent to that of a true private network. The carrier realizes the benefit of sharing the involved network with other users, passing on the savings to the VPN customer.

Figure 6.6 Virtual Private Network, U.S. domestic.

VPNs offer the advantage of scalability, as new sites can be added and bandwidth to individual locations can be increased, with the incremental cost maintaining a reasonable relationship with the increased functional requirement. Additionally, configuration and reconfiguration effort and expense are reduced, as the only significant requirement is that the points and levels of access be considered. Clearly, the time frame associated with carrier provisioning or reconfiguring such a network also is reduced, as dedicated circuits need not be provided between the various points of termination. Further, such a network is more resilient than a truly dedicated network, as the carrier network is highly redundant. Therefore, the carrier quickly can route traffic around a point of blockage or catastrophic failure [6-12].

While VPNs may be international in scope, they are generally limited to calling on a domestic basis or between two nations. BT and MCI, through their Concert offering, recently announced multicountry calling capability.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

Value-Added Services

Value-added services are defined as those that alter the form, content, or nature of the information, thereby adding value to it. Examples include store-and-forward services such as voice mail, email and fax mail. In the data world, networks that accomplish the process of protocol conversion are considered as providing value-added services. Value-added services increasingly are offered by carriers of substance.

Portability

Portability of numbers is an issue of real significance, and increasingly so. Traditionally, all numbers have been associated with either a geographic area (e.g., NPA and exchange code), a carrier (e.g., 800 and 500 numbers) or a service offering such as DID. Given the fact that users prefer to retain the same number (logical address), regardless of physical location, carrier or service offering, there is a movement to satisfy that desire. The intensity of the issue is increased through the development of competitive alternatives, not only for IXC services, but also for local loop service.

In the United States, 800/888 numbers have been portable across carriers since 1992, although they are restricted by LATA boundary. In other words, and for the most part, only LECs can offer intraLATA 800 services. Similarly, only IXCs can offer interLATA 800 services. Such restrictions will be lifted in the near future, as the LECs satisfy the requisite conditions of the Telecommunications Act of 1996. Outside the United States, portability is a most unusual exception to the rule.

Portability of local numbers is viewed as an issue of increasing significance, especially given plans for local service competition under the provisions of the Telecommunications Act of 1996. In order to accomplish such a level or portability, even within a given geographic area, substantial investments must be made in the necessary centralized intelligence and database technology, much as was the case with 800 services. It currently is unclear how such an investment will be funded. Currently, telephone number changes are required if a user shifts local service allegiance from the LEC to a CAP. This fact should not be surprising, as the NANP is locally administered by the largest BOC, which has a less than compelling incentive to be flexible in that regard. As a footnote, 500 numbers and 900 numbers (which are not geographically specific) currently are not portable across carriers, although the FCC has determined that such portability would be in the public interest [6-1], [6-21], and [6-22].

The ultimate in portability is the concept of Personal Communications Services (PCS), which will be discussed in Chapter 12. PCS involves inexpensive wireless phones which will offer two-way access anywhere, anytime for voice, data, video and image communications. PCS, at least theoretically, will allow an individual to hold a number (logical address) for life. That number will serve many devices (voice telephones, fax machines, and computer modems), with the caller being prompted to make the appropriate selections and with the called party controlling options for the restriction of such privileges. While in the early stages of development and deployment, PCS likely will have great impact early in the next century.

Equal Access: Another Special Issue

Equal access is intended to ensure that the end user can access any IXC with equal ease. In other words, a user can dial a long distance call from a residence or business simply by dialing the telephone number, without a requirement for dialing special access codes. Equal access is intended to facilitate a competitive environment through removing unnecessary technical barriers. Prior to its implementation in the United States, access to an IXC other than AT&T required dialing an access number to the carrier, an authorization code and the target telephone number. This requirement clearly placed other carriers at a competitive disadvantage.

The implementation of equal access requires that users in a specific geographic area be surveyed and afforded the right to choose a carrier on the basis of pre-selection. Users not responding are assigned a default carrier with such defaults being selected randomly and spread across the available carriers based on their respective market penetration. All user choices or default selections are noted in a centralized database residing on a database server, which is queried as each call is placed. Based on the ID of the originating circuit, the database is consulted and the call is connected through the designated IXC carrier. This same process can apply equally to all outgoing calls, regardless of distance (i.e., local, intraLATA, interLATA and international), subject to regulatory approval and deployment of the technology.

Alternatively, the user can access the carrier through dialing an access number (10XXX). Such a technique would be used in order to place a call through another carrier in the event of a failure or blockage of the network of the primary carrier.

Access charges are intended to compensate the LEC for the costs of connecting the call across expensive local loop facilities, conducting the pre-selection survey, investing in the database server and administering the equal access database. While the structure of access charges varies from country to country, they include some combination of Subscriber Line Charges (SLC) and Carrier Access Charges.


Communications Systems and Networks:Public Switched Telephone Network (PSTN)

Subscriber Line Charges

Subscriber Line Charges (SLC) are billed to the user by the LEC on a monthly basis. They are flat-rate, recurring charges which generally vary by type of facility (residence line, business line, PBX trunk, and FX line). They may be billed by channel, as has been proposed by the FCC for ISDN loops. The SLC applies to all users of LEC loops, whether or not they use the LEC network for IXC access.

Carrier Access Charges

Carrier Access Charges are billed by the LEC to the IXC in two forms. First, flat-rate, recurring charges apply for Tandem Exchange termination. Second, Carrier Common Line Charge (CCLC) is a minutes-of-use charge which applies to each call connected to the IXC.

As a result of the relandscaping of the telecommunications environment under the terms of the Telecommunications Act of 1996, the FCC will reconsider the levels of all access charges no later than May 1997. AT&T and a number of other carriers suggest that the SLC should double and that the CCLC should be eliminated. For example, AT&T suggests that the SLC for residential single line circuits should increase from $3.50 to $7 per month, and from $6 to $12 for business multiline circuits (KTS business lines). Regardless of the level of increase in the SLC, it will make basic service more expensive, perhaps making it unaffordable for some. To the extent that the SLC is increased and the CCLC is decreased, overall benefit will be realized by large business users which are long distance-intensive [6-23] and [6-24].

References

[6-1] 1996 MultiMedia Telecommunications Market Review and Forecast. Washington D.C.: MultiMedia Telecommunications Association. 1996.
[6-2] Brooks, John. Telephone: The First Hundred Years. NY: Harper & Row, 1976.
[6-3] Engineering and Operations in the Bell System. NJ: Bell Laboratories. 1977.
[6-4] Greene, Tim. “Bells Bond to Spread the Word on New Area Codes.” Network World, May 20. 1996.
[6-5] Potter, David C. “Cracking the NANP Code.” Telecommunications. October 1995.
[6-6] Potter, David C. “Surviving the North American Numbering Plan.” TeleProfessional. March 1996.
[6-7] Toth, Victor J. “Winners and Losers in FCC’s New NANP System.” Business Communications Review. October 1995.
[6-8] Toth, Victor J. “Preparing for a New Universe of Toll-Free Numbers.” Business Communications Review. November 1995.
[6-9] Greene, Tim. “Phone Numbers Are Running Out.” Network World, May 20. 1996.
[6-10] Rohde, David. “Those #$ (&%*!% Area Codes.” Network World. September 18, 1996.
[6-11] Tunstall, W. Brooke. Disconnecting Parties. NY: McGraw-Hill, Inc. 1985.
[6-12] Elbert, Bruce R. Private Telecommunication Networks. Norwood MA: Artech House. 1989.
[6-13] Hills, Michael T. “Long-Distance Pricing 1996—Yikes!” Business Communications Review, May 1996.
[6-14] Bodin, Madeline. “You Should Be Worried.” Call Center. September 1995.
[6-15] Rohde, David. “Bitter Pill: 800 Numbers Rationed.” Network World. June 19, 1995.
[6-16] Harder, Jerry. “The Brave New World of Toll-Free Service.” Business Communications Review. February 1995.
[6-17] Rohde, David. “Need an 800 Number? Hurry Up, Supply’s Low.” Network World. January 9, 1995.
[6-18] Rebber, Roger. “Parade of Carrier Options.” Call Center. February 1996.
[6-19] Taff, Anita. “Follow-Me Phoning.” Mobile Office. November 1995.
[6-20] Greene, Tim and Wexler, Joanie. “Follow-Me Phone Numbers Available.” Network World. February 15, 1995.
[6-21] Seybold, Andrew M. “Follow-Me Phone Numbers.” Mobile Office. August 1995.
[6-22] Toth, Victor J. “The FCC’s Complex Plans for Local Number Portability.” Business Communications Review. September 1995.
[6-23] Rohde, David. “Subscriber Line Charge Headed Up.” Network World. May 20, 1996.
[6-24] Rodger, Will. “Are Bells Inflating Telephone Rates?” Inter@ctive Week. May 20, 1996.

General References

1996 MultiMedia Telecommunications Market Review and Forecast. Washington D.C: MultiMedia Telecommunications Association. 1996.
Elbert, Bruce R. Private Telecommunication Networks. Norwood, MA: Artech House. 1989.
Engineering and Operations in the Bell System. NJ: Bell Laboratories. 1977.
Gasman, Lawrence. Manager’s Guide to the New Telecommunications Network. Norwood, MA: Artech House. 1988.
Introduction to Telecommunications. Phoenix, AZ: AG Communications Systems. 1990.
Keen, Peter G.W. and Cummins, J. Michael. Networks in Action. Belmont, CA: Wadsworth. 1994.
Sexton, Mike and Reid, Andy. Transmission Networking: SONET and the Synchronous Digital Hierarchy. Norwood, MA: Artech House. 1992.
Sherman, Kenneth. Data Communications: A Users Guide. Reston. 1981.


Communications Systems and Networks:Fundamentals of data Communications

Chapter 7
Fundamentals of Data Communications

I submit to the public a small machine by my invention, by means of which you alone may, without any effort, perform all the operations of arithmetic, and may be relieved of the work which has often times fatigued your spirit.

Blaise Pascal, 1623–1662

Little did the humble Pascal understand the complexity of computing systems which would develop over the next 300 or so years, much less the requirement for networking them. The ability to communicate with a remote calculating machine first was demonstrated in 1940 by Dr. George Stibitz at Dartmouth College. Stibitz explained, and demonstrated the use of a calculator newly developed by Bell Labs. The calculator was located in New York City and communications took place over standard telegraph lines [7-1]. Contemporary computers, even the most lowly Personal Computer (PC), are shipped from the factory with communications capabilities which would astound the experts of even ten years past.

Up to this point, we have explored the world of voice communications. During that process, we learned that many of the devices and circuits in the Public Switched Telephone Network are digital in nature. In large part the contemporary PSTN is a data network, transporting and switching voice data. This chapter will introduce the basic concepts of data data. The balance of this book largely and truly is data-oriented.

In order to comprehend the intricacy of contemporary data communications systems and networks, it is necessary to develop a solid understanding of the certain basic concepts. These definitions and concepts extend across all technologies and service offerings, from the historical to even the most contemporary.

This chapter first addresses the concept of functional domains, as we did in Chapter 6 which dealt with the world of PSTN voice communications. Terminal equipment, communications equipment and communication software all will be explained, with detailed discussion of modems and DSUs/CSUs. The concept of protocols will be examined at length, with discussion of basic protocol dimensions and issues. Computer network architectures will be explored, with emphasis on IBM’s SNA and OSI, the international standard reference model. Finally, we will pause to consider the importance of security in data systems and networks.

Functional Domains

Functional domains comprise the spheres of influence exerted by the various network elements which perform specific tasks in a data network. Data terminal equipment, data communications equipment, communications software, switches and transmission facilities all are physical elements of such a network, with each performing specific functions, and with all supported by a signaling and control system. Since the general nature of circuit switches was explored in Chapters 2 and 6, that discussion will not be repeated, nor will signaling systems, which were discussed in Chapter 6.

Data Terminal Equipment (DTE)

The data equivalent of CPE (Customer Premise Equipment) in the voice world, DTE is the computer transmit and receive equipment, including a wide variety of dumb terminals, or terminals without embedded intelligence in the form of programmed logic. Such terminals are devices that merely provide a user interface to a more capable host computer; examples of dumb terminals include the Hewlett-Packard HP2521P and the Televideo 950. Semi-intelligent terminals (IBM 317x and 327x) possess a limited amount of intelligence, allowing them to perform certain, limited processes, independent of the intelligence contained in the host. Intelligent terminals generally are in the form of personal computers (PCs), which are networked to a host computer. Such devices are highly capable in their own right, although and in this context, they often are linked across a network to an even more capable host. At the top of the terminal food chain are client workstations, highly intelligent and capable devices that access a more capable server in a client/server environment. In such an operating environment, the clients’ requirements for access to files, applications and network communications software are satisfied by a server which typically is accessed across a LAN. As a result, the client workstation can perform certain appropriate functions (e.g., screen formatting) related to the specific user task at hand, while the server’s memory and processing power is dedicated to the performance of tasks that are accomplished more effectively on a centralized basis.

DTE also is in the form of host computers such as mainframes and midrange (minicomputer) computers. Host computers, also known as host nodes, are highly capable devices with substantial processing power and storage memory. Hosts also, at least theoretically, are carefully administered to ensure that they operate successfully and reliably. They also serve as effective information repositories, with the data backed up and archived on external storage media such as magnetic tapes.

Data Communications Equipment (DCE)

Also known as Data Circuit Terminating Equipment (DCTE), DCE is the equipment that interfaces the DTE to the network, in the process resolving any issues of incompatibility between those domains. Incompatibility issues can include digital versus analog, voltage level, transmission speed and bit density. DCE includes modems, DSUs and CSUs, and Front-End Processors (FEPs), all of which will be discussed in greater detail later in this chapter.


Communications Systems and Networks:Fundamentals of data Communications

Communications Software

Communications software often is required and generally is embedded in the computer operating system. Alternatively, it can take the form of a systems task under the control of the computer’s operating system. The role of communications software is to assist the operating system in managing local and remote terminal access to host resources, to manage security and to perform certain checkpoint activities. The remote terminals interface to the operating system access methods, which contain the specific code required to transfer data across the network channels between the devices. Examples of access methods include IBM’s BTAM (Basic Telecommunications Access Method) and VTAM (Virtual Telecommunications Access Method).

Alternatively, commercial communications management software can be used to control and manage access to the host. IBM’s CICS (Customer Information Control System) is such a product. Such software resolves contention issues between diverse applications without impacting programs or terminals. It handles polling, selection, and program interrupts, thereby ensuring minimum response time. It also resolves error conditions at both the data and line levels. CICS and other TSRs (Terminate-and-Stay-Resident) software is maintained in RAM (Random Access Memory).

Networks

Also known as paths, circuits, or channels, networks provide the connections between computer resources in order to accommodate the flow of information. The network can be in the form of a Local Area Network (LAN), a Metropolitan Area Network (MAN), or a Wide Area Network (WAN), which provide communications over areas of increasing geographic scope. LANs, MANs, and WANs, which will be discussed in later chapters, also can be interconnected.

Switches

Developed in support of voice communications, circuit switches serve to provide for the flexible interconnection of circuits, in the process providing a communications path that supports a continuous stream of transmission. Traditional circuit switches still are widely used in support of data communications, although they have lost much ground to packet switches during the past 25 years. Frame and cell switches have appeared during the past few years, and represent the switching technique for data communications far into the future.

Packet, frame, and cell switches are highly advanced, computerized switching devices which have substantial capacity and which have the ability to share high-capacity transmission systems among large numbers of individual user transmissions. Such switches read the destination address of each segment (packet, frame, or cell) of data in a data stream. Each packet, frame or cell individually then is forwarded through the switch. Packet, frame, and cell switching will be discussed in detail in later chapters.

DCE: AN EXPANDED VIEW

While we have discussed, and will discuss, data networks and switches in great detail in other chapters, this is a convenient and meaningful place to pause and explore the concept and detail of several types of data communications equipment. Specifically, we will examine modems, codecs, terminal adapters, CSUs and DSUs, and front end processors.

Modems

Modems MOdulate and DEModulate signals. In other words, they change the characteristics of the signal in some way. Modems are of several basic types, line drivers, short haul modems, and conventional modems.

Line drivers

Line drivers actually are interface converters, rather than modems in the classic sense. Line drivers are used to extend the distance of a digital connection, within finite limits, by converting the digital signal to a low-voltage, low-impedance signal that can be transmitted more effectively and over longer distances over dedicated, specially conditioned twisted pair circuits. As an example, the RS-232 specification generally limits the distance between devices to 50 feet at transmission rates of 56 Kbps. At lower speeds, line drivers can reshape the digital pulses to extend that distance. At speeds of up to 9.6 Kbps, line drivers can extend that limitation to 500-5,000 feet. The distance can be extended further through the cascading of line drivers, in a unidirectional network; bi-directional communications requires separate wire pairs and separate sets of line drivers.

Short-Haul (limited-distance) modems

Short-Haul (limited-distance) modems are used where line drivers fail in terms of either capacity or distance. Short-haul modems can work at distances between 5,000 and 100,000 feet, and usually are used for private line and hardwired links, but can operate over local loop facilities.

Conventional modems

Conventional modems provide for digital communication across an analog circuit, accomplishing the digital-to-analog conversion in order to resolve that dimension of incompatibility between the DTE and the network. The original de facto standards for modems were set by AT&T with the introduction of the DataPhone in 1961 [7-2]. Currently, standards are international in nature, designated as the V.xx family of standards from the ITU-T. The digital input is in the form of varying electrical voltages, which represent binary 1s and 0s. The output from the modem is a modulated analog carrier wave, that can be modulated in terms of its amplitude, frequency or phase, or a combination. Through this process, the 1s and 0s of the digital data world can be sent over the plain old voice telephone network.

Amplitude Modulation (AM)

Amplitude Modulation (AM) involves the modulation of the amplitude of the analog sine wave, as depicted in Figure 7.1. Using a single-bit AM technique, each 1 bit entering the transmitting modem is expressed as a relatively high amplitude sine wave or series of sine waves, and each 0 bit as low amplitude sine waves. It is possible to express multiple bits by defining four levels of amplitude. In a dibit (2-bit) coding scheme, for instance, the lowest level of amplitude represents a 00 bit pattern, the next highest a 01 bit pattern, the next a 10, and the highest a 11. In this fashion, the speed of data transmission is doubled at the same analog line speed; halving the connection time and reducing the cost of transmission. Amplitude modulation rarely is used individually as it is highly sensitive to the impacts of attenuation and line noise.

Figure 7.1 Amplitude Modulation.


Communications Systems and Networks:Fundamentals of data Communications

Frequency Modulation (FM)

Frequency Modulation (FM), also known as Frequency Shift Keying (FSK), is the sole technique used in low-speed Hayes-compatible modems. FSK involves the modulation of the frequency of the analog sine wave (Figure 7.2). Using a single bit FM technique, 1 bits are transmitted as relatively low frequency signals, and 0 bits as high frequency signals. Again, the benefits of dibit transmission can be realized by defining four levels of frequency, with each sine wave representing a 2-bit pattern (00, 01, 10, 11).

Figure 7.2 Frequency Modulation.

Phase Modulation (PM)

Phase Modulation (PM), or Phase Shift Keying (PSK), involves the carefully synchronized shifting of the position of the sine wave (Figure 7.3). Using a single-bit technique, the continuous sine wave pattern is interrupted and restarted at the baseline to indicate a change in value (e.g., from a 1 bit to a 0 bit). Once again, the advantages of dibit transmission can be achieved by defining four degrees of phase shift. Through the definition of eight degrees of phase shift, contemporary modems can affect tribit transmission, achieving 3 bits of data per signal.

Figure 7.3 Phase Modulation.

AM and PSK

AM and PSK often are used in combination. The use of multiple levels of amplitude and phase shift yield transmission rates of as much as 28.8 Kbps over voice-grade analog circuits, using conventional high-speed modems. For example, Quadrature Amplitude Modulation (QAM), combines differential phase and amplitude shifts to achieve 16 distinct states; thereby four bits can be represented with a single signal. At 2400 baud, a transmission rate of 9600 bps can be achieved. The ITU-TS V.29 recommendation specifies two possible amplitude values for each of eight phase angles.

Conventional modems can be external or internal. They can also be in the form of a PCMCIA (Personal Computer Memory Card Industry Association) card, which fits into a slot on a laptop computer. Multiplexing modems perform some of the functions of a multiplexer, but at a more limited level. Multiple data streams can be transmitted over a single circuit. Voice/data modems allow voice and data transmission over the same circuit, with data being transmitted during lulls in the voice conversation. Data rates up to 28.8 Kbps can be achieved, although the quality of the voice signal can suffer considerably with such a high data rate coexisting on the same circuit.

Conventional modems can be characterized along a number of dimensions including asynchronous versus synchronous, compression, diagnostics, equalization, gain control and band limitation.

Asynchronous versus Synchronous

Modems can be either asynchronous or synchronous. Asynchronous modems transmit a character at a time, with the receiving device relying on start and stop bits to separate transmitted characters. Synchronous modems are much faster, as the signal is synchronized (timed) by a transmit clock (TC) in either the transmit modem or the transmit terminal. The paired modems synchronize on that clocking pulse, in order to distinguish between blocks of data being transmitted, rather than identifying each individual character in a transmission. When large amounts of data are being transmitted, synchronous modems increase the efficiency of data transfer, resulting in increased speed of transfer and lower associated transmission cost [7-3].

Diagnostics

Diagnostics is a characteristic of higher-speed and more expensive modems. Such modems can test their internal clock, transmitter, and receive circuits. Additionally, they may have the capability to monitor their performance and even diagnose certain conditions contributing to performance degradation. Further, they are manageable through higher-level Element Management Systems, which typically are located remotely and which manage large numbers of modems and modem pools (groups of modems to which access is shared amongst multiple users).

Error Correction

Error Correction capabilities are included in some modems. Among the first of which was a modem protocol known as MNP (Microcom Networking Protocol). While proprietary error correction software still is embedded in certain modems, the ITU-T V.42 modems have standardized this function.

Compression

Compression is a characteristic of high-speed modems, allowing the transmission of multiple bits with a single signal (sine wave) or change in signal. Compression makes use of digital shorthand to represent a large number of bits in a specific sequence through a much lesser set of analog signals or signal changes in a specific sequence. Compression rates of 4:1 are routine in many contemporary modems. In addition to numerous proprietary compression schemes, there are standard techniques such as those embedded in modems designed in compliance with ITU-T V.42bis recommendations. The term bis is from Latin, meaning second; in other words, the second and enhanced release of the standard. Third releases are designated ter, translated from Latin as third.

Equalizers

Equalizers compensate for channel distortion, thereby improving transmission rate and error performance.

AGC (Automatic Gain Control)

AGC (Automatic Gain Control) amplifiers are included to adjust for amplitude variations and to ensure that the incoming signal is of a constant strength.

Band-Limiting

Band-Limiting filters improve error performance by managing the frequencies of the incoming signal, filtering out any extraneous frequencies.

Codecs

The reverse conversion of analog to digital is necessary in situations where it is advantageous to send analog information across a digital circuit. Certainly, this is often the case in carrier networks, where huge volumes of analog voice are digitized and sent across high capacity, digital circuits. This requirement also exists where high capacity digital circuits connect premise-based, analog PBX or KTS voice systems to Central Office Exchanges or to other PBXs or KTSs.

The device which accomplishes the A-to-D conversion is known as a codec. Codecs code an analog input into a digital (data) format on the transmit side of the connection, reversing the process, or decoding the information on the receive side, in order to reconstitute the analog signal. Codecs are widely used to convert analog voice and video to digital format, and to reverse the process on the receiving end.


Communications Systems and Networks:Fundamentals of data Communications

Terminal Adapters (TAs) and NT-Xs

Terminal Adapters (TAs) are interface adapters for connecting one or more non-ISDN devices to an ISDN network. TAs, which are ISDN DCE, are equivalent to protocol or interface converters for use with equipment that does not have ISDN capability. The TAs must be exactly tuned to the specific terminal equipment. Network Termination (NT), in ISDN networks, is a function accomplished through the use of Network Termination logic embedded in the carrier network and the user equipment. NT2 is an interface to an intelligent device responsible for the user’s side of the connection to the network, performing such functions as multiplexing and switching; a NT2 would be the interface to an ISDN-compatible PABX or router. NT1 is responsible for interfacing to the carrier’s side of the connection, performing such functions as signal conversion and maintenance of the local loop’s electrical characteristics. These functions are similar to those provided by Data Service Units (DSUs) and Channel Service Units (CSUs).

CSUs and DSUs

Channel Service Units (CSUs) and Digital Service Units (DSUs) are devices which, in combination, interface the user to the digital network. In contemporary systems. CSUs and DSUs generally are combined into a single device, known variously as a CSU/DSU, CDSU, or ISU (Integrated Service Unit). It typically is found under the skin of another device, such as a multiplexer (MUX). They are used in a wide variety of digital voice and data networks, including DDS and T-carrier, which will be discussed in detail in Chapter 8.

CSUs

These provide the customer interface to the circuit. They also allow the isolation of the DTE/CPE from the network for purposes of network testing. CSU functions include electrical isolation from the circuit for purposes of protection from aberrant voltages, serving the same function as a protector in the voice world. Additionally, the CSU can respond to a command from the carrier to close a contact, temporarily isolating the DTE domain from the carrier domain. This allows the carrier to conduct a loopback test in order to test the performance characteristics of the local loop from the serving central office to the CSU and back to the central office.

The CSU also serves to interface the DTE domain to the carrier domain in an electrical environment. For instance, within the DTE, 1 bits are represented as positive (+) voltages and 0 bits as null (0) voltages. The network requires that 1 bits be alternating + and - voltages and that the 0 bits be 0 voltages. Further, the network requires assurance that ones density is achieved. Depending on the carrier network, from 15 to 80 zeros can be transmitted in a row, as long the density of ones is at least 12.5% over a specified interval of time. CSUs will insert, or stuff, 1 bits on a periodic basis in order to ensure that the various network elements maintain synchronization.

The CSU also provides signal amplification and will generate keep alive signals to maintain the circuit in the event of a DTE transmission failure. Finally, the CSU will store in temporary memory data describing its performance in order that it might be considered by an upstream network management system.

DSUs

DSUs convert the DTE unipolar signal into a bipolar signal that is demanded by the network. DSU functions include regeneration of digital signals, insertion of control signals, signal timing and reformatting.

Front-End Processors (FEPs)

FEPs combine the functions of a concentrator and a message switch. They have the ability to concentrate and switch traffic between multiple terminals and groups of terminals in order that a single circuit can be shared for access to mainframe resources. They also are an interface to Wide Area Network (WAN) circuits to serve mainframe resources to remote terminals. Most FEPs are midrange computers that, in turn, connect to the primary host mainframe; FEPs have their own databases. FEPs provide additional functions including error detection and correction, queuing, editing validation, and limited application processing. While the mainframe clearly could perform such tasks, it is more cost-effective to apply a lower order computer to the performance of such mundane responsibilities. In this fashion, the power of the mainframe is reserved for more difficult and demanding tasks in support of user-oriented applications.

Protocol Basics

Protocols are the procedures which are employed to ensure the orderly exchange of information between devices on a data link, data communications network, or system. Protocols comprise standards which, at a basic level, include the dimensions of line setup, transmission mode, code set, and non-data exchanges of information such as error control (detection and correction). Protocols have two major functions, handshaking and line discipline [7-4].

Handshaking
is the sequence that occurs between the devices over the circuit, establishing the fact that the circuit is available and operational. The handshaking process also establishes the level of device compatibility, determines the speed of transmission by mutual agreement, and so on.
Line Discipline
is the sequence of network operations that actually transmits and receives the data, controls errors in transmission, deals with the sequencing of message sets (e.g., packets, blocks, frames, and cells), and provides for confirmation or validation of data received.
Protocol Converters
are devices that translate from one native protocol into another, e.g., from ASCII to IBM SNA/SDLC.
Gateways
are hardware/software combinations that connect devices running different native protocols. In addition to protocol conversion, gateways provide a gateway connection between incompatible networks. Examples include Ethernet-to-Token Ring gateways, X.25-to-Frame Relay gateways, and T-carrier-to-E-Carrier International Gateway Facilities (IGFs).
Protocol Analyzers
are diagnostic tools for displaying and analyzing communications protocols. Analyzers allow technicians, engineers and managers to test the performance of the network to ensure that the systems and the network are functioning according to specifications. LAN managers, for instance, use protocol analyzers to perform network maintenance and troubleshooting and to plan network upgrades and expansions.


Communications Systems and Networks:Fundamentals of data Communications

Line Set-Up/Connectivity

A very basic protocol issue involves the manner in which the circuit is set up between devices. There are three alternatives: simplex, half-duplex and full duplex (Figure 7-4).

Figure 7.4 Simplex, Half Duplex (HDX) and Full Duplex (FDX) Transmission.

Simplex
transmission is unidirectional. The information flows in one direction across the circuit, with no capability to support a response in the other direction. Simplex transmission generally involves dedicated circuits. Simplex circuits are analogous to escalators, doorbells, fire alarms, and security systems. Contemporary applications for simplex circuits, although rare, include remote station printers, card readers, and a few alarm systems (fire and smoke alarms). Generally speaking, simplex transmission is conducted across dedicated circuits of low capacity.
Half-Duplex (HDX)
transmission operates in both directions, although not simultaneously. HDX is generally used for relatively low-speed transmission, usually involving two-wire, analog circuits provided on a circuit-switched basis through the PSTN. As the circuit must be turned around in order to support the change in direction of the conversation, it tends to limit the speed and agreeability of conversational data communications. Line turnaround time is a limiting factor, being in the range of 50 to 500 milliseconds (thousands of a second), depending on the length of the circuit.
In many environments, HDX is the predominant transmission mode, although high-performance networks are becoming increasingly available and cost-effective. Examples of HDX application include line printers, polling of buffers, and modem communications (many modems can support FDX, as well). HDX is used extensively in transaction-based communications, such as credit card verification and ATM (Automatic Teller Machine) networks. Such applications are not seriously affected by delays associated with line turnaround.
Full Duplex (FDX)
is a fully bidirectional transmission mode in which communications is supported in both directions, simultaneously. FDX typically requires two simplex circuits, one operating in each direction. FDX circuits are generally characterized as being four-wire, high-capacity, dedicated circuits, most of which are multichannel in nature. All wideband and broadband circuits are FDX in nature, as are most multichannel circuits. FDX circuits are sometimes used to connect half-duplex terminals in order to avoid issues of line turnaround. More typical examples of FDX applications include channel links between host processors, channel links between controllers/concentrators and hosts, and other applications involving the interconnection of substantial computing systems. Carrier services that deliver FDX capabilities include DDS, E/T-carrier, and broadband services such as Frame Relay, SMDS and ATM, all of which will be discussed in later chapters.

Transmission Mode: Transmission Method

There are two basic methods of data transmission, asynchronous and synchronous.

Asynchronous

Asynchronous, or character-framed, transmission, is a method which grew out of telegraphy and teletypewriting. From Latin and Greek, it translates as not together with time; in other words, it is not synchronous. Asynchronous transmission is a start-stop method of transmission in which each computer value (letter, number, or control character) is preceded by a start bit, which alerts the receiving terminal to the transmission of something worthy of its attention. The transmitted computer value is succeeded by a stop bit, which advises the receiving terminal that the transmission of that set of information is ended; some asynchronous protocols make use of two stop bits.

PCs, teletypes and other devices which make use of asynchronous transmission frame, or surround, each byte of information with start and stop bits, which are interpreted by the receiving terminal and subsequently stripped away. The inclusion of start and stop bits adds two or three bits of overhead to the transmission of each 8-bit byte. Additionally, asynchronous transmission adds a parity checking bit for relatively poor error control. The framing of the data with these three or four bits of control information yields an overhead, or inefficiency, factor of 20% to 30%.

Asynchronous transmission can be characterized as start-stop (not synchronized) transmission of one character at a time at a variable speed. Additionally, overhead is high and error control is poor.

Synchronous

From Latin and Greek orgins, synchronous translates as together with time. Such transmission is message-framed and overcomes the inefficiencies of asynchronous, start-stop, transmission for high-speed data communications applications. Rather than surrounding each character with start and stop bits, a relatively large set of data is framed or blocked, with one or more synchronization bits or bit patterns being used to synchronize the receiving terminal on the rate of transmission. Through the receipt of the synchronizing bits, or clocking pulses, the receiving device can match its speed of receipt to the rate of transmission across the circuit. Each bit and byte of data and control information can be separately distinguished, as the device knows when to expect what information, and in what sequence. As the large block or frame of data is surrounded by only a few framing bits and synchronizing bits, the overhead is much reduced, the efficiency of transmission is much increased and the effective throughput is much greater.

Error control is quite sophisticated and reliable, involving statistical sampling techniques and mathematical calculations performed on the set of data. Synchronous transmission can be characterized as transmission of multiple characters at a time, organized into character sets and presented in blocks or frames. The transmission is synchronized, and takes place at a predetermined and relatively high rate of speed. Further, error control is excellent and overhead is relatively low.


Communications Systems and Networks:Fundamentals of data Communications

Isochronous (Isoc)

Isochronous (Isoc) data is synchronous data transmitted without a clocking source. From the Greek isochronos, all bits are of equal importance and are anticipated to occur at regular intervals of time. Bits are sent continuously, with no start-stop bits for timing. Rather, timing is recovered from transitions in the data stream, with a whole number of bit-length intervals between characters. Bit integrity is preserved, with no modifications (i.e., bipolar conventions). Isochronous transmission is transparent and does not recognize control characters. While there are few commercial applications, some T-carrier nodes operate isochronously on the DS-1 links, syncing up with several lines operating at slightly different speeds. Isoc is often used in secure military applications that require encryption. Isochronous voice and video transmission also is supported by several recent LAN standards, such as Isochronous Ethernet (IsoEthernet), which will be discussed in Chapter 9.

Realtime, uncompressed voice communication is a type of isochronous data, as human conversation is not synchronized and can be presented in a continuous stream. If voice were synchronous, we would all talk at a precise and common rate of speed; not overtalking each other. Similarly, realtime, uncompressed video communication is isochronous, or stream-oriented.

Pleisiochronous

From the Greek pleion, meaning more, pleisiochronous communications involves careful synchronization of transmission systems of varying levels of bandwidth through the use of highly accurate clocking devices. The preferred approach involves a master clocking source such as a cesium clock. All lower order devices (switches and MUXs) slave off the master clock. Through such a technique, the T/E carrier hierarchy is developed, with a master clocking source serving to ensure that digital facilities of lesser capacities can be aggregated into facilities of higher capacities, with each set of data retaining its individual integrity.

Code Sets

Code sets or coding schemes, analogous to alphabets, are employed by all computer systems in order to create, store and exchange information. While code sets vary, they all rely on a specific combination of 1s and 0s, of a specific total length, in order to represent something of value, such as a letter, number or control character (e.g., carriage return, line feed, space, blank, and delete).

The first widely accepted standard coding scheme was Morse code, invented by Samuel Morse for use in telegraphy. Morse code used a series of dots and dashes to represent letters, numbers, and punctuation marks. In order to speed transmission, the most commonly used letters were represented by the fewest number of dots and dashes (e.g., E became •, T became –, A became • –).

Baudot Code (ITA #2)

Morse code was the primary communication code for many years, until Emile Baudot invented the Baudot Distributor in the 1870s. That device transmitted values in a 5-bit coding scheme over a line between two electromechanical devices that were synchronized. The Baudot Distributor soon gave way to the teletype, which also was based on the Baudot coding scheme, subsequently known as International Telegraph Alphabet (ITA) #2.

Baudot code (updated in 1930) is limited to 32 (25)characters. Considering that each bit has two possible states (1 or 0), 5 bits in sequence yield 25 (32) possible combinations. As 32 values is not sufficient to represent all 26 characters in the English alphabet, plus the 10 decimal digits, punctuation marks, and the space character, the shift key was used to shift between letters and other characters. Letters (LTRS) are represented by an arrow pointing down. Lower case (LTRS shift) means that all following characters are alpha characters (LTRS). Figures (FIGS) are represented by an arrow pointing up. When a FIGS character is recognized, all succeeding characters are recognized as FIGS numbers and special characters) [7-4] and [7-5].

Baudot employs asynchronous transmission, as start and stop bits separate characters. Error detection and correction requires human editing. It is, therefore, a human-to-human, rather than a machine-to-machine communication technique, with detected errors requiring retransmission.

Clearly, Baudot is a highly limited coding scheme. The limited range of expression (32 characters) is barely enough to accommodate the relatively simple English, French, and Spanish alphabets. For that matter, all letters must be in upper case. Additionally, the asynchronous requirement for start and stop bits make Baudot overhead-intensive. Finally, the error detection and correction technique is far less than desirable. As a result, Baudot currently is limited to use in very old teletypewriters.

As a footnote, 5-bit coding schemes are not necessarily overly limiting. For instance, a proprietary five-bit code is used in the airline reservation systems (e.g., American Airlines’ SABRE System and United Airlines’ APOLLO). Such applications involve a limited character set that is easily accommodated by a 5-bit code. In fact, a 7- or 8-bit coding scheme would be inefficient.

Extended Binary Coded Decimal Interchange Code (EBCDIC)

EBCDIC, developed by IBM in 1962, was the next standardized code to be used extensively. An improvement over earlier Binary Coded Decimal (BCD) (1950) and Extended Binary Coded Decimal (Extended BCD) (1951), EBCDIC was developed to allow different IBM computer systems to communicate based on a standard coding scheme. Although EBCDIC is standardized today, users can modify the coding scheme [7-4].

EBCDIC involves an 8-bit coding scheme, yielding 28 (256) possible combinations and, thereby, significantly increasing the range of expression. As a result, more complex languages can be supported, as can both upper and lower case letters, a full range of numbers (0 to 9) and all necessary punctuation marks. Equally importantly, if not more so, the 8-bit coding scheme supports a large number of control characters, which is critical in the coordination of communications between computers of real significance.

EBCDIC-based machines communicate on a synchronous basis, thereby improving on the speed on transmission. As start and stop bits do not surround each character, overhead is reduced and efficiency of transmission is improved. Further, a more complex, machine-to-machine error detection and correction technique yields improved performance in that regard—detected errors may require retransmission, although forward error correction is often employed, with the receiving system determining the errored bits and correcting for those errors.


Communications Systems and Networks:Fundamentals of data Communications

American (National) Standard Code for Information Interchange (ANSCII or ASCII)

ASCII was first developed in 1963 and specifically oriented toward data processing applications. It was subsequently modified in 1967 by the American National Standards Institute (ANSI) to address modifications found in contemporary equipment—that version was originally known as ASCII II, but is now known simply as ASCII [7-5].

ASCII employs a 7-bit coding scheme (Figure 7.5), supporting 128 (27)characters, which is quite satisfactory for most alphabets, puctuation, characters, and so on. As ASCII was designed for use in asynchronous computer systems (non-IBM, in those days), fewer control characters were required, making a 7-bit scheme acceptable.

Figure 7.5 ASCII code example, with character framing.

As is the case with asynchronous communications, in general, start and stop bits frame each character, and synchronization bits are not employed. ASCII makes use of a simple error detection and correction scheme known as parity checking. Parity checking is error prone with detected errors often going unnoticed or requiring retransmission, although forward error correction often is currently employed.

UNICODE (UNIVERSAL CODE)

UNICODE is an attempt to standardize longer and more complex coding schemes used to accommodate more complex languages such as Japanese and Chinese. In the Japanese language, for instance, even the abbreviated Kanji writing system contains well over 2,000 characters; Hatakana and Katakana alphabets are also used, further adding to the complexity. As 7- and 8-bit coding schemes cannot accommodate such a complex alphabet, computer manufacturers traditionally have taken proprietary approaches to this problem through the use of two linked 8-bit values.

UNICODE supports 65,536 (216) characters, thereby accommodating the most complex alphabets; in fact, multiple alphabets can be satisfied simultaneously. Further, UNICODE standardizes the coding scheme in order that computers of disparate origin can communicate information on a standard basis. As the transfer of UNICODE data does not require code translation, speed of transfer is improved, errors are reduced and costs are lowered.

Supported by relatively substantial machines, UNICODE employs synchronous transmission and sophisticated error detection and correction conventions, as discussed above in connection with EBCDIC.

Data Format

The formatting of the data is a critical part of a communications protocol. Data formats let the receiving device logically determine what is to be done with the data and how to go about doing it. Data formats include code type, message length, and transmission validation techniques. A data format generally involves a header, text, and a trailer (Figure 7.6).

Figure 7.6 Data format, with header, text and trailer.

Header
A communications header precedes the data to be transmitted, establishing the fact that the transmission link exists both physically and logically. It also provides for synchronization between the devices and the link, and enables the receiving device to route the data correctly. The user header includes user-definable information such as system access (password), organization/department ID, operator ID, terminal ID, database/application ID, destination address, message sequence number, date/time ID, and message priority.
Text
The text portion of the data set is the information to be communicated. It may contain a fixed or a variable amount of information organized into packets, blocks, frames, or cells. The text is preceded by Start-of-Text (STX) and succeeded by End-of-Text (ETX) control characters in order that the receiving device can determine the location of the message data.
Trailer
The trailer, tail or trace portion of the data set contains information relative to the analysis of the message, including message tracking and diagnostics. Trailing the text, the trailer information may contain the originating ID, the data block number, and total number of blocks being transmitted, and identification of system processing points involved in the transmission.

Error Control: Data Transmission Integrity

The integrity of the transmitted data is of prime importance. There are techniques that can be employed for error detection and, ideally, correction. These three basic modes of error control are recognition and flagging, recognition and retransmission, and recognition and forward error correction.

Recognition and Flagging
of errors provides for no automatic means of correction. Used primarily in networks involving dumb terminals with no means of buffering or retaining information transmitted, retransmission of errored data is not possible. Detected errors simply are flagged (identified) as such. Error correction requires a human-to-machine request for retransmission.
Recognition and Retransmission
is used in more sophisticated networks where the transmitting device has buffer memory and, therefore, can retransmit an errored set of data which has been detected. Serious failures in the devices and/or the circuit can result in repeated errored retransmissions, which lower the throughput of the communication link.
Recognition and Forward Error Correction
involves the addition of enough additional information that the receiving device is able to make the required corrections, without the requirement for retransmission.

Echo Checking

Echo checking is one of the earliest means of error detection and correction. Echo involves the receiving device echoing the received data back to the transmitting device. The transmitting operator can view the data, as received and echoed, making corrections as appropriate. However, errors can occur in the transmission of the echoed data, as well, making this approach highly unreliable.

Echo can be characterized as very slow and overhead-intensive, as characters are transmitted one at a time; therefore, the process is bandwidth-intensive, as well. Further, the error detection and correction process is manual (human-to-machine) and decidedly unreliable. As a result, echo checking seldom is used in contemporary data communications.


Communications Systems and Networks:Fundamentals of data Communications

Parity Checking

Parity checking is by far the most commonly used method for error detection and correction, as it is used in asynchronous devices such as PCs. Parity involves the transmitting terminal’s appending one or more parity bits to the data set in order to create odd parity or even parity. In other words, an odd or even value is always created, character-by-character or set-by-set of data. While less than ideal, this approach is easily implemented and offers reasonable assurance of data integrity. There are two dimensions to parity checking, vertical redundancy checking, and longitudinal redundancy checking.

Vertical Redundancy Checking (VRC) entails the appending of a parity bit at the end of each transmitted character or value to create an odd or even total mathematical bit value. The receiving device executes the same mathematical process to verify that the correct total bit value was received. Logically speaking, the two devices sum the bit values vertically, as represented in Figure 7.7. While inexpensive and easily implemented in computers employing asynchronous transmission, VRC is not highly reliable; VRC often is referred to as send and pray.

Figure 7.7 Example ASCII code with VRC and LRC parity checking.

Longitudinal Redundancy Checking (LRC) or Block Checking Character (BCC) adds another level of reliability, as data is viewed in a block or data set, as though the receiving device were viewing data set in a matrix format. This additional technique of checking the total bit values of the characters on a horizontal basis employs the same parity (odd or even) as does the vertical check (Figure 7.7). However, it is less than completely reliable, as compensating errors can still occur in nonadjacent characters. While remaining relatively inexpensive and easily implemented in devices employing asynchronous transmission, LRC/BCC adds a significant measure of reliability. Also known as checksum, the LRC is sent as an extra character at the end of each data block [7-5].

Block Parity

The technique of block parity improves considerably on simple parity checking. While Spiral Redundancy Checking (SRC) and interleaving improved on the detection of errors due to increased transmission speeds and more complex modulation techniques, they gave way to Cyclic Redundancy Checking (CRC), which is commonly employed today.

Cyclic Redundancy Checking (CRC) validates transmission of a set of data, formatted in a block or frame, through the use of a unique mathematical polynomial known to both transmitter and receiver. The transmitting device statistically samples the data in the block or frame and applies a 17-bit generator polynomial based on a Euclidean algorithm; the result of that calculation is appended to the block or frame or text as either a 16- or 32-bit value. The receiving device executes the identical process, comparing the results. The result is a integrity factor of 10-14; in other words, the possibility of an undetected error is 1 in 100 trillion. By way of example and at a transmission speed of 1 Mbps, 1 undetected error would be expected approximately every 30 years!

An unerrored block or frame is ACKnowledged by the receiving device through the transmission an ACK, whereas an errored block or frame is Negatively AcKnowledged with a NAK. A NAK prompts the transmitting device to retransmit that specific block or frame. The transmission of an ACK by the receiving device cues the sending device that the next block or frame of data can then be sent.

While CRC is relatively memory- and processor-intensive and therefore expensive to implement, it is easily accommodated in high-order computers which benefit from synchronous transmission techniques. As CRC ensures that data transmission is virtually error-free, it is considered mandatory in most sophisticated computer communications environments.

Forward Error Correction (FEC)

Forward Error Correction (FEC) involves the addition of redundant information embedded in the data set in order that the receiving device can detect errors and correct for them without requiring a retransmission [7-6]. The two most commonly employed techniques are Hamming and BCH (Bose, Chaudhuri and Hocquengham).

While even more memory- and processor-intensive than CRC, FEC allows the receiving device to correct for errors in transmission, thereby avoiding most requirement for retransmission of errored block or frames of data. As a result, FEC improves the efficiency, or throughput, of the network, reducing transmission costs in the process and without sacrificing data integrity.

Data Compression

As the length of the data sets and the distances over which they travel increase, and as the likelihood of errors in transmission increases accordingly, data compression becomes sensible. Additionally, data compression reduces the bandwidth required to transmit a set of data—bandwidth=$$$. Data compression techniques can include formatting, redundant characters, commonly used characters, and commonly used strings of characters.

Formatting
of data need not be transmitted across the network. In a basic example, data compression might involve the removal of formatting from a commonly used form, such as an expense report. Such formatting can involve a large amount of redundant data, as the receiving device can easily reformat the data, placing the various fields of data in the appropriate places on the form, which resides in memory.
Redundant characters
can be easily identified by the transmitter communicated to the receiver. This approach is also known as string coding, yielding compression factors of as much as 4:1.
Commonly used characters
can be easily identified and abbreviated through the use of an identifier and a smaller set of bits, much as the technique used by Samuel Morse in the development of Morse Code. Huffman Coding is commonly used in this instance, yielding compaction factors of 2:1 or 4:1.
Commonly used strings of characters
similarly, can be identified and transmitted in abbreviated form. Such an approach relies on the probability of character occurrence following a specific character (e.g., Q is generally followed by U). Markov source and other techniques address this potential.


Communications Systems and Networks:Fundamentals of data Communications

Asynchronous Data Link Control (DLC) Protocols

Asynchronous protocols are used primarily for low-speed data communications between PCs and very small computers. Framing occurs at the byte level, with each byte surrounded by a start bit (a 0 bit) and a stop bit (a 1 bit). A parity bit often accompanies each character, as well. Telex transmission incorporates an additional stop bit.

Kermit and XMODEM are asynchronous protocols, organizing information into 128-byte packets. Kermit also uses CRC error control. The data also can be blocked at the application level, and VRC can be complemented with the additional technique of LRC for improved error control.

Bit- versus Byte-Oriented Synchronous Protocols

Two general types of data communications protocols exist, byte-oriented and bit-oriented. While the performance characteristics of byte-oriented protocols are acceptable for many applications, bit-oriented protocols are much more appropriate for communications-intensive applications where the integrity of the transmitted data is critical.

Byte-oriented protocols communicate value strings in byte formats, generally of 8 bits per byte. Control characters (e.g., start bit, parity bit, and stop bit) are embedded in the header and trailer of each byte or block of data. As byte-oriented protocols are overhead-intensive, they are used exclusively in older computer protocols, at the second layer, or link layer. Byte-oriented protocols generally are asynchronous and half-duplex (HDX), operating over dial-up, two-wire circuits. Examples include Bisynchronous Communications (Bisync or BSC).

Bit-oriented protocols transmit information in a much larger bit stream, with opening and closing flags identifying the text from the control information, which addresses control issues associated with the entire data set. Bit-oriented protocols are much less overhead-intensive; they are usually synchronous, full-duplex and operate over dedicated, four-wire circuits. Examples include IBM’s Synchronous Data Link Control (SDLC) and the ISO’s High-Level Data Link Control (HDLC).

Binary Synchronous Protocol (Bisync or BSC)

Bisync was developed by IBM in 1966 as a byte-oriented protocol that frames the data with control codes which apply to the entire set of data. Bisync organizes data into blocks of up to 512 characters, which are sent over the link sequentially (one-at-a-time). An ACK or NAK is transmitted from the receiving terminal to the transmitting device following the receipt of each block. Error control is on the basis of a Block Checking Character (BCC), which is transmitted along with the data; the receiving device independently calculates the BCC and compares the two calculations.

The Bisync block consists of synchronizing bits, data and control characters sent in a continuous data stream, block-by-block. The specific elements of the Bisync block, as illustrated in Figure 7.8, are as follows and in sequence [7-7] and [7-8].

Figure 7.8 BSC block.

• PAD: PADding character sent as the first character to alert the receiving device of the transmission of a block of data and to ensure that the receiving device is in step with the data bits.
• SYN: SYNchronizing characters (usually 2) to establish character synchronization between transmission and receiving device.
• SOH: Start of Header, which precedes the routing information
• Header: Header address information to indicate the address of the transmitting device.
• STX: Start of Text control character to indicate the beginning of the data.
• text: The data being transmitted.
• ETX: End of Text control character to indicate the end of the data.
• BCC: Block Check Characters for error detection.
• PAD: PADding character, trailing the transmission to ensure the receipt of all previous characters and to indicate the end of the block.

Synchronous Data Link Control (SDLC)

SDLC, developed in the mid-1970s, is at the heart of IBM’s System Network Architecture (SNA). SDLC is a bit-oriented protocol that uses bit strings to represent characters. SDLC uses CRC error correction techniques, in this specific case known as Frame Check Sequence (FCS). SDLC supports high-speed transmission, and generally employs full-duplex (FDX), dedicated circuits. SDLC can work either in HDX or FDX, supports satellite transmission protocols, and works in point-to-point or multipoint network configurations.

Up to 128 frames can be sent in a string, with each frame containing up to 7 blocks, each of up to 512 characters. Each block within each frame is checked individually for errors. Errored blocks must be identified as such to the transmitting device within a given time limit, or they are assumed to have been received error-free.

The SDLC frame consists of synchronizing bits, data and control characters sent in a continuous data stream, frame-by-frame. The specific elements of the SDLC frame (Figure 7.9) are as follows and in sequence [7-7].

Figure 7.9 SDLC Frame.

• Flag (F) Flag bits, in a specific bit pattern, to alert the receiving device to the transmission of the frame.
• Station Address (A) Address field to identify the specific device transmitting the frame.
• Control (C) Control field containing commands or responses to control the data link
• Information (I) Information (data) being transmitted.
• Frame Check Sequence (FCS) Field containing the CRC character sequence used to check the integrity of the transmitted address and control information, as well as the data.
• Flag (F) Flag bits, in a specific bit pattern, to alert the receiving device to the end of transmission of the frame


Communications Systems and Networks:Fundamentals of data Communications

High-Level Data Link Control (HDLC)

HDLC was developed by the International Standards Organization (ISO) as a superset of IBM’s SDLC and the United States National Bureau of Standard’s (NBS) ADCCP protocols. A version of HDLC is the Link Access Protocol-Balanced (LAP-B), which is used in ITU-TS X.25 packet switched networks. While HDLC was built on SDLC and is very similar, the two generally are not compatible, depending on the framing conventions in the specific HDLC implementation.

Network Architectures

A network architecture defines the communications products and services which ensure that the various components can work together. Early on, even the various systems of a given manufacturer did not interoperate, let alone afford connectivity with the products of other manufacturers. While the IBM Systems Network Architecture (SNA) and the Digital Equipment Corporation DECnet architectures have solved these internal problems, they still do not interoperate (nor are they ever likely to do so). Truly open systems architectures are still in the distant future, although great strides have been made in this regard through the Open Systems Interconnection (OSI) model fostered by the International Standards Organization (ISO).

A number of standard computer network architectures have been defined, many of which segregate various functions into discrete layers of responsibility, for ease of development and management. Network architecture examples include Xerox Networking System (XNS), DECnet, Advanced Research Projects Agency network (ARPAnet) (now the Internet), U.S. Department of Defense Network (DDN), IBM’s Systems Network Architecture (SNA), and the Open Systems Interconnection (OSI) model.

Layered Operations Models

Layered models serve to enhance the development and management of a network architecture. While they primarily address issues of data communications, they also include some data processing activities at the upper layers. These upper layers address application software processes, presentation format, and the establishment of user sessions. Each independent layer, or level, of a network architecture addresses different functions and responsibilities. The layers work together, as a whole, in order to maximize the performance of the process. The various functions address the functions of data transfer, flow control, sequencing, error detection, and notification.

Data Transfer allows the transfer of data from one node to another. Included are such issues as normal or expedited data flow; packet, block or frame sizing; and data assembly and segmentation. Flow Control controls the flow of packets through the network to reduce congestion and the resulting degradation of network performance. Sequencing of the data packets is required where packets may take different routes between nodes. Error Detection is required to ensure data integrity. Notification provides for the advice from receiver to transmitter of the receipt of packets and their condition.

Systems Network Architecture (SNA)

Developed in 1974 by IBM, SNA was a five-level design architecture that has grown into a seven-layer model. SNA comprises software and hardware interfaces to allow various IBM systems and software to communicate. SNA includes network nodes, physical units, and logical units.

Nodes
are all physical devices in the SNA network. Nodes can include computers, communications processors (FEPs), terminal controllers and terminals.
Physical Units (PUs)
manage the communications hardware and software, participating in the controlling and routing of network communications. All physical devices are assigned a PU Type (1, 2, 3, or 5), that identifies the level of the device (terminal, controller, communications processor or host node) and its origin (IBM/SNA or non-IBM/SNA)
Logical Units (LUs)
manage communications software for communications with end users. A logical unit session is an end-to-end communication between an end-user terminal and the originating application residing in the host. As an example, LU 6.2 supports peer-to-peer communications between intelligent devices, without requiring the host to be responsible for communications support activities. LU 6.2 is also known as Advanced Program-to-Program Communications (APPC).

While SNA is similar to, it is not compatible with, the OSI model.


Communications Systems and Networks:Fundamentals of data Communications

Open Systems Interconnection (OSI) Model

The OSI Reference Model is a layered architecture (Figure 7.10) consisting of a set of international networking standards known collectively as X.200. Developed by the International Standards Organization (ISO), the basic process began in 1977 and was completed in 1983. The OSI model defines a set of common rules that can be used by computers of disparate origin in order to exchange information (communicate). As is the case with SNA and other such proprietary architectures, the model is layered to segment software responsibilities, with supporting software embedded in each node to provide an interface between layers. Specific levels of service can be negotiated between nodes.

Figure 7.10 OSI Reference Model.

The transmitting device uses the top layer, at which point the data is placed into a packet, prepended by a header. The data and header, known collectively as a Protocol Data Unit (PDU), are handled by each successively lower layer as the data works its way across the network to the receiving node. At the receiving node, the data works its way up the layered model; successively higher layers strip off the header information.

Layer Seven (Application Control)
provides support services for user and application tasks. File transfer, interpretation of graphic formats and documents, and document processing are supported at this level. As a example, X.400 e-mail messaging takes place at Layer Seven.
Layer Six (Presentation Control)
performs functions related to the formatting and displaying of received data by terminals and printers. Functions herein include data formatting, code set conversion (EBCDIC-to-ASCII), and text compression and decompression.
Layer Five (Session Control)
formats the data for transfer between end nodes, provides session restart and recovery, and general maintenance of the session from end-to-end.
Layer Four (Transport Control)
is responsible for maintaining the end-to-end integrity and control of the session. Data is accepted from the Session Control layer and passed through to the Network Control layer. The two protocols that can be used at this layer include Transmission Control Protocol (TCP) and the five levels of the OSI Transport Protocol (TP). The X.25 packet-switching protocol operates at Layers One, Two, Three, and Four.
Layer Three (Network Control)
comprises software that addresses the PDUs and transports them to the ultimate destination, setting up the appropriate paths between the various nodes. At this layer, message routing, error detection and control of internodal traffic are managed. The Internetwork Protocol (IP) operates at this layer.
Layer Two (Data Link Control)
establishes the communications link between individual devices over a physical link or channel. At this level lie responsibility for framing, error control, flow control, data sequencing, time-out levels, and data formatting. HDLC is used at this level.
Layer One (Physical Control)
defines the electrical and mechanical aspects of the interface of the device to a physical transmission medium, such as twisted pair, coax, or fiber. At this layer are found communications hardware and software drivers, as well as electrical specifications such as RS-232C.

Security

Security is an issue of prime importance (Figure 7.11) across all dimensions of communications and networks, but perhaps most importantly in the world of data communications. In the traditional data world of mainframes in glass houses, security was very tightly controlled. In the contemporary world of distributed processing and networked computer resources, security is much more difficult to develop and control. Security encompasses a number of dimensions, including physical security, authentication, authorization, port security, transmission security, and encryption.

Figure 7.11 Security as a priority.

Physical security

Physical security involves access control—control over the individuals who have access to the facilities in which the systems reside. Clearly, access must be restricted by security guards, locks and keys, electronic combination locks and/or electronic card key systems which require additional input, such as a Personal Identification Number (PIN). The latter is preferable, as the system can maintain a record of specific access.

Authentication

Authentication provides a means by which network managers can authenticate the identity of those attempting access to computing resources and resident data. Authentication consists of Password Protection and Intelligent Tokens. Password protection should be imposed to restrict individuals on a site, host, application, screen and field level. Passwords should be of reasonably long length, alphanumeric in nature and changed periodically. There is a current trend toward the use of dedicated password servers for password management. Intelligent tokens are one-time passwords which are generated by hardware devices and which are verified by a secure server on the receive side of the communication. They often work on a cumbersome challenge-response basis.

Authorization

Authorization provides a means of controlling which legitimate users have access to which resources. Authorization involves complex software which resides on every secured computer on the network; ideally, it provides single sign-on capability. Authorization systems include Kerberos, Sesame, and Access Manager.

Kerberos
the best known authorization software, was developed by Massachusetts Institute of Technology (MIT). Although it is available without charge, commercial versions exist. As Kerberos uses DES, it is not easily exportable to other nations [7-9]. IBMs Kryptoknight is a Kerberos variant, weaker but exportable. Kerberos is named after the three-headed monster which guards the gates to the underworld according to Greek myhtology.
Sesame (Secure European System for Applications in a Multivendor Environment)
was developed by the ECMA (European Computer Manufacturers Association. It is flexible, open and intended for large, heterogeneous network computing environments. It also is highly complex and not effective for smaller applications.
Access Manager
recently approved by the IETF (Internet Engineering Task Force), uses an API for applications, employing scripting. Scripting involves a process of mimicking the log-on procedures of a program, providing basic levels of security for small networks.


Communications Systems and Networks:Fundamentals of data Communications

Port Security

Port security is essential in order to deny unauthorized remote access. Passive devices will report on unauthorized access, usage anomalies, etc. Active devices, which are preferable, will act to deny access to unauthorized users and to disable ports in the event that user-definable parameters are exceeded.

Transmission Security

Transmission Security is critical to ensure that unauthorized entities are not allowed to intercept the data as it is communicated across the network. Transmission of data is especially insecure over analog links; wireless transmission is inherently insecure. Transmission security is virtually ensured over coaxial cable and, especially, over fiber optic cable, as these media cannot easily to physically tapped. In order to maximize security, however, it is necessary that the data be encrypted.

Encryption

Encryption involves scrambling and compressing the data prior to transmission; the receiving device will be provided with the necessary logic to decrypt the transmitted information. Encryption logic generally resides in firmware included in standalone devices, although it can be incorporated into virtually any device. For instance, it is now being incorporated into routers, which can encrypt data on a packet-by-packet basis. Encryption comes in two basic flavors, private key and public key. Private key encryption requires that the key be kept secret. Public key encryption involves an encryption (encoding) key that can be used by all authorized network users; the key for decoding is kept secret. Data encryption standards include DPF (Data Private Facility) and DES (Data Encryption Standard), which uses a challenge-response approach and intelligent tokens.

Firewalls

Firewalls comprise application software which can reside in a communication router, server or some other device. That device physically and/or logically is a first point of access into a networked system. On an active basis, the device can block access to unauthorized entities, effectively acting as a security firewall. Firewalls currently are the subject of much interest, especially as organizations seek to protect their data from the ravages of hackers and other less-than-honorable creatures who prowl the Internet.

References

[7-1] Shelly, Gary B. and Cashman, Thomas J. Introduction to Computers and Data Processing. Fullerton, CA: Anaheim Publishing Company. 1980.
[7-2] Brooks, John. Telephone: The First Hundred Years. NY: Harper & Row, 1976.
[7-3] Keen, Peter G.W. and Cummins, J. Michael. Networks in Action. Belmont, CA: Wadsworth Publishing Company. 1994.
[7-4] Sherman, Kenneth. Data Communications: A Users Guide. Reston, VA: Reston Publishing Company, Inc. 1981.
[7-5] Held, Gilbert. Understanding Data Communications. Indiannopolis. IN: SAMS Publishing. 1994.
[7-6] Doll, Dixon R. Data Communications: Facilities, Networks and Systems Design. NY: John Wiley & Sons. 1978.
[7-7] Data Communications Concepts. Rochester, MN: IBM (GC21-5169-5). September 1985.
[7-8] Gelber, Stan. Introduction to Data Communications: A Practical Approach. Horsham, PA: Professional Press Books. 1991.
[7-9] Voydock, Victor L. and Kent, Stephen T. Security Mechanisms in High-Level Network Protocols. ACM. 1983. Reprinted: Partridge, Craig. Innovations in Internetworking. Norwood, MA: Artech House. 1988.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

Chapter 8
Conventional Public Data Networks (PDNs)

[I]n 1816, Mr. Ronalds (afterwards Sir Francis Ronalds) showed that an electric telegraph was possible, and endeavoured to persuade the Government of the importance of his system. The official reply to his appeal was as follows: “Mr. Barrow presents his compliments to Mr. Ronalds, and acquaints him, with reference to his note of the third instant, that telegraphs of any kind are now wholly unnecessary, and that no other but the one now in use will be adopted. Admiralty Office, Aug. 5, 1816.” The “one in use,” here indicated, was the semaphore, … which, it may be mentioned, was quite useless during the night, or when fog prevented the signals being seen.

—Wonders of the Universe, 1899

Data communications began in 1835 with the invention of the first practical telegraph by Samuel F.B. Morse and with his first long distance message, “What hath God wrought!” sent from Baltimore, Maryland to Washington, D.C. in 1846. This simplex (later diplex and quatraplex) device used start and stop signals of varying lengths over uninsulated iron, and later copper, wire. The first commercial data communications carrier was Western Union, founded in 1856 to provide telegraph services [8-1].

Modern data communications beyond the boundaries of the data processing center involved the physical transfer of punch cards or magnetic tapes via mail or courier. While this approach is still used in some cases as a primary means of data transfer (more than you might think), it is generally a last resort. Sneakernet is slow and expensive. The traditional voice network, despite its severe limitations, became a common means of electronic data transfer for short duration, low-speed communications. As the demand for data networking developed, and as the enabling technology evolved, a number of alternatives emerged. Data communications is growing at an annual rate in excess of 25%, while voice is growing at about 5% to 6%—roughly the rate of population growth.

Evolution of Data Networking

All Wide Area Network (WAN) communications initially were voice, with the exception of the separate telegraph networks, and remained that way for over 100 years. As a result, the networks evolved in a manner that best supported voice communications.

The Voice Model

The voice Public Switched Telecommunications Network (PSTN) was designed to support voice-only communications. As a result, PSTN can be characterized in terms such as analog, two-wire, two-way, narrowband, circuit-switched, and ubiquitous.

Analog

The network is presumed to be analog. The local loop is always analog, unless digital circuits are ordered specifically (e.g., ISDN and T-carrier). The carrier networks largely are digital, for reasons which include increasing traffic capacity, and improving error performance.

Two-Wire

Two-Wire local loops predominate, and are quite satisfactory for narrowband voice and low-speed data. Four-wire local loop circuits are used only to support wideband services such as T1 and emerging broadband services. The internal carrier networks are four-wire, in support of high-capacity, multichannel wideband and broadband communications.

Copper

Copper twisted-pair remains the predominant medium in the local loop, although fiber optic cable is being deployed to the business premise on a selective basis. Fiber and fiber/coax networks are being deployed to the neighborhood and premise on a trial basis. Otherwise, it is unusual for coaxial cable, microwave or fiber to be deployed to the premise. The internal carrier networks of twisted-pair, microwave and coaxial cable are rapidly being replaced with fiber—in many cases that replacement process is virtually complete. Microwave and satellite have continuing application in certain areas due to climate, terrain and population density. They also are used for backup purposes, in the event of a catastrophic failure of the primary facilities, and for access to sparsely populated areas and island nations.

Two-Way

Two-Way or duplex, communications is conversational in nature. Such a mode of communications is absolutely fundamental to the PSTN, as the parties in a voice conversation require the ability to communicate in both directions.

Circuit Switched

Circuit Switched networks are appropriate for voice PBXs and various types of network exchanges, as they provide a continuous talk path for the duration of the conversation. Dedicated, leased-line circuits are provided for very large organizations which communicate intensively between fixed locations (e.g., PBX tie trunks).

Narrowband

Narrowband (low capacity) facilities are quite satisfactory for most voice communications. Wideband (DS-1 and DS-3) access applies to high-capacity local loops for PBX applications. Broadband communications is currently limited for the most part to backbone carrier networks.

Ubiquitous and affordable

Ubiquitous and affordable are key terms in the voice world, at least in developed countries. In fact, universal access to high-quality, affordable service now is viewed as a basic human right in many countries.

Interconnection

Interconnection is fundamental to the PSTN and provides for connection between voice terminals, virtually regardless of location. LECs, IXCs and international carriers all are interconnected.

Hierarchical

Hierarchical structure of PSTNs is traditional, with multiple levels of carriers and switches, including Local Exchange Carriers (LECs), IntereXchange Carriers (IXCs), and International Record Carriers (IRCs). As noted in Chapter 6, hierarchical switch structures dominated carrier network design for many years. Contemporary configurations tend to be flatter, with many switches serving multiple purposes. Increasingly, the network intelligence tends to be centralized, with a small number of databases serving to provide multiple switches with routing instructions, for instance.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

Data Over Voice Networks

The next step in the evolution of networking was that of data transmission over voice networks. In the late 1950s large organizations in North America wanted to move data over telephone lines. This first was accomplished with a variation of the IBM 729 tape drive, which interfaced with the analog PSTN through a Bell dataset (1957) [8-2], or DataPhone (1961) [8-1], via an acoustic coupler and telephone set; an exact replica reconstituted the digital data stream on the receive end. Datasets quickly spread around the world. The telephone companies and PTTs rented the datasets to end users; deregulation let users acquire and interconnect their own equipment. The original datasets connected to the PSTN through a Direct Access Arrangement (DAA) device which served as a coupler, or protector, to protect the network from high signal levels, out-of-band frequencies, and aberrant voltages. This protection is incorporated into contemporary modems and other devices and is standardized and regulated by the ITU-T on an international basis and by the FCC (US) and other national regulatory bodies.

The telephone companies began to digitize their networks in the 1960s, as digital technology became reliable and inexpensive enough to support telecommunications applications and as the requirement surfaced for increased bandwidth in the carrier networks. Digital transmission facilities, in the form of T-carrier (North America) and E-carrier (Europe), increased the traffic capacity of existing facilities. In the 1970s, analog Electronic Common Control (ECC) switches began to be replaced with fully digital switches. Data transmission at relatively high speeds and over fully digital networks became a reality, although it would be a number of years until such capability became widely available.

Dataphone Digital Service (DDS) was the first publicly available service that was digital from end-to-end. Although still in wide use, it now competes with E/T-carrier, X.25, ISDN, Frame Relay, SMDS, and ATM for data transmission.

Data Networking Over the WAN (and MAN): Digital Data Networking

The evolution of data communications progressed at a snail’s pace for over a hundred years. For much of that time, neither the applications nor the enabling technologies existed. DDS and X.25 were major steps forward in the 1960s; T-carrier added to the solutions suite in the 1970s. ISDN began to appear in the 1980s, but never developed into a viable service offering. Only very recently has ISDN emerged from 25 years of obscurity to offer cost-effective solutions in certain applications.

Recently the evolution of digital data networking over Wide Area Networks (WANs) and Metropolitan Area Networks (MANs) has progressed with truly blinding speed. Frame Relay and SMDS are now widely deployed both domestically and internationally. ATM, while currently deployed on a limited basis, is viewed by most industry experts to be the network technology of choice far into the future. Broadband ISDN, the ultimate service offering of ATM, is touted as the culmination of network technologies in a broadband service scenario.

Clearly, digital transmission offers significant advantages, especially for data transmission. The advantages include increased bandwidth and bandwidth utilization, improved error performance and increased throughput, and enhanced management and control. This chapter focuses on conventional digital data networking options including dedicated leased lines, circuit switched connections, and packet switching; specifically Dataphone Digital Service (DDS), Switched 56, T-carrier, Packet Switching (X.25), and ISDN. An introduction into emerging data networking options will be presented in much greater detail in a later section including Frame Relay and Cell Relay (SMDS, ATM, and B-ISDN).

Dataphone Digital Service (DDS)

Dataphone Digital Service (DDS), also known as Digital Data System and SubRate Digital Loop (SRDL), was introduced by AT&T in 1974 [8-2], but the term now is used generically to describe an end-to-end, fully digital, dedicated service provided by most carriers. DDS is widely deployed in the United States and Canada and many other developed countries and is intended for relatively high-speed data transport between purely digital devices (computers). Employing specially-conditioned, dedicated, leased-line circuits provided to user organizations by the carriers, a DDS configuration may be either point-to-point or multipoint. In either case, all network control is the responsibility of a designated head-end system. The head-end, usually in the form of a Front-End Processor (FEP), controls all access to the network through a process of polling the remote devices. Additionally, all communications must pass through the head end; in other words, devices cannot communicate directly, as would be the case in a mesh network, where all locations are interconnected directly.

DDS is intended for full-duplex (FDX) synchronous communication provided over 4-wire circuits between devices of significance, (e.g., mainframes) and which communicate intensively (frequently and passing significant volumes of data). The DDS network provides network timing and synchronization through a master clock, to ensure that all clocks in all slaved network nodes operate at the same rate, or clock speed. These same timing signals are provided to end user Data Communications Equipment (DCE) for transmission synchronization. DCE is in the form of a DSU/CSU, as described in previous chapters. The DSU/CSU generally will operate at the full line rate, or on a subrate basis (lower speed), as required. While transmission generally is full-duplex (FDX), half-duplex (HDX) and simplex transmission is also served.

Transmission rates vary, within limits, according to the user organization’s requirements. Bandwidth generally is available at line rates of 2400 bps, 4800 bps, 9600 bps, 19.2 Kbps, and 56 Kbps (64 Kbps service is available in some areas). DDS signals actually are carried inside T1 channels in the carriers’ internal networks (T1 will be discussed later in this chapter).

While the cost equation of DDS circuits varies according to specific carrier tariffs and pricing strategies, cost is sensitive to distance between the points of termination and the level of bandwidth—such is the case with all dedicated leased-line services. A traditional rule of thumb is that DDS generally is cost-effective in applications that require communications between two locations greater than one hour per day at 56 Kbps.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

The cost equation changes where multiple locations are connected in a multipoint network configuration. A multipoint circuit also is known as a multi-drop circuit in telephone company parlance, as local loop connections historically are dropped from poles where they connect to larger cables. Multipoint circuits are also referred to as fantail circuits, as they fan out like the tail of a fish on the distant end. As shown in Figure 8.1, a headquarters data center in New York might be connected to a regional data center in Seattle. Field offices in Everett and Tacoma can cost-effectively take advantage of the same coast-to-coast circuit, as the incremental circuit mileage is low and the associated cost of those additional drops, therefore, is low.

Figure 8.1 DDS leased lines connecting data centers in New York and Seattle, with drops to Everett and Tacoma.

In such a multipoint network, the head-end addresses each remote system connected to the circuit, on the basis of a unique logical address and in a user-definable and variable polling sequence. The target device recognizes its address and responds across the network—all other devices remain silent. At that point, the two computer systems conduct a dialogue until such time as either the data transfer is complete or until the head-end truncates the communication in order to address other devices according to its programmed polling schedule. ATM (Automatic Teller Machines) typically are connected to the central bank in such a manner. In a typical ATM scenario, the central computer polls the individual ATMs, downloads the user’s request for a cash withdrawal, matches the account number and PIN for authentication purposes, queries the centralized database to determine the assigned level of withdrawal privileges and the current account balance, and either authorizes or denies the cash withdrawal.

DDS provides excellent reliability, which generally is stated as being 99.5%. All dedicated services, however, are susceptible to catastrophic failure from such causes as cable-seeking backhoes. Therefore, network redundancy must be considered in the form of either back-up DDS circuits or some alternative network service.

From an applications perspective, DDS is used for relatively intensive data-only communications applications between fixed physical addresses. In such an environment, it can be highly cost-effective, as usage charges do not apply to network traffic. Typical applications include connecting data centers for purposes of file transfer or data backup. Image transfer and other bandwidth-intensive applications such as CAD (Computer-Aided Design) can make cost-effective use of DDS circuits, also benefiting from the bandwidth and excellent error performance offered by the dedicated digital circuit. DDS also serves to connect e-mail and Group IV facsimile servers in a messaging network.

Switched 56 Kbps

Switched 56 is the generic name for Digital Switched Access (DSA), although 64 Kbps service is available in some areas. Switched 56 is a circuit-switched digital service intended generally for the same applications as DDS, although it is more cost-effective for less intensive communications. Although the service is switched, rather than dedicated, most of the general characteristics and all of the components are the same as DDS; the sole exception being that digital carrier exchanges are involved in setting up the DSA connections. DTE is in the form of computer systems that connect to digital local loops through DCE in the form of a DSU/CSU. Digital exchanges serve to switch the connection (see Figure 8.2), which is provided through digital carrier transmission facilities on the basis of special routing logic.

Figure 8.2 Switched 56 Kbps service.

The key difference between DDS and Switched 56 is that the calls are switched between physical locations on the basis of a logical address, which is the computer equivalent of a voice telephone number. In fact, Switched 56 is the digital data equivalent of a circuit-switched voice call through the PSTN. Based on specific routing instructions, the digital network switches establish the end-to-end circuit over entirely digital circuits. The call is set up, maintained, and torn down much like a voice call and it is priced in much the same way; the cost of the call is sensitive to distance, duration, time of day, and day of year. The cost of the call and of the local loop ($30 to $75 per month), of course, are dependent on specific carrier tariffs and pricing strategies. As the carriers’ Switched 56 service networks typically are not interconnected, calling generally is limited to each specific carrier domain unless the user has made other arrangements.

While DDS is more cost-effective for applications in which communications are intensive between specific physical locations, Switched 56 Kbps service is more cost-effective for communications between locations that communicate less frequently or that communicate lesser amounts of data. Switched 56 services often are employed as a back-up to DDS facilities; calls are switched through the highly redundant carrier networks, rather than relying on vulnerable dedicated circuits as is the case with DDS.

Digital Carrier Systems and Networks: T-carrier

Carrier systems are defined as systems that derive multiple logical channels from a single physical communications path, thereby supporting multiple communications. Initially developed for use within public carrier (LEC and IXC) networks, the systems provided increased traffic capacity between exchanges without the requirement for additional transmission facilities. As voice traffic grew in the post-war (W.W.II) period, the Central Office (CO) exchanges were strained, as were the transmission facilities connecting them—carrier systems solved that problem [8-1].

The original N-carrier (N = Number of channels) system, introduced in 1950, employed twisted-pair cable for connecting CO exchanges on an analog basis. A 2-wire or 4-wire analog connection employed multiplexers to deliver groups of 12 and, later, 24 Frequency Division Multiplexed (FDM) voice-grade channels. Technology was developed to provide supergroups of 60 channels and master-groups of 600 channels [8-2], [8-3], and [8-4].


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

L-carrier (L = Larger) was quite an improvement, employing coaxial cable and an analog transmission scheme. L5E, the last L-carrier system, used 22 coaxial pairs (tubes) to carry a total of 132,000 simultaneous voice grade conversations. Although this was an impressive improvement over N-carrier, the inherent problems of analog transmission were still present. Additionally, the coax cables were expensive and bulky, and the analog Radio Frequency (RF) amplifiers were expensive and prone to failure [8-2] and [8-3].

Digital carrier was first introduced by the U.S. Bell System in 1957 in Newark, New Jersey in 1957. Designated T-carrier (T = Trunk), it referred to a specific set of cable pairs and digital repeaters spaced every 6,000 ft. [8-5]. T-carrier was rapidly and extensively deployed throughout the carrier networks, initially for short-haul interexchange trunking [8-2]. T1, also known as digroup (digital group), was first offered commercially by AT&T in 1977 on the basis of a special assembly tariff, and was added to the interstate DDS Tariff #267 in December 1981 [8-6]. In 1983 it was tariffed by AT&T under the name Accunet 1.5. T1 provides 24 channels based on a convenient multiple of 2 x 12 channels that formed the basis for the original analog N-carrier [8-2]. Currently, there are about 200,000 private and public T1 links in service, and about 1,200 private networks are based on T3 [8-7].

T-carrier Concept

T-carrier is a dedicated, digital, leased-line service offering that employs time division multiplexing (TDM) in order to derive multiple channels from a single four-wire circuit operating in full duplex (FDX) transmission mode. In capsule, T-carrier offers the advantages of digital error performance, increased bandwidth, and improved bandwidth utilization. As is the case with digital services it also delivers increased management and control capabilities to the carriers and end users. Additionally, T-carrier is medium-independent; it can be provisioned over twisted-pair, coax, microwave, satellite, infrared, or fiber optic cable. As is the case with any dedicated service offering, T-carrier cost is sensitive to distance and bandwidth. While T-carrier initially was deployed in support of voice transmission, it supports data, image and video, as well. Further, T-carrier will support any and all such information streams on an unbiased basis—it offers the advantage of supporting integrated communications. As shown in Figure 8.3, T-carrier can obviate the need for multiple voice, facsimile, data, video and image networks [8-3] and [8-4].

Figure 8.3 T-carrier as a replacement for multiple dedicated, leased-line networks.

The significance of T-carrier extends well beyond its practical advantages. Specifically, as the first digital carrier system, it set the standards for digital transmission and switching, including the use of Pulse Code Modulation (PCM) for digitizing analog voice signals. T-carrier not only set the basis for the North American digital hierarchy (Table 8.1), but it led to the development of similar standards, such as E-carrier in Europe (Table 8.2) and J-carrier in Japan. Ultimately, the CCITT (now ITU-T) developed international standards in order to ensure interconnectivity. Although T-carrier, E-carrier, and J-carrier are very different in terms of certain specifics of the protocols employed (e.g., transmission rates, encoding techniques. and signaling and control methods), their basic characteristics are much the same.

Table 8.1 North American Digital Carrier Hierarchy (T-carrier)
Digital Signal (DS) Number | Data Rate (Mbps) | Number of 64 Kbps Channels (DS-0’s) | Equivalent Number of Tx’s
DS-1 (T1) | 1.544 | 24 | 1 T1
DS-1C (T1C) | 3.152 | 48 | 2 T1
DS-2 (T2) | 6.312 | 96 | 4 T1, 2 T1C
DS-3 (T3) | 44.736 | 672 | 28 T1, 14 T1C, 7 T2
DS-4 (T4) | 274.176 | 4032 | 168 T1, 84 T1C, 42 T2, 6 T3

Table 8.2 International (ITU-T) Digital Carrier Hierarchy (E-carrier)
Level Number | Data Rate (Mbps) | Number of 64 Kbps Channels (DS-0s)
1 | 2.048 | 30
2 | 8.448 | 120
3 | 34.368 | 480
4 | 139.264 | 1920
5 | 565.148 | 7680

Channelized T-carrier

The basic component of T-carrier is a 64 Kbps channel, referred to as DS-0 (Digital Signal #0). Digital carrier is a channelized service, at least in a standard implementation. In other words, a single, high-capacity digital circuit supports multiple logical channels, with each channel supporting a separate conversation. A T1 circuit, for instance, operates at 1.544 Mbps, supporting a standard 24 Time Division Multiplexed (TDM) channels, each of 64 Kbps. E1 supports 30 TDM channels of 64 Kbps; J1 supports 24 channels as does T1.

T-carrier hierarchy standards (Table 8.1) were set by the American National Standards Institute (ANSI) in its T1.107 specifications. Beginning at the T1 level, the hierarchy progresses up to T3, which provides bandwidth of approximately 45 Mbps in support of 672 channels. Most end users subscribe to T1 services, as one or more T1’s satisfy their bandwidth requirements. Generally, the next step is T3, with the intermediate levels being unusual in end-user implementation, although they are employed extensively in the carrier networks. As one might expect, as the data rate increases, the carrier reference frequency increases, and issues of signal attenuation and crosstalk increase; this fact creates special engineering problems [8-6] that can be resolved by various means including spacing repeaters more closely together [8-5].

The process of transmitting data (voice, data, video, or image) in given and consistently repeated channels, or time slots, is know as byte interleaving. Each byte of a given conversation to be transmitted is accepted by the MUX, assuming capacity is available, and is assigned one or more time slots. In a baseline example, those 64 Kbps time slots are reserved for that conversation, with the MUX providing the transmitting device with regular and repeated access to them for the duration of the communication.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

Unchannelized T-carrier

Unchannelized T- carrier can be used to support bandwidth-intensive services that do not lend themselves to 64 Kbps channelization and standard framing conventions [8-8]. In other words, the traditional convention of 64 Kbps channels can be abandoned in favor of carving the T1 pipe into any segments of bandwidth of any usable size or increment. Additionally, any combination of bits can be transmitted, including an infinite number of zeros, without concern for the violation of the 1s density rules; in other words, a clear channel of 64 Kbps or more, rather than a 56 Kbps channel [8-5] and [8-6]. For instance, a very high-speed data communication or a full motion videoconference, might require a full T1 pipe. A less intensive communication might require 512 Kbps (8 channels, or one-third of a T1 facility).

Such services are supported through customer equipment in the form of highly intelligent TDM MUXs. In a private, dedicated leased-line network, this is easily accomplished. However, the carrier must be aware of the fact that such use will be made of the facility, in order that the entire facility can be properly allocated and managed.

Encoding

While T1 is a digital service, it supports the transmission of analog data as well. Voice and video, analog in their native forms, must be digitized through the use of codecs prior to being transmitted over a T1 circuit. The standard digitizing technique for voice, known as Pulse Code Modulation (PCM), was developed as an integral part of T-carrier. It also became the standard technique for digitizing voice in PBXs and other devices, for the obvious reason of providing seamless transmission between such devices and the network. The quantizing techniques typically employed include PCM and ADPCM; non-standard approaches included CVSD, VQL, VQC and HCV.

Pulse Code Modulation (PCM)

PCM is based on the Nyquist theorem developed by Harry Nyquist in 1928. Nyquist established the fact that the maximum signaling rate achievable over a circuit is twice the number of signal elements [8-9]. In consideration of the Nyquist theorem, PCM specifies that the analog voice signal be sampled at twice the highest frequency on the line. As a voice-grade analog line provides 4,000 Hz of bandwidth, the signal must be sampled 8,000 times per second. Each sample is a measurement of the amplitude of the sine wave; the frequency of signal change is automatically taken into account. The individual samples are encoded (quantized) into an 8-bit binary (digital) approximate value, based on a table of 255 standard values of amplitude. The individual samples then are transmitted in regular time slots over the T-carrier circuit, with the process reversed on the receiving end of the connection in order to reconstitute an approximation of the original analog voice signal (Figure 8.4). While the sampling rate and the 8-bit coding scheme were the subject of much debate, the yield is very high quality voice, although the bandwidth requirement is a bit excessive. It should be noted that sampling that is too infrequent results in a reconstructed analog voice signal that is less than smooth and accurate and, therefore, not pleasing. This phenomenon yields unacceptable levels of quantizing noise [8-2] and [8-5].

Figure 8.4 PCM encoding of analog voice signal, with reconstruction of approximate analog voice.

      4,000 Hz
        X 2
      8,000 Samples/Second
        X 8 Bits per Sample
      64 Kbps

As noted in the above calculation, 8,000 8-bit samples per second yields a bandwidth requirement of 64 Kbps for a PCM-encoded digital voice signal. As PCM was the first standard technique widely used in digital carrier systems, the 64 Kbps channel became standard, worldwide, for all forms of digital networking.

Differential Pulse Code Modulation (DPCM)

DPCM is more bandwidth efficient than PCM, as only the changes in signal level are encoded and transmitted. Based on the logical assumption that the change, or differential, in the voice signal occurs relatively slowly, fewer bits can be used to represent each sample; 4 bits are generally used in this form of compression, which yields a 2:1 compression ratio. DPCM generally provides voice quality comparable to that of PCM. However, noise (distortion) may result on the occasions in which the signal varies significantly from one sample to another (e.g., a 4,000 bps modem transmission over a T-carrier circuit).

Adaptive Differential Pulse Code Modulation (ADPCM)

ADPCM can be used to further improve on the quality of DCPM, without increasing the number of bits required. Through increasing the range of signal changes which can be represented by a 4-bit value, DPCM is adapted to provide higher transmission quality. As the result is a 32 Kbps voice stream, the bandwidth per conversation is halved; twice as many conversations (48 versus 24) can be carried over a T1 facility [8-5].

    4,000 Hz
      x 2
    8,000 Samples/Second
      x 4 Bits per Sample
    32 Kbps

As ADPCM will not interface with a CO exchange based on PCM, it is necessary that special equipment be used to insert two compressed voice conversations into a single PCM channel. A Bit Compression Multiplexer (BCM) generally is in the form of a printed circuit board which fits into the T1 MUX [8-5].

Digital Speech Interpolation (DSI)

DSI is rooted in a voice compression algorithm known as Time Assigned Speech Interpolation (TASI) developed by Bell Labs in the 1950s for transatlantic telephone cable systems [8-10]. DSI makes the legitimate assumption that there are predictable pauses in normal human speech; during those pauses, additional voice signals are inserted. This technique is sometimes referred to as silence suppression. As DSI works on the basis of statistical probabilities, it can be employed effectively only when there are a significant number of voice conversations supported. For instance, 72 channels yield additional compression of 1.5:1, and 96 channels yield an additional 2:1, for a total compression ratio of 8:1 (8 Kbps per voice conversation). Newer implementations can provide as much as 16:1 (4 Kbps).

DSI suffers the disadvantage of degradation of the signal quality during periods of heavy use. If the parties are speaking rapidly, with few pauses, the voice signal can be clipped. The more conversations supported, however, the lower the statistical probability of such degradation. DSI also suffers from high overhead. Regardless of the number of channels supported, as much as 96 Kbps of overhead is required.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

Quantizing variations are sometimes employed, although they are neither generally accepted nor widely deployed. Those variations include the following [8-5]:

• Continuously Variable Slope Delta (CVSD): Compression Ratio = 4:1 (16 Kbps), or 8:1 (9.6 Kbps)
• Vector Quantizing Code (VQC): Compression Ratio = 4:1 (16 Kbps)
• High Capacity Voice (HCV): Compression Ratio = 8:1 (8 Kbps)

Framing

T-carrier employs a very specific set of conventions to transmit information, with framing being one example. Using T1 as an illustration, each channel of input is time division multiplexed into a T1 frame, or set of data. In other words, conversation 1 might be allocated time slot 1 (channel 1), conversation 2 might be allocated time slot 2 (channel 2), and so on through conversation 24 and channel 24. That set of sampled data is inserted into frame 1, which is appended by a framing bit in order to distinguish it from subsequent frames of data. The process is then repeated for frame 2, and so on.

The combined processes of voice encoding and framing yield a total T1 bandwidth of 1.544 Mbps. Of that total, 1.536 Mbps is available for information transfer, as noted in the following calculation; the remaining 8 Kbps is required for framing.

    4,000 Hz
      x 2
    8,000 Samples/Second
      x 8 Bits per Sample
    64 Kbps = DS-0
      x24 Channels
    1.536 Mbps
    + 8 Kbps Framing
    1.544 Mbps = DS-1 (T1)

There exist several generations of framing conventions, designated as D1, D2, D3, D4, and Extended SuperFrame (ESF). Additionally, the ITU-T has developed an international set of recommendations for framing digital carrier signals.

D1 Framing

Developed in 1962, D1 framing robbed the Least Significant Bit (LSB), the eighth bit, in order to insert a signaling bit in each channel of each frame; signaling bits were alternating 1s and 0s. The quality of digitized voice conversation was not affected, as 7 bits are satisfactory for reconstructing a high-quality approximation of the analog voice input. Data, however, is seriously impacted by truncating an 8-bit value. As a result, data transmission was limited to 56 Kbps. Data remains limited to 56 Kbps in many carrier networks due to similar limitations imposed in D4 framing. While D1 framing no longer is used, the least significant bit is still robbed, even in the contemporary D4 framing technique.

D2 Framing

D2 Framing was used to create a superframe, a 12-bit pattern for framing locators. Information was transmitted in a 12-frame sequence or superframe.

D3 Framing

D3 Framing, which is still in use, assumes that all inputs are analog, whether they are voice or data. It uses a superframe format and sequence bits.

D4 Framing (M24 Superframe)

D4 Framing (M24 Superframe) uses a repeating 12-bit sequence (1000 1101 1100), repeated every 12 frames, to allow robbing of the least significant bits of the sixth and twelfth frames only. Voice and data are accommodated, with data being treated as a digital input. While this improves available signal capacity and yields better voice transmission, data is still limited to 56 Kbps. Additionally, one’s density must be maintained through the insertion of stuff bits. Considered together, the twelve frames are designated a superframe.

Extended Superframe (ESF)

Extended Superframe (ESF), originally tariffed by AT&T in 1985, is now widely available. ESF superframes are 24 frames in length; signaling is accomplished in frames 6, 12, 18, and 24. The bit positions liberated by ESF are used for error checking and network management. ESF offers the advantages of nondisruptive error detection (6-bit CRC) and network management, using only 8 Kbps of overhead [8-2], [8-3], and [8-4].

ITU-T Framing Conventions

ITU-T Framing Conventions are quite different from those described above, which are used in North America and Japan (modified). ITU conventions call for Level 1 (E1) to employ 32 DS-0 channels, 30 for information and two specifically designated for signaling and control. The functional equivalent of framing bits are carried in the first such DS-0 channel, while the second carries signaling bits [8-5].

Transmission

Transmission facilities can include unshielded twisted-pair (22 or 24 gauge), shielded copper, coaxial cable, microwave, satellite, infrared or fiber optic cable. Therefore, Digital Carrier is medium-independent. A T-carrier circuit is also know as a T-span or T1 pipe. Regenerative repeaters are used to reshape and boost the signal at regular intervals, every 6,000 ft. in a twisted-pair system. The repeaters are powered by the CO exchange at levels up to 100 volts. The repeaters maintain their synchronization through the transmission bit stream. Therefore bipolar transmission is critical, as is the 1’s density rule.

Hardware

DS-1 equipment is required both for end-user organizations and for carriers. That equipment must be of the same generation in order to effect compatibility. Ideally, within the user organization, it should be of the same origin and software generic as is the carrier side in order to deliver the same functionality and feature set.

Channel Banks

Designed for voice-only service in analog applications, channel banks are used for interfacing analog switches (PBXs and COs) to DS-1 circuits. Channel banks perform two functions in sequence. First, they multiplex up to 24 (T1) analog signals on a common Pulse Amplitude Modulation (PAM) electrical bus. Second, they encode the individual PAM channels into a digital format, using PCM, for transmission over a DS-1 circuit [8-3] and [8-4].

Channel banks also will accommodate digital data. As relatively unintelligent devices, channel banks place each conversation on a separate channel; for instance, a 9.6 Kbps data conversation occupies a 64 Kbps channel, just as does a 56 Kbps data transmission or a digitized voice conversation. Therefore, channel banks do not make efficient use of available bandwidth. Combined channel banks and CSUs often are in the form of printed circuit boards which fit into PBX card slots for seamless interface to a network T1 circuit.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

Channel Service Units (CSUs) and Digital Service Units (DSUs)

Discussed at length in Chapters 2 and 7, DSUs are devices which, in combination, interface the user environment to the digital network at the physical (mechanical) and electrical level, corresponding with Layer 1 of the OSI model. In contemporary systems, they generally are combined into a single device, known as a CDSU or an ISU (Integrated Service Unit), which may be under the skin of another device, such as a multiplexer (MUX). They are used in a wide variety of digital data networks, including DDS and T-carrier.

Multiplexers (MUXs)

MUXs are a significant step up from channel banks in terms of intelligence, capability, and cost. Originally based on channel banks and containing CSUs and DSUs, contemporary Statistical Time Division Multiplexers (Stat MUXs) offer a tremendous range of flexibility and capability. MUXs typically offer capabilities that include support for both channelized and non-channelized service, support for multiple medium interfaces (e.g., twisted-pair, coax, and fiber), support for multiple trunk types (e.g., DID and combination), support for superrate transmission (>64 Kbps channels), and support for subrate transmission (<64 Kbps channels). Additionally, they offer the advantage of user-definable configuration, internal diagnostics, voice compression, and T-carrier to-E-carrier protocol conversion. Intelligent MUXs also have the ability to allocate bandwidth on a priority basis for specified users and applications, and even to reserve bandwidth, perhaps for a scheduled videoconference. Finally, intelligent MUXs can allocate bandwidth on a dynamic basis, assigning channel capacity as required to meet the demands of traffic. For instance, a videoconference may require superrate capacity for a short period of time, multiple low-speed data communications may require subrate channels for a brief moment and, at other times, the entire capacity of the circuit may be in support of 32 Kbps voice conversations.

Nodal Multiplexers

Nodal MUXs, a further step up the MUX food chain, act as T-carrier network switches. In addition to serving as a traditional MUX for the resident site, they also serve as true networking devices, much as does a combined CO/Tandem switch in the voice world. Nodal MUXs provide the additional function of dynamic alternate routing (Figure 8.5), which allows them to switch traffic over an alternate path in the event of a condition of blockage or failure in the primary circuit.

Figure 8.5 Private T-carrier network with nodal multiplexers to provide dynamic alternate routing.

Digital Access Cross-Connect Systems (DACS or DCCS)

These are nonblocking, electronic common control switches which serve to cross-connect digital carrier bit streams on a buffered basis by redirecting individual channels or frames from one circuit to another. Effectively, they provide an electronic common control means of cross-connection which replaces the traditional manual method of physical cross-connection of wires. A DAC can redirect traffic in order to better manage the capacity and performance of the T-carrier network [8-10]. Although originally developed for carrier use, DACS also are deployed in large user organizations to support private digital carrier networks. Smaller versions, residing on a PC, are available for less communications-intensive environments. Typically of significant port capacity, DACS provide support for DS-0, DS-1, and DS-3 [8-3].

Variations on the Theme: E-carrier and J-carrier

While the theme for digital carrier was set in the United States, the concept was quickly adopted by the CEPT (Committee on European Post and Telegraph). The resulting E-carrier standard is quite different in its implementation. The Japanese version, J-carrier, is similar to T-carrier, but with differences sufficient to cause incompatibility.

E-carrier is characterized by an entirely different digital hierarchy, (Table 8.2) beginning with E-1, at 2.048 Mbps. E-1 supports 30 clear information channels; 2 channels are set aside for signaling and control. This non-intrusive signaling and control convention, plus the fact that there are no 1s density rules which apply, results in E-carrier’s providing clear channel communications of a full 64 Kbps per channel. The E-carrier multiframe (16 Frames) corresponds to the T-carrier superframe (12-24 Frames).

J-carrier is quite similar to T-carrier, although the hierarchy is slightly different. Line coding and framing also vary from the U.S. ANSI approach. The advantages of these differences are questionable; incompatibility is assured, which fact should not be surprising. The J-carrier digital hierarchy begins at 1.544 Mbps, proceeding to 6.313 Mbps, 32.064 Mbps (J1), 97.728 Mbps (J3), and 397.20 Mbps [8-3] and [8-6].

Fractional T1

Fractional T1 (FT1), previously offered only in Canada, first was tariffed in the United States in 1987 by Cable and Wireless. Now offered by many LECs and IXCs, FT1 provides T1 functions and features, but involving fewer DS-0s. It is offered in fractions of T1 channel capacity, generally at 1, 2, 4, 6, 8 or 12 DS-0 channels. Subrate transmission also is available at speeds of 9.6 Kbps. FT1 is particularly applicable where remote locations are connected to a more significant location such as a regional office. At that point, they connect to a full T1 MUX or nodal processor, which aggregates the traffic with that of the larger site over a full T1/T3 backbone network. FT1 also serves videoconferencing, data communications, and other applications that require more than 56/64 Kbps, but less than a full T1 [8-4].

T-carrier Applications

The applications for Digital Carrier are many. Large user organizations find Digital Carrier services to be highly cost-effective for local loop access, typically replacing multiple, individual PBX trunks. Large corporations find T-carrier effective for private, leased-line networks or access to virtual private networks (VPNs). The ability of T-carrier to accommodate voice, facsimile, data, video, and image information on an unbiased basis and, therefore, to eliminate or reduce the number and variety of specialized circuits, offers great advantage.

Internet service providers commonly use T-carrier for access to the LEC CO, as well as access to an Internet backbone provider. Given current US tariffs, a T1 clearly becomes cost-effective in replacement of 8-10 or more individual circuits; a T3 becomes cost-effective at a level of 3-4 T1s. Notably, the relationship is far different in Europe and parts of Asia, where leased line costs are considerably higher.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

Even in comparison to newer LAN internetworking technologies such as Frame Relay, T-carrier holds it own. For instance, a large bank in Missouri recently tripled the size of its private T-carrier network to 30 nodes. They have plans to increase the network by another 20 nodes by 1997. The primary application is the transport of data from ATM machines and remote bank branches to IBM mainframes located at the central site in St. Louis. The T-spans are leased from a combination of IXCs [8-11].

T-carrier Developments and Futures

The most significant recent and emerging developments of digital carrier relate to equipment and applications. Many manufacturers of CSUs/DSUs have incorporated intelligence into their products, in effect turning them into commodity-level MUXs. MUX manufacturers have developed adapter cards which allow the transmission of SNA, ISDN, Frame Relay, and ATM over T-carrier. Direct connection of Ethernet and Token Ring LANs is sometimes supported, with the MUX effectively acting as a bridge or router. Some manufacturers have also released direct SONET fiber optic interfaces at speeds up to 155 Mbps. Contemporary MUXs are addressable devices that can be managed and controlled remotely. Additionally, several manufacturers of traditional MUXs have incorporated inverse multiplexing capabilities. Inverse multiplexing will spread a high-bandwidth transmission (a videoconference or file transfer) across multiple DS-0 channels or across multiple DS-1 circuits.

T-carrier certainly offers cost and performance advantages when compared to individual trunking. Additionally, it is attractive due to its ability to integrate voice, data, video, and other forms of information. Additionally, competition and deregulation have caused T-carrier costs to drop dramatically during the past ten years, although they recently have begun to increase. Yet, in a private, leased-line network application, T-carrier suffers from the same flexibility and vulnerability issues that affect alternative leased-line technologies. As a result, virtual private networks have replaced T-carrier networks in many large, voice-intensive user applications. Additionally, ISDN competes effectively with T-carrier in PBX-CO trunking applications. In data-intensive applications, T-carrier is losing ground to emerging broadband network technologies such as Frame Relay, SMDS, and ATM. Ultimately, ATM is likely to replace T-carrier, altogether.

In the meantime, however, T-carrier continues to enjoy a strong following, with T1 MUXs being the hottest-selling equipment for enterprise-wide networking. According to International Data Corporation, 1995 mux sales were $1.2 billion worldwide, an increase of 20% over the previous year. IDC forecast sales of $1.5 billion for 1996 [8-11].

Digital 800 Services

Digital 800 service is a very new offering, having been announced and trialed in 1994 by AT&T; the first general release offerings were those of AT&T and MCI in January, 1995. The service currently is offered nationwide in the United States by AT&T (800 Multimedia) and MCI (MCI 800 Digital Service) at a cost of less than 30 cents per minute. In the case of AT&T, different rates apply to voice calls (typically 6 to 10 cents per minute under contract) and data (22 cents a minute for peak calling and 19 cents for off-peak) calls [8-12]. It is intended only for medium-to-large customers subscribing to high-volume 800 service offerings. Sprint Corporation announced its Toll-Free Switched Digital Service in December 1995.

Digital 800 uses the same numbering conventions used for voice calls, based on the North American Numbering Plan (NANP), which is governed by the ITU standard dialing scheme. Therefore, carrier interconnection is provided, a problem which plagues Switched 56/64 Kbps and Frame Relay data service offerings employing proprietary numbering schemes. Additionally, the 800 numbers are portable. In fact, the same, and even existing, 800 number can be used for both analog and digital voice and data.

The carrier network distinguishes the nature of the call and routes it to the call destination via the appropriate facilities. Digital calls are routed exclusively over digital facilities. Although capabilities differ by carrier, routing considerations can include type of call (digital data versus analog voice versus videoconference), originating NPA, and time-of-day. Separate and distinct and management reports are available for each class of calling activity [8-13].

Bandwidth-on-demand, within limits, is provided as an inherent part of Digital 800. Digital bandwidth is provided in 64 Kbps increments (Nx64), up to full T1 at 1.544 Mbps. Depending on the nature of the call (voice versus data versus videoconference) the appropriate amount of bandwidth is supported.

Termination of Digital 800 requires a digital local loop, which can be in the form of ISDN, T1, or Switched 56/64 Kbps service. Termination equipment varies according to the nature of the terminating loop, although an Inverse MUX is required in order to associate multiple 64 Kbps channels where required. The carriers have suggested that the Inverse MUX requirement is temporary, to be eliminated as soon as multirate ISDN is available.

Access to the service can be in the form of an analog dialup connection, Switched 56/64 Kbps service, or ISDN. Where multiple channels are required for a high-bandwidth transmission, an inverse MUX currently is required at the originating end of the connection.

Digital 800 issues abound, as the LECs are not fully equipped at this point to handle the potential demand for the service. Therefore, users should not assume that Digital 800 termination is possible in every location. The features differ significantly between AT&T and MCI, especially with respect to sophisticated routing capabilities of analog voice versus digital data calls. Additionally, the carriers have not yet established (nor are they likely to establish) network-to-network interfaces; in other words, all incoming call centers must use the same Digital 800 carrier.

Applications for Digital 800 primarily are business-to-business. The envisioned applications include catalog ordering, software uploads/downloads, online information services, publishing, graphics editing, videoconferencing, multimedia communications, video augmentation, and image augmentation. While the carriers have a lot of work to do in order to make Digital 800 ready for mass consumption, it is expected to be a mainstream business service offering by 1998 [8-13] and [8-14].


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

X.25 Packet Switching

Packet switching was invented in the early 1960s by Paul Baran and his research associates for the RAND Corporation. Interestingly enough, the concept first was published in 1964 as a means of transmitting secure voice for military application. In the late 1960s, the U.S. General Accounting Office (GAO) issued a report suggesting that there existed a large number of data centers supported, at least in part, by the federal government. Further, the report indicated that many of those data centers were underutilized, and others were severely stressed. The imbalance was due largely to the lack of a wide area network technology that would allow the sharing of those resources on a cost-effective basis.

As a result of that study, the Advanced Research Project Agency Network (ARPANET), the first sophisticated packet switched network, was created in 1971. ARPANET was developed to link computers on a time-share basis in order to share computer resources on a cost-effectively [8-15]. Specifically, ARPANET was designed to support various defense, higher education, and research and development organizations [8-16]. In 1983 the majority of ARPANET users spun off to form the Defense Data Network (DDN), also called MILNET (MILitary NETwork), which included European and Pacific Rim continents. The United States and European locations which remained ARPANET then merged with the Defense Advanced Research Project Agency Network to become DARPA Internet [8-17].

Packet switching soon was commercialized and made widely available by Telenet, Graphnet (a facsimile-like service) and others. Packet switching was utilized very early on and extensively in Europe, as well. In fact, packet switching quickly became available in most countries, and currently is virtually ubiquitous. The CCITT (now the ITU-T) in 1976 internationally standardized X.25 as the interface for a packet-switched network.

The wide availability of packet switching has made it consistently popular over the last twenty years or so. Additionally, packet networks are highly cost-effective for applications that require many-to-many connectivity, and which involve relatively low data volumes. That popularity is growing and is ensured well into the future, largely through its historical deployment as the network technology of the Internet. It should be noted that X.25 is an interface specification, and does not define the internal operations characteristics of the data network.

The Concept of Packet Switching

The basic concept of packet switching is one of a highly flexible, shared network in support of interactive computer communications across a wide area network (WAN). Previously, large numbers of users spread across a wide area with only occasional communications requirements had no cost-effective means of sharing computer resources (time-share) from their remote terminals. In specific, the issue revolved around the fact that asynchronous communications are bursty in nature; data transmission is in bursts of keystrokes or data file transfers, with lots of idle time on the circuit between transmissions in either direction or relatively small amounts of data. Additionally, those early networks consisted of analog, twisted-pair facilities, which offered very poor error performance and relatively low bandwidth.

Existing circuit-switched networks certainly offered the required flexibility, as users could dial up the various host computers on which the desired database resided. Through a low-speed modem, data is passed over the analog network, although error performance was less than desirable. However, the cost of the connection was significant, because calls were billed based on the entire duration of the connection, even though the circuit was idle most of the time. Dedicated circuits could solve the cost issue, as costs are not usage-sensitive; however, dedicated circuits are expensive. Further, users tended not to be concentrated in locations where they could make effective use of dedicated circuits on a shared basis. Finally, large numbers of dedicated circuits would be required to establish connectivity to the various hosts.

Packet switching solved many of those problems, in the context of the limitations of the existing networks—namely, analog, twisted-pair. Packet-switched networks support low-speed, asynchronous, conversational and bursty communications between computer systems. As packet-switched network usage is billed to the user on the basis of the number of packets transmitted, they are very cost-effective for low-volume, interactive data communications. This cost advantage comes from the fact that the bursty nature of such interactive applications allows large volumes of data transmissions from multiple users to be aggregated in order to share network facilities and bandwidth [8-17]. Further, packet-switched networks perform the process of error detection and correction at each of the packet switches, or nodes, improving the integrity of the transmitted data considerably.

Understanding the concept and nature of packet switching requires the examination of a number of dimensions and characteristics of such networks including packet structure, switching and transmission, error control, connection-oriented service, latency, permanent virtual circuits versus switched virtual circuits, protocol conversion, and access techniques.

Packet Structure

Information is transported and switched through the network on the basis of packets (Figure 8.6). Each packet is of a fixed maximum size, typically containing 128B (B=byte or octet) or 256B of payload (user data); packet sizes of up to 4,096B can be accommodated in some networks. The typical upper limit of a packet is 1,024B [8-18], as is the case in many airline reservation networks.

Figure 8.6 Packet structure.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

The payload data is encapsulated by a beginning flag (8 bits) and an ending flag (8 bits) that serve to the distinguish each packet from other packets traveling the same path. The beginning flag also serves as synchronizing bits in order that the packet nodes (intelligent switches) and the receiving terminal equipment synchronize on the rate of transmission. As discussed in Chapter 7, this approach reduces overhead in data transmission and improves the efficiency of transmission. A packet address field of 8 bits (4 bits for the calling DTE and 4 bits for the called DTE) is prepended to the data in order that the various packet nodes might route each packet to the target device. Control data (8-16 bits) includes the packet sequence number so that the target node and terminal equipment are able to identify errored, corrupted, or lost packets, or to resequence the packets should they arrive out of order. Further, the packet sequence number allows the identification of lost or corrupted (errored) data packets in a stream of data. Additionally, the control data includes the number of the virtual circuit (4 bits) and virtual channel (8 bits) over which the data will travel, if a path has been preordained. Finally, error control data is included in the form of a CRC check (16 bits), As discussed in Chapter 7, this level of error control offers a high degree of reliability [8-17].

Packet Switching and Transmission

In a typical scenario, the transmitting terminal, equipped with a modem, dials a telephone number to gain access to a local packet node on a circuit-switched basis through the LEC central office exchange. Alternatively, a short-haul dedicated circuit might connect the user location directly to the packet node. Once the connection to the packet node is established, the transmitting device sends a control packet across the network to establish a data session with the target host computer. The originating node receives that packet, checks for transmission errors, reads the address, and forwards the packet towards the destination, across the most direct and available link. The process is repeated at the next node and so on, until the data reaches the packet node serving the target host. That node sends the packet to the target, which acknowledges its receipt and establishes a session by responding with a control packet to the originating device.

At that point, the originating device begins a stream of data, segmented into packets, with each packet numbered sequentially. Each packet is routed through the network independently, from node to node, in the direction of the target device, based on the most direct and available path at that instant. Should a reasonable route not be available immediately, the packet will be held in queue in buffer storage for a reasonable length of time, until a link becomes available. Once the communication session is complete, a control packet is sent across the network to terminate the data call.

In this scenario in Figure 8.7, each packet may take a different route from transmitter to receiver, in what is known as a datagram mode of transmission. This mode, therefore, requires that the packets be resequenced before being transmitted from the final node to the receiving device, ARPANET and its X.25 successor, pioneered the concepts of locally adaptive routing, network message segmentation, and datagram transmission mode.

Figure 8.7 Packet switched network, supporting transmission in datagram mode.

The internodal links originally were dedicated analog trunks, which later were replaced by digital circuits—usually 56 Kbps DDS circuits. Over time, many of those circuits were replaced with T-carrier facilities. Currently, the facilities generally are high-speed fiber optic in nature, although all variety of analog and digital media are employed in consideration of specific network economics.

Error Control

X.25 also provides for error control through the use of a Cyclic Redundancy Check (CRC). Should an error occur in transmission, the node receiving that packet will recognize the error and correct for it through requesting a retransmission of the corrupted packet. Each node acting on the packet repeats that process. Additionally, lost packets are discovered at the destination node through examination of packet sequence numbers. Retransmissions of lost packets are then requested.

Error control was extremely important in early packet networks, as the facilities consisted of analog twisted-pair. Through a cascading error control process, the integrity of the individual packets and of the packet stream could be improved. However, this process is CPU-intensive, adding to the cost of the packet nodes. Additionally, the process is time-consuming, as each packet must be checked for errors prior to being forwarded to the next node.

Connection-Oriented

It should be noted that X.25 packet switching is a connection-oriented service. A call is set up over a shared path (virtual circuit), over which all packets may travel in support of a logical connection. On the other hand, each packet may travel over a different path, depending on the availability of the various network links at any given moment in time. Each packet of data is separately addressed and, therefore, is capable of working its way through the network independently of the other packets in a stream of packetized data. This characteristic of packet networks is a critical advantage, as the network and all of its elements are shared among large number of users—the cost of transmission across such a network is very low in the context of an appropriate application. Remember X.25 is an interface standard and does not address the internal operation of the network.

Permanent Virtual Circuits (PVCs) and Switched Virtual Circuits (SVCs)

Packet switching supports a large number of conversations over virtual circuits using the same, previously designated circuit or path. While the individual packets of the typical user may travel different paths, large users may be supported by PVCs. In this scenario, all packets will travel the same path between two computers, which path is established by routing instructions programmed in the involved nodes. Alternatively, the network may select the most available and appropriate path on a call-by-call basis using Switched Virtual Circuits (SVCs). Again, all packets in a given session travel the same path [8-19].


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

Protocol Conversion

As an option, packet-switched networks will accomplish protocol conversion (Figure 8.8). Protocol conversion can include any protocol that is well-established, well-understood, widely-deployed and, therefore, supported by the carrier. As this process of protocol conversion adds value, packet networks (X.25) are widely recognized as the first Value-Added Networks (VANs). Protocols supported typically include asynchronous, IBM Bisync (BSC), and IBM SDLC.

Figure 8.8 Disparate packet networks interconnected via X.75, with protocol conversion.

Latency

Latency or delay, is a troublesome and limiting characteristic of packet networks. As each packet may take a different route though the network, each may travel a route of a different length; therefore, propagation delay may vary from packet to packet. Additionally, each packet may travel through a different number of packet nodes, each of which must act on the packet to read its address, check for errors, request retransmissions of errored packets, and so on—this fact compounds the issue of packet delay. Further, each packet may encounter different levels of congestion in the network, which may add to packet delays. Finally, additional delay is imposed on each packet if protocol conversion is required. While this process adds value, it does add to the latency factor. The end result is that some level of latency not only is assured, but also is variable and uncertain in magnitude [8-6].

While this characteristic of packet switching does not affect some applications, it renders others ineffective. For instance, e-mail communications over the Internet is not seriously impacted, although the delays may be aggravating at times. On the other hand, isochronous (stream-oriented) communications such as realtime audio, voice, or video are not effectively supported over a packet network.

Access

X.25 actually is the ITU-T standard describing the physical, link and packet level protocols between the user DTE/DCE and the network [8-17] and [8-18]. Devices capable of packetizing the data are connected over a X.25 link. In a true X.25 environment, the user accomplishes the packetizing process through DCE in the form of a PAD (Packet Assembler/Disassembler), the standard for which is X.3. The PAD also may contain intelligence for password protection and performance reporting [8-8].

Occasional or casual users typically access a packet network on a dialup basis, from asynchronous PCs through modems. In such a scenario, the actual packetizing of the data is performed at the originating network node. For example, individuals accessing the Internet through an online information service often use this approach.

Large user organizations often access the network via a dedicated, leased-line link to the closest network node. Such access often is in the form of an unchannelized T1 facility, perhaps supporting frame relay. Large users connecting substantial hosts to a X.25 network present data to the node under the terms of a protocol known as subscriber Link Access Procedure Balanced (LAPB), which ensures error-free local access and egress on a full duplex (FDX) basis. The user data is segmented into a packet by the PAD, and encapsulated in a LAPB frame before presentation to the network [8-18] and [8-20]. The frame level procedure described in X.25 can be either the ISO High Level Data Link Control Procedure (HDLC) or IBM Bisync (BSC) [8-20]. Internet Service Providers (ISPs), for instance, make heavy use of such dedicated facilities.

Network Interconnection

X.25 networks are widely available as a Public Data Network (PDN) service offering, generally using packets of 128B or 256B. However, certain applications are supported more effectively by transmission of larger packets. For example, the airline reservation systems (e.g., American Airlines’ SABRE and United Airlines’ APOLLO) have deployed custom packet networks that use packet payloads of 1,028B. As this application involves the frequent transmission of relatively large sets of data (e.g., flight schedules, fares, and seating availability), a larger packet size is more appropriate. The larger packet size improves efficiency, because the payload is very large, while the overhead information is roughly the same as in the case of a smaller packet. While a larger packet is more likely to contain an errored bit, require retransmission and, therefore, reduce throughput; the custom reservation networks employ digital facilities in order to minimize this exposure.

The interconnection of such disparate networks is accomplished through an ITU-T standard known as X.75. Through an X.75 network-to-network interface, as depicted in Figure 8.8, issues of packet size are resolved in order that information flow is not affected.

Packet-Switching Hardware

The user of a X.25 packet network may require no hardware other than a PC and modem. Occasional and casual users of the Internet through an online information service (e.g., America Online, Australia Online, CompuServe and Prodigy) fall into this category. The packetizing of the asynchronous data is performed at the local X.25 node. Larger users will install DCE in the form of a Packet Assembler/Disassembler (PAD), which is specified by the ITU-T as X.3. The PAD performs the packet assembly (segmentation) of the data for the transmitting device, disassembling the packet for the receiving device in order to reconstitute the data in its native format.

Packet carriers, of course, must invest in packet nodes, rather than circuit switches. Such packet nodes are intelligent devices capable of supporting complex routing tables, buffering packets in temporary memory, resolving packet errors, and accomplishing protocol conversions.

Packet Switching Standards

The ITU-T sets standards recommendations for packet switching. Those standards include the following [8-6], [8-8] and [8-20]:

• X.3: Packet Assembly/Disassembly functions
• X.25: Interface between DCE and DTE for public packet networks
• X.28: Terminal-to-PAD communications formats
• X.29: Host-to-PAD communications formats
• X.31: Packet-mode services over ISDN
• X.32: Defines X.25 synchronous dialup mode
• X.75: X.25 internetwork call control procedures


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

Packet Switching Applications and Futures

The original application for X.25 packet switching was that of interactive time-sharing, which involves long connect times and low data volume. While such applications are still supported effectively by X.25, contemporary applications include online interactive processing (reservations systems), messaging (email), batch file transfer (data backup), information service access (America Online, CompuServe, and Prodigy), and Internet access.

Packet-switching offers the advantage of being a highly mature, if limited, network technology. Therefore, it is relatively inexpensive to deploy and is highly cost-effective in support of applications that require many-to-many connectivity and which involve relatively low volumes of data transport. Additionally, it is virtually ubiquitous, having been deployed in every corner of the globe. However, it is limited in terms of speed and latency. As a result, many applications and service providers are moving toward newer network technologies. For example, the airline reservations systems are rapidly moving to Frame Relay, at least for the domestic (U.S.) networks. Internet Service Providers prefer ISDN or Frame Relay. The Internet backbone network largely has shifted to Frame Relay or ATM, operating at T1 or T3 speeds at a minimum; much of the backbone is being upgraded to fiber optic facilities operating at speeds of 155 Mbps. The future of packet switching is assured because of its low cost and high availability. Additionally, low-intensity users will continue for many years to access the Internet on a dialup basis through X.25 packet switches.

X.25 is growing at record rates in Latin America, Central Europe, and other developing regions. In such areas, the poor quality of the networks make X.25’s error correction capabilities a must for data communications. Demand also is growing in Western Europe and North America, where Internet access is X.25-based, at least at the edges of the networks [8-21]. The postal administration in France recently built a X.25 LAN internetwork that eventually will extend to most of its 7,000 post offices. Bank branches in Belgium and other countries of Western Europe also are expanding their X.25 networks due to the low cost and high degree of flexibility [8-22].

Integrated Services Digital Network (ISDN)

ISDN (Integrated Services Digital Network) was first explored as a concept from 1968 to 1971 by a CCITT study group. A more focused conceptual study took place during the 1981 to 1984 CCITT study period. The first set of published standards recommendations appeared in 1984 in the form of a CCITT Red Book, which provided the basic framework for the concept, network architecture, UNI (User Network Interface) protocols and common channel signaling protocols. As a result of the 1985 to 1988 study period, a Blue Book was published, which provided description of supplementary services, rate adaptation, ISDN Frame Relay, and the initial set of B-ISDN (Broadband ISDN) recommendations. (The color of the books has no significance, other than the fact that a different color is chosen for each study period.)

ISDN is a suite of services based on a set of technologies, including transmission, switching, and signaling and control. ISDN is a set of international standards recommendations which will allow the provisioning of a wide range of services which are intended to be available on a ubiquitous basis. Additionally, the ISDN network is accessible through a standard set of interfaces—one for low-bandwidth applications and another for high-bandwidth.

The specific characteristics of ISDN include its entirely digital nature—CPE, transmission facilities and switching systems all are fully digital. Three channel types are identified, including B-channels (Bearer channels) that carry the information, D-channels (Data channels) for signaling and control, and H-channels (High-speed channels) for channel aggregation in order to accommodate bandwidth-intensive applications. The User Network Interface (UNI) protocols include Basic Rate Interface (BRI) for low-speed termination, and Primary Rate Interface (PRI) for high-speed access. Common Channel Signaling System #7 (SS7) is a fundamental requirement of ISDN.

Announced to the world with great fanfare, ISDN quickly captured the imagination of carriers, manufacturers and user organizations worldwide. ISDN offers the compelling advantages of improved bandwidth, flexibility, error performance, reliability, availability, and interconnection to a wide range of services. Unfortunately, it has stalled. For the past 25 years, ISDN has progressed at such a slow pace that it has become legendary. Among the many reasons for its slow development are slow standards development, lack of adherence to standards, lack of availability, regulatory hurdles, circuit and equipment costs, and poor marketing.

Standards development at the ITU-T is infamously slow. Standards traditionally were released every four years in monsoon fashion and with total droughts in the interim. Over time, the various committees were afforded the privilege of developing and releasing certain standards recommendations on an intermediate basis—standards now come in sprinkles and showers.

Standards from the ITU actually are in the form of standards recommendations. Individual member nations are free to implement ISDN options as they see fit, or to deviate from the standards, as long as international interconnectivity is accomplished at some reasonable level. The most notable international difference is that of the basic ISDN hierarchy. The North American version follows the T1 hierarchy, with PRI including 24 B channels; the European (ITU) version is based on E-1, providing 30 B channels. While this difference is understandable in the context of maintaining backward compatibility with existing networks, it also perpetuates issues of basic protocol incompatibility.

Systems manufacturers of CO exchanges and PBXs have a strong interest in maintaining the proprietary nature of their systems architectures. Therefore, they have implemented ISDN in distinctly different ways. ISDN compatibility became ISDN compliance —a decidedly lower level.

Additionally, carriers have implemented nonstandard versions of ISDN. Pacific Bell, for instance, offers ISDN at a rate of 56 Kbps per channel, rather than the standard 64 Kbps. This limitation is due to the fact that SS7 is not fully deployed in Pacific Bell’s carrier network; as a result, in-band signaling and control consumes 8 Kbps of channel bandwidth. Pacific Bell has announced its intention to rectify this situation in 1997, although the recently announced Pacific Bell/Southwestern Bell merger may affect that decision.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

Islands of ISDN were the result of these various implementations. A given carrier, using the hardware and software of a given manufacturer, could not easily achieve full connectivity with another carrier deploying another version of ISDN. Weary of delays in the standards process, some carriers (e.g., Southwestern Bell) developed and implemented proprietary versions of ISDN, further contributing to the problem. During the past several years, this problem has been mitigated through cooperation of the manufacturers and carriers, with active involvement of Bellcore [8-23] and [8-24].

Availability of ISDN was slow to develop, as the carriers were reluctant to invest in the technology unless they were convinced that a market existed for the services and/or that the technology offered internal cost savings. ISDN is not inexpensive to deploy, a fact which unfortunately has been reflected in high end-user circuit and equipment costs. Availability recently has increased to a significant extent, with the RBOC’s and GTE having made considerable commitments to its deployment. The independent telephone companies are increasingly making ISDN a priority, although they understandably lag far behind the RBOCs due to cost-of-service factors [8-25].

Regulators generally have required that the LECs pass on the cost of ISDN infrastructure to ISDN users, rather than allowing them to average those costs across the entire rate base. In other words, they have viewed ISDN as an optional service that must pay its own way, or that the carriers should absorb any associated losses. As the carriers have been unwilling to do so, ISDN rates have remained high.

Rates for ISDN access were not tariffed at attractive levels compared with the cost of basic services. Again, the regulators were, and still are, largely responsible. The carriers also bear responsibility as well, as they have not been willing to absorb initial losses in order to stimulate the growth of the service offering. Ameritech, for instance, charges $135 for installation and $34.64 per month for a low-speed ISDN BRI circuit; an additional $20 per month applies if the premise is more than three miles from an ISDN central office. Southwestern Bell is the prize winner, at $578 for installation and $57.70 per month [8-26]. In New York, NYNEX charges $14 per month in addition to the normal line charge, plus installation or upgrade charges which vary from about $50 to $312 [8-27]. Rates for PRI vary considerably as well. In some cases based on a per-channel charge and in other cases on a flat rate per PRI [8-28]. In some states, additional per-minute surcharges apply to ISDN; starting with call setup, rather than call connection. The charges typically are higher for a data call than for a voice call.

Equipment costs were high, as the manufacturers were constantly investing in R&D to maintain ISDN compliance with developing standards. Additionally, the limited demand for ISDN caused the manufacturing runs to be small—lower costs are achieved through increased volume. As an example, Terminal Adapters, which provide the interface to an ISDN circuit for non-ISDN equipment, have come down in price from about $1,000 in 1993 to an average of less than $500 today. That is an improvement, but still a substantial investment for a small business or residential user [8-29].

Marketing by the LECs was not effective. Not only were costs maintained at unattractive levels, but advertising and promotion were limited, and availability clearly was not high. Further, meaningful and cost-effective applications were not identified and stressed. With typical lack of foresight, the LECs placed heavy emphasis on the low-speed BRI version, which is suitable only for residence, small business, and SOHO (Small Office/Home Office) application. High-speed PRI was not emphasized heavily as a replacement of T1 trunking. ISDN Centrex was touted heavily, but with limited success. Centrex ISDN marketing was heavily slanted toward CO-based Local Area Networking, which was a dismal failure.

While ISDN has frustrated the industry, in general, there currently are over 200,000 ISDN access lines worldwide. Some industry pundits forecast that more than 750 million will be installed by the year 2000—the author does not share that level of enthusiasm. ISDN is much more mature in Europe and certain parts of the Pacific Rim than it is in the United States. In those regions, deployment was encouraged by the regulators and even subsidized by the governments. Additionally, marketing was much more effective, focusing on PRI, rather than BRI [8-24].

Standard Interfaces and Channel Types

The current version of ISDN is Narrowband ISDN (N-ISDN). (Broadband ISDN (B-ISDN), which is still on the drawing boards, is discussed in Chater 11.) ISDN currently is available in essentially two interface varieties BRI (2B+D) and PRI (23B+D in North America, and 30B+D in Europe and many other countries) (see Figure 8.9). In each case, the ITU specifies the electrical characteristics, signaling, coding and frame formatting. There is one variation on the theme; H-channel, designed for high-bandwidth applications, bonds multiple B channels.

Figure 8.9 ISDN BRI and PRI interfaces.

Basic Rate Interface (BRI)

Basic Rate Interface (BRI) also is known as Basic Rate Access (BRA) and 2B+D. BRI provides 2 B channels (Bearer, or information-bearing channels), each operating at the clear-channel rate of 64 Kbps by virtue of SS7 nonintrusive signaling. Each B channel can carry digital data, digitized voice (PCM-encoded at 64 Kbps or a lower rate), or a mixture of low-speed (subrate) data as long as it all is intended for the same destination. BRI also provides a D (Data) channel at 16 Kbps, which is used for control, messaging, and network management. The D channel also generally is made available for packet data transmission and low-speed telemetry when not in use for signaling purposes. Cost-effective applications include credit card authorization, which involves very small bursts of data [8-30]. BRI is primarily used for residential, small business, Centrex, and telecommuting applications that are not particularly bandwidth-intensive. The B channels can be aggregated or bonded, to provide up to 128 Kbps to a given conversation, such as a videoconference; additionally, multiple BRIs can be bonded for even greater capacity. Whether bonded or not, ISDN BRI provides multiple channels over a single physical loop, which is a great advantage.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

A single BRI line can support up to eight devices, which might be in the form of telephones, facsimile machines, or computers. Additionally, up to 64 individual telephone numbers can be supported [8-31]. While BRI supports as many as three simultaneous calls, only one can be a voice conversation.

BRI uses an 8-pin connector which is defined by the International Standards Organization (ISO) in ISO 8877 and which uses a RJ-45 jack. Full duplex (FDX) connectivity is accomplished over a digital twisted-pair local loop through the application of special carrier electronics. A NT1 (Network Termination 1) device provides for compatibility with network protocols.

Primary Rate Interface (PRI)

Primary Rate Interface (PRI) also is known as 23B+D in the US and Japan. The European or ITU version is known as Primary Rate Access (PRA) or 30B+D. PRI offers 23 B (Bearer) Channels, plus 1 D (Data) channel. Both the B and D channels operate at 64 Kbps. The individual B channels can be used as discussed in the case of BRI; the D channel is reserved exclusively for signaling. As the standards provide for a D channel to support up to five PRI connections, numerous carriers have recently embraced this concept, thereby yielding additional usable bandwidth for user application. For example, the first PRI in a PBX trunking application would be provided at 23B+D; the next four PRIs would be deliver 24B+0D.

PRI provides a full duplex (FDX) point-to-point connection through a NT2-type intelligent CPE switching device (e.g., a PBX or router) device for protocol interface with the carrier CO exchange switch.

While designed for transmission over a standard T1 trunk, PRI is a significant improvement over T1, because the channels can be allocated dynamically. Each channel can act as an incoming, outgoing, combination, or DID trunk as the need arises. The nature of the channel can be determined as required or as specified, varying based on user-definable parameters. Additionally, multiple B channels can be aggregated to serve bandwidth-intensive applications, such as videoconferencing.

H-Channels

H-channels (High-speed channels), are functionally equivalent to B-channels, but provided greater aggregate bandwidth in PRI applications. H0 channel signals have a aggregate bit rate of 384 Kbps, while H1 channels operate at an aggregate of 1.536 Mbps for the North American version (H11) and 1.920 Mbps for the European version (H12). This capability of channel aggregation allows multirate communications on a dynamic basis through inverse multiplexing over multiple B-channels. It does have a drawback, however, when compared to traditional Inverse MUXs as the connection must be torn down and reinitiated when channels are added or dropped. The feature is known variously as Multirate ISDN, Nx64, Channel Aggregation and bonding. H channels find application in fast faxing (Group IV), videoconferencing, high-speed data transfer and high-quality audio transmission.

ISDN Equipment

ISDN hardware, at the end user side of the connection, includes Terminal Equipment (TE), Terminal Adapters (TAs), and Network Terminations (NTs) as shown in Figure 8.10. The carrier requires digital COs that are equipped with ISDN and SS7 software.

Figure 8.10 ISDN terminations in TE1 and TE2 CPE.

Terminal Equipment (TE)

Terminal Equipment (TE) is the term for a functional device that connects a customer site to ISDN services. Examples include computers, telephones, facsimile machines, and videoconferencing units. TE1 has a built-in ISDN interface, while TE2 devices do not have native ISDN compatibility.

Terminal Adapters (TAs)

Terminal Adapters (TAs) are interface adapters for connecting one or more TE2 (non-ISDN) devices to an ISDN network. TAs act as ISDN DCE, serving a function equivalent to protocol or interface converters. Applied to equipment which does not have ISDN capability built within it; the TAs must be exactly tuned to the specific CPE/DTE. TAs can be in the form of either standalone units or printed circuit boards fitting into an expansion slot of a PC.

A key function of the TA is that of rate adaption, which effectively throttles down the transmission rate from 64 Kbps to the rate at which the non-ISDN device is capable [8-32]. As an example, a non-ISDN PC might be capable of only 19.2 Kbps through the serial port. Another example might involve a connection supported at only 56 Kbps (non-ISDN or Pacific Bell “ISDN”) on the receiving end; the device would throttle down to that rate, rather than 64 Kbps. Rate adaptation is accomplished in North America through the ITU-T V.120 protocol; the European standard is V.110.

Network Terminations (NTs)

Network Terminations 0(NTs) are Network Termination devices, NT1s and NT2s.

NT2s

NT2s (Network Termination type 2) are intelligent devices responsible for the user’s side of the connection to the network, performing such functions as multiplexing, switching or ISDN concentration. A NT2 device would likely be in the form of a PABX, LAN router or switching hub.

NT1s

NT1s (Network Termination type 1) physically connect the customer site to the carrier side of the connection, performing such functions as signal conversion and maintenance of the local loop’s electrical characteristics. In a PRI environment, these functions are similar to those provided by Data Service Units (DSUs) and Channel Service Units (CSUs). In a BRI environment, these devices are TE1 devices.

Inverse MUXs,

Inverse MUXs, offered by some manufacturers, allow multiple BRIs to be bonded, or linked, for greater aggregate transmission over a BRI circuit(s). For example, four BRIs can be linked to support a 512 Kbps data transmission. Such an approach competes effectively with Fractional T1 (FT1).

D-Channel Contention Devices

D-Channel Contention Devices, offered by some manufacturers, allow as many as eight devices to share a BRI circuit, contending for access to the B-channel. The individual devices identify themselves to the network through contention for the D channel.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

ISDN Characteristics And Benefits

ISDN is unusual, if not unique, as it is undoubtedly the most carefully planned, well coordinated, and best documented network technology in history. Despite this fact, it will be at least a decade before it is widely available and implemented. The key characteristics of ISDN include its end-to-end digital nature, unusual for a circuit-switched network. Through a small family of interfaces, a wide range of services can be accessed through the LEC, IXC or CAP. Rate adaption and channel aggregation allow bandwidth-intensive applications to be supported on a dynamic basis.

ISDN’s reliance on SS7 (discussed in Chapter 6) offers a number of advantages, including faster call setup and nonintrusive signaling and control. Additionally, SS7 (either with or without ISDN) makes possible a number of interesting CLASS services, including Caller ID, Name ID, call trace, selective call forwarding, and selective call blocking.

ISDN also is interoperable with X.25, Frame Relay, SMDS and ATM. In fact ISDN standards were developed specifically with these services in mind. Frame Relay, in particular, is closely aligned with ISDN link-level protocols. Broadband ISDN (B-ISDN), although many years in the future, is dependent on ATM network technology.

ISDN Characteristics and Drawbacks

ISDN is not without its drawbacks, which include limited availability, standards variations, channel application, and high cost. As discussed earlier, availability is limited in most nations, because ISDN and SS7 software are costly for the carriers to deploy. While ISDN capability can be extended to non-ISDN CO exchanges, that incremental cost is not trivial. As discussed previously, standards vary by carrier and manufacturer, and BRI limits the user to a single voice channel.

Not surprisingly, cost/benefit considerations dictate the success or failure of technologies, regardless of how compelling they appear at first glance. The cost of an ISDN BRI circuit is more than twice that of an analog line—installation costs can range as high as $578.00 per BRI (Southwestern Bell). These costs tend to discourage ISDN to a considerable extent, particularly in voice-intensive environments—although ISDN provides three channels, only one can be used for voice at any given time.

Additionally, many carrier tariffs impose a usage surcharge in the form of a flat rate per minute. The usage charge may apply to local, as well as long distance, calls. Additionally, data calls often carry a higher usage rate than do voice calls. While this additional usage charge tends to discourage ISDN usage, the call connect time may be reduced significantly through ISDN. Pacific Bell [8-31] suggests that a 20MB file can be transmitted from California to Japan via a 90 Kbps ISDN connection in 3.7 minutes at a cost of $6.32. This compares quite favorably with an analog modem transfer at 14.4 Kbps, which would take 23.1 minutes and cost $29.85. Group IV facsimile transmission over ISDN lines also offers significant long distance cost savings when compared to Group III analog transmission.

Hardware Costs are additional in support of ISDN. In a BRI environment, such additional equipment might include Terminal Adapters (TAs), Inverse MUXs, and BRI contention devices. In a PRI application, ISDN software for PBXs and routers is an additional cost. Older systems might require replacement in order to effect ISDN compatibility.

A final cost issue centers on equal access charges, or Subscriber Line Charges (SLCs). In 1995, the FCC decision considered the application of the SLC to ISDN on a per-channel basis, rather than the standard per-circuit approach [8-33]. Although the FCC relented under pressure from carriers and users, regulators may strike a similar posture in the future.

ISDN Standards

As mentioned earlier in this chapter, ISDN standards are voluminous. While still under development in some respects, current ITU-T standards for ISDN include the following:

• I.441/4511: ISDN Primary Rate Interface (PRI)
• I.515: Parameters for ISDN internetworking
• Q.700: Signaling System Number 7 (SS7) specifications
• Q.921: Layer 2 specification for D-channel; Link Access Protocol-D (LAP-D)
• Q.931: Layer 3 User Network Interface (UNI) specifications
• V.110: B channel procedures (Europe) for Terminal Adapters (TAs)
• V.120: B channel procedures (North America) for TAs

In addition to the ITU-T, other organizations are active in the development and promotion of ISDN standards. For example, ANSI (US) and ETSI (Europe) each lobby the ITU for the acceptance of their parochial ISDN variations.

ISDN Applications

The applications for ISDN are broad in range. While ISDN was long described as “a technology in search of an application,” it recently has been opened to applications developers, and aggressively so. There is no killer ap for ISDN, rather there are a number of applications that, in total, promise to ensure the future of ISDN. A host of applications which benefit from the improved quality of digital networking and that are bandwidth-intensive are well served by ISDN. Further, ISDN offers an affordable circuit-switched alternative to DDS, Switched 56, and T-carrier, which simply cannot be cost-justified in many cases.

Personal office internetworking, remote office internetworking, and telecommuting (or Telework) all are facilitated by the increased bandwidth and error performance offered by ISDN BRI. In such applications, file transfers and facsimile transmission are accomplished much more quickly and with much greater clarity; the improved quality of the voice communications are an added benefit [8-34].

ISDN also is used for access to X.25 packet networks, with users benefiting from the faster call setup and teardown time made available by virtue of SS7. As either the B channels or D channel can be used for packet data transfer in a BRI implementation, ISDN offers additional flexibility and bandwidth utilization. Additionally, some manufacturers of Terminal Adapters offer built-in X.25 PADs for end-to-end error correction [8-35].

As a replacement or backup for dedicated digital services, ISDN performs well for data and image networking, whether in a host-to-host, LAN-to-LAN, or remote LAN access application. Intensive users of the Internet and World Wide Web find ISDN bandwidth to be of great advantage, as the speed of call setup and file transfer are much increased compared to dialup analog connections. For instance, a typical WWW page takes 3 minutes to load over an analog line with a 14.4 Kbps modem, but less than 20 seconds at BRI speed of 128 Kbps [8-36]. As discussed in Chapter 4, incoming call centers can take advantage of ISDN to increase productivity, as well as make use of remote agents working from home.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

For purposes of illustration, at least one example merits further discussion. A remote worker might desire to access an application residing on a LAN-connected server. An ISDN call to a local LAN site would save on long distance charges; that LAN site would connect the user to a remote site through another ISDN link. When the remote client workstation is idle, ISDN would disconnect the LAN-to-LAN link to save on long distance charges. Through a process known as spoofing, the application would remain alive, as it continues to see a logical link over the B-channel. The interactive data conversation can quickly be reinitiated due to the fast call setup time of SS7, which is an integral element of ISDN. The remote worker in this scenario might be a telecommuter, working from home several days a week.

In terms of vertical markets, ISDN is of particular interest in the healthcare and education sectors, largely because of its ability to support imaging and video through rate adaption. TeleMedicine, in particular, is of interest, as it allows specialists to diagnose and treat patients in remote areas based on video examination and transmission of X-ray images across error-free and high-speed ISDN links.

The applications for ISDN are virtually unlimited, at least in terms of the network services that can be accessed. Through a single ISDN local loop, voice, facsimile, data, video and image information can be accommodated. Additionally, simultaneous access to multiple networks and network services can be accomplished, perhaps including circuit-switched voice, X.25 packet, and Frame Relay. From a user perspective, ISDN is highly flexible. From a carrier perspective, ISDN offers the advantage of consolidating access to multiple networks; relieving the strain on local loop, switching, and transport facilities. Additionally, ISDN offers the LECs the promise of putting the telephone company world back together much like it was before deregulation, divestiture, and competition. In other words, the LECs can market ISDN as a single network access solution—sort of a one-stop shop.

International ISDN: Variations on the Theme

ISDN has experienced differing levels of success around the world due to various marketing approaches, pricing strategies and, in some cases, aggressive government support. For instance, the Japanese government has lent strong support to the development and deployment of high-technology networks and network services.

Telecom Australia was very successful in marketing PRI to large user organizations, in part as an alternative to leased lines. An unusual offering is that of semi-permanent circuits within PRI, priced at approximately 50% of the cost of a dedicated circuit. In the competitive Australian telecom environment, this approach was successful in countering leased-line networks offered by alternative carriers such as Optus.

Deutsche Bundespost Telekom offers ISDN on a widely available and low cost basis. In excess of 80% of Germany’s population has access to ISDN within six weeks of placing an order. Pricing is very attractive compared to leased lines. For application development, CAPI (Common Application Programming Interface) is supported.

For years, carriers in Western Europe have offered a service known as 0B+D. That offering provides access to a solo 16 Kbps D-channel for low-speed data transmission. Packet data is supported at speeds up to 9.6 Kbps, with signaling and control consuming the balance of the capacity—no B-channels are involved. This service effectively challenges X.25 packet networking for transaction-oriented applications such as credit card authorization.

Broadband Data Networking

Although Broadband Data Networking will be discussed in detail in a later section, it is worth a quick overview of certain key technologies and service offerings, including Frame Relay and Cell Relay.

Frame Switching (Frame Relay)

A relative newcomer, Frame Relay was first deployed in the mid-1990s. Much like packet switching, each frame is addressed individually. Frame relay also makes use of special switches and a shared network, of very high speed. Unlike packet switching, frame relay supports the transmission of virtually any computer data stream and frames are variable in length (up to 4,096 bytes). Rapidly gaining in popularity, frame relay is widely available in many highly developed nations. International frame relay service is also becoming widely available. A service which is primarily data-oriented, Frame Relay does not support voice or video effectively. As is the case with X.25 packet switching, Frame Relay overhead can be relatively high, delays (latency) in transmission are expected, and network congestion can result in lost data; the responsibility for error detection and correction is shifted to the user in a Frame Relay environment.

Cell Switching

Clearly the future of communications networking, cell switching encompasses both Switched Multimegabit Data Service (SMDS) and Asynchronous Transfer Mode (ATM), data is organized into cells of fixed length (53 octets), shipped across very high-speed facilities and switched through very high speed, specialized switches. While SMDS has proved to be very effective for data communications ATM will be pervasive in the future; ATM will be the platform for Broadband ISDN (B-ISDN). ATM is primarily data-oriented, although it is ultimately intended to support voice and video. Standards are still developing and availability is limited. Current disadvantages of ATM include its relatively high cost, high overhead, and lack of fully developed standards.


Communications Systems and Networks:Conventional Public Data Networks (PDNs)

References

[8-1] Brooks, John. Telephone: The First Hundred Years. NY: Harper and Row, 1976.
[8-2] Engineering and Operations in the Bell System. NJ: Bell Telephone Laboratories, Incorporated. 1977.
[8-3] Bates, Regis J. Introduction to T1/T3 Networking. Norwood, MA: Artech House. 1992.
[8-4] Trulove, James E. A Guide to Fractional T1. Norwood, MA: Artech House. 1992.
[8-5] Flanagan, William A. The Guide to T-1 Networking. NY: Telecom Library Inc. 1990.
[8-6] Minoli, Daniel. Enterprise Networking: Fractional T1 to SONET, Frame Relay to BISDN. Norwood, MA: Artech House. 1993.
[8-7] Nolle, Tom. “Don’t Bury Traditional T1 Just Yet.” Business Communications Review. September 1995.
[8-8] Gelber, Stan. Introduction to Data Communications: A Practical Approach. Horsham, PA: Professional Press Books. 1991.
[8-9] Doll, Dixon R. Data Communications: Facilities, Networks, and Systems Design. NY: John Wiley and Sons, Inc. 1978.
[8-10] Elbert, Bruce R. Private Telecommunication Networks. Norwood, MA: Artech House. 1989.
[8-11] Korzeniowski, Paul. “T1 Continues to Grow in Private Networks.” Business Communications Review. February 1996.
[8-12] Rhode, David. “Sprint turns on 800 Switched Data Service.” Network World. October 30, 1995.
[8-13] Briere, Daniel. “Digital 800 Era Arrives—So Does a Dilemma.” Network World. March 6, 1995.
[8-14] “Digital 800 Gains Momentum.” Network World. September 25, 1995.
[8-15] Kleinrock, Leonard. Principles and Lessons in Packet Communications. Partridge, Craig. Innovations in Internetworking. Norwood MA: Artech House. 1988.
[8-16] Heart, F.E.; Kahn, R.E.; Ornstein, S.M.; Crowther, W.R.; and Walden, D.C. The interface message processor for the ARPA computer network. Partridge, Craig. Innovations in Internetworking. Norwood, MA: Artech House. 1988.
[8-17] Spohn, Darren L. Data Network Design. NY: McGraw-Hill, Inc. 1993.
[8-18] Stallings, William. ISDN and Broadband ISDN with Frame Relay and ATM (Third Edition). NY: Prentice-Hall. 1995.
[8-19] Rybczynski, Antony. X.25 Interface and End-to-End Virtual Circuit Service Characteristics. Partridge, Craig. Innovations in Internetworking. Norwood, MA: Artech House. 1988.
[8-20] Held, Gilbert. Understanding Data Communications. Indianapolis, IN: SAMS Publishing. 1994.
[8-21] Burch, Bill. “X.25 Protocol Proves to Have Enduring Appeal.” Network World. October 31, 1995.
[8-22] “X.25 Emerges as a LAN Interconnect Option.” Data Communications. March 1995.
[8-23] Levitt, Jason. “Hold The Phone!” Information Week. May 15, 1995.
[8-24] Horak, Ray. “ISDN: To Be Delivered as Promised?” Datapro Communications Analyst. Delran, NJ: Datapro Information Services. January 1995.
[8-25] Greene, Tim. “Sprint/United, Other Small Carriers Get Into ISDN Game.” Network World. August 7, 1995.
[8-26] Buerger, David J. “National ISDN’s Third Birthday is Nothing to Write Home About.” Network World. November 13, 1995.
[8-27] Roth, Cliff. “ISDN Modems Come to Town.” NewMedia. March 11, 1996.
[8-28] Gareiss, Robin. “ISDN: Stop Singing Those Blues.” Data Communications. March 1996.
[8-29] Sullivan, Kristina B. “ISDN Moves Toward the Mainstream.” PC Week. December 11, 1995.
[8-30] Stargess, James. “ISDN D Channel Packet Service: Coming Soon to a Store Near You.” Network World. March 11, 1996.
[8-31] ISDN: A User’s Guide to Services, Applications and Resources in California. San Francisco, CA: Pacific Bell. 1994
[8-32] “ISDN and Data Networking.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services. May 1995.
[8-33] Metcalfe, Bob. “The FCC’s Doubling of ISDN Rates May Finally Kick Off a User Revolt.” Infoworld. April 3, 1995.
[8-34] Case, Linda and Mulligan, John. ISDN As a Telecommuting Solution. Piscataway, NJ: Bellcore. 1996.
[8-35] Tredinnick, Ian. “X.25: A New Lease on Life with ISDN.” Telecommunications. June 1995.
[8-36] Kalman, Steve. “So You Want to Use ISDN….“ Network World. December 4, 1995.


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

Chapter 9
Local Area Networks: Connectivity and Internetworking

Just as computer networks have grown across continents and oceans to interconnect major computing facilities around the world, they are now growing down corridors and between buildings to interconnect minicomputers in offices and laboratories.

—Robert M. Metcalfe and David R. Boggs, Xerox Palo Alto Research Center, Ethernet, 1976

Once upon a time, computer networks consisted of mainframes in glass houses. Input was in the form of punch cards read by card readers and output was in the form of printed results via local printers. Local terminals were mostly used for control and programming input. All processing was on a batch basis, rather than being interactive. In other words, the input was transmitted in a batch from a card reader over a short circuit to the processor, the processor processed the program in a batch, and the output to the printer was in a batch. The first true mainframe was the IBM 360, introduced in 1964 [9-1]. As the first computer capable of both scientific and business computing, it went full circle, hence the designation 360 [degrees] [9-2]. During the author’s pursuit of several degrees (academic) at The University of Texas at Austin, his programs (which seldom ran successfully) were processed in batch mode on a CDC 6600 computer which cost roughly $6 million, occupied a huge room, required tons of air conditioning, and had enough large cabinets to house the population of a small nation.

Over time, input to the mainframe was extended to multiple users at dumb terminals that connected to ports on the mainframe through terminal controllers, or cluster controllers. Controllers essentially act as traffic concentrators to allow multiple slow terminal inputs to share one of a limited number of very expensive ports on the host computer. As time ticked away, Remote Job Entry (RJE) was developed to allow the remote entry of data over a WAN, with the clusters of dumb terminals and terminal controllers residing at remote locations.

In parallel to the development of data networking, the computers, themselves, began to change. Computers became more powerful as processor speeds increased with the development of ever faster microprocessors on silicon chips. Memory became more available as chip technology and hard drive technology improved. Additionally, computers became smaller and less expensive, to the point that the typical desktop PC is equivalent to an early mainframe that would have filled a moderate-size office building! (The PC, by the way also is more powerful and infinitely easier to use.) The PC was legitimized by the introduction of the IBM PC in 1983. By 1993, it was estimated that 75% of professionals had a PC or workstation on the desktop.

It was only logical that all of this computing power and storage capability on all of these desktops would lead to a need to network those devices within the workplace. It has been estimated that 80% of data transfer is confined to the workplace, while only 20% travels across the WAN. Whether or not that figure is accurate, it is clear that PC users need to share access to hosts, databases, printers, and WANs. LANs provide a solution to that requirement.

LAN technology was first conceived by Robert M. Metcalfe and his associates at the Xerox Palo Alto Research Center (Xerox PARC). That concept was originally known as the Altos Aloha Network, as it connected Altos computers through a concept based on the University of Hawaii’s AlohaNet packet radio system technology. In a memo written on May 22, 1973 this magical network became known as ethernet, from luminiferous ether, [9-3] the nonexistent omnipresent passive medium once thought to support the transmission of electromagnetic energy through a vacuum. Xerox commercialized the technology and renamed it The Xerox Wire. When Digital Equipment Corporation (DEC), Intel and Xerox standardized the technology in 1979, they reverted to the name Ethernet. Ethernet quickly became a de facto standard. Ethernet and LANs were officially recognized in February, 1980, when the IEEE established Project 802 at the request of members. In December, 1982, the first standard was published and circulated.

Ethernet, clearly, still is the most popular LAN standard. According to Metcalfe’s estimates [9-4], in 1994 there were 50 million ethernet-connected computers, five million of which were on 10 Mbps networks. Further, 500,000 Ethernet networks were TCP/IP registered and 50,000 were connected to the Internet. No doubt those numbers have increased considerably in the past few years.

This discussion of the basic concepts of LANs and LAN internetworking serves as the launching pad for discussion of the network technologies of the future. In this chapter, the definition, origin, and evolution of LANs and their application will be addressed. Dimensions of LANs to be explored include media alternatives, physical and logical topology, baseband versus broadband, media access control, and standards and standards bodies. Bridges, routers, hubs, switches, and gateways will be defined and illustrated, as will LAN operating systems. This chapter will conclude with a discussion of LAN internetworking, remote LAN access, and recent developments in the realm of high-speed LANs.

LANs Defined

A LAN is a form of local (limited-distance), shared packet network for computer communications. LANs interconnect computers and peripherals over a common medium in order that users might share access to host computers, databases, files, applications, and peripherals. LANs offer raw bandwidth of 1 Mbps to 100 Mbps or more, although actual throughput often is much less. LANs are limited to a maximum distance of only a few miles or kilometers, although they may be extended through the use of bridges, routers, and other devices. Data are transmitted in packet format, with packet sizes ranging up to 1500B+. For the most part, LAN specifications are the province of the IEEE, although ANSI and other standards bodies increasingly are involved.


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

LAN Applications and Benefits

LANs are used almost exclusively for data communications over relatively short distances, such as within an office, office building or campus environment. LANs allow multiple workstations to share access to multiple host computers, other workstations, printers and other peripherals, and WAN connections. LANs increasingly are used for imaging applications, as well. They are also being used for video and voice communications, although currently on a very limited and generally unsatisfactory basis.

LAN applications include communications between the workstation and host computers, other workstations, and servers. The servers may serve to provide the workstation with access to text files, image files, applications, printers, or communications software for access to the WAN.

LAN benefits include the fact that a high-speed transmission system can be shared among multiple devices in support of large numbers of active terminals and large numbers of active applications—sort of a multi-user, multitasking computer network. LAN-connected workstations realize the benefit of decentralized access to very substantial centralized processors, perhaps in the form of a mainframe host computer and storage capabilities (information repositories). Additionally, current technology allows multiple LANS to be internetworked through the use of LAN switches, routers, and the like.

Media Alternatives

The shared medium for LANs include most of the transmission media discussed in Chapter 3. Although coaxial cable was the original medium and still is used widely in various configurations, twisted-pair has recently become the medium of choice in many environments. Fiber optic cable is used widely as a backbone technology, although it seldom is deployed to the desktop. Wireless LANs generally are limited to special radio technologies, although infrared technology is used in certain applications. Microwave and infrared systems are used to connect LANs and LAN segments in a campus environment. Satellite rarely is used in any way, as propagation delay renders it generally unsatisfactory for interactive communications

Coaxial Cable

Coaxial cable was the transmission medium first employed in LANs. Although it is expensive to acquire and costly to deploy and reconfigure, its performance characteristics are excellent. Additionally, DP/MIS managers always have been comfortable with coax, as it traditionally was specified in the mainframe and mid-range computer world. In fact, the technology initially didn’t exist to make effective use of other options such as twisted-pair, fiber optics and radio systems.

In retrospect, perhaps the use of coaxial cable lessened the resistance of DP/MIS managers to the concept of LANs. Those who lived in the mainframe world (most did), regarded (some still do) PCs with disdain. They also sneered (some still do) at twisted-pair, which they refer to as telephone wire.

The advantages of coaxial cable include high bandwidth (500+ MHz), exceptional error performance, and lack of severe distance limitation. Additionally, security is high and durability is excellent. On the other hand, the costs of acquisition, deployment, and reconfiguration are high. The disadvantages of coaxial cable have been mitigated to a large extent through the development of new coax designs. Those designs also affect the performance of the system, however. Three variations of coax design are ThickNet, ThinNet, and Twinax.

ThickNet, or thick Ethernet
also known as 10Base5, uses traditional thick coax, often referred to as goldenrod, undoubtedly referring to its high cost and high value. 10Base5 translates to 10 Mbps, Baseband (one conversation at a time over a single channel), and 500 meters maximum segment length. While individual devices can be separated by much greater distances over the medium in a data communication, each segment (link) in the network can be no more than 500 meters. A maximum of two repeaters can be used to extend each individual segment.
ThinNet, or thin Ethernet
also known as 10Base2, uses coax of thinner gauge. The thinner cable is less costly to acquire and deploy, although its performance is less in terms of transmission distance. 10Base2 translates to 10 Mbps, Baseband, and 200 meters maximum segment length (actually 185 meters, rounded up).
Twinax, or twinaxial cable
is similar to ThinNet coax, but with two conductors, rather than one. Twinax is used in older IBM midrange systems such as Systems 34, 36, and 38, as well as the younger IBM AS/400 and RS/400.


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

Twisted-Pair

Recently twisted-pair has become very popular as a LAN medium. Although its performance characteristics are less appealing, its low cost and high availability certainly are attractive. Unshielded Twisted-Pair (UTP) performs nicely at low data rates using the same cable plant for LANs as is used for telephone terminals, hence the current tendency to pull multiple Category 5 UTP pairs to each jack—voice and data terminals can share a common wiring system. Additionally, UTP has been proved to perform at very high data rates (100 Mbps) over short distances.

The advantages of UTP include its low costs of acquisition, deployment, and reconfiguration; its durability is moderate. The disadvantages of UTP include its relatively low bandwidth and poor error performance, at least over long distances. Additionally, UTP offers little security as the radiated electromagnetic field is considerable at high speeds (frequencies).

Shielded twisted-pair (STP) sometimes is used in LAN applications, although it is unusual outside of Token Ring LANs. STP might be used in an environment in which UTP data transmission might be especially susceptible to EMI/RFI, or might cause interference on adjacent pairs. Generally, however, another transmission medium, such as ThinNet, would be employed.

The disadvantages of UTP have been mitigated to some extent, and the LAN applications have increased through the development and use of Category (Cat) or Level 3, 4, and 5 UTP. By way of example, consider 10Base-T, 1Base5 and CDDI.

10Base-T, or twisted-pair Ethernet
uses Cat 3, 4, or 5 UTP. 10Base-T translates to 10 Mbps, Baseband, Twisted-pair. The maximum segment length between the 10Base-T hub and the attached device (workstation, printer, etc.) is 100 meters or less. 10Base-T actually is a wire hub that serves as a multiport repeater, as well as a central point of interconnection.
1Base5
a variation on the theme of 10Base-T, uses Cat 3, 4, or 5 UTP. 1BaseT translates to 1 Mbps, Baseband, 500 meters or less.
CDDI, or Cable Distributed Data Interface
also is known as TPDDI (Twisted-pair Distributed Data Interface). CDDI employs Cat 5 UTP as an inexpensive means of connecting workstations and peripherals to FDDI fiber optic backbone LANs. Transmission rates up to 100 Mbps are supported. Distance is not specified, but it is generally less than 20 meters between the hub and the device.
Additionally, Category 3 (Cat 3) UTP often is used for 4 Mbps Token Ring LANs; Category 4 (Cat 4) UTP has a bandwidth of 20 MHz and commonly is used for 16 Mbps Token Ring LANs.

Fiber-Optic Cable

Due its outstanding performance characteristics, fiber-optic cable is also used in LANs. However, its cost and fragility generally relegate it to use as a backbone technology. FDDI (Fiber Distributed Data Interface) is the current LAN standard (IEEE and ANSI) for such a network. FDDI can be extended to the desktop, either directly or through the use of twisted-pair in a CDDI application.

The advantages of fiber include its high bandwidth, which is 100+ Mbps in the LAN world, and excellent error performance (Bit Error Rate (BER) [identically equal to] 10-14). Additionally, fiber is capable of transmitting data over very long distances and with excellent security. The disadvantages of fiber include its high costs of acquisition, deployment, and reconfiguration. Fiber also is very fragile; it must be protected carefully. Additionally, few users truly require 100 Mbps at the desktop—at least for the moment.

Wireless Technology

Wireless LANs offer the obvious advantage of avoidance of cabling costs, which can be especially important in a dynamic environment where there is frequent reconfiguration of the workplace. Additionally, wireless LANs provide LAN capabilities in temporary quarters, where costly cabling would have to be abandoned.

Each workstation is fitted with a low power transmit/receive radio antenna in the form of a card. Frequency assignments are in the 900 MHz, 2 GHz, and 5 GHz bands. A hub antennae is located at a central point (Figure 9.1), such as the center or a corner of the ceiling, where line-of-sight can be established with the various terminal antennae. The antenna are then connected to other hub antennae and to the servers, peripherals, and hosts via cabled connections, which also connect together multiple hub antennae for transmission between rooms, floors, and buildings. In order to serve multiple workstations, spread-spectrum radio technology is used to make effective use of limited bandwidth. Spread spectrum involves scattering packets of a data stream across a range of frequencies, rather than using a single transmission frequency. A side benefit of spread-spectrum is that of increased security, as the signal is virtually impossible to intercept [9-5]. While the raw aggregate bandwidth of a wireless radio LAN is generally described as 4 Mbps, the effective throughput is more in the range of 1 to 2 Mbps per hub [9-6]. Some wireless LANs also use direct sequence transmission—a signal is sent simultaneously over several frequencies; increasing the chances that the signal will get through to the access hub [9-7].

Figure 9.1 Wireless LAN configuration.

Some wireless LANs use unlicensed frequencies (900 Mhz) to avoid expensive and lengthy licensing by the regulatory authorities (FCC). However, other systems in close proximity could cause interference and additionally, a wide variety of other devices (e.g., garage door openers and bar code scanners) use the same frequencies. The systems which use licensed frequencies (2 GHz and 5 GHz), avoid the potential for interference, but do require that the manufacturer carefully police the deployment of such systems under the terms of an omnilicense.

Although it still is somewhat unusual, infrared light can be used as the transmission medium, rather than radio. As described in Chapter 3, an infrared LAN system generally requires line-of-sight between the light source and receiver. Within a room, however, the light signal can bounce off of walls, ceilings and other surfaces until it reaches the receiver. As the light signal cannot penetrate solid objects, it will bounce around until it loses power. This infrared transmission technique is known as diffused propagation [9-5]. PDAs (Personal Digital Assistants) make widespread use of infrared to establish links with workstations and other PDAs for data transfer. Enhanced infrared technology recently has been demonstrated at speeds of 1.5, 4, and even 155 Mbps [9-8].


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

Whether using radio or infrared light frequencies, wireless LANs are a relatively immature technology which is yet to be widely accepted. Acquisition costs are not particularly low when compared to wired LANs, although reconfiguration costs are virtually nonexistent. Additionally, wireless offers the advantage of portability. On the negative side, bandwidth and throughput are limited. Error performance and security are issues of some significance. Additionally, costs are not insignificant, with the access hubs averaging about $2,000 and the workstation cards about $600 [9-6], [9-9], and [9-10]

Topology: Physical and Logical Configurations

The physical topology (layout) of a LAN is in the form of a Bus, Ring, or Star. (trains, ovals, planets, and constellations are not defined; vendors promoting such topologies should be avoided at all costs!)

Bus Topologies

As shown in Figure 9.2, bus topologies are multipoint electrical circuits, that can be implemented using coax, UTP, or STP. Data transmission is bidirectional, with the attached devices transmitting in both directions. While generally operating at a raw data rate of 10 Mbps, actual throughput is much less. Bus networks employ a decentralized method of media access control known as CSMA (Carrier Sense Multiple Access), that allows the attached devices to make independent decisions relative to media access and initiation of transmission. This approach results in data collisions and requires frequent retransmission. Bus networks are specified in the IEEE 802.3 standard, and generally have a maximum specified length of 1.5 miles (2.5 Km). Ethernet is based on a bus topology. A tree topology is a variation on the bus theme, with multiple branches off the trunk of the central bus. Bus networks also suffer from the vulnerability of the bus—should the bus be compromised, the entire network is compromised. Similarly, tree networks are dependent on the integrity of the root bus [9-2].

Figure 9.2 Ethernet bus topology.

Ring Networks

Figure 9.3 shows a network laid out in a physical ring, or closed loop, configuration. Information travels around the ring in only one direction, with each attached station or node serving as a repeater [9-2]. Rings generally are coax or fiber (FDDI) in nature, operating at raw transmission rates of 4, 16, 20 or 100+ Mbps. Rings are deterministic in nature, employing token-passing as the method of media access control to ensure the ability of all nodes to access the network within a predetermined time interval. Priority access is recognized. A master control station is responsible for controlling access to the transmission medium. Backup control stations assumes responsibility in the event of a failure of the master. Throughput is very close to raw bandwidth, as data collisions do not occur in such a carefully controlled environment. On the negative side, the failure of a single node can compromise the entire network. Electrical ring networks are specified in the IEEE 802.5 standard (FDDI is an ANSI specification). Token-Passing Ring, IBM Token Ring, and FDDI all are based on ring topologies.

Figure 9.3 Ring topology.

Star Topologies

Figure 9.4 shows a network consisting of a central node, hub, or switch, to which all other devices are attached directly, generally via UTP or STP. Transmission rates vary with AT&T’s StarLAN operating at 1 to 10 Mbps, and both 100Base-T and 100VG-AnyLAN at 100 Mbps. The primary advantage of a star is that a disruptive or failed station can be isolated, thereby eliminating any negative effect it may have on LAN performance. Additionally, each node has access to the full bandwidth of the LAN, at least in a LAN switch environment. The primary disadvantage is that a hub failure is catastrophic; because all connectivity is provided through the central hub, its failure affects the entire LAN. Examples of star configurations include AT&T’s StarLAN and DataKit, 100Base-T, 100VG-AnyLAN, PBXs, and Centrex CO-LANs.

Figure 9.4 100Base-T Star topology.

Physical Versus Logical Topology

This refers to the fact that the network may operate logically as though the physical layout were different. An Ethernet bus LAN might be configured physically as a star in a 10/100Base-T implementation. The bus still exists, but protected under the skin of the central hub to which all stations are connected via UTP; the internal bus is known as a collapsed backbone. In this fashion, the network gains the logical advantages of the Ethernet protocol, as well as the physical advantages of a UTP-based star. Similarly, a ring network might operate logically as a ring, but be supported physically by a collapsed backbone bus.

Baseband versus Broadband

There exist two LAN transmission options, Baseband and Broadband. Baseband LANs, which are the most prevalent by far, are single-channel systems which support a single transmission at any given time. Broadband LANs, which are most unusual, support multiple transmissions via multiple frequency channels.


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

Broadband LANs

Broadband LANs are multichannel, analog LANs (Figure 9.5) typically based on coaxial cable as the transmission medium, although fiber optic cable is also used on occasion [9-2]. Individual channels offer bandwidth of 1 to 5 Mbps, with 20 to 30 channels typically supported. Aggregate bandwidth is as much as 500 MHz. The various channels are multiplexed onto the carrier through Frequency Division Multiplexing (FDM). Radio modems accomplish the digital-to-analog conversion process, providing the transmitting device access to an analog channel. The modems, which must be tuned and managed carefully, may be fixed-frequency or frequency-agile. Fixed-frequency modems are tuned to a specific frequency channel, while frequency-agile modems have the ability to search for an available channel. Although frequency-agile modems are more expensive to acquire and administer, they offer improved communications and bandwidth utilization. As the LAN is analog in nature, it can easily accommodate voice and video. Some broadband LANs are referred to as 10Broadband36, translated as 10 Mbps, Broadband (multichannel), with 3600 meters maximum separation between devices.

Figure 9.5 Broadband versus Baseband.

The characteristics of Broadband LANs, generally speaking, are not endearing. However, their unique properties do have application. As an example, a chain of theme parks uses Broadband LANs extensively to support paging (audio voice), closed circuit TV (video), and data. Becuase the LAN is analog, it supports audio and TV easily. Further, the application is static, rather than dynamic, as the paging zones and closed-circuit TV channels require fixed amounts of bandwidth, and the frequency channel assignments need be changed infrequently, if ever. Further, the locations of the terminal equipment (paging source and horns, and VCRs and TV monitors) are fixed, or seldom change.

Baseband LANs

Baseband LANs are single channel, supporting a single communication at a time (see Figure 9.5). They are digital in nature, varying the bit state through voltage on/off or light pulse on/off. Total bandwidth of 1 to 100 Mbps is provided over coax, UTP, STP, or fiber optic cable. Distance limitations depend on the medium employed and the specifics of the LAN protocol. Baseband LAN physical topologies include ring, bus, tree, and star.

Baseband LANs are by far the most popular and the most highly standardized. Ethernet, Token Passing, Token Ring and FDDI LANs are all baseband. They are intended only for data—data communications is, after all, the primary reason for the existence of LANs. Recently, however Ethernet, FDDI and other LANs have announced versions to support voice, video, and videoconferencing. While the support of such isochronous traffic offers clear advantages in support of workgroup communications, the LAN data traffic can be affected to a considerable extent.

Media Access Control

LAN access, at the physical and electrical level, is accomplished at the Network Interface Unit (NIU), or Network Interface Card (NIC). A NIU or NIC is at the board level, with the boards typically fitting into an expansion slot of an attached device (workstation or PC). Alternatively, multiple cards may be contained within a multiport device that supports multiple workstations on a pooled basis. Each NIU/NIC has a unique logical address for purposes of identification; the address is hard-coded on a silicon chip.

Media Access Control (MAC)

Media Access Control (MAC) describes the process which is employed to control the basis on which devices can access the shared network. Some level of control is required to ensure the ability of all devices to access the network within a reasonable period of time, thereby resulting in acceptable access and response times. It is also important that some method exist to either detect or avoid data collisions, which are caused by multiple transmissions being placed on the shared medium simultaneously. Media Access Control can be accomplished on either a centralized or decentralized basis, and can be characterized as either deterministic or nondeterministic in nature.

Centralized Control

A centralized controller polls devices to determine when access and transmission by each station is allowed to occur. Stations transmit when requested to do so, or when a station transmission request is acknowledged and granted. This process of polling requires the passing of control packets, adding overhead and reducing the amount of throughput relative to the raw bandwidth available. Additionally, the failure of the central controller will disrupt the entire network; in such an event, the controller is taken off-line and a back-up controller assumes responsibility. Centrally controlled networks generally employ deterministic access control; Token Ring and FDDI networks are centrally controlled.

Decentralized Control

Decentralized control is somewhat anarchistic, as each station assumes responsibility for controlling its access to the shared network. Additionally, each station must assume responsibility for detecting and resolving any data collisions which might occur in the likely event access and transmission overlap with other devices. Decentralized control networks generally use nondeterministic, or contentious, media access control. For instance, Ethernet LAN control is decentralized.


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

Deterministic Access

Deterministic access is a media access control convention that allows both the centralized master station and each slaved station to determine the maximum length of time which will pass before access is provided the network. In other words, each station can be guaranteed the right to communicate within a certain time frame. Additionally, access priorities can be assigned by the system administrator. Deterministic access is also known as noncontentious, because the devices do not contend for access; rather, access is controlled on a centralized basis.

Deterministic access employs token passing. The token, which consists of a specific bit pattern, indicates the status of the network—available or unavailable. The token is generated by a centralized master control station, as described above, and transmitted across the network. The station in possession of the token is in control of access to the network. It may transmit or may require other stations to respond. Transmission is in the form of a data packet of a pre-determined maximum size, determined by the number of nodes on the ring and the traffic to be supported; oversized transmissions are segmented. After transmitting, the station will pass the token to a successor station in a predetermined sequence. While the process is complex and overhead-intensive, it yields careful control over the network.

Deterministic access is especially effective in high-traffic environments where a lack of control would cause chaos in the form of frequent data collisions. It also finds application in environments such as process control, where it is critical that each station be able to access the network on a periodic basis. For example, oil refineries employ deterministic media access control through proprietary token-passing LANs. The refining process requires that the nature of the specifics of the crude oil (raw material) be considered in terms of a number of characteristics, including sulfur content, paraffin content, and viscosity. With these factors in mind, the refining process is tailored to act on the raw material in such a way as to ensure that the end product (e.g, 97 octane unleaded gasoline) is consistent from one batch to another. In a hypothetical scenario, the master control station would address tokens to individual devices in the form of various sensors. The individual sensors monitor pressure and temperature conditions as well as the rate of flow of various chemicals through valves, throughout the entire process. In order to control the process effectively, each sensor must be addressed on a regular basis so that it can transmit data to the master controller. Additionally, some devices at certain times during the process may require more frequent, priority access. In consideration of that data, the master controller will command other devices to increase or decrease temperature, open or close valves, and so on. Such a network also is highly redundant in order that a network or device failure will not compromise the integrity of the process.

An extension of this concept is being applied in field trials by CATV (Community Antenna TV) providers in a convergence scenario. Internet access is provided to large numbers of residences, businesses, and schools over a two-way coaxial cable system terminating in cable modems at each premise. As much as 30 Mbps is reserved for such applications, with as much as 10 Mbps available to an individual user. In order to manage contention over such a network, which extends over fairly significant distances, a token-passing media access control technique is employed, with the master station located at the CATV provider’s head-end.

General characteristics of token-based networks include a high level of access control, which is centralized. Access delay is measured and assured, with priority access being supported. Throughput is very close to raw bandwidth, as data collisions are avoided; throughput also improves under load, although absolute overhead is higher than is the case with non-deterministic access techniques. Deterministic access standards include Token-Passing Ring, IBM Token Ring, and Token-Passing Bus.

Token-based LAN technologies are somewhat overhead-intensive, due to the token passing and management processes. However, they can more than compensate for that fact by virtue of the avoidance of data collisions. Token Ring, for instance comes in 4, 16, and 20 Mbps. In each case bandwidth utilization is virtually 100% [9-11].


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

Nondeterministic Access

Nondeterministic media access control, places access control responsibilities on the individual stations. Also known as Carrier Sense Multiple Access (CSMA), it is most effective in low-traffic environments. There are two variations, CSMA/CD and CSMA/CA.

Carrier Sense Multiple Access (CSMA) is a decentralized, contentious media access control method used in Ethernet and other bus-oriented LANs. Each of multiple stations, or nodes, must sense the carrier to determine network availability before access to the medium to transmit data. Further, each station must monitor the network to determine if a collision has occurred. Collisions render the transmission invalid and require retransmission. In the event of a busy condition, the station will back off the network for a calculated random time interval before attempting subsequent access.

CSMA works much like an old telephone party line, where there are multiple subscribers with individual logical addresses (in the form of telephone numbers) connected to a single physical circuit. When placing an outgoing call, the subscriber must pick up the telephone to monitor the line for a short period of time in order to sense the level of activity. If there is no activity, a call can be placed. If there already is a call in progress, another call attempt cannot be made without causing interference (and hard feelings). Rather, the telephone must be hung up. Subsequent random monitoring of the circuit can take place in order to determine its availability. Incoming calls are addressed to each party on the party line by varying the number of rings to indicate the unique logical address of each party sharing the circuit. Only the target party could answer the call without creating ill will. In other words, a set of media access control protocols were developed to govern the manner in which the circuit was managed to the satisfaction of all parties.

The above CSMA approach is known as Nonpersistent CSMA. Variations include 1-Persistent CSMA and P-Persistent CSMA. CSMA is implemented in two standard means, CSMA/CD and CSMA/CA. In either case, latency and throughput degrade under heavy loads of traffic. For example, an Ethernet network running at a theoretical speed of 10 Mbps typically provides about 4 to 6 Mbps throughput. While it is less costly than Token Ring networking, it also delivers less efficient use of bandwidth [9-11].

Carrier Sense Multiple Access with Collision Detection (CSMA/CD) is the most common media access control method used in bus networks. In an Ethernet environment, for instance (see Figure 9.6), the transmitting station sends a data packet in both directions of the bus, appended with a preamble (8 octets) for purposes of synchronization, destination (6 octets) and source (8 octets) addresses, and a type field (2 octets) identifying the higher layer protocol used in the data field (46 to 1500 octets). A Frame Check Sequence (FCS) consisting of a 32-bit CRC serves for error control [9-12]. Each transceiver (transmitter/receiver) of each station along the way reads the address prepended to the data packet. Should the address match, the transceiver provides the packet to the target device. Should the address not match, the transceiver forwards the packet to the next transceiver. Should a node detect a data collision, that station sends a brief jamming signal over a subcarrier frequency of the network to advise all stations of the collision. At that point, all devices back off the network, calculating a random time interval before attempting a retransmission.

Figure 9.6 CSMA/CD, with Ethernet frame format.

Carrier Sense Multiple Access/Collision Avoid (CSMA/CA) includes a priority scheme to guarantee the transmission privileges of high-priority stations. CSMA/CA requires a delay in network activity after each transmission is completed. That delay is proportionate to the priority level of each device, with high-priority nodes programmed for short delays and with low-priority nodes programmed for relatively long delays. As collisions may still occur, they are managed either through Collision Detect or through retransmission after receipt of a Negative Acknowledgment (NAK). CSMA/CA is more expensive to implement, as it requires that additional programmed logic be embedded in each device or NIC. CSMA/CA does, however, offer the advantage of improved access control, which serves to reduce collisions and, thereby, improve the overall performance of the network.

LAN Equipment

In addition to the attached devices (also referred to as nodes or stations), LANs may make use of other devices to control physical access to the shared medium, to extend the maximum reach of the LAN, and to switch traffic. Such hardware is in the form of NICs/NIUs, transceivers, MAUs, hubs, bridges, routers, and gateways. As is the case with much of the technology addressed in this book, the lines blur between these devices and their individual functions. Therefore, the focus will be on the classic definitions, expanding on those concepts and illustrating multifunctional devices as appropriate.

Network Interface Cards (NICs)

Also known as Network Interface Units (NIUs), NICs are printed circuit boards that provide physical access from the node to the LAN medium. The NIC can be fitted into the expansion slot of a PC, or it can exist as a separate box. A standalone, multiport NIC can serve a number of devices, thereby providing an additional level of contention control. A standard IEEE NIC contains a unique, hard-coded logical address. Transceivers are embedded in NICs/NIUs and MAUs. MAUs (Media Access Units, or Multistation Access Units) are standalone devices which contain NICs in support of one or more nodes.


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

Bridges

Bridges are relatively simple devices that are used to connect LANs of the same architecture (Ethernet-to-Ethernet). Bridges operate at the bottom two layers of the OSI model, providing Physical Layer and Data Link Layer connectivity. Bridges, at the most basic level, act to extend the physical reach of a LAN, passing traffic from one LAN segment to another based on the destination address of the packet. In other words, they act as LAN repeaters where specified distance limitations are exceeded (Figure 9.7). Bridges have buffers, in order that they can store and forward packets in the event that the destination link is congested with traffic.

Figure 9.7 Bridged LAN network.

A key advantage of bridges is their inherent simplicity. As protocol-independent devices, they do not perform complex processes on the data packets traveling through them. Neither do they attempt to evaluate the network as a whole in order to make end-to-end routing decisions. Rather, they read the destination address of the incoming data packet and forward it along its way to the next link. Cascading bridges accomplish this process link-by-link. As a result, bridges are inexpensive and fast. Such bridges can support multiple LANs connected by multiple media. In other words, multiple ports are provided with interfaces to coax, UTP, and fiber optic transmission systems. Additionally multiple LANs of disparate origin can be supported. For instance, Ethernet-to-Ethernet and Token Ring-to-Token Ring connectivity can be provided [9-13]. It also is possible to interconnect disparate LANs such as Ethernet-to-Token Ring, through the use of an encapsulating bridge. Such a bridge encapsulates the native LAN data, surrounding it with control information appropriate to the LAN to which the target device is attached.

More sophisticated bridges add more functionality, although they are more expensive and slower. Such bridges can also route traffic, at a simple level, between LANs based on the destination address. The routing table can be entered into program logic by the system administrator or can be learned by the bridge as it views the originating addresses of traffic passing through it over a period of time [9-14].

Filtering bridges filter traffic that is not addressed to another connected LAN or LAN segment. Filtering bridges are employed in LAN segmentation to reduce unnecessary congestion on LAN segments, improving overall access and throughput.

Media Access Control (MAC) bridges are more sophisticated still. MAC bridges connect unlike, or disparate, LANs (e.g., Ethernet-to-Token Ring). This is accomplished through the process of encapsulation, or translation. When operating in this mode, the bridge alters the packet/frame format, by encapsulating, or enveloping, the original packet with control data specific to the protocol of the destination LAN supporting the target device. Such an approach might be used to connect an Ethernet LAN to a Token Ring LAN, or where 2 Ethernet LANs are connected via a FDDI backbone [9-13].

Specific bridge protocols include Spanning Tree, Source Routing Protocol, and Source Routing Transparent.

Spanning Tree Protocol (STP) bridges
also known as Learning Bridges, are defined in IEEE 802.1 standards. Spanning tree bridges are self-learning, filtering bridges for use in connecting LANs on a point-to-point basis. The bridge is programmed or teaches itself the addresses of all devices on the network; subsequently, the network tree of the bridge provides only one span (link) for each LAN-to-LAN connection. Some spanning tree bridges also have the capability to provide security by denying access to certain resources based on user and terminal ID. Bridges which support the spanning tree algorithm have the ability to automatically reconfigure themselves for alternate paths if a network segment fails, thereby improving overall reliability [9-15].
IBM Source Routing Protocol (SRP)
bridges are programmed with specific routes for each packet, based on considerations such as the physical location of the nodes, and the number of bridges involved. The maximum number of bridges hopped is thirteen (13).
Source Routing Transparent (SRT)
is defined in the IEEE 802.1 standard. It is effectively a combination of STP and SRP. The SRT router can connect LANs by either method, as programmed [9-2].


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

Hubs and Switches

Hubs and switches reflect the trend toward star, and away from bus, configurations. Hubs can be either active or passive. Passive hubs act simply as cable-connecting devices, while active hubs also serve as signal repeaters [9-2]. The first generation of hubs (1984) acted as LAN concentrators and repeaters, with a single internal collapsed backbone bus for connecting like LANs. The second generation accommodated multiple LAN architectures (Ethernet and Token-Passing Ring) over separate ports; rudimentary network management and configuration capabilities were often included as well [9-13].

A collapsed backbone is a fairly simple concept, and one worth exploring in some detail. LANs traditionally work on the basis of a common electrical bus (shared cable medium) to which each device or group of devices is directly connected. While this approach works effectively, it requires that the cable be deployed through the entire workplace. The traditional coax medium is expensive to acquire and deploy as is fiber optic cable. Additionally, the cable is susceptible to physical damage unless it is protected by conduits, armoring or some other means, all of which involve additional cost. Alternatively, the high-speed backbone bus can be collapsed and placed within a hub, to which the devices are connected by means of a less expensive medium such as UTP. In this manner, the backbone bus is protected and the cost of cabling is much reduced. Should an individual device (workstation, NIC or MAU) create difficulty, it can be isolated by disabling the port by which is attached to the hub. Should a UTP cable suffer damage, the connection can be similarly disabled and the problem corrected at relatively low cost. While the UTP cable is inherently less capable than coax or fiber, equivalent bandwidth can be provided as long as the distances between the devices and the hub are within tolerable limits. The above is an accurate description of a 10Base-T configuration.

Intelligent Hubs, the third generation, provide multiple buses for multiple LANs, either of the same or disparate architectures (Figure 9.8). They support multiple media (coax, UTP, and fiber), multiple speeds, and multiple LAN protocols. As addressable devices, they can be centrally managed via SNMP (Simple Network Management Protocol) or another appropriate network management protocol. Intelligent hubs also provide bridging and basic routing capabilities [9-13]. Intelligent hubs with basic routing capabilities are also known as LAN switches; they can read the target address of the packet and forward it to the appropriate LAN segment, filtering it in the process in order to avoid its contributing to congestion on other LAN segments. The LAN switch also offers the advantage of a high-capacity, multibus switching matrix that can provide full LAN bandwidth to multiple, simultaneous communications on a point-to-point basis. For instance, one workstation can access another over a 10-Mbps connection, while another has a full 10-Mbps connection to a database server, and while still another is passing a file to a print server at high speed [9-16].

Figure 9.8 Intelligent hub configuration.

Regardless of the generation, the hubs serve, at minimum, as central points of interconnection for LAN-attached devices. Additionally, hubs serve as concentrators of LAN traffic and as repeaters, with multiple hubs interconnected through high-speed media [9-14]. A number of hub manufacturers offer stackable hubs, which offer the advantage of scalability; in other words, the hubs can be stacked and interconnected in order to increase port and traffic capacity. While this is an inexpensive approach to increasing capacity, there is a tradeoff in terms of the lack of high-speed interhub busses in a stack configuration [9-17].

Routers

Routers are highly intelligent devices that support connectivity between both like and disparate LANs, as shown in Figure 9.9. Additionally, routers provide connectivity to MANs (SMDS) and WANs (X.25, Frame Relay and ATM). Routers are protocol-sensitive, typically supporting multiple protocols, and large and varying packet sizes such as might be involved in supporting both Ethernet and Token Ring. Routers operate at the bottom 3 layers of the OSI model, using the Physical Layer, Link Layer and Network Layer to provide connectivity, addressing and switching [9-14].

Figure 9.9 Router network.

Server-based routers also are available in the form of router software embedded in a server. As they perform more slowly than their hardware relatives they generally are not considered up to the task of serving an enterprise-wide application. They do have application, however, in support of smaller, remote sites [9-18].

In addition to supporting filtering and encapsulation, routers route traffic based on a high level of intelligence that allows them to consider the network as a whole. Hubs and bridges, on the other hand, simply view the network on a link-by-link basis. Routing considerations might include destination address, packet priority level, least-cost route, minimum route delay, minimum route distance, and route congestion level. Routers are also self-learning, as they can communicate their existence to other devices and can learn of the existence of new routers, nodes and LAN segments. Routers constantly monitor the condition of the network, as a whole, in order to dynamically adapt to changes in the condition of the network. Routers are multiport devices with high-speed backbones which can be on the order of 1 Gbps+. Additionally, they typically provide some level of redundancy in order that they are less susceptible to catastrophic failure [9-13].

Interesting recent developments in the world of routers include those of alternate routing and inverse multiplexing. As noted by Charles Darling [9-19], what dedicated-WAN links lack in cost efficiency they make up for in terms of lack of reliability (backhoe-fade). Select manufacturers now offer routers that sense network failure and re-establish the connection via an alternate connection. While a backup ISDN link may be painfully slow compared with a T1 connection, Darling suggests that slow is better than stop. Additionally, some routers offer inverse multiplexing capabilities over ISDN and T-carrier facilities.

Router protocols include both bridging and routing protocols. These protocols fall into three categories: inter-router protocols, serial line protocols, and protocol stack routing and bridging.


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

Inter-router protocols are router-to-router protocols that can operate over heterogeneous networks. The protocol passes routing information and keep alive packets during periods of idleness. Examples include RIP (Routing Information Protocol) from Novell and OSPF (Open Shortest Path First) from the Internet Engineering Task Force (IETF).

Serial line protocols provide for communications over serial or dialup links connecting unlike routers. Examples include HDLC, SLIP (Serial Line Interface Protocol), and PPP (Point-to-Point Protocol). More discussion of these specific protocols is provided in Chapter 13 which deals with the Internet.

Protocol Stack Routing and Bridging Protocols advise the router as to which packets should be routed and which should be bridged.

Gateways

A term originally applied to what we now call routers [9-20], gateways are at the top of the LAN food chain. Gateway routers perform all of the functions of bridges and routers, including protocol conversion at all seven layers of the OSI Reference Model. Generally consisting of software residing in a host computer, such a midrange or mainframe, gateway technology is expensive but highly functional.

Protocol conversion, rather than encapsulation, can serve to fully convert from Ethernet to Token Ring, to FDDI or any other standard or proprietary LAN protocol. Additionally, protocol conversion can address higher layers of the OSI model, perhaps through Layer 7, the Application Layer. IBM SNA, DECnet, Internet TCP/IP and other protocols can be converted from network-to-network. As the process of protocol conversion is complex, gateways tend to operate rather slowly, compared to bridges and routers. As a result, they may create bottlenecks of congestion during periods of peak usage.

LAN Segmentation

LAN segmentation is a concept that simply involves dividing a single LAN into two or more physical segments. A LAN segment typically involves a workgroup that communicates intensively on the basis of station-to-station, stations-to-specific servers, or stations-to-specific peripherals such as local printers. As the usage is intensive, as the traffic patterns are well understood, and as the traffic is highly localized, a LAN segment can be effected through the use of a filtering bridge (which function may be included in a router or intelligent hub). The physical LAN still exists in its physical and logical entirety—it is just segmented.

The advantage of segmentation is that the relatively intensive traffic within the workgroup is confined to a physical and logical segment (domain) of that LAN. Therefore, that traffic does not affect the users on the balance of the LAN. When a LAN is divided into many, relatively small segments, the concept is known as microsegmentation. While the cost of the bridges may be of concern, the performance advantages often outweigh cost considerations.

LAN Operating Systems

A LAN Operating System, or Network Operating System (NOS), is software that provides the network with multiuser, multitasking capabilities. The operating system facilitates communications and resource sharing, thereby providing the basic framework for the operation of the LAN. The operating system consists of modules which are distributed throughout the LAN environment. Some NOS modules reside in servers, while other modules reside in the clients. International Data Corporation estimated that the total sales of LAN operating systems increased 54% from 1989 to 1990 to $1.14 billion and was expected to reach $2.8 billion in 1995; Novell NetWare accounts for three million users and a 65 to 77% market share [9-14] and [9-2].

Digressing for just a moment, the client/server model originated with the development of the U.S. Department of Defense ARPANET in the 1960s. As the cost and size of computer systems decreased and as the capabilities of those systems and the networks increased, the embodiment of client/server changed. A contemporary client is an application that generally resides on a microcomputer. The application can be word processing, a spreadsheet, or a database. The client runs against a server, a multiport computer that contains large amounts of memory, allowing multiple clients to share the servers’ resources, while performing certain functions independently. Servers are database engines capable of processing client requests for information. Servers also manage the data. As an example, client/server continues to be used extensively in the Internet. When accessing America Online, Prodigy, CompuServe, or another service provider, one uses the Graphic User Interface (GUI) and browser software that resides on the client PC. When initiating an Internet session, that software runs with software installed in the service provider’s communications server. Through this approach, the two devices communicate effectively without requiring that the software to be downloaded from the server as part of every Internet session. Because the graphic files are huge, a great deal of time and bandwidth would be wasted. Once connected to the communications server, the user subsequently can accesses a large number of database servers on a point-and-click basis, courtesy of the GUI. Only the target data is transmitted across the Internet.

In addition to supporting multitasking and multiuser access, LAN operating systems provide for recognition of users based on passwords, user IDs, and terminal IDs. On the basis of such information, LAN OSs can manage security using access privileges. Additionally, a LAN operating system provides multiprotocol routing, as well as directory and message services. DOS-based LAN operating systems include Novell NetWare and Sun Microsystems’ TOPS/DOS. OS/2 and UNIX-based LAN operating systems include Banyan VINES, IBM LAN Server, Microsoft LAN Manager, and Novell SFT NetWare.


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

LAN Internetworking

LAN Internetworking is the networking of two or more LANs, which may be similar or dissimilar in nature. The LANs may be in close proximity, or they may be geographically distant. Equipment used for LAN Internetworking includes that discussed above, plus a few other options. Specifically, the range includes bridges, routers, gateways, PADs (X.25), and TAs (ISDN). In a Frame Relay environment, FRADs (Frame Relay Access Devices) perform as the functional equivalent of PADs in the X.25 world.

WANs

WAN option for internetworking geographically distant LANs, include dialup options such as X.25 Packet Switching, ISDN, and Switched 56/64 Kbps. Dedicated leased-line options include DDS, T-carrier, and Fractional T1. Recent and developing fast packet network services include Frame Relay, SMDS (Switched Multimegabit Data Service), and ATM (Asynchronous Transfer Mode). These services are available from a wide variety of vendors, including LECs, IXCs, and specialized data carriers.

High-Level Internetworking Protocols

These provide the means by which the LANs can interconnect, at some level, including resolving issues of data formatting, addressing, and sequencing, as well as flow control and error control. The internetworking protocols which will be addressed include TCP/IP, XNS, SPX/IPX, and APPN.

TCP/IP (Transmission Control Protocol/Internet Protocol) integrates dissimilar systems and networks, operating at OSI Layers 3 and 4. TCP/IP initially was developed for the U.S. Department of Defense for use in ARPANET, which became standardized as X.25. Because early ARPANET protocols were subject to frequent network crashes, a new set of core protocols were proposed in 1974 by Vinton G. Cerf and Robert E. Kahn; that set of design protocols became the foundation for the development of the TCP/IP protocol suite. The U.S. Department of Defense stimulated development by funding Bolt, Beranek, and Newman (BBN) to implement TCP/IP for UNIX operating systems and the University of California at Berkeley to incorporate the BBN code into the Berkeley UNIX variation [9-20].

The TCP/IP protocol suite to bring together disparate networks, independent of host hardware, operating systems, transmission media and data link technologies. The resulting internet is transparent to the user, appearing as a single network. Additionally, TCP/IP is capable of supporting internetworking in the face of high error rates, as well as node or link failures [9-20].

TCP/IP has become widely popular as an internetworking protocol, as it is effective, inexpensive, and well-understood. TCP/IP remains a foundation of the Internet, and enjoys wide usage in all variety of networks and internetworking applications. The fact that the TCP/IP code is in the public domain encourages its use and further development, which continues to this day. The TCP/IP protocol suite is divided into two distinct protocol layers, TCP and IP.

Transmission Control Protocol (TCP) is a virtual circuit protocol, managing the flow of user application data and providing translations of application names to lower-level addresses. TCP supports reliable, peer-to-peer communications on a connection-oriented basis. TCP accepts the data stream, segments it, and passes it to IP for routing. On the receiving end of the data transfer, TCP accepts the segmented data from IP, resolves error conditions, resequences the data segments, and passes them to the target device [9-20] and [9-21].

Internet Protocol (IP) is the protocol layer that defines the nature of the format of the data (packets, or datagrams) and the routing of the data by IP address. The IP element of the TCP/IP protocol suite accepts the segmented data from TCP, routes it, resolves error conditions, and presents the data to TCP for resequencing. IP is a best effort protocol, meaning it provides no assurance of delivery—it is the responsibility of TCP to detect errored or lost packets and to effect resolution of such conditions [9-20] and [9-21].

XNS (Xerox Networking System) originally was developed for integrating Xerox office systems. Each packet is routed like a datagram in an X.25 network, with each packet routed independently and over the best available link.

SPX/IPX (Sequenced Packet Exchange/Internet Packet Exchange), Novell’s derivative of XNS, using echo protocol and error protocol. SPX/IPX is the defined interface for Novell NetWare.

APPN (Advanced Peer-to-Peer Networking) is an IBM protocol that allows routing of LAN traffic, independent of a Front End Processor (FEP). Supporting X.25, Token Ring and other network protocols, APPN is an integral part of SNA and SAA, and provides a transition toward routers, rather than IBMs traditional approach.


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

Virtual LANs (VLANs)

Virtual LANs are software-defined LANs that group users by logical addresses into a virtual, rather than a physical, LAN through an intelligent hub or LAN switch (Figure 9.10). The LAN switch can support many virtual LANs which operate as subnets [9-22]. Users within a virtual LAN are grouped either by IP address or by port address, with each node attached to the switch via a dedicated circuit. Users also can be assigned to more than one virtual LAN, should their responsibilities cross workgroup domains.

Figure 9.10 Virtual LAN configuration.

The LAN switches can be networked, thereby extending the reach of the virtual LAN. The networking is generally provided through FDDI, Fast Ethernet (100 Mbps), 100VG-AnyLAN, or 155 Mbps ATM over SDH/SONET fiber. VLANs can also be extended across the WAN through routers and via dedicated leased lines or ATM. Remote LAN access currently cannot be accommodated on a true VLAN basis. VLANs are proprietary; standards are not likely in the near future.

The advantages of switched virtual LANs are that bridge and router networks can be flattened and simplified, including the elimination of source-routing bridge hop restrictions. Congestion can be reduced through intelligent microsegmentation, yielding increased throughput, increased access, and reduced response time. Workstations can be provided with full bandwidth at each port. Physical Move, Add, and Change (MAC) activity is reduced because these requirements can be resolved through software changes; the cost of a MAC is estimated between $300 to $1,000. Additionally, security is much improved, through the association in software of users and terminals with subnetworks and hosts. Additionally, a measure of security is provided through software firewalls within the confines of each domain [9-23] and [9-24].

On the downside, VLANs are not easily implemented or managed. It takes a good deal of effort to develop the switch database and identify the various logical subnets. Further, VLANs typically require a complete replacement of the typical switch or router network—software upgrades just aren’t available. Costs are likely to come down and processes are likely to be automated in the future, as is always the case with successful new technologies.

Remote LAN Access

Remote LAN access is the ability to access a LAN from a remote location. The need for remote LAN access is increasing, worldwide, especially in the United States and Western Europe. A recent study by Forrester indicated that 75% of U.S. companies will need remote access solutions in 1995, with 70% of U.S. professional workers spending 20%+ of their time away from their desks, according to BIS [9-25].

As predicted ten years ago, Telecommuting is now growing at a fast pace. According to Dataquest, the number of teleworkers in Western Europe will double to 10.6 million in 1997, and telecommuters in the United States will roughly triple to 10 million in 1996. While most of these teleworkers will work out of the home only part time, the need for remote LAN access is clear [9-25].

The concept is one of providing access from remote locations to a LAN. Access to one or more host computers is often required as well. In support of telecommuters, contractors, remote offices, and the Small Office/Home Office (SOHO), remote LAN access is often essential to the operation of the enterprise. Additionally, remote access is often provided to customers, suppliers, and trading partners. The yield is that the remote user is provided access to resources with the same level of privilege as though he were onsite [9-14].

Key components to be examined are the network, the equipment and the applications supported. Other issues include security management and network management.

The remote LAN access network can assume a variety of forms, depending on issues such as availability, cost, and bandwidth. Network options literally run the full range of conventional data networks from the analog PSTN to ISDN, Switched 56, DDS, and T-carrier. Emerging network technologies such as Frame Relay, SMDS, and ATM are also appropriate. Finally, and in order to support truly mobile remote LAN access, cellular radio and packet radio data networks are commonly employed [9-25] and [9-26].

Network equipment varies according to the nature of the network employed. Improvements in equipment, as well as improvements in network technologies, have enabled cost-effective remote LAN access. That equipment can include high-performance workstations and high-speed modems for access to the PSTN. Access to X.25 networks requires PADs (Packet Assemblers/Disassemblers), ISDN requires TAs (Terminal Adapters), and Frame Relay requires FRADs (Frame Relay Access Devices). Access via a cellular wireless packet network requires the use of wireless modems. The LAN side of the connection requires the installation of modem pools, routers, and various other devices to support remote user access. According to Dataquest Inc., remote access routers accounted for $1.4 billion of a total $4 billion in routers shipped in 1995 [9-27].

Applications most often supported include e-mail, file transfer, and database access. Additional applications include scheduling, printing, access to online services, client support, and Internet access (Figure 9-11).

Figure 9.11 Remote LAN access applications [9-25].


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

LAN Standards and Standards Bodies

Standards developed by the IEEE (Institute of Electrical and Electronics Engineers) have largely governed the world of LANs since the formation of Project 802 in February 1980. Project 802, working within the scope of the OSI reference model, was chartered to deal with the two bottom layers. Notably Layer 2, the data link layer, was divided into two subgroups, Media Access Control (MAC) and Logical Link Control (LLC) [9-2]. The initial focus was on Ethernet, with the first recommendation being finalized in December 1982. That first release of the three standards were accepted by the IEEE membership, the U.S. National Bureau of Standards and the ECMA (European Computer Manufacturers Association). Correlating international standards were issued by the ISO (International Standards Organization). The ISO standards are known as 8802 LAN Standards.

Since that time, the IEEE has continued to develop a broad range of LAN and MAN standards. IEEE standards include the following:

• 802.1: Architecture and Internetworking (High-Level Interface). Defines architecture layers and rules for interconnection of disparate LAN protocols. Includes data formatting, network management and internetworking.
• 802.2: Defines equivalent of Logical Link Control services, including protocol for data transfer.
• 802.3: Defines CSMA/CD Access Method and Physical Layer specifications.
• 802.4: Token-Passing Bus Access Method and Physical Layer specifications.
• 802.5: Token-Passing Ring Access Method and Physical Layer specifications.
• 802.6: Metropolitan Area Network (MAN) Access Method and Physical Layer specifications. DQDB (Distributed Queue Dual Bus) is defined.
• 802.7: Broadband Technical Advisory Group. Standards for definition of a broadband cable plant design. Established guidelines for LAN construction within a physical facility such as a building.
• 802.8: Fiber Optic Technical Advisory Group. Established to assess impact of fiber optics and to recommend standards. Note that this standard is distinct from that of ANSI’s FDDI.
• 802.9: Integrated Voice and Data Networks (Isochronous Traffic)
• 802.10: Internetwork Security.
• 802.11: Wireless.
• 802.12: High-Speed LANs (e.g., 100VG-AnyLAN).

In addition to the IEEE, other standards bodies are involved in the establishment and promotion of certain LAN and computer networking standards. ANSI (American National Standards Institute), for example, developed the following standards:

• X.3T9-3: HPPI (High Performance Parallel Interface).
• X.3T9-5: FDDI (Fiber Data Distributed Interface).
Table 9.1 Dimensions of popular LAN standards.
 | ETHERNET | IBM TOKEN RING | FDDI
Standard | IEEE 802.3 | IEEE 802.5 | ANSI X3T9-5
Logical Topology | Bus | Ring | Ring
Physical Topology | Bus, Star | Ring, Star | Dual Ring,
 |  |  | Dual Bus
Media | Coax, UTP, STP | Coax, UTP, STP | Fiber
Transmission Mode | Baseband | Baseband | Baseband
Bandwidth | 10 Mbps | 4, 16, 20 Mbps | 100 Mbps
Media Access Control | Non-Deterministic: | Deterministic: | Deterministic:
 | CSMA/CD, CSMA/CA | Token-Passing | Token-Passing
Traffic Type | Data | Data | Data, Video, Voice

Life in the Fast LAN: The Need for Speed

During the past few years, traditional LANs have been pushed to their limits. More workstations and more active users have resulted in more LAN traffic. Increased use of graphics and other bandwidth-intensive applications have increased LAN traffic. Collaborative computing increased the demands on existing LAN technologies—especially voice and videoconferencing. Also users have became increasingly impatient, demanding faster response times. In general, LAN users mirror the times in which we live—more is better, bigger is better, and faster is better yet. Bandwidth of 10 Mbps, 16 Mbps and even 20 Mbps just doesn’t cut the mustard anymore! In response to this requirement, Fast LANs have been developed, offering bandwidth of 100 Mbps—soon to be 1 Gpbs. Fast LAN options currently include 100Base-T, or Fast Ethernet, and 100VG-AnyLAN.

100Base-T, or Fast Ethernet

A variation of 10Base-T, and standardized as IEEE 802.3u (June 14, 1995), 100Base-T is a high-speed LAN standard, that uses CSMA/CD and operates at 100 Mbps through an Ethernet switching hub. Multiple 10 Mbps connections are supported through multiple ports on the switch. Cat 3, 4, or 5 UTP can be used in 4-pair configuration; Cat 5 UTP is generally used for a maximum LAN diameter of 500 meters. Three pairs are used for transmission, with the fourth pair used for signaling and control (CSMA/CD) in half-duplex mode [9-28]. Connections to nodes, servers and other switching hubs are provided at 100 Mbps, supporting 10 10-Mbps channels. The 100 Mbps media include fiber (up to 30 miles or 50 Km without repeaters) and Cat 5 UTP at 100 meters. Full duplex transmission is supported by some manufacturers, yielding a theoretical total bandwidth of 200 Mbps [9-29]. Ethernet, however, is collision-prone; 100 Mbps of theoretical bandwidth may yield only 58 Mbps throughput. 100Base-T seems destined for greatness, given the huge installed Ethernet base. Additionally, the cost per port for 10Base-T and 100Base-T hubs has decreased over the past year from an average of $632 in October 1995 to $428, according to the Dell’Oro Group [9-30]. Fast Ethernet workstation adapters are now priced as low as $150, compared to approximately $75 for conventional 10-Mbps adapters [9-31].


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

Iso-Ethernet (Isochronous Ethernet Integrated Services)

Ratified by the IEEE in the Fall of 1995 and providing 16.144 Mbps, Iso-Ethernet adds speed to traditional 10Base-T Ethernet. It is intended to support isochronous (stream-oriented) traffic such as realtime voice and video conferencing through an Ethernet switching hub. The 809-2a standard provides 10 Mbps for data traffic and sets aside an additional 6.144 Mbps for voice and video through 96 64-Kbps ISDN B channels and 1 ISDN D channel at 64 Kbps. Multiple B channels can be linked, which most typically would be required in support of videoconferencing. In fact, the entire network can function in isochronous mode at 16.144 Mbps, providing 248 B channels at 64 Kbps. Although the products currently available limit connectivity to a single hub, Iso-Ethernet should be available on a multisegment basis in the future. LAN-WAN connectivity over ISDN links is facilitated by the adherence to ISDN standards. There are plans to develop a version for 100Base-T. Manufacturers of Iso-Ethernet hubs include Nexion Inc, Ericsson Business Networks AB, Incite, and Luxcom Inc. Costs vary widely, but are in the range of $200 to $300 per NIC and $400 to $1,700 per port for the hub [9-32], [9-33], and [9-34].

100VG-AnyLAN

100VG-AnyLan (VG=Voice Grade) is a joint development of AT&T Microelectronics, Hewlett-Packard, and IBM and is standardized by the newly created IEEE 802.12 committee. 100VG-AnyLAN supports Ethernet, Token Ring, and other LAN standards, incorporating a collisionless polling technique. It’s not quite as simple as it appears—a router upgrade is required to connect 100VG Ethernet and 100VG Token Ring [9-35].

Distances are 100 meters for Cat 3 UTP (4 pairs), 150 meters for Cat 5 UTP (2 pairs) and Type 1 STP (2 pairs), and 2000 meters for fiber. The specifications suggest that higher speeds are possible [9-35]. All pairs are used for transmission in half-duplex mode at 25 MHz. Priority access is provided through the DPMA (Demand Priority Media Access) technique. 100VG-AnyLAN can be deployed in a scaleable star topology [9-28]. As 100VG-AnyLAN has the ability to support priority access and collisionless transmission, some view it as superior to 100Base-T for multimedia LAN communications. However, the huge embedded base of Ethernet, as well as manufacturer support for it, makes 100Base-T a natural choice for most organizations [9-29].

Not surprisingly, an exception to this judgement deals with linking non-Ethernet LANs. 100VG-AnyLAN does a much better of linking Token Ring LANs, for instance. While Ethernet sends data in frames of 1,500 bytes, maximum, Token Ring can accommodate data fields up to 16,000 bytes. 100VG-AnyLAN handles this well; 100Base-T doesn’t [9-36] and [9-28].

FDDI (Fiber Distributed Data Interface)

FDDI is the standard (ANSI X3T9-5; IEEE 802.2) for a fiber optic, token-passing ring LAN. Bandwidth is at 100 Mbps, although several manufacturers offer 200 Mbps, full duplex interfaces. The excellent performance characteristics of fiber optics, in general, apply well to the LAN world. Error performance is in the range of 10-14; devices can be separated by as much as 1.2 miles (2 kilometers) over multimode fiber and 37.2 miles (62 kilometers) over single mode fiber [9-37] and [9-38]. The maximum frame size is 4500B, which accommodates the native frame sizes of all standard LAN networks [9-39].

FDDI is largely relegated to a backbone application due to the high cost of termination. In other words, the opto-electric conversion process is costly. A direct fiber interface to a PC workstation can be accomplished at an average cost of around $600, although this cost should drop over time. The advantages of FDDI, however, can be extended to the workstation through a concentrator which accomplishes the opto-electric conversion process for multiple attached devices. The connection from the concentrator to the workstations is accomplished via UTP over distances of 100 meters or less, based on a standard known variously as CDDI (Cable Distributed Data Interface) and TPDDI (Twisted-Pair Distributed Data Interface).

The fragility of the fiber is a deterrent to the application of FDDI, as well. The FDDI specifications provide for a dual counter-rotating ring, which provides a measure of redundancy. Should the primary ring fail, a Dual Attached Station (DAS) or Dual Attached Concentrator (DAC) can still communicate with any other device by transmitting in the opposite direction through the secondary ring, which typically is collocated in the same cable sheath as the primary ring (see Figure 9.12). Should there be more than one physical failure in the cable plant, however, the ring will segment and the network will fail. There are dual-homing solutions to this dilemma, although they involve considerable additional expense, with the designated stations being connected via fiber to multiple servers in order to provide redundancy [9-40].

Figure 9.12 FDDI dual counter-rotating ring.

FDDI is assured a place as a LAN backbone technology, at least until such time as ATM becomes a major force. However, its future as a desktop technology is questionable due to the high cost of FDDI NICs, which average in the range of $600 and can be as much as $2,000; CDDI cuts that cost by about 50% [9-38]. The cost of FDDI router modules is in the range of $10,000 to $30,000 [9-41]; FDDI switches are in the range of $7,000 to $18,000 per port [9-42]. 100Base-T and VG-AnyLAN offer similar performance at much lower cost.

ATM (Asynchronous Transfer Mode)

Discussed in detail in Chapter 11, ATM promises to change the face of LAN networking. ATM is based on cell switching technology which accommodates any form of information. The data is segmented into a cell of 53 octets, 48 of which are data payload and 5 of which are control overhead. Voice and video are supported as effectively as data. Isochronous data is transported and switched as easily as is asynchronous or synchronous data. Additionally, and as ATM is viewed as the future of Wide Area Networking, ATM in the world of the LAN provides a smooth path to LAN-to-LAN internetworking over the WAN. The LAN standard for ATM was originally specified a rate of 155 Mbps, although a 25-Mbps standard was later added.

At the time of this writing, ATM has yet to make a significant impact on the LAN world. ATM is not backward-compatible, as it requires a complete and expensive upgrade of equipment in the form of ATM hubs and NICs. Additionally, there are issues of hardware interoperability among the various manufacturers. Despite these drawbacks, ATM is being implemented on a limited basis in organizations with the funds and courage to step into the future [9-43].


Communications Systems and Networks:Local Area Networks: Connectivity and Internetworking

FireWire

Based on the IEEE 1394 standard, FireWire is designed to eliminate the bottleneck at the serial port of the LAN-attached PC. While 100-Mbps LANs address the bottleneck of the shared medium, they overwhelm the attached workstation (much like drinking out of a firehose). As videoconferencing and multimedia applications increase in popularity, it is necessary to increase the speed of the SCSI (Small Computer Serial Interface) in order to support them and take full advantage of the speed provided by the LAN. FireWire addresses that requirement through standards for 100, 200, and 400 Mbps. The chip sets which accomplish this minor miracle currently are in the range of $30, but are expected to drop to $10 in 1996 and $6 in 1997 [9-44].

Nonstandard LANs

In addition to standard LANs there exist a number of nonstandard options. Some are proprietary standards that serve certain applications and vertical markets, such as those described earlier with reference to the oil refining industry. Others are more widely accepted, such as ARCnet (Attached Resource Computer network). Developed in 1977 by Datapoint Corporation, ARCnet is a highly reliable, low-cost token bus system based on a physical star and logical ring, and a character-oriented protocol. Delivering 2.5 Mbps on a standard basis, a new version delivers 20 Mbps [9-14]. The ARCnet standard is similar to the IEEE 802.4 specification, although its employs a baseband network [9-2].

References

[9-1] Shelly, Gary B and Cashman, Thomas J. Introduction to Computers and Data Processing. Fullerton, CA: Anaheim Publishing Company. 1980.
[9-2] Nunemacher, Greg. LAN Primer. Third Edition. NY: M&T Books. 1995.
[9-3] Metcalfe, Robert M. and Boggs, David R. Ethernet: Distributed Packet Switching for Local Computer Networks. Association for Computing Machinery, Inc. 1976.
[9-4] Metcalfe, Bob. “From the Ether.” InfoWorld. October 31, 1994.
[9-5] Williams, Veronica A. Wireless Computing Primer. NY: M&T Books. 1996.
[9-6] Ketchersid, John and Ferguson, Jerry. “Freedom!” Network World. November 13, 1995.
[9-7] Larsen, Amy K. “Wireless LANs: Worth a Second Look.” Data Communications. November 1995.
[9-8] Lee, Yvonne L. “Notebooks Connect to Network via Infrared.” Infoworld. April 8, 1996.
[9-9] Gambon, Jill. “The Price of Freedom.” Information Week. February 26, 1996.
[9-10] “Wireless LANs Get Throughput Boost.” Information Week. January 22, 1996.
[9-11] Tolly, Kevin. “Token Ring versus Ethernet: The Real Cost Story.” Data Communications. May 21, 1995.
[9-12] Miller, Mark A. Internetworking: A Guide to Network Communications LAN to LAN; LAN to WAN. Second Edition. NY: M&T Books. 1995.
[9-13] Spohn, Darren L. Data Network Design. NY: McGraw-Hill, Inc. 1993.
[9-14] Levy, Joseph R. and Hartwig, Glenn. Networking Fundamentals: From Installation to Application. NY: MIS: Press. 1995.
[9-15] Ethernet Tutorial and Product Guide. Irvine, CA: LANTRONIX. 1995.
[9-16] Lopez, Steve. “Why Switch?” Internetwork. March 1995.
[9-17] Petrosky, Mary. “Hub Shopping Spree.” Network World. May 29, 1995.
[9-18] Roberts, Erica. “Server-Based Routing Reconsidered.” Data Communications. March 1996.
[9-19] Darling, Charles B. “Routers Can Save Your WAN Dollars.” Datamation. July 1, 1995.
[9-20] Feit. Sidnie. TCP/IP: Architecture, Protocols and Implementation. NY: McGraw-Hill, Inc. 1993.
[9-21] Comer, Douglas E. Internetworking with TCP/IP. Second Edition. NY: Prentice-Hall. 1991.
[9-22] Jacobs, Paula. “Virtual LANs: Too Good to Be True?” Network World. March 27, 1995.
[9-23] Morency, John P. “Do VLANs Really Deliver?” Business Communications Review. July 1995.
[9-24] King, Steven S. “VLANs Raise Delicate Design Issues.” Network World. April 17, 1995.
[9-25] Allard, Hank. “Remote LAN Access: Strategies and Solutions.” Network World Technical Seminars. 1995.
[9-26] Gangler, Barbara. “Remote Possibilities.” Internetwork. June 1995.
[9-27] Duffy, Jim. “Remote Access Gear Piles Up.” Network World. May 20, 1996.
[9-28] Finneran, Michael. “Life in the Fast LAN.” Business Communications Review. May 1995.
[9-29] Rosen, Ron. “User’s Guide to 100Base-T and 100VG-AnyLAN.” Handbook of Local Area Networks. John P. Slone, Editor. NY: Auerbach Publications. 1995.
[9-30] Lach, Eric. “Faster and Cheaper Ethernet on the Way.” Communications Week. May 27, 1996.
[9-31] Okin, Ken and Lee, Tony. “Fast Ethernet is Here to Stay.” Network World. April 8, 1996.
[9-32] Brand, Richard. “Iso-Ethernet Bridging the Gap From WAN to LAN.” Data Communications. July 1995.
[9-33] Greenfield, David. “Iso-Ethernet A Reprieve for Ethernet?” Data Communications. March 1996.
[9-34] Sodergren, Mark. “Pumping Up 10Base-T with isoEthernet.” Network World 7, 1995.
[9-35] Rauch, Peter and Lawrence, Scott. “100VG-AnyLAN: The Other Fast Ethernet.” Data Communications. March 1995.
[9-36] Newman, David and Levy, Bruce. “100Base-T vs. 100VG: The Real Fast Ethernet.” Data Communications. March 1996.
[9-37] Peri, Ron. “Life in the Fast Lane.” Communications Week. January 23, 1995.
[9-38] Sullivan, Kristina B. “Promise of FDDI Holds True.” PC Week. January 15, 1996.
[9-39] Implementing FDDI in Enterprise LANs. SysKonnect, Inc. 1995.
[9-40] Heneghan, Hank. “New Configurations Make FDDI More Survivable.” Network World. November 20, 1995.
[9-41] Schurr, Amy. “Still Alive: FDDI Keeps Competition at Bay.” PC Week. December 18, 1995.
[9-42] Saunders, Stephen. “FDDI Switches: Immediate Relief for Backbones Under Pressure.” Data Communications. November 1995.
[9-43] Bruno, Charles. “Checking the Routing Structure of the Switching Blueprints.” Network World. September 25, 1995.
[9-44] Bournellis, Cynthia. “Raising the LAN Speed Limit.” Internetwork. November 1995.


Communications Systems and Networks:Broadband Network Infrastructure

Chapter 10
Broadband Network Infrastructure

Et loquor et scribo, magis est quod fulmine iungo. I speak and I write but more, it’s with light(ning) that I connect.

—Giovanni Pascoli, describing his views of the telegraph, 1911.

—translated by Daniel Minoli

Broadband Networking addresses the near and distant future of telecommunications—the need for speed! As we have discussed in previous chapters, the PSTN set the stage. It is still in place, is highly available, it works beautifully for voice and quite well for many nonvoice applications, and is highly reliable and cost-effective. However, it offers limited bandwidth, is assumed to be analog at the local loop level, introduces errors in transmission, is relatively slow in establishing connections, and is expensive for communications-intensive applications.

Conventional public data networks (PDNs) were significant improvements over PSTN. Although designed specifically for data communications, the PDNs still relied, at least in part, on the PSTN model for basic connectivity (local loops, data nodes collocated with voice switches, and common transport facilities). The traditional data model included both dedicated and switched connections, as well as a packet-switched alternative, X.25. Conventional PDNs provided improved performance in terms of speed, error control, throughput and network management.

The broadband network model is still emerging. Although some broadband network technologies are still immature, they are rapidly being deployed in backbone networks in developed countries. They also now are being extended directly to large end users. Broadband networks also rely on the voice model to some extent, often using the same, although upgraded, local loop; equipment collocated in PSTN end offices; and common, although upgraded, backbone transmission facilities. Some broadband technologies are intended specifically for data transmission, although others were designed to support a full range of voice, data, video and image traffic.

Broadband networks, generally speaking, share a number of characteristics. Bandwidth, by definition, is greater than DS3 ([ge]45 Mbps). Additionally, bandwidth is often provided on-demand in order to address dynamic bandwidth requirements of applications such as videoconferencing, multimedia conferencing, and bursty LAN-to-LAN traffic. Error performance is excellent, network management is robust, and resiliency is high due to substantial redundancy. While broadband networks are cost-effective for bandwidth-intensive applications, the absolute cost of acquisition and deployment is quite high. As a result, the necessary infrastructure is being deployed cautiously.

In previous chapters we explored the fundamentals of transmission systems (Chapter 3), the nature and specifics of PSTN (Chapter 6), and conventional digital and data networks (Chapter 8). Those discussions set the stage for an in-depth presentation of the latest in access and transport technologies. This chapter will deal with a number of developing local loop technologies. We will also examine SONET, the standard for fiber-optic backbone networks.

Local Loop Technologies

Regardless of the sophistication and elegance of the backbone network technology, it is still necessary to gain access to it. Despite the hyperbole about fiber optic cable or hybrid fiber/coax connections to the premise, little investment has been made in such access technologies. Some large user organizations in commercial office parks or high-rise buildings have direct fiber connections from LECs, IXCs or CAPs. A few privileged residential and small business customers have access in areas where various field trials are underway. The rest of us must still contend with the limitations of the twisted-pair local loop. However, significant advances have been made in the use of UTP. Additionally, fiber and wireless technologies have been developed to extend broadband capabilities to the premise. Specifically, we will explore the local loop access technologies of Asymmetric Digital Subscriber Line (ADSL), High-Bit Rate Digital Subscriber Line (HDSL), and Wireless Local Loop (WLL).

Asymmetric Digital Subscriber Line (ADSL)

Asymmetric Digital Subscriber Line (ADSL) is an advanced, high-bandwidth local-loop technology designed to extend the life of existing UTP loops for the transmission of broadband signals. Developed by Bellcore at the request of the regional Bells, ADSL provides for very high-capacity transmission over relatively short local loops in the Carrier Serving Area (CSA). ADSL makes use of DMT (Discrete MultiTone) and other compression techniques to accomplish this feat. ADSL protocols and interfaces recently were standardized by ANSI as T1.413. The technology is promoted by the ADSL Forum, which boasts membership of about 60 manufacturers and carriers [10-1].

ADSL Technology

In addition to supporting POTS voice over a separate analog channel, ADSL supports a high-speed downstream channel. The downstream bearer channel is in increments of 1.536 Mbps up to 6.144 Mbps, based on T1 specifications. Additionally, a bidirectional channel is provided in increments of 64 Kbps up to 640 Kbps. Variations of standard ADSL are several, as indicated in Table 10.1. The higher-speed versions ([ge]51.84 Mbps) also are known as Very High Data Rate Subscriber Line (VDSL).

Table 10.1 ADSL variations
DOWNSTREAM CHANNEL (Simplex) | BIDIRECTIONAL CHANNEL (HDX) | MAXIMUM DISTANCE
6.144 Mbps (US)* | 640 Kbps | 2 Miles (3 Km)
51.84 Mbps (US) | 5 Mbps | 0.6–1.2 Miles (1–2 Km)
155 Mbps (US) | 15 Mbps | 500 meters
8 Mbps (European) | 608 Kbps | 3–4 Km
*4 bearer channels @ 1.536 data rate yields a data rate of 6.144 Mbps; overhead is additional. Further variations exist as specified in ANSI T1E1.4/94-007 Revision 8.


Communications Systems and Networks:Broadband Network Infrastructure

The original inputs of voice, data, and image information are anticipated to be carried across the WAN via an ATM backbone network, ideally based on fiber optics. The video signals may also travel across the ATM WAN, and may be received at the central office via broadcast satellite, or the programming may be stored on tape or disk in a video server at the CO. The voice input is handled at each end of the connection through a splitter which ensures that it is unaffected by the presence or absence of digital data. The video and data inputs are time division multiplexed into an ADSL signal which originates in an ATU-C (ADSL Transmission Unit-Central Office). The signal then travels the local loop cable plant, terminating in one or more ATU-Rs (ADSL Transmission Units-Remote) located on customer premises. The ATU-Rs act as modems, splitting the total bandwidth into three channels—downstream channel, bidirectional channel, and voice channel. The ATU-Rs can be in the form of standalone units, or printed circuit boards in PCs or other host computers. They can also be contained within set-top boxes in a video or TV application. The bit error rate (BER) of ADSL is 10-9, which compares favorably even with traditional T1 at 10-7.

ADSL Applications

ADSL is intended for applications requiring a high-speed downstream channel, and a relatively low-speed upstream channel (see Figure 10.1). While the technology is not appropriate for many bandwidth-intensive, conversational data communications applications, it appears to be ideal for entertainment TV (CATV), business TV and educational TV. Telecommuters also can be well served by ADSL for remote LAN access. In a SOHO (Small Office Home Office) environment, ADSL provides plenty of bandwidth for most applications, including Internet access, and file and image transfer. Into the future, ADSL promises to serve Video-on-Demand (VOD) applications, providing sufficient bandwidth for multiple downstream video channels, as well as the upstream video selection.

Figure 10.1 ADSL configuration in example residential application.

The primary interest in ADSL is on the part of the incumbent telephone companies, which are facing competition from CATV companies for the residential voice and data market. As the CATV providers prepare to compete for that business, they are making plans to upgrade existing coaxial cable plant to add bidirectional, switched voice and data capabilities. The CAPs and IXCs have similar plans, although they must build new local loop facilities to reach that market. In the face of that pressure, the telephone companies must find a means to increase bandwidth in the local loop in order to compete effectively. Their options are to lay new cable plant (fiber optic or coax), make use of wireless technology, or increase the capacity of existing twisted-pair plant. ADSL offers a relatively inexpensive solution, accommodating entertainment TV, videoconferencing, and higher-speed data transfer over existing cable plant of varying gauges. Most carriers view ADSL as a short-term solution, filling the bandwidth gap until more substantial cable plant is deployed.

ADSL Status

While ADSL has performed well under laboratory conditions, it has yet to be proven in the field. Bell Atlantic was a primary force behind ADSL development, and continues to champion the technology. Pacific Bell and some other RBOCs, have rejected ADSL, preferring a hybrid local loop technology of fiber and coax.

Bell Atlantic has been trialing ADSL since March 1993 to deliver video-on-demand in Fairfax County, VA and Dover Township, NJ. US West plans to trial ADSL for Internet access and remote LAN access in Minneapolis/St. Paul, MN and Boulder/Denver, CO. The monthly rate for the US West offering (1.544 Mbps) will vary from $60 to $100 per month, compared to ISDN (128 Kbps) charges of $32 per month plus usage or $100 per month on a flat rate basis; US West anticipates dropping the monthly rate to as little as $35 by 1998 [10-2]. GTE is also offering ADSL in Irving, TX for Internet access and remote LAN access [10-3] and [10-4]. Southwestern Bell intends technical trials of ADSL at both 1.544 Mbps and 6 Mbps [10-5]. UUNET Canada announced in June 1996 the beginning of a trial that ultimately will involve as many as 400 users. This first application of ADSL by an Internet Service Provider (ISP) will operate at 1.544 Mbps from the network to the user, with a 64 Kbps upstream channel [10-6].

In addition to the strong interest of U.S. LECs, ADSL has gained the attention of foreign carriers. British Telecom (UK) began a field trial in February 1994, and Telefonica de Espana (Spain) followed a month later. Trials also are being conducted by Mercury Communications (UK) and Telecom Australia, and are planned for the networks of Italy, France, Korea, The Netherlands, Hong Kong, Brazil, Finland, Norway and Germany.

The costs of implementing ADSL technology are high in absolute terms, but quite reasonable when compared to the alternative of laying new cable plant, such as hybrid fiber/coax. While the ATU-R currently sells for about $1,000, costs are expected to drop considerably as support for ADSL increases [10-7]. The total cost to the carrier is in the neighborhood of $6,000 per line, although it is expected to fall to $3,000 by 1997 and $750 in the future [10-8]. Brooktree Corp. (CA) recently (May, 1996) announced a transceiver chip which will deliver 384 Kbps on a bidirectional basis for $30; the interface card built around it is expected to cost as little as $100 [10-9].

There also exist nonstandard versions being trialed by GTE and other carriers. One such version is known as SDSL (Symmetrical Digital Subscriber Line), operating at 1.544 Mbps on a symmetrical basis. SDSL is touted by AT&T Paradyne as a solution for videoconferencing applications, that require symmetrical bandwidth [10-10] and [10-11]. The higher-speed versions of ADSL also are known as VDSL (Very High Bit-Rate Subscriber Line). In competition with the DMT compression technique is Carrierless Amplitude/Phase modulation (CAP), which is supported by AT&T Paradyne and other manufacturers. Using the less-expensive CAP technique, AT&T Paradyne announced in June 1996 another version of ADSL, operating downstream at 7 Mbps. Paradyne plans to request that ANSI make CAP a second standard [10-4]. In fact, the only ADSL products working in the field are based on CAP, rather than DMT. Pioneer manufacturers of ADSL equipment include Amati Corporation, AT&T Paradyne, Orckit, and PairGain Technologies.


Communications Systems and Networks:Broadband Network Infrastructure

High Bit-Rate Digital Subscriber Line (HDSL)

High Bit-Rate Digital Subscriber Line (HDSL) was also developed by Bellcore at the request of the RBOCs. It is intended as a more cost-effective means of providing T-1 local loop circuits over existing UTP.

HDSL Technology

HDSL eliminates repeaters in the T1 local loop for distances up to 12,000 feet, using the same 2B1Q (2 Binary, 1 Quaternary) coding scheme used in ISDN. Conventional T1 uses 2 pairs, each of which operates in simplex mode (one transmitting and one receiving) in a different direction at the full T1 rate of 1.544 Mbps. At such high frequencies, interference can be significant between the T1 pairs and adjacent pairs in the cable; additionally, signal attenuation is considerable. Therefore, it is necessary that the repeaters be spaced approximately 6,000 feet apart in order to adjust for distortion and signal loss.

HDSL, while it also uses two pairs of UTP, splits the pairs into full-duplex (FDX) channels. Each pair operates at 784 Kbps, (see Figure 10.2) half the T-1 rate plus some additional overhead. As the transmission rate per pair is halved, the frequency level is roughly halved; therefore, signal loss and interference are much less. The yield is that of longer transmission distances (up to 9,000 feet) without repeaters. As one might expect, the UTP cable plant must be in good condition and free of bridged taps.

Figure 10.2 HDSL configuration in example business application.

The real advantage of HDSL is that T1 service can be provisioned at much lower cost and in a much shorter interval of time. While HDSL equipment currently costs about $2,000 per circuit [10-12], that cost will come down quickly as the technology gains market share. As repeaters are eliminated or reduced in number, the incremental cost of HDSL is mitigated to some extent. Additionally, the cable plant supporting HDSL does not require special conditioning or engineering, further reducing costs, as well as allowing service to be provisioned much more quickly. Finally, HDSL offers error performance of approximately 10-10, as compared to the 10-7 level offered by repeatered T1 over twisted-pair, according to PairGain Technologies Inc., the leading supplier of HDSL equipment [10-13], with over 300,000 units sold.

Wireless Local Loop (WLL)

Wireless Local Loop (WLL) technologies, which will be discussed in more detail in Chapter 12, involve a relatively low-power, omnidirectional digital radio transmitter capable of supporting bidirectional communications. A number of manufacturers have released such products for voice applications—AT&T, DIVA, Ericsson, and Motorola are notable. Such a system is designed to support voice and low-speed data in a relatively small geographic area, with a radio transceiver located at the customer premise and serving multiple terminal devices. Spread spectrum radio provides improved security, as well as improved bandwidth utilization.

While its Quality of Service (QoS) generally does not compare favorably with cable alternatives, WLL does offer the advantages of rapid deployment and immunity to many issues of topography. WLL is not limited to narrowband voice. Broadband WLL operates much like ADSL, although on a wireless basis. Bellcore standard systems for Broadband WLL include ADML and LMDS. Asymmetric Digital Microcell Link (ADML) provides up to 1 Gpbs aggregate bandwidth at each radio site; [ge]1 Mbps can be provided to each premise. Local Multipoint Distribution Services (LMDS) is similar to ADML, but with a greater area of coverage.

Hybrid Local Loops

Hybrid local loop technologies include some combination of media and transmission technologies. Generally discussed in the context of a convergence scenario (Chapter 15), hybrid local loops typically involve Fiber-To-The-Neighborhood (FTTN), terminating in a remote shelf comprising a TDM MUX and an optoelectric conversion device. The signal is carried the last few hundred meters or so over coax, UTP (ADSL), or radio (WLL). This approach provides maximum bandwidth and signal quality to a remote unit, which contains all of the expensive optoelectric conversion equipment. The relatively short connection from the remote unit to the premise can easily be supported by conventional cable systems or WLL technology.

SONET/SDH

SONET/SDH is a set of international standards for broadband communications over single-mode fiber optic transmission systems, allowing manufacturers to build equipment to support full interconnectivity and interoperability. SONET/SDH uses a transfer mode which defines the switching and multiplexing aspects of a transmission protocol, supporting both asynchronous and synchronous traffic in any form. Intended primarily for the carrier networks, SONET/SDH can also be deployed to the user premise, although such implementation currently is unusual. The Network-to-Network Interface (NNI), also known as Network Node Interface, was specified by the CCITT in order that national and regional networks can be blended into a cohesive global network. The User Network Interface (UNI) was also specified in order that users might connect on a standard basis.

SONET/SDH describes the characteristics of a fiber optic physical infrastructure (OSI Layer 1), rather than a set of services. However, a number of recently developed services depend on bandwidth, error performance, flexibility, and scalability which can be provided best over a SONET infrastructure. Examples of such services certainly include Frame Relay, SMDS, ATM, and B-ISDN, all of which will be discussed in Chapter 11. Additionally, T-carrier, DDS, N-ISDN, and X.25 networks traffic all benefit from the performance characteristics of SONET infrastructure. For that matter, even voice traffic gains advantage.

According to Northern Business Information, the SDH/SONET transmission equipment market is expected to reach $8.5 billion by 1999, out of a total transmission market of $37.4 billion. Growing at 25% per year, the SDH/SONET market is strongest in the Asia/Pacific region, where huge network upgrades are taking place in China, Indonesia, Malaysia, and Thailand [10-14]. With the exception of definition and initial discussion of SDH, this chapter will focus of SONET, the original and U.S. standard.


Communications Systems and Networks:Broadband Network Infrastructure

SONET (Synchronous Optical NETwork) was the first attempt to develop a set of fiber-optic system standards. As each manufacturer’s products were designed according to proprietary specifications systems of disparate origin were incompatible—they simply did not interconnect, much less interoperate. Therefore, each fiber optic link (e.g, from CO-to-CO) was required to have equipment of the same origin at both ends. This limitation effectively forced the carriers to select a single equipment vendor, limiting the ability of other manufacturers to compete and stifling technical creativity. Additionally, the interconnecting carriers had to limit fiber optic systems either to a single vendor, or to optoelectric interfaces which limited the capacity to far less than that actually supported by the individual systems. (The lowest common denominator always rules.) Therefore, the economic and technical benefits of a multivendor market were limited, and largely unrealized.

Initial standardization efforts began in 1984, when MCI proposed the development of connectivity standards, or mid-span fiber meets, to the Interexchange Carrier Compatibility Forum (ICCF). The ICCF then requested that the Exchange Carriers Standards Association (ECSA) develop those standards [10-15]. In 1985, Bellcore proposed SONET to the ANSI T1X1 committee; the process continued until final approval for a much-revised SONET was gained in June 1988. The resulting ANSI specification for SONET Phase 1, were released in T1.105-1988 and T1.106-1988, specifying a basic transmission level of 51.84 Mbps, which will carry a T3 signal of 45 Mbps plus additional overhead.

SDH (Synchronous Digital Hierarchy) is the international version of SONET standards. The initial SDH efforts, driven by the SONET impetus, were begun by the CCITT in 1986. In 1988, the SONET standards were accepted by the CCITT, (now ITU-T) with modifications which were mostly at the lower multiplexing levels. These differences are largely due to the requirement to accommodate the complexities of internetworking the disparate national and regional networks. The ITU-T (nee CCITT) Recommendations referenced are G.707, G.708 and G.709.

Standards work continues on SONET/SDH, with the involvement of standards bodies and associations including ANSI, EIA, ECSA, Bellcore, IEEE and ITU-T (nee CCITT) [10-16].

• ANSI (American National Standards Institute), founded in 1918, coordinates and harmonizes private sector standards development. ANSI also serves as the U.S. representative to the International Standards Organization (ISO), the originator of the Open Systems Interconnection (OSI) reference model.
• EIA (Electronic Industries Association) was founded in 1924 as the Radio Manufacturers Association. A trade organization representing the interests of U.S. electronics manufacturers, the EIA assists in the development of optoelectric interfaces and test procedures for SONET.
• ECSA (Exchange Carriers Standards Association), formed in 1984, represents the interests of U.S. IXCs. The ECSA T1 committee addresses issues of functionality and characteristics of interconnection and interoperability. The T1X1 committee addresses issues of digital hierarchy and synchronization.
• Bellcore (Bell Communications Research) was formed in 1984 under the terms of the Modified Final Judgement (MFJ) which forced the divestiture by AT&T of the Bell Operating Companies (BOCs). Bellcore is the research and development arm of the RBOCs, its client/owners. Bellcore focuses on standards development, test procedures and Operations Support System (OSS) development, rather than the physical sciences. Bellcore is now in the process of being privatized, as the interests of the RBOCs no longer are common in a deregulated, competitive environment.
• IEEE (Institute of Electronic and Electrical Engineers) is a worldwide professional association dealing with SONET only peripherally. The IEEE has significant responsibility for the development of LAN standards, including FDDI, which have great impact on SONET.
• ISO (International Standards Organization) is an organization comprised of the national standards organizations (ANSI) of the various nations. The ISO heavily influences international standards set by the ITU-T, and is best known for its involvement in the OSI (Open Systems Interconnection) model.
• ITU-T (International Telecommunications Union-Telecommunications Standardization Sector), formed in 1865, is an agency of the United Nations. The ITU-T develops international standards in order to promote a world order of interconnectivity and interoperability. ITU-T is sometimes abbreviated as ITU-TS and ITU-TSS.

SONET Standards Development

SONET standards were developed in three phases. Phase I (1988) defines transmission rates and characteristics, signal formats, and optical interfaces. Phase I also defines Optical Carrier (OC) levels and Data Communications Channels (DCC), used for network management purposes in support of mid-span meet at the payload level. While Phase I does not support network management from end-to-end, neither does it preclude that potential. Phase II refined the physical portion of the standards and defined protocols used on data communications channels DS-1 to DS-3. Phase II also defines interoperability parameters for mid-span meets, network management, OSI CMISE (Common Management Information Service Elements) and add/drop multiplexer capabilities. Phase II further defines OAM&P (Operations, Administration, Management and Provisioning) procedures and connectivity to B-ISDN. Phase III provides all network management (OAM&P) requirements for midspan meet. Phase III also defines all network management standard message sets (alarm state, circuit-pack failure, and intermittent failure) and addressing schemes for interconnection. Finally, Phase III provides for ring and nested protection switching standards [10-15] and [10-16].


Communications Systems and Networks:Broadband Network Infrastructure

SONET/SDH Transmission Hierarchy

SONET defines the Synchronous Transport Signal Level-N (STS-N) as the electrical signal. When converted to an optical signal for transport over a standard fiber optic medium, the term Optical Carrier-N (OC-N) is applied. As shown in Table 10.2, the basic building block of the digital hierarchy is OC-1 at 51.84 Mbps—SONET begins at broadband levels. Notably, the various STS levels are considerate of the existing digital signal hierarchy, thereby achieving backward compatibility with legacy systems. For example, a T3 frame maps comfortably into a STS-1 signal which becomes an OC-1 frame. Similarly, multiple T1 frames can be aggregated to form and map into an STS-1 signal, which then becomes an OC-1 frame.

Table 10.2 SONET/SDH signal hierarchy
Optical Carrier (OC) Level | SONET STS Level | SDH STM Level | Signal Level | Equivalent DS3 (45 Mbps) Channels | Equivalent DS0 (64 Kbps) Channels
OC-1 | STS-1 |  | 51.84 Mbps | 1 | 672
OC-2 | STS-2 |  | 103.68 Mbps | 2 | 1,344
OC-3* | STS-3 | STM-1 | 155.52 Mbps | 3 | 2,016
OC-4 | STS-4 | STM-3 | 207.36 Mbps | 4 | 2,688
OC-9 | STS-9 | STM-3 | 466.56 Mbps | 9 | 6,048
OC-12 | STS-12 | STM-4 | 622.08 Mbps | 12 | 8,064
OC-18 | STS-18 | STM-6 | 933.12 Mbps | 18 | 12,096
OC-24 | STS-24 | STM-8 | 1.24416 Gbps | 24 | 16,128
OC-36 | STS-36 | STM-12 | 1.86624 Gbps | 36 | 24,192
OC-48 | STS-48 | STM-16 | 2.48832 Gbps | 48 | 32,256
OC-96 | STS-96 | STM-32 | 4.976 Gbps | 96 | 64,512
OC-256** | STS-256 |  | 13.2192 Gbps | 256 | 171,360
Note: ANSI also has specified OC-192, which operates at a line rate of 9.953278 Gbps, providing the equivalent of 5,376 DS1s and 192 DS3s. The ITU-T has not formalized that standard on an international basis.
*OC-3 was defined by the CCITT as the basic transport rate for B-ISDN [10-17].
**OC-256 is the theoretical maximum transmission rate of SONET; it has not been defined fully.

At OC-1, for instance, a T-1 bit stream of 45 Mbps is presented as a STS-1 signal of 51.84 Mbps, with an actual maximum payload rate of 49.54 Mbps [10-18]. When converted from an electrical signal to a fiber optic photonic signal, the bit stream is known as OC-1. The OC-1 comprises 810-byte frames transmitted at a rate of 8,000 frames per second. SONET speeds range from OC-1 (51.84 Mbps) to OC-96 (4.976 Gbps), as currently defined in full. The maximum theoretical speed is that of OC-255 (13.2192 Gbps). Fractional speeds are achievable at virtually any level, with subrate transmissions below OC-1 being multiplexed to form an OC-1 channel.

SONET terms of significance include the following:

• Optical Carrier (OC) is the definition of the SONET optical signal. The defined OC levels begin at OC-1 (51.84 Mbps) and culminate in OC-255 (13.2192 Gbps).
• Synchronous Transport Signal (STS) is the electrical equivalent of the SONET optical signal; it is known as Synchronous Transport Module (STM) in SDH. The signal begins as electrical and is converted to optical for transmission over the SONET fiber facilities. Each STS-1 frame is transmitted each 125µs, yielding raw bandwidth of 51.84 Mbps. The STS frame includes five elements, Synchronous Payload Envelope, Section Overhead, Line Overhead Path Overhead, and Payload.
• Synchronous Payload Envelope (SPE) is the envelope that carries the user payload data. It is analogous to the payload envelope of a X.25 packet. The SPE consists of 783 octets (87 columns and 9 rows of data octets).
• Transport Overhead (TOH) consists of Section Overhead and Line Overhead.
• Section Overhead (SOH) of 9 octets is dedicated to the transport of status, messages, and alarm indications for the maintenance of SONET links.
• Line Overhead (LOH) of eighteen (18) bytes controls the reliable transport of payload data between network elements.
• Path Overhead (POH), contained within the SPE, comprises 9 octets for the relay of OAMandP information in support of end-to-end network management.
• Payload is the actual data content of the SONET frame and rides within the SPE. Total usable payload at the OC-1 level consists of up to 49.54 Mbps, into which a T3 frame fits quite nicely. The balance of the 51.84 Mbps is consumed by Transport Overhead and Path Overhead.
• Multiplexing is on the basis of direct time division multiplexing. Either full SONET speeds or lesser asynchronous and synchronous data streams can be multiplexed into the STS-N payload, which is then converted into an OC-N payload. In other words, an appropriate combination of FDS-1, DS-1, DS-2 and DS-3 signals can be directly multiplexed into an electrical STS-1 payload, which is then converted into an optical OC-1 payload. The multiplexing process involves byte-interleaving, much as described for traditional TDMs.

SONET/SDH Topology

SONET networks are highly redundant, with dual fibers providing backup. Although they can be laid out in a linear, star, ring or hybrid fashion, the optimum topology is a dual, counter-rotating ring. In a SONET ring, one fiber transmits in one direction, with the other transmitting in the other direction. Through this layout, it is highly unlikely that any device on the network can be isolated through a catastrophic failure, such as a cable-seeking backhoe. There are two primary implementations of the SONET physical topology, path-switched, and line-switched rings.

Path-Switched Rings

These employ two fibers. As illustrated in Figure 10.3, all traffic moves in both directions, thereby providing protection from network failure. A path-switched approach also improves error performance, as the receiving stations examine both data streams, selecting the better signal.

Figure 10.3 Path-switched SONET implementation.


Communications Systems and Networks:Broadband Network Infrastructure

Line-Switched Rings

These involve either two or four fibers. In the single ring implementation, traffic moves in one direction, with the other fiber acting as backup. In the event of a network failure, the backup ring is activated to allow transmission in the reverse direction. A 4-fiber implementation supports transmission in one direction over 1 fiber in each of the 2 rings. By way of example, Fibers #1 in Rings #1 and #2 might transmit in a clockwise direction, while Fibers #2 in Rings #1 and #2 would transmit counterclockwise. The second fiber in each ring acts to support transmission in the reverse direction in the event of a failure in the primary ring. Line-switched rings smaller that 1200 kilometers offer standard restoral intervals of 50 milliseconds or less [10-19].

Paths, Tributaries and Channels

The SONET pipe can carry information at Gbps speeds, with excellent performance characteristics, including error performance and network management. The pipe can also carry any variety of asynchronous and synchronous information (voice, data, video, and image) and presented in a number of frame sizes—concatenation is a clear advantage. The pipe consists of Virtual Paths, Tributaries, and Channels, as reflected in Figure 10.4.

Figure 10.4 Relationship of Path, Virtual Path and Virtual Channel.

Virtual Paths, or Virtual Containers
are simply end-to-end communications paths, or routes or circuits, that carry traffic from one end point to another. The path is not fixed or dedicated, neither is it dedicated to a particular conversation or user. A virtual path consists of many virtual tributaries.
Virtual Tributaries
carry one form of signal, such as a DS-1, DS-2 or DS-3 signal within a byte-interleaved frame. Virtual tributaries can be mapped into a single virtual path. A virtual tributary may be channelized (e.g., a 48-channel T-1 for voice) or unchannelized (e.g, a clear channel DS-1 for full motion video). Virtual tributaries are sized to accommodate the originating signal and in consideration of the legacy digital hierarchy. For instance, VT1.5 operates at 1.544 Mbps (T1), VT2 at 2.048 Mbps (E1), VT3 at 3.152 Mps (T1c), VT6 at 6.312 Mbps (T2). Individual VTs are distinguished by the use of a pointer, which identifies the position of the VT within the STS frame; the pointer also provides synchronization in a SONET environment.
Virtual Channels, or Tributary Units
exist within virtual tributaries. For example, a virtual tributary might carry a T1 frame. Within that tributary, there might exist 24 channels with each channel carrying a single voice or data communication in multiple time slots.

Sonet Frame Format

The STS-1 frame (Figure 10.5) is the basic building block for SONET, much as is the DS1 frame in a T/E-carrier environment. The STS-1 frame can be considered logically as a matrix of 9 rows of 90 octets, yielding 810 octets in total. The data are transmitted from top to bottom, one row at a time and from left to right. SONET accommodates payloads (data content) in increments of 765 octets, logically organized in matrixes of 9 rows × 85 columns. The payload is contained within a Synchronous Payload Envelope in increments of 774 bytes (9 rows × 86 columns), with the additional column attributable to Path Overhead (POH). Where superrate services require more than a single STS-1, they are mapped into a higher level, concatenated STS-N, with the constituent STS-1s being kept together [10-20]. For example, a 135 Mbps B-ISDN H4 frame requires huge amount of contiguous, unbroken bandwidth. SONET accommodates this requirement by linking 3 STS-1s into an STS-3c, with the c indicating concatenation [10-21].

Figure 10.5 SONET frame structure.

The SPE, which contains the payload data, actually floats within the SONET frame. While SONET is a synchronized network, with all devices relying on a common clocking signal, variations in clocking can occur. These clocking variations can be the result of different master clocks in different national networks, thermal expansion and contraction in individual fiber optic cables, and other phenomena. Rather than buffering individual frames to effect synchronization, floating mode operation allows the network to adjust to frame float with the SPE being identified by the pointer. The floating mode reduces cost and delay which would be caused by the use of buffers to exactly synchronize each frame and SPE [10-21].

The SONET overhead structure mirrors that of the existing digital carrier network for purposes of non-intrusive, end-to-end network management. Overhead layers include Path Overhead, which is further divided into Section Overhead and Line Overhead, and Path Overhead.

Section Overhead (SOH)

SOH of nine (9) bytes provides for management of optical network segments between Section Terminating Equipment (STE) in the form of repeaters. The repeaters can be standalone or can be built into switches, such as Digital Cross Connect Systems. At the Section Layer, every repeater in the network performs the section overhead functions which include framing, span performance, and error monitoring, and STS ID numbering. These functions are similar to those performed by traditional point-to-point protocols such as SDLC and LAP-D. The 9 bytes of Section Overhead include 1 byte STS-1 signal ID, 2 bytes Bit Interleaved Parity (BIP) for error monitoring, 1 byte Orderwire (connection request), and 3 bytes DCC (Data Communication Channel).

Line Overhead (LOH)

LOH of eighteen (18) bytes controls the reliable transport of payload data between network elements. A DXC (Digital Cross-Connect System) would perform Line Layer functions, including error control, switching and multiplexing, order-wire, express orderwire (priority connection request), automatic protection switching to back-up circuits, insertion of payload pointers, and synchronization control. The 18 bytes of Line Overhead comprise 3 bytes STS-1 pointer, 1 byte BIP (error monitoring), 2 bytes automatic protection switching, 9 bytes DCC, 1 byte orderwire, and 2 bytes reserved for future use.

Path Overhead (POH)

POH, not to be confused with Pooh (the bear), of nine (9) bytes comprises all aspects of end-to-end performance monitoring and statistical reporting. Path management is an essential responsibility of the Add/Drop Multiplexers (ADMs). Functions performed at the Path Layer include end-to-end performance monitoring, statistical reporting, STS Mapping, and DS-to-OC mapping. The 9 bytes of Path Overhead comprise 1 byte trace, 1 byte BIP, 1 byte Payload ID, 1 byte maintenance status, 1 byte user ID, 1 byte frame alignment, and 3 bytes reserved for future use.


Communications Systems and Networks:Broadband Network Infrastructure

SONET/SDH Hardware

The hardware aspects of SONET are difficult to describe in discrete terms, as many of the functional elements overlap. Just as manufacturers of traditional voice and data equipment often build multiple functional elements under the skin of a single box, so do SONET/SDH equipment manufacturers. Given that caveat, the following is a description of discrete functional aspects of hardware devices.

Terminating Multiplexers
are Path Terminating Equipment (PTE) that provide user access to the SONET network (Figure 10.6), operating in a manner similar to a T3/E3 Time Division Multiplexer. Multiple DS-0’s and DS-1’s can be multiplexed to form an STS-1 or STS-3 frame, for instance. Terminal multiplexers also accomplish the conversion from electrical STS-N signals into Optical Carrier (OC-N) signals.

Figure 10.6 Terminal Multiplexer (TM) and Add/Drop Multiplexer (ADM) in SONET application.

Concentrators
perform the equivalent functions as traditional electrical concentrators and hubs. SONET concentrators combine multiple OC-3 and OC-12 interfaces into higher OC-N levels of transmission [10-15].
Add/Drop Multiplexers (ADMs)
do not have a exact equivalents in the electrical (DS) world, although they perform roughly the same functions as do traditional T-carrier TDMs. Generally found in the Central Office Exchange, they provide the capability to insert or drop individual DS1, DS2, or DS3 channels into a SONET transmission pipe (Figure 10.6). ADMs accomplish the process electrically, with the OC-N channel being converted prior to the process and being reconverted subsequently.
ADMs offer great advantage over traditional DS-N MUXs. The T-carrier approach, for instance, requires that a DS3 frame be de-multiplexed into its 28 component DS1 frames, which must be broken down into 24 DS0 channels in order to extract and route an individual channel. Once that has been accomplished, the process must be reversed in order to reconstitute the DS3, minus the extracted DS0, and send it on its way. ADMs perform the additional functions of dynamic bandwidth allocation, providing operation and protection channels, optical hubbing, and ring protection.
Digital Loop Carrier (DLC)
systems typically are located at the Local Exchange Carrier (LEC) office and are used to concentrate traffic in multiple DS0s into a single DS3 signal. Having performed this intermediate step, they hand off the STS-1 signal to a Terminating MUX which performs the OC-N conversion.
Digital-Cross Connects (DXCs)
perform approximately the same functions as their electrical equivalents (DACs/DCCSs), providing switching and circuit grooming down to the DS1 level. They provide a means of cross-connecting SONET/SDH channels through a software-driven, electronic common control cross-connect panel with a PC user interface. The routing of traffic through a DXC is accomplished through the use of payload pointers, which point to the payload in the OC-N frame and provide synchronization. Importantly, DXCs also serve to connect the fiber rings. DXCs perform the additional functions of monitoring and testing, network provisioning, maintenance and network restoral.
Regenerators
perform the same function as their traditional electrical equivalents. Often found under the skin of other SONET equipment, they are optoelectric devices which adjust the amplitude, timing, and shape of the signal.

Advantages of SONET

SONET offers a number of advantages in addition to the inherent advantages of fiber optic transmission systems. Certainly, the fact that SONET is highly standardized offers the benefits of interconnectivity and interoperability between equipment of different manufacturers. That translates into freedom of vendor choice and yields lower costs through competition. Additionally, SONET/SDH is extendible to the premise on a fully interoperable basis. While such extension currently is unusual for SONET, such deployment provides end-to-end advantages of enhanced bandwidth, error performance, dynamic bandwidth allocation, and network management. In an end-to-end deployment scenario, SONET is particularly attractive in support of broadband services such as SMDS, Frame Relay, ATM and, ultimately, B-ISDN.

In bandwidth-intensive applications, the high absolute cost of SONET can be offset by virtue of its extraordinarily high capacity. Whether deployed in a carrier network or extended to the user premise, SONET supports the aggregation of all forms of traffic, including voice, data, video, image, and facsimile. As a result, a SONET infrastructure can obviate the need for multiple transmission facilities in support of individual services. The simplicity of multiplexing and de-multiplexing via ADMs reduces costs, delay, and error. Clearly, SONET/SDH offers the considerable advantage of network resiliency through its inherent redundancy and self-healing capabilities.

Finally, SONET offers tremendous security, as is the case with fiber optic transmission systems. Fiber is difficult, if not impossible, to physically tap without detection. It is difficult to identify the one channel for detection out of the thousands of information channels supported in a SONET mode. As Francis Bacon said in 1625, “There is no secrecy comparable to celerity” (of Delay, Essays)—speed is a hallmark of SONET.

Applications of SONET/SDH

SONET primarily is deployed in backbone carrier networks where its many advantages can be put to full use. Particularly in a convergence scenario, the carriers have the potential to realize considerable cost savings by using a single fiber infrastructure in support of bandwidth-intensive video and image streams, in addition to voice, data, and facsimile traffic. That scenario ultimately will deliver SONET fiber to the premise—perhaps even to residences.


Communications Systems and Networks:Broadband Network Infrastructure

AT&T, for instance, is in the process of upgrading its network to deploy SONET rings in Sacramento, San Francisco, Atlanta, Washington, and Baltimore at a cost of about $2.7 billion [10-23]. Sprint in 1994 announced the completion of the Silicon Valley Test Track, linking seven companies and several learning institutions to test ATM switching technologies. The initial OC-1 ring was planned to be upgraded to OC-3 in early 1995 and to OC-12 later in the year [10-24]. More recently, Sprint deployed the first international SONET ring, linking four cities in New York and three in Canada. The capacity of that OC-48 SONET ring will be increased to 10 Gbps through the use of Wave Division Multiplexing (WDM) equipment in order to derive four OC-48 channels [10-25]. MCI recently announced a similar nonstandard SONET deployment to provides 10 Gbps between Washington, DC and Richmond, VA. The SONET ring will be used in support of MCI’s e-mail messaging service [10-26]. Finally, AT&T announced in May 1996 plans to beef up its network with WDM equipment to realize 20 Gbps over OC-48 SONET fiber—an eight-fold increase [10-27].

SONET also finds application in campus environments, including not only institutions of higher learning, but also business campuses. In such an environment, significant volumes of data and image information often are transmitted between buildings (e.g., mainframe-to-mainframe). In the future, internetworking of Gbps LANs will be required—in such applications, fiber makes sense and SONET makes even more sense. Mission-critical environments, such as airports, find the redundancy and resulting resiliency of a SONET infrastructure to be particularly attractive.

As interesting and recent application of SONET technology is that of the 1996 Summer Olympics in Atlanta. BellSouth, the incumbent LEC, deployed 40 OC-48 SONET rings to transport CD-quality voice, broadcast-quality video, and data simultaneously to nine cities in the Greater Atlanta area where the 26 various competitions took place. All information flowed through the SONET pipes, including competition results, accreditation, data, voice, and video. The uncompressed digital video signals traveled to the International Broadcast Center, where the signals were sold to other broadcasters and produced 40 worldwide video satellite feeds for 3,000 hours of Olympic coverage [10-28].

Independent end users can gain access to SONET transmissions that are offered by a number of the LECs (Ameritech, BellSouth, Pacific Bell and US West), IXCs (AT&T, LDDS Worldcom, and Sprint) and CAPs (MFS and TCG). The costs, however, can be high; coast-to-coast SONET circuits at 155 Mbps (OC-3) are quoted at almost $425,000 per month [10-29].

References

[10-1] Paone, Joe. “ADSL: The New Kid on the Block.” Internetwork. June 1996.
[10-2] Thyfault, Mary E. “High Bandwidth at Low Price.” Information Week. April 8, 1996.
[10-3] Greene, Tim. “ADSL Prepped for Prime Time.” Network World. April 22, 1996.
[10-4] Greene, Tim. “It’s Far from Quiet on ADSL Front.” Network World. June 24, 1996.
[10-5] Girishankar, Saroja. “Southwestern Bell Initiates ADSL.” Communications Week. May 27,1996.
[10-6] Caruso. Jeff. “First ’Net ADSL Trial Announced.” Communications Week. June 24, 1996.
[10-7] Schroeder, Erica. “ADSL is Gathering TelcoAdherents.” PC Week. March 25, 1996.
[10-8] Dagres, Todd. “The Copper Rush: Standards Compete.” Communications Week. June 10, 1996.
[10-9] Caruso. Jeff. “Awash in New X-DSL Options.” Communications Week. May 27, 1996.
[10-10] Valovic, Tom. “Video on Demand: Is It Still Viable?” Telecommunications. October 1995.
[10-11] Greene, Tim. “SDSL Promises T-1 Bandwidth over Standard Telephone Lines.” Network World. October 2, 1995.
[10-12] Stuck, Bart. “The Local Loop Adapts for New Roles.” Business Communications Review. October 1995.
[10-13] CopperOtics Enhancing the Performance and Application of Copper Cable with HDSL. Cerritos, CA: PairGain Technologies. 1995.
[10-14] World Transmission Equipment Markets. Northern Business Information. February 21, 1996.
[10-15] Spohn, Darren L. Data Network Design. NY: McGraw-Hill, Inc. 1993.
[10-16] Davidson, Robert P., and Muller, Nathan J. The Guide to SONET: Planning, Installing and Maintaining Broadband Networks. NY: Telecom Library. 1991.
[10-17] Sexton, Mike, and Reid, Andy. Transmission Networking: SONET and the Synchronous Digital Hierarchy. Norwood, MA: Artech House. 1992.
[10-18] Miller, Mark A. Analyzing Broadband Networks: Frame Relay, SMDS, and ATM. NY: M&T Books. 1994.
[10-19] Hines, I.J. ATM: The Key to High-Speed Broadband Networking. NY: M&T Books. 1996.
[10-20] Minoli, Daniel. Enterprise Networking: Fractional T1 to SONET, Frame Relay to BISDN. Norwood, MA: Artech House. 1993.
[10-21] Kingsley, Scott M. “The Sonet Hierarchy.” Datapro Communications Analyst. Datapro Information Services Group. 1996.
[10-22] Flanagan, William A. Frames, Packets and Cells in Broadband Networking. NY: Telecom Library. 1991.
[10-23] “An Upgrade In Store for AT&T.” Information Week. June 19, 1995.
[10-24] “Sprint’s SONET Ring Links Silicon Valley.” New Media. December 1994.
[10-25] Rendleman, John. “Sprint Readies International Fiber Ring.” Communications Week. June 10, 1996.
[10-26] Schroeder, Erica. “MCI Speeds up Bandwidth, Rings up Messaging Service.” PC Week. May 13, 1996.
[10-27] Schroeder, Erica. “AT&T’s Fiber Network to Get Eightfold Boost.” PC Week. May 13, 1996
[10-28] Dziatkiewicz, Mark. “Network of the Olympians.” Convergence. March 1996.
[10-29] Gareiss, Robin. and Heywood, Peter. “Tomorrow’s Networks Today.” Data Communications. September 21, 1995.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

Chapter 11
Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

To be great is to be misunderstood.

—Ralph Waldo Emerson, Self Reliance, 1841

Broadband networks offer great potential. As emerging technologies, they also are greatly misunderstood, for which fact we authors, consultants, and lecturers are eternally grateful. (Hopefully, we foster understanding, rather than confusion.)

The concept of broadband networking has its roots in the early 1970s when the CCITT first defined Broadband ISDN. Anticipating the development of highly bandwidth-intensive applications, and the demand for them, B-ISDN was defined on a very preliminary basis—the result of these continuing efforts remain many years distant. In the meantime, however, a number of developments have taken place. First, the demand for computer internetworking grew at levels which astounded even the most astute computer and data network pundits. Second, imaging systems developed and increasingly required networking. Third, the potential for videoconferencing applications became apparent. Fourth, the development and commercialization of the Internet and World Wide Web truly has been mind-boggling. Finally, entertainment networking now has captured the attention of telephone companies and others as they seek to compete to develop networks that will carry TV content, as well as voice, data, video, image, facsimile, and all other forms of data over a single network.

Chapter 10 addressed broadband infrastructure technologies. This chapter will address the service offerings which frame the applications. The focus here is on three network service offerings: Frame Relay, Synchronous Multimegabit Data Service (SMDS), and Asynchronous Transfer Mode (ATM). Together, they fall under the umbrella term Fast Packet Services (Figure 11.1). Fast refers to the fact that they rely on a broadband transmission infrastructure (> 45 Mbps) in the form of SONET/SD, and on very fast and capable switching systems, as well. Packet is a generic term referring to the manner in which data is segmented—into packets, frames, blocks, cells, etc.—that are handled separately, yet generally linked in some way, through the network. Services is the operative word here. No matter how elegant the underlying technologies, their ultimate value is in enabling the creation and delivery of services of value. At the bottom of Figure 11.1 are noted the access standards defined by the ITU-T.

Figure 11.1 Fast packet networking. Courtesy of Frame Relay Forum

This chapter will conclude with a brief exploration of Advanced Intelligent Networks (AINs) and B-ISDN. AINs reflect the marriage of computer, database, and network technologies, offering tremendous potential in the creation and delivery of services. B-ISDN is the ultimate network service delivery concept.

“Do not despise the bottom rungs in the ascent to greatness,” wrote Pulilius Syrus (Moral Sayings) in the 1st Century, B.C. So it is with fast packet networking, which has its roots in X.25 (slow) packet networking, which has its roots in the AlohaNET packet radio network. (It seems as though good ideas have long and even multiple lives.) Without belaboring that point, we will explore the comparisons between X.25 and Frame Relay.

Frame Relay

Frame Relay has experienced unprecedented growth since its commercial introduction by Wiltel (since acquired by LDDS Worldcom) in 1992. AT&T, the largest U.S. domestic provider with about 35% of the market, enjoyed a 600% increase in Frame Relay service in 1995, following a 500% increase in 1994. The 1995 worldwide market for Frame Relay equipment and services is forecast at a total of $2.19 billion, up from the 1994 market of $1.71 billion, an increase of 28%. The carrier service revenues for Frame Relay were estimated by Infonetics Research to be approximately $700 million in 1995 and forecast to be $2.3 billion in 1997. The worldwide frame relay customer count grew from approximately 5,000 in January 1995 to about 15,000 by January 1996 [11-1].


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

Frame Relay Defined

Frame Relay is a network interface, or access, standard which was defined in 1988 by the ITU-T in its I.122 recommendation, “Framework for Providing Additional Packet Mode Bearer Services.” Access to a Frame Relay network is accomplished using the LAP-D (Link Access Protocol-D channel) signaling protocol developed for ISDN, as it originally was intended as an ISDN framing convention for a bearer service. Frame Relay standards say nothing about the manner in which the internal network operates. As is the case with X.25 packet networks, such issues are left to manufacturers that develop proprietary switching technologies [11-2]. Access rates generally range up to T1, although speeds of T3 and above are possible [11-3]. Notably, Frame Relay is backward-compatible, as it considers the characteristics of the embedded networks and the standards on which they are based. Electrical interfaces are not rigidly defined for Frame Relay.

Very much analogous to a streamlined and supercharged form of X.25 packet switching, Frame Relay sets up and tears down a call with control packets, as does X.25. Frame Relay also forwards packets of data, in the form of frames. Similar to X.25, Frame Relay effectively multiplexes frames of data over a shared network of virtual circuits for maximum network efficiency. The interface is in a FRAD (Frame Relay Access Device) which can be implemented on the customer premise, much as is the case with a X.25 PAD (Packet Assembler/Disassembler). As is the case with X.25, Frame Relay is intended for bursty data traffic. While both can support carry voice, video and audio, the presentation can be less than pleasing due to packet delay and loss.

At that point, the two technologies diverge (see Table 11.1 for a comparison between X.25 and Frame Relay). Frame Relay is a connection-oriented service that assumes a high-speed user link, as well as a high-speed transport system that is generally fiber optic in nature. Frame Relay assumes no responsibility for error detection and correction in the user information field as there are assumed to be no errors in transmission; rather, error control is the responsibility of the end user. In other words, Frame Relay operates at Layers 1 and 2 of the OSI Reference Model. This ceding of responsibility to the end user reduces the processing load on the network, reducing latency (delay) significantly and yielding faster transmission of each frame of data. Frame Relay does check for errors in the control field, which is used for routing and other network purposes; errors in this field cause frames to be discarded. Frame Relay is protocol-independent and provides no protocol conversion services.

Table 11.1 X.25/Frame Relay Comparison
ATTRIBUTE | X.25 | FRAME RELAY
FACILITIES | Analog Assumed | Digital Assumed
PAYLOAD | 128B/256B Fixed | < 4,096B Variable
ACCESS SPEED | < 56 Kbps-DS1 | < 56 Kbps-DS1, DS3
LINK LAYER PROTOCOL | LAP-B | LAP-D/LAP-F
LATENCY | High | Moderate
ORIENTATION | Connection-Oriented | Connection-Oriented
ERROR CONTROL | Network | User
PROTOCOL CONVERSION | Yes | No
PRIMARY APPLICATION | Interactive Data | LAN-to-LAN

Frame Relay Standards

Frame Relay is supported by a wide range of manufacturers and carriers, both domestic and international. Standards bodies include ANSI, ETSI and the ITU-T. The Frame Relay Forum, a voluntary group of manufacturers and other interested parties, develops and promotes Implementation Agreements (IAs), to address manufacturer interoperability issues based on the standards. Select applicable standards are noted in Table 11.2.

Table 11.2 Frame Relay Standards
SUBJECT AREA | ITU-T | ANSI
Architecture and Service Description | I.233 | T1.606
Data Link Layer Core Aspects | Q.922 Annex A | T1.618
PVC Management | Q.933 Annex A | T1.617 Annex D
Congestion Management | I.370 | T1.606a
SVC Signaling | Q.933 | T1.617
Source: DigiNet Corp.

Frame Relay Access

Frame Relay access is provided on the basis of a dedicated digital link into a Frame Relay node. The typical speed of the access link can range up to 44.736 Mbps and can be in the form of DDS (56/64 Kbps), Switched 56/64 Kbps, ISDN BRI (64/128 Kbps) or PRI (1.544 Mbps), FT1 (N x 64 Kbps), T1 (1.544 Mbps) and T3 (44.736). In March 1996, LDDS Worldcom (MS) [11-4], and MCI (DC) announced Frame Relay service at speeds of 6 Mbps, 10 Mbps and 19.8 Mbps. No information is available relative to the success of these offerings, and no other carriers have followed suit at the time of this writing.

Customer DCE is the form of a FRAD (Frame Relay Assembler/Disassembler), which may be standalone, although it generally is embedded under the skin of another device such as a router. From the FRAD, access is gained to the link and, subsequently, to the Frame Relay network node. As the node resides in the FRND (Frame Relay Network Device). The UNI (User Network Interface), as defined by ANSI and ITU-T, defines the nature of this access interface.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

Frame Relay Network

The Frame Relay network (Figure 11.2) consists of specified network interfaces in the form of the User Network Interface (UNI) and Network-to-Network Interface (NNI). The specifics of the internal carrier network are based on ISDN, making use of Permanent Virtual Circuits (PVCs). While Switched Virtual Circuits (SVCs) are not yet implemented; many of the major carriers intend to make them available by mid-1997. Among the first to implement SVCs will be Ameritech, MCI, and CompuServe [11-5]. Frame Relay networks can be public, private, or hybrid.

Figure 11.2 Frame Relay network.

User Network Interface (UNI)
is the demarcation point between the user DTE and the network, and is in the form of a FRAD (Frame Relay Access Device) and a FRND (Frame Relay Network Device).
Network-to-Network Interface (NNI)
is defined as the interface between frame relay networks and is based on multinetwork PVCs. While some early implementation work has begun in this regard, most network-to-network connections are provided over digital trunks or ATM, where it is available. This current method of internetwork connection has implications relative to Implicit Congestion Notification and Network Management.
ISDN
is the basis of the internal Frame Relay network although the user links generally are not ISDN, largely due to lack of availability. Additionally, the ISDN LAP-D protocol governs the user links, although they generally are not ISDN for reasons of availability and additional cost.
Permanent Virtual Circuits (PVCs)
define fixed paths through the network for each source-destination pair, based on programmed logic. Such definitions are fixed in network routing tables, with alternative routes defined and invoked in the event of a network failure. Regardless of network traffic, the PVC will always be used to serve a given source-destination pair. Frame Relay networks currently are based on PVCs.
Switched Virtual Circuits (SVCs)
are set up call by call, based on programmed network routing options. At the end of the conversation, the SVCs are torn down; the next SVC provided for the same source-destination pair could be quite different, depending on network availability. While the standards envision SVC networks, they are not yet available.
Mesh Networking
is easily accomplished with Frame Relay, and on a scalable basis. That is to say that the cost of Frame Relay implementation is relatively proportionate to the task at hand. As more sites are added to the network, more FRADs, access links and FRNDs are added; as the bandwidth requirement increases, the capacity of the link is increased. The costs grow relatively gracefully as the network is expanded to provide access to additional sites, and as bandwidth is increased on a site-by-site basis.
Network Processing
is not performed in Frame Relay, at least not to the extent we experienced in X.25 networks. A Frame Relay network assumes that the frame is error free. As the link is digital (ideally SONET) and based on ISDN, there is no compelling requirement to check for errors. Once the frame is identified as being valid and once the address is recognized, the frame is relayed to the next node and, ultimately, to the end user. Frame Relay also assumes that all frames are passed through the network successfully, and are received in the order transmitted. This is the equivalent of removing OSI Layer 3 functions from the X.25 model. Further, Frame Relay assumes no responsibility for protocol conversion.
The upshot of this avoidance of network processing is that the cost of the network is reduced; latency is reduced, as well. Rather than the carrier’s assuming such responsibilities, and the associated costs, they are shifted to the user domain. While this may appear to be burdensome, the capabilities of such DCE has increased tremendously over the past few years, while the cost of such capability has decreased.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

Frame Relay Equipment

Frame Relay, as a service offering, depends on certain hardware and firmware in order to accomplish the interface. That equipment includes the Frame Relay Assembler/Disassembler (FRAD), the Frame Relay Network Device (FRND), and the Frame Relay switch.

Frame Relay Assembler/Disassemblers (FRADs)
also known as Frame Relay Access Devices, are analogous to Packet Assembler/Disassemblers (PADs) in a X.25 packet-switched network. The FRAD essentially organizes the user data into a Protocol Data Unit (PDU) that can vary in size up to < 4,096B. The FRAD then encapsulates the PDU into a Frame Relay frame, placing the necessary control information around it. FRADs can be standalone units, serving multiple hardwired devices, or they can be in the form of a printed circuit board that fits into the expansion slot of a workstation. Additionally, FRADs can be incorporated into X.25 PADs, T-carrier MUXs, or even PBXs for dedicated networks. More likely, they are incorporated into a high-end bridge or router serving a LAN.
In early 1996, several vendors announced CO-based FRADs that offer the potential to eliminate the end user investment in such equipment. Although they are limited in functionality, intended to support conversion of SDLC traffic to frame format, they appear to offer advantages to users seeking to replace dedicated networks connecting large data centers [11-6] and [11-7].
Frame Relay Network Devices (FRNDs)
are the link terminating equipment in the Central Office.
Frame Relay Switches
are nodal processors capable of switching frames at very high speed. They contain buffers that, within limits, can absorb incoming frames until the switch can act on them, and buffers that can absorb outgoing frames until the link becomes available. The switches contain very high-speed switching matrixes and internal busses. They have sufficient intelligence, in the form of routing tables to read the control information embedded in the frames in order to route the frames correctly over the PVC, which has been identified previously in the call setup process. The nodal processors also have intelligence sufficient to check for errors in the frame, although error correction processes are performed at the end-user level. Since the switches perform no error correction or protocol conversion functions, they act on the frames very quickly, thereby minimizing latency. Frame Relay nodal processors can be managed from a centralized Network Operations Center, thereby enhancing the scalability of the network [11-8].
The Frame Relay switch also may contain a voice compressor module, where voice is communicated over Frame Relay. Memotec (CX 1000) and Micom (Netrunner) switches provide this capability, using the ACELP compression algorithm. While Frame Relay is not intended for voice, it can be accommodated with varying degrees of quality.

Frame Relay Protocol: Frame Structure

The Frame Relay Protocol involves the relaying of frames of user data across the network. In an appropriate LAN, MAN, or WAN data application, the preponderance of the frame is the user data; relatively little control information is included. As illustrated in Figure 11.3, the five data fields in the ANSI T1.618 frame format comprise beginning and ending flags, an address field, an information field, and a frame check sequence (FCS). Although the Frame Relay Protocol is a subset of the HDLC (High Level Data Link Control) protocol used in other data communications environments, it lacks control information such as frame sequence number. In the Frame Relay environment, it is the responsibility of the user to identify and correct for frame sequence errors or missing frames.

Figure 11.3 Frame Relay frame.

Flag Field
1 octet with fixed binary sequence 01111110 is employed to identify and separate frames. Flag fields appear at the beginning and end of the frame.
Address Field
2 octets are used as a default length. Address fields include most necessary control information in the Data Link Connection Identifier (DLCI). The address field also contains a Command/Response field, Address Field Extension, Forward and Backward Explicit Congestion Notification fields, and Discard Eligibility data.
Data Link Connection Identifier (DLCI)
10 bits that identify the data link and its service parameters to the network. The service parameters include frame size, Committed Information Rate (CIR), Committed Burst Size (Bc), Burst Excess Size (Be), and Committed Rate Measurement Interval (Tc). The significance of these service parameters will be discussed later in this chapter
Command/Response (C/R)
1 bit is reserved for use of FRADs, rather than the Frame Relay network. Defined to facilitate the transport of polled protocols such as SNA, such protocols require a command/response for signaling and control.
Address Field Extension (EA)
2 bits signal the extension of the addressing structure beyond the 2 octet default. The use of EA, which is unusual, must be negotiated with the carrier at the time the service is established. As the popularity of Frame Relay grows and as large public and private Frame Relay networks develop, provisions are in place to expand the EA field to as many as 60 bits.
Forward Explicit Congestion Notification (FECN)
A 1-bit field available to the network is used to advise upstream devices of congestion. The receiving device clearly recognizes that the frame carrying the FECN survived. It also is advised that subsequent frames may not be so fortunate. Should subsequent frames be discarded or corrupted in transmission, the receiving device is advised that recovery may be required in the form of requests for retransmission. Should the upstream device be in control of the rate of data transfer, it has the opportunity to throttle back.
Backward Explicit Congestion Notification (BECN)
A 1-bit field is used by the network to advise devices of congestion in the direction opposite to the traffic flow. If the user device is capable of reducing the frame rate, it is well advised to do so, as frames may be discarded by the network once the notification is posted.
Discard Eligibility (DE)
This is a 1-bit field is indicating the eligibility of the frame for discard under conditions of network congestion. Theoretically, the DE is set by the user equipment.
Information Field
Contains user information, either in the form of payload data or internetwork control information passed between devices such as routers. Although the Information Field may be < 4,096B in length, ANSI recommendations are that the maximum size be 1,600B, consistent with most LAN traffic.
Frame Check Sequence (FCS)
A 2-octet CRC supporting frames with information fields < 4,096B in length).


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

Local Management Interface (LMI) Protocol

The LMI protocol provides operational support for the User Network Interface (UNI). Originally defined by the Frame Relay Forum in 1990, it since has been adopted by ANSI and the ITU-T. The LMI is a polling protocol between the FRAD and the network that verifies the existence and availability of the PVC, as well as the integrity of the UNI link.

Congestion Management

As a shared network designed for intensive data communications, Frame Relay is subject to congestion. Indeed, it is designed for congestion as a natural occurrence which serves to reduce the overall cost of the network. Congestion management is addressed through the following parameters, specified in an addendum to ANSI T1.606 [11-3], [11-8], and [11-9]:

• Access Rate The maximum data rate (bandwidth) of the access channel. Data can also be transmitted or received over the access link at lesser rates.
• Committed Information Rate (CIR) The data rate which the network guarantees to handle under normal conditions, based on mutual agreement between the carrier and the customer. In the event that the CIR is exceeded, the network reserves the option to mark excess frames as discard eligible. The discard function takes place at the entry node, in order to obviate any issues of unnecessary congestion in the network.
• Offered Load The data rate offered to the network for delivery measured in bps.
• Committed Burst Size (Bc) Maximum amount of data that the carrier agrees to handle under normal conditions.
• Excess Burst Size (Be) Maximum amount of data that the network will attempt to deliver over a specified time (T), as required by the user. In recognition of the bursty nature of LAN-to-LAN communications, the transmitting device may burst above the CIR for a brief period of time, with the network attempting to accommodate such bursts within limits of burst size and burst interval. The network reserves the option to mark the excess data discard eligible.
• Measurement Interval (T) The time interval measuring burst rates above the CIR and the length of such bursts.
• Discard Eligibility (DE) Indicates the eligibility of the frame for discard, in the event of congestion. DE may be set by either the FRAD or the FRND. Theoretically, at least, the FRAD would be programmed to recognize when the CIR is exceeded and to volunteer frames for discard should the network suffer unreasonable levels of congestion.
• Explicit Congestion Notification (ECN) The means by which the network advises devices of network congestion. Forward Explicit Congestion Notification (FECN) advises the target device of network congestion in order that it might adjust its expectations. Backward Explicit Congestion Notification (BECN) advises the transmitting device of network congestion in order that it might reduce its rate of transmission accordingly. Theoretically, it is the responsibility of the end devices to adjust. However, the effective assumption of such responsibility is unusual. For example, the Frame Relay network might send a BECN to advise a router of congestion in the network. While the router can impose a certain amount of flow control, its buffer memory is limited. Ultimately, it is the transmitting DTE that must adjust its rate of flow, which is unlikely.
• Implicit Congestion Notification Inference by user equipment that congestion has occurred. Such inference is triggered by realization of the user device (e.g., FRAD, Mainframe, or Server) that one or more frames have been lost. Based on control mechanisms at the upper protocol layers of the end devices, the frames would be resent.

Frame Relay Costs

The costs of Frame Relay vary widely among equipment manufacturers and carriers. It is clear, however, that Frame Relay is highly cost-effective for building mesh networks at > 56 Kbps. The equipment cost is that of the FRAD, which can be standalone, or can be built under the skin of a bridge or router. A DSU/CSU also is included in the device. In addition to the cost of the FRAD, the carriers’ charges typically include some combination of port charge (bandwidth-sensitive), access line (bandwidth- and distance-sensitive), Committed Information Rate (CIR) and burst size (Bc) (time-sensitive).

Frame Relay networks traditionally have been priced on a case-by-case basis. In consideration of the widespread popularity of the service, however, the FCC in October 1995 classified Frame Relay as a basic service. This reclassification required that the RBOCs, AT&T, MCI, and Sprint file tariffs. The publishing of Frame Relay rates allows smaller users to comparison-shop, simplifying the process and likely reducing their costs. Lager users, on the other hand lose some bargaining power. Significantly, the FCC has taken a position which will likely extend to other fast packet services in the future [11-11] and [11-12].

Prices have swung up and down since the FCC decision as competitors seek to develop their strategies. AT&T 512 Kbps PVCs are priced at $1,037; with 512 Kbps ports at $1,370 [11-13] and [11-14]. In the highly-competitive Frame Relay market, mesh networking that can be accomplished at costs which can be as little as 50% of the cost of a comparable FT-1 network [11-15]. Further, costs can be mitigated to some extent through the use of compression devices such as those offered by Telephone Company Systems, Inc. These devices allow transmission at a lower port speed and CIR through the recognition of patterns within data frames intended for as multicasting, or transmission to multiple addresses [11-16].

Frame Relay via VSATs is now offered by Orion Atlantic LP through its VISN (Virtual Integrated Sky Network) to sites in Europe and the eastern two-thirds of the U.S. Priced at $2,000 to $5,000 per month, VISN claims to be 35% to 40% less costly than it cabled counterparts [11-17].


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

Frame Relay Advantages and Disadvantages

Frame Relay’s unique characteristics offer some distinct advantages over X.25, Switched 56/64 Kbps, and DDS. Additionally, Frame Relay is widely available both domestically and internationally. The market is highly competitive, which puts it in an advantageous position relative to other fast packet technologies (i.e., SMDS and ATM.)

Frame Relay Advantages

Advantages include its excellent support for bandwidth-intensive data and image traffic. Even stream-oriented traffic such as realtime voice and video can be supported, although not particularly effectively. The absolute speed of Frame Relay, its improved congestion control, and reduced latency certainly are improvements over X.25 networks. As Frame Relay is protocol-insensitive, it can carry virtually any form of data, and in variable-size frames. Bandwidth-on-demand, within the limit of the access line, is provided, with costs being reasonable for high-speed bursts. Additionally, the network is highly redundant, providing improved network resiliency.

The elimination of dedicated circuits makes Frame Relay highly cost-effective when compared to dedicated services such as DDS and T-carrier. Frame Relay is reasonably priced. In fact, savings of 30% to 40% over leased lines are commonly reported. Frame Relay costs, also, are scalable, maintaining a graceful relationship with the needs of the user organization in terms of bandwidth and number of terminating locations. Mesh networking, therefore, can be accomplished at reasonable cost, even on an asymmetrical basis.

Disadvantages

Disadvantages include its latency. Although it is an improvment over X.25, it does not compare well with SMDS and ATM. The latency issue can be significant when the service is used in support of SNA traffic, and renders Frame Relay largely unsuitable for voice and video. Additionally, only a few IXCs (e.g., LDDS Worldcom and MCI) currently offer high-speed Frame Relay service. Finally, the carriers have not come to terms on interconnectivity, leaving the user typically bound to a single carrier [11-18] and [11-3].

Frame Relay Applications

Frame Relay was designed to fill the gap between packet-switched networks (X.25), circuit-switched networks (Switched 56/64 Kbps), and dedicated data networks (DDS, T/E-Carrier). It is intended for intensive data communications involving block-level communications of data and image information. Frame Relay will support voice and low-speed video, although the quality can be generally is poor due to intrinsic latency (delay) and discarded frames during periods of network congestion due to heavy usage.

Frame Relay applications primarily, therefore, are data or image in nature. LAN internetworking, of course, is the driving force behind Frame Relay, although, controller-to-host, terminal-to-host, and host-to-host applications abound. The recent availability of dialup access also makes the service cost-effective for bandwidth-intensive telecommuting application. Internet Service Providers (ISPs) recently have made significant use of Frame Relay, both for user access to the ISP and for backbone network applications. For instance, the CompuServe network is about 60% Frame Relay and 40% X.25 [11-19].

An excellent example of the application of Frame Relay is that of the airline reservation networks, all of which are in the process of transition. Apollo Travel Services is converting its reservation network to Frame Relay to connect approximately 15,000 travel agency workstations at 1,000 sites. Owned by United Airlines, USAir, and Air Canada, Apollo expects response time to improve to two seconds from the current four seconds. The network will run at 56 Kbps, as opposed to the current 2,400 to 4,800 bps. Using AT&T’s InterSpan Frame Relay Service, running over a TCP/IP network platform, the service also will offer mesh networking between travel agencies, without the need to go through the Apollo head-end for e-mail and other purposes [11-20].

Voice over Frame Relay, over both private and public networks, is an option that recently has created a lot of interest. Although the voice stream is subject to intrinsic Frame Relay delays and although the service is overhead-intensive for such an application, it does allow the user organization to take advantage of occasional excess bandwidth to connect voice for free. [11-21], [11-22], [11-23], [11-24], [11-25], [11-26], and [11-27]. Advanced compression techniques such as ACELP (Algebraic Code-Excited Linear Prediction) appear to offer the best quality voice at 16 Kbps, 8 Kbps, and even 4.8 Kbps [11-28].


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

Switched Multimegabit Data Service (SMDS)

Switched Multimegabit Data Service (SMDS) is an offshoot of the Distributed Queue Dual Bus (DQDB) technology defined by the IEEE 802.6 standard for Metropolitan Area Networks (MANs), as a means of extending the reach of the LAN across a metropolitan area. The original work on the DQDB concept was done at the University of Western Australia where it was known as Queued Packet Synchronous Exchange (QPSX). Subsequently, the original technology was licensed to QPSX Ltd., formed by the University of Western Australia and Telecom Australia [11-8]. The real commercial success is attributable to further development work by Bellcore, at the request of the RBOCs. The first commercial offering was by Bell Atlantic in 1992, based on a test implementation at Temple University at 45 Mbps [11-29].

Since that time SMDS has enjoyed particular success in the U.S. through deployment by most of the RBOCs and GTE. As the RBOCs and their subsidiary BOCs primarily are LECs (Local Exchange Carriers) limited to providing service within the confines of the LATA, they have exhibited particular interest in network technologies that are appropriate for providing service in confined geographic areas. This geographical limitation of SMDS, therefore, did not pose a practical limitation for the LECs. Additionally, SMDS is extendible across the WAN.

While the RBOCs have deployed SMDS fairly aggressively in the past, their ardor has cooled lately. As the Telecommunications Act of 1996 promises to release them from the artificial LATA constraints, they currently seem to be lusting after ATM, which is not geographically restrained and which is the network technology of the future. By way of example, US West pulled the plug on SMDS on April 1, 1996, citing its long-term interest in ATM and the relative popularity of its competing Transparent LAN Service. NYNEX, by the way, decided early on to skip over SMDS in favor of ATM [11-30]. While other RBOCs have remained loyal to SMDS, they are also likely to have similar plans. Ameritech, for instance, has only 80 SMDS customers in its five-state region. MCI Communications has approximately 130 SMDS customers, and plans to offer SMDS-to-ATM internetworking in late 1996 [11-31]. If the above sounds negative, it’s because SMDS by no means is the ultimate answer for all networking requirements. The ultimate solution appears to be ATM, upon which B-ISDN is founded. SMDS does have a future, although perhaps in a niche market.

SMDS also has enjoyed moderate success in Western Europe, where the nations tend to be small in geographic terms and where population is dense in the major metropolitan areas. The European version of SMDS is known as CBDS (Connectionless Broadband Data Service). CBDS is available in Australia (Telecom Australia), Germany (DBP), and England (BT)—numerous additional trials are underway.

SMDS Defined

According to Bellcore, SMDS is a high-speed, connectionless, public, packet switching service that will extend Local Area Network-like performance beyond the subscriber’s premises across a metropolitan or wide area. SMDS is a MAN network service based on cell-switching technology. Generally delivered over a SONET ring, SMDS has a maximum effective serving radius of approximately 30 miles (50 Km). SMDS is a connectionless service that accepts user data in the form of a Protocol Data Unit (PDU) up to 9,188 octets in length over access lines of < 45 Mbps (DS3); OC-3 (155 Mbps) access is planned, as are higher levels. The user data is segmented into 53-octet cells, 48 octets of which are payload and 5 octets of which are overhead. The segmentation process can occur either at the network node or in the user equipment.

SMDS is designed to support LAN-to-LAN traffic, under the IEEE 802.6 standards, although other data applications are supported effectively. SMDS offers excellent performance characteristics, including a guaranteed rate of access, transport and delivery. SMDS also provides a smooth migration path to ATM. In fact, the 53-octet cell format was chosen specifically for this reason.

SMDS Standards

The IEEE developed the original MAN standard 802.6. That standard was intended as a standard for the interconnection of DQDB subnetworks within metropolitan areas. The DQDB subnetworks can provide data concentration, routing, or switching functions; or can interconnect workstations, hosts and LANs over a metropolitan area [11-9]. According to the IEEE, the 802.6 DQDB standard is intended to provide “a high-speed shared medium access protocol for use of a dual, counter-flowing, unidirectional bus subnetwork.” Bellcore then modified that standard to develop SMDS, that is a carrier service based on the 802.6 concept and intent. The scope of the standard includes two layers, DQDB and Physical. Within the two layers are defined the functions of Medium Access Control (MAC), connection-oriented service and isochronous service.

Medium Access Control (MAC)
is defined in support of Logical Link Control (LLC) for purposes of establishing network compatibility at the link level with other networks, such as Ethernet, FDDI, and Token Ring. Connectionless service is supported at this level.
Connection-Oriented Service
is defined for asynchronous communications such as signaling functions. Signaling requires a guaranteed and consistent path through the network.
Isochronous Service
is defined for applications which are stream-oriented and particularly delay-sensitive. Realtime, digitized voice and video are common and realistic examples.

Bellcore has issued a number of standards in the form of Technical References (TRs). The TRs cover Generic System Requirements, Access Requirements, Networking Requirements, Operations Interfaces, Frame Relay Access to SMDS, and a host of other issues relative to access, network management, billing, and operations. Bellcore also issues Technical Advisories (TAs), which are preliminary documents, ultimately becoming TRs.

The SMDS Interest Group (SIG), formed in 1991, has released a number of technical implementation specifications that address specifics such as AppleTalk and DECnet over SMDS networks. The European SIG has developed a similar set of specifications. The SMDS Interest Groups are not standards bodies. Rather they are voluntary organizations of manufacturers, carriers, consultants, and other interested parties.

European Telecommunications Standards Institute (ETSI) has adopted most 802.6 standards elements, including many SMDS features, for the European market.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

SMDS Access

Access to a SMDS network is via a dedicated digital facility < 45 Mbps (T3) from the Subscriber Access Terminal (SAT) through a generic interface known as the Subscriber Network Interface (SNI). Access typically is on the basis of a dedicated T1 facility at 1.544 Mbps or T3 at 44.736 Mbps, although access also is provided at 56/64 Kbps. Plans are to develop a SONET OC-3 interface, as well, operating at 155.520 Mbps [11-30]. Where direct access to a SMDS network is not available, access can be accomplished via Frame Relay network-to-network interface.

Distributed Queue Dual Bus (DQDB)

DQDB is the IEEE 802.6 standard which Bellcore adapted for SMDS access purposes. DQDB is based on a dual-bus architecture as illustrated in Figure 11.4. Each bus is unidirectional, carrying data in 53-octet cells. As the two busses act in concert, full-duplex (FDX) transmission is possible. In order to access the SMDS network, a reservation is placed on the upstream bus. Because the reserved time slots are presented on the downstream bus, the access unit , or DQDB engine, places data on those allocated time slots, which appear at intervals. The intervals of presentation are regular for delay-sensitive isochronous data, such as voice. The access network is implemented in a star topology, with each loop connected to a SMDS cell switch.

Figure 11.4 Distributed Queue Dual Bus (DQDB).

Subscriber Network Interface (SNI)

SNI is generic access over a dedicated link which can be DS-0 (56/64 Kbps), DS1 (1.544/2.048 Mbps) or DS3 (45/34 Mbps). The access configuration on the customer premise can support single or multiple CPE devices.

SMDS Interface Protocol (SIP)

SIP is a three-layer network access protocol, based on 802.6 and operating on the generic Subscriber Network Interface (SNI). SIP layers, which do not conform exactly to the OSI model, include the following:

• SIP Level 1: Physical and Electrical Transport
• SIP Level 2: Framing and Error Detection
• SIP Level 3: Addressing and Error Detection

The SIP segmentation process is similar to that described in the case of DQDB. The user PDU is encapsulated with SMDS-specific header and trailer information and is subsequently segmented into 53-octet cells. Each cell comprises 5 octets of control information and 48 octets of payload. At the receiving end, the process of reassembly reverses the segmentation process.

Data Exchange Interface (DXI)

DXI is a protocol developed by the SMDS Interest Group, dividing the SIP functions between a DSU and a host, bridge, or router. In a DXI implementation, SIP Levels 1 and 2 are based on the ISO HDLC protocol and operate on the bridge or router and the host. SIP Level 3 operates only on the DSU and the network, across the generic SNI. This approach speeds the acceptance of SMDS, as SIP can be added to a bridge or router via a software upgrade [11-30].

SIP Relay

SIP Relay provides Frame Relay Access as defined by the SMDS Interest Group. Where SMDS is not available, this approach allows SMDS connectivity via Frame Relay. SIP Relay provides encapsulation for SMDS Level 3 PDU, its transmission across a Frame Relay network, connection to an SMDS network, and delivery to a SMDS address. The process of final segmentation occurs at the point of Frame Relay/SMDS network interconnection.

SMDS Network

As shown in Figure 11.5, and as discussed previously, customer DTE gains access to the SMDS network over a dedicated digital link that usually is in the form of a FT1, T1 or T3 circuit. The DTE can connect through a Subscriber Network Interface (SNI) that accommodates SIP Levels 1, 2, and 3 in collaboration with the network-based Switching System (SS). Alternatively, a DXI interface might support multiple DTE. The DXI interface splits SIP functionality between the host, bridge, or router and the DSU. Dual connections are made to the Distributed Queue Dual Bus (DQDB), consisting of an upstream and a downstream bus. The busses provide connection to a cell-based Switching System that resides in the LEC network. The various SSs are interconnected by Inter-Switching System Interfaces (ISSIs) in the form of high-capacity digital trunks. These trunks are intended to be SONET in nature, operating at OC-3 (155 Mbps) and above.

Figure 11.5 SMDS network. Source: TR-TSV-000772, Copyright © 1991, Bellcore. Reprinted with Permission.

The LEC Switching Systems are highly capable devices that can switch cells of data at very high speed on a connectionless basis. They contain buffers for flow control and are capable of making alternate routing decisions in the event that inter-switch trunks are congested. The SSs contain very high-speed internal busses, in the Gbps range, in order to accommodate multiple users operating at speeds < 45 Mbps.

SMDS Protocols: Segmentation and Reassembly and Cell Structure

The user data is presented to the network in the form of a Protocol Data Unit (PDU) which is < 9,188 octets in length (Figure 11.6). Such a PDU range accommodates virtually any native protocol, including SDLC. The DQDB protocol layer adds a header and trailer to the PDU, identifying the PDU as a data unit and providing an error control mechanism in the form of a 32-bit CRC. This Initial MAC PDU (Medium Access Control PDU) is then divided into 53-octet cells, known as Segmentation Units, which travel over time slots through the network.

Figure 11.6 SMDS segmentation and cell structure. Source: TR-TSV-000772, Copyright © 1991, Bellcore. Reprinted with Permission.

The structure of the SMDS slot is that of 53-octets, 48 octets are reserved for payload and the other 5 are overhead. The DQDB slot is divided into 2 segments, the Access Control field and the Segment field. The Access Control Field (1 octet) controls access to the bus. The Segment Field (52 octets) contains the Segment Header (4 octets), and the Segment Payload (48 octets), or user data.

Two types of SMDS slots are identified. Queued Arbitrated (QA) slots support asynchronous (non time-sensitive) data traffic. Pre-Arbitrated (PA) slots support isochronous traffic (voice and compressed video), which is delay-sensitive.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

SMDS Costs

Equipment costs include SIP-capable hosts, bridges, routers, and DSUs, in some combination. The DSU, also known as a SMDSU, typically is contained under the skin of a DS-1 or DS-3 MUX.

Network access costs include a dedicated access line to a SMDS network node. The dedicated circuit may be FT1 (N x 64 Kbps), DS-1 (T1 at 1.544 Mbps or E1 at 2.048 Mbps, or DS-3 (T3 at 45 Mbps or E3 at 34 Mbps). Network costs also typically include a port charge and monthly usage charge, per address. Table 11.3 shows an example of network charges, courtesy of MCI Communications, the only IXC offering SMDS. This plan sets fixed prices of 4.1 cents per MB of data at speeds < T1 and 3 cents per MB at greater speeds; in every case a usage cap is set [11-32] and [11-33].

Table 11.3 MCI SMDS pricing, March 1996
 | Monthly Port Charge/Address |  | Maximum Monthly Usage Charge/Address
Bandwidth | RBOC SMDS Access | Private-Line Access | RBOC SMDS Access | Private-Line Access
64 Kbps | $50 | $180 | $293 | $164
128 Kbps | N/A | $336 | N/A | $327
256 Kbps | N/A | $394 | N/A | $654
384 Kbps | N/A | $578 | N/A | $980
512 Kbps | N/A | $735 | N/A | $1,307
768 Kbps | N/A | $946 | N/A | $1,547
1.024 Mbps | N/A | $1,178 | N/A | $1,620
1.526 Mbps | $250 | $1,470 | $3,037 | $1,740
4.0 Mbps | $750 | $3,000 | $3,940 | $3,500
10.0 Mbps | $1,500 | $5,500 | $5,833 | $6,600
16.0 Mbps | $2,000 | N/A | $8,813 | N/A
25.0 Mbps | $2,500 | N/A | $12,960 | N/A
34.0 Mbps | $3,250 | N/A | $16,524 | N/A
Source: Network World, April 8, 1996

SMDS Advantages

The advantages of SMDS are considerable. Intended for LAN-to-LAN internetworking over the MAN, it is extendible to the WAN and has application to a broad range of data communications requirements. As shown in Table 11.3, its wide range of bandwidth options at lower speeds position it well against Frame Relay and ATM; further, it currently offers higher speeds that does Frame Relay.

Where available, an SMDS network is relatively simple to implement and reconfigure. Unlike Frame Relay, there is no requirement to establish PVCs with a connectionless service. Rather, any-to-any connectivity can be established based on SMDS addresses. The lack of PVCs and the scalability of SMDS make networking highly cost-effective compared with either a leased-line mesh network or a PVC-based Frame Relay network.

Further, SMDS offers excellent access control and congestion control, thereby avoiding the latency issues and exposure to data loss which are characteristic of X.25 and Frame Relay networks. These characteristics also make SMDS an excellent alternative for isochronous communications, which is intolerant of latency and loss. Finally, SMDS provides a smooth migration path to ATM via software upgrades—in fact, it was designed with ATM in mind.

SMDS Disadvantages

SMDS suffers from limited availability. Not all of the RBOCs and CAPs offer SMDS. Primarily intended as a MAN network technology, it can be extended to the WAN, although performance becomes something of an issue when distance increases. In any event, MCI stands alone in the IXC world as supporting SMDS. Unlike Frame Relay and ATM, SMDS is limited to a public offering—it just doesn’t make sense as a private network technology. The limited carrier support for SMDS also translates into limited manufacturer support. While large numbers of manufacturers build Frame Relay and ATM gear, SMDS equipment vendors can be counted on your fingers and toes, with digits to spare. This lack of vendor support also translates into a less competitive market with small manufacturing runs and, therefore, higher equipment costs that are not likely to come down [11-29].

Assuming that conventional wisdom is correct, ATM is the network of the future. Therefore, the future of SMDS is likely to be a short one. While it performs beautifully, is cost-effective and available, it just doesn’t have the horsepower (bandwidth) to compete with ATM in a B-ISDN scenario. Until ATM takes over, however, SMDS will continue to enjoy a small, but loyal, following. Even into the world of ATM, SMDS can continue to serve as an ATM access technology.

SMDS Applications

SMDS applications primarily are data in nature. Although intended for LAN internetworking in a Metropolitan Area Networking scenario, SMDS also serves to connect LAN-to-host, controller-to-host, terminal-to-host, host-to-host, and for host channel extension. SMDS also supports image networking beautifully, as well as point-of-sale networking, distributed process control, and desktop publishing. The service also can support isochronous data such as realtime digitized voice and video, although such application is unusual.

Bell Atlantic in March 1996 announced an interesting application for SMDS involving Internet Service Providers (ISPs). While still restricted to intraLATA service provisioning Bell Atlantic’s IP Routing Service (IPRS) will offer a means of providing large numbers of dialup users with analog or ISDN access. In each LATA a single CO switch will be equipped with the capability to accept that IP-addressed traffic and concentrate it through 34 Mbps SMDS pipes, accomplishing the cell segmentation process in the CO switch. At the receiving end, the ISP or intranet managers must place a high-capacity switch or router with a SMDS interface. The advantage is in the high-capacity network access, and elimination of ISDN termination equipment and banks of modems. [11-34].

Calgon recently installed a multisite SMDS network from MCI to link a number of systems, including IBM mainframes and token ring LANs. Applications supported include e-mail, order processing, and inventory updates. The 56-Kbps lines connect to Cisco routers, MultiTech DSU/CSUs, a Cabletron hub and TCP/IP and IPX network protocols. ATM was rejected for lack of standards; and Frame Relay due to the high cost of multiple PVCs. Plans are to extend the network throughout the entire corporation, and upgrade to 45 Mbps circuits [11-35].


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

Asynchronous Transfer Mode (ATM)

Asynchronous Transfer Mode (ATM) was developed as a concept by the ITU-T as an outgrowth of ISDN standards which developed in the early 1980s. While the concept of Narrowband ISDN (N-ISDN) was intriguing, it soon became clear that the demand would develop for a wide range of bandwidth-intensive services which would be beyond the scope of narrowband (Nx64 Kbps) or even wideband (1.5 Mbps-45 Mbps) transmission facilities and circuit-switched connections. Given that assumption, which has since proved to be correct, the ITU-T cast an eye toward the future of broadband (> 45 Mbps) networking. Broadband ISDN (B-ISDN) was the conceptual result. Although B-ISDN still is very much in the future (N-ISDN has yet to reach its potential), its ATM network technology foundation is beginning to make a mark in the market.

The first ATM network in the U.S. was a testbed gigabit network known as the National Research and Education Network (NREN). Sponsored by the U.S. government Advanced Research Project Agency (ARPA) and the National Science Foundation (NSF), the project began in 1990. There currently are a number of such testbed networks in the U.S. In Europe, the Research for Advanced Communications in Europe (RACE) project 1022 was initialized in 1987 to demonstrate the feasibility of ATM. RACE is sponsored by a consortium of carriers, end users and universities. The R1022 ATM Technology Testbed (RATT) has exceeded expectations. RACE project 2061, also known as EXPLOIT, is a more recent RACE project intended to prove the viability of Integrated Broadband Communications (IBC) in the European Community (EC). In Japan, Nippon Telephone and Telegraph (NTT) has embarked on a project with the cooperation of manufacturers to replace the existing network trunk structure with ATM by 2005 [11-36].

ATM Defined

Asynchronous Transfer Mode (ATM) is a fast-packet, connection-oriented, cell-switching technology for broadband signals. ATM is designed, from concept up, to accommodate any form of information—voice, facsimile, data, video and image—at broadband speeds and on an unbiased basis. Further, all such data can be supported with a very small set of network protocols, regardless of whether the network is local, metropolitan or wide area in nature. In terms of user access rates, ATM currently operates at access speeds of DS1 and DS3, with much higher speeds planned in the future. The backbone transmission rates are DS3 and OC-1 at a minimum, and often at OC-3. A 25.6 Mbps ATM LAN standard was more recently and reluctantly approved by the ATM Forum, with strong encouragement from the ATM 25 Alliance. [11-37]. ATM is highly scalable in terms of both bandwidth and geographic reach.

ATM can be distinguished from Frame Relay in that ATM is a backbone network technology, whereas Frame Relay is an access technology. ATM also has application on-premise through LAN switches, hubs, routers, and the like. PBXs eventually will be equipped with ATM switching matrices, as well. Through the 25 Mbps standard recently adopted, ATM also is finding its way to the workstation.

ATM data can be of three types. Constant Bit Rate (CBR) traffic, such as T-carrier, requires the presentation of time slots on a regular and unswerving basis. Variable Bit Rate (VBR) traffic, such as compressed video and bursty LAN traffic, requires access to time slots at a rate that can vary dramatically from time-to-time. Available Bit Rate (ABR) traffic, such as bursty data, can deal with time slot access on an as-available basis. ABR traffic also is known as best-effort ATM. As we will discuss later in this chapter, all earlier classes of service are now specified as CBR, VBR and ABR in the ATM world; in each case, specific Quality of Service (QoS) parameters are defined.

In any case, and as the data are presented to and accepted by the network on a start/stop basis, the transmission mode is asynchronous—hence the termAsynchronous Transfer Mode. The transmission facility, of course, is highly synchronized; the ATM switch and all other network elements are synchronized with the pipe, as well.

The user data are sent to the network over a digital facility. At the workstation, router, or ATM switch, data are organized into 48 octet cells. Each cell is prepended with a header of 5 octets and multiplexed, contending for access to a broadband facility, ideally SONET in nature. As the ATM cell is 53 octets in length, with 48 octets of payload and 5 octets of overhead, it is reminiscent of SMDS. SMDS, as we discussed earlier in this chapter, actually is a variation of ATM. While SMDS provides an immediate solution for certain applications, it likely will be relegated to niche applications in the future. ATM is intended to be the ultimate and complete network transport solution, supporting a theoretically infinite range of services via B-ISDN.

The advantage of the small cell size is that it can accommodate any form of data—digital voice, facsimile, data, video, and so on. The fixed length of the cell offers the network switches the advantage of predictability, as compared to a variable length frame. These two considerations yield decreased delay, as data move through the switching systems and across the transmission links in frequent little blasts. Long, and especially variable, frames occupy the attention of the network for relatively long periods of time, causing delay as other data would have the effect of waiting their turn.

ATM is the first network technology to offer true Bandwidth-on-Demand, as the bandwidth can be varied during the course of the call [11-3]. True enough, other services offer bandwidth which can vary with each call, but none can offer the ability to adjust the amount of bandwidth required to support a call once the call is established. For example, a high-quality videoconference might require 1.544 Mbps (T1) capacity as a rule. Yet, with the sophistication of contemporary compression techniques, that call might require much less bandwidth much of the time. Once that call is setup, a full T1 is dedicated to it, regardless of the actual bandwidth requirement moment-by-moment. ATM is not so rigid, as it can adapt dynamically to the bandwidth actually required.

As is the case with Frame Relay and SMDS, ATM networks do not provide for error detection or correction. Neither do they provide for protocol conversion. Rather, these responsibilities are shifted to the end user. The advantages are increased speed of switching, elimination of associated delay, and reduced cost because the ATM switches require less memory and processing power.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

ATM Standards

ATM standards are set by the ITU-T. Beginning in 1988 with the first set of B-ISDN standards recommendations, ATM and B-ISDN were inexorably linked. In 1992 the ATM Forum was formed as a voluntary organization of manufacturers, consultants, and interested parties to develop interoperability specifications based on member consensus. The Internet Engineering TaskForce (IETF) also has gotten involved, as ATM has significant implications relative to the Internet, as least at a backbone level. While a lot of work remains to be done in the arena of ATM standards, the following provides a view of some of the more important standards and standards under development and review.

ITU-T Standards of significance include:

• I.113: B-ISDN Vocabulary
• I.121: Broadband Aspects of ISDN
• I.150: B-ISDN ATM Functional Characteristics
• I.211: B-ISDN Service Aspects
• I.311: B-ISDN General Network Aspects
• I.321: B-ISDN Protocol Reference Model
• I.327: B-ISDN Functional Architecture Aspects
• I.361: B-ISDN ATM Layer Specification
• I.362: B-ISDN ATM Adaptation Layer Functional Description
• I.363: B-ISDN ATM Adaptation Layer Specification
• I.413: B-ISDN User-Network Interface
• I.432: B-ISDN User-Network Interface-Physical Layer Specification
• I.555: Frame Relay and ATM Internetworking
• I.610: B-ISDN Operations and Maintenance Principles and Functions

ATM Forum Implementation Documents of significance include the following:

• ATM User-Network Interface (UNI) Specification for PVCs
• ATM Broadband InterCarrier Interface (B-UNI) Specification
• ATM Data Exchange Interface (DXI) Specification

Internet Engineering Task Force (IETF) RFCs (Requests for Comment) include:

• RFC 1483: Definition of Multiprotocol Encapsulation over AAL 5
• RFC 1577: Definition of Internet IP over ATM

ATM Access

Access to an ATM backbone network is at rates equal to or greater than DS-1. Whether access is from an end-user CPE environment or from a Frame Relay, X.25, or SMDS network switch, the access rate is DS-1, DS-3, or perhaps at a higher rate such as OC-3 (155 Mbps). Access is provided through a User Network Interface (UNI) specified by the ATM Forum; in each case the interface address is 20 octets in length.

User Network Interface (UNI)
specifically refers to a private UNI between a user device and an ATM network. At this level, the ATM network assumes all responsibility for conversion of the user Protocol Data Unit (PDU) into ATM PDUs and cells. A variation of the UNI concept also is employed by ATM users to access a SMDS network. This SIP Connectionless Service Protocol is via ATM Adaption Layer (AAL) 3/4. In the future, the user interface usually will be through a SDH/SONET connection, although FDDI connectivity will be supported, as well.
Data Exchange Interface (DXI)
is a private UNI for end user access to an ATM Network from DTE/DCE such as a bridge, router, or ATM DSU. The DXI concept allows for the sharing of protocol responsibility between the user and the network provider. At the Physical Layer, the DXI allows for connection via V.35, EIA 449/530, or EIA 612/613 HSSI connection. A variation of the HDLC protocol is used at the Data Link layer. The user information is encapsulated within a DXI (HDLC) frame and converted to the appropriate, class-specific ATM protocol at the DCE. The DCE assumes responsibility for functions through Segmentation and Reassembly (SAR), presenting the data to the ATM network switch in ATM cells. There exist several DXI modes, which correspond to AAL 3/4 and AAL 5.
Network-to-Network Interface (NNI)
also known as B-ICI (B-ISDN InterCarrier Interface), is a public UNI for interconnection of public networks via PVCs. NNIs exist for interconnection of ATM networks; NNIs also exist for interconnection of ATM networks and Frame Relay networks. Interoperability issues that must be addressed include protocol conversion, mapping between virtual circuits, alignment of traffic management parameters, and mapping of local network management information.
Frame UNI (FUNI)
is a derivative of the DXI standard. FUNI was developed by the ATM Forum in early 1995 to extend ATM access to smaller sites at rates from 56 Kbps to 1.544 Mbps (T1). Low-speed data enters a router, which forwards the data to the ATM switch as frames similar to Frame Relay frames. Those frames then are converted to cells.

ATM Network and Equipment

The ATM Network consists of Customer Premise Equipment (CPE), Broadband Switching Systems (BSSs) and interconnecting transmission facilities (Figure 11.7) [11-9] and [11-38].

Figure 11.7 ATM Network. Source: TA-NWT-001110, Copyright © 1993, Bellcore. Reprinted with Permission.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

CPE (Customer Premise Equipment)

CPE comprises Data Terminal Equipment (DTE), Data Communications Equipment (DCE), and true CPE.

DTE
includes Mainframe, Mid-range and PC-server host computers connected through the UNI.
DCE
comprises ATM-equipped bridges, routers, brouters and gateways connected through the DXI UNI. ATM premise switches are offered by a number of vendors. Such switches are used for LAN interconnection, employing a highly redundant cell-switching fabric capable of switching speeds which can reach as high as OC-3 (155 Mbps).
CPE
includes ATM-based PBXs and Video Servers. While these devices currently do not exist, they will be added to this definition. First, ATM proves itself as being truly voice- and video-capable, and that capability must be standardized. Such devices will be connected via the UNI or the DXI.

BSSs (Broadband Switching Systems)

BSSs are carrier exchange switches capable of broadband switching and transport. They employ highly redundant cell-switching fabrics that currently can operate at less than 80 to 100 Gbps. ATM switches are also highly intelligent, providing buffering, routing and flow control, as well as segmentation and reassembly. The switches are highly redundant and fault-tolerant. They fall into two categories, core switches and edge switches.

Edge Switches
also are known as Access Nodes or Service Nodes. They are distributed in close proximity to ATM users and are connected to the core switches via fiber facilities, much as is a CO in the voice world. In fact, they often are collocated with a CO switch.
Core Switches
also are known as Backbone Switches. They generally are housed in a wire center, along with a traditional CO circuit switch or Tandem.

Transmission Facilities

Transmission facilities at the Network-to-Network (NNI) level and between network nodes are SDH/SONET fiber optic in nature; other media can be supported, but are not ideal. Local loop facilities (UNI and DXI) can be any medium capable of supporting transmission speeds of > DS-1 (1.544/2.048 Mbps), although fiber is always preferable. For very short distances in a premise-based ATM environment, Category 5 UTP will support ATM speeds up to 155 Mbps; Cat 3 UTP has been proven at 25.6 Mbps for distances < 90 meters.

ATM Protocols and Cell Structure

ATM is based on a 53-octet cell structure, comprising 48 octets of payload and 5 octets of overhead (Figure 11.8). Unlike the SMDS cell, all 5 octets of overhead precede the payload. The choice of 48 octets was a compromise between the U.S. ECSA (Exchange Carriers Standards Association) T1S1 committee and ETSI (European Telecommunications Standards Institute). The ECSA promoted a 64-octet cell, while ETSI was in favor of 32 octets, each reflecting the bandwidth required for the parochial PCM voice encoding technique. The choice of 48 octets was a perfect mathematical compromise [11-39]. It is worth noting that the cell size and composition is very overhead-intensive, at about 10%. Standard PCM-encoded voice, at 8 bits per sample can deal effectively with a small cell payload. Data, on the other hand, generally are presented in much larger packets, blocks, and frames. Hence, the data world would have preferred a much larger cell, while many in the voice world actually would have preferred a smaller cell.

Figure 11.8 ATM cell structure. Source: TA-NWT-00113, Copyright © 1993, Bellcore. Reprinted with Permission.

While this level of overhead might seem wasteful of bandwidth, the advantages far outweigh the drawbacks. The small size offers the ability to handle any type of data. Additionally, the fixed cell size offers the advantage of predictability, unlike the variable-length frames of Frame Relay. Additionally, bandwidth is cheap over SONET pipes.

In any event, the 48-octet payload was set as a standard for the ATM cell. The cell is divided into header and information segments (Figure 11.9), with the 5-octet header structured as follows:

Figure 11.9 ATM protocol reference mode. Reprinted with Permission by Network VAR.

• Generic Flow Control (GFC): 4 bits that provide local flow control, but which field has no significance on an end-to-end basis. Intermediate ATM switches overwrite this field with additional VPI information [11-9]. In other words and for example, GFC is significant in order to control data flow across a UNI, but is unnecessary at a NNI (Network-to-Network Interface) level.
• Virtual Path Identifier (VPI): 8 bits identifying the virtual path.
• Virtual Channel Identifier (VCI): 16 bits identifying the virtual channel.
• Payload Type Indicator (PTI): 3 bits, distinguishing between cells carrying user information and those carrying service information.
• Cell Loss Priority (CLP): 1 bit, identifying the priority level of the cell in order to determine the eligibility of that cell for discard in the event of network congestion.
• Header Error Control (HEC): 8 bits, providing error checking of the header.

The ATM reference model is multidimensional, with three planes and four layers, as illustrated in Figure 11.9. The bottom two layers of this reference model loosely compare to the Physical Layer of the OSI Reference Model. As in the OSI model, each layer of the ATM model performs its designated functions independently, all layers are tightly linked and the functions are highly coordinated. The layers of the ATM Reference Model are the Physical Layer, the ATM Layer, ATM Adaptation Layer, and higher layers and functions. The planes include the Control Plane, User Plane, and Management Plane.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

Physical Layer (PHY)

Physical Layer (PHY) functions are addressed through two sublayers: Physical Medium and Transmission Convergence. The ATM Forum’s specifications for various User Network Interfaces (UNIs) address the implementation of the physical layer. The B-UNI, or Public UNI, is the specification for carrier internetworks. The UNI and DXI are Private UNIs, describing the implementation specifics for user access to the ATM network.

Physical Medium (PM)
sublayer specifies the physical and electro-optical interfaces with the transmission media, on both the transmit and receive side. Timing functions are provided at this level.
Transmission Convergence (TC)
sublayer is responsible for frame generation, frame adaption, cell delineation, header error control, and cell rate decoupling. The frame generation function takes the frame of data presented by the transmitting device across the PM sublayer, for presentation to the ATM Layer and subsequent segmentation into cells. On the receive side, the TC sublayer receives data in cells, decouples them in order to reconstitute the frame of data, checking all the while for header errors before presenting the data to the PM sublayer which passes the data to the end user device across the UNI.

ATM Layer (ATM)

ATM functions include multiplexing of cells, selection of appropriate VPIs and VCIs, generation of headers, and flow control. It is at this layer that all multiplexing, switching and routing takes place for presentation to the appropriate Virtual Paths and Virtual Channels of the SONET fiber optic transport system, which interfaces through the Physical Layer.

ATM Adaptation Layer (AAL)

AAL functions are divided into two sublayers, the Convergence Sublayer (CS) and the Segmentation and Reassembly (SAR) sublayer.

Convergence Sublayer (CS)
functions are determined by the specifics of the service supported by that particular AAL. Service classes are designated as Class A, B, C and D.
Segmentation and Reassembly (SAR)
sublayer functions segment the user data into payloads for insertion into cells on the transmit side. On the receive side, the SAR extracts the payload from the cells and reassembles the data into the information stream as originally transmitted.
AAL Types
are supported by the functions of the Convergence Sublayer (CS). There exist defined AAL Types 1, 2, 3/4 and 5, each of which supports a specific class of traffic (Figure 11.10). The AAL Classes are not fully standardized at this writing. Additionally, not all carriers support all AAL Classes. By way of example, AT&T will offer AAL Classes A and C, while MCI likely will offer AAL Classes A, C and D [11-9].

Figure 11.10 AAL service classes. Source: ITU-T Recommendation I.362 (03/93)

AAL Type 1
supports Class A traffic, which is connection-oriented Constant Bit Rate (CBR) traffic timed between source and sink. Such traffic is stream-oriented and intolerant of delay. Digitized voice transmission (isochronous), T-carrier (synchronous) and uncompressed video traffic (synchronous) are supported via Class 1 AAL. All traffic is carefully timed and must depend on a guaranteed rate of network access, transport, and delivery. Such traffic would be marked as high-priority in the cell header, in order that it not be delayed in transmission—such delay would have considerable impact on presentation quality. Class A traffic would be transmitted over a Virtual Path (VP) and in a Virtual Channel (VC) appropriate for such high-priority traffic.
AAL Type 2
supports Class B traffic, which is connection-oriented, Variable Bit Rate (VBR), isochronous traffic timed between source and sink. Compressed audio and video are Class B; they are marked as high-priority in the cell header and transmitted over an appropriate VP and VC.
AAL Type 3/4
supports Class C or Class D traffic, which is Variable Bit Rate (VBR) data traffic with no timing relationship between source and sink. Class C traffic, such as X.25 packet data and Frame Relay data, is connection-oriented VBR traffic with no timing relationship between source and sink. Class D traffic, such as LAN and SMDS data, is connectionless VBR traffic which is sensitive to loss, but not highly sensitive to delay [11-9].
AAL Type 3/4
supports Message Mode and Streaming Mode Service. Message Mode Service is used for framed data where only one Interface Data Unit (IDU) is passed. In other words, it is a single-frame message of up to 65,535 octets(216 – 1). Streaming Mode Service is used for framed data where more than one IDU is passed. The IDUs can be separated in time; in other words, a stream of IDUs are sent. The IDUs can be up to 65,535 octets, with a 10-bit CRC added to the trailer at the SAR Layer.
AAL Type 5
supports Class C traffic in Message Mode only. AAL 5 traffic is Variable Bit Rate (VBR) traffic with no timing relationship between source and sink, and consisting of only 1 IDU (Figure 11.11). AAL Type 5 is also known as SEAL (Simple and Efficient AAL Layer), as some of the overhead has been stripped out of the Convergence Layer. AAL Type 5 is intended for use in signaling and control (e.g., NNI applications) and network management (e.g., Local Management Interface, LMI). The IDUs can be of variable length, up to 65,535 octets. A 32-bit CRC check is appended to the IDU at the Convergence Layer, as part of the trailer. Class X traffic, which is VBR and either connection-oriented or connectionless, is supported by AAL 5 [11-40].

Figure 11.11 AAL Type 5 operation.

Higher Layer Protocols and Functions

These relate to the specifics of the user Protocol Data Unit (PDU), such as a SDLC frame.

Control Plane

These functions include all aspects of network signaling and control.

User Plane

These functions deal with issues of user-to-user information transfer and associated controls (flow control and error control mechanisms).

Management Plane

These functions involve the management of the ATM switch or hub. The Management Plane is divided into Plane Management and Layer Management.

Plane management acts on the management of the switch as a whole, with no layered approach. Management of and coordination between the various planes is accomplished in Plane Management.

Layer management acts on the management of the resources at each specific layer of the model; Operation, Administration and Maintenance (OA&M) information.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

ATM Performance: Quality of Service (QoS)

ATM performance parameters are defined in ITU-T Recommendation I.350. Those parameters are used to measure B-ISDN performance of an end-to-end user-oriented connection in terms of Quality of Service (QoS), specific to each service class. The ATM Forum has extended this standard through the definition of QoS parameters and reference configurations for the User Network Interface (UNI).

Performance Parameters defined by the ITU-T address accuracy, dependability and speed. Accuracy parameters include Cell Error Ratio (CER) and Severely Errored Cell Block Ratio (SECBR). Dependability parameters include Cell Loss Ratio (CLR) and Cell Misinsertion Rate (CMR). Speed parameters address Cell Transfer Delay (CTD), Mean Cell Transfer Delay (MCTD) and Cell Delay Variability (CDV).

Quality of Service (QoS) objectives to be set by the network providers include Class of Service 1, 2, 3, and 4. QoS Class 1 addresses Service Class A traffic, providing QoS equivalent to digital private lines. QoS Class 2 supports Service Class B traffic such as audioconferencing, videoconferencing and multimedia. QoS Class 3 addresses Service Class C traffic, including connection-oriented data protocols such as SDLC and Frame Relay. QoS Class 4 supports Service Class D traffic involving connectionless data protocols such as SMDS.

ATM Advantages

ATM clearly offers the great advantage of lots of bandwidth, with access rates usually at T1 or T3, and OC-3 in some cases. The backbone operates at OC-3 (155 Mbps) or better. Further ATM is the first service to offer true bandwidth-on-demand. That bandwidth also is provided over high-quality, fiber optic facilities that provide excellent error performance. In combination, ATM’s strong error performance, access control and congestion control yield outstanding levels of throughput.

ATM also is highly flexible. It is the only technology that can operate equally well in LAN, MAN, and WAN environments. ATM also handles any form of data—voice, facsimile, data, image, video and multimedia—and with Quality of Service levels geared to match traffic requirements. Further, the traffic can be asynchronous, synchronous, or isochronous in nature, and in any combination. Although some standards have yet to be fully defined, ATM offers interconnection with Frame Relay, SMDS, and X.25 networks.

Much as we discussed relative to SMDS, ATM offers mesh networking without the need for complex and expensive leased lines. As a result, network configuration and reconfiguration are much simplified. Finally, ATM networks and associated costs are scalable. In other words, the cost of the network is very much in proportion to the scale of the network in terms of attached devices, networked locations, and bandwidth requirements.

Also, ATM is medium-independent to some extent. While the backbone ATM networks are designed around a SONET fiber optic transmission system, UTP and STP can be used to attach workstations to an ATM LAN switch. The local access facilities generally are copper or microwave at the T1 and T3 levels. Fiber is required at higher speeds such as OC-3 (155 Mbps) and above. Recently, ATM over VSATs was made available internationally in order to leapfrog national networks that do not support ATM. Rates are 8 Mbps or below, and 34/45 Mbps.

ATM Disadvantages

ATM suffers from limited availability, which is not surprising, given its youth and inexperience. LECs currently offering public ATM service in some metropolitan areas include Ameritech (CBR and VBR; options include T1 ATM, ATM-to-LAN, and Frame Relay-over-ATM), BellSouth, Cincinnati Bell (ATM and Frame Relay-over-ATM), GTE, Pacific Bell (CBR and VBR; ABR planned), Southwestern Bell (CBR and VBR), and US West (CBR and VBR; ABR planned by 1997). NYNEX announced an ATM-based Business Network Architecture to be built in 1996. In June 1996, Bell Atlantic announced trials in New Jersey and the Washington, D.C. area [11-41], and plans to offer ATM in six metropolitan areas on a flat-rate basis by the end of 1996. CAPs offering ATM services include MFS (CBR, VBR and voice-over-ATM) and Teleport Communications Group (CBR and VBR; options include LAN interconnection and broadband interconnection [11-42], [11-43], and [11-44].

ATM is particularly limited with respect to international availability, although Western Europe clearly is an exception. Connecting from the United States even to Europe is most unusual. However, Tandem Computer and several client organizations recently completed an 18-month trial of ATM as a replacement for Frame Relay connections between the United States and Europe. Through the PTAT submarine fiber optic cable, they established a T3 link leased from Cable and Wireless, using Stratacom switches. The test included ABR, VBR, and CBR services, including compressed voice over VBR. Results were reported to be highly positive [11-45].

Aside from issues of availability, it should be noted that ATM is not an inexpensive technology. Complete equipment upgrade is generally required in the form of LAN switches, routers, and DSUs. The cost of carriers services is not trivial, either. It also is worth noting that much work remains to be done on ATM standards. Standards for voice and video over ATM are not yet solidified, and network-to-network interfaces have yet to be fully defined. Network management standards are a long way from being complete, as one would expect with such a new technology.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

ATM Costs

While ATM is expensive to deploy, it compares favorably with dedicated leased lines in a mesh configuration for intensive data communications. ATM offers significant performance advantages when compared to traditional data networking alternatives. However, ATM often requires total equipment upgrade, although Frame Relay and SMDS equipment vendors recently have smoothed that transition path.

Sample hardware costs include the following:

• ATM Chips [congruent to] $25; 51 Mbps; 10,000 units
• PC/Workstation Adapters [congruent to] $500–$1,500
• Access MUXs [congruent to] $10,000–$175,000
• Router Adapters [congruent to] $8,000–$20,000
• Premise Switches [congruent to] $1,500 per port
• ATM DSUs [congruent to] $5,000 (T1)–$15,000 (T3)
• Test Equipment [congruent to] $25,000–$100,000

For the most part, carriers have limited their offerings to T1 and T3 bandwidth, with either CBR or VBR. The focus is on data applications, although some support for voice is beginning to appear at the time of this writing. Usage charges are applied by some carriers, while others such as Pacific Bell price the service on a flat-rate basis. Network costs generally include the following cost elements, which vary in their application and level according to carrier and tariff.

• Installation Charge [congruent to] $5,000 (T3)-$8,000 (OC-3)
• Access Line/Port [congruent to] $3,000 (T1)-$63,000 (T3); mileage-sensitive
• Usage Charge per Gigacell

Example network costs include Sprint’s ATM services between New York and Los Angeles priced at $4,240 for T1 and $31,600 for T3. LDDS Worldcom charges $94,500 for T3 service with VBR between New York and Los Angeles; the T3 flavor with CBR is priced at $121,500 [11-46], [11-47], [11-48], [11-49], and [11-50].

ATM Applications

ATM is intended to support any application which the contemporary mind can conceive. The driving force behind ATM development and deployment currently is that of data applications. ATM does a beautiful job of supporting point-to-point data communications, as well as point-to-multipoint data conferencing. In a high-speed, multimedia collaborative computing environment, ATM really shines as a workgroup solution.

As a backbone technology, ATM is a true solution to bandwidth bottlenecks. For instance, a number of carriers are deploying or have plans to deploy ATM to address the looming Internet meltdown. For instance, Pacific Bell announced in December 1995 its plans to deploy ATM to increase its Internet capacity from 15,000 to 600,000 e-mail messages per second using Stratacom switches. According to Pacific Bell, its users generate 40% of all Internet traffic [11-51].

Ultimately, of course, ATM is intended to support voice and video, as well as data and image over LAN, MAN, and WAN. At this point, however, the standards are lagging for voice and video. The ATM Forum and others are working overtime to address these issues, and there is no question that they will be resolved in time. ATM, after all, is the network technology of the future.

ATM LANs

ATM-based LANs deserve special mention. Although some users have deployed high-speed ATM in LAN switches, the driving force appears to be that of the 25.6 Mbps ATM standard. Promoted by the ATM 25 Alliance and later accepted by the ATM Forum, that standard promoted the deployment of ATM in a workgroup environment and in support of collaborative activities which are multimedia (voice, data, video, and image) in nature. Connectivity is provided via an intelligent ATM switching hub, which serves to mitigate congestion issues that would result from such traffic over conventional LANs. ATM LANs can run over existing cabling structures, including UTP and STP, although the switch requires equipment upgrade and new NICs must be installed in existing workstations. In direct competition with FDDI, 100BaseT and 100VG-AnyLAN, 25-Mbps ATM certainly does offer more direct compatibility with ATM in the WAN. As always, the huge installed base of Ethernet makes competing technologies a bit of a hard sell [11-37], [11-52], and [11-47].

Broadband ISDN (B-ISDN)

Broadband ISDN (B-ISDN) was formally addressed in 1988 through the first set of B-ISDN standards from the ITU-T (I.121). These standards were formally revised in 1990, and continue to experience revision and augmentation. The ATM Forum, formed in 1992, builds on these standards through the development and promotion of specifications for equipment interfaces in the ATM network. As noted previously, B-ISDN builds on the services foundation of Narrowband ISDN (N-ISDN). However, B-ISDN is based on cell-switching technology, whereas N-ISDN is a circuit-switched standard. B-ISDN makes use of ATM as the backbone network switching and transport technology, with SDH/SONET as the backbone transmission medium.

As we discussed in Chapter 8, N-ISDN generally has been less than a stunning success. Deployment of N-ISDN varies from country to country, and within each nation on a state, province, and metropolitan area basis. Generally speaking, it is not widely available at the time of this writing. Even where available, it generally has not enjoyed great market penetration, due to high cost and lack of meaningful applications.

Opinions differ widely relative to the likely success of B-ISDN. Some analysts suggest that B-ISDN is dependent on the success of N-ISDN, while others suggest that it will leapfrog N-ISDN, becoming pervasive in the future world of the converged network. As B-ISDN prototype switches have been built and tested by all major switch manufacturers, the technology certainly exists. The uncertainty revolves around the value of the likely services to be offered, as well as the costs of deploying such a network.

Broadband ISDN (B-ISDN Defined)

B-ISDN is defined by the ITU-T as a service requiring transmission channels capable of supporting rates greater than the primary rate. The primary rate is defined in Primary Rate Interface/Primary Rate Access (PRI/PRA) as DS-1. In other words, B-ISDN is a set of services requiring broadband facilities at 45 Mbps (T3) or 34 Mbps (E3).

There are three underlying sets of technologies and standards that are absolutely critical to B-ISDN. First, SS7 is viewed as the signaling and control which will support B-ISDN, as it supports N-ISDN. Second, Asynchronous Transfer Mode (ATM) is the backbone network switching and transport technology. Third, SDH/SONET is the physical backbone network transmission technology.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

B-ISDN Access

B-ISDN user access is broadband in nature, relying on SDH/SONET fiber optic transmission standards. There are two access interfaces specified at this time. User Network Interface A (UNI A) operates at OC-3 rates of 155 Mbps, while User Network Interface B (UNI B) operates at OC-12 rates of 622 Mbps. Network-to-Network Interfaces (NNIs) will be provided for network access to B-ISDN from Frame Relay, SMDS and N-ISDN networks.

B-ISDN Services

The ITU-T defines two types of B-ISDN services, interactive and distribution.

Interactive Services
involve bidirectional transmission and include three classes of service, conversational, messaging and retrieval. Conversational services include voice, interactive data and interactive video. Messaging services include compound document mail and video mail. Retrieval services include text retrieval, data retrieval, image retrieval, video retrieval and compound document retrieval.
Distribution Services
may or may not involve user presentation control. For example, interactive TV is a service requiring presentation control. Interactive TV lets the viewer interact with the program, perhaps to select a product marketed over TV, to influence the ending of a movie, or to change the camera angle in order to view a football play from a different perspective. Conventional broadcast TV exemplifies a service requiring no presentation control.

B-ISDN Equipment

B-ISDN user equipment is an extension of those that were explored in Chapter 8. Broadband Terminal Equipment 1 (B-TE1) is defined as B-ISDN-compatible CPE. While the exact nature of the B-TE1 is yet to be determined, it is likely that it will take the form of ATM-compatible B-ISDN communications servers. These servers will combine the functions of a PBX, data switch, and video switch. At the extreme, they will take the form of ATM-based multimedia communications servers.

Broadband Terminal Equipment Type 2 (B-TE2) is defined as terminal equipment that supports a broadband interface other than B-ISDN. Terminal Equipment Type 2 (TE2) continues to be defined as terminal equipment that supports an interface other than ISDN. Both B-TE2 and TE2 equipment will interface with the network through a Broadband Terminal Adapter (B-TA).

B-ISDN Costs

B-ISDN implementation costs cannot be determined at this point, although they will be very high. Carrier network costs will include investments in ATM switches and SDH/SONET fiber optic transmission facilities. User investments in totally new hardware and software will be nontrivial, to say the least.

B-ISDN Advantages

B-ISDN has the clear advantage of being standards-based. As previously noted, ISDN is based on probably the most carefully though-out and documented set of standards in the history of the planet. Unfortunately, the standards actually are standards recommendations that have not been applied universally on the same basis. Whether or not B-ISDN standards recommendations will suffer the same remains to be seen.

N-ISDN was intended to be universally available. This hasn’t happened. We also will have to wait and see if B-ISDN also suffers from lack of availability. In all likelihood, the high cost of implementing B-ISDN will restrict its availability and use to areas where there exist large concentrations of customers with pockets deep enough to afford the service. Where there is sufficient density of demand, carriers will certainly deploy the underlying technologies.

B-ISDN will support connections that are switched, permanent, semi-permanent, point-to-point, and multipoint. It will support services that are on-demand, reserved and permanent; and either connection-oriented or connectionless in nature.

Based on the foundation technologies of SS7, ATM, and SONET, B-ISDN will offer significant advantages. These advantages include broadband switching and transmission, bandwidth-on-demand and the ability to accommodate all forms of data on a highly flexible basis. Finally, B-ISDN is future-proof—there are no understudy service technologies waiting in the wings to supersede B-ISDN.

B-ISDN Disadvantages

If all this seems to be too good to be true, it’s because it is! As Aesop noted in the 6th century B.C.: “Every truth has two sides; it is well to look at both, before we commit ourselves to either.” So it is with Broadband ISDN. B-ISDN standards are in their developmental infancy. True enough, the underlying technologies are well on their way, but B-ISDN really hasn’t been well-defined at this point. When those standards recommendations are set over the next few decades, they likely will remain open to interpretation, as has been the case with N-ISDN. Additionally, the cost of implementing B-ISDN will be very high—it will not be for everyone.

B-ISDN Applications

B-ISDN applications are all futures, including virtually anything one can imagine, short of teleportation, which likely will be reserved for Star Trek reruns. B-ISDN certainly will support any form of data communications we can imagine—connectivity will be supported between any imaginable combination of hosts, workstations, LANs and servers, and across any distance. Voice, data, video and image communications will be supported in the ultimate form of high-resolution multimedia.

High-Definition TV (HDTV) will be supported along with the rest, and on an interactive basis. Large, high-resolution, digital display technologies will replace the TV set and computer monitor, allowing future generations to experience the unbridled joy of interacting with their favorite talk show host on a multimedia basis and live (in real time).


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

Advanced Intelligent Networks (AINs)

Once upon a time, the networks were truly dumb. Through the 1960s, and even into the 1970s, they remained fairly dumb. In other worlds, the networks were composed largely of switches and pipes that could do little more than connect calls as directed, based on a hierarchical order of limited switching intelligence. That intelligence was in the form of very limited programmed logic, housed in databases that interacted at a minimal level. In other words, each switch performed its own job, with little thought of the network, as a whole.

Intelligent Network, Version 1 (IN/1) was born in 1976, with the introduction of IN-WATS (800) services and the first Common Channel Signaling (CCS) system. IN/1 provided for the switches to consult centralized, service- and customer-specific databases (Figure 11.12) for routing instructions and authorization code verification. NI/1 services include INWATS, calling card verification and Virtual Private Networks (VPNs).

Figure 11.12 Intelligent Network (IN) supporting 800 services and calling card verification.

The linchpin of the intelligent network is the Service Creation Element (SCE), which is a set of modular programming tools allowing services to be developed independently of the switch, the nature and capability of which can vary by manufacturer. The SCE divorces the service-specific programmed logic from the switch logic, allowing the independent development of the service—the service is available to all switches in the network. The concept of a sparse network is one of dumb switches supported by centralized intelligence. This concept is highly viable in terms of both performance and economics.

The IN/1 approach was lacking in that it still required substantial programming work at both the SCE and the switch level. Bellcore research led the development of IN/2, which required substantial investment in the end offices. IN/2 was dropped in favor of IN/1+, the current version of AIN [11-53].

AIN Defined

AIN was defined by Bellcore in the early 1980s as AIN Software Release 1.0. This release is intended to provide a generic and modular set of tools that allow the creation, deployment and management of services on a flexible basis. The software tools yield a suite of service offerings which are accessible to all network switches, but which operate independently from the switch logic. The services, therefore, can be defined, developed and deployed quickly, and in a multivendor environment.

The depth and complexity of AIN Software Release 1 caused the telephone companies to move forward with their own various AIN releases, known as Releases 0.X. All Releases 0.X are fully compatible with Bellcore’s Release 1.0, which may never be implemented in its original and defined form. AIN Release 0.0 addresses basic call modeling functions for Service Switching Points (SSPs) and database functions for Service Control Points (SCPs). AIN Release 0.1 defines generic call model for interaction between SSPs and SCPs; it includes features in support of N-ISDN services. AIN Release 0.2 adds Intelligent Peripherals (IPs). [11-53].

Characteristics of AINs include service creation toolkits, that allow the creation of centralized logic residing in centralized databases for the development and delivery of features across the network. AINs support all ISDN Features, including Caller ID, Selective Call Blocking, and Distinctive Ringing. Finally, AINs are intended to provide support for Personal Communications Services (PCS), which allow subscribed features to be supported across networks of all types; PCS is conceptual at this time.

Service Creation Environment (SCE)

The Service Creation Environment (SCE) is the key distinction of an AIN. The SCE offers the carrier a toolkit for the development of service offerings that can be provided on a network basis. The services can be generic or customer-specific. The customer-specific services often can be created through the linking of generic services and the varying of the available options and parameters. Additionally, the SCE can be opened to the user organization, which can then customize the service offering as desired.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

AIN Architecture

The architecture of the AIN differs greatly from that of the traditional network, and even from that of IN/1. These differences largely deal with the nature and location of the programmed logic and the databases which drive the service offerings. The AIN architecture (Figure 11.13) includes SS7, Service Switching Points, Signal Transfer Points, Service Management Systems, Adjunct Processors, and Intelligent Peripherals.

Figure 11.13 Advanced Intelligent Network.(AIN) configuration supporting networked call centers

Common Channel Signaling System 7 (SS7)
as has been discussed, is an out-of-band signaling system for communication between devices in the carrier networks. SS7 is a requirement for ISDN and AIN. SS7 is being deployed throughout networks, worldwide and in support of all advanced networks and network services.
Service Switching Points (SSPs)
are PSTN switches that act on the instructions dictated by AIN centralized databases. SSPs can be end offices or tandem switches, as defined in the Chapter 6 discussion of the PSTN.
Signal Transfer Points (STPs)
are packet switches that route signaling and control messages between SSPs and SCPs, and between STPs.
Signal Control Points (SCPs)
contain all customer information in databases that reside on centralized network servers. SCPs provide routing and other instructions to SSPs, as requested and required.
Service Management Systems (SMSs)
are network control interfaces that allow the service provider to vary the parameters of the AIN services. Under certain circumstances, the user organization may be provided access to a partition of the SMS.
Adjunct Processors (APs)
are decentralized SCPs that support service offerings limited to a single SSP or a regional subset of SSPs. APs might support routing tables or authorization schemes specific to a single switch or regional subset of switches.
Intelligent Peripherals (IPs)
provide intelligent peripheral capabilities to enhance the delivery of certain services. For example, voice processing and voice recognition might be implemented in support of collect-call processing. Services such as AT&T’s 1-800-OPERATOR and MCI’s 1-800-COLLECT allow the processing of a collect or third-party billed call without operator intervention.
Voice recognition also can be used for voice printing, which allows for user authentication in highly secure applications. A number of LECs are providing automated directory assistance services, accomplishing database lookups based on voice recognition inputs through Intelligent Peripherals.

AIN Services

AIN services truly are open to the imagination. However, the availability of AINs is very uneven within the United States and, certainly, around the world. AIN services are of wide variety, including the following:

• Find-Me Service provides flexible and selective call forwarding. The numbers to which the calls are to be forwarded can be programmed and re-programmed from any location. Caller priority access can be subject to entry of proper passwords provided by the called party. Such capabilities recently have appeared in the commercial market, based on Intelligent Peripherals (IPs) known as Personal Assistants. Such systems also provide for scheduling of follow-up calls, provide scheduled reminder messages and maintain contact lists [11-54].
• Follow-Me Service provides for call forwarding on predetermined schedule. A telecommuter, for instance, might have the network forward calls to the home office three days a week during normal business hours. Calls would be directed to the traditional office two days a week. Calls clearly outside of normal business hours would automatically be directed to a voice mail system.
• Computer Security Service would automatically serve to provide secure access to networked hosts based on Caller ID, and supplemented by authorization codes. Additionally, the network would automatically keep a log of all access and access attempts, thereby providing an audit trail.
• Call Pickup Service, also known as Call Notification Service, provides for calls answered to be answered automatically by a voice processor. The called party can notified by pager, fax, e-mail, or other means. The priority of the calling party can be distinguished by the caller’s entering a privilege code provided by the called party. To pick up the call, the called party dials DISA port on the network switch and enters password codes in a manner to that used to accesses contemporary voice mail systems.
• Store Locator Service, also known as Single Number Dialing, provides the ability to advertise a single number. The network routes the call to closest store location, based on the originating address (telephone number) of the caller. This service is being deployed widely in the United States in support of pizza parlors and other restaurants offering delivery services. It also is used widely for directing calls to networked incoming call centers such as reservations centers (e.g., airlines, auto rental agencies and hotel chains).
• Multilocation Extension Dialing provides for network routing of calls based on abbreviated numbers. It is similar to a coordinated dialing plan in a networked PBX environment.
• Call Blocking typically supports the blocking of calls to international destinations, either in total or to specific country codes. Content Blocking supports the blocking of call to specific numbers, such as 900 numbers. This capability is deployed fairly commonly in many foreign networks, but is not widely available in the United States. Cellular radio providers have made extensive use of such capability in order to avoid cellular fraud involving certain countries in the Middle East, The Bahamas, and South and Central America. Ameritech offered Call Control Service on a trial basis (1994), allowing residential customers to block calls to specific numbers or to all numbers except those on an allowed list. Widespread deployment of such capabilities are unlikely in the near future; for instance, Ameritech estimated that only 46% of its residential access lines would have access to AIN by year-end 1996 [11-55]
• Caller Name is a variation of Caller ID, with linkage to directory services. The incoming call is identified on a Visual Display Unit (VDU) by originating number and associated directory listing. The VDU can either be built into the telephone or can be in the form of an adjunct unit that sits between the telephone and the circuit. In a CTI (Computer Telephony Integration) scenario, it can be in the form of a PC or computer workstation.
• Enhanced Call Return allows the subscriber to access what is, in effect, a highly sophisticated, network-based voice mail system. Bell Atlantic’s trial offering allows the user to call the system and enter security codes to gain access to the switch and data stores. A voice announcement will identify the date, time, and phone number of the last incoming call, at which point the return call can be launched by pressing a number on the telephone keypad [11-56].
• Enhanced Call Routing is a network-based enhancement to 800 calling. The callers are presented with options which allow them to specify their needs and then be connected with the offices or individuals best able to satisfy them. MCI and Stentor (Canada) began trials on such a system in early 1995, providing seamless interconnection between the United States and Canadian networks [11-57].
• Call Completion Service allows the Directory Assistance operator to extend the call automatically, perhaps at an additional charge. This capability is offered by cellular providers such as US West Cellular (at no additional charge) to avoid accidents caused by driving and dialing.
• Number Portability serves to provide portability of telephone numbers such as INWATS and 900 numbers. This function will be utilized increasingly as the regulators insist on portability of local numbers. Such portability is essential to facilitate local competition as decreed by the Telecommunications Act of 1996.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

AIN Futures

The future of the AIN, as defined by Bellcore, is a bit uncertain. GTE and each of the RBOCs and IXCs have developed their own versions of IN in support of 800 services, calling card verification, and other services. Whether they will move toward the Bellcore standard version is not clear, although it appears to be unlikely. AINs will be implemented across the major carriers; in fact, they already have been deployed in part. As AIN capabilities roll out on a gradual basis, we likely never will see headlines announcing the arrival of AIN. Rather, it has crept into the networks and will continue to do so. Driving forces for the continuing rollout of such capabilities include recent FCC (May 4, 1995) and state PUC decisions in support of Caller ID and Name ID, which require SS7 and some level of AIN. A number of carriers have begun to offer automated Directory Assistance, and that trend is likely to continue. The Telecommunications Act of 1996 introduced local competition and several states have taken the initiative of requiring local number portability and equal access at a local exchange level—AINs are key to implementing such flexibility.

More exotic AIN functionality is illustrated in Figure 11.13, involving a reservation system taking advantage of processing power embedded in the network—the following approximate scenario has been followed in several cases. A hotel reservation network might involve incoming call centers in New York, Chicago and San Francisco. These call centers are networked through AT&T so that callers might be directed to the closest call center that can handle the call based on criteria such as queue length, average holding time, and priority level of the caller as determined by Caller ID or PIN number. In cooperation with a third-party vendor, the hotel company might write a generic software program to accomplish the routing of calls. That program would enable inquiries against a relational database in which resides customer profiles in order that calls might be handled in the most appropriate way. The program and database might reside on a centralized computer platform located in the Chicago call center, in the data center of the third party vendor, or perhaps even in the carrier’s wire center. The centralized network control and routing system would make frequent status checks against the individual ACDs in the call centers in order to determine traffic load and make performance comparisons against Quality of Service parameters, which are user-definable. Based on this process, each call would be routed in the most effective manner. Once this system is deployed and performing effectively, it could be made available on a licensed basis to other hotel chains, rental car agencies, and other reservation networks. Each licensed user then might have similar capabilities, with the system administrator remotely accessing a physical and logical partition of the programmed logic and database in order to support his own reservation network supported by MCI, Sprint, or LDDS Worldcom. Through the development of such a scenario, multiple users take advantage of computer and database technologies embedded in the carrier network, and supporting multiple reservation networks. The interaction between the carriers takes place over SS7 links.

The types of services described above don’t necessarily require broadband networks to support them, although broadband is always good. For that matter and in this world oriented toward instant gratification, more is always better and faster is better, still. Broadband networks certainly fill that need with more bandwidth which supports faster communications. Into the future, the true potential of AINs will be realized only over broadband networks that will be ATM-based, SS7-supported and multimedia-ready. For example, the Digital 800 services were discussed in Chapter 8 under the heading Conventional Public Data Networks. Although Digital 800 currently makes of conventional circuit-switched digital networks, the service is far from conventional. Through the application of network intelligence, ultimately in the form of AINs, the routing of the voice, data, image and video calls are accomplished. AINs will add the ability to switch the calls between carrier networks, in the unlikely event that the carriers are willing to do so. Broadband networks will add the performance characteristics so necessary in effectively supporting such bandwidth-intensive communications.


Communications Systems and Networks:Broadband Network Services: Frame Relay, SMDS, ATM, B-ISDN, and AINs

References

[11-1] Rohde, David. “AT&T’s Frame Relay Play.” Network World. May 27, 1996.
[11-2] Flanagan, William A. Frames, Packets and Cells in Broadband Networking. NY: Telecom Library, Inc. 1991.
[11-2] [11-3] Spohn, Darren L. Data Network Design. NY: McGraw-Hill, Inc. 1993.
[11-4] Schroeder, Erica. “WorldCom Unwraps High-Speed Frame Relay.” PC Week. March 11, 1996.
[11-5] Wexler, Joanie. “SVCs Promise to Further Boost Frame Relay Growth.” Network World. May 27, 1996.
[11-6] Cooney, Michael. “Hypercom Ups Brand Office Ante with New Central FRAD.” Network World. February 26, 1996.
[11-7] Cooney, Michael. “Trio Targets Central Office FRAD Market.” Network World. April 1, 1996.
[11-8] Minoli, Daniel. Enterprise Networking: Fractional T1 to SONET, Frame Relay to BISDN. Norwood MA: Artech House. 1993.
[11-9] Miller, Mark A. Analyzing Broadband Networks: Frame Relay, SMDS, and ATM. NY: M&T Books. 1994.
[11-10] Nolle, Tom. “Frame Relay Laws Get Back to Basics.” Internetwork. December 1995.
[11-11] Riggs, Brian. “Frame-Relay Tariffs Spook Users.” LAN Times. November 20, 1995.
[11-12] Liebermann, Robert, and Szoke, Peter. “How to Size Frame Relay Access for Interconnecting Local Nets.”
Network World. May 6, 1996.
[11-13] Rohde, David. “AT&T Caves in on Its Frame Relay Rate Hike.” Network World. February 19, 1996.
[11-14] Wexler, Joanie, and Rohde, David. “Frame Prices Shaken.” Network World. January 29, 1996.
[11-15] Taylor, Steven. “Frame Relay: Priced to Sell.” Data Communications. October 1995.
[11-16] Rohde, David. “Compression Device Cuts Congestion.” Network World. July 31, 1995.
[11-17] “Frame Relay Liftoff.” Data Communications. February 1996.
[11-18] Bursk, Edward. “The Benefits of Implementing Frame Relay.” Data Communications Management. Norwood, MA: Auerbach Publications. 1995.
[11-19] Greene, Tim. “Frame Relay Cruises Down The Info Highway.” Network World. November 6, 1995.
[11-20] Thyfault, Mary E. Frame Relay Travel Net Set.
Information Week. December 25, 1995.
[11-21] “Running Voice, Fax, Data, LANs on Frame Relay.” Communications News. November 1994.
[11-22] Csenger, Michael. “ACT Exhibits Voice and Video over Frame Relay.” Network World. September 19, 1994.
[11-23] Csenger, Michael. “Voice over Frame Relay Finds Home in Niche Applications.” Network World. September 26, 1994.
[11-24] “Cut Costs! Pipe Voice and Data Together.” Datamation. January 15, 1996.
[11-25] Heckart, Christine, and Gage, Beth. “Voice Gets Framed.” BYTE. February 1996.
[11-26] Conner, Louis. “Why Wait for ATM? Frame-Relay Carries Voice Traffic Right Now.” Communications Week. January 29, 1996.
[11-27] Henderson, Byron. “And You Thought Frame Relay Way Just for Data.” Network World. December 4, 1995.
[11-28] Llana, Andres, Jr. “Global Frame Relay.” Data Communications Management. Norwood, MA: Auerbach Publications. 1996.
[11-29] Anderson, Patricia. “Switched Multi-megabit Data Service (SMDS).” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. August 1995.
[11-30] Miller, Mark A. Internetworking: A Guide to Network Communications LAN to LAN; LAN to WAN. NY: M&T Books. 1995.
[11-31] Greene, Tim. “US West Pulls Out of SMDS Mart.” Network World. March 11, 1996.
[11-32] Rohde, David. “MCI Reprices SMDS.” Network World. April 8, 1996.
[11-33] Rohde, David. “MCI Debuts 'Toll-Free SMDS.’” Network World. April 1, 1996.
[11-34] Rohde, David. Bell “Atlantic Breathes Internet Life into SMDS.” Network World. April 1, 1996.
[11-35] “Calgon Integrates Chemical Plants with SMDS.” Communications News. February 1996.
[11-36] “Future Directions Involving ATM.” Datapro Communications Analyst. Datapro Information Services Group. November 1995.
[11-37] Schatt, Stan. Asynchronous Transfer Mode. San Diego, CA: Computer Intelligence InfoCorp. 1996.
[11-38] Minoli, Daniel. “ATM Public Network Switching Technology.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. November 1994.
[11-39] Minoli, Daniel. Telecommunications Technology Handbook. Norwood, MA: Artech House. 1991.
[11-40] Minoli, Daniel updated by Raymond, Mark. “ATM and Cell Relay Concepts.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. September 1995.
[11-41] Rockwell. Mark. Bells “Expand ATM Services.” Communications Week. June 3, 1996.
[11-42] “ATM Hits the Local Network.” Inter@ctive Week. June 17, 1996.
[11-43] Bernier, Paula. “Southwestern Bell Follows the Leaders into ATM.” Inter@ctive Week. June 17, 1996.
[11-44] Greene, Tim. “Ameritech Makes Renewed ATM Push.” Network World. April 1, 1996.
[11-45] Tanzille, Kevin. “ATM Swims to Strong Showing in Trans-Atlantic Trial.” Communications News. May 1996.
[11-46] Minoli, Daniel. “Economic Considerations for ATM Technology and Services.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. January 1995.
[11-47] McCarthy, Vance. “Tame Your Ethernet Traffic with an ATM Backbone.” Datamation. May 1, 1996.
[11-48] Greene, Tim. “Beam your ATM Traffic over to Foreign LANs.” Network World. April 8, 1996.
[11-49] Janah, Monua. “Vendors Foster ATM in the LAN.” Information Week. May 27, 1996.
[11-50] Axner, David. “What Users Should Know About ATM Carrier Services.” Telecommunications. March 1996.
[11-51] Schmitt, Julie. “Pacific Bell Speeds E-mail on Internet.” USA Today. December 18, 1995.
[11-52] Cohen, Jodi. “ATM Under the Gun.” Network World. May 13, 1996
[11-53] Briere, Daniel D., and Langner, Mark. “Advanced Intelligent Networks.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. November 1994.
[11-54] Briere, Daniel, and Heckert, Christine. “Watching the Demise of Calling Cards.” Network World. March 25, 1996.
[11-55] “Will Proposed AIN Solution for International Blocking Work?” Advanced Intelligent Network News. May 31, 1995.
[11-56] “Bell Atlantic Enhances Return Call.” Advanced Intelligent Network News. May 17, 1995.
[11-57] “MCI and Stentor Connect 800 Services as Canadian Telecom Market Heats Up.” Advanced Intelligent Network News. May 3, 1995.


Communications Systems and Networks:Wireless Networking: voice and Data

Chapter 12
Wireless Networking: Voice and Data

Hello, Shreeve! Hello, Shreeve! And now, Shreeve, good night.

—The first wireless transatlantic telephone call between H.R. Shreeve, a Bell Telephone engineer at the Eiffel Tower in Paris, France and B.B. Webb in Arlington, Virginia on October 21, 1915

In 1876, Alexander Graham Bell demonstrated the telephone at the Centennial Exposition of the United States in Philadelphia, Pennsylvania. From that simple demonstration of one-way transmission over a distance of several hundred feet, the copper-based telephone network grew at an astounding rate. In 1880, Bell invented the first wireless communications system, using reflected sunlight and photoelectric selenium receivers. Using this technique, however impractical, he was able to transmit intelligible speech a distance of up to 700 feet! Bell named this invention the photophone, later renaming it the radiophone, which he described as his greatest invention [12-1] and [12-2]. AT&T continued work on the technology, extending its reach to several miles. The German Naval Command made limited use of advanced devices of this sort during World War II [12-2].

Towards the end of the nineteenth century and not long after Bell’s demonstration, a young German scientist named Heinrich Rudolf Hertz discovered the phenomenon of invisible force waves emanating for several meters around an electric spark of sufficient intensity. Classical physicists, at a loss to explain the phenomenon, theorized the existence of an unknown medium, luminiferous ether, which conducted that signal. Shortly thereafter, Guglielmo Marconi was able to transmit these Hertzian waves over several kilometers—he named the new technology Radio [12-2]. In 1886, Marconi was granted a patent for the first practical wireless telegraph, for which he shared the 1909 Nobel Prize in physics. In the meantime, Reginald Fessenden developed in 1890 wireless voice communications [12-3].

The first commercial application of radio technology was that of broadcast radio introduced in the United States in 1920. The first radio station, the Westinghouse station KDKA in Pittsburgh (PA), inaugurated service by broadcasting returns of the Harding-Cox presidential election. On July 25, 1922, the first commercial station, WBAY owned by AT&T, began broadcasting from the Long Lines building in New York City. Its first paying customer, two months later, was the Queensborough Corporation, advertising its Hawthorne Court real estate development in Jackson Heights. In the meantime, AT&T employees supplied the programming, which consisted of vocal selections, piano recitals, poetry recitations and other content that seems fairly tame by today’s standards. Among the performances was a recitation of James Whitcomb Riley’s poem “An Old Sweetheart of Mine” by Miss Edna Cunningham, the audience reaction was not recorded. [12-1]. While not an immediate commercial success, radio enjoyed U.S. market penetration of 50% of households in 1930, 90% in 1940, and 100% by 1995.

Television, while first demonstrated in 1926 by John Logie Baier, a Scottish inventor, was refined by yet other Bell Labs employees, Frederick Eugene Ives and Frank Gray. The first public demonstration in the United States of color TV took place in 1927, between Bell Labs in Whippany, New Jersey and Washington, D.C., where the audience included Secretary of Commerce Herbert Hoover. Vaudeville acts were included (again, the audience reaction was not recorded). Delayed by the Great Depression and then World War II, broadcast TV was introduced in 1946 and enjoyed success similar to that of radio [12-1]. Market penetration was estimated at 50% in 1955, 90% in 1960 and 99% in 1995. Wireless radio technology also was deployed early-on in maritime communications, or ship-to-shore telephony and telegraphy. The first terrestrial mobile application was a one-way system employed in police radio dispatch trials in 1921 at the Detroit Police Department [12-4] and [12-2].

The wireless industry has experienced exponential growth over the last decade, growth that is expected to continue at a pace unprecedented in the history of communications. According to the ITU, the 1994 U.S. market size was (US$) $11 billion; Europe, $10 billion; Japan, $9.5 billion and South-East Asia, $4.5 billion. Some estimates place the number of wireless users at 100 million by the year 2010 [12-5].

While cellular voice accounts for the vast majority of this market, a plethora of new technologies recently have emerged with a broad set of new applications. The technologies discussed in this section include Trunk Mobile Radio (TMR), paging, cordless telephony, Wireless Office Telecommunications Systems (WOTS), Cellular, Wireless LANs, Wireless Local Loop (WLL), Low Earth Orbiting Satellites (LEOs), Personal Communications Services (PCS), and Personal Digital Assistants (PDAs). Within each of these technology/application categories there exist a number of specific technologies for discussion. Additionally, each technology can support some combination of voice, data, facsimile, video, and image applications.

Wireless is about more than being unplugged or untethered. Wireless, in full form, speaks to a fundamentally different way of working and living. Wireless communications adds the element of mobility, thereby removing the constraints of constant attachments to a physical space such as an office building, school, hospital, or home. Yet, wireless communications technologies are relegated to niche applications and likely will be for quite some time. For many applications, wireless just can’t compete with wired networks. The limitations of wireless and the underlying reasons will be discussed in this chapter. Theodore Vail, twice president of AT&T (1880s and early 1900s) summed it up when he said: “The difficulties of the wireless telegraph are as nothing compared with the difficulties in the way of the wireless telephone” [12-2]. While wireless telephony may have been quite a trick in those days, it is nothing compared with wireless data communications.

Wireless Defined

Wireless, quite simply, refers to communications without wires. While microwave and satellite communications are without wires, those technologies generally are considered to be high-speed, network backbone, or access technologies which are either point-to-point, point-to-mutipoint or broadcast in nature (see Chapter 3 for discussion of the principles and characteristics of radio transmission). In the context of this discussion, wireless technologies are local loop or local in nature and are application- and service-oriented, rather than being transport-oriented.


Communications Systems and Networks:Wireless Networking: voice and Data

Standards and Regulation

Standards are very important in telecommunications, and wireless is no exception. Wireless technologies have the dubious distinction of lots of standards, most of which are incompatible and conflicting. There exist standards that are U.S. (FCC), European (CEPT/ETSI), international (ITU-R) and, of course, Japanese. There are formal standards and de facto standards. Ultimately, the standards wars will yield winners and losers, but not in the immediate future.

Regulation is extremely important in the wireless world, because there exists significant potential for interference between transmissions. In order to avoid this problem, radio must be managed along several dimensions, including frequency allocation and power levels. Regulatory Authorities and standards bodies of significance include the ITU-R, IEEE, ETSI, and FCC. The ITU-R originally was known as the CCIR (Consultative Committee on International Radio); a branch of the ITU it sets international standards. The IEEE (Institute of Electrical and Electronics Engineers) is in the process of developing standards for Wireless LANs, through the 802.11 Working Group. ETSI (European Telecommunications Standards Institute) sets standards within the EC (European Commission) countries of Western Europe. The RACE program, which is directed at the promotion of Integrated Broadband Communications addresses wireless in its R1043 recommendation document. The Federal Communications Commission (FCC) has been responsible for regulation of the wireless, as well as the wired, world in the United States since 1934. On a periodic basis, the various national regulatory authorities meet to sort out national and international spectrum allocation issues at WARC (World Administrative Radio Conferences), which is sponsored by the ITU-R.

Frequency Allocation

Frequency Allocation or Spectrum Management, involves the designation of certain frequencies in the electromagnetic spectrum in support of certain applications. Examples include AM and FM broadcast radio, UHF and VHF broadcast TV, Trunk Mobile Radio (TMR), cellular radio and microwave radio. This requirement is essential in order to avoid interference among various applications using the same, or overlapping, frequency ranges. In limiting each application to a specific range of frequencies, the manufacturers, carriers, and end users of such systems can better be monitored and controlled.

Power Levels

The power levels various transmitters must be regulated, as stronger signals propagate farther. Clearly, the end result of transmitting at too high a power level is that of interference with distant systems using the same, or overlapping frequency ranges.

Advantages and Disadvantages of Wireless

Before dealing with technology and applications specifics, we should pause to address the advantages and disadvantages of wireless, at least in a general way. The deployment and management of networks without wires offers clear benefits, but also suffers from severe limitations.

Deployment of wireless networks certainly can offer advantages of reduced cost of installation and reconfiguration. Tremendous costs can be saved by eliminating requirements to secure terrestrial right-of-way, dig trenches and plant poles, place conduits and hang crossarms, splice cables, place repeaters, and so on. For that matter, wired networks may not even be a viable option in rocky or soggy terrain. Additionally, wireless offers greatly improved speed of deployment and reconfiguration. Wireless networks also offer great portability; in other words, the antennae quite easily can be disassembled and reassembled at another location, whereas wired networks must be either abandoned or removed and sold as scrap metal. Finally, wireless networks can even offer the great advantage of mobility, as is the case with cordless telephony, cellular radio, and packet radio data networks.

Wireless also suffers from certain limitations, the most significant of which is that of spectrum availability—radio is a finite resource. The laws of physics and Mother Nature (not to mention Table 3.1), state that radio operates between 3 kHz and 30 GHz. While that may seem like a lot of spectrum, there also are a lot of applications and users competing for it. This limited radio spectrum is divided into even more limited spectrum allocated in support of each application (e.g, microwave and cellular radio). Within each slice of allocated spectrum there clearly exists only so much bandwidth. Regardless of how cleverly we design compression algorithms to maximize its use, there still is only so much bandwidth available. As was discussed in connection with microwave and satellite radio (Chapter 3), error performance and security are always issues with airwave transmission.


Communications Systems and Networks:Wireless Networking: voice and Data

The Cell Concept: Frequency Reuse

Radio systems are designed for a certain area of coverage. Even early radio and TV broadcast systems used the concept of coverage areas to provide service to a defined service area. Therefore, the same frequencies could be reused to support service in metropolitan areas some distance away. For instance, 98.1 (MHz) on your FM dial might be WXYZ in New York and KFRC in San Francisco, California. Similarly, Channel 7 on your TV might be WFAA in Dallas, Texas and KGO in San Francisco. Broadcast TV stations in the United States can reuse frequencies if separated by at least 150 miles [12-6].

The formal concept of radio cells dates back to 1947 when Bell Telephone Engineers developed a radio system concept that included numerous, low-power transmit/receive antennae [12-1]. Scattered throughout a metropolitan area, such an architecture would increase the effective subscriber capacity of radio systems by breaking the area of coverage into small cells, or smaller areas of coverage. Each frequency could be reused in non-adjacent cells. Additionally, the cells can be split, or subdivided further as the traffic demands of the system increase—the costs of the network are highly scaleable.

Frequency reuse is sensitive to factors which should now be familiar as a result of the discussion of microwave and satellite systems in Chapter 3. Specifically, these factors include frequency, power level, antenna design, and topography. Higher frequency signals always attenuate to a greater extent over distance given the same power level. Antenna design is sensitive to wavelength and other factors. Topography is always an issue, as line of sight is always preferable.

Cells are generally defined in three categories, macrocells, microcells, and picocells (Figure 0112.1). As the cells shrink, the advantages of frequency reuse increase significantly. However, the costs of network deployment increase dramatically and the issues of switching traffic from moving transmitters from cell-to-cell increase considerably. Nonetheless, the increase in traffic-handling capacity can be quite remarkable, with associated increases in revenue potential. Assuming that 12 channels are available for use in a metropolitan area of a 60-mile radius, consider the following theoretical scenario shown in Figure 12.1.

Figure 12.1 Macrocells, microcells, and picocells.

Macrocells
cover a relatively large area. One (1) macrocell might support 12 channels and only 12 simultaneous conversations. In a 7-cell reuse pattern (which is typical) with each cell covering a radius of about 11 miles, no improvement is realized; only 12 conversations can be supported. This lack of improvement is due to the fact that the cells must overlap; conversations on the same frequency channels in adjacent cells will interfere with each other.
Microcells
cover a smaller area. If a macrocell were divided into microcells, in a 7-cell reuse pattern, a reuse factor of 128 is realized. The same 12 channels could support 1,536 simultaneous conversations
Picocells
are quite small, covering only a few blocks of an urban area or, perhaps, a tunnel, walkway, or parking garage. In a 7-cell reuse pattern, with each cell covering a radius of approximately 1/2 mile, the reuse factor climbs to 514. The same 12 channels could theoretically support up to 6,168 simultaneous conversations. [12-2]

Digital versus Analog

Clearly, communications is going digital. Nonetheless, analog does have a place, if for no other reason than it is the incumbent technology. Transition from analog is expensive and disruptive, and will take some time to complete. This scenario holds true in the wireless, as well as the wired, world. Just as was the case in the wired world, digital wireless offers the advantages of more efficient use of bandwidth (spectrum), improved quality of transmission through enhanced error performance, increased throughput (a logical extension of diminished transmission errors), and improved security. There exist no less than 16 different means of modulating a radio signal, most of which relate to digital radio. Generally speaking, Amplitude Modulation (AM) alone is ineffective due to the phenomenon of fading. For the most part, a combination of Phase Shift Keying (PSK) and Amplitude Modulation (AM) is used to yield compression of up to 16:1.

Multiplexing and Access Techniques

Communications networks take great advantage of the concept of DAMA (Demand-Assigned Multiple Access). DAMA allows multiple devices to share access to the same network on a demand basis (first come, first served). There exist a number of ways in which multiple access can be provided in a wireless network; those techniques largely are mutually exclusive.


Communications Systems and Networks:Wireless Networking: voice and Data

Frequency Division Multiple Access (FDMA)

Frequency Division Multiple Access (FDMA) divides the assigned frequency range into multiple carrier frequencies to support multiple conversations as shown in Figure 12.2. Multiple narrowband frequency channels are derived from a wider band of radio spectrum, much as Frequency Division Multiplexers (FDMs) operate in the wired world (Chapter 2). Transmission #1 takes place on one frequency, while transmission #2 takes place on another. The station equipment must be frequency agile, in order to search and seize an available frequency channel, especially as the mobile transmitter/receiver moves from one cell to another in a cellular network.

Figure 12.2 Frequency Division Multiple Access (FDMA).

Analog cellular systems employ FDMA, which also can be used in digital systems. In either scenario, each conversation is supported by a single channel; a single base station or cell site can support multiple channels, which are subsets of a wide band of radio spectrum. For instance, the U.S. AMPS (Advanced Mobile Phone System) system provides for a total allocation of 40 MHz, which is divided into 666 frequency pairs, each of which provides 60 kHz (30 kHz for the forward channel and 30 kHz for the reverse channel). The two channels supporting a single conversation are widely separated in order to avoid confusion on the part of the terminal equipment; the AMPS systems provides for 45 MHz separation. On average, U.S. AMPS cell sites support 57 frequency channels [12-6]. Table 12.1 provides a comparison of AMPS and GSM, a digital standard discussed later in this chapter.

Table 12.1 Comparison of AMPS (FDMA) and GSM (TDMA)
 | Transmission Mode | Multiplexing Technique | Duplexing Technique | Frequency Band
AMPS | Analog | FDMA | FDD | 800 MHz
GSM | Duplex | FDMA/TDMA | TDD | 800 MHz & 900 MHz

Frequency Division Duplex (FDD) is a means of providing duplex (bidirectional) communications. Forward and backward channels make use of separate frequencies. FDD is used with both analog and digital wireless technologies, including cordless telephony and cellular.

Time Division Multiple Access (TDMA)

Time Division Multiple Access (TDMA) is a digital technique which divides each frequency channel into multiple time slots, each of which supports an individual conversation (Figure 12.3). This concept is exactly the same as in the wired world where TDMs perform the same function. The total available bandwidth, the bandwidth of the individual channels, and the number of time slots per channel vary according to the particular standard in place, as well as the specific coding technique employed. For instance, GSM involves a carrier channel of 200 kHz, with a channel rate of approximately 200 Kbps. The channel is divided into 8 time slots of 25 Kbps each, easily supporting low-bit-rate digitized voice of 9.6 Kbps, plus overhead for framing and signaling. Each conversation makes use of 2 time slots, one for the forward channel and one for the reverse channel. Services based on TDMA offer roughly 3 times the traffic capacity of FDMA services [12-1]. A comparison of GSM and AMPS is provided in Table 12.1.

Figure 12.3 Time Division Multiple Access (TDMA).

TDMA terminal equipment is simpler and less expensive. This largely is due to the fact that the transmit and receive functions are not operative at the same point in time, eliminating the full-duplex (FDX) requirement. A typical TDMA system, such as GSM, actually is both FDMA and TDMA. Multiple carrier channels are provided, divided by frequency. Within each carrier frequency channel, multiple time slots (digital channels) are supported.

E-TDMA (Enhanced TDMA), developed by Hughes Network Systems, is an improvement over TDMA, employing Digital Speech Interpolation (DSI) compression and half-rate vocoders (voice coders), operating at 4.8 Kbps, in order to improve on bandwidth utilization. E-TDMA is said to provide 16:1 improvement over analog technology.

Time Division Duplex (TDD) is a digital means of providing bidirectional communications. The forward and backward channels make use of separate time slots. TDD can be employed with both channels using the same frequency (ping-pong transmission), or it may be used in conjunction with FDD.


Communications Systems and Networks:Wireless Networking: voice and Data

Code Division Multiple Access (CDMA)

Code Division Multiple Access (CDMA) is a relatively new technology that has its roots in spread-spectrum radio developed for secure military use. CDMA is in place in numerous trials, but is not widely deployed. In fact, the first commercial CDMA system was placed in service in Hong Kong only recently [12-5], where cellular phones are considered almost a necessity and where the networks have suffered terrible congestion. CDMA is a wideband radio technology, providing the full carrier channel to all terminals through a frequency-hopping technique, in tune with the base station. Each terminal has its own unique 10-bit code, which is applied to the channel; that code allows the terminal and base station to recognize data intended for it, rejecting all other data [12-3]. Each of a great number of transmissions is spread across the entire available spectrum and is denoted by a unique code which is imprinted on the packet radio transmission (Figure 12.4). In this manner, each transmission can be identified from all others, as well as from background noise; error performance is excellent.

Figure 12.4 Code Division Multiple Access (CDMA).

CDMA improves bandwidth utilization, as a great number of users can share the same wideband radio frequency channel. Improvements of up to 2000% (20x) are predicted, compared to AMPS. CDMA also provides excellent security as it is virtually impossible to intercept more than a small portion of a transmission; encryption can be used to provide additional security [12-7].

CDMA was perfected by Qualcomm, which develops, manufactures, markets and licenses CDMA products. CDMA recently has been licensed by a great number of manufacturers and providers of cellular, PCS, Wireless LAN and other systems and networks. CDMA is being trialed by Ameritech Mobile, Bell Atlantic Mobile, GTE Mobilnet, Southwestern Bell Mobile Systems, and other cellular providers [12-5]. NEC has also licensed the technology.

Switched Mobile Radio (SMR)/Trunk Mobile Radio (TMR)

The first experimental two-way mobile radio system was placed into service by the Detroit Police Department in 1921, operating in the 2-MHz band, followed by the Bayonne, New Jersey police department in the early 1930s. While this AM (Amplitude Modulation) radio application grew quickly, even as late as 1937 there were only 40 channels allocated by the FCC. In the late 1930s, FM (Frequency Modulation) replaced AM as the method of choice due to its improved quality of reception and lower power requirements. (FM receivers tend to lock in on the stronger competing signal, whereas AM recognizes all competing signals.) In 1949 the FCC recognized two-way mobile radio as a new class of service, and began to allocate spectrum and regulate its use [12-8] and [12-2].

Commercial applications were first offered in 1946, when AT&T was granted the first license for two-way, mobile FM service in St. Louis, MO. This service offered the additional advantage of being connected to the PSTN WAN. The transmitters had a range of approximately 50 miles. As the costs were reasonable, the service grew in popularity and the systems were soon oversubscribed. In fact, it was not uncommon for a provider to load as many as 100 subscribers per channel; as a result, service was horrible. In 1976, by way of example, service in the New York metropolitan area (20 million population) consisted of 20 channels supporting 543 subscribers; there was a waiting list of approximately 3,700 [12-8].

Switched Mobile Radio (SMR), also know as Trunk Mobile Radio (TMR) entered the scene in the 1960s marketed as Improved Mobile Phone Service (IMTS). This service made better use of FM bandwidth through narrowband communications (smaller frequency ranges). IMTS also allowed users to search multiple frequencies on a manual basis. Shortly thereafter, intelligent mobile sets were developed that searched channels automatically. The concept of SMR/TMR remains much the same as it was originally. The provider places a radio tower and omnidirectional transmit/receive antennae on the highest possible point in the area and blasts the signal at the maximum allowable power level. As illustrated in Figure 12.5, this approach provides a coverage area of 50 miles or more, depending on topography.

Figure 12.5 Switched Mobile Radio (SMR) network.

SMR/TMR largely has been supplanted by cellular service offerings, although it still is widely used in dispatch and fleet applications such as police, fire, and emergency vehicles; taxi fleets, utility fleets (e.g., telephone companies, electric utilities, and CATV providers), and courier services. In the United States, 80 MHz has been allocated for SMR.

Enhanced Switched Mobile Radio (ESMR)

Enhanced Switched Mobile Radio (ESMR) is a technique developed by Nextel and Geotek Communications for the development of a voice and data, cellular-like network using embedded SMR networks operating at 800-900 MHz. For instance, Nextel acquired and linked a large number of SMR networks throughout the United States. Through the use of digital technology, each frequency channel is divided into multiple time slots to support multiple conversations; call hand-off is supported. MCI in 1995 withdrew its offer of US$1.3 billion for 17% of Nextel, without citing any reasons. It seems apparent that MCI had second thoughts about committing such a significant amount of money and putting its reputation on the line for a technology which is largely unproven. The Nextel network, which offers data throughput of 7.2 Kbps, is yet to be fully deployed [12-9].

Paging

The concept of a paging system to cover a local or metropolitan area was first introduced in 1950 in the New York, and involved proprietary solutions including the GOLAY standard from Motorola [12-8]. During the 1970s, the British Post Office (BPO) developed a standard set of code and signaling formats, which evolved into the POCSAG (Post Office Code Standardization Advisory Group) code. The POCSAG standard provides for transmission speed of 2400 bps, using bandwidth of 25 kHz. The CCIR (now ITU-R) standardized that code, internationally, in 1981. With the exception of the Japanese (not surprisingly), all developed nations have conformed to this standard. According to estimates from the Personal Communications Industry Association, at year-end 1995 there are well over 34 million pager subscribers, worldwide; it is estimated that there are over 27 million subscribers to over 2,000 paging services in the United States, alone [12-10] and [12-11].


Communications Systems and Networks:Wireless Networking: voice and Data

Paging Networks

Pagers generally operate over 25 kHz channels in the 900 MHz band. In 1984 the FCC dedicated 1 MHz of 40 channels in this band for nationwide paging purposes. Paging services are provided by RCCs (Radio Common Carriers) and PPOs (Private Paging Operators). RCCs are regulated by the FCC and the state PUCs, and make use of FCC-designated frequencies. PPOs are unregulated, but must share spectrum with other users in the VHF and UHF bands.

SkyPage and other paging network providers provide a VSAT satellite link to terrestrial paging networks, as shown in Figure 12.6. In this fashion, the local paging systems are networked in order that a page can be delivered across a wide area rather than only locally. Networking is also accomplished through leased lines and X.25 packet-switching.

Figure 12.6 Terrestrial paging network with satellite interconnectivity.

Paging Equipment

Pagers can be classified as tone-only, numeric, and alphanumeric. Tone-only pagers cause the device to emit an audible tone. Numeric pagers allow the receipt of numbers, only, on a display, whereas alphanumeric pagers allow the receipt of both alpha and numeric characters.

Two-way paging systems have been available abroad for years, but only recently have they been introduced in the United States by Destineer, MobileComm, PageNet, and others. Such pagers are alphanumeric, supporting the display of a message and return number (e.g., telephoner, pager). Additionally, the user can select and transmit a return message from a small set of predetermined messages. The return messages are also user-definable through an RS-232 serial link between the pager and a PC. The messages can be up to 50 characters in length [12-12] and [12-13]. Pagers have also been incorporated into other devices, such as watches (e.g., Seiko and Swatch) and cellular telephones. The Seiko pager/watches use the FM radio band, rather than standard pager frequencies.

Whether standalone or merged into another device, typical capabilities include some combination of alphanumeric display ([le]32 Characters), two-way communications, message storage ([le]231 messages), audible, and vibration alert, and fax receipt (in development). Additionally, several manufacturers offer PC Pager cards which fit into the PCMCIA (Personal Computer Memory Card Industry Association) slot of laptop PCs. They can also operate independently. All such cards are PCMCIA type II and do not require external power supplies. This approach effectively merges the wireless applications of two-way alphanumeric paging, computing, and email. The ability to receive an alphanumeric page through a wireless, laptop PC and to then respond with an email message is truly extraordinary. Although these developments are recent and not widely available, they clearly will achieve some significant level of acceptance in future as the workforce becomes increasingly mobile. Manufacturers of such PC Paging cards include HP StarLink, Motorola, Sony Electronics, and Toshiba.

Paging Applications

At the extreme, pagers currently support applications including message notification, information services, stock quotes, event information (1996 Olympics), and email.

Paging Developments

Motorola recently has floated a new set of proprietary solutions, which it hopes to see officially accepted as industry standards. Those solutions provide two-way messaging, support data transmission, and provide greater bandwidth, and include include FLEX (2,400 bps, 25 kHz), ReFLEX25 (6,400 bps, 25 kHz), ReFLEX50 (25.6 Kbps, 50 kHz), and InFLEXion (112 Kbps, 50 kHz; 240 Kbps, 100 kHz; supports voice).

International Paging

Paging in Europe is somewhat constrained by the lack of agreement on common standards, although the POCSAG standard is generally recognized, supporting transmission of 1200 bps and operating in the 150 to 170 MHz band. A pan-European digital paging system known as ERMES (European Radio Message System), supported by ETSI and the EC, is making progress. ERMES operates at 6,250 bps in the 170 MHz band and uses FSK as a modulation method.


Communications Systems and Networks:Wireless Networking: voice and Data

Cordless Telephony And Wireless Office Telecommunications Systems (WOTS)

Wireless Office Telecommunications Systems (WOTS) are adjuncts which provide cordless telephony communications capabilities behind PBXs, Electronic Key Systems, Hybrids, or Centrex. They generally are limited to voice applications, although some support low-speed data as well, typically using CDPD technology. WOTS systems involve a wireless master controller that is hard-wired to special ports on the PBX, KTS, Hybrid, or Centrex. As illustrated in Figure 12.7, the master controller, in turn, is hard-wired to subcontrollers and antennae that are distributed throughout the office complex or campus in a picocell configuration. The terminal equipment is in the form of wireless handsets, that are generally low in cost and limited in range. Some multifunction handsets exist, that can be used as traditional cellular phones when the user so desires [12-8].

Figure 12.7 Wireless Office Telecommunication System (WOTS) configuration.

Actually an extension and application of common cordless telephony, WOTS provides the advantage of mobility for select employees who must have the freedom to wander around the complex, but who must have communications capability at all times. The cost of WOTS currently is in the range of $1,000 per user, but with likely drop in the near future.

Cordless Telephony Standards

There exist multiple cordless telephony standards used to provide WOTS service including CT1, CT1+, CT2, CT2+, CT3, DECT, Part 15 and AMPS [12-14] and [12-15].

CT1 (Cordless Telephony Generation 1)
was developed in Europe, where it was known as CEPT-1. CT1 operates in the 900 MHz range over 40 channels; two separate channels are used, one for transmission and one for reception. CT1 is analog and low-cost, but limited in range. Manufacturers are numerous, including AT&T and Telenorma.
CT1+
a variation on CT1, was developed in concert by Belgium, Germany and Switzerland. CT1+ was intended as the basis for a public wireless service, along the lines of Telepoint. Although CT1+ was not successful, it did originate the concept of a Common Air Interface (CAI), which allows multiple manufacturers to develop products in support of a public cordless telephony service offering.
CT2 (Cordless Telephony Generation 2)
was developed in the U.K., where it formed the technology basis for the ill-fated Telepoint service. CT2 is a digital technology deployed in Europe, Canada, and the Asia-Pacific. While it originally supported only outgoing calling, contemporary implementations support two-way calling. CT2 uses FDMA and does not support hand-off; therefore, the user must remain within range of the antenna used to set up the call. CT2 uses 4 MHz of bandwidth divided into 40 channels—20 for transmission and 20 for reception. Dynamic channel allocation requires a frequency-agile handset. CT2 was the first international standard providing a Common Air Interface (CAI) for systems operating in the 800 MHz and 900 MHz bands. It is used in Canada and enjoys wide acceptance in Asia. Manufacturers include GPT, Multitone Electronics, Nortel (nee Northern Telecom), and SAT.
CT2+
is an improvement on CT2, supporting two-way calling and call hand-off. CT2+ uses 8 MHz of bandwidth in the 900 MHz range. CT2+ is based on dynamic channel allocation, requiring frequency-agile handsets. Encryption is supported for improved security. A common signaling and control channel offers improved call setup times, increased traffic capacity and longer battery life, as the handset must monitor only the signaling channel. CT2+ has been used in applications such as the Walkabout trial in Canberra, Australia.
CT3
developed by Ericsson in 1990, is designed for high-density office environments using TDMA. CT3 uses the same frequency bands as CT2+, supporting roaming and seamless hand-off. CT3 has application in a telepoint application (PCS), as well as in office applications (WOTS).
DECT (Digital European Cordless Telecommunications)
is the pan-European standard for digital cordless telephony, using TDMA. Ratified by ETSI in 1992, DECT operates in the 1880 to 1900 MHz frequency band that recently was set aside for that purpose in all EC member nations. Designed for high-density environments, DECT supports hand-off; the user can roam from cell-to-cell within the range of the WOTS system. Functionally, DECT is much like CT3. In addition to public cordless telephony, DECT supports wireless PBX, wireless LAN, and WLL. According to Northern Business Information and Datapro, the market for DECT-based WOTS will grow at 1 to 2 million extensions per year, solidifying DECT’s position [12-15]. Manufacturers include Alcatel, Ascom, Ericsson, Philips, and Siemens. DECT also is endorsed by ETSI for use in Wireless LANs in Europe.
Part 15
FCC frequencies are used in the United States by AT&T and others for the provisioning of WOTS. These unlicensed frequencies are in the 902 to 928 MHz range, also known as the SIM (Scientific, Industrial, and Medical) band. They, therefore, are subject to interference from industrial microwave ovens, barcode scanners, security systems, and other devices. The FCC set aside the 1.910 to 1.930 MHz spectrum for communications within buildings. At this writing, the spectrum remains to be cleared of existing microwave users. Manufacturers include AT&T, Ericsson, (Rolmphone 900) and SpectraLink.
AMPS (Advanced Mobile Phone System)
analog cellular frequencies are used in some U.S. systems, including Bell Atlantic Mobile (Office Direct) and Southwestern Bell Mobile Systems (FreedomLink). Manufacturers include Panasonic.
PCS
frequencies in the 1910-MHz to 1930-MHz band are used by some manufacturers, including Nortel. These frequencies were recently set aside by the FCC for use in private PCS applications, and do not require licensing [12-16].


Communications Systems and Networks:Wireless Networking: voice and Data

Cellular Radio

The basic concept of cellular radio dates back to 1947, including numerous, low-power transmit/receive antennae. Scattered throughout a metropolitan area, such an architecture served to increase the effective subscriber capacity of SMR/TMR radio systems, by breaking the area of coverage into small cells. Thereby, each frequency could be reused in non-adjacent cells. Additionally, the cells could be split, or subdivided, further as the traffic demands of the system increase; in other words, the network was highly scaleable. Traditional cellular radio, it should be noted, involves a circuit-switching mode.

This original concept is the basis of cellular radio, which first appeared in Chicago on October 13, 1983. AT&T operated that network for exactly 79 days, when the MFJ took effect. At that point a subsidiary of Ameritech assumed ownership [12-2]. By 1984, the Chicago network already was saturated in some cells and cellular telephones were in the hands of 91,600 people, growing to 19 million by 1994 [12-3] and [12-2]. Multiple low-power transmit/receive antennae are distributed throughout a geographic area, with each cell site having a relatively small, circular area of coverage (Figure 12.8). The coverage of the individual cells overlap with those of neighboring cells, with a minimum cell diameter of one mile and a maximum of about five miles [12-7]. As the terminal device moves from out of the effective range of one cell, the call is switched from cell antenna to another through a process known as hand-off, in order to maintain connectivity at acceptable signal strength. The hand-off is controlled through a MTSO (Mobile Traffic Switching Office) or MTSX (Mobile Traffic Switching Exchange), which is the functional equivalent of the PSTN Central Office. The MTSO also provides access to the PSTN, usually via leased lines. Further, the MTSOs are interconnected, either through the PSTN or through private microwave or leased-line facilities.

Figure 12.8 Cellular network with Mobile Traffic Switching Office (MTSO) connected to PSTN.

The process of hand-off uses a break and make approach. The connection with one cell site antenna is broken before connection is reestablished with another preselected cell site. As the duration of the break is very short, it is not noticeable in a voice communication. It, however, renders data communications difficult, at best.

Each cell site supports a limited number of frequency channels in order to take advantage of frequency reuse. For instance, U.S. analog AMPS networks divide 333 frequencies among cell sites, with the average cell site supporting 57 channels. In order to improve the performance of the network by reducing crosstalk, the original omnidirectional antennae were replace with a vectored version. Vectoring involves three vectors, each with coverage of 120 degrees. Splitting the frequencies into three vectors had the unfortunate effect of reducing by two-thirds the number of channels available to any given user in the cell site. As a result, more cell sites of smaller size were required, which entailed additional cost in the range of $500,00 to $1 million per site. Additionally, and for aesthetic reasons, many cities and towns are placing moratoria on the construction of new antennae sites. Metawave Communications and others are developing a solution in the form of antenna which divide the area of coverage into multibeam antennae to support all 333 channels on the basis of 12 beams, each with a 360 degree sweep. The smart antennae communicate continuously with the MTSO in order that channel allocation is managed cell-by-cell and on the basis of the network as a whole, based on shifts in traffic patterns [12-17].

Cellular Standards

Cellular standards are numerous and, as they vary along national lines, are incompatible. Standards include both analog and digital solutions with the clear trend toward digital. Digital systems offer the advantages of improved error performance and improved bandwidth utilization through compression. Digital systems also support data communications much more effectively.

Analog Cellular

Analog cellular was the first approach and still is the most prevalent, given its widespread implementation in the early years. Analog standards include AMPS, N-AMPS, TACS and NMT [12-15].

AMPS (Advanced Mobile Phone System)
was developed by Motorola and AT&T and is used in the United States. It is an analog technology operating on 50 MHz in the 800 MHz band and supports 666 channels split into 30-kHz voice channels, one each for forward and reverse communications. In the United States, 25 MHz and 333 channels each are provided to the wireline carrier (telephone company or telephone company consortium) and nonwireline carrier. Because it is based on FDMA, and FDD transmission, AMPS does not handle data well, with transmission generally being limited to 6,800 bps. Although widely deployed in the U.S., Australia, The Philippines and other countries, AMPS is rapidly giving way to digital technology.
N-AMPS (Narrowband AMPS)
also developed by Motorola, enhances the performance of an analog AMPS system. System capacity is improved by splitting the 30-kHz channels into three 10-kHz channels, thereby tripling AMPS capacity. While N-AMPS has not been widely deployed, it is used by some U.S. carriers. Motorola equipment is required.
TACS (Total Access Communications System)
is a derivative of AMPS developed for use in the U.K. in the 900 MHz band. At this higher frequency, more native bandwidth is available; therefore, TACS supports up to 1,000 channels, compared with the 666 supported by AMPS. TACS has found acceptance in very few nations, and it is not considered to be a long-term technology solution. JTAC (Japanese Total Access Communications System) is a TACS variation, operating in the 800 to 900 MHz ranges.
NMT (Nordic Mobile Telephone)
was developed and placed into service in the early 1980s in Scandinavian countries including, Denmark, Finland, Norway, and Sweden. NMT 450 operates in the 450 MHz range, which yields excellent signal propagation. Therefore, it is especially appropriate for sparsely populated areas supported by few cell sites. NMT 450 has found little acceptance outside of the Scandinavian countries. NMT 900 operates in the 900 MHz range, and is appropriate for more densely populated areas. NMT 900 has found acceptance in certain countries in Asia, as well as the Nordic countries, although it is not considered to be a long-term technology.


Communications Systems and Networks:Wireless Networking: voice and Data

Digital Cellular

Digital cellular standards clearly will dominate the cellular radio world into the future. Current digital standards include JDC, USDC and GSM, with GSM clearly being the dominant. As one might expect, most digital standards, including GSM, are based on TDMA and TDD.

JDC (Japanese Digital Cellular)
operates in various frequency bands in the 800 MHz, 900 MHz, 1400 MHz, and 1500 MHz ranges. It has not found acceptance outside Japan, with the exception of a few Asian countries under Japanese economic influence.
USDC (United States Digital Cellular)
was developed as a standard by the TIA (Telecommunications Industry Association) subcommittee TR 45.3. Operating in the 800 MHz band, USDC has not found broad acceptance and likely will not survive.
GSM (Global System for Mobile Communications)
was adopted by the CEPT in 1987 as the standard for European cellular. GSM operates in the 800 MHz and 900 MHz frequency ranges and is ISDN-compatible. GSM offers additional security in the form of a Subscriber Identification Module (SIM), which plugs into a card slot in the handset, much as a PCMCIA card fits into a laptop computer. The SIM contains user-profile data, a description of access privileges and features, and identification of the cellular carrier in the area of home registry. The SIM can be used with any GSM set, providing complete mobility across nations and carriers supporting GSM (assuming cross-billing relationships). Clearly, GSM will emerge as the international standard of choice. GSM is in place, and is predominant throughout Europe and much of Asia, supporting full roaming privileges from country-to-country. While some U.S. cellular carriers are trialing GSM, it is not being deployed aggressively in this country—that is to the disadvantage of U.S. users.

The Future of Cellular Radio

According to Global Telecoms Business there are now over 35 million cellular subscribers in more than 150 countries. Cumulative growth rates are more that 30% per year. The United States market grew by almost 50% in 1993 and by 325% in Pakistan. They go on to say that wireless now accounts for nearly 50% of Ericsson’s sales, compared to a mere 6% in 1984. Although worldwide cellular penetration currently stands at about 0.8%, estimates are that it will grow to incredible levels. Lehman Brothers, for example, estimates cellular penetration of 9.4% by the year 2000; that equates to 105 million users of a total accessible population of 1.1 billion[12-18].

In order to achieve that level of penetration, cellular rates for airtime must be reduced. With pressure from PCS/PCN and other technologies during the next decade, that is likely to be the case. Merrill Lynch estimates that rates may drop as much as two-thirds during the next ten years, from the current average of $0.45 to $0.15 by 1994. Nonetheless, GSM licenses in Europe fetch prices in the range of $100 million; AirTouch Communications CFO Chris Christensen is quoted as forecasting that its European GSM investments will hit cash flow break-even in three to four years and will hit income break-even in five years.

Cellular radio is big business, to say the least. AirTouch spun off from Pacific Telesis (Pacific Bell and Nevada Bell) in 1993, with the IPO (Initial Public Offering) raising $1.25 billion. In 1993, pre-tax profits were estimated at $108 million on revenues of $1.2 billion. Subsequently, AirTouch formed a joint venture with US West, effectively merging the two networks in order to reduce overheads, increase the footprint and combat the competitive threat of PCS. The spin-off of Airtouch yielded multiple benefits to PacTel. First, it relieved pressure from the California regulators, who became increasingly concerned about the same holding company owning such a profitable nonregulated subsidiary—PacTel was concerned about the PUC making demands for the cellular business to help subsidize the regulated business. Second, it allowed the public offering, which provided sorely needed cash to PacTel. Third, it allowed the merger of AirTouch with US West. Finally, it cleared the way for PacTel to bid for PCS licenses in its franchised serving areas, which was not allowed for telephone companies holding cellular licenses in the same geographic area.

Cellular Data Communications

Cellular data communications is difficult at best, as the analog FM networks are not designed to support data, certainly not at speeds above 9.6 Kbps. Given the high error rates typical in cellular networks, the data protocol must allow for repeated transmissions of errored and lost data packets, thereby lowering throughput to the range of 1200 bps. Additionally, radio modems must be used in order to interface the computer to the cellular CPE and, in turn, to the network. While a number of manufacturers have developed PCMCIA cellular modems which operate at speeds up to 28.8 Kbps (cost ???@ $500) [12-19], throughput is much less. Digital cellular systems improve on the analog approach, offering all of data communications advantages enjoyed in the wired world. Those advantages include more usable bandwidth, improved error performance and, therefore, enhanced throughput.

In either event, data over cellular networks suffers from the same issues that affect cellular voice, only much more so. For instance, the break and make connection technique used in cellular networks has a very deleterious impact on data communications. Additionally, signal fade affects communications as the terminal moves farther from the cell site, especially at high speed. To compensate for these factors, cellular modems must employ the most robust error correction protocols.

In support of data communications over AMPS cellular networks, several manufacturers recently (January 1995) unveiled data-ready cellular phones. Some of the devices have their own keypads, while others connect to a laptop PC for data entry. Display screens vary in size from 16 to 160 characters. In addition to support for voice and short message service, they will support Internet access, facsimile, and email [12-20].


Communications Systems and Networks:Wireless Networking: voice and Data

Circuit Digital Packet Data (CDPD)

Circuit Digital Packet Data (CDPD) is the data communications technique most commonly trialed and deployed in U.S. cellular networks, although it has not taken hold outside U.S. borders. Based on TCP/IP, CDPD operates over existing AMPS networks in the 800 MHz band, although substantial additional carrier investment is required to implement the technology. CDPD is intended to take advantage of the natural idleness in cellular networks in between disconnections and connections, and during the break and make process—even heavily used cellular networks are said to be idle approximately 20% to 30% of the time. CDPD uses these periods of idleness to transmit packetized data at rates up to 19.2 Kbps, using connectionless protocols including either the Internet Protocol (IP) or OSI Connectionless Network Protocol (CLNP) [12-21]and [12-22]. WAN connectivity is through the traditional AMPS cellular networks, as well as through the separate CDPD internetworks.

CDPD modems are frequency-agile, searching for available channels over which to send encrypted 128-byte packets, which contain a destination address, source address, sequence number and payload [12-3]. PCMCIA modems are in development to replace the external modems currently required. The contention method is DSMA/CD (Digital Sense Multiple Access/Collision Detect), which is much like CSMA/CD used in Ethernet LANs. CDPD operates at Layers 1 and 2 of the OSI Reference Model, providing access to Layer 3 protocols IP or ISO Connectionless Network Protocol (CLNP). As a result of its IP-based design, applications such as Netscape and Mosaic can run on top of CDPD in order to provide access to the Internet and World Wide Web.

CDPD was formalized in July 1993 by the Cellular Digital Packet Data consortium, which comprises Ameritech Cellular, Bell Atlantic Mobile (BAM), CONTEL Cellular (now GTE Mobilnet), GTE Mobilnet, McCaw Cellular Communications, NYNEX Mobile Communications, PacTel Cellular (now AirTouch), and Southwestern Bell Mobile Systems. The CDPD Forum, established in June 1994, intends to promote the commercialization of products and services. CDPD service was available in most of the 50 U.S. markets by year end 1995. CDPD is being trialed by all of the companies in the CDPD consortium, although interconnection is not provided (read no roaming).

Third-party application developers have recently announced the availability of a number of CDPD applications, including LAN access, host access, call management and voice processing, credit card verification, check verification, and vehicle tracking and dispatch [12-23]. In a cellular radio application, costs for CDPD include activation charges, which can be in the range of $45; monthly charges in the range of $15 to $125; and usage charges currently based on some combination of minutes of usage, packets and kilobytes, whether calls are incoming or outgoing [12-24], [12-25], and [12-26].

Wireless Data Networks: Packet Radio

Data-specific wireless networks have been deployed in the United States during the last several years, with coverage of virtually all major metropolitan areas using the 800 to 900 MHz radio bands [12-3]. Such networks offer data communications to data-intensive users using proprietary packet protocols; integrated messaging service is supported, as well. Applications include sales agents, maintenance and truck fleets. Providers include RAM Mobile Data, Ardis, and Metricom—these companies face competition from Destineer Corp., Nextel Communications and Geotek Communications. Charges generally include a setup charge and a cost per packet, which can vary by packet size. Package plans are also available.

RAM Mobile Data (NY) was formed in 1988 by RAM Broadcasting Corporation; BellSouth acquired a 49% stake in 1992. RAM operates its nationwide Mobitex service using 200 channels in the 900 MHz band, each channel offering throughput of 8 Kbps. At year end 1994, RAM claimed to have a presence in 216 metropolitan areas and 7,500 U.S. cities, covering 90% of the population [12-27]. RAM cities are interconnected through the RAM packet data backbone, with planned WAN access through X.25 and other options. Major users include Kodak and Unisys [12-3].

ARDIS (IL), formerly known as Advanced Radio Data Information Services, was formed in 1990 as a wholly-owned subsidiary of Motorola, merging the IBM Network and Motorola Data Radio Network. ARDIS builds on the foundation of a network originally designed for IBM in 1983. ARDISnet operates over 600 channels in the 800 MHz band and offers throughput from 4.8 Kbps (nationwide) to 19.2 Kbps in selected cities. While the 4.8 Kbps service makes use of a proprietary protocol (Motorola Data Protocol or MDP), 19.2 Kbps service is based on RD-LAP (Radio Data-Link Access Protocol). ARDIS claims to have reached over 10,700 cities in 400 U.S. metropolitan areas as of year end 1994 [12-27]. WAN access is provided through PDNs (Public Data Networks), as well as the ARDIS packet data backbone network. CSX Transportation, a railroad operator, is a major user [12-3].

Metricom offers Ricochet, which provides data transmission at 77 Kbps in the unlicensed 902 to 928 MHz band using spread spectrum technology. Ricochet uses a mesh of low-power, microcellular radio sites in the San Francisco Bay Area, Seattle, Boston, Houston and other major cities. WAN connections are provided through asynchronous modems or via The Internet.


Communications Systems and Networks:Wireless Networking: voice and Data

Wireless LANs

As discussed in some detail in Chapter 9, Wireless LAN technology has enjoyed modest success in the LAN world during the last few years. Offering the obvious advantage of no wiring costs, Wireless LANs can be deployed to great benefit in a dynamic environment where there is frequent reconfiguration of the workplace. They also offer clear advantages in providing LAN connectivity in temporary quarters, where cabling soon would have to be abandoned. Wireless LANs are largely based on spread spectrum technology refined in World War II for use in radio-controlled torpedoes. This approach offers significantly increased security and throughput [12-3].

Standards are not yet entirely formalized, although the IEEE is examining the development of standards through the efforts of the 802.11 Working Group, which began its efforts in 1989. The emerging standard initially will aim at throughput of 2 Mbps [12-28]. Wireless LANs operate in three distinct radio frequency ranges, as well as on an infrared basis.

902 Mhz to 928 MHz are unlicensed ISM (Industrial, Scientific, Medical) frequencies. This approach avoids expensive and lengthy licensing by the regulatory authorities, but carries the potential for interference from other such systems in close proximity. As this frequency range was set aside by the FCC for unlicensed communications within buildings, such systems are susceptible to interference from other systems including cordless telephones and barcode scanning systems. Spread spectrum technology is generally used at these frequencies to mitigate issues of interference. Because power levels are low, distances generally are limited to 500 to 800 feet. Manufacturers include California Microwave, NCR and Proxim.

2.4 GHz-2.5 GHz and 5.8 GHz-5.9 GHz microwave systems using spread spectrum technology are also permitted to operate without licensing at low power levels and over limited distances. Manufacturers include Western Multiplex Corp. and Xircom. Many of the systems that use licensed frequencies in this range avoid the potential for interference, but do require that the manufacturer carefully police the deployment of such systems under the terms of an omnilicense. Alternatively, these frequencies can be used without licensing, if they are low-power and use spread-spectrum coding.

18 Ghz to 19 GHz are sometimes employed in a wireless LAN environment at low power levels. The same frequencies are used in commercial microwave systems offering the potential for interference unless spread-spectrum coding is employed. Manufacturers include Microwave Radio Corp. and Motorola.

Infrared light systems require no licensing. The potential for interference between systems is very limited and line-of-sight is required. Transmission rates of 4 Mbps are common, with some systems providing transmission of 10 Mbps and 16 Mbps. Typical applications include interbuilding connectivity. Manufacturers include A.T. Schindler Communications, InfraLAN Technologies, Laser Communications, Radiance Communications, and Spectrix Corp.

Wireless LANs: Applications and Futures

While Wireless LANs have gained a foothold in United States, their future is less certain elsewhere. Traditionally, DECT has been endorsed by ETSI as the standard, providing up to 1.14 Mbps. However, the 2.4 GHz (U.K.) and 18 GHz (Germany) bands are also being promoted. The concern of ETSI and the EC seems to be that the use of these frequencies will favor U.S. manufacturers.

An interesting application for Wireless LANs is that of certain grocery stores in northern California. Some shopping carts are equipped with wireless terminals which communicate with servers through hub antennae using unlicensed frequencies and spread-spectrum technology. The shopper can key into the terminal the general categories of items on the shopping list and be guided through the store with the aid of a map displayed on the terminal screen. Scattered throughout the store are special in-store coupon offers that can be accepted through wireless acknowledgement. Once the shopper reaches the checkstand, the coupon acknowledgement is communicated to the intelligent point-of-sale device (cash register) and is credited against the purchase, without any paper changing hands.

Wireless Local Loop (WLL)

The worldwide local loop market is estimated at $100 billion, most of which is still twisted-pair. The low cost of installing and maintaining Wireless Local Loops is likely to position it as a strong competitive threat into the future. Nortel (nee Northern Telecom) estimates that the cost of copper local loops in North America ranges from $1,200 to $1,300 per residence, and can run as high as $5,000 where terrain is especially difficult or where population density is low. Nortel also estimates that WLL can be provided for no more than $900 per subscriber, with the added advantages of much more rapid deployment and much lower operating costs (25% less than copper), which include repair, reconfiguration, and loop testing.

As discussed briefly in Chapter 10 and illustrated in Figure 12.9, a WLL configuration involves either wired or microwave links to the Central Office from the low-power, omnidirectional antennae. Each antennae covers a relatively small geographic area, such as a neighborhood. Multiple channels are provided through frequency separation and time division multiplexing. The channels can be narrowband in support of voice-grade services, or can be as large as T1 in support of PBX trunking.

Figure 12.9 Wireless Local Loop (WLL) configuration.


Communications Systems and Networks:Wireless Networking: voice and Data

WLL Field Trials and Implementations

Wireless Local Loop is a technology with more than just promises to offer—it has true and legitimate application. WLL is used in Sri Lanka, Ghana, Columbia, Indonesia, India, Spain, and other developing countries, where recent and strong commitments have been made toward the goal of universal service. In such an environment, speed of deployment is of great importance. Additionally, subscriber sparsity, unfriendly terrain, and difficult weather conditions often make the deployment of wired networks problematic.

Current and planned field trials and actual implementations are numerous, both in the United States and abroad. Of particular interest is the planned application of WLL by new entrants in the now competitive local service arena. In competition with the incumbent LECs, the new providers will have three alternative means of connecting to the user. First, they may lease local loop facilities from the LECs. While the terms and conditions under which this will take place have yet to be determined, they likely will not be pleasing to either party. Second, new wired local loops can be deployed. This approach likely will make sense only where there exists dense populations of significant business customers. Third, WLL networks can be implemented rapidly and and with relatively inexpensive ongoing operational costs.

Southwestern Bell (U.S.) currently is testing a Motorola system using low-power WLL in suburban areas. The system will provide the last 1,000 ft. or so of the local loop. Southwestern Bell expects to see cost savings of greater than 90%.

US West (U.S.) plans to test TDMA alternatives in rural areas, including those surrounding Billings, Montana; Taos, New Mexico, and Fort Collins, Colorado using equipment from SR Telecom. The company intended to have some level of infrastructure in place during the first half of 1996 and to expand coverage rapidly through 1997.

BellSouth (U.S.) plans to test (1996) a system it calls Wireless ISDN (WISDN), which it expects to reduce the cost of provisioning by 20%.

WinStar Telecommunications Group (U.S.) is offering broadband wireless service in 28 cities. Operating in the 38 GHz band, the system delivers service at distances up to five miles. It is intended for use in AAV and IXC bypass, as well as campus networking applications. The WinStar system also has potential for PCS applications. WinStar systems also have been in trial by Mercury Communications (UK) and Deutsche Telekom (Germany).

Ionica (UK) was formed in 1991 and granted a national license in 1993; investors include Telecom Finland, Yorkshire Electricity, Northern Electric, and Robert Fleming Investment Trust. The initial roll-out (1995) covered two regions and a population of up to 10 million; ultimately, the company expects to capture up to 5% of the local loop market with revenues up to £200 million. Ionica also is actively considering opportunities in Mexico and throughout Latin America.

Millicom International Cellular (Luxembourg) holds stakes in 24 cellular licenses and is highly profitable. Liberty Communications, its UK subsidiary, is positioning to gain a WLL license in the UK, with investment expected in the range of $200 million to provided two-way broadband WLL.

Telecom Finland plans a WLL network rollout in 1996. The company expects to take up to 30% of the market from the incumbent carrier over a period of five years and to reach profitability in three years.

Telekom Malaysia plans to increase its subscriber density from 11% to 25% by 2000, largely through WLL. Telekom Malaysia intends to support 40,000 subscribers by the end of 1995.

Grupo Iusacell (Mexico) operates cellular services in Mexico, with revenues of over $300 million. WLL plans include Mexico City, which was targeted for initial, limited deployment in 1995. The company expects to invest over $800 million for a national roll-out, once the incumbent carrier’s monopoly expires in 1996.

Bakrie Brothers Electronic Company (Indonesia) is planning to invest $80 million in a WLL network to be offered by its subsidiary, Ratelindo, in which the incumbent carrier has a 45% interest. More than 500,000 WLL lines were planned to be in service by yearend 1995.

Personal Communications Services (PCS)

Personal Communications Services (PCS) is the U.S. term for the Personal Communications Network (PCN) concept originally developed in the U.K. PCS is a service concept that is technology-dependent and that operates on a set of frequencies set aside for its purpose. PCS ultimately intends to provide a full range of enhanced services through a single device utilizing one telephone number, which will work anywhere and anytime, for life. The U.S. International Trade Commission estimates the U.S. PCS market will reach $30 to $40 billion by 2000 [12-29]—pretty optimistic for a technology-based service offering which is totally unavailable at the time of this writing! It is estimated that the buildout of the U.S. PCS networks will require capital investment of approximately $12 to $20 billion over the next decade [12-7] and [12-30]. Widespread PCS availability is expected in the 1998/1999 timeframe [12-31].


Communications Systems and Networks:Wireless Networking: voice and Data

PCS Networks

PCS networks will be fully digital in nature, with the various providers most likely making use of TDMA or CDMA access and coding technology [12-7]. For example, Sprint, Bell Atlantic, and US West have embraced CDMA; AT&T, BellSouth and Southwestern Bell are committed to TDMA, citing the immaturity of CDMA [12-32], [12-33] and [12-34]. GSM (TDMA-based), or DCS 1900 (a GSM derivative) will likely be the PCS technology of choice in most countries, although analog networks will be supported during the transition to digital. Pacific Bell, by the way, also chose DCS 1900, thereby adding to the confusion because of the issue of incompatibility [12-35].The networks will be based on microcell configurations, supporting large number of stationary or slow-moving users. Signaling System 7 is an intrinsic element of PCS. In addition to improved call setup times, SS7 is the technology that will deliver enhanced features such as selective call forwarding, call blocking, call trace, and Calling Line ID (CLID).

While the spectrum allocation will vary by country or region, the designated U.S. frequencies include Narrowband, Broadband, and Unlicensed PCS spectrum. Actually, much of the PCS spectrum was already spoken for by high-band microwave systems. Clearing that spectrum is the responsibility of the PCS licensees, at an estimated cost of at least $70 million [12-3]. For the first time in U.S. history, the PCS spectrum was auctioned (and re-auctioned in some cases, after default on downpayments) by geographic area. The 1995 auctions of two frequency blocks brought in $7.7 billion, and the 1996 auctions are expected to account for another $6 billion or so [12-36].

Unfortunately, the competing PCS providers are not expected to provide interconnectivity, except through the PSTN, much as is the case with cellular providers. Additionally, different technologies will be deployed in support of PCS, from region-to-region. This translates into a lack of portability, or roaming capability; in other words, the PCS terminal used in San Francisco may not be able to access a PCS network in Dallas.

Narrowband PCS

Narrowband PCS has been allocated spectrum in the ranges of 900 to 901 MHz, 930 to 931 MHz, and 940 to 941 MHz. That spectrum will be used to extend the capabilities of pagers to include acknowledgement paging, two-way messaging and digital voice.

Broadband PCS

Broadband PCS is allocated 120 MHz in the 1850 to 1990 MHz range. This spectrum will deliver next-generation wireless communications including WLL, voice and data services, and cellular-like services for pedestrian traffic in high-density areas. [12-31]

Unlicensed PCS

Unlicensed PCS spectrum will serve Wireless LANs, wireless PBXs, and PCS voice and data services within a building or campus environment. Unlicensed PCS spectrum has been set aside in two ranges. Bandwidth of 20 MHz in the 1.900 GHz to 1.920 GHz range will be used by asynchronous devices such as PDAs. Additionally, 20 MHz, split into two 10 GHz bands, is set aside in the 1.890 GHz to 1.900 GHz range and the 1.920 GHz and 1.930 GHz range. This spectrum is set aside for isochronous voice communications [12-3].

PCS Equipment

PCS equipment will take a variety of forms, including PDAs, PCS telephones, and enhanced pagers. Many devices will be dualmode—for example, a PCS/Cellular telephone. Such a telephone might incorporate a built-in pager. As PCS is based on microcell architecture, the devices will be low-power and, therefore, lightweight and low cost. Even though the batteries will be much smaller than those found in contemporary wireless devices, developing battery technology is expected to yield much longer battery life. Most PCS devices will be cordless telephones, which will work exactly like a contemporary cordless telephone when the user is at home or at the office. They also will offer mobility, so that the user can make and take calls on the move. The size and weight are expected to be such that they truly will be pocket-size.

PCS Services and Applications

PCS promises to offer a wide range of services and applications at a wireless level. The most common application will be that of voice communications on a basis similar to cordless telephony. Through the use of an inexpensive, low-power handset, the user will be able to both originate and receive calls within the provider’s area of coverage, as long as he is within the limited range of the antennae. Additionally, the user can be mobile, although not at a high rate of speed. PCS is designed to support stationary or slow-moving pedestrian traffic, whereas cellular telephony is provided in support of high-speed vehicular traffic, as well.

Enhanced paging will be supported, ultimately through multifunction terminal equipment. Such pagers will support short message service, ultimately transmitted from a personal computer through the network and received on a small display built into the PCS terminal. The next step in this applications evolution is the ability to receive email through wireless access to the Internet or a corporate email server. Taking the scenario one more step, wireless database access will be supported, as will a limited level of wireless computing. Although with limitation, Personal Digital Assistants (PDAs) presently provide such capabilities through wireless access to packet radio networks. In all likelihood, PDA connectivity will be a function of PCS networks, which will provide better coverage than do the current proprietary packet radio network providers [12-37] and [12-38].

Ultimately, PCS is expected to provide multimedia communications, even incorporating slow-scan video at perhaps 7 to 10 frames per second. It also will support facsimile and Group III speeds or higher. Radio-determined vehicle locations will be provided, and smart terminals will provide maps and instructions to the destination, with constant adjustments based on dynamic traffic conditions.


Communications Systems and Networks:Wireless Networking: voice and Data

Low-Earth Orbiting Satellites (LEOs)

Low-Earth Orbiting and Middle-Earth Orbiting satellites (LEOs and MEOs) are satellites which operate at low altitudes of several hundred miles in a variety of orbits, as compared to Geosynchronous Earth Orbiting satellites (GEO), which were discussed in Chapter 3. LEOs and MEOs are systems of satellites that are configured as constellations of small, low-power satellites. In combination, they provide full coverage of major land masses. Designed to provide wireless voice and data communications to remote areas and to mobile users, the various proposals include from 12 to 840 satellites. These systems are also known as Mobile Satellite Systems (MSSs), as opposed to the Fixed Satellite Systems (FSSs) in geostatic orbit.

Whizzing around the earth like electrons whizzing around the nucleus of an atom (Figure 12.10) , LEO and MEO networks are designed so that a satellite is always within reach of a terrestrial terminal. Once a connection is established between terminal and satellite, the satellites communicate directly to pass the call to the satellite closest to the target terminal, which completes the connection. The concept was conceived by Motorola, which named its proposed 77-satellite constellation Iridium, after the element iridium, which boasts 77 electrons whizzing around its nucleus. Subsequently, the proposal was pared down to 66 satellites, although the name Iridium stuck. (After all, Iridium seems to roll off the tongue better than Dyprosium, the rare earth element with an atomic weight of 66.)

Figure 12.10 Low-Earth Orbiting (LEO) satellite constellation.

Estimates are that the total satellite market could reach $50 billion by 2005. If LEOs and MEOs could capture just 5% to 10% of that market, the rewards could be incredible. The costs, however, are not low; terminals are expected to cost approximately $3,500, and airtime will be in the range of $3.00 per minute. The costs of the proposed networks range from $2.6 billion(Inmarsat) to $9 billion(Teledesic).

LEO networks are defined in two categories. Little LEOs operate in the 2 GHz (S-band) range and are intended to support voice and other PCS services. Big LEOs operate in the 1.5 Ghz to 1.6 GHz (L-band) and 2.4 GHz (S-band) range and are intended specifically for voice and data communications. Table 12.2 provides a sense of some of the more significant LEO and MEO proposals.

Table 12.2 Example proposed LEO and MEO constellations
PRIMARY COMPANY/CONSORTIUM | PROJECT | CONSTELLATION SIZE
American Mobile Satellite Corp. | AMSC | 2
Calling Communications Corp. | The Calling Network | 840
Celsat America | Celstar | 2
Constellation Corp. | Aries | 48
Ellipsat | Ellipso | 24
Inmarsat | Inmarsat P | TBD
Loral Qualcomm | Globalstar | 48
Motorola | Iridium | 66
TRW | Odyssey | 12

Selected projects, backers and estimated costs are as follows:

• Iridium (Motorola, BCE, Veba, et al), $3.4 billion
• Teledesic (McCaw Cellular and Microsoft), $9 billion
• Globalstar (Loral Qualcomm, AirTouch, Dacom, Vodafone, et al)
• Orbocomm (Orbital Science Corp., Teleglobe, TRI, et al)
• Inmarsat (BT, France Telecom, KDD, Norwegian Telecom, et al), $2.6 billion
• AMSC (American Mobile Satellite Corp.), $870 million
• Celsat (Celsat, Inc., Cellular Communications Inc.); $220 million per satellite, plus launch [12-39], [12-40], [12-41], [12-42], [12-43].

Personal Digital Assistants (PDAs)

Personal Digital Assistants (PDAs) are multifunction wireless devices that were first conceived by Apple Computer and appeared on the market in the mid-1990s [12-44]. Although the concept is an intriguing one, PDAs have met with very little market acceptance at the time of this writing. Assuming that they live to tell the tale, PDAs may achieve some reasonable level of success in the early twenty-first century, likely through PCS networking.

PDA Equipment

PDAs are lightweight (13.6 oz. to 1.8 lbs.) wireless devices that communicate via infrared transmission or various radio frequencies. Current costs are in the range of $500 to $1,500, depending on manufacturer and configuration options. As a result of disappointing sales, costs have dropped over the last few years. For example, Sony reduced the price of its Envoy PDA from $995 to $499 in August 1995. Proprietary operating systems are employed and Graphic User Interfaces (GUIs) are standard. Data entry is via a combination of handwriting and soft keys, with some devices supporting external keyboards. The devices will accommodate 1 or 2 PCMCIA cards for wireless networking, with most also supporting infrared communications. The PCMCIA slot(s), of which there are 1 or 2, support wireless modems, flash memory, applications and attachable keyboards. Manufacturers include Apple (Newton), BellSouth (Simon), Motorola (Marco), Sharp (Zaurua), and Sony (Magic Link and Envoy).

PDA Networking

PDAs are networked through the use of modems, which may be either external or in the form of a PCMCIA card. Wireless messaging/paging services are provided through PDA-specific network vendors including Apple Notification Service, SkyTel, MobileComm, and Motorola NewsCard. Transmission rates vary from 2.4 Kbps to 14.4 Kbps, although throughput generally is much less.

Networking, on some PDAs, is also supported via access to data-specific networks such as those offered by ARDIS, Metricom, RAM, and Mobile Data [12-44]. Some also provide for connectivity to cellular networks, through an external adapter. Additionally, some may be connected to the PSTN through an RJ-11 connection. Connectivity to desktop computers, LANs and printers is provided through internal or external wireless radio adapters, or via infrared technology.


Communications Systems and Networks:Wireless Networking: voice and Data

PDA Functions and Applications

PDAs are intended to perform a wide range of functions in support of personal and business use, hence the term Personal Digital Assistant. Current functions include handwriting recognition and handwriting-to-text conversion. These functions, coupled with limited data networking capabilities, offer excellent support for sales and delivery people. Federal Express and other delivery companies use such devices to great advantage.

Extending these functions a bit further, PDAs also can be used for email access, facsimile networking, and access to ISPs and then to the Internet. The information contained in the PDA, perhaps downloaded from the Internet or from a facsimile server, can be uploaded via an infrared link or hardwired line to a workstation, which may be LAN attached. The devices also typically provide calendaring and scheduling applications. They generally support the management of to-do lists, as well.

PDA Advantages and Disadvantages

The advantages of PDAs certainly are their inherent small size and weight, which translate to portability and mobility. The capability to recognize handwriting is of great value in sales and delivery applications. Even though their functionality is limited, they are multifunctional and serve well in niche applications.

On the negative side, the handwriting recognition capabilities generally are poor, typically recognizing only block printing. There is little third-party application support, as the market is so limited and sales have been so weak, the operating systems are proprietary and the horsepower (processing power) is limited. Additionally, the size and weight of the devices are not small enough for them to be considered truly portable in comparison to a pager or cellular phone. Given these factors, as well as their relatively low functionality and high cost, they are not seen as likely replacements for laptop computers, cellular phones, and other single function devices that can be used either alone or in combination.

PDA Futures: Gadgets in Search of a Market?

The future of the PDA is uncertain, at best. The market is ill-defined and the costs are high. Additionally, the functions are not of sufficient breadth or depth to replace other devices, such as laptops and cellular phones. While PDAs may continue to build niche markets for order-taking and other applications, it is highly unlikely that serious business professionals will cheerfully lug one more device around, almost regardless of the cost. However, BIS Strategic Decisions forecast that about 150,000 units would be purchased in 1995 [12-45]. Forrester Research was more optimistic, forecasting that 373,000 units would be sold in 1995 and that 1999 sales would reach 4.8 million units for revenue of $1.5 billion [12-46].

In the meantime and in a desperate attempt to bolster sales, the manufacturers have increased advertising and hired college students to play with the devices at computer stores. They also have lowered prices significantly since introduction. For example, the Motorola’s Envoy has dropped from $1,695 to $1,000; Apple’s Newton MessagePad 120 from $1,000 to $599 and Sony’s Magic Link from $995 to $499 [12-46] and [12-47]. Even these measures have not been enough. In August, 1995, Motorola Corp. (Envoy and Marco PDAs) announced the layoff of about 180 employees. AT&T stepped away from EO, Inc., a new company formed to develop PDA technology; EO subsequently ceased operations.

References

[12-1] Brooks, John. Telephone: The First Hundred Years. NY: Harper and Row. 1975.
[12-2] Calhoun, George. Digital Cellular Radio. Norwood, MA: Artech House. 1988.
[12-3] Williams, Veronica A. Wireless Computing Primer. NY: M&T Books. 1996.
[12-4] Gasman, Lawrence. Manager’s Guide to the New Telecommunications Network. Norwood, MA: Artech House. 1988.
[12-5] Ireland, Tom. “The Standards Wars in Digital Cellular.” Telecommunications. April 1996.
[12-6] Baldwin, Thomas F. and McVoy, D. Stevens. Cable Communications. NY: Prentice-Hall, Inc. 1988.
[12-7] Bates, Regis J. Wireless Networked Communications. NY: McGraw-Hill, Inc. 1994.
[12-8] Paetsch, Michael. Mobile Communications in the U.S. and Europe: Regulation, Technology, and Markets. Norwood, MA: Artech House. 1993.
[12-9] Dellecave, Tom Jr. “McCaw To Nextel’s Rescue.” Information Week. April 24, 1995.
[12-10] Karmer, Matt. “Going Beyond The Beep.” PC Week. December 11, 1995.
[12-11] Carey, Anne R. and Parker, Suzy. “Explosive Business.” USA Today.
[12-12] “SkyTel 2-Way: Paging Dick Tracy.” Information Week. December 18, 1995.
[12-13] Moore, Mark. “Paging Net to Off To Bumpy Start.” PC Week. December 18, 1995.
[12-14] Costello, Richard A. “Wireless PBX Systems.” Delran, NJ: Datapro Communications Analyst. March 1995.
[12-15] Velasquez, Sonina and Trivett, Diane. “Wireless Telecommunications Office Systems: Overview.” Delran, NJ: Datapro Communications Analyst. September 1994.
[12-16] Rohde, David. “NorTel Wireless Phone System Links Campus Users.” Network World. July 3, 1995.
[12-17] Erickson, Jim. “Redmond Firm Tries Out Smart Antennas.” Seattle Post-Intelligencer. July 8, 1996.
[12-18] Dempsey, Michael. “Not-So Saturation Coverage From GSM.” Global Telecoms Business. October/November 1994.
[12-19] Wallace, Bob. “AT&T to Ship PCMCIA Cellular Modem.” InfoWorld. November 7, 1994.
[12-20] Moore, Mark. “Data-Ready Cell Phones To Debut.” PC Week. January 1, 1996.
[12-21] Velazquez, Sonina. “How CDPD Works.” Internetwork. July 1995.
[12-22] Barney, Doug. “McCaw Rolls Out CDPD Service.” InfoWorld. November 28, 1994.
[12-23] Barney, Doug. “Third-Party Cellular Mobile Apps Readied.” InfoWorld. November 21, 1994.
[12-24] Greene, Tim. “Reason to Roam With Your Cellular Phone.” Network World. July 10, 1995.
[12-25] Hills, Alex. “CDPD Puts IP Networks on the Move.” Business Communications Review. May 1995.
[12-26] Wexler, Joanie. “McCaw Activates CDPD Service, Details Pricing.” Network World. April 17, 1995.
[12-27] Kobelius, James. “Prospects Are Golden for Wireless Data Services.” Network World. November 7, 1994.
[12-28] Paone, Joe. “Still on The Fringes.” Internetwork. July 1995.
[12-29] Cawley, Joel. “The Era of Intelligent Communications.” Telecommunications. April 1995.
[12-30] Naik, Gautam. “A Lot of Little Hassles Slow Spread of Wireless Network.” Wall Street Journal. May 11, 1995.
[12-31] Mathias, Craig and Rysavy, Peter. “The ABCs of PCS.” Network World. November 7, 1994.
[12-32] Wexler, Joanie. “Sprint Starts Difficult Task of Putting PCS House in Order.” Network World. August 7, 1995.
[12-33] Dawson, Fred. “PCS: Financing The New Kid.” Convergence. March 1996.
[12-34] Wexler, Joanie. “Getting To Know PCS.” Network World. May 22, 1995.
[12-35] Greene, Tim and Wexler, Joanie. “Pacific Bell Chooses Ericsson for Wireless.” Network World. May 29, 1995.
[12-36] “PCS Infrastructure.” Convergence. March 1996.
[12-37] Moore, Mark. “Two More PCS Networks Slated to Debut Next Year.” PC Week. December 18, 1995.
[12-38] Alleven, Monica. “Carriers Win With Narrowband PCS.” “PCS Today,” a supplement to Satellite Communications. November 1995.
[12-39] Saunders, Renee. “Looking to 1999: PCS by Satellite.” Satellite Communications. March 1995.
[12-40] Careless, James. “Ka-Band Satellites: A Guide to the Proposed U.S. Systems.” Via Satellite. December 1995.
[12-41] Schuerholz, Katherine A. “U.S. Ka-Band Satellites—An Overview of The Proposed Systems.” Via Satellite. December 1995.
[12-42] Gifford, James M. “Shedding Some Light on Teledesic.” Satellite Communications. March 1996.
[12-43] Ayer, Renee. “Strategies for Capturing the Satellite-Delivered Voice Services Markets.” Satellite Communications. December 1995.
[12-44] Brodsky, Ira. “PDAs Will Usher in The Next Net Revolution.” Network World. November 7, 1994.
[12-45] Bjarin, Tim. “Foretelling The Future of PDAs.” Mobile Office. April 1995.
[12-46] Santalesa, Rich. “PDAs Today: What You Need To Know.” Mobile Office. August 1995.
[12-47] Varhol, Peter D. and Varhol, Pamela H. “Info At Hand.” Mobile Office. December 1995.


Communications Systems and Networks:The Internet (the Net) Environment

Chapter 13
The Internet (the Net) Environment

Top 10 ways to pose as a jaded Net vet:

10.When referring to browsers, use the preferred spelling “Netscrape” and “Internet Exploder.” (You, of course, use Lynx.)
9.You’re male? Call yourself d00d. Female? Grrl.
8.Refer to online services only when you absolutely have to, and when you do, use these preferred spellings: America OnHold, Plodigy, Compu$erve, and Microsoft Notwork.
7.If you use the term “digerati,” make it clear you are being ironic.
6.Change your sig to read, “I have Neiman-Marcus cookie recipes”
5.Change your alternative sig to read: “Of course, Mondo 2000 did it first.”
4. Want to change your sig? Never use one you’ve seen somewhere else.
3. Spell the “cool” k-e-w-l.
2. Spell the word “kewl” k-0-0-l with two zeroes.
1. Avoid discussions about the relative merits of the MacOS, Windows and OS/2. Just mention casually that if it doesn’t grep, it’s not a real computer.

— c|net (http://cnet.com)

Author's Note: For explanations of http and .com, read this chapter. For explanations of Lynx, digerati, and grep, refer to the end of this chapter. If you thoroughly understand all of these terms, you may skip this chapter.

The Internet has captured the imagination of the U.S, and of the world! From its early beginnings as DARPANET, linking a select few military and R&D facilities, it has grown to comprise thousands of networks and millions of users in more than a hundred countries. The Internet is the “kudzu” of networks, growing like the uncontrollable weed of Southern infamy.

The Internet truly was the Information Superhighway, long before the term was coined. While it was actually more of a private road, it was characterized by a sense of freedom that was truly unparalleled. That early network stood apart by virtue of its providing free and open access to information—that characteristic remains today as the hallmark of the Internet. The Internet is a network of networks, and has become a Global Village, much as envisioned by Marshall McLuhan. In some sense, at least, The Internet is The Information Superhighway!

The Internet Defined

The Internet is a global network of networks currently linking over 60,000 networks and spanning over 150 countries. According to Network Wizards the number of connected hosts nearly doubled in 1996, to almost 9.5 million (Table 13.1). There are well over 35 million users, with a growth rate that exceeds 15% per month, according to some estimates. Figure 1.1 provides a graphic view of the growth of the Internet (there were only four hosts in 1969). E-mail, the most popular application, is estimate to account for well over one billion messages and over one trillion bytes (1TB) of data per month.

Table 13.1 Internet Domain Survey, January 1996: Number of Hosts, Domains and Nets. Source: Network Wizards (http://www.nw.com)
 |  |  |  | Network Class
Date | Hosts | Domains | Replied to Ping* | A (Large) | B (Medium) | C (Small)
Jan 96 | 9,472,000 | 240,000 | 1,682,000 | 92 | 5,655 | 87,924
Jul 95 | 6,642,000 | 120,000 | 1,149,000 | 91 | 5,390 | 56,057
Jan 95 | 4,852,000 | 71,000 | 970,000 | 91 | 4,979 | 34,340
Oct 94 | 3,864,000 | 56,000 | 1,024,000 | 93 | 4,831 | 32,098
Jul 94 | 3,212,000 | 46,000 | 707,000 | 89 | 4,493 | 20,628
Jan 94 | 2,217,000 | 30,000 | 576,000 | 74 | 4,043 | 16,422
Oct 93 | 2,056,000 | 28,000 |  | 69 | 3,849 | 12,615
Jul 93 | 1,776,000 | 26,000 | 464,000 | 67 | 3,728 | 9,972
Apr 93 | 1,486,000 | 22,000 | 421,000 | 58 | 3,409 | 6,255
Jan 93 | 1,313,000 | 21,000 |  | 54 | 3,206 | 4,998
*Estimated by pinging 1% of all hosts

Figure 13.1 Growth in Internet hosts.(Sources: Network Wizards (http://www.nw.com) and Mark Gibbs, Gibbs & Co.).

The Internet is grounded in the U.S. Department of Defense ARPANET (Advanced Research Projects Agency NETwork), which began in 1969 as a means of linking personnel and systems involved in various computer science and military research projects. ARPANET, and its successor DARPANET (Defense Advanced Research Projects Agency NETwork) were developed to be totally fail-safe. The distribution of computing power and the redundancy of the data switches and computer links were all intended to provide a meshed computer network that could withstand a nuclear strike

In the early 1970s, work began at Stanford University on a set of internetworking protocols designed to prove connectivity among the ARPANET computers. In May 1974, Vinton G. Cerf (Stanford University) and Robert E. Kahn (Advanced Research Projects Agency, U.S. Department of Defense) published “A Protocol for Packet Network Intercommunication” in the IEEE Transactions on Communications [13-1]. That concept became known as TCP/IP (Transmission Control Protocol/Internet Protocol). Development work on the protocols was completed in 1980, and in 1983 the Office of the Secretary of Defense mandated that ARPANET users accept the new set of computer protocols, which became the standard for ARPANET. In order to encourage colleges and universities to transition to TCP/IP, DARPA eased the implementation process for Berkeley Software Distribution, commonly known as BSD UNIX or Berkeley UNIX, a version of the UNIX operating system which they mostly ran at the time. Toward that end, DARPA funded Bolt Baranek and Newman (BBN) to implement the TCP/IP protocols with Berkeley UNIX; this approach filled an internetworking protocol void and formed the foundation for the Internet [13-2].

In late 1983, ARPANET was split into two unclassified networks, DARPANET (Defense ARPANET) and MILNET (MILitary NETwork). Although ARPANET was officially retired in June, 1990, the Internet has survived. TCP/IP has been enhanced recently and currently enjoys wide popularity in education, research and development, and commercial applications.


Communications Systems and Networks:The Internet (the Net) Environment

NSFNET (National Science Foundation NETwork) was founded in 1985 by the National Science Foundation to link its supercomputer centers, and to provide access to the Internet. NSFNET is a high-speed backbone network consisting of point-to-point links in a mesh configuration. The network was fully deployed in 1988, initially at 56 Kbps. In 1986, NSFNET partially funded a number of regional networks, tying into the backbone. In 1992 the backbone was upgraded to T3, operating at 45 Mbps. More recently, major portions were upgraded to OC-3 (155 Mbps) and beyond.

Internet Physical Topology

The physical topology of the Internet, ultimately, is not really all that important. However, and for those of you (like the author) who absolutely must know at some level, it consists of leased-lines that connect various major computing center in a partially-meshes network for purposes of redundancy and network resiliency. Initially, ARPANET consisted of approximately 50 BBN Packet Switching Nodes (PSNs), that were custom-built and scattered around the United States and Western Europe. NSFNET (1985) consisted of 56-Kbps leased-line circuits connecting the SFC supercomputer centers in San Diego; Boulder, CO; Champaign, IL; Pittsburgh; Ithaca, NY; and Princeton, NJ.

The original NSFNET was replaced (1988) by an expanded version through a partnership of MERIT (statewide network run by the University of Michigan), IBM, and MCI. Sites were added at San Francisco; Seattle, Houston, and Ann Arbor, MI and other cities where there resided large computer centers. The third version of the NSFNET backbone was deployed in 1989, increasing backbone speed, and adding some circuits while deleting others. In 1996, NSFNET was officially retired and replaced with the MERIT Network (Figure 13.2). That network consists of NAPs (Network Access Points) in San Francisco, (Pacific Bell), Chicago (Ameritech) and New Jersey (Sprint), as well as Merit Access Exchanges in San Francisco (MAE West) and Washington, D.C. (MAE East) provided by MFS Datanet.

Figure 13.2 MERIT backbone network.

Aside from the backbone network, NSFNET funded a number of mid-level networks at the state and regional levels. Access networks also have been funded in various networks to support backbone connections for specific organizations or consortia. Campus networks also connect to the backbone through dedicated lines leased from various carriers [13-2]. In an interesting recent development, universities have become distressed over the degradation in Internet performance as traffic levels have increased. In fact, a number of them have petitioned the National Science Foundation to build a new, separate NSFNET intranet (private Internet) just for them—seems as though success does come at a price [13-3]. Figure 13.3 shows a view of CERFnet, one of numerous backbone networks providing commercially available access to the NAPs and MAEs.

Figure 13.3 CERFnet National T3 Topology Map of August 1, 1996. (Reprinted with permission of CERFnet.)

Internet Standards, Administration, and Regulation

The Internet is a most unusual network. Virtually any entity can connect to the Internet to offer resources or to access them. Virtually any type of information can transverse the Net, and without interference. There is no central authority that regulates the Internet, although there are organizations that set certain fundamental standards and guide its operation. The Internet, by design, is autonomous and even anarchistic. That fact is both a strength and a weakness of the Net.

There do exist a number of organizations which are involved in various Internet administrative and support activities. These organizations include the GSI, IAB, IETF, IESG, IRTF, and The Internet Society (also known as ISOC).

The Internet Architecture Board (IAB) (nee Internet Activities Board) is a voluntary board comprising 12 expert individuals who use the resources of their sponsoring companies to further the interests of the Internet [13-4]. The IAB supervises the activities of two task forces, the IETF and the IRTF. In combination, those organizations set policy and direction.

The Internet Engineering Task Force (IETF) identifies, prioritizes and addresses short-term issues and problems, including protocols, architecture and operations. Proposed standards are published on the Internet in the form of RFCs (Requests for Comment). Once the final draft of a standard is prepared, it is submitted to the Internet Engineering Steering Group (IESG) for approval. The IETF recently formed a task force, the IPng (IP next generation) to address the future of the Internet, including expansion of IP addresses and determination of functionality and feature content.

The Internet Research Task Force (IRTF) deals with long-term issues, including addressing schemes and technologies [13-5].

The Internet Assigned Numbers Authority (IANA) assigns IP addresses to organizations desiring to place computers on the Internet, with the number of addresses depending on the size of the organization. Class C addresses support up to 256 (28) individual machines, Class B addresses support up to 65,536 (216) machines, and Class A address support as many as 16,777,216 (217) machines.

The organization assigned the numbers then can reassign them on the basis of either static or dynamic addressing. Static addressing involves the permanent association of an IP address with a specific machine. Dynamic addressing assigns an available IP address to the machine each time a connection is established. For instance, an Internet Service Provider (ISP) will assign an IP address to a user machine each time the user accesses the ISP to seek connection to the Net. Once the connection is terminated, that IP address becomes available to other users [13-6].

Interestingly, Sprint has blocked Internet traffic to users of Class C ISPs with assigned IP addresses longer than 18 bits. Sprint claims that the lengthy addresses have caused router tables to overflow, affecting its capability to handle Net traffic in general. As one might imagine, the Class C ISPs have protested Sprint’s action, as it has the same effect of blocking access to a telephone if the authorized telephone number is too long. At the time of this writing, other carriers have declined to take such action, preferring to consider backbone router upgrade options.

The Internet Society (ISOC) is a voluntary organization that acts to lend some formal structure to the administration of the Net. The Internet Society has granted the IESG formal authority to make decisions on standards.


Communications Systems and Networks:The Internet (the Net) Environment

Internet Network

Originally, the Internet backbone network was designed, deployed, operated, managed and owned by various government, educational, and R&D institutions. In large part, ownership is now on a private, commercial basis. The network is a series of dedicated backbone networks owned variously by public and private organizations, and involving circuits that interconnect numerous hosts and subnetworks. While the backbones operated at 56 Kbps until fairly recently, they generally have been upgraded to DS1 or DS3, with some upgraded to much higher speeds. ANS and MCI are examples of backbone providers.

Advanced Networks and Services (ANS), a consortium of IBM, MCI, and Merit Network, owns a substantial part of the backbone network. ANS also provides access to NSFNET and is the access provider of choice for many Fortune 1000 companies [13-7].

MCI announced (March, 1995) a 5-year, $50 million relationship with the NSF to built a very-high-speed Backbone Network Service (vBNS) running over an ATM/SONET backbone at 155 Mbps (OC-3), with plans to upgrade to 622 Mbps (OC-12). The network will connect the Pittsburgh and San Diego (CA) Supercomputing Centers, Cornell Theory Center (Ithaca, NY), the National Center for Supercomputer Applications (Urbana, IL) and the National Center for Atmospheric Research (Boulder, CO). Initially, access service also will be offered in San Francisco, New York, Chicago, and Washington, D.C. [13-8] and [13-9]. MCI also announced (June 1996) plans to meld its backbone with that of BT (British Telcom) under the umbrella of their Concert joint venture. The offshore links will run at 45 Mbps [13-10].

User Equipment Requirements

At a minimum, the full-fledged Internet user requires a 486 PC capable of supporting a Windows Graphical User Interface (GUI); a Macintosh computer will also do the trick. Lots of memory (both RAM and hard drive) are most helpful. As speed is important, a 28.8 Kbps modem is ideal for access over analog lines. To get the full benefit of sound and color graphics, it is necessary to equip the terminal with a color monitor, speakers, and a sound card. Such a PC can be had for $1,000 or so, although a full multimedia PC with a large color monitor, CD-ROM and all the other niceties easily is in the range of $2,500. If ISDN circuits are to be employed (better quality and higher speed), an ISDN Terminal Adapter must be added in the form of either an internal PC card or standalone unit—the additional cost begins in the range of $100 to $250, plus the additional cost of the circuit. Large users, of course, also require the appropriate routers and other devices, which they may already have in place. On the other hand, access to the Net may require more such equipment, as another network is being added to the mix in support of additional applications and additional associated traffic. The router also should include security in the form of a firewall (discussed later in this chapter) to provide protection against hackers and the like. Clearly, this is not an inexpensive proposition.

Help is on the way. A number of manufacturers over the past few years have proclaimed the emergence of much less expensive devices known variously as diskless workstations, Net devices, Net readers, Internet terminals, Net stations. Reminiscent of the dumb terminals of the old mainframe days, these devices would have little or no processing power or storage capacity. Rather, they would have the ability to access the Internet and World Wide Web, and support a highly-pleasing GUI. All of the serious processing power would reside in the network, as would all storage capacity. Serious computer users are unlikely to embrace such a device, although casual users might accept it if the price is low enough. Costs are anticipated to be in the range of $500, although there is discussion of terminals at half that price. Manufacturers developing such devices include Oracle Corp., Sun Microsystems Inc., Apple Computer Inc., IBM, Web Book Inc., SunRiver Corp. and Japan Computer Corp. [13-11] through [13-17].

Internet Access

While the number of Internet users is growing at unbelievable rates, not everyone has access. In this Information Age, there is great concern about creating a new class system of the information haves and have-nots. In an attempt to address this issue, there is great debate about subsidizing some level of universal service, much as was assured in the 1930s for the PSTN. With the goal of providing access to every American school by the year 2000, $36 million was raised from private sources in 1995, with matching funds from the U.S. government sources. Additionally, various carriers have offered special access rates and some manufacturers have donated equipment or offered special discounts [13-18].

Access to the Internet can be accomplished on any number of bases. Access can be over a dedicated or dialup circuit, through a direct connection or through an intermediate service provider [13-19]. The performance of the connection depends on the amount of bandwidth access provided and the nature of the access loop.

Terminal access via dialup connection is provided by a number of Information Service Providers, who provide content, as well as access. America Online, CompuServe and Prodigy fall into this category, with their retail rates and content providers listed in Table 13.2. Additionally, there exists a huge number of Internet Service Providers (ISPs), which focus solely on the access business. Public access providers provide access on a leased line basis.


Communications Systems and Networks:The Internet (the Net) Environment

Internet Service Providers (ISPs)

Internet Service Providers (ISPs) are by far the most popular means of connection. Individuals and small businesses access the Net through gateways provided by firms such as America Online, Australia Online, CompuServe, GEnie, and Prodigy. Such access is accomplished through a dialup connection and via a modem over an analog local loop. The user, through the circuit-switched PSTN, dials a local number associated with a X.25 packet node provided by VAN network providers such as BT Tymnet (BT) and SprintNet (Sprint) in the United States, and Datapac (Bell Canada) in Canada. Some providers provide only limited access to Internet resources, generally to e-mail. Examples of limited access providers, at the time of this writing, include AT&T EasyLink, MCI Mail, and The Well (Whole Earth ’Lectronic Link).

Major IXCs also have gotten into the act, led by AT&T and MCI. AT&T’s entry was announced in February 1996 at a stunning cost to its long-distance customers of $0.00 for the first five hours of usage for the first year; each additional hour is priced at $2.50. AT&T also offers an unlimited access option for $19.95. Non-AT&T customers will pay slightly higher costs, which still are highly competitive [13-20]. Within the first 9 weeks of the offering, AT&T claimed to have signed up 150,000 customers, making it the second largest pure access provider in the United States. Netcom On-Line Communication claims to be the largest with 400,000 customers [13-21]. Other notable ISPs include ANS CO+RE Systems, BBN Planet Corp., CerfNet, Global enterprise Services, and UUNET Technologies [13-22]. Subject to regulatory approvals, UUNET has announced its merger with MFS, one of the largest Competitive Access Providers (CAPs). The merger will create the only ISP with fiber optic local loops and inter-city facilities [13-23] and [13-24]. UUNET also has announce plans to collocate its own ADSL equipment in LEC central offices in order to speed access rates. The company will achieve high-speed access over standard local-loops without paying higher LEC rates for ADSL services [13-25].

All of the RBOCs have announced plans and field trials for Internet access as well. Pacific Bell announced in June 1996 that it immediately would offer dialup access at 28.8 Kbps. The installation charges were waived until September 1, and the rates are highly competitive with other ISPs [13-26]. PacBell charges $19.95 per month for unlimited usage; less intensive users have the option of $9.95 per month for 10 hours of usage, with additional usage billed at the rate of $1.00 per hour and a ceiling of $19.95. This type of aggressive pricing likely will be typical over the next several years as the RBOCs, AT&T and others seek to gain a strong foothold in the Internet access market.

Finally, there exist a huge number of small, local and regional ISPs. Typically locally-owned and privately-held, they provide low-cost service on a dialup basis. Largely, they support analog dialup access to a communications server via modem pools. They also typically support ISDN access, and some support Frame Relay, as well. They generally lease T1 or FT1 circuits from the LEC CO to their server location, and from there to the backbone service provider as illustrated in Figure 13.4. Facing tremendous pressure from the likes of AT&T, UUNET, PacBell and others with deep pockets, their futures are uncertain.

Figure 13.4 Access to the Internet via PSTN connection to an Internet Service Provider (ISP).

Public Access Providers

Public Access Providers offer direct access to an IP host for full Internet access. Examples include CERFnet, CICnet, JVNCnet (Global Enterprise Services), Netcom, PSInet (Performance Systems International), UKnet, and The World. Such direct access requires that the appropriate access protocols be installed on the connecting host computer, whether it be an individual workstation or mainframe. Similarly, LANs will connect through a bridge or router. While such connections are more costly, they prove effective for more active users.

SLIP and PPP

The access protocols, which are loadable software, allow the user to connect through a modem, appearing to the Net as though the connection were direct. The access protocols comprise SLIP (Serial Line Interface Protocol) and PPP (Point-to-Point Protocol), which is a more powerful version of SLIP, offering less overhead and improved error performance. LAN connections require that the TCP/IP protocol stack run alongside the LAN network operating system (NOS).

Direct Connections

Direct connections are provided to large user organizations, and to those who use the Net intensively, through a large number of companies that specialize in that business. The largest such company is Advanced Networks and Services (ANS), a consortium of IBM, MCI, and Merit Network [13-7] and which recently was acquired by America Online. (Merger Mania strikes again!). Direct access can be on the basis of any number of alternatives, including ISDN, DDS ([ge]56/64 Kbps), DS-Carrier (E1/T1-E3/T3) and Frame Relay.

CATV Access

CATV access to the Net, in a convergence scenario, is being proposed by a number of companies. Perhaps the first serious proposal is from a new company, @home. @home proposes to deliver bandwidth of up to 10 Mbps over CATV facilities, beginning in Sunnyvale, CA and extending to selected cities in 1996. While CATV providers don’t exactly have a sterling reputation for service quality, many of them rapidly are upgrading their networks to compete in a convergence scenario (Chapter 15). Assuming that the upgrades take place and that two-way systems are installed, cable modems promise to deliver as much as 10 Mbps, which will far exceed what typically is available via more traditional carrier alternatives [13-27].

Internet Access Costs

The cost of Net usage is pretty reasonable. It largely is free for college and university students and faculty, and a privileged few others, although nominal charges sometimes apply. U.S. tax dollars have funded much of the Net and still do, although private enterprise has taken over in large part. Access can be either on a dialup or dedicated basis, with costs varying widely between and within those options.


Communications Systems and Networks:The Internet (the Net) Environment

Dialup Access

Dialup access charges for information service providers such as America Online, CompuServe, and Prodigy is dependent on modem speed—high-speed access at 9.6, 14.4, or 28.8 Kbps is at a higher cost per minute. Additionally, the service providers have a habit of rounding up connect time to the next full minute, with a minimum in some cases. Therefore, a 45-second connection for an e-mail flash session, can be charged as though it were a three-minute connection. In any event, the Net is not free, but it is quite reasonable for most of us. Table 13.2 provides a sampling of the costs of Internet service:

Table 13.2 Example costs for Internet access through Information Service Providers and Internet Access Provider (ISP).
 | America Online | CompuServe | Prodigy* | Microsoft Network** | Fictitious ISP, Inc.
Access Method | Dialup | Dialup | Dialup | Dialup | Direct (SLIP or PPP)
Basic Monthly Fee | $9.95 or $19.95 | $9.95 or $15.00 | $9.95, $14.95 or $29.95 | $4.95 or $19.95 | $19.95
Access Included in Basis Fee | 5 or 20 hrs | 3 or 20 hrs | 3, 5, or 30 hrs | 3 or 20 hrs | 20 hrs
Additional Usage | $2.95/hour | $1.95/hour | $2.95/hour or $0.05/minute | $2.00/hour | $1.00/hour
Example Content Providers | ABC, MTV, Nickelodeon, Nick at Nite, Road and Track, Woman’s Day, Time, The New York Times, National Geographic, American Express | Rolling Stone, Sports Illustrated, People, Forbes, Fortune, Money, Comedy Central, CNN | Homework Helper, News Week, Newsday, Los Angeles Times | Court TV, C-SPAN, Eastman Kodak, Eddie Bauer, QVC, Home Shopping Network, RockNet, Starwave-ESPNet, Sports Zone | N/A
*Jointly owned by Sears and IBM, Prodigy was sold in May 1996 to International Wireless.
**Alas, it would seem as though Microsoft Network may not survive. Microsoft has announced a reversal in strategy, re-focusing on its core software business, rather than ISP networking.

Dedicated Access

Dedicated Access is provided by companies specializing in that line of business. Additionally, many of the Local Exchange Carriers (LECs) and Interexchange Carriers (IXCs) are offering access arrangements using T1, Frame Relay, ISDN, and SMDS services. By way of example, Pacific Bell charges $400 per month for Internet access, plus an installation fee that ranges from $1,250 to $3,500. Transport options include Frame Relay (56 Kbps) at $125 per month and installation of $2,000. T1 (1.544 Mbps) involves a monthly charge of $1,715; SMDS (16 Mbps) is $5,200 monthly with an installation of $6,500.

Network Domains

The Internet is divided logically into domains. Under the terms of IPv4 (Internet Protocol version 4), these are identified as a 32-bit portion of the total address. Addresses follow a standard convention, which is similar to user@organization.domain. According to Datapro, more than 70% of the registered domain names are commercial, with growth projected to 90% by 1997.

Domain types include the following:

• .com = commercial organizations
• .edu = educational institutions
• .gov = government agencies
• .mil = military
• .net = network access providers
• .org = non-profit organizations

For example, Ray@ContextCrp.com is the address for Ray (user), at The Context Corporation (organization providing the connection), a commercial enterprise.

Domains also identify the country, in the form of a two-character country code. Country codes are appended to the standard address, and are necessary only if the target country domain differs from the country domain of origin. By way of example:

• .AU = Australia
• .JP = Japan
• .NZ = New Zealand
• .SW = Sweden
• .US = United States

Internet addresses are administered by the Network Information Center (NIC) Internet Registry, and are divided into classes, based on the size of the subnetwork. There is currently a great deal of pressure on the addressing scheme, which now supports approximately two million addresses. IP Version 4 (IP4), recently approved, will serve addressing needs into the next century through an expanded address field of 32 bits. IP4, however, does not support advanced functions such as multicasting, resource reservation, and improved security. Another recently approved option, IP6, extends the address field to 128 bits and provides additional functionality, although CPE upgrades are required.

Internet Protocols

Internet protocols include TCP and IP, as well as application-level protocols. TCP/IP is fundamental to the operation of the Internet, while the application-level protocols serve to support specific user applications.

Transmission Control Protocol (TCP) and Internet Protocol (IP)

TCP and IP, as were discussed in Chapter 8, are specific, layered protocols that operate within a protocol stack typically referred to as the TCP/IP protocol suite. TCP/IP is a public domain protocol, because it was developed with public funds for use in a public network, the Internet. The TCP/IP networking protocol suite operates at Layer 3 (Network) and Layer 4 (Transport) of the OSI reference model. TCP/IP has been enhanced continuously and used extensively in all variety of computer networks, including X.25 and Ethernet. Additionally, ISO FTAM, X.400, and X.500 applications protocols (Layer 7) have been layered above TCP/IP by some vendors. The advantages of TCP/IP include its high level of documentation, ease-of-use, stability, and broad applicability. TCP/IP provides a means of passing datagrams between virtually any network capable of sending and receiving bits—it is a highly-effective lowest common denominator protocol.


Communications Systems and Networks:The Internet (the Net) Environment

TCP

Transmission Control Protocol (TCP) is a Layer 4 (Transport) protocol that evolved from the Network Control Protocol (NCP) of ARPANET. NCP was developed to provide reliable transmission across the essentially unreliable media of analog UTP and packet radio (AlohaNET). In support of higher level applications, TCP can be characterized as making use of virtual circuits in support of byte-stream oriented communications. TCP is a connection-oriented protocol that provides end-to-end flow control and error control. It also supports status exchange and synchronization [13-28] and [13-19].

IP

Internet Protocol (IP), the basic building block of the Internet, is a Layer 3 (Network) internetworking protocol for the routing of datagrams through gateways connecting networks and subnetworks. IP can be characterized as being datagram-oriented—it provides for packet segmentation and reassembly and provides specific addressing conventions. IP supports routing control and status translation and communications. It also supports multiple service types, including low-delay, high-bandwidth, and high-reliability paths. Dialup IP access protocols include SLIP and PPP.

SLIP

SLIP (Serial Line Interface Protocol) was the original and remains the most basic protocol for handling IP packets across a voice-grade telephone connection. Installed on both the user’s workstation and the provider’s server, SLIP forwards packets created by TCP/IP software.

PPP

PPP (Point-to-Point Protocol) performs the same basic functions as SLIP. Additionally, it performs fairly sophisticated compression in order to eliminate unused or redundant data in the headers of long sequences of packets in a transmission stream. Further, PPP supports multiple native machine and network protocols and supports subnet routing. For instance, PPP installed on a telecommuter’s home PC will allow communication with the home office through a router connecting to a LAN based on AppleTalk or Novell. It will also support IP packet communication through the Internet [13-6].

Application-Level Protocols

Application-level protocols function above the TCP/IP protocol suite in support of specific Internet applications. Examples include Telnet and File Transfer Protocol (FTP).

Telnet

Perhaps the oldest Internet application protocol, Telnet provides terminal emulation, allowing the user to assume control over the applications that reside on a remote system. Virtual network terminal services allow the DTE to emulate other terminal devices, transparently, in a client/server environment.

FTP

File Transfer Protocol (FTP) supports the exchange of files between two hosts across the Internet. ACSII and binary file transfers are supported between a client and a server.

SMTP

Simple Mail Transfer Protocol (SMTP) supports text-oriented e-mail between any two devices that support MHS (Message Handling Service). Multipurpose Internet Mail Extension (MIME) is a SMTP extension that allows the attachment to textual e-mail of other types of files, including audio, graphics and video. Thereby, compound mail can be transmitted across the Net.

Internet Applications

Internet applications are growing as fast as the imagination and technology will support. The applications include e-mail, file transfer, Bulletin Board Systems (BBSs), library catalogs, online banking, video and radio broadcasting, and even voice telephony.

E-mail

E-mail clearly is the most popular application. More than one billion e-mail messages of over one trillion bytes (1TB) transverse the Internet each month. It is estimated that over 100 million people will use e-mail by the year 2000.

File Transfer

File transfer is accomplished through the File Transfer Protocol (FTP). Through any of over 8,000 FTP servers, any of the thousands of Net servers and their resident file resources be accessed and transferred in ASCII or binary code from the server to the user’s computer. While many FTP resources are privileged, others are unrestricted and available for public consumption. Such unrestricted resources can be accessed via the use of the account name anonymous. Large files ([ge]50 KB) generally will be in compressed format using compression techniques specific to the computer operating system; examples include .Z or .tar (UNIX), .zip (MS-DOS), and .hqx (Macintosh).

BBSs

Bulletin Board Systems (BBSs) are specific to a region or area of topical interest. Each supports numbers of subcategories. Network News, or Usenet News, formed in 1979, is a collection of over 6,000 special-interest Bulletin Boards (BBSs). Example BBSs include the following:

• com Computer, including specific LAN technologies
• biz Business
• K12 Topics of interest to primary and secondary school educators (K–12)
• rec Recreation
• sci Sciences, such as biology, chemistry and physics
• soc Social issues such as religion and politics

Library Catalogs

Library catalogs for over 300 libraries are available through the Internet. Such catalogs include the U.S. Library of Congress, the Research Libraries Information Network and many major colleges and universities. Through the Interlibrary Loan program, Internet users may be able to have the document loaned to their local library.

Realtime Applications

Realtime applications are growing at significant rates. There are a number of legitimate applications, and many which are less so. Realtime applications include collaborative design and development, interactive role-playing, interactive remote education and chat lines (realtime BBSs). Other applications include voice and video conferencing, network games, gambling, and radio and video broadcasting (cybercasts).

Online Banking

Online banking has received a good deal of interest as a result of the failed acquisition talks between Microsoft and Intuit. While security issues abound, there is little doubt that this application has great promise.


Communications Systems and Networks:The Internet (the Net) Environment

Video Broadcasting

Video broadcasting deserves special mention. Although it is terribly bandwidth-intensive and the quality is poor, it is possible to transmit packet video over the Net. Through the use of CU-SeeMe software developed at Cornell University by Tim Dorsey, and available free of charge, poor quality video is possible. Videoconferencing also is possible with a SLIP/PPP connection and a high-speed modem ([ge]14.4 Kbps). A black-and-white video camera can be had for under $100 from Connectix Corp. and others. In either case, connection is provided through a video server known as a reflector — approximately 50 such sites exist. Unfortunately, video and image usage promises to bring the Net to its knees if used unwisely. Internet floodwalls are being considered to at least isolate such traffic to a segment of the Net [13-29].

Radio Broadcasting

Radio broadcasting makes use of packet radio systems such as RealAudio from Progressive Networks. AM radio quality is possible with a ten-second delay. As is always the case with packet-switched networks, streaming audio is subject not only to delay, but also to data loss with no opportunity for recovery. In other words, the general quality is not great, but the price is right. By way of example, the author had a number of students from Asia at a graduate-level course he taught at the University of San Francisco. Several students from Japan, in particular, regularly listened to radio broadcasts from Tokyo over the Internet. Again, the quality was not great, but because it was free the price was right. Additionally, the students really had no other means of hearing such a broadcast, or getting information from home on a timely basis. According to the Associated Press, there were over 200 radio stations broadcasting over the Net at yearend 1995. Additionally, Microsoft and NBC have plans to offer a 24-hour news channel [13-30].

Internet Telephony

Also known as IPhone, NetPhone, and Internet Voice, Internet Telephony is a means of transmitting voice over the Internet, bypassing the traditional PSTN and saving money in the process. Internet telephony is accomplished through the use of special software residing on a multimedia PC equipped with a microphone, speaker, and modem (14.4 Kbps or better). For the most part, the software works on a half-duplex basis, allowing only one person can to talk at a time using a push-to-talk protocol reminiscent of CB radio. Through appropriate modems and using recently developed software, full duplex communications also can be supported. In every case, a voice conversation currently is supported only through the use of matching software residing in both transmit/receive devices.

Whether full or half duplex, voice is not well-supported over packet networks due to issues of audio quality, packet delay, and packet loss. Additionally, it currently is necessary that both parties schedule the call in advance, typically either via e-mail over the Net or through a short preliminary telephone call. Current software/hardware technology does not allow the caller to ring the target PC over the Net. This limitation likely will be overcome in the near future through the development of a standalone device sitting between the PC and the access circuit, much like a contemporary voice/fax/modem splitter.

However, it is free if you are lucky enough to be a college student or faculty member. End users connecting to the Net directly or through an Internet Service Provider (ISP) can make use of this application essentially for free, although small usage charges may apply above a certain usage threshold. Users connecting through an information service provider (AOL, CompuServe, or Prodigy) face more significant, but still reasonable, usage charges. In any event, the cost of Internet usage compares quite favorably with long distance charges imposed by traditional PSTN carriers.

As one might expect, some of the PSTN carriers are very upset about this application. Contrary to what one might expect, others applaud it. ACTA (America’s Carriers Telecommunications Association), an association of smaller carriers, has filed a formal protest with the FCC. AT&T, on the other hand, has announced its support of Internet telephony. The carrier issue, clearly, is one of erosion of revenues. AT&T’s surprising position is a reflection of its position as the second largest ISP in the country. In fact, AT&T announced in July 1996 its intention to marry its PSTN and Internet service offerings in order to provide additional service and cost options to its customers. It would appear that AT&T intends to overwhelm its competition and dominate the Internet telephony market, which will find a constituency whether AT&T participates or not. Additionally and not surprisingly, Intel, Microsoft, and other chip and software manufacturers have thrown their weight behind Internet Telephony.

Other issues abound, including reduced tax revenues at the local, state, and federal levels. The Universal Service Fund will be threatened unless ISPs and backbone carriers are required to contribute—the upshot will be an increased burden on PSTN users in support of local service cross-subsidies to maintain a high level of network access to rural areas at reasonable cost to those end users. ISPs face increased costs for servers, modems, local loops, and links to the backbone networks in support of increased traffic. The backbone networks, that are already experiencing brownout and which are facing meltdown, will experience extra pressure on scarce and expensive bandwidth, which will force additional investment—and on, and on, and on.

Realizing that we can’t solve this dilemma within the covers of this book, perhaps it is time to mention a few of the providers of such software (and the specific products). Those vendors include Electric Magic (NetPhone), FreeTel Communications (FreeTel), Netscape Communications (CoolTalk), NetSpeak (WebPhone), Quarterdeck (WebTalk), Third Planet Publishing (DigiPhone), and VocalTec (Internet Phone). Motorola and a large number of other manufacturers are now packaging Internet Phone capabilities into their new modems; these powerful modems contain Digital Signal Processors (DSPs) which are capable of accommodating the necessary compression algorithms. Internet telephony, as you may have sensed by this point, is a very hot topic at the time of this writing. As an indication of that fact, note the sheer number of references from which this treatment gathers information [13-8] and [13-31] through [13-48].


Communications Systems and Networks:The Internet (the Net) Environment

There also have been several recent and fairly interesting announcements of new products and approaches for Internet telephony. NetSpeak, makers of the $49.95 WebPhone software have announced a Business WebPhone System (BWS). When a user logs onto the Internet, he automatically is registered as active on NetSpeak’s server and is able to receive voice calls without previous arrangement. This works much like the send an instant message capability provided by AOL and others for e-mail purposes. The system will work over any IP network, including one involving workstations connected over LANs to Intranet servers (Intranets are discussed later in this chapter). Additionally, PBX and ACD systems can be customized to support Intranet calling using the BWS software.

Remote Messaging

Integrated, remote messaging over the Internet is a new concept, but one which is technically feasible and which has been translated into real products. Centigram, Enhanced Systems, and others in the messaging business (Chapter 5) have developed system software that allows a remote user to access the office messaging platform. After satisfying the necessary security challenges, the remote worker can download e-mail, voice mail, and fax mail over the Internet. The messages can be played on the user’s multimedia PC, for instance, and responses can be created and uploaded over to the Net to the office platform. The centralized office system then forwards those messages to the originators in their native format—e-mail, voice, or fax. Although the voice is a bit rough, of course, the concept is solid, the products work, the cost of the systems and software are justifiable, and the cost of the call is negligible.

World Wide Web (the Web)

The WorldWide Web (WWW), also known as the Web, is The Internet’s first killer ap. The WWW was developed by Mr. Tim Berners-Lee at CERN, the European Laboratory for Particle Physics in Geneva, Switzerland. The Web is a multiplatform web that supports multimedia communications on the basis of a Graphic User Interface (GUI). The GUI provides hypertext, which allows the user to click on a highlighted text word and search related files, across Web servers, through hot links. In other words, the Web is hyperlinked. In addition to text, the Web supports graphics, audio and video, with various levels of quality and speed depending on the bandwidth available.

While CERN conceived the Web, its home now has moved to the W3 Consortium (W3C). W3C is a cooperative venture of CERN, MIT, and Institut National de Recherche en Informatique et en Automatique (INRIA). The primary focus of W3C is that of the World-Wide Web Core Development (WebCore) project, which is intended to develop Web standards [13-49]. Progress can be monitored through the W3C Web site (of course) at http://www.w3.org/hypertext/WWW/Consortium Prospectus/.

The popularity of the Web truly is astounding. From ground zero in 1994, Network Wizards (http://www.nw.com) estimates that there were close to 80,000 WWW-prefixed hosts in January 1996. It is estimated that over 1 TB of data moves across the Web on a monthly basis—that figure is expected to grow to over 20 TB by yearend 1997 [13-8]. While there currently are only 8 million or so Web users, that number is expected to grow to about 200 million by the year 2000 [13-50].

Web Sites and Home Pages

Organizations or even individuals can develop a Web site, consisting of a computing platform (server) connected to the Web on a fulltime basis. Although the typical business approach involves the deployment of a dedicated server, smaller users may achieve the same end through renting Web site capability from an ISP, that logically partitions a server in support of multiple users and multiple Home Pages.

While the number of Web sites was at [approx]100 in March 1993, there currently exist over 80,000 Web sites. Although the rate of growth has slowed as the numbers have gotten bigger, the number of Web sites were doubling every 54 days in September 1995. The Web currently enjoys about 5 million users in 1996, and is expected to grow to about 11 million by 1998, and 22 million by the year 2000, according to Forrester Research. In June 1994, Web traffic reached 1.056 TB, accounting for 6.1% of all Internet traffic.

Home Pages provide a point of presence on the Web for individuals and businesses, typically supporting advertising and informational purposes. Within each Web site is a Home Page, or multimedia informational document that may contain graphics, animated graphics, video clips, and audio clips, as well as text. Individuals may develop Personal Home Pages, that offer updates on personal life along the lines of a cyberspace version of the ever-popular “What I did on my summer vacation.”

A commercially successful example of a Home Page is that of Sun Microsystems. Sun offers customer service information on its Home Page, reporting savings of $4.6 million per year. The quality of Home Pages varies considerably, with some being the cyberspace equivalent of highway billboards—blatantly commercial and considerably out-of-date. Despite the earlier reference to Marshall McLuhan, the medium is not the message.

Universal Resource Locators (URLs)

URLs are unique WWW Addresses assigned to each Web site and to each Home Page. The structure of the URL follows a standard convention which is

     method://host_spec{port}{path}{file}{misc}

For example:

     http://info.cern.ch/hypertext/WWW/MarkUp/MarkUp.html

where http = hypertext transport protocol and html = hypertext markup language.

HTTP is the default protocol for transmitting HTML content over the Internet. It advises the browser to use the http protocol in accessing Web documents. HTML was the first programming language for creating compound documents for Web sites, and for supporting hot links to other sites. HTML has the clear advantage of device independence—in other words, the specifics of the user terminal (Macintosh, IBM-compatible PC, or Sun workstation) do not affect the presentation of the file [13-6].

WWW Standards

Standards for the WWW are set by the W3 Consortium, which is run by The Massachusetts Institute of Technology (MIT), Intitut National de Recherche en Informatique Et En (INRIA) in Europe, and in collaboration with CERN. Tim Berners-Lee, creator of WWW, serves as the group’s coordinator.


Communications Systems and Networks:The Internet (the Net) Environment

WWW Applications

WWW applications include advertising, publishing, micromarketing, catalogs and direct sales, and entertainment. The great hope is that the Web will become a significant tool for commerce, allowing customers to access a Home Page on a Web site, gain information about a product or service, and actually make a purchase online. Largely due to security concerns, that application is expected to reach only $518 million in 1996, up from $350 million in 1995, according to Forrester Research [13-51]. IDC predicts that in the year 2000, over 200 million Web users will conduct $150 to $200 billion of commerce over the Net [13-50]. Reportedly, Home Pages are being added at the rate of one every four seconds! [13-51].

Commercial Home Pages

Home Page sponsorship is offered by several directories and frequently-hit home pages. Netscape sells sponsorships for $40,000 to $60,000 per quarter; Time Warner, $30,000; and Hotwired, $15,000. In return for this rather princely sum, your home-page banner will appear on their home page; users can click on your banner and hyperlink to your home page [13-52].

Zima now advertises its home page on six different home pages. The Marin Institute for the Prevention of Alcohol and Other Drug Problems (San Rafael, California) and others have complained loudly about such cyberbooze encounters. Zima countered by suggesting that it is a responsible cybercitizen, clearly asking that the user be at least 21 years of age to join “Tribe Z.”

Personal Home Pages

Personal Home Pages exist by the thousands. Photos of children, audio clips of the growls and screeches of family pets, and video clips of summer vacations—all of these are possible and all of these are present on The Net! Truly bored NetHeads can while away their time with such Home Pages as:

• Mr. Potato Head: Revealing data about everyone’s favorite vegetable toy.
• The Uselessness of Pi and its Irrational Friends: Calculate the value of Pi to as many decimal places as you desire.
• Strawberry Blow Torches: A step-by-step guide to the process of using this popular breakfast food as an incendiary device.
• Lost in Space: A guide to every episode of this popular (?) TV show.

Search Mechanisms and Browsers

The huge number of servers and incredible amount of information available on the Internet and Web quickly made it difficult to find the desired resource. One couldn’t find the information unless one knew pretty much where to find it—sort of like having to know at least the approximate spelling of a word in order to look it up in the dictionary to determine the exact spelling. This problem was addressed in the early 1990s through the development of search mechanisms and, more recently, Web browsers.

Search mechanisms are in the form of client/server software that support the search for Internet informational resources, through the development and maintenance of resource directories. The first primitive text browser appeared in 1991, courtesy of CERN. In 1993, the first graphical browsers appeared: Viola for X windows, Mac browser from CERN and Mosaic for X Windows [13-49]. Browsers which are widely used include Archie, Gopher, Veronica, Jughead and WAIS. While Netscape and Mosaic are the most popular, a great number of others exist, as well [13-19].

Archie

A corruption of archive, Archie is a FTP search mechanism first deployed in 1991. Archie allows one to search for a file (exact name unknown) on a file server (name unknown) somewhere on the Net. Archie servers contain directory listings of all such files, updated on a monthly basis through a process of file server polling. Archie will provide a user-definable number of file hits, as well as file names, server names, and directory paths to access each listed file. Archie capabilities are limited to specific search strings, thereby providing little flexibility. Currently, Archie is often integrated into Gopher or WWW clients, to be activated when the user accesses an Archie server.

Gopher

Developed at the University of Minnesota, where the Golden Gopher is the school mascot, Gopher is a user interface that provides easy access to server resources in educational institutions. Gopher has become a de facto user interface standard allowing users access to a directory of over 1,800 Gopher server sites, click on the name of the server, and browse its file resources on the basis of nested menus. Gopher requires that the user know the server on which the subject file is located, somewhere in gopherspace.

Veronica

Veronica (Very Easy Rodent-Oriented Net-wide Index to Computerized Archives) is an Archie variation that supports an index of Gopherspace titles on which a search can be performed. The selected resources are then delivered to the user in the form of a Gopher menu.

Jughead

Jughead (Jonzy’s Universal Gopher Hierarchy Excavation and Display) is quite similar in operation to Veronica, although it limits the search to a specific organization. Jughead also delivers a custom menu of available resources located on the basis of the keyword search. Playing off Archie and Gopher, subsequent developers of search mechanisms tried to stay with the Archie comic book/rodent theme, proving for once and for all that even acronyms can be fun. Alas, the more recent and more powerful browsers were not named with a noticeable sense of humor.

Mosaic

Mosaic is a browser developed at the National Center for Supercomputing (NCSA) at the University of Illinois Urbana-Champaign campus. Mosaic provides a consistent user interface supporting Macintosh, Microsoft Windows, and UNIX X-Windows. Mosaic can used over either dedicated or dialup Internet connections. The dialup access provider must support either SLIP or PPP. Mosaic allows the easy browsing of WWW resources through menus that support hypertext. Through a simple process of mouse-clicking, the user can select menu options. Selected files can include audio and graphics, both of which can be viewed without the requirement to download the subject file.

Mosaic technology is licensed by the NCSA for commercial application. Spyglass, Inc. has licensed well over 12 million copies of Mosaic to IBM, DEC, and others who intend to resell the company’s Enhanced Mosaic. Enhanced Mosaic includes enhanced security mechanisms based on S-HTTP (Secure HTTP).

Netscape Navigator

Developed by Netscape Communications, Netscape Navigator was built by a team led by Marc Andersen, creator of the original Mosaic. It features simultaneous image loading and continuous document streaming speed performance.


Communications Systems and Networks:The Internet (the Net) Environment

WAIS (Wide Area Information Service)

WAIS servers allow the user to specify the databases requested for search, and to conduct a subject-matter search on the basis of keywords.

Intranets

Intranets are the concept of the Internet turned inward—an unexpected turn, perhaps, but a very significant one. Intranets essentially are mini-Internets deployed within organizations or groups of organizations. They can be in the form of internal Internets, functioning to provide access to information resources within the company, university or other organization. They can be confined to a campus environment or can extend across the wide area to link together multiple, geographically-dispersed locations. They also can function as a closed subnet.

Although conceived as recently as 1995, Intranets have spread quickly. In early 1996, Netscape management estimated that fully 70% of its revenues ($21 million, 3Q 1995) were coming from the Intranet market. Further, Netscape counted 50 of the Fortune 100 among its Intranet clientele. According to Forrester Research, 22% of largest U.S. companies have deployed the Internet concept on an Intranet basis [13-53]. From its humble beginnings in 1995, it is anticipated that the market for Intranet software will exceed $1 billion by 1997.

Intranets can be used for communications to and between employees for just about any purpose imaginable. A number of corporations use Intranets to keep their employees advised of company policies, job postings, company events, product literature, press releases, and so on. As is the case with the Internet and World Wide Web, images, video clips and sound clips can be added to textual information. Hypertext links can be included to hot link to other sites and databases, and even to the Internet and WWW.

Effective Intranet examples abound. Compaq Computer allows employees to tap into their Intranet in order to reallocate investments in 401(k) plans. National Semiconductor uses its Intranet to schedule departmental meetings online. Ford used an extended Intranet to link engineers in Asia, Europe, and the United States in order the assist in the design of the 1996 Taurus automobile. Silicon Graphics, which dubbed its Intranet Silicon Junction, provides access online to over two dozen corporate databases. Previously, access to that information was on the basis of a paper request to an information access expert, a process that could take days. Even Hollywood has gotten into the act. DreamWorks SKG is using an Intranet to link production managers and artists toward the development of the full-length animated movie Prince of Egypt. The company will use the technology to track the status and progress of projects and animation objects, and to coordinate scenes. Plans are to expand its use to other projects, including movies, music and TV shows [13-54].

Healthcare organizations have made fairly extensive use of Intranets to link remote clinics, reducing paperwork and abbreviating communication time [13-55] and [13-56]. Kaiser Permanente has put the Intranet concept to use to keep employees abreast of changes in health legislation and insurance law, as well as to provide access to company telephone directories and human resources manuals [13-57].

Eli Lilly uses its Intranet to schedule clinical trials of new drugs and to speed the process of regulatory submissions in 120 countries. The company’s initial implementation of 3,000 desktops was accomplished at a costs of about $80,000. Plans are to hook up approximately 16,000 employees, or about one-third of its entire staff. The company considered groupware products such as Lotus Notes, but found the costs unfavorabe because of the training and support requirements when compared to the Intranet alternative [13-58].

On the carrier front, the major IXCs all offer network-based Intranet services, or intend to do so. By way of example, MCI offers Safenet, which is a highly secure offering intended for financial institutions and the like. MCI also plans, in alliance with Digital Equipment, for more general consumption, services dubbed Website and Enterprise Connect [13-59].

In the continuing battle for the desktop, Microsoft Windows is in contention with Netscape and other browser manufacturers, although alliances are the likely outcome. As we noted in the case of Eli Lilly, the groupware manufacturers also are in the middle of this battle, and appear to be at a decided disadvantage. The Intranet approach offers numerous advantages, including multiplatform functionality, low cost of connectivity, low cost of application development, and scalability. Additionally, the Intranet uses the same browsers as one would use for Internet applications, avoiding the training and support requirements imposed by another application software package such as groupware.

In response to the challenge of the Intranet and browser software, groupware manufacturers such as Lotus have lowered prices dramatically for both client and server software. They also have improved the user interfaces to make them more browser-like. Lotus Notes (version 4, January 1996) even includes its own browser that can be used for Web access and search.

Internet Security

The Internet is inherently insecure. It is, after all, an open network—that is its major strength and its major weakness. While commerce is promoted as the future of the Net, lack of security has slowed development of commercial applications. However, it is worth noting that providing your credit card number over the Net is probably as secure as is giving your credit card to a server at a restaurant.

In a typical retail environment, one’s credit card is swiped through a card reader, which reads the magnetic stripe and transmits the credit card number to an authorization clearing house. The leading manufacturer of such devices is VeriFone, which announced in August 1995 its intentions to acquire Enterprise Integration Technologies (EIT), a leader in the development of Internet security systems and protocols. Commerce on the Net promises to be big business, although well into the future.

Beyond security concerns over Internet commerce, one must remember that access to the Net is a two-way door—just as users can get out, others can get in. All too often, those others have no legitimate right to do so. Although few organizations will admit to having had their systems breached via the Internet, it is clear that such occurrences are all too common. A 1995 study by the National Computer Security Association indicated that more than half of the 250 information-security chiefs polled had experienced Net-related security breaches during the past year. A similar poll conducted of 1,290 IS executives by Information Week and Ernst & Young indicated that 20% of the companies had experienced break-ins or attempts [13-60].


Communications Systems and Networks:The Internet (the Net) Environment

Security Risks and Countermeasures

The Net is rife with risks. Hackers, crackers, saboteurs and other unsavory characters abound, eagerly attacking the Net and its users at every opportunity. The risks include system intrusion, unauthorized data access, system sabotage, planting of viruses, theft of data, theft of credit card numbers, and theft of passwords. While the Internet and WWW can’t be blamed for the concepts and practice of mischief, fraud, theft, and other socially unacceptable forms of behavior, they certainly provide another high-tech cyberalley on the Information Superhighway. As noted by Panchatantra in the fifth century B.C.: “Not a cow, nor a gift of land, nor yet a gift of food, is so important as the gift of safety, which is declared to be the great gift among all gifts in this world.”

CERT (Computer Emergency Response Team) at Carnegie-Mellon University comprises a group of experts which are responsible for overseeing security issues on The Net. While it is highly doubtful that a single security measure or standard will prevail in the near and distant future, there exists a number of options, including message encryption, authentication, and authorization. Firewalls, incorporating much of the above, recently have gained the spotlight in terms of a defense mechanism.

Encryption

Encryption involves scrambling and compressing the data prior to transmission. The receiving device will be provided with the necessary logic in the form of a key to decrypt the transmitted information. Encryption logic generally resides in firmware included in standalone devices, although it can be built into virtually any device. For instance, such logic now is being incorporated into routers, which can encrypt/decrypt data on a packet-by-packet basis. Encryption comes in two basic flavors, private key, and public key.

Private key encryption, also known as single-key or secret-key encryption, requires that the key be kept secret.

Public key encryption involves the RSA encryption (encoding) key that can be used by all authorized network users—the key for decoding is kept secret. Public key encryption is freely available on the Net via a program known as PGP (Pretty Good Privacy), developed by Philip Zimmerman. PGP was under a cloud for some time, as there was concern that it was so powerful as to be in violation of U.S. technology export laws. By the way, encryption technology technically is classified under U.S. law as a form of munitions. The commercial version of PGP is known as ViaCrypt PGP, offering an improved user interface.

Data Encryption Standards

Data encryption standards include DPF (Data Private Facility), DES, RSA and Clipper. DES (Data Encryption Standard), which uses a challenge-response approach and intelligent tokens, was formulated by the U.S. National Bureau of Standards. RSA, named after its developers, Rivest, Shamir and Adleman, is the standard for public key encryption. Clipper, an encryption standard developed by the U.S. government, uses escrowed keys to permit government deciphering through a back door. Clipper, which is non-exportable, is used extensively by the U.S. government and those who wish to do business with it. Encryption programs used on the Net include SSL, S-HTTP, and combinations of them.

Secure Socket Layer (SSL)
from Netscape negotiates point-to-point security between client and server, including type of encryption scheme and exchange of encryption keys. SSL sends messages over a socket, which is a secure channel at the connection layer, existing in virtually every TCP/IP application. While SSL can accommodate a number of encryption algorithms, Netscape has licensed RSA Data Security’s BSafe to provide end-to-end encryption, as well as key creation and certification. Netscape’s Netsite Commerce Server technology, including SSL, has been licensed by the likes of DEC, Novell, the Bank of America and Delphi. Socket, by the way, is an operating system abstraction that allows application programs to automatically access communications protocols. The concept was developed by Bolt Beranek and Newman in conjunction with the company’s early work on TCP/IP.
Secure HyperText Transport Protocol (S-HTTP)
from Enterprise Integration Technologies also negotiates point-to-point security between client and server although at the application layer. EIT has licensed RSA Data Security’s BSafe TIPEM (Toolkit for Interoperable Privacy-Enhanced Messaging). S-HTTP is a superset of HTTP and, therefore, is specific to The Web. Several manufacturers of Web servers have announced plans to include S-HTTP in their products. S-HTTP has gained the support of the WWW Consortium, and looks to be moving toward acceptance as a de facto standard.
SSL and S-HTTP
are being linked by Terisa Systems, Inc., which was founded by RSA and EIT. Investments in the company and its technology have been made by IBM, CompuServe, America Online, Prodigy and Netscape.

Authentication

Authentication provides a means by which network managers can authenticate the identity of those attempting access to computing resources and the data they house. Authentication consists of Password Protection and Intelligent Tokens.

Password protection
should be imposed to restrict individuals on a site, host, application, screen, and field level. Passwords should be of reasonably long length, be alphanumeric in nature and be changed periodically. There is a current trend toward the use of dedicated password servers for password management.
Intelligent tokens
are hardware devices that generate one-time passwords to be verified by a secure server. They often work on a cumbersome challenge-response basis.


Communications Systems and Networks:The Internet (the Net) Environment

Authorization

Authorization provides a means of controlling which legitimate users have access to which resources. Authorization involves complex software which resides on every secured computer on the network. Ideally, it provides single sign-on capability. Authorization systems commonly used in support of Net security include Kerberos, Sesame, and Access Manager.

Kerberos
draws its name from Kerberos (also known as Cerebrus), the three-headed monster which guarded the entryway to the infernal regions in Greek mythology. Perhaps the best known authorization software, it was developed by the Massachusetts Institute of Technology (MIT) and is available without charge, although more powerful commercial versions exist as well. As Kerberos uses DES, it is not easily exportable. IBMs Kryptoknight is a Kerberos variant, weaker but exportable. By way of example, EIN uses Kerberos in its Secure Server product. Although Hercules defeated Kerberos, according to Greek legend, a hacker of Herculean proportions has yet to emerge victorious over this powerful software.
Sesame (Secure European System for Applications in a Multivendor Environment)
was developed by the ECMA (European Computer Manufacturers Association). It is flexible, open and intended for large, heterogeneous network computing environments. It also is highly complex and not effective for smaller applications.
Access Manager
recently approved by the IETF, uses an API for application development, employing scripting. Scripting involves a process of mimicking the log-on procedures of a program, providing basic levels of security for small networks.

Firewalls

Firewalls are application software that reside in a communication router, server, or some other device. That device physically and/or logically is a first point of access into a networked system (see Figure 13.5). On an active basis, the device can block access to unauthorized entities, effectively acting as a security firewall. Firewalls provide logging, auditing, and sucker traps to identify access attempts and to separate legitimate users from intruders. Firewalls can be in the form of a programmable router ([ge]$3,000) or a full set of software, hardware, and consulting services such as offered by DEC in the form of SEAL (Screening External Access Link) ([ge]$25,000). While detailed discussion of firewalls is beyond the scope of this book, the intensity of interest is indicated by references [13-61] through [13-66].

Figure 13.5 Firewall implementation in a router.

SATAN

SATAN (Security Administrator Tool for Analyzing Networks) is software designed to identify and report security weaknesses, including unauthorized access and virus contamination. Through mimicking an intruder, the software was designed to identify security holes and to alert the system administrator of their presence. Very easy to use as a result of its Mosaic interface, SATAN unfortunately also can be employed to crack the very security it is intended to ensure. SATAN was developed by Dan Farmer of Silicon Graphics and Wietse Venema of the Netherlands University of Eindhoven. When Farmer made SATAN available, free-of-charge, on the Internet on April 5, 1995, he separated from Silicon Graphics, officially by mutual consent.

CERT issued a SATAN advisory warning on April 10, 1995. That warning suggested that SATAN posed significant risk of intrusion when run with certain Web browsers, including Netscape and Lynx, but not Mosaic. The danger is presented if a user moves immediately from a session running SATAN to browsing the Web, without first quitting the browser. The very next day, Dan Farmer posted SATAN v.1.0 on the Web. That version offers tighter security and warns users of the potential for system vulnerability.

Misuse and Content

There have been a large number of highly publicized cases of the Internet and the Web having been misused for illicit and immoral purposes including transmitting stolen credit card numbers and cellular telephone ID numbers. While any communications medium can be used for such purposes, the Net creates another set of difficulties for law enforcement, as communications are virtually instantaneous and multiple parties can gain access to the illegal data through a bulletin board. Further, it is difficult if not impossible in many cases to track down the offenders.

The U.S. Federal Communications Commission (FCC), however, is seriously considering regulating the content of the Internet. While censorship can go too far, there are numerous and clearly documented cases of beasts who prowl the Net. (Author’s humble opinion: At the risk of lapsing into a discussion of morals, there should be a method for constraining those who would use the Net and the Web for immoral purposes as defined by law. At the very least, there should be a means of blocking access of minors to such material. There also should be stiff penalties imposed on violators.)

The Electronic Frontier Foundation, Electronic Privacy Foundation, and Voters Telecommunications Watch are battling the FCC and U.S. Congress in this regard, citing freedom of speech; petitions were passed (you guessed it) over the Internet. Although a Communications Decency Act was passed in 1996, it was overturned in Federal District court, citing violation of free speech as guaranteed by the First Amendment to the Constitution. Tthe federal government is expected to appeal to the U.S. Supreme Court. Should the Act be upheld, remaining to be addressed would be the issues of who would assume the role of cybercop, and the extent to which the service providers would be held liable for the transgressions of their subscribers. While we may never see Net content censored, there do exist a number of commercially available software filters that allow parents to deny access to Internet sites which might contain unsavory content, as defined by the filter developers. Those filters run against Web servers, which are updated on a regular basis in order to keep pace with the dynamics of the Web sites and their content. Outside the United States, very tight content controls have been exercised in some countries; as one might expect, those nations include Singapore and the Peoples Republic of China (PRC).


Communications Systems and Networks:The Internet (the Net) Environment

Internet Oddities, Screwball Applications, and Some Really Good Ideas

As mentioned previously, the applications for the Net are limited only by the technology and the human mind. There have been a number of recent announcements of Internet oddities and screwball applications. The author leaves the distinctions to the reader. By the way, many of these actually work; others probably will, someday.

Package Tracking is offered on the Web by Federal Express and UPS. The customers of both carriers can access the Web sites and get the latest status of packages, based on package tracking numbers. In combination, these 2 carriers report well over 400,000 status inquiries per month handled in this manner. The savings are in millions of dollars, compared to the costs of handling voice calls through an incoming call center.

Distribution of software, upgrades and bug fixes is a really good idea. In many cases, software is provided free-of-charge as a public domain release; subsequently, enhanced versions are provided commercially.

Online publishing has really taken off over last several years. A large number of major newspapers have developed Web sites to test the medium, but only two newspapers reported 1995 advertising revenues in excess of $100,000. Most of the technology publications have developed Web sites for online access to published articles and late-breaking news. Advertising revenues are not made public.

Virtual Reality and 3-D services are proposed and even offered, although on a limited basis. Silicon Graphics announced WebSpace (March 30, 1995), largely for home-shopping applications. The SG software is available, in test version, over the Net at no charge. Later versions are proposed to be available for $49.

CyberFairs are job fairs that allow companies to post job listings and recruit applicants online. Interactive communications are supported.

CyberGambling (Now there’s a constructive idea!) is now being offered by casinos. The casinos are able to circumvent U.S. gambling laws by placing their servers offshore. Users are required to have offshore bank accounts, as well, in order to deposit their winnings (Virtual Vegas is just what this country needs to tempt the shut-ins and elderly who are addicted to gambling.) At the time of this writing, it is unclear whether Gamblers Anonymous has a Web site.

Author’s Explanations

Lynx is a text-based Web browser that can be run from a UNIX shell account. Lynx displays only unadorned ASCII text, with no styling, pictures, graphics or other frilly stuff like that.

Digerati is an insider’s term for the digitally literate (digital literati). Such people also are known as NetHeads, Bit Flippers and GearHeads.

Grep refers to Generalized Regular Expression Parser, a powerful UNIX search utility. Grep is capable of searching a text document or program, finding and displaying or printing lines of text or code which contain a specific character string. If it doesn’t grep, it’s not a real computer, is an inside joke conceived by and for UNIX programmers.

References

[13-1] Cerf, Vinton G. and Kahn, Robert E. “A Protocol for Packet Network Interconnection.” IEEE Transactions on Communications. Institute of Electrical and Electronics Engineers. 1974.
[13-2] Comer, Douglas E. Internetworking with TCP/IP. Second Edition. NY: Prentice Hall. 1991.
[13-3] Metcalfe, Bob. “Coming Internet Collapse Spurring Shortsighted Proliferation of Intranets” InfoWorld. May 20, 1996.
[13-4] Muller, Nathan. “Dial 1-800-Internet.” BYTE. February 1996.
[13-5] Feit, Sidnie.TCP/IP: Architecture, Protocols and Implementation. NY: McGraw-Hill Inc. 1993.
[13-6] Miller, Robert and Keeler, Elissa. Internet Direct: Connecting through SLIP and PPP. NY: MIS:Press. 1995.
[13-7] Krick, John H. “Introduction to the Internet.” Datapro Communications Analyst. Delran, NJ: Information Services Group. September 1994.
[13-8] Wilder, Clinton. “The Net on the Edge.” Information Week. April 29, 1996.
[13-9] “MCI to Upgrade Internet Backbone.” Information Week. March 25, 1996.
[13-10] Wexler, Joanie. “MCI and BT to Meld Net Backbones.” Network World. June 17, 1996.
[13-11] Andrews, Paul. “Could this be the End of the PC as We Know It?” The Seattle Times. March 31, 1996.
[13-12] Andrews, Paul. “Out with the PC, In with the Net Reader?” The Seattle Times. April 7, 1996.
[13-13] Gates, Bill. “Proposals for Cheap Internet Terminal are Misguided, Computer History Shows.” Skagit Valley Herald. April 10, 1996.
[13-14] Lee, Yvonne L. “Japan Computer Corp. Unveils Internet Device.” Infoworld. February 26, 1996.
[13-15] Melford, Bob. “Are $500 Internet Terminals in your Future?” Digital News & Review. March 1996.
[13-16] Silwa, Carol and Messmer, Ellen. “'Net Devices Coming…But What are They Good For?” Network World. May 20, 1996.
[13-17] Weston, Rusty. “The Survey Says: Internet Terminals Hold Little Appeal.” PC Week. November 27, 1995.
[13-18] Carl, Jeremy. “Universal Access to Internet: Who Pays?” Web Week. May 20, 1996.
[13-19] Muller, Nathan J. “Using the Internet.” Datapro Communications Analyst. Delran, NJ: Information Services Group. December 1994.
[13-20] Davis, Jessica. “AT&T Internet Pricing Rattles Rivals.” Infoworld. March 4, 1996.
[13-21] “AT&T Says It’s No. 2 Pure Net Access Provider.” The Seattle Times. May 26, 1996.
[13-22] “Buyers’ Guide: National Internet Service Providers.” PC Week. November 27, 1995.
[13-23] Wexler, Joanie and Greene, Tim. “MFS Buys $2b Slice of the ’Net.” Network World. May 6, 1996.
[13-24] Willis, David with Milne, Jay. “Domestic Internet Service Providers: Adapt or Perish.” Network Computing. June 1, 1996.
[13-25] Greene, Tim. “UUNET Won’t Wait for High-Speed ’Net Access.” Network World. June 17. 1996.
[13-26] Rendleman, John. “PacBell, LCI Offer Internet Access.” Communications Week. June 10, 1996.
[13-27] Maddox, Kate. “Cable Answers the Call.” Information Week. June 3, 1996.
[13-28] Saho, L. Michael. “Transmission Control Protocol/Internet Protocol (TCP/IP).” Communications Analyst. Delran. NJ: Datapro Information Services Group. March 1994.
[13-29] Raisch, Robert. “Imminent Death of the Internet: Realtime Video at 11.” Inter@ctive Week. May 20, 1996.
[13-30] Remstad, Evan. “Broadcast Services Expanding on the Internet.” Skagit Valley Herald. December 16, 1996.
[13-31] Heck, Danny. “Entering the Age of the Internet.” Seattle Post-Intelligencer. May 19, 1996.
[13-32] Attride, Robert. “Voice on the Internet.” White Paper, J. Alexander Securities, Inc.
[13-33] Barker, Ben. “ACTA Acts Up, Seeks Congressional Relief.” Communications Week. May 27, 1996.
[13-34] Bort, Julie. “Telephony Comes of Age.” InfoWorld. May 20, 1996.
[13-35] Buerger, Dave. “Competition? Internet Phones Make Telephone companies Call for FCC Help.” Network World. March 11, 1996.
[13-36] Copilevitz, Todd. “Dialing Long-Distance on The 'Net.” San Francisco Examiner. March 5, 1995.
[13-37] Duncan, Rebecca J. “Addressing the Issues: Internet Security.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. September 1994.
[13-38] Gibbs, Mark. “No More freelunch.com on the ’Net.” Network World. September 25, 1995.
[13-39] Glaser, Mark. “The Internet as Telephone: Fad or Future?” NewMedia. November 1995.
[13-40] “Internet Firewalls.” Datapro Communications Analyst. Delran, NJ: Datapro Information Services Group. May 1995.
[13-41] “Internet Voice Traffic Makes a Big Noise.” Tele.com. May 1996.
[13-42] Jorgensen, Jacob. “The Transmission of Interactive Voice Over the Internet.” BYTE. March 1996.
[13-43] Morreale, Herb. “The Internet Threat to Telephone companies.” Convergence. May 1995.
[13-44] Neubarth, Michael. “The Phones They Fear.” Internet World. June 1996.
[13-45] Rebber, Roger. “Connecting Your Call Center To The Web.” Call Center Magazine. May 1996.
[13-46] Retkva, Rosalyn. “Telephone Politics.” Internet World. June 1996.
[13-47] Venditto, Gus. “Internet Phones: The Future is Calling.” Internet World. June 1996.
[13-48] Wexler, Joanie. “Giants Back Voice Over ’Net.” Network World. March 18, 1996.
[13-49] Blum, Adam. Building Business Web Sites. NY: MIS:Press. 1996.
[13-50] Metcalfe, Bob. “Do the Numbers Add Up to an Intoxicated Internet Facing a Hangover?” InfoWorld. March 11, 1996.
[13-51] Carey, Anne R. and McLean, Elys A. “Buying On Line.” USA Today. July 15, 1996.
[13-52] Rafter, Michelle V. “Firms Commercialize Cyberspace In Rush Of Ads On World Wide Web.” Seattle Times. December 17, 1995.
[13-53] Colman, Price. “The Key to the Digital Universe: Intranets.” Convergence. March 1996.
[13-54] Cortese, Amy. “Here Comes the Intranet.” Business Week. February 1996.
[13-55] Rice, Valerie. “Health Group Gets Intranet Treatment.” PC Week. May 6, 1996.
[13-56] Booker, Ellis. “Intranet Ties together Branch Offices for Health Care Provider.” Web Week. May 20, 1996.
[13-57] “Intranets: An Inside Look at Real-World Applications.” Internetwork. May 1996.
[13-58] Gross, Neil. “Oh, What a Tangled Web.” Business Week. February 26, 1996.
[13-59] Higgins, Kelly Jackson. “Intranet Virtual Realities.” tele.com. May 1996.
[13-60] Violino, Bob. “Your Worst Nightmare.” Information Week. February 19, 1996.
[13-61] Haas, Steven Vonder. “Firewalls Address the Threat Within.” Inter@ctive Week. January 29, 1996.
[13-62] Lamb, Steven. “Here’s Why Internet Firewalls are Hot.” Internetwork. May 1996.
[13-63] Merenbloom, Paul. “Fire Walls are More Sophisticated But Also More Unruly.” InfoWorld. January 29, 1996.
[13-64] Paone, Joe. “Guarding the Internet Door.” Internetwork. December 1995.
[13-65] Sherizen, Sanford. “Fighting Fire with Firewalls.” Beyond Computing. March 1996.
[13-66] Snyder, Joel. “A Flurry of Firewalls.” Network World. January 29, 1996.


Communications Systems and Networks:Video Communications Defined and Evolved

Chapter 14
Video and Multimedia Networking

I have never received a telephone call that justified the excitement and fuss of the electronics involved. If I can’t see somebody I love, for instance, such as a daughter, or a son, I would rather receive a letter.

—William Saroyan, “Let’s Just Nobody Ever Forget Joan Castle.”Sons Come & Go, Mothers Hang in Forever, 1979

One may wonder how critical video and multimedia networking are to our daily lives. The answer is not clear. While we all understand that a picture can be worth a thousand words, the ability to engage in interactive video or multimedia communications currently is not necessarily all that important to most of us, either personally or professionally. Video and multimedia networking currently is expensive in terms of both bandwidth and equipment, although these costs will certainly come down over time. Many of the highly touted benefits have yet to be proven, although a compelling case is developing.

Certainly, video and multimedia have application in education. People tend to have different learning styles. Some are visual learners, some are auditory and still others tend to be more kinesthetic. In any event, the addition of the visual information stream certainly assists in the educational process, as it does in the communications process. A fascinating application is in the world of healthcare. As I will discuss later in this chapter, telemedicine has proved itself to be of great importance in the delivery of high-quality medical care to remote areas where specialists, and even general practioners, may not be available.

Video Communications Defined and Evolved

“What’s past is prologue,” wrote William Shakespeare in The Tempest. So it is in video, as it is in all of life and all of technology—without history, there is no future. Video (from the Latin video, meaningI see) communications has its roots in broadcast TV, which is transmitted over the airwaves, and still is the primary source of television in many areas and in most countries. The first true television mechanism was developed in 1884 by Paul Nipkow, a German engineer. Using a scanning disk, lenses, mirrors, a selenium cell, and electrical conductors, he was able to transmit images in rapid succession to a lamp, which changed in brightness according to the strength of the currents received. Using this mechanical scanning technique, Nipkow demonstrated that portions of a full image viewed in rapid succession (15 images or more per second) created the illusion of viewing the full image [14-l]. It later was discovered that viewing 15 or more images per second created the illusion of full motion due to electrochemical processing delays in the human eye. While this mechanical scanning approach was abandoned in later years, the concept of persistence of vision remains valid. A second process, know as the phi phenomenon, was first explained by psychologist and film theorist Hugo Munsterberg in 1916. This process explains the fact that we hallucinate, or believe that we see, a continuous action, rather than a series of still images—the mind, in effect, fills in the blanks [14-2]. Modern television and video systems create the illusion of motion by refreshing screens in rapid succession, a dot at a time and a line at a time.

The development of modern television was largely due to the efforts of Herbert E. Ives, a scientist at Bell Telephone Laboratories. Son of Frederick Eugene Ives, who in 1878 developed the first practical process for making halftone printing plates, Ives was oriented toward the visual world. He and his associates in 1923 combined the photoelectric cell with the vacuum tube repeater to produce the first commercial system for the rapid transmission of pictures over telephone wires, for use by newspapers. Using a scanning beam developed by Frank Gray, another Bell Labs scientist, multiple realtime images of people were transmitted in rapid succession and television was born. The first public demonstration was held in April 1927; with color television was demonstrated in June 1929 [14-3]. That experimental transmission included the transmission of pictures of an American flag, a watermelon, and roses. The transmitting system had three sets of photoelectric cells, amplifiers and glow-tubes, with each filtering out one color—red, green, or blue (RGB). At the receiving end, mirrors superimposed the monochromatic images to create a single color image [14-1]. In the 1930s, the first commercial television stations began operation over the radio waves.

Coaxial cable entered the world of television in 1936, with the first experimental transmission taking place between New York and Philadelphia. Jointly conducted by AT&T and the Philadelphia Electric Storage Battery Company (Philco), the experiment proved highly successful in terms of transmission performance as multiple frequencies could be transmitted over the same shielded (noise-free) medium. In 1950, AT&T opened the first coaxial cable for coast-to-coast TV transmission [14-4]. Community Antenna TeleVision (CATV), generally based on coaxial cable, largely has supplanted broadcast TV in the U.S. Relatively recently CATV has spread to a number of other developed countries, including England and Australia.

At this point, only two key evolutionary concepts remain—those of the iconoscope and kinescope. Vladimir Zworykin, a Russian immigrant, built on his graduate work in Russia where had studied the nature of fluorescence under Boris Rosing. On January 1, 1939, Zworykin received patents for his iconoscope (transmitting) and kinescope (receiving) tubes. These patents formed the basis for modern cameras and cathode ray tubes used as display devices (TV sets and computer monitors) [14-1] and [14-5].

Video communications extends well beyond broadcast TV and CATV, into videoconferencing, multimedia communications, and, ultimately, interactive TV. In this chapter the nature of the equipment and networks which support video and multimedia collaborative communications will be explored, as will related standards and costs.


Communications Systems and Networks:Video Communications Defined and Evolved

Video Basics

In order to fully understand the nature and implications of advanced video communications, it is necessary to comprehend the basics of video. The basic concepts are those of frame rate, scanning, resolution, aspect ratio, luminance, chrominance, and synchronization.

Frame rate
refers to the rate at which frames of still images are transmitted. Video is a series of still images that are transmitted in succession in order to create the perception of fluidity of motion. If transmitted in rapid succession, the perception is one of complete fluidity—24 frames per second (fps) is considered to be motion picture quality, while 30 fps is considered broadcast quality. If the frames are transmitted at a slow rate, the result is a herky-jerky video of poor quality. Particularly below 15 fps, quality suffers quite noticeably.
Scanning
refers to the process of refreshing the screen in horizontal lines. Odd lines are refreshed in one scan, and even lines in the next. Each set of odd and even lines refreshed constitutes a frame refreshed, with the scanning rate being a function of the power source of the receiver. For example, the American NTSC standard provides for 30 fps, involving 60 scans, which relates directly to the 60 Hz of the U.S. power source.
Resolution
refers to the definition, or sharpness, of the image. Resolution is determined by the number and density of the pixels (picture elements), which essentially are dots of picture. The greater the number and density of the pixels, the better the resolution. If the same number of pixels are spread over a greater area, the result is a grainier picture, as one can readily see by sitting close to a big-screen TV.
Aspect ratio
refers to the relationship between the width and the height of the image. The 4:3 (4 wide to 3 high) aspect ratio specified by the American NTSC standard is rooted in the early days of television, when round picture tubes made effective use of this approach.
Luminance
refers to intensity, or brightness, which can vary within an image. A video transmission varies the luminance by varying the power level, or amplitude, of the signal.
Chrominance
refers to color, with different standards allowing for varying levels of color depth. Clearly, the video image is more pleasing and life-like when the variation of color is as broad as possible.
Synchronization
includes vertical and horizontal synchronization, both of which are critical. Vertical synch is required to keep the picture from scrolling or flipping. Horizontal synch keeps the picture from being twisted.

Analog TV Standards

The initial television standards were set in the United States, where broadcast TV originated. The FCC set the initial VHF transmission standards in 1945 at 4.5 MHz. The National Television Standards Committee (NTSC) was formed in 1948 to standardize the characteristics of the broadcast signal. Ultimately, the Radio Corporation of America (RCA), which was owned by AT&T, lobbied the Electronics Institute of America (EIA) and set the initial black-and-white TV standards. Color TV was commercialized some years later. Among the first live color broadcasts were the Cotton Bowl and Rose Bowl games on January 1, 1954 [14-1]. As the cost of color TV sets was quite high, color didn’t really take off until the 1960s when sets became affordable for the masses. Major analog standards are NTSC and PAL, which are compared to digital HDTV in Table 14.1.

Table 14.1 Television standards compared: NTSC, PAL, and HDTV.
 | NTSC | PAL | HDTV
Analog/Digital | Analog | Analog | Digital
Scanlines | 525 | 625 | 1,920 or 1,280
Synchronization | 40 | 49 | N/A
Resolution (pixels per line) | 640 | 640 | 1,080 or 720
Frame Rate (fps) | 30 | 25 | 60, 40, or 24
Aspect Ratio | 4:3 | 4:3 | 16:9
NTSC (National Television Standards Committee)
was established in the United States as the first standard (1953), setting the tone for broadcast TV. While other standards have since been developed, they all derived from the NTSC baseline. NTSC is characterized as analog in nature with 525 scanlines. There are 640 pixels per line, 485 of which are dedicated to the active picture. The frame rate is 30 fps and the aspect ratio is 4:3. An early analog standard that is viewed as being overly complex and ineffective in the contemporary digital world, NTSC is also said to mean “Never the Same Color” [14-6].
PAL (Phase Alternate Line)
was established in western Germany, The Netherlands, and the United Kingdom in 1967. PAL addresses the problems of uneven color reproduction that plagued NTSC due to phase errors associated with signal propogation. PAL inverts the color signal by 180º on alternate lines, hence the term Phase Alternate Line [14-6]. PAL is currently used in much of western Europe, Australia, and Africa. PAL is characterized as analog, with 625 scanlines. There are 640 pixels per line, with 576 dedicated to the active picture. The frame rate is 25 fps, and the aspect ratio is 4:3.
SECAM (Systeme Electronique Couleur Aven Memoire)
a variation of PAL, was developed in France. In addition to its use in France, it also is the standard in regions once under the influence of France, including areas of the Middle East.


Communications Systems and Networks:Video Communications Defined and Evolved

Digital TV

Digital TV still is very much in the early stages of development. Digital TV transmission offers the same advantages as any other form of digital communications, including enhanced bandwidth efficiency and signal quality management and control. Digital video is nothing more than data, offering advantages in terms of processing, storage, and manipulation. These advantages include editing, alteration (morphing), reproduction, compression, transmission, storage, and store and forward capability.

In its native form, video (or TV) comprises synchronized analog voice and analog image information. Digital video requires that the information be digitized through the use of a video codec. Because a broadcast quality video signal is extremely bandwidth- and storage-intensive, the resolution of such digital video requires 640 horizontal pixels and 480 vertical; chrominance and luminance require 24 bits/pixel; and the frame rate is 30 fps. The video signal alone requires 7,372,800 bits per frame. At a frame rate of 30 fps, the bandwidth requirement is 221,184,000 bps. Clearly, it is not within the realm of reason to transmit a broadcast quality video signal requiring 221+ Mbps. It is clear that the storage requirements are incredible and compression is critical if the networks are to support digital TV.

High Definition TV (HDTV)

Despite all the advantages of digital technology as applied to television production, storage and transmission, all of the TV sets are analog. A conversion from analog to digital broadcast TV is revolutionary and completely unthinkable, unless there exists a compelling reason for the changeout of untold millions of TV sets. That compelling reason could (but probably won’t) take the form of HDTV (High Definition TV).

The definition of HDTV standards caused a debate that raged for a number of years between Japanese analog standards and digital standards proposed by the United States. The U.S. digital standards proposals focused on those offered by the Grand Alliance, comprising AT&T, General Instruments, Zenith, The Massachusetts Institute of Technology (MIT), Thompson Consumer Electronics, Philips Consumer Electronics and the David Sarnoff Research Center. It appears as though the Grand Alliance has won the battle, at least within the United States [14-7]. While the standards have yet to be fully determined, HDTV will be digital, with an aspect ratio of 16:9. The number of scanlines will be either 1,920 or 1,280; resolution will be either 1,080 or 720 pixels per line; and the frame rate will be either 60, 40 or 24 fps. At the time of this writing, the future of HDTV remains very uncertain. Although the quality of the presentation is much improved, the bandwidth required is significant and entirely new equipment is required. Additionally, digital radio spectrum must be cleared in order to support digital TV alongside existing analog broadcast, until such time as the conversion is complete. The FCC has taken the position that the cost of clearing that spectrum will be the burden of the private sector.

Bandwidth and Compression

The bandwidth required for video transmission is significant, affected by frame rate, resolution, color depth, aspect ratio, and audio. Broadcast-quality TV requires about 6 MHz in analog form, of which the signal occupies about 4.5 MHz. As little can be done to compress an analog signal, analog TV is limited to airwave broadcast or CATV transmission over analog coaxial cable—in other words, analog is doomed!

Digital video, on the other hand, can be compressed fairly easily. Because uncompressed, broadcast quality, digital video requires between 90 Mbps and 270 Mbps, compression is critical. Without compression, a 1 Gbps fiber optic network could accommodate no more than 11 digitized NTSC channels. To digitize and compress the video information stream, the analog video and data signal first must be digitized through the use of a codec. Clearly, the amount of bandwidth required to transmit digital video, and the amount of memory required to store it, can be reduced by reducing the frame rate, resolution, or color depth. However, the result is less than pleasing. In order to maintain the quality of the video presentation, therefore, the data must be compressed using an appropriate and powerful data compression algorithm.

Lossless compression allows the video signal to be reproduced faithfully with no data loss and compression rates are in the range of 10:1. However, even the relatively new ITU-R 723 standard reduces the data rate to only 45 Mbps. Lossy compression results in a degraded picture, but allows compression at rates up to 200:1 [14-8]. Actually, compressed video currently can be transmitted with quite acceptable quality at T1 speeds of 1.544 Mbps or less. MPEG uses lossy compression in the form of DCT. There are a number of steps involved in video compression, including filtering, color-space conversion, scaling, transforms, quantization and compaction, and interframe compression.

Filtering
reduces the total frequency of the analog signal through a process of averaging the values of neighboring pixels or lines. For instance, a black pixel and a white pixel become a gray pixel. Taps are the number of lines or pixels considered in this process; MPEG, for instance, uses a 7-tap filter.
Color-space conversion
involves the reduction of color information in the image. As the human eye is not highly sensitive to slight color variations, the impact is not noticeable. Black and white, however, is prioritized, as the human eye is very sensitive at that level.
Scaling
addresses the creation of the digital image according to the presentation resolution scale. Rather than digitizing the video signal in large scale, the codec is tuned to the scale of presentation in terms of horizontal and vertical pixels, thereby reducing the amount of data that must be digitized. In consideration of this factor, the aspect ratio must be standardized.
Transforms
convert the native two-dimensional video signal into data dimensions. Although beyond the scope of this book, the various approaches include Discrete Cosine Transform (DCT), vector quantization, fractal transform, and wavelet compression.
Quantization and compaction encoding
reduce the number of bits required to represent a color pixel. Although again, beyond the scope of this book, compaction techniques include run-length encoding, Huffman coding, and arithmetic coding.
Interframe Compression
considers and eliminates redundant information in successive video frames. For instance, the background of a movie scene might not change, although the actors move around the set. While the motion of the actors must be reflected, the background need not be transmitted over the network—it can be compressed out of each frame until such time as background changes must be reflected.


Communications Systems and Networks:Video Communications Defined and Evolved

Video Standards

According to an anonymous, but very wise, man: “The nice thing about standards is that there are so many of them!” Video compression standards are no exception—they are numerous and incompatible. Early standards were developed for specific purposes, such as motion picture production (MPEG) and photographic editing (JPEG). Only recently has the ITU-T become involved in the development of international standards towards B-ISDN. In the videoconferencing world, numerous proprietary standards have been developed that require that the network involve equipment from only a single vendor.

As of late, a number of true standards (as opposed to proprietary standards) have developed. These video compression standards include Px64, JPEG, and MPEG and its variations. Virtually all manufacturers have embraced these standards, incorporating one or more of them into their systems alongside a proprietary compression technique. Generally involving Px64, this approach provides at least a minimum level of communication between systems of disparate origin—at least between fairly substantial systems. The world of desktop videoconferencing is much more parochial. Proprietary standards predominate, with the yield all too often being incompatibility [14-9]. As is always the case in networking, the lowest common denominator rules; lacking a common denominator, anarchy rules.

Px64

Px64is an ITU-T standard designed to support videoconferencing and various levels of bandwidth in increments of 64 Kbps up to a maximum of 2.048 Mbps (E1). (Note: p = 1-30 channels of 64 Kbps, with the maximum of 30 bearer channels being supported by E1.) Px64 specifies various frame rates and levels of resolution. Most manufacturers of videoconferencing equipment support Px64 as a lowest common denominator, although they each prefer their own proprietary standards in promotion of their own equipment and unique feature sets. Px64 also is known as H.261, referring to the specific ITU-T video coding standard, as well as the video formats. Those formats include CIF (Common Intermediate Format), which is optional, and QCIF (Quarter-CIF), which is mandatory in compliant codecs. H.261 supports 352 pixels per frame, 288 lines per frame and 30 frames per second, although lower frame rates also are supported.

Actually, H.261 is an element of the ITU-T H.320 umbrella standard for videoconferencing that addresses narrowband visual telecommunications systems and terminal equipment. Related ITU-T standards include H.221, which defines a frame structure for support of audiovisual teleservices in 64-Kbps channels; and H.222, which defines the frame structure for such services in an ISDN environment. While these umbrella standards truly are international in nature, the United States and European camps unfortunately (and not surprisingly) are divided over certain implementation aspects of the ITU-T standards. Specifically, the differences deal with the manner in which audio and still-frame graphics are handled. For example, the Europeans have adopted JPEG for graphics (ITU-T T.81), which is compatible with most PC-based graphics software. That approach is totally incompatible with the H.261 standard implemented in the United States, although it does provide a bridge to true multimedia applications [14-10].

JPEG

JPEG (Joint Photographic Experts Group) was developed jointly by the ISO and ITU-T. JPEG is a compression standard that is used for editing of still images, as well as color facsimile, desktop publishing, graphic arts, and medical imaging. A symmetrical compression technique, JPEG is equally expensive, processor-intensive, and time-consuming in terms of both compression and decompression. Motion-JPEG is used in the editing of digital video. JPEG is not appropriate for video transmission, as the compression rate is in the range of only 20:1-30:1. JPEG transmission in support of videoconferencing requires bandwidth in the range of 10 to 240 Mbps.


Communications Systems and Networks:Video Communications Defined and Evolved

MPEG

MPEG (Motion Picture Experts Group) standards are several and still in final development stages. MPEG standards provide very high compression levels and excellent presentation quality. MPEG is a joint technical committee of the International Standards Organization (ISO) and the IEC (International Electrotechnical Commission). MPEG offers the critical advantage of asymmetrical compression and decompression. Additionally, the standard is supported by IBM, Apple, AT&T, and a host of other manufacturers and carriers. While the compression of the video signal is time-consuming and expensive, the decompression process is rapid and involves relatively inexpensive equipment. MPEG compression is as high as 200:1 for low-motion video of VHS-quality; broadcast quality can be achieved at 6 Mbps. Audio is supported at rates from 32 Kbps to 384 Kbps for up to 2 stereo channels.

MPEG 1
standardized in 1992, provides VHS (videotape) quality at 1.544 Mbps and is compatible with single-speed CD-ROM technology. In fact, it was designed to put movies on compact disc. MPEG 1 integrates synchronous and isochronous audio with video, and allows the random access required by interactive multimedia applications. Intended for limited-bandwidth transmission, it provides acceptable quality and output compatible with standard televisions. Current applications include video kiosks, video-on-demand, and training and education. Compression of about 100:1 is supported by MPEG-1.
MPEG 2
(1994) is the proposed standard for digital video at 4 to 100 Mbps over transmission facilities capable of such support (fiber optics, hybrid fiber/coax and satellite). While MPEG-2 requires much more bandwidth than MPEG-1, it provides much better resolution and image quality at much greater speed. While there remain technical issues associated with the transmission of MPEG 2 video over ATM, those issues are being addressed. MPEG 2 already has found application in Direct Broadcast Satellite (DBS) services, also known as Direct Satellite Systems (DSS). Such services employ Ku-band satellites and VSAT dishes in competition with CATV, running MPEG at rates of about 3 and 7.5 Mbps [14-11]. In a convergence scenario (Chapter 15), MPEG-2 is the standard of choice, supporting compression rates of about 200:1. MPEG 3, designed for HDTV application, was folded into MPEG-2 in 1992. [14-6].
MPEG-4
is a low bit-rate version intended for application in videophones and other small-screen devices. It is still under development.

Video Equipment

Video equipment includes transmit (camera) and receive (display) equipment that operate in concert with and through various intermediate devices in order to format the signal properly and otherwise treat it for effective transmission over a network. The intermediate devices include codecs, inverse multiplexers, servers and control units. A simple videoconferencing arrangement is presented in Figure 14.1.

Figure 14.1 Videoconferencing network employing cameras, codecs, and monitors.

Codecs
accomplish the process of digitizing, or coding, the analog signal on the transmit side and decoding it on the receive end. The codecs also accomplish the process of data compression and decompression, according to the specifics of the compression algorithm used. Additionally, codecs may include encryption features for security purposes. Codecs can be very inexpensive for PC-based systems, although, as in all of life, you get only what you pay for. Realtime MPEG 1 and MPEG 2 encoders range between $15,000 and $75,000; MPEG1/2 decoders can cost as little as $300.
Inverse Multiplexers (Inverse MUXs)
are used in commercial videoconferencing systems where dedicated bandwidth is not available for relatively bandwidth-intensive communications. An inverse MUX splits the video signal into two or more component parts that are transmitted over separate circuits or, perhaps, separate channels of multiple DS1 circuits. The Inverse MUX on the receiving end reassembles and resynchronizes the complete video signal for proper presentation.
Servers
are extremely high-capacity storage devices, containing many GBs (GigaBytes) of memory. Servers store video and audio data for delivery to clients on demand. While some video servers have found their way into business applications in a LAN environment, they are expensive and, therefore, unusual. Server technology primarily is aimed at a convergence scenario, in which video-on-demand will be delivered over ATM-based, fiber optic networks.
Multi-point Control Units (MCUs)
are digital switching and bridging devices which support multipoint videoconferencing, with up to 28 parties (sites) supported. MCUs must be compatible with the compression standards employed with the codecs. H.231 describes ITU-T MCU standards and T.120 describes generic conference control functions. MCUs are costly, ranging from $40,000 to over $200,000, depending on configuration and capability. MCUs may be found in the carrier network in support of a carrier videoconferencing service, or on the end user premise in support of a videoconferencing network based on leased lines.
Videophones
originated with the AT&T Picturephone, which was demonstrated at the New York World’s Fair in 1964. Never intended for legitimate application, the Picturephone was extremely bandwidth-intensive, requiring about 90 MHz, and weighed about 26 pounds [14-6]. During the past few years, AT&T, BT and others have developed videophones that sell for less than $1,000. As the cost is high—each party must have a videophone of the same manufacture—and the picture quality is poor (2 fps), videophones have been a market failure at the time of this writing.
But hold the phone, literally! Matsushita, the parent company of Panasonic, has developed and demonstrated the first version of a wireless videophone for use in Japan’s cordless phone system. The phone uses ITU-T standard video compression techniques to squeeze video down to a 32-Kbps channel for display on a 2.5-inch color LCD display. A 1/3-inch camera also is built into the device for video transmission at 3-7 frames per second [14-12].


Communications Systems and Networks:Video Communications Defined and Evolved

WAN Video Networks

Video networking can be accomplished over a number of facilities and service offerings, depending on the application and the amount of bandwidth required (Figure 14.2). Analog circuits will support videoconferencing at low speeds, although the results are less than completely pleasing. The failed videophones offered by AT&T, BT and others make use of dialup analog circuits. As is always the case, digital circuits offer better performance than do analog circuits.

Figure 14.2 Videoconferencing across the Wide Area Network (WAN).

ISDN circuits are preferable to analog circuits, because they provide more bandwidth and better transmission quality. However, the greater cost and lesser availability of ISDN has slowed the acceptance of videophones based on ISDN technology. Switched 56/64 Kbps circuits can be used for videoconferencing, generally grouped or bonded to provide multiple channels. Switched 384-Kbps connectivity can be provided on the basis of Fractional DS1 or through ISDN PRI channels in a channel group known as HO.

DS-1 facilities support full-motion, high-quality videoconferencing over dedicated networks at rates up to 2.048 Mbps for E1 and 1.544 Mbps for T1. However, such facilities are costly and not widely deployed in such applications. Large user organizations with dedicated DS-1 backbone networks make highly effective use of videoconferencing, with the video communications contending with voice and data for network access through intelligent MUXs.

Broadband networks are much more capable of supporting the demands of videoconferencing. Frame Relay will support video, although that clearly is not the primary reason for its existence. While Frame Relay will perform well under normal circumstances, it is likely to yield herky-jerky video should the network suffer severe congestion. SMDS provides much better video performance than Frame Relay, due to improved congestion management and lesser latency. However, and as discussed in Chapter 11, SMDS is a MAN technology of limited availability. ATM undoubtedly will be the network technology of choice in a convergence scenario. ATM will offer tremendous bandwidth over fiber optic or hybrid fiber/coax networks and in support of voice, image, facsimile, and data traffic, as well as video.

LAN-Based Video Networks

LANs were not designed with video in mind, but neither were existing WANs for that matter. In any event, LAN technology has developed to the point that it will support video, although such implementations are still unusual and problematic. By way of example, a 10 Mbps Ethernet LAN may provide only 4 Mbps throughput; sharing that bandwidth among 20 or 25 users reduces the available bandwidth to unacceptable proportions. Additionally, LANs generally impose delay on the signal. This is especially true of Ethernet, as explained in Chapter 9.

The basic problem is that video is isochronous, or stream-oriented, traffic. LANs were not developed to support continuously streaming data. Additionally, video is highly bandwidth-intensive. Even 100 Mbps LANs have trouble supporting high-quality video intermingled with more traditional and legitimate LAN data traffic. Traditional (relatively speaking) LAN options for videoconferencing include Fast Ethernet, Switched Ethernet and FDDI. More recent technologies and standards include ATM and IsoEthernet.

Videoconferencing

Videoconferencing, at the time of this writing, clearly is the primary application for video networking. According to the MultiMedia Telecommunications Association (MMTA) and the International Teleconferencing Association, revenues for videoconferencing products and services grew from $2.3 billion in 1993 to $4.4 billion in 1995. Revenues are expected to reach $8 billion in 1997, for a compound annual growth rate of 33% since 1990. Computer Intelligence Infocorp estimates that in 1994 some 14,000 U.S. establishments had installed videoconferencing systems, with the education market leading the way at 21% of the total [14-13].

Videoconferencing systems consist of cameras, monitors, video boards, microphones, and speakers. Videoconferencing can be accomplished in the workplace over a LAN, although such applications are unusual—it generally is more effective, easier, and less costly to walk across the hall and hold a face-to-face meeting. Videoconferencing over the WAN, however, offers great benefits in terms of reduced cost and increased availability for meetings. Systems for videoconferencing can be quite substantial or can be PC-based. Videoconferencing has increased significantly over the past few years, as the cost of equipment and bandwidth have decreased. Videoconferencing systems comprise room systems, rollabout systems, and PC-based systems.

Room systems
are complex and quite expensive systems intended for videoconferencing between groups of people. While a specially designed room and equipment could easily cost $250,000 in the 1980s, a room system can be had for less than $25,000 today. Manufacturers include BT, Compression Labs, PictureTel, and VTEL. The three major U.S. IXCs have been providing room-based conferencing services for years from select locations through AT&T’s Global Business Video Services (GBVS), MCI’s VideoNet, and Sprint’s Video Select Bureau (SVSB) [14-14]. GTE and Pacific Bell also have joined the fray during the last few years. Rates are in the range of $150 to $300 per hour. Kinko’s Copy Centers began deploying services in 1994, with plans for availability in 100 locations [14-8].
Rollabout systems
essentially are portable and much less expensive versions of room systems, also intended largely for group-to-group conferencing. Such systems accounted for about 75% of the standalone equipment market in 1995, and are expected to capture 90% by 1998 [14-13].
PC-based systems
or desktop systems, are intended for person-to-person conferencing. PC-based systems are enjoying increased popularity, with the total cost generally being in the range of $1,000 to $5,000 per seat, plus the cost of the workstation [14-15], [14-16], [14-17], and [14-18]. Taking advantage of the 100 million desktop computers in corporate America alone, some estimate that revenues from PC-based systems will reach $1 billion worldwide by 1997. Others take a much less starry-eyed view, suggesting that the figures are more in the range of $120 million [14-13] and [14-19].The systems generally work over LANs or ISDN circuits, with workgroup systems generally costing in the range of $1,500 to $7,000 per seat. Prices are expected to drop precipitously during the next few years. Analog transmission is also accommodated by some systems through modems at speeds up to 9600 bps. As one might expect, the cost of the system and the network are directly related to the frame rate supported and the elegance of the compression technique employed. Manufacturers include Intel (ProShare), Compression Labs (Cameo), and Nortel (Visit). Inexpensive PC-based systems can be had for as little as several hundred dollars today. The cost is that of camera and codec, the latter of which fits into the expansion slot of a PC (386 or better) or Macintosh computer, with the monitor serving as the video presentation device. Inexpensive PC-based systems are being used for Internet videoconferencing, although quality is poor due to latency and data loss associated with packet-switching.

Great strides are being made in the support of PC-based videoconferencing systems that can be supported over LANs and, in the near future, through PBXs. As noted by Bob Metcalfe (of Ethernet fame), five out of six calls handled by a PBX never reach the WAN; rather, they are station-to-station. Although videoconferencing originally was touted as a means of reducing travel expense, it eventually may save more shoe leather than gasoline [14-20].


Communications Systems and Networks:Video Communications Defined and Evolved

Multimedia

Multimedia is a combination of voice, data, video, and image information—blended into a single, coordinated, and synchronized presentation—with strong emphasis on the visual. Multimedia systems consist of a combination of monitors, speakers, software, cameras, microphones, and very significant amounts of computer memory. Multimedia, in the purest sense, typically is supported on a standalone basis. Multimedia PCs are commonplace, supporting voice clips, data, video clips, and images for access to CD-ROMs. Although such multimedia systems are effective only in limited applications (training, education and research) the business market was estimated by Dataquest to have grown from $1.5 billion in 1993 to $3 billion in 1995. Dataquest further expects a continuing annual growth rate of 32%, with multimedia systems becoming commonplace by 1998 [14-21].

Multimedia networks, currently in their infancy, must support this demanding blend of data. The difficulty of multimedia networking is twofold. First, the data stream is highly bandwidth-intensive, due to the impact of video and image information. Second, multimedia is isochronous in nature, as the voice and video elements are stream-oriented. Therefore, the networks that support multimedia must provide substantial bandwidth. They also must accept and deliver the data stream on a regular, continuous, and reliable basis. Such network performance is found only in a few instances, including circuit switched (expensive), dedicated (expensive), or cell-switched (expensive) networks. In case you missed it, expensive is the operative word. While multimedia can be supported at lower cost through ISDN BRI, the bandwidth available is not sufficient to support high-quality video. Additionally, ISDN is relatively expensive (compared to analog circuits) and certainly is not ubiquitous. Multimedia networking in the LAN environment also is problematic—LANs just weren’t designed for the task. To be truly effective, multimedia must be networked—and on an interactive basis. Therein lies the problem!

Multimedia LAN servers are now offered by a small number of firms. Such servers can store 6 to 12 hours of compressed video (low-quality) on 36 GB at a cost of $20,000 to $40,000. As always, better quality is more expensive, and more of a bandwidth hog.

Software: Focus on Collaboration

Software must be in place to support electronic text, image, audio, and video information in a multimedia conference. While the voice and video aspects of the conference are supported in a fairly straightforward manner, the real and distinct advantage of multimedia conferencing is that of allowing multiple parties to collaborate on textual and graphic documents. Special software allows each party to contribute to such documents, in collaboration with the other parties—hence the term collaborative computing. During such a collaborative session, the original text document is saved, while each party contributes changes that are identified by contributor. Once the parties agree to the collaborative edits and enhancements, the entire text file is refreshed and saved.

Similarly, a design or a concept can be developed graphically and on a collaborative basis through whiteboarding, much as the parties would do on a physical whiteboard (or blackboard) in a face-to-face meeting. Typically, each party to the conference would have access to a special whiteboard pad and stylus. Each party can then modify the initial drawing, with each individual’s contribution being identified by separate color. Again, and once the group has agreed on the final graphic rendition, the graphic is saved and all screens are refreshed.

The clear benefits of such a collaborative process, conducted on a logical basis over a wide area network, include reduced travel time, reduced travel expense and increased speed of collaborative effort. Even in a LAN environment, shoe leather is conserved and productive time is maximized.


Communications Systems and Networks:Video Communications Defined and Evolved

LAN Networking

Multimedia over LANs, as noted previously, is problematic. Bandwidth certainly is an issue, as is flow control. Multimedia is not tolerant of delay due to its isochronous voice and video elements. Current options for LAN video and multimedia collaboration include Fast Ethernet, IsoEthernet, FDDI and ATM. In any case, one must be cautious in supporting multimedia over a LAN.

Fast Ethernet
will support multimedia, but not necessarily very effectively. Switched Ethernet at 100 Mbps, provides plenty of raw bandwidth, but contention at the switch remains an issue. Starworks (Starlight Networks) performs both multicast and peer-to-peer networking over a FDDI backbone connected to Ethernet switches. Starlight-networks claims that up to 40 users can be supported in this fashion. The company’s StarWare, running on top of Novell’s Netware, converts an existing server into a multimedia server, prioritizing video data.
Isochronous Ethernet (IsoEthernet)
recently was formalized by the IEEE 802.9a committee. As illustrated in Figures 14.3 and 14.4, IsoEthernet runs over Cat 5 UTP at 16 Mbps, with 10 Mbps reserved for standard Ethernet packet streams and 6 Mbps available for isochronous video/multimedia. Through this process of frequency division multiplexing, isochronous data (voice and video) is supported effectively and without interfering with the basic reason that LANs are deployed—data communication. The advantage is that Ethernet is everywhere. The drawback is that it is a solution limited to a LAN (read single-site environment)[14-22].

Figure 14.3 IsoEthernet bandwidth allocation.

Figure 14.4 IsoEthernet network in support of videoconferencing.

FDDI
clearly, is the most capable LAN standard for multimedia, although it also is expensive to deploy and support. FDDI’s sheer bandwidth of 100 Mbps and its token-ring access method (Figure 14.5) will support multimedia applications reasonably effectively, although it is possible that an intensive multimedia conference can speak to all of the available bandwidth. FDDI-II, still in draft form, specifically is intended to support isochronous traffic, as well as standard asynchronous LAN traffic. FDDI II will also be expensive.

Figure 14.5 Videoconferencing over FDDI.

ATM-based LANs
in the workplace will support multimedia quite nicely, even at 25 Mbps and 50 Mbps. ATM offers low latency, prioritized cell transport, and WAN connectivity. Workplace ATM is expensive, however, at around $1,000 per seat at 25 Mbps; higher speed ATM versions are considerably more expensive.
Dedicated LAN Networks
also have been developed for videoconferencing and collaborative computing. By way of example, VideoLAN Technologies in March 1996 unveiled a system that involves proprietary equipment and transmission technology. The system will support NTSC-quality video and full-spectrum audio between terminals as much as 2,000 feet apart. The system also is designed to support video-on-demand through the use of video servers, and is expected to be used in support of distance-delivered learning over the WAN. Not inexpensive, the system sells for $4,795 per seat and requires a dedicated network, rather than running alongside data in a legacy LAN environment [14-23].

MAN Networking

SMDS is the one true MAN technology capable of supporting multimedia at reasonable cost. SMDS will support isochronous traffic on a priority basis. SMDS is not widely available, however.

WAN Networking

ATM offers the greatest potential for multimedia over the WAN. Now being deployed at Gbps backbone rates and with DS1-DS3 access rates, ATM supports multimedia nicely. ATM, however, is expensive. The ultimate solution, of course, is B-ISDN, which is based on ATM network technology and which employs SDH/SONET as the physical infrastructure. B-ISDN will support a wide range of services, providing bandwidth-on-demand.

The Internet

The Internet also supports videoconferencing and multimedia, with the latter being the purpose behind the World Wide Web (WWW). Although it is slow and rough, the presentation of true multimedia is routine and inexpensive. Clearly, there is a significant issue in terms of bandwidth as well. The Internet really wasn’t designed to support voice or video, much less multimedia. Heavy use of the Internet for such applications places great strain on the backbone networks, causing brownouts (access delays and slow response times) and even threatening meltdown. Internet Service Providers (ISPs) sometimes discourage or even forbid videoconferencing, as it requires enough bandwidth to freeze out other users. Additionally, the bandwidth limitations of the typical local loop further affect the viability of such applications, particularly in the case of analog local loops, regardless of the speed of the contemporary modem. As always, the strength of the chain is limited by the weakest link.

The Internet supports multipoint videoconferencing through the MBone (Multicast backBONE), which allows a variety of shared, realtime collaborative applications to interact with reasonable efficiency. Videoconferencing, in specific, is supported by the CU-SeeMe software, that was developed at Cornell University and has become a de facto standard. Future, serious use of the Internet for such applications will depend heavily on improved compression technologies and increased bandwidth in the backbone [14-24].

Multimedia Standards

At the international level, the ITU-T’s series of H.32x video and T.12x conferencing standards set the stage for at least a minimal level of interoperability. Related compression standards include H.323 for Ethernet and H.310 for ATM. The International Multimedia Teleconferencing Consortium (IMTC) is sponsoring a number of test events in support of ITU-T standards.

The Multimedia PC Marketing Council (MPC) was formed in 1991 as a subsidiary of the Software Publishing Association. Members include Creative Labs, Fujitsu, Microsoft, NEC, Tandy, and Zenith. MPC developed an industry standard for multimedia workstations, based on the 80386SX microprocessor, an 808386 chip with a 16-bit data path. Multimedia also is viable on late-model Macintosh computers and most RISC workstations.


Communications Systems and Networks:Video Communications Defined and Evolved

The Future of Video and Multimedia

There can be little doubt about the value of enhancing a communication with visual information. Pictures add another and very important element to the process of learning and comprehension. Moving pictures let us see the person to whom we are talking, creating a more natural and effective person-to-person communication. Taking it one step further, a truly collaborative effort is greatly enhanced when multiple persons can work on a document. Supporting all of this over a network can save a lot of money, time, shoe leather, and gasoline. Serving to supplement, but never replacing, face-to-face collaboration, video and multimedia networking has a legitimate place in the networked world.

Within the next few years, videoconferencing will be commonplace. Large organizations just can’t deny its value, and the costs of the systems technologies are becoming quite reasonable. As costs continue to drop, small business, home business, and even consumer markets for multimedia equipment will expand greatly. Further, the networks are increasing in capability and soon will be able to support quality multimedia networking at reasonable cost. Infonetics Research estimates that 16% of desktops already are multimedia equipped and that 45% will be in 1998. Al Lill of the Gartner Group predicts that the next generation of PCs will have video processors built in, requiring only a $40 camera and $3 of software [14-24]. In the meantime and according to TeleSpan Publishing Group, about 30,000 desktop video systems were shipped in 1994 and another 80,000 or so in 1995 [14-25].

Telemedicine

An application in point is that of telemedicine, which supports consultation and even remote diagnosis and treatment. A number of projects have successfully experimented with this concept, largely in support of remote clinics. Through a videoconferencing system and network, a nurse or medical technician in a remote clinic can gain the assistance of a doctor (even a specialist) located at a major urban hospital. The doctor can guide the technician through the process of diagnosis and treatment, viewing the patient over a videoconferencing network and perhaps viewing x-rays transmitted over the same high-quality, digital network. For that matter, a multipoint conference can be established so that the physician might consult with distant colleagues on a particularly difficult diagnosis and treatment plan. Taking the scenario one step further, the physician can even guide the technician through an emergency surgical procedure! Prescriptions, clearly, can be transmitted electronically to a local pharmacy. While such an application scenario currently is a bit unusual, it has been accomplished and is in daily use. The typical commercial enterprise might not find videoconferencing or multimedia networking to be a lifesaving application, they will be critical elements of the technology mix for those firms seeking to gain or maintain competitive advantage.

References

[14-1] Settel, Irving and Laas, William. A Pictorial History of Television. NY: Grosset & Dunlap, Inc. 1969.
[14-2] Mast, Gerald, revised by Kawin, Bruce F. A Short History of the Movies. Fifth Edition. NY: Macmillan Publishing Company. 1992.
[14-3] Brooks, John. Telephone: The First Hundred Years. NY: Harper & Row. 1975.
[14-4] Mayer, Martin. About Television. NY: Harper & Row. 1972.
[14-5] Oslin, George P. The Story of Telecommunications. Macon, GA: Mercer University Press. 1992.
[14-6] Trowt-Bayard, Toby. Videoconferencing: The Whole Picture. NY: Flatiron Publishing. 1994.
[14-7] Prentiss, Stan. HDTV. Second Edition. Blue Ridge Summit , PA: TAB Books. 1994.
[14-8] Minoli, Daniel. “Videoconferencing.” Delran, NJ: Datapro Communications Analyst. May 1994.
[14-9] Bort, Julie. “Standards Compliance won’t Ensure Interoperability.” InfoWorld. October 16, 1995.
[14-10] Halhead, Basil R. “Videoconferencing Standards.” Delran, NJ: Datapro Communications Analyst. September 1994.
[14-11] Halhead, Basil R. “Video Server Technology and Applications Evolve.” Business Communications Review. August 1996.
[14-12] “Handy-Dandy Video Phone.” Network World Collaboration. March/April 1996.
[14-13] 1996 Multimedia Telecommunications Market Review and Forecast. Washington, DC: Multimedia Telecommunications Association. 1996.
[14-14] Briere, Daniel D. and Kincaid, Caroline C. “Videoconferencing Services in the United States: Overview.” Delran, NJ Datapro Communications Analyst. April 1994.
[14-15] Stahl, Stephanie. “Cheaper Video Hits the Desktop.” Information Week. April 24, 1995.
[14-16] McCarthy, Vance. “Desktop Videoconferencing: Still a Rough Cut.” Datamation. May 15, 1995.
[14-17] Wexler, Joanie and Timmins, Annmarie. “Videoconferencing for the Masses is on the Way.” Network World. September 25, 1996.
[14-18] Kobielus, James. “Drawing a Bead on Desktop Conferencing.” Network World. May/June 1995.
[14-19] Jerram, Peter. “Videoconferencing gets in Sync.” NewMedia. July 1995.
[14-20] Metcalfe, Bob. “Video Telephones will Arrive in Businesses First—Connected to LANs.” InfoWorld. April 10, 1995.
[14-21] Tackett, Ram. “Pain Worth the Gain?” Network World. November/December 1995.
[14-22] Tristam, Claire. “How to Buy Videoconferencing.” Open Computing. December 1995.
[14-23] Hatlestad, Luc. “Videoconferencing System Offers TV-Quality Video on LANs.” InfoWorld. March 11, 1996.
[14-24] Halhead, Basil R. “Desktop Video—Not a POTS Solution Yet.” Business Communications Review. June 1996.
[14-25] Borthick, Sandra L. “Can POTS over POTS Restart Multimedia?”Business Communications Review. April 1996.


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

Chapter 15
Convergence: Information Superhighway or Superhypeway?

We have now reached the stage when virtually anything we want to do in the field of communications is possible. The constraints are no longer technical, but economic, legal, or political.

—Arthur C. Clarke. United Nations Telecommunications Day, 1983.

There is no question that technology is moving very quickly to enable new and compelling applications in the LAN, MAN, and WAN environments. Many of these applications are extremely bandwidth-intensive, including high-speed data, video, and even multimedia. Therefore, the traditional voice and data networks must be completely redesigned.

Hundreds of millions of dollars are committed to deploying new network infrastructure in the form of SDH/SONET transmission facilities. ISDN, finally, is living up to its promise, and is becoming widely available. Frame Relay networks now are widely available in the United States and other developed nations, with international connectivity. ATM, although still in its infancy, is becoming available in the LAN, MAN, and WAN worlds. As the basis for B-ISDN, ATM undoubtedly will be widely available in the not-too-distant future. The Internet now boasts many millions of users. Online service providers are experiencing unbelievable growth, with America Online now boasting of approximately 6 million subscribers. Revenues from video services are estimated to be as high as $170 billion by 2003 in the United States, alone. The costs of rebuilding the network infrastructure in support of voice, data, entertainment, video, and multimedia applications is estimated to be as much as $116 billion [15-1] for the telephone company version. The CATV providers, with a different view that is more focused on entertainment and Internet access and with broadband facilities already in place, estimate a cost of $20 to $30 billion [15-2].

This network infrastructure is being developed to deliver something widely known as the Information Superhighway. Initially conceived in the United States as the National Information Infrastructure (NII), heavy sponsorship was proposed by the federal government. That government commitment was withdrawn in favor of commercial development of the concept, which still enjoys government endorsement and encouragement. Internationally, the concept also goes under the names International Information Infrastructure (III) and Global Information Infrastructure (GII).

The concept of the Information Superhighway is a sound one. The applications are exciting and even compelling. Many of the enabling technologies are available and are being deployed and many of the necessary standards have been defined, at least in their early versions. Examples include SDH/SONET, SMDS, Frame Relay and ATM. B-ISDN, the ultimate service offering, still is very much in the early stages of development.

Despite the publicity surrounding The Information Superhighway, it is a broad, sweeping and troubled concept. Its form is not well defined, its applications are not entirely clear, its funding is uncertain, regulatory issues abound, and implementation is by no means assured. Highway or Hypeway? Only time will tell! In that context, it is worth reflecting on the content of a letter sent in 1829 from Martin Van Buren, Governor of New York, to President Andrew Jackson.

Dear Mr. President:

The canal system of this country is being threatened by the spread of a new form of transportation known as railroads. The federal government must preserve the canals for the following reasons.

One: If canal boats are supplanted by railroads, serious unemployment will result. Two: Boat builders would suffer and tow-line, whip and harness makers would be left destitute. Three: Canal boats are absolutely essential to the defense of the United States.

As you may well know, Mr. President, railroad carriages are pulled at the enormous speed of 15 miles per hour by engines which, in addition to endangering life and limb of passengers, roar and snort their way through the countryside, setting fire to crops, scaring the livestock, and frightening women and children. The Almighty certainly never intended that people should travel at such breakneck speed.

(signed)

Martin Van Buren

Governor of New York

The Information Superhighway truly is not a thing, and it will not be an event. Rather, it is a concept that will unfold in various ways and with various capabilities. In India, for example, the I-Way might mean placing a single payphone in every small village, while urban dwellers would gain Internet access. In the United States, select business and residence users in urban areas likely will have access to multiple providers of high-speed networks in support of voice, data, video, and entertainment. U.S. schools and libraries, with government support, will have access, perhaps universally. In secondary and rural U.S. markets, such capabilities will be spotty, if available at all. The development of the I-Way, certainly in full form, will be gradual and will be driven by market forces, more than by social interests and government policy.

Definition

Convergence is defined as the moving toward union or one another. In the context of The Information Superhighway, the concept of convergence cuts across a number of dimensions, including a wide range of applications and the underlying technologies. In full form, convergence represents the coming together of every technology and application that we have discussed in the previous 14 chapters.

Applications

Applications truly are at the very crux of convergence. The only conceivable reason for investing billions of dollars in network technologies is to serve legitimate, revenue-producing applications. There appears to be no single killer ap driving the Information Superhighway, although the World Wide Web comes close. Certainly, there do exist a number of interesting and productive niche applications which, in various user-specific combinations, constitute a killer ap suite. Multimedia, in full form, is currently viewed as the ultimate in terms of presentation mode, although broad and legitimate WAN applications are yet to be defined.

Network Technologies

The network technologies under the umbrella of the Information Superhighway are already being put in place. Analog switches and transmission facilities rapidly are being replaced with digital network elements. This process is largely complete in the carrier backbone networks and the central office exchange networks. The local loop, of course, is virtually 100% analog, at least in the world of voice telecommunications.


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

Data networks for the most part are digital, and have been so for years. Data networks certainly are being upgraded to provide higher-speed services over fiber optic backbones. Additionally, new switching technology is being put in place to support Frame Relay, SMDS, and ATM networking.

CATV networks, also, are experiencing significant upgrade. The old one-way coaxial cable distribution systems are being converted to two-way. The larger CATV providers in many cases are replacing the old analog coaxial cable distribution systems with analog fiber, upgradeable to digital fiber. While the coax premise connection remains in place, the effect of a hybrid fiber/coax system is significant in terms of bandwidth and, therefore, deliverable applications.

Terminal Technologies

Terminal devices are evolving at a rapid pace, as well. Multimedia PCs are widely available to support synchronized data, video, image, and audio applications. While multimedia is useful for games, education, and WWW access, it largely remains a standalone application for PCs. True multimedia over the WAN awaits the deployment of broadband network technologies and cost-effective service offerings.

Driving Forces on the Superhighway

The evolution of the network moved at a relatively slow pace for the first hundred years. With the exception of Step-by-Step (SxS) electromechanical switches and rotary dial telephones, little in the way of technology was introduced for the first fifty years. Crossbar (Xbar) switching (1937), Direct Distance Dialing (DDD) (1950s) and tone-dialing (1960s) were considered to be absolutely revolutionary. The pace accelerated (relatively speaking) with DDS, Switched 56 Kbps, and T-carrier in the 1970s and 1980s. Toward the mid-1980s, the pace picked up considerably, and ISDN deployment began to make an impact in the early 1990s. There exists a number of forces that are driving the development of the Information Superhighway. Those forces include deregulation, privatization and competition, any applications, as well as technology.

Deregulation and Competition

Deregulation, perhaps, was the primary driving force. Beginning with the FCC’s Carterphone decision in 1968, end users were presented with a wide variety of options for terminal equipment. The Modified Final Judgement (MFJ), which took full effect on January 1,1984, was the next step, dictating the breakup of the AT&T Bell System and ending what had constituted a virtual monopoly over communications in the United States, from R&D to network equipment manufacturing to service delivery. Competition developed as a result of the actions of the FCC and the federal courts. The level of competition will intensify by orders of magnitude once the Telecommunications Act of 1996 (Chapter 16) takes full effect.

CPE (Customer Premise Equipment) and long distance competition developed quickly after the MFJ took effect. CPE competition is widespread, with literally hundreds or even thousands of manufacturers competing for the voice, data, video and image systems markets. Competition for the long distance market is intense in the United States, with well over 400 facilities-based carriers vying for the InterLATA market. Some level of IntraLATA competition exists in several states, including California, which has opened (January 1996) the LATA to full competition. The Telecommunications Act of 1996 (Chapter 16) will increase that level of competition, nationwide.

Local service competition exists, at some level, in a number of U.S. states. Alternative Access Vendors (AAVs) provide high-speed fiber optic facilities in major industrial and commercial areas, largely for the purpose of providing direct access to the IXCs, bypassing the Local Exchange Carriers (LECs). The same AAVs also provide local dialtone in a number of states, although on a limited basis. Such service generally is Centrex-like, using DID numbers rented in blocks from the serving telephone company. As there is no portability of local numbers, the user organization must change telephone numbers in order to exercise this option. Again, the Telecommunications Act of 1996 has opened the floodgates to local competition, virtually without restriction.

Local loop competition, as such, has not existed to any great extent in the United States or other developed nations. The primary exception, of course, has been that of the AAVs. CATV providers are providing data communications services, including Internet access in a few areas. These limited trials likely will expand rapidly as the CATV networks are upgraded to provide two-way service. Ultimately, both CATV providers and electric utilities are likely to offer local loops and local service in competition with the incumbent telecommunications carriers. Wireless Local Loop (WLL) technology will introduce competition from the providers of Personal Communications Service (PCS). AT&T/McCaw, AirTouch, Bell Atlantic Mobile Services, and other cellular carriers are in a strong position in this regard. The Telecommunications Act of 1996, once again, removes most restrictions to competition in the local loop.

Applications

Applications, clearly, are the primary force driving the concept of the Information Superhighway. Users have developed a real appetite for bandwidth-intensive applications, lacking only the network infrastructure to support them. The capability of a single provider to deliver a full range of voice, data, video, and image services across the full spectrum of meaningful applications is a compelling feature of a converged network. Basic telecommunications applications certainly must be supported, including voice and data communications, and Internet access. A convergence scenario also adds TV to the basic service mix, resulting in the blending of voice, data, and entertainment applications. The more exciting applications include videoconferencing, distance-delivered learning, music- and video-on-demand, home shopping, publishing, and integrated messaging.

Voice Communications

Voice communications, including both the provisioning of local loops and the delivery of local service, certainly is part and parcel of convergence. While local service is not stunningly profitable at this point, competition and relaxation of regulation over local service rates are likely to go hand-in-hand. Additionally, the successful local service provider will have a competitive edge in the highly profitable long distance market. Bundled with other voice services (e.g., enhanced custom calling features), such a package could be made to be most attractive and highly profitable.


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

Data Communications

Data communications services tend to be highly profitable. The growth and growth potential for bandwidth-intensive data services is well documented. Data communications services will include DDS, T-carrier, Frame Relay and ATM. In addition to the LECs and IXCs, a number of the AAVs currently are offering a subset of these services to their large business and government clients.

Internet Access

Internet access is a natural for a convergence scenario. A large number of large end-user organizations have dedicated Internet access, often provided over T-carrier facilities. Additionally, millions of small businesses and individuals have dialup access to the Internet, generally over dialup, analog lines. The explosive growth of the WWW will make Internet access highly desirable and profitable. As noted in Chapter 13, AT&T has made a strong move in this regard, having become the second largest Internet Service Provider in a matter of only a few weeks during early 1996.

In fact, Internet access likely will be the first big contributor to I-Way profitability. Business Research Group estimates that the six primary Internet business categories (equipment, access software, access service, expertise, commerce and content) accounted for $854 million in 1994; that figure is expected to reach $4 billion by 1997 [15-3].

Television

Television is currently provided by CATV providers on a highly profitable basis, especially since CATV rate regulations were lifted during the past few years. In addition to basic offerings, premium channel subscription, and pay-per-view are growing in popularity and profitability. While CATV is likely to continue as the primary means of TV delivery, Direct Broadcast Satellite has grown in popularity, offering greater choice of channels, and at reasonable cost. Employing digital satellites and MPEG 2 compression, transmission quality is excellent. The end user must either purchase or lease a VSAT dish, although the costs have come down to less than $500.

Videoconferencing

Videoconferencing expands to Video Dial Tone, or Visual Dial Tone, on the Information Superhighway. This application is most appealing, although affordable bandwidth and terminal equipment remain major issues.

Distance-Delivered Learning

Distance-Delivered Learning currently has long been accomplished through the media of broadcast television or CATV. More recently, there have been numerous applications of special educational programs over satellite TV, the Jason project being such an example. Additionally, a number of technical seminars are routinely delivered on a commercial basis over business TV (BTV) channels.

Video-on-Demand

Video-on-Demand (VOD) offers great potential, although its future is very uncertain. A number of field trials have shown technological problems and limitations, mostly related to server capacity and performance. Additionally, it is not at all clear that there will exist a market for VOD that is strong enough to justify the cost of deployment of high-capacity local loops and VOD servers. Near-VOD (NVOD) is a variation on the VOD theme, providing access to a predetermined set of video offerings. These videos will be run at frequent intervals, perhaps beginning every fifteen minutes. The user will reserve access to the video channel at the desired viewing time [15-4] and [15-5].

Despite the enormity of the investments required, the technical problems remaining, the uncertainty of the demand, and the low probability of short-term profits, a number of VOD trials are underway. Perhaps the best known is the Time Warner Full Service Network (FSN) trial in Orlando. The FSN trial reached its limit of 4,000 homes (at a cost of about $5,000 per home) in January 1996 and now is in a market research phase in Florida [15-6], [15-7], [15-8] and [15-9]. Bell Atlantic’s Stargazer trial, which includes 750 VOD titles, is expanding and is planned for commercial deployment by yearend 1996. Continental Cablevision is conducting a trial of near-VOD, including 1,000 homes in Natick, Massachusetts [15-6]. Numerous other trials are either in progress or planned for the near future. For a variety of reasons, other have been canceled; those include the AT&T/GTE trial in Manassas, Virginia and the Pacific Telesis trial in Milpitas, California [15-10].

Music-on-Demand

Music-on-Demand (MOD) provides access to a wide variety of music over high-quality local loops. MOD involves access to an audio server, much like a CD-ROM jukebox.

Interactive Games

Interactive games are networked video games, allowing multiple players to engage in a competitive game experience. Again, the CD-ROM game is housed in a server residing in the network.

Home Shopping

Home shopping is already experiencing modest success over the Internet. This application is likely to grow significantly, not only on the Internet, but also on the basis of catalog servers residing at regional locations in the network. Localized Home Shopping catalogs will likely be developed on servers in a convergence scenario; thereby local shopping malls and department stores could effectively provide the same type of service, but on a regional or localized basis. Significant issues of credit card security are being resolved through encryption.

Publishing

Publishing is already experiencing limited success on the Internet. A wide variety of scientific and technical papers have long been distributed in this fashion. Additionally, Web Home Pages provide substantial vehicles for the publishing and distribution of certain types of documents. A critical remaining issue is that of copyright laws that would effectively govern the subsequent use of documents published electronically.

Integrated Messaging

Integrated messaging offers great potential. Extending well beyond the boundaries of voice mail and email, integrated messaging will include videomail and image mail. The compound mail, in effect, will be Multimedia Mail.

Technology

The technology to support the Information Superhighway largely is in place, or in various stages of development. Certainly, a wide variety of voice and data communications technologies are well-developed. The real technology issues relate to the development of appropriate video and image technologies in the form of high-capacity servers, user interfaces, and effective multimedia terminals.


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

Terminal Equipment

Terminal equipment currently provides excellent support for individual voice, data, video, and image applications, but through separate devices—telephones, computers and TV sets. Multimedia PCs will support voice, data and video, but their voice and video capabilities are not all that great. Cable-ready PCs are now available, although at higher cost; in fact, many Apple computers have been cable-ready for years. While this can be useful for video editing, few people have become addicted to watching TV on a PC. About the only converged device that has so far been successful is that of a combined telephone and fax machine.

Terminal equipment, in a convergence scenario, likely will not be in the form of a single, multifunctional device. Rather, it is likely to take the form of modular computers, telephones, TV displays, cameras and other devices to be snapped together as desired. In this manner, the user will realize the advantages of modular functionality, which then can be upgraded on a modular basis. In different rooms of a residence, different individuals might use these devices in different combinations.

For instance, the SOHO (Small Office Home Office) might take advantage of a multiline wireless telephone and headset, a wireless computer keyboard and mouse, a wireless CPU and hard drive, and a wireless flat panel display with attached camera that would be mounted on the wall. Connection would be provided on a wireless basis to combined color printer/fax machine/copier.

The family room might focus on a large, flat-screen display device. The master bedroom would contain a smaller display. The playroom and children’s rooms would feature smaller displays, as well, as would the kitchen and bathrooms. In every case, a wireless remote control, wireless keyboard and mouse, wireless camera, and wireless telephone could be included in the mix of devices.

The end result is that of a modular, wireless Home Area Network (HAN). Any and all applications could be accessed, conceivably from any room. While this scenario might seem a bit exotic, it is technically feasible at this very moment. The remaining issues, of course, center on standards and costs.

In the author’s opinion, the highly-touted NetStation (Chapter 13) will not take the world by storm. This concept, once again, is that of a dumb terminal with a keyboard, mouse, display, and communications software. All processing power and all storage would reside in the network. There certainly will be applications for such a device, assuming that the cost comes down below $500. Those who take there computing even remotely seriously will continue to favor premise-based solutions. I would not even have considered writing this book and developing the graphics on the basis of network computing. My guess is that the typical reader would not make use of such a concept either. I also doubt that the typical couch potato has much of an inclination to compute at all. As a small indication of the intense speculation over the future of the information appliance, note references [15-11] through [15-16].

User Interfaces

User interfaces are very much in the development phases. The primary effort is focusing on developing a highly intuitive Graphic User Interfaces (GUIs) for an effective navigator, much like the concept of a Web browser. Perhaps through a wireless remote, one would be able to select application options from menus presented on a converged device consisting of a big-screen display, supporting video applications as well as serving as the display for a multimedia computer system. Microsoft, Apple, Sun, Scientific-Atlanta, Digital Equipment Corp. and others are working diligently to develop such interfaces [15-17].

Network Interfaces

Network interfaces, in the form of set-top boxes and CATV modems, require additional development and standards. The interface can be located on the set-top (much as a CATV converter), inside the terminal equipment, outside the premise (as is the case with a contemporary telephone company Network Termination Unit), or in some combination. The network interface likely will comprise some combination of firmware and software, and will act as a combined codec, firewall, and communications controller or splitter. The control function will provide access to multiple voice, data, video and image applications through separate channels over the high-speed distribution network. The current cost of set-top boxes is in the range of $500 to $700, partially because the manufacturing runs are so small. At a price point of $150 to $300 per box, they would become practical [15-18]. Current manufacturers of such boxes include General Instruments, Scientific-Atlanta, Hewlett-Packard, Toshiba, Thompson, Fujitsu, Sun, Apple and IBM [15-19].

The network interface that finally will emerge victorious, in the my opinion, will be a combination of firmware (on silicon chips) and software. The advantage of firmware is speed—standardized, stable and routine functions will be performed in silicon and will be executed quickly. The advantage of software is flexibility—dynamic and less stable functions will be performed in software in order that bugs can be fixed and functionality can be modified and upgraded. Additionally, software fixes, upgrades and enhancements can be downloaded over the network.

Media

Media technologies are developing rapidly, with emphasis on Fiber-to-the Neighborhood (FTTN), as it is unlikely that Fiber-to-the-Curb (FTTC) or Fiber-to-the-Home (FTTH) will prove to be economically viable in the near future. Therefore, current plans and trials largely focus on hybrid fiber/coax distribution systems. Hybrid fiber/UTP, through technologies such as ADSL, offers at least a stopgap solution, extending the economic life of the embedded local-loop plant of the telephone companies. Additionally, wireless technologies, such as Wireless Local Loop (WLL) and Broadband PCS offer great potential, although much work remains to be done.

Fiber, clearly, seems to be the preferred technology for reasons of bandwidth and error performance. Taking fiber as far as possible extends these advantages to the maximum, but carries with it higher cost. As a result, the last few hundred feet or yards or meters or so of the converged loop likely will remain coax or UTP. While it is unlikely that the result will be a Gpbs in every living room, 51 Mbps (OC-1) or even 155 Mbps (OC-3) certainly is possible. With digital transmission and MPEG 2 compression can squeeze as many as ten video channels into the bandwidth required by only one channel in the analog coax world of CATV [15-18].


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

ATM

ATM (Asynchronous Transfer Mode) clearly will be the network technology of choice. As the basis for B-ISDN, ATM will support the transmission of asynchronous, synchronous, and isochronous data. Voice, data, video, and image applications are all supported. There remain issues of ATM support for voice and video, but those issues are being addressed and likely will be resolved in the near future.

Server Technology

Server technology is well developed, but experiencing difficulty in the provisioning of video applications, particularly Video-on-Demand. VOD is extremely memory-intensive, requiring very substantial and expensive servers. Hewlett-Packard claims that its Media Server video jukebox will support Video-on-Demand (VOD) to 10,000 simultaneous users. Time Warner’s Full Service Network (FSN) trial in Orlando, Florida employs servers from Silicon Graphics (CA), currently supporting about 80 movie titles with 40 more planned to be added. The FSN server will allow 25% of the 4,000 subscribers to access the server simultaneously [15-9]. In addition to Hewlett-Packard, and Silicon Graphics, Oracle, IBM and others manufacture such servers.

Providers of the Toll Roads

The Information Superhighway is not free. As it is anticipated that well over $100 billion will be required to construct the I-Way in the United States, alone. That investment by no means ensures that every business and residence in the United States will have high-speed access; rather, deployment will be driven by market potential. The result likely will be much like that of the U.S. system of roads, with urban areas having access to high-speed freeways, loops and the like (hopefully without the congestion). High-speed interstate highways will interconnect the major urban centers. Smaller towns and cities will have lesser access, and rural areas will be relegated to access via even more modest farm-to-market roads. Voice-grade gravel paths will connect to the farms and ranches. The potential providers of the toll roads include the current providers of telecommunications, data communications, CATV, electric power and wireless services. Table 15.1 provides a comparison of telecommunications, data communications and CATV networks along a number of key dimensions.

Table 15.1 Comparison of typical, contemporary telecommunications, data communications, CATV, wireless, and Internet networks
 | Voice | Data | CATV | Wireless | Internet
Presence | Ubiquitous | Widely Available | Ubiquitous | Varies | Ubiquitous
Transmission Mode | Analog/Digital | Digital | Analog | Analog[rarr]Digital | Analog/ Digital
Bandwidth | 4 KHz to 45 Mbps | 56 Kbps-45 Mbps | 500 MHz+ | Voice Grade | 4 KHz to 45 Mbps
Call Direction | Two-Way | Two-Way | One-Way | Two-Way | Two-Way
Switching Technology | Circuit | Circuit, Packet, Frame, Cell | N/A | Circuit/Packet | Circuit/ Packet
Transmission Medium | UTP Loop, Fiber Backbone | UTP Loop, Fiber Backbone | Coax | Radio Fiber | UTP Loop, Backbone
Interconnectivity | Absolutely | Varies | Rare | Cellular, Yes; Data, No. | Absolutely
Network Management | Strong | Strong | Rare | Moderate | Poor
Market Perception | Excellent | Excellent | Poor | Low Reliability | High Reliability, Low Quality
Cost | Highly Affordable | Varies | Reasonable | Moderate to High | Free to Reasonable

Telecommunications Networks

Telecommunications networks were developed expressly to support voice communications. They are virtually ubiquitous in developed nations, supporting bidirectional communications on a circuit-switched basis. The national networks are fully interconnected, to provide complete international calling capabilities. Voice networks do not require significant bandwidth at the local-loop level, with the exception of T1 and T3 facilities in support of relatively large PBX systems and data centers, while very large end user environments sometimes are connected via digital, dedicated leased lines (e.g., T1, T3, or ISDN PRI). The networks traditionally have been analog in nature, and still are for most residential and small business applications, although ISDN finally is making an impact. The local loop terminates in a local central office exchange, or Class 5 exchange—these exchanges rapidly are being upgraded to digital switches with ISDN capabilities.

The backbone telecommunications networks largely have been upgraded to fully digital switches and digital fiber optic facilities, which are being upgraded to SDH/SONET. Such upgraded backbone networks certainly provide additional bandwidth, performance, and economies of scale for voice carriers through high-capacity, multichannel facilities. Additionally, they provide the side benefit of supporting certain data communications applications through the same switch/transmission infrastructure.

Voice network providers certainly are eyeing ATM to B-ISDN as the network technology for the next century. However, ATM is not yet entirely appropriate for voice communications for reasons which include its relatively high overhead. Additionally, there is no compelling reason to invest in replacing the embedded circuit-switched network with an expensive ATM network, at least not outside the backbone.


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

Telecommunications carriers bring a lot of strength to the table in terms of their strong network design, deployment, and management skills. The telecom networks are known for their reasonable cost and high degree of reliability. Additionally, the carriers have strong customer service reputations and are used to transaction-based billing. Perhaps their biggest weaknesses are lack of flexibility, lack of market responsiveness, historically weak marketing skills, and complete inexperience in the dimension of content. Content is key in the Internet world and certainly will be so in the world of convergence. As some have noted, the telephone companies have developed and re-developed numerous convergence strategies which quickly have back-fired—sort of like the Wile E. Coyotes of a convergence cartoon [15-3].

Data Communications Networks

Data communications traditionally involves either modems for transmission over analog circuits, dedicated leased lines (e.g., DDS and T-carrier), or switched digital services (Switched 56/64 Kbps). Additionally, ISDN is a thoroughly acceptable network technology for data communications, although transmission speed is limited. The deployment of Next Generation Data Networks is moving rapidly, with Frame Relay leading the pack. SMDS also enjoys a modest level of success. ATM, of course, is viewed as the ultimate datacom solution into the foreseeable future. While the data network providers also bring a lot of strengths to the convergence battle, like the telephone companies, they generally lack experience with content.

CATV Networks

Entertainment networks, for the purposes of this discussion, are those of CATV providers. With rare exception, these networks are isolated islands of entertainment based on analog coaxial cable facilities. Bandwidth is substantial, but is Frequency Division Multiplexed into fixed video channels of approximately 6 MHz. Further, CATV networks are one-way, with rare exception. Finally, CATV networks are dedicated, multipoint broadcast networks, rather than being switched and interconnected (Figure 15.1). Therefore, existing CATV networks are not suitable for I-Way use, even though they pass 98% of the 95 Million households in the U.S. Current (1996) penetration of landline cable is in the range of 62 million (65%) and is growing at an annual rate of about 3%; about 1 million receive CATV via microwave and 5 million via satellite [15-20].

Figure 15.1 Typical analog coax CATV network.

A number of CATV providers recently have made major commitments to upgrade existing facilities to fiber optic/coax hybrids to provide substantial bandwidth and to support bidirectional communications. According to TCI management, only about 10% of the 20 million or so households passed by its CATV systems have been upgraded to 750 MHz, two-way capability. Nationwide, only about 8% of households have access to two-way CATV systems [15-21]. In terms of the major CATV providers, about 17% of homes were passed with upgraded fiber/coax systems in 1995. Estimates are that the percentage will grow to 51% in 1997 and 83% by 2001 [15-20]. While still analog in nature, the networks are being deployed with an eye toward future upgrade to digital technology. If CATV providers are to be successful in a convergence scenario, they also must provide switched interconnectivity with voice and data networks, as well as with the Internet. Developing the necessary infrastructure will be difficult for many of the CATV providers because they typically are undercapitalized, private companies with relatively small cash reserves and lacking access to capital (debt and equity) markets. Further the CATV companies do not have transaction-based billing systems in place, and generally lack a high level of network management capability, as well as customer service and support systems and staff [15-22]. Not only must they expand their technological capabilities and skill sets, but they must enhance their public perception. A 1994 study by George Washington University indicated that only 13% of small businesses would prefer to deal with the local CATV provider, rather than the LEC or an IXC [15-23].

It is worth noting that CATV providers are under increasing pressure on their home fronts from Direct Broadcast Satellite (DBS). Using digital satellites with MPEG 2 compression, the signal is received through a fixed VSAT dish that focuses on the satellite associated with the service provider. As of mid-1996, there existed about 2 million DBS subscribers. That number is expected to reach 17 million by the end of 1998 [15-22]. Given the erosion of their core business, CATV providers are aggressively seeking ways to augment their revenues and will likely be a force in the convergence market. Some suggest that their strength will be in small and rural markets, in which the major LECs and IXCs have little interest [15-23].

The great advantage of CATV providers lies in the bandwidth of the existing networks and, certainly, the proposed upgraded networks. Through the use of cable modems providing access to upgraded, two-way, hybrid fiber/coax networks, as many as 1,000 homes can be provided access to a local node which, in turn, connects to a central switch. Each cable modem can provide as much as 10 Mbps total bandwidth to each premise, depending on total network load. As noted in Table 15.2, a file of 16 MB can be downloaded in about 16 seconds, versus over 1 hour with a contemporary high-speed modem. Unlike a LAN environment, the shared CATV network yields throughput very close to the theoretical 10 Mbps per modem, as the network employs a centralized, non-contentious media access control technique much like token passing.

Table 15.2 Time required to download a 16 MB file using modems, ISDN BRI, and 10 Mbps cable modem
Transmission Method | Time Required
14.4 Kbps Modem, Analog Line | 2 hours, 28 minutes
28.8 Kbps Modem, Analog Line | 1 hour, 14 minutes
ISDN BRI at 128 Kbps | 16 minutes, 39 seconds
Cable Modem at 10 Mbps | 16 seconds


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

Assuming that the CATV network is upgraded to digital, compression techniques can be employed to provide channel capacity that is virtually limitless in support of entertainment, Internet access, remote LAN access, telephony, and other applications. Estimates are that CATV providers will capture as much as 20% of the wireline telephone market by 2005 [15-20]. The CATV providers have a leg up on the telephone companies and data network providers in the battle for I-Way dominance—that advantage is one of experience with content acquisition and management. Combining that content experience with high-capacity embedded loops and experience in a market-driven business, they stand a good chance of emerging victorious. If the telephone companies can be characterized as Wile E. Coyotes, the CATV providers are the Roadrunners in this developing cartoon of convergence [15-3].

Wireless Networks

Wireless networks in the United States are currently limited to cellular providers and those who offer wireless data services (e.g., ARDIS and RAM Mobile Data). PCS licenses have been awarded to U.S. providers, although the networks have yet to be deployed. AT&T, by the way, acquired 21 major-market PCS licenses at federal auction [15-24]. Providers of limited PCS/PCN services exist in Europe, Australia, parts of Asia, and other regions of the world.

Wireless access to the I-Way clearly offers advantages in terms of both speed and cost of deployment. Wireless Local Loop (WLL) technologies are being trialed in the United States and elsewhere, and are being deployed in many developing countries. However, WLL truly is not intended for provision of broadband network services. While standards and technologies for the delivery of Broadband PCS (B-PCS) are progressing, B-PCS likely will not be a viable technology option during this century.

Electric Power Utilities

Many electric power utilities are currently building, or planning to build, fiber optic networks, at least to the neighborhood. Ostensibly, in many cases, these networks are intended to provide a network-based means for load control management of electric power and other utilities. It is clear that many of the power utilities intend to lay a fiber optic grid and to lease capacity to providers of the Information Superhighway. While some of the major power utilities may intend to become Internet providers, none have announced such intentions. In any event, it is highly unlikely that they will do so en masse [15-25] and [15-26]. Their cautious approach is due to the fact that the communications business is foreign to them, at least in a commercial sense. While the utilities are experienced in the design and deployment of cable systems, they generally don’t have experience in terms of transaction-based billing, media content, and other areas critical to the provisioning of voice, data, and video services.

Heated discussions currently are taking place relative to pole and conduit access. Traditionally, the telephone companies and power companies each have enjoyed reciprocal rights to use the facilities of the other for hanging or pulling cables; CATV providers also traditionally have been provided access. Pole and conduit usage fees apply, although the level of such fees has always been quite reasonable. As the competition for the I-Way grid intensifies, traditional logic no longer applies. The debate already has ensued and is likely to reach significant proportions.

There are a number of small power utilities that have deployed CATV networks to support Internet access, as well as entertainment TV. Some of them have been highly successful, although in small markets. Notable in this regard is MWR Telecom, a spin-off of Midwest Power Company. The company built its own 110-mile fiber optic network to serve internal needs, and since has resold excess capacity to carriers (AT&T, MCI and Sprint) and over 70 large user organizations. Glasgow Electric Plant Board has deployed a two-way coax system that supports CATV, Internet access, and telecommunications in competition with the incumbent providers in its serving area of about 13,000 customers. The Glasgow offering has been well received, particularly in terms of Internet access and cable TV [15-10] and [15-27]. Central and Southwest Corporation, Pacific Gas & Electric, Entergy Corporation, The Southern Company, Portland General Electric are among the other investor-owned utilities experimenting with the technology and service concepts that will position them as I-Way providers [15-10]. In general, it is unlikely that the power utilities will be a major force in the world of the I-Way. While they may function as providers of the grid, they are unlikely to be successful as providers of services or content.

The Internet

The Internet is suggested by some to be the Information Superhighway, at least for the present and, perhaps, well into the future. While the Internet and the WWW are constrained by network limitations of bandwidth and packet delay, they certainly deliver many of the applications currently envisioned for the Highway. Those applications that are available and growing certainly include shopping-at-home and distance-delivered learning. As noted in Chapter 13, voice communications, videoconferencing, and radio broadcasting also are supported, but not very effectively. These applications are inappropriate for the Internet and place great strain on the available resources.

The Net and the Web certainly are not the ultimate vision of the Highway, but they do deliver a fair amount of functionality now. As the ultimate vision of the ATM-based, Fiber-to-the-Premise (FTTP), multimedia-ready Information Superhighway is years away, the Internet likely will continue to enjoy a niche in the I-Way market. In fact, the Internet ultimately will serve the same function it largely serves today—that of an application-oriented network which will be accessed by a converged local network.

The Converged Network

One scenario of the converged network is illustrated in Figure 15.2. Digital local loops that are hybrid fiber/coax or fiber/UTP in nature will terminate at the premise in a network termination unit which can be in the form of a set-top box. The set-top box will serve as a controller/splitter in support of voice, data, facsimile, video, and TV. Modular devices will provide the appropriate mix of transmission and reception capabilities for each user, including visual display. The set-top box, or perhaps each device, will contain an ATM chipset.

Figure 15.2 Converged wireline network.


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

Each of perhaps several thousand such local loops will connect to a local ATM hub or node that will connect to the head-end ATM switch via SONET fiber optic facilities. The head-end ATM switch will provide connection to the PSTN for voice, facsimile, and video-conferencing. Connections also will be provided to various data networks, a video server for Video-On-Demand, an audio server for Music-On-Demand, a satellite network for broadcast TV and radio, a game server for network game-playing, and the Internet for a wide variety of other applications.

I-Way Issues

There are a number of significant issues which must be overcome if the Information Superhighway is to become a reality. These issues include standards, regulation, taxation, addressing, and interconnectivity.

Standards

Standards (read standards recommendations) allow manufacturers and service providers to build and deliver to a common set of specifications, with options they can exercise to maintain a reasonably high level of differentiation. Assuming that standards develop quickly, manufacturers will build to them while complaining about stifled creativity. If they develop slowly, manufacturers will develop their own ad hoc standards in order to get products and services to market and remain competitive.

Standards are in place for some aspects of the Information Superhighway. SDH/SONET, for instance is well-developed, although work remains to be done at the higher levels (above OC-48). Similarly, ATM needs some work, at least in terms of AALs for voice and video. B-ISDN clearly needs attention, and it relies on ATM. In the video realm, MPEG-2 and ATM suffer from some incompatibility/inefficiency issues. Wireless transmission systems are unproven, much less standardized—WLL, PCS and, certainly, B-PCS fall into this category. Standards for set-top boxes and user interfaces are in the distant future. Standards for modular CPE devices are even more distant.

In an attempt to set a standard, several alliances and joint ventures have been formed. By way of example AT&T, Hewlett-Packard, Intel, and Hybrid Networks announced in December 1995 a joint venture to develop CATV modems in support of voice, data, and video over an existing coax cable plant. The devices will be built to an open standard, which the partners hope would become the de facto standard for such applications [15-28].

Regulation

Regulatory issues are not trivial in the context of the I-Way. Barring the abolishment of the FCC (which has been suggested), state PUCs and other local, state/province, national and international regulatory authorities, a number of issues loom large. Regulatory issues include franchise rights, right-of-way, universal service, provider of last resort, and censorship.

Franchise Rights

Franchise access rights are regulated at the local level. Local loops and local telecommunications services largely remain the domain of the Local Exchange Carriers (LECs). Such exclusive franchises originally were granted by municipal and county governments. Currently, a mix of state and federal oversight prevails, although the Telecommunications Act of 1996 provides for competition at that level. CATV franchises, generally speaking, are granted on a local (municipal or county) basis, with varying levels of rate regulation at both the local and federal levels. Local government are used to being rewarded by CATV providers for franchise rights, generally on the basis of gross receipts taxes. Telephone companies have balked at the suggestion of paying such local taxes for I-Way franchises. They claim to be heavily taxed at all levels, already. Additionally, it is their position that their rates and services are regulated at the national and state levels, not at the local level.

Right-of-Way

Right-of-Way is another local issue. Municipal and county governments tend to take an interest in the digging up of streets and walkways for the purposes of laying cables. Local governments (e.g., Milpitas, CA), on more than one occasion, have take strong exception to cabling projects to lay redundant I-Way grids. Local governments have also recently taken strong exception to the placement of cellular, WLL, and PCS antennae and enclosures. Wireless is not entirely without wires and boxes. Additionally, health concerns still arise relative to EMF emissions.

Universal Service

Universal Service is a concept that has influenced telecommunications policy in developed nations for many years. The best possible service, universally available at the lowest possible cost is a basic precept on which telecommunications networks developed. Currently, all telecommunications providers (LECs and IXCs, alike) contribute to a universal service fund. If CATV providers, power utilities, CAPs/AAVs, ISPs and others are allowed to skim the cream off of the I-Way without contributing to that fund, the concept of universal service risks degradation beyond all recognition [15-29].

Provider of Last Resort

Provider of Last Resort is a concept closely tied to both universal service and competition. In order to be truly universally available, some company must assume the responsibility for providing service under the worst possible circumstances. From the standpoint of pure profit motivation, there is no incentive for a carrier to provide products and services such as lifeline service or Telecommunications Devices for the Deaf (TDDs). Nonetheless, there is a social obligation to provide them, and some service provider must be held accountable. The various regulators of the Highway have not fully addressed this issue, in a deregulated environment.

Censorship

Censorship, increasingly, is the focus of government attention and associated regulation is virtually inevitable. Recent instances of Internet cyberporn have led to government investigations and numerous arrests. Internet Bulletin Board Systems (BBSs) and Chat Groups have been used for illegal activities such as child abductions, posting of illegally-obtained credit card numbers and cellular telephone ID numbers, and various other illegal activities. Law enforcement is making occasional arrests of violators, although the difficulty of tracking down and prosecuting the offenders is difficult given the anonymity of the medium.


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

Debates rage over issues of television content, with the V-chip (Violence Chip) apparently having been settled on as the solution. Assuming that all TV and VOD content is rated and assuming that the software/firmware is developed, it is possible that parents automatically could reject the access of minor children to certain scenes, programs, or even entire channels. That assumes, of course, that the same parents who can’t program the VCR (or even reset the VCR clock) can figure out how to program the V-chip! Similarly, software filters are commercially available for the Internet. Such filters block access to Web sites of unseemly content. The filters are regularly updated through a server maintained by the software provider.

Taxation

Municipal and county governments long and heavily have relied on taxation of traditional utility companies to balance their budgets. By way of example, the League of California Cities states that utility taxes accounted for $996 million in 1993, up from $687 million in 1988. The shift to wireless communications has left the cities in something of a lurch.

Cellular telephony and satellite TV have required that the tax codes be rewritten. They also have made the job of calculating and collecting revenues much more difficult. The Internet poses a similar problem and PCS adds yet another dimension. Convergence of voice, data, and entertainment networks adds to the confusion and speaks to an issue that must be resolved.

Assignment and Portability of Logical Addresses

Logical addresses come in the form of telephone numbers, IP addresses, and so on. With the exception of 800/888, In-WATS numbers (in the United States), none of these addresses currently are portable, from carrier-to-carrier, or service provider-to-service provider. By way of example, U.S. AAVs/CAPs provide local telecommunications service in some areas. However, they must do so on the basis of DID numbers that they lease from the LEC. As a result, users are forced to change telephone numbers, placing these competitors at a disadvantage. This disparity results from the fact that the North American Numbering Plan (NANP) is administered by Bellcore, the R&D arm of the RBOCs. Within each area code, or NPA (Numbering Plan Area), the predominant LEC (read RBOC) is responsible for number assignment. It doesn’t take the Chairman of Bell Labs to figure out who this arrangement benefits.

Similarly, one becomes tied to an information service provider. For example, ContextCrp@aol.com by no means is portable to CompuServe, Prodigy, GEnie, The Well, or any other service provider. The Context Corporation effectively was wed to America Online until it set up its own domain, contextcrp.com. As some of us are well aware, divorces are far more difficult and expensive than are weddings. Organizations with true domain names (e.g., contextcrp.com), do enjoy full portability, of course.

PCS/PCN takes the issue of address assignment and portability to the extreme. PCS, in full theoretical form, allows one logical address to follow one for life and across the full range of applications, including telephony, cellular telephony, paging, facsimile, email, and video mail. Address portability is critical in this environment, and especially so in a converged network environment.

Interconnectivity

Interconnectivity is critical in telecommunications networks and the Internet. Some data networks provide for interconnectivity on the basis of privilege and other factors; examples include the Internet, X.25, and Frame Relay networks. Other data networks are not necessarily intended to support high levels of interconnectivity. Regardless of the provider, the converged network must support full interconnectivity, at least for voice, videoconferencing and certain types of data, and on an equal access basis [15-29].

One Potato, Two Potato, Three Potatoe, Four…

Potato(e) can be spelled more than one way, as Vice-President Dan Quayle illustrated several years ago. There also is more than one way to build an I-Way. There is a very serious question as to just how many wires (hard wires and wireless wires) should be extended to provide access to the I-Way. Even if the applications were proven to have broad market appeal at compensatory price levels, there is only so much to go around. One must wonder how much redundant infrastructure is reasonable, and at what cost. Perhaps the electric utilities have the right idea—build one information grid and provide access to a wide variety of service providers. Of course, this idea is not new. Utilities traditionally have provided a single grid for telecommunications, data communications, CATV, electric power, gas, water, and sewer services. The fundamental economic concept of a natural monopoly still has merit.

Rochester Telephone (Rochester, New York), well-known as an innovator, several years ago hit upon a variation of the same theme. The New York PUC approved the separation of the company into R-Net (grid provider) and R-Comm (service provider). R-Net acts as an information grid wholesaler, providing access to service providers, including R-Comm. On January 1, 1995, the people of Rochester became the first U.S. citizens to have a choice of local telephone service providers since 1919 [15-30].

In all likelihood, a natural duopoly or triopoly will prevail in many areas. Telecommunications and CATV networks already exist, they need only to be upgraded. While the level of capital investment is not trivial in either case, it is quite likely that two grid providers can survive quite comfortably and profitably. If one adds wireless carriers to the equation, perhaps that number expands to three, particularly in a PCS scenario. Four wired potatoes likely is not within the realm of reason and three is problematic. Wireless potatoes are additional.

Content is the Key

As standards develop (or not), technologies evolve, applications find favor, and networks are laid, it will become increasingly clear that I-Way providers must find a means of differentiation. Service quality, reliability, responsiveness and other factors, certainly will help to differentiate one provider over another. However, that differentiation must extend beyond price, promotion, and place. Product, the fourth P of the classic marketing definition, is critical.

Content is the key. Content includes music, movies, games, educational programming, and a host of other things that entice business and personal users to access the I-Way. Clearly, the industry has realized the importance of content, as numerous mergers, acquisitions, and strategic alliances will attest.


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

The Feeding Frenzy: Satisfaction or Acid Indigestion?

The starting pistol has been fired and the race is on to build the Information Superhighway. Telephone companies, CATV providers, CAPs/AAVs, PCS licensees, electric utilities, and others all are jockeying for the pole position to lay the grid. In recognition of the fact the content is the key, significant emphasis has been placed on relationships with major movie studios, record labels and multimedia developers of interactive video games. Additionally, hardware manufacturers and software developers are gobbling each other up at a record pace. According to Broadview Associates, worldwide high-tech M&A (Mergers & Acquisitions) activity increased to $134 billion for 2,913 deals in 1995; 1993 figures were $90.5 billion for 1,816 deals. Through the first six months of 1996, Broadview tallied 1,624 transactions for a total of $125.7 billion [15-31]. The feeding frenzy is on, but not without some level of serious indigestion.

The following is a small, but representative sample of the scope and scale of such activity. (The author begs forgiveness in the event he failed to record the fact that one of these highly-touted deals fell apart. After all, marriages make headlines, while estrangements and divorces seldom merit a footnote in the announcements section.)

Bell Atlantic and Tele-Communications Inc. (TCI) announced in October 1993 a merger, which was called off in February 1994 for financial reasons. At that time, Bell Atlantic reached some 23% of U.S. homes; TCI passed nearly 40%.

Time Warner (content, CATV and publishing) announced the acquisition of Turner Broadcasting System (broadcast) on September 22, 1995. TCI (CATV) was the key to the merger, as it holds 21% of Turner voting stock; TCI gets extended rights to carry Turner cable networks, as well as the right to buy Turner’s interest in the SportsSouth regional sports network. US West, which holds a 20% stake in Time Warner, challenged the merger [15-32] and [15-33].

Disney (content) offered to acquire ABC/Capital Cities (content and broadcasting) for $19 billion. The merger produces a company with combined revenues of $18.7 billion. The Justice Department requested more information prior to approving the purchase [15-33].

TCI is acquiring (July 1995) Viacom’s CATV business for around $2.25 billion. Viacom’s coverage includes California, Washington, Oregon, Tennessee, and Ohio; 2.2 million subscribers are affected. Viacom will focus on other business; the company owns the MTV network and Paramount studios (so much for acquiring content). TCI is acquiring (July 1995) Western Communications, which Viacom was in the process of acquiring before it was acquired by TCI. Western Communications was owned by Chronicle Publishing Co., which owns the San Francisco Chronicle newspaper, KRON-TV and other smaller newspapers and TV stations.

TCI also proposes (July 1995) to acquire Intermedia’s systems in Santa Clara County, California. This is the third time that the deal has been structured. That deal has since taken the form of a swap of TCI’s Nashville properties for the Intermedia properties in Santa Clara county. TCI also announced (July 1995) its intentions to link its various Northern California CATV properties with a digital fiber optic ring. It will also provide high-speed Internet connections, as well as telephone service (both wired and wireless) in concert with Sprint and other CATV companies. Additionally, TCI now owns about 24% of the U.S. cable market, with close to 14 million subscribers [15-34] and [15-35].

TCI became partners some years ago with Cox, Comcast and Continental Cablevision in the Teleport Communications Group (TCG) venture. TCG is a CAP, providing alternative access services in a number of major U.S. cities [15-7].

Bell Atlantic filed with U.S. Federal District Court in January 1994, for video communications waivers in connection with its plan to acquire Tele-Communications Inc. (TCI). The deal fell through, although Bell Atlantic’s waivers were granted in March 1995.

Microsoft made a run at Intuit (Quicken, QuickBooks and electronic banking) in 1995. The $2.1 billion deal fell through in May 1995, after objections from the U.S. Justice Department.

Pacific Telesis Group (PacTel) acquired in July 1995 Cross County Wireless for $175 million. Cross County Wireless offers wireless video and TV through a microwave distribution network. PacTel gained 40,000 subscribers in Riverside County, California. PacTel announced its intention to provide that service to five million households in Los Angeles, Orange and San Diego counties by the end of 1995. The system will support 100 channels, CD-ROM quality sound, and Video-On-Demand (VOD). According to PacTel, the system offers great appeal to people who aren’t happy with existing cable service [15-36].

Gannett announced in July 1995 the acquisition of Multimedia for $1.7 billion. Gannett owns 82 newspapers with a total circulation of 6.4 million. Multimedia owns 11 daily newspapers, 5 TV stations, 2 radio stations, Multimedia Cablevision, Multimedia Entertainment (Donahue and Rush Limbaugh TV shows) and Multimedia Security Service. In 1985, Gannet acquired The Detroit News and 5 TV stations. Gannett now owns 15 TV stations, 3 over the FCC limit of 12; some of those stations are in overlapping markets, which is prohibited by the FCC.

Time Warner Entertainment took a 10% stake in April 1995 in Interactive Digital Solutions, founded by Silicon Graphics and AT&T to develop hardware and software to support the Information Superhighway. Time Warner’s Full Service Network (FSN) trial in Orlando, Florida began with connections to 5 homes in December 1994; as of April 1995, that total was only 60 homes—there are potholes in the Information Superhighway [15-37].

Netscape Communications (WWW Browser) announced (September 22, 1995) its acquisition of Collabra Software Inc. (Internet networking software) for $108.7 million in stock.

AT&T announced in September 20, 1995 that it will break up into three companies and will sell AT&T Capital Corp., its captive financing business. The largest voluntary breakup in history is expected to be completed by January 1, 1997, splitting the $75 billion company into three market focused-companies. A one-time $7.5 billion charge-off will occur as a result. Approximately 8,500 employees, all in the Global Information Solutions (GSI) computer business, will lose their jobs. GSI was the result of the NCR acquisition, which did not live up to expectations.


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

The post-divestiture AT&T boasted assets of $79.2 billion, annual revenues of $75.1 billion and a total workforce of 303,000. Table 15.3 provides a view of AT&T, both post-divestiture and post-spinoff.

Table 15.3 AT&T, post-divestiture and post-spinoff
At&T, Post-Divestiture | At&T, Post-Spinoff
AT&T Communications Services (formerly AT&T Long Lines) | AT&T Corp.
Role: Long Distance Service, Universal Card, AT&T McCaw Cellular (acquired 1994). | Role: Long Distance, Universal Card, AT&T McCaw Cellular, Wireless, Internet Services, AT&T Laboratories. Revenues: $51 billion. Assets: $56 billion. Employees: 127,000
AT&T Bell Telephone Laboratories | Lucent Technologies
Role: Research & Development | Role: Research and manufacturing of CPE/DTE. Includes Bell Laboratories and AT&T Technologies. Revenues: $21 billion. Assets: $20 billion. Employees: 131.000.
AT&T Technologies (formerly Western Electric) |
Role: Manufacturer of CPE/DTE |
AT&T Global Information Solutions (formerly NCR Corp.) | NCR Corp.
Role: Manufactures Computers, ATMs, Electronic Cash Registers | Role: Data Processing Systems (no PCs), ATMs, and Electronic Cash Registers. Revenues: $8 billion. Assets: $5 billion. Employees: 38,000.

AT&T also announced in February 1996 announced its Internet access service. The installation charge is waived through the first year of the offering. AT&T long distance customers get the first five hours of usage for free, additional usage is priced at very competitive rates.

In January 1996, AT&T purchased a 2.5% stake ($137 million) in DirecTV, a provider of entertainment TV via DBS satellite. AT&T will market DirectTV to its customer base, billing for the monthly services through its standard long distance billing system. Purchase and installation of the dishes can be financed through AT&T credit cards. AT&T has an option to increase the stake to 30%, depending on the number of customers it delivers to DirecTV [15-24].

US West offered in February 1996 to acquire Continental Cablevision for a package that totals $10.8 billion. US West hopes that this will be more successful than its investment in Time Warner—the two companies are suing each other over Time Warner’s agreement to buy Turner Broadcasting [15-38].

SBC (Southwestern Bell) announced in April 1996 its intent to acquire Pacific Telesis (Pacific Bell and Nevada Bell) subject to approvals of stockholders and regulators. The combined size of the companies will make the new organization a real force in the market. SBC’s 1995 revenues were $12.7 billion and PacTel’s $9.0 billion; their subscriber base will total 25 million, including 7 of the top 10 largest metropolitan markets in the U.S. and 16 of the top 50.

Bell Atlantic announced in April 1996 that it will acquire NYNEX for $22.1 billion in stock, ranking as the second largest merger in U.S. history. The new Bell Atlantic will boast combined assets of $51 billion, making it the second largest phone company, behind AT&T (which is splitting up, of course). Combined revenues will be $26.9 billion from a customer base of 37 million in a service territory which stretches from Maine to North Carolina.

Repaving the Information Superhighway

Repaving the I-Way sometimes means repaving the flyway, referring to airwave technologies. (The author begs forgiveness for stretching the metaphor to the breaking point.) In any event, a number of companies are investing vast amounts of money to gain advantage on the I-Way. In fact, it seems as though each week brings announcements equivalent to the annual GDP(Gross Domestic Product) of a third-world nation.

Bell Atlantic and Pacific Telesis won federal court approvals in March 1995 to provide InterLATA video services, and via satellite, in competition with CATV providers. Such services previously had been prohibited under the terms of the MFJ. Bell Atlantic’s approval extends nationwide, while Pacific Telesis is authorized to provide services across LATAs, but only within its service areas. Bell Atlantic later delayed its plans to offer CATV service. The impact on this agreement of the SBC acquisition of PacTel remains to be seen.

Bell Atlantic and NYNEX invested $100 million in CAI Wireless Systems. The investment is toward the development of broadband wireless video transmission.

Ameritech intends to spend $4.4 billion over 15 years for a hybrid fiber/coax network. The first phase will pass 300,000 homes by the end of 1995, and 1.2 million homes by year-end 1996. Each year thereafter, 1 million homes will be added to the network until such time as 6 million homes are passed.

GTE Corp. intends to invest $220 million to provide video service to 500,000 homes in Thousand Oaks, California and St. Petersburg and Clearwater, Florida. An earlier trial planned for Manassas, Virginia was canceled.

PacTel announced in March 1995 its intentions to develop a $16 billion fiber/coax network to serve 1 million homes in 23 cities by the end of 1996. An additional $40 billion is targeted to extend that network to half of California by 2000, and to all of California by 2010. Much of the content is intended to be provided by Tele-TV, a joint venture of PacTel, NYNEX, and Bell Atlantic. Media Server software will be provided by Oracle, MediaStream video jukeboxes will be provided by Hewlett-Packard and orders have been issued for 4 million set-top boxes [15-39]. The initial trial in Milpitas, California was canceled after disputes with the municipal government over right-of-way and taxation of video networks and services. Similar disputes have arisen in San Jose, where only a few hundred homes have been connected, rather than the 200,000 PacBell hoped to connect by mid-year 1996 [15-40]. Again, we’ll have to wait to see if the SBC takeover of PacTel has any effect on this arrangement and these trials.

BellSouth plans to trial video services to 12,000 homes in Atlanta and other areas.


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

Intuit, immediately after the failed acquisition by Microsoft, signed alliances with 20 of the largest U.S. financial institutions toward the provisioning of home-banking services using Intuit’s Quicken personal finance software. The alliance includes Chase Manhattan Corp., Bank of Boston, Union Bank, American Express Co., and Wells Fargo & Co. The banks and financial institutions will offer Quicken to their customers. Reportedly, several large banks now have cast an eye toward Intuit, although electronic banking has been less than a stunning success up to this point.

Continental Cablevision in September 1995 announced its intentions to invest $700 million to add voice, data, and VOD services to its existing networks in Los Angeles and the Central Valley of California. Pacific Bell currently provides telephone service to most of Continental’s 900,000 California customers [15-41].

Disney Development has teamed with AT&T Microelectronics, Broadband Technologies, Jones Intercable, General Electric and Honeywell Home Control to build a Fiber-to-the-Curb (FTTC) network in Celebration, Florida, a planned residential community near Disney’s EPCOT (Experimental Prototype Community of Tomorrow) Center. The ATM-based fiber network ultimately may serve as many as 20,000 residences via OC-1 SONET fiber at 51 Mbps. Each group of 100 homes will have access to the full 51 Mbps downstream via a local ATM switch; upstream bandwidth was not discussed. The FTTC system can be justified as the community will be a new development, with the network not being constrained by legacy technologies. The first residents were scheduled to move in in June 1, 1996, and the full broadband capabilities of the system are scheduled to be activated in 1997 [15-42].

Cablevision Systems Corp. spent $300 million in 1995 to rebuild its CATV system in Cleveland largely to fend off Ameritech [15-7].

Sprint, Comcast Corp., Cox Cable Communications and Tele-Communications Inc. (TCI) called off (January 1996) their 1994 agreement to upgrade millions of CATV lines to carry voice and data. The deal called for Sprint to pay its partners $1.75 per premise per month, plus 22% of the revenue from local exchange services. Sprint now plans to resell loops leased from LECs [15-43].

In Other News

Bay Networks agreed in September 1995 to buy Xylogics for $330 million in stock. Xylogics competes in the remote LAN access market.

Cisco Systems, Inc. announced in September 1995 it would buy Internet Junction, Inc. for $5.5 million in stock. Internet Junction manufactures software for Internet access.

Oracle (Media Server software) and Intel (ProShare videoconferencing software) announced in June 1995 their intention to develop technology to provide video conferencing and videomail through servers in a convergence environment, over ISDN lines.

Pacific Gas & Electric (PG&E) announced in June 1995 its intentions to wire 50 households is Walnut Creek, California. Through the CATV energy channel, users will be able to see how much their accrued bill is at any point in the month, what price they are paying per kilowatt hour, how much electricity their refrigerator is using and other information. Through a wireless remote control device, they will also be able to program a small computer on the TV set to change thermostat settings, turn appliances on and off, control lights when away from the home, pay energy bills automatically, and reduce bills by using certain appliances only during non-peak times. Communications with the appliances and meters will be through the use of power-line carrier, operating on existing electrical wiring. The project is in partnership with Microsoft (software and set-top box) and TCI (CATV). PG&E intends to extend system capabilities to include home security and fire alarms, and medical emergency panic buttons. The system and installation costs about $1,800 per household, and will be available to users at a cost or around $10 per month.

Cyberhomes, some 40,000 of them, exist using home automation systems such as that manufactured by Honeywell (Total Home), based on the X-10 chip. The cyberhome takes advantage of what some have termed to be a Home Area Network (HAN). In Corte Madera, California, 150 cyberhomes are offered, beginning at $450,000, plus $23,500 for the high-tech extras. Features include videoconferencing, Internet access, 5 PCs, a combined printer/copier/fax, and 5 residential local loops. The HAN is Ethernet in nature, with redundant fiber optic cables reserved for future use; an optional satellite dish is available.

US West announced (August 1995) its intentions to pull the plug on US Avenue, a Home Shopping venture in San Ramon, California. According to a company spokesperson: “More evolved technologies that could unlock home shopping are elusive. Cost-effective entertaining and informative programming formulas are yet to be discovered” [15-44].

Intel (software/firmware) announced (September 22, 1995) its intention to work with Lotus (software) to create software that will allow videoconferencing using Intel’s ProShare videoconferencing board while using Lotus Notes collaborative software. IBM, which recently acquired Lotus, will install the boards.

Netscape Navigator software security was recently (September, 1995) cracked, again. Two UC Berkeley students broke the security code and published the results on the Internet, forcing Netscape to scramble to provide a fix. The Internet’s security remains questionable.

The Computer Security Institute released in September 1995 the results of a recent study indicating that 20% of major companies, government agencies and universities have suffered a breach of computer network security. Nearly 40% indicated that they do not use firewalls. Startlingly, 30% of the break-ins occurred at sites where firewalls were installed! The study was mailed to 3,511 security professionals, of whom 320 responded. Sales of firewalls are expected to increase from $1.1 billion in 1995 to $16.2 billion in 2000, a compound growth rate of 70%. The same study indicated that 78% of the organizations used the Internet and that 83% of employees were provided Internet access.

The city and county of San Francisco announced in September 1995 its decision to accept 3Com’s offer of $4.0 million to rename Candlestick Park to 3Com park, at least for a period of four years. (Is nothing sacred in the Information Age?)


Communications Systems and Networks:Convergence: Information Superhighway or Superhypeway?

Tele-TV was formed as a content consortium by Pacific Telesis, Bell Atlantic and NYNEX. The consortium is headed by Howard Stringer, formerly of CBS. Americast was formed by Walt Disney, Ameritech, SBC (Southwestern Bell) and GTE for the same purpose.

SNET (Southern New England Telephone) abandoned (January 1996) its plans for interactive video dial tone. The company will pursue a standard CATV franchise in Connecticut. The company noted that the equipment is too expensive to provide services such as video-on-demand [15-45].

References

[15-1] “Cost To Build Info Superhighway May Top $100 Billion.” Communications News. May 1995.
[15-2] Reed, Nancy. “You Built It, They Will Come…Maybe.” Convergence. November 1994.
[15-3] Birkhead, Evan. “Reality Check.” Internetwork. September 1995.
[15-4] “Video-On-Demand: Are They Crazy?” Global Telecoms Business. October/November 1994.
[15-5] Lockwood, Judith S. “Dialing For Dollars: Video Dial Tone.” Convergence. May 1995.
[15-6] “Top 10 Interactive Television Trials.” Convergence. March 1996.
[15-7] Grover, Ronald. “I-Way or No Way for Cable?” Business Week. April 8, 1996.
[15-8] Arlen, Gary and Krasilovsky, Peter. “Whatever Happened to Interactive Television.” Convergence. March 1995.
[15-9] Boyle, Kellie. “FSN: Interactive Hyperbole?” Convergence. December 1995.
[15-10] Lockwood, Judith. “Utilities Energized for Telecom Business.” Convergence. November 1994.
[15-11] Buerger, David J. “The Inter-Personal Computer is a Trojan Horse that will Only Benefit Vendors.” Network World. November 20, 1995.
[15-12] Meade, Peter. “Crossing the Lines.” Information Week. August 21, 1995.
[15-13] Metcalfe, Bob. “Faster, easier, Cheaper Information Appliances Looking for New Identity.” InfoWorld. October 23, 1995.
[15-14] “PCs: ‘Ridiculous’ or Wave of Future?” San Francisco Examiner. September 9, 1995.
[15-15] Smith, Gina. “NC: An Idea Whose Time has Come. San Francisco Examiner. December 10, 1995.
[15-16] Yamaguchi, Mari. “Apple Tests Simpler, Cheaper Computer.” Seattle Post-Intelligencer. March 15, 1996.
[15-17] Williams, Tom. “The Facade of Ownership.” Telephony. January 23, 1995.
[15-18] Hargadon, Tom. “The State of the Info Highway.” New Media. October 1995.
[15-19] Arlen, Gary and Krasilovsky, Peter. “Market Squeeze for Digital Set-Tops.” Convergence. March 1996.
[15-20] “Cable TV—New Services, Positive Implications.” Investment Insights. Merrill Lynch, Pierce, Fenner & Smith. 1996.
[15-21] Dawson, Fred. “Cable Companies Add to Interactive Arsenal.” Inter@ctive Week. May 20, 1996.
[15-22] Dawson, Fred. “Cable Plays Catch-Up in Customer Services Arena.” Inter@ctive Week. June 17, 1996.
[15-23] Lutkowitz, Mark. “CATV Providers: Can They Succeed with Business Users?” Telecommunications. June 1995.
[15-24] Wilson, Carol. “How Will AT&T Phone Home?” Inter@ctive Week. January 29, 1996.
[15-25] Niggle, Michael R. and Nixon, Walter W. “Why Electric Utilities Should Build the Information Superhighway.” Telecommunications. March 1995.
[15-26] Kennedy, Michael. “Electric Utilities: The New Local Telephone Company.” Telecommunications. November 1995.
[15-27] Jones, Kyle F. “Electric Power, Cable TV, and Technology: The Glasgow Electric Plant Board Experience.” Presentation at ComNet '96. February 1, 1996.
[15-28] McElroy, Colleen. “Venture Set to Develop Online Cable Connection.” San Francisco Examiner. November 29, 1995.
[15-29] Bhasin, Roberta. “All Systems Go for Competition.” Convergence. April 1995.
[15-30] “Rochester Telephone’s New Frontier.” Convergence. April 1995.
[15-31] “Information Technology Industry: Mergers & Acquisitions.” Broadview Associates. July 15, 1996.
[15-32] Lieberman, David. “Time Warner Get $175M If TBS Deal Fails. USA Today. October 6, 1995.
[15-33] Sidel, Robin. “Turner, Time Warner Merger Talks Intensify.” San Francisco Examiner. September 14, 1995.
[15-34] Pelline, Jeff. “TCI Buys Viacom’s Cable TV Systems.” San Francisco Chronicle. July 26, 1995.
[15-35] Sakson, Steve. “Viacom Spinning Off Cable Systems.” San Francisco Examiner. July 25, 1995.
[15-36] Tanaka, Wendy. “PacTel Joins Cable TV Wars with Purchase of Jersey Firm.” San Francisco Examiner. July 27, 1995.
[15-37] Abate, Tom. “Time Warner Invests in Tech Future.” San Francisco Examiner. April 26, 1995.
[15-38] Lieberman, David. “US West, Continental Deal Could Spark More Mergers.” The Seattle Times. March 3, 1996.
[15-39] “Pac Bell to Give Oracle Interactive Contract.” San Francisco Chronicle. September 1, 1995.
[15-40] Buckholtz, Chris. “Pac Bell’s Fiber/Coax Network Hits Bureaucratic Snag.” Telephony. January 29, 1996.
[15-41] Bloomberg Business News. “Continental Cable Jumps into the Telephone Arena.” San Francisco Chronicle. September 1, 1995.
[15-42] Colman, Price. “Celebration: Town of the Future.” Convergence. December 1995.
[15-43] Rohde, David. “Sprint Cable Deal Dissolves.” Network World. February 19, 1996.
[15-44] Pelline, Jeff. “Lots of Hype, But Not Much Happening.” San Francisco Chronicle. August 11, 1995.
[15-45] Bernier, Paula. “SNET Kills VDT Plan, Opts for Cable TV Service.” Inter@ctive Week. January 29, 1996.


Communications Systems and Networks:Regulation: Issues Without Answers

Chapter 16
Regulation: Issues Without Answers

Order marches with weighty and measured strides; disorder is always in a hurry.

—Napoleon Bonaparte Maxims 1804-1815

Regulations, from Latin regula meaning rule, are rules or orders established by governmental bodies and having the force of law. As generally is the case in matters of government, regulations are not developed quickly. Like standards, they develop slowly, based on human experience and setting the stage for the next cycle of experience. Generally written by groups of lawyers, they are characteristically lengthy and complex to the extent that it takes other groups of lawyers to interpret them. Where there are disagreements or disputes, lawyers appeal to the regulators and all too often litigate those matters through the court systems. As noted by Karl Shapiro in Reports of My Death (Algonguin, 1990) "Lawyers love paper. They eat, sleep, and dream paper. They turn paper into gold, and their files are colorful and their language neoclassical and calligraphically bewigged…" While current regulations are available electronically, as well, the size of the files to be downloaded reflect the size of the official paper documents. (Author’s Note: At the time of this writing, regulatory changes are occurring with unprecedented speed in the U.S. The Telecommunications Act of 1996 currently is in the process of interpretation by the FCC, which is setting implementation rules at this very moment. Characteristically, such laws and rules will be challenged in the courts. Therefore, the views and opinions stated in this chapter are subject to change.)

This chapter isolates discussion of recent developments in U.S. regulation, as well as pending regulatory issues. I will focus on the Telecommunications Act of 1996 (The Act), and how it will shape the future of communications in the United States. Also discussed will be issues of decency, rates and tariffs, and number portability. Information relative to The Act and other regulatory and legislative information may be obtained from the FCC and Congress over the Internet as follows:

• World Wide Web: http://www.fcc.gov
• Gopher: gopher.fcc.gov
• FTP: ftp.fcc.gov (log in as anonymous, using your e-mail address as your password)
• House of Representatives: http://thomas.loc.gov
• Senate: gopher://ftp.senate.gov

Regulations tend to build on one another, for without the experience of history the future tends to be a bit uncertain. Over time, a complex fabric of regulation has been woven at the international, national, state and local levels. While the seams generally are well-stitched, there are significant overlaps in some cases and the patterns don’t always match up right. In the United States, the weave of the fabric traditionally has been very tight and has covered the body of communications from head to toe. The clear trend is one of a much lighter and much looser weave, and lesser coverage; in other words, deregulation. As deregulation takes hold and competition heats up, comfort and freedom of movement become increasingly important. The risk, of course, is that those unused to the full sun of a competitive environment (read LECs) may suffer from sunburn for a short time. Those same companies would claim to have sharpened their market skills in the cellular radio market over the past 10 years or so; as with all things, time will tell.

Full deregulation, however, is unlikely. At the risk of stretching the fabric analogy to the ripping point, the telecom world of New Zealand is completely nude. Some years ago (late 1980s), the government completely deregulated telecommunications, abolishing the regulator in the process. As a result, any legal disputes among carriers must be addressed through the courts, as with any other commercial civil dispute. Over the years, the carriers have engaged in several such disputes. The issue of interconnection, for instance, worked its way through the entire national court system and then was appealed to the Privy Council in England for final resolution. As one might expect, no other nation has taken deregulation quite to this extreme.

For the most part, the U.S. sets the regulatory model for the rest of the world. This has been the case traditionally, and continues to be so, with notable exceptions like that of New Zealand. Following the U.S. lead, CPE and long distance competition has been introduced in much of the world, and regulation generally has been relaxed in favor of allowing market forces to determine which products and services will find success, and at what prices. A great many nations have privatized their government-owned networks, either completely or partially. Numerous others have plans in that regard, including Australia, Germany, Italy, Korea, Spain, Thailand, and Turkey. In some cases, the proceeds of privatization have been earmarked for specific purposes such as education. Table 16.1 provides a chronology of selected key regulatory and legal events in telecommunications history.

Table 16.1 Summary of selected key regulatory and legal events in telecommunications history
Year | Event
1865 | ITU (International Telegraph Union) created. Later forms CCITT (now ITU-T) to set standards for international connectivity of telegraph networks (later, telecommunications and radio, as well).
1876 | Alexander Graham Bell granted patent for telephone.
1910 | Mann-Elkins Act grants Interstate Commerce Commission (ICC) interstate regulatory authority.
1913 | Department of Justice (DOJ) considers antitrust action against Bell System, based on commitment by President Woodrow Wilson to break up monopolies.
1913 | Kingsbury Commitment causes DOJ antitrust action to be dropped in return for AT&T’s agreement to interconnect with independent telephone companies, stop acquiring them, and divest its stock in Western Union.
1918 | Post Office assumes interstate regulatory authority for telephone and telegraph by executive order of President Wilson.
1921 | Graham-Willis Act establishes telephone companies as natural monopolies.
1927 | Radio Act of 1927 establishes Federal Radio Commission to regulate all radio spectrum except bands owned by federal government.
1934 | Communications Act of 1934 establishes Federal Communications Commission (FCC) to regulate interstate, international, and maritime communications, with universal service stated as the goal. DOJ begins major antitrust action against Bell System, which is delayed due to issues of national interest during WW II.
1935 | First state Public Utility Commissions (PUCs) formed to assume intrastate regulatory authority from municipal and city governments.
1945 | Supreme Court rules in Ashbacker Radio Corporation versus the FCC that radio spectrum allocation is to be on the basis of comparative hearings.
1949 | DOJ files antitrust action against AT&T, which action had been delayed by WW II. This action results in 1956 Consent Decree.
1955 | FCC’s Hush-a-Phone Decision supports AT&T’s contention that even acoustically-coupled foreign (non-telephone company provided) devices cannot be connected to the network without special arrangement.
1956 | Consent Decree negotiated as settlement between AT&T and DOJ, allowing AT&T to retain ownership of Western Electric if it manufacturers only for Bell companies. Also prevents Bell System from offering data processing services and other services not related to functions of a common carrier. Requires that Bell System patents be licensed to others on basis of reasonable fees.
1959 | FCC’s Above 890 Decision grants private microwave access to a dedicated portion of radio spectrum. Also allows construction of such networks, regardless of economic impact on the established common carrier.
1962 | Communications Act of 1962 places authority with FCC to assign commercial satellite frequencies. Act establishes Communications Satellite Corporation (Comsat) to act as a carriers’ carrier (wholesaler) for international satellite service and in conjunction with Intelsat. Intelsat (International Telecommunications Satellite Organization) established as international financial cooperative which owns and operates satellites for international communications.
1963 | Microwave Communications Inc. (MCI) files application to operate as a Specialized Common Carrier (SCC).
1968 | FCC’s Carterphone Decision counters Hush-a-Phone decision, allowing interconnection of foreign equipment through standard protective coupling device provided by telephone company.
1971 | FCC’s SCC Decision clears way for MCI and other SCCs to construct and operate networks.
1972 | FCC’s Domsat Decision allows domestic satellite market. AT&T excluded from market for three years.
1975 | FCC establishes Part 68 registration program for certification of foreign equipment, eliminating requirement for coupling devices.
1978 | FCC’s MTS/WATS Decision allows MCI and others to offer switched MTS voice services.
1980 | Second Computer Inquiry (Computer Inquiry II) requires AT&T to offer enhanced communications and CPE/DTE through separate subsidiary.
1982 | Modified Final Judgement (MFJ) negotiated between DOJ and AT&T as a modification to 1956 Consent Decree. MFJ forces divestiture of Bell Operating Companies (BOCs) and establishes equal access. Also removes restrictions on AT&T against computer and related businesses. AT&T retains Long Lines (long distance), Bell Telephone Laboratories (R&D), and Western Electric (manufacturing). AT&T retains embedded CPE base. AT&T files reorganization plan with Federal District Judge Harold H. Greene.Congress grants FCC authority to award radio spectrum licenses on basis of lottery, rather than comparative hearings. Cellular radio licenses are granted on this basis.
1983 | Judge Greene files order based on AT&T reorganization plan. Order specifies 7 RBOCs, with Bellcore for common R&D support. LATAs established, with AT&T and other IXCs allowed to provide interLATA service. BOCs and other LECs allowed exclusive rights to provide local and intraLATA long distance services.
1984 | MFJ takes full effect January 1.
1985-1996 | MFJ relaxed through series of waivers allowing RBOCs to offer enhanced services such as voice mail. Several PUCs allow IntraLATA and local competition.
1993 | Omnibus Budget Reconciliation Act provides for creation of a new class of wireless services, PCS. FCC authorized to auction PCS spectrum.
1994 | First PCS auctions held, raising $8.3 billion.
1996 | Telecommunications Act of 1996 passed by Congress, allowing full and open competition across all dimensions, including manufacturing, local service, and long distance. Conditions established for RBOC entry into long distance market within home states. FCC begins process of establishing rules for implementation of act. Implementation specifics in process of full definition; ultimate impact remains unclear. Communications Decency Act enacted to hold responsible creators of content and service providers both responsible for access of minors to indecent or offensive material over the Internet. The act was ruled unconstitutional, in violation of free speech guaranteed by the First Amendment. DOJ is expected to appeal to the Supreme Court.
Source: See [16-1], [16-2], [16-3], [16-4], [16-5], and [16-6].


Communications Systems and Networks:Regulation: Issues Without Answers

Telecommunications Act of 1996

On February 8, 1996 President Clinton signed into effect a law which passed both houses of Congress by overwhelming majorities and which will dramatically re-draw the landscape of telecommunications. The Telecommunications Act of 1996 (The Act) effectively supersedes the 1982 MFJ, removing line-of business restrictions and promising to allow full and open competition in virtually every aspect of communications—from radio broadcasting to CATV to local exchange and long distance. Ownership restrictions in large part will be lifted, allowing the carriers to invest, relate, merge, and acquire. Over time, some undoubtedly will retire. Rates will be deregulated, tariffs may be eliminated, and the regulator will take a back seat.

Lines of Business

The Act effectively removes the line-of-business restrictions imposed by national regulations since the early part of this century and strengthened by the MFJ. The RBOCs will be able to enter the long distance business, AT&T can compete as a LEC, they all can operate CATV businesses within and without their home states, they can manufacture products, and on, and on. In some cases, restrictions apply, at least until certain tests are satisfied.

Mergers and Acquisitions

The Act also lifts restrictions on ownership. In other words, LECs, IXCs. CATV, satellite, radio, TV, and wireless companies are free to merge, acquire and otherwise invest in each other without much in the way of restriction. Outside the world of telecommunications, strictly speaking, there has been a flurry of such activity for years as companies position themselves for the world of convergence (Chapter 15). Disney purchased Capital Cities/ABC and Time Warner bid for Turner Broadcasting. US West invested in Time Warner and has plans to acquire Continental Cablevision. AT&T invested in DirecTV, PacTel acquired Western Wireless, AT&T became an Internet Service Provider, and so on.

Since The Act passed, the emphasis has shifted, with SBC (Southwestern Bell) having acquired Pacific Telesis, and Bell Atlantic having bid for NYNEX. While both deals hinge on approvals from stockholders and regulators, they signal a dramatic increase in the pace of the race. Both deals are discussed in more detail later in this chapter.

Media ownership restrictions were eased as well. A company still is restricted in a single local market from owning two TV stations, or a newspaper and TV station, or a newspaper and CATV operation, or a CATV operation and broadcast TV station. However, the act does increase the stations which can be owned to a number which does not exceed 35% of the total national market.

Rules and Implementation

The FCC, despite a 10% budget cut, has a truly overwhelming task ahead. In the short term, there are 80 to 90 implementation rules that must be defined within the first six months. In the longer term (within 18 months of enactment) these rules must be revisited, tweaked, and fully implemented. In order to speed the process, the FCC rapidly released paper and electronic (WWW) Notices of Proposed Rulemaking (NPRMs). Respondents are severely limited to the length of their responses on the first round, and the second round of responses are even more limited, despite the fact that the NPRMs are quite lengthy. Additionally, response times are very short.

Included in the issues of significance are the Universal Service Fund, rules under which the LECs will be allowed to offer long distance service in their home states, interconnection between incumbent and competing carriers, and rights of way.

Universal Service

This remains an issue without a complete answer. The current Universal Service Fund (USF) involves about $17 billion a year to be paid directly to the LECs by IXCs and end users. The USF is designed to support the provisioning of life-line service to those who can’t afford the cost of basic telephone service. It also is intended to subsidize the cost of providing service to high-cost areas, defined as areas where the cost of providing service is at least 115% of the national average—in large part, it is a national cost averaging scheme designed for the benefit of society, in general [16-7] and [16-8].

In all likelihood, the USF will be spread over not only end users and IXCs, but also over providers of CATV, cellular and PCS services, as well as others who compete to provide voice and data services. Especially given the recent development of voice over the Internet, the Internet Service Providers (ISPs) and backbone providers likely will be asked to ante-up, as well. In fact, Internet access may well be defined as a basic service subject to support from the USF. The Act contains provisions for data service to every region in support of education, healthcare, and libraries.


Communications Systems and Networks:Regulation: Issues Without Answers

LEC Long Distance

Effective immediately on passage of The Act, the RBOCs, and GTOCs (GTE Operating Companies) were free to offer long distance services outside their home states. Several did just that, reselling long distance service to their cellular customers; additionally, NYNEX and Bell Atlantic planned to file resale tariffs immediately. Ultimately, they and other RBOCs are likely to place their own switches in support of their own traffic, much as do other facilities-based carriers. On a selective basis, they will also place their own transmission systems, much as do the CAPs.

Their getting into the long distance business at home, however, is another matter entirely…and the stakes are HUGE. Even in 1994, the interexchange long distance market was over $67 billion, with AT&T accounting for 55.2%, MCI 17.4%, and Sprint 10.1%. In US West territory (the smallest market) revenues are about $3.5 billion; at the top of the scale, Ameritech accounts for about $8.5 billion. The market is expected to grow at a compound annual rate of about 6% through the end of the twentieth century [16-9]. Clearly, the RBOCs are eager to leverage their brand recognition in their home states, where they are best known and where they enjoy long-standing relationships with customers. Additionally, their in-region intraLATA networks can be interconnected very easily.

In order to offer in-region long distance service, however, the RBOCs must satisfy a 14-point competitive checklist. Each point on the list is intended to prove that they offer competitors free and easy access to local facilities, and at fair and reasonable rates that are based on cost [16-10]. For the first three years after authority is granted, in-region long distance can be offered only on the basis of a separate subsidiary; after that time, the requirement disappears. Interestingly, the GTOCs are free to enter the interLATA market immediately and without restriction [16-11], even in-region. With the exception of Los Angeles, however, GTE does not serve any truly significant markets, although it does serve a number of major market suburbs (e.g., Irving, a suburb of Dallas, TX). As GTE’s far-flung service areas don’t generate enough traffic between them to support in-region networks, this issue likely is moot for GTE.

Interconnection: The Quid Pro Quo

Interconnection is an issue of great significance. The voice world always has been fully interconnected, while the data world has been less so, and the CATV world never had much use for the concept. In the world of convergence, all the competing carriers will offer some combination of voice, data, and content/entertainment. Voice and interconnection are the operative words here, as any viable service package must include voice and Internet access, which absolutely require interconnection through local loop facilities.

Interconnection issues cut several ways. Clearly the IXCs, CATV providers and other competing carriers are concerned about the terms under which they can connect to the existing local loop infrastructure in order to reach the customer quickly. While many of them will build or rebuild infrastructure to do that independently, that will take time and will be on a highly selective basis, addressing areas where market potential justifies the investment. On a wireless basis, the costs will be in the range of $750 to $1,000 per premise, with uncomfortable bandwidth constraints. On a wired basis, the costs will be more in the range of $2,000 to $5,000 per premise for a new plant and $500 to $750 for CATV and telephone company rebuilds and retrofits. Clearly, this level of investment is not trivial. In the meantime, the competing carriers must have access to the embedded local loop plant owned by the incumbent carrier. The terms of that interconnection are the immediate issue.

As we have discussed, the LECs must satisfy a checklist of 14 points in order to provide interLATA long distance within their home states. Most especially, they must satisfy the state PUCs, DOJ, and FCC that interconnection is a significant reality or, at least, is significantly available on reasonable terms. Further, the costs of interconnection must be at levels that reflect real costs in order that the competing carriers can buy local loop access at compensatory wholesale rates to allow them to retail those loops at competitive prices. Those costs must be unbundled in order that switch costs, for instance, not be applied to non-switched facilities.

The act identifies a minimum set of network elements to which access must be provided on an unbundled and nondiscriminatory basis—individual states may add to that list. The list of elements includes the following:

• Network interface devices
• Local loops
• Local and tandem switches (including software features)
• Interoffice transmission facilities
• Signaling and call-related database facilities
• Operations support systems (OSSs) and information
• Operator and directory assistance facilities

On one hand, the LECs have an interest in being agreeable, so that they can speed the process and wrest themselves free of the restrictions. On the other hand, they have an interest in delaying the process until such time as they can solidify their market positions. One could argue either way, and many do. The LECs suggest that their costs are very close to their tariffed retail prices for local loops and that wholesale discounts in the range of 5% are appropriate—that, in fact, is the discount offered by Rochester Telecom in its Rochester trial. AT&T and others suggest that the discounts should be more in the range of 25% to 40% [16-10]. Notably, AT&T virtually withdrew from the residential local service market in Rochester, claiming that it couldn’t survive in that market at those prices [16-12]. The battle lines appear to have been drawn—the PUCs, the DOJ, and the FCC will sort it all out, the courts will get involved, and so on. This issue is far from resolution.


Communications Systems and Networks:Regulation: Issues Without Answers

In the meantime, Ameritech has signed an interconnection agreement with MFS Communications; Bell Atlantic with Jones Intercable; and BellSouth with Time Warner, MCI, and Hart Communications. These RBOCs claim that they already have satisfied the 14-point checklist, and they have stated their plans to file for permission to offer long distance services in the subject states [16-13] and [16-14]. In the case of the Ameritech/MFS agreement, the companies have agreed that Ameritech will lease circuits, only, with the cost of the switch unbundled. Additionally, customers will retain their telephone numbers should they switch to MFS. Finally, they have stipulated to exchanging local traffic at identical and reciprocal rates [16-15]. Ameritech, NYNEX and Pacific Bell all have stated that they have satisfied the 14-point checklist and that they expect to have approval to offer long distance services in-region by year-end 1996 [16-11].

Elsewhere, things are not quite so friendly. AT&T filed a complaint with several PUCs to the effect that Ameritech isn’t cooperating; Ameritech countered to the effect that AT&T wasn’t offering compensatory rates. MCI filed complaints with the California and Oregon PUCs, complaining about anti-competitive measures associated with the use of the 415 (CA) and 916 (OR) area codes [16-16].

Also in the meantime, investment pours into local access. MCIMetro has committed some $2 billion to building its own facilities [16-17]. The company plans to have such service available in 24 cities by yearend 1996, and at competitive prices. For instance, MCIMetro service is available in Baltimore at rates 5% below that of Bell Atlantic [16-18]. Sprint has teamed with several CATV companies to develop local networks [16-7]. AT&T, while not revealing a strategy, estimates that building loops in the top 50 markets would exceed $5 billion [16-17]. In AT&T’s hip pocket, of course, is the wireless option; the company is a leading manufacturer of Wireless Local Loop (WLL) systems and owns a huge cellular company.

While AT&T groused about the wholesale cost of local loops in Rochester, Time Warner took another approach. The company has built 13 SONET rings, offering direct fiber links to large businesses and undercutting Rochester Tel by 10%-30% for local loop access. The brass ring, of course, (not to be confused with the fiber ring) is the volume of long distance and other services that the company plans to capture. Rochester Tel claims that it has suffered only 3%-4% erosion in its customer base, with most of that attributable to AT&T’s brief but aggressive spurt of residential activity [16-12].

Although the LECs are restricted in their home states, they are free to compete for long distance business elsewhere. Elsewhere, they face the same problems as do the competing carriers on their home turf. As we have noted, SBC and Ameritech immediately filed in a number of states to provide long distance service to their cellular customers on a resale basis. Undoubtedly, many of the RBOCs will aggressively pursue the long distance business, and initially on a resale basis. In time, they will build their own backbone facilities and place their own switches on a selective geographical basis. Yet, the issue of local loop interconnection remains. As the RBOCs begin to compete with each other, their discussions about interconnection arrangements should be most interesting. (Note: The Act contains provisions for of rural and small telephone companies to petition for certain exemptions. Such companies are defined as those with less the 2% of the nation’s subscriber base. This clause effectively provides for possible exemption for all but the RBOCs and GTE.)

Access to Rights of Way

The Act contains provisions relative to pole attachments; those provisions were amended by the FCC in its August 1, 1996 preliminary implementation rules. The Act and its FCC interpretation provide for nondiscriminatory access by CATV providers and telephone companies to poles, ducts, conduits, and rights-of-way owned by power utilities and incumbent LECs.


Communications Systems and Networks:Regulation: Issues Without Answers

Rates and Tariffs

Rates and tariffs have been part and parcel of telecommunications regulation for many years, as was discussed in Chapter 6. Beginning with the MFJ, the posture of the FCC gradually relaxed to the point that interstate long distance tariffs are largely optional. Actually, the FCC would prefer that they not be filed at all, and seriously is considering eliminating them altogether. Such a move would allow carriers to bundle services, perhaps including CPE in a package of cellular, PCS, long distance and local service. At last report, 10,000 annual long distance tariffs filed with the FCC account for 4 million pages of paper. In fact, there is discussion about eliminating local service tariffs, as well, in favor of allowing market forces to dictate prices in the soon-to-be competitive market [16-16], [16-19] and [16-20]. No doubt the spotted owl and other forest critters are looking forward to the outcome of this debate!

CATV providers have been up and down the regulatory path, first having been regulated, then deregulated, then re-regulated and now looking forward to de-regulation again. The Act charges the FCC with developing 18 new cable rules, in addition to those oriented specifically toward telecom. The intent is that all CATV regulations will be lifted in 1999. Should a CATV provider desire freedom at an earlier time, it must prove effective competition from at least one other provider. At this point, the rules specify that effective competition means that a rival must reach 50% of a market and that 15% of potential customers must have subscribed to the competing service. Not surprisingly, the CATV industry wants those numbers reduced, while competitors want them left untouched. Additionally, the FCC must deal with the issue of CATV set-top boxes, which currently are rented at very profitable rates. While retailers and manufacturers would prefer that they be sold outright, standards issues are a long way from being resolved [16-21].

The Internet

The Internet and, especially, the World Wide Web remain both hot topics and open issues. As part of the government’s initiatives in telecom reform, Congress passed the Communications Decency Act (CDA) in February 1996. That act provided for sentences of up to two years and levies of fines up to $250,000 for those who made indecent or offensive material available to minors on the Net. Not only were the creators of such content liable, but also the Information Service Providers (e.g., American Online, CompuServe, and Prodigy). A number of coalitions and groups lead by the American Civil Liberties Union (ACLU) and Electronic Frontier Foundation (EFF) challenged the law. The CDA was stricken down by a panel of federal judges in June 1996, citing violation of free speech as guaranteed by the First Amendment to the Constitution. Judge Stewart Dalzell, who wrote the opinion, stated that: “The Internet may fairly be regarded as a never-ending worldwide conversation. The government may not, through the CDA, interrupt that.” The Justice Department is expected to appeal the decision to the U.S. Supreme Court, which could hear final arguments as early as Fall 1996 [16-22].

Regardless of the outcome, the issue of censorship of the Internet and the Web will continue unabated for many years. It is clear that measures of some sort must be taken to limit access of minors to certain material. It may be that the government will require installation on newer PCs of something akin to the V-chip (Violence-chip) which are required to be included in new TV sets under provisions of The Act. Software filters currently are available that allow parents to impose some level of restriction, although the cost is additional and the filters must be updated continuously.

Other remaining Internet issues include the extent to which Internet Service Providers (ISPs) will be required to contribute to the Universal Service Fund. As the FCC develops rules and implementation strategies for The Act, the Internet, itself, may benefit through classification as an essential service. Its availability will be increased at low cost to libraries and schools, further encouraging its continuing and expanding use by future generations. More than just a footnote is the fact that the expanding use of Internet telephony (Chapter 13) certainly threatens to impact the Universal Service Fund in a very negative way.


Communications Systems and Networks:Regulation: Issues Without Answers

Number Portability

As noted in Chapter 6, the PSTN relies on a standard logical addressing scheme known as a numbering plan. Based on the U.S. numbering scheme (the first, if not the best approach), it includes country codes, area codes, central office prefixes and extensions. Various combinations of 1s and 0s are thrown in to advise the network of things like a request for operator assistance, or the crossing of an area code boundary or national border. These logical addresses always were oriented geographically in the voice world, and oriented by customer and carrier in the data world; further, those numbers were not portable.

The only true exceptions to this rule are relatively recent. In-WATS (800 and 888) numbers have been portable in the United States. for several years. In-WATS primarily serves voice applications, but also can suit data applications well, particularly with the advent of Digital 800 (Chapter 8). In the data world, IP addresses (data and Internet telephony) are specific to a device, rather than a physical location. Internet addresses are a curious mixture of fixed domains and logical extensions. Depending on your approach, you may be independent or you may be wed to an information service provider as we noted in Chapter 13.

The voice world is the real problem, as it is absolutely fundamental and as the traditional addressing scheme verges on exhaustion. First, and as we discussed in Chapter 6, the worldwide numbering scheme had to be expanded to relieve the pressure from the incredible growth of cellular phones, pagers and facsimile machines. Second, wireless PCS networks are sure to add greatly to that pressure. Finally, and as The Act opens the floodgates to competition, additional numbers will be required.

Contributing to the problem is the fact that the North American Numbering Plan (NANP) has been under the control of Bellcore since its inception in 1984, with the implementation responsibility, state-by-state, being in the hands of the largest carrier (read RBOC). As a result, there existed a strong disinclination toward flexibility (read portability). For example, customers choosing to do local service business with CAPs/AAVs rather than LECs (in the few states which permitted such an option) were required to change telephone numbers. While such an approach may seem unfair, the demand clearly was not great—certainly not to the extent that the significant investment in network intelligence would have been prudent. In a deregulated environment, competition would be hampered severely by such limitation, and the weight of demand clearly would warrant the associated investment.

In any event, the FCC has determined that Bellcore no longer can be considered as an impartial administrator of the NANP. As Bellcore is owned by the RBOCs, in consortium, it is assumed that Bellcore is biased or, at least, the specter of bias colors the organization’s perception. (This is particularly interesting at the moment, as Bellcore is in the process of being privatized. The interests of the RBOCs no longer are common, given the free-for-all landscape established by virtue of The Act.) As a result, the FCC will appoint a neutral North American Numbering Council (NANC) comprised of independent industry representatives and overseen by government observers; NXX code assignments and area code relief planning will be centralized in that impartial council. The North American Numbering Plan Administrator (NANPA) that will replace Bellcore in this capacity will be an independent commercial entity.

Further, the FCC is investigating long-term approaches to number portability to include portability by service provider, service type and location. Service provider portability will allow the customer to retain the same number if he changes providers. Service type portability will allow retention of the number should service type change. For instance, from analog POTS to ISDN to DID. Geographic portability is the ultimate, allowing retention of the same 10-digit number literally anywhere, much as one can roam with anywhere with a cellular phone. This last alternative is, by far, the most difficult to effect [16-23] and [16-24].

Re-Landscaping: Reorganizations and Mergers

The mergers and reorganizations stimulated by the Telecommunications Act of 1996 will have dramatic impact on employees. In addition to the breakup of AT&T, SCB, and Pacific Telesis have proposed to merge, as have Bell Atlantic and NYNEX. Whether breaking up, merging or just getting fit for battle, many companies are planning to downsize their staffs. AT&T, the RBOCs, GTE and others already have been through several rounds of downsizing and rightsizing. In some cases, this has led to the loss of critical human resources, giving rise to the term “dumbsizing.” (The next wave of activity undoubtedly will be to put another 50,000 consultants on the street, for which the author is not grateful.) Aside from the effect on company employees, the general landscape of communications will be affected.

The risks of downsizing can be illustrated by the experience of BellSouth. The company began a master plan in 1992 to control costs. That plan later was reversed to focus on a strategy to please its customers, regardless of cost. In other news, Ameritech reportedly is being sued by the Wisconsin PUC because of poor service allegedly resulting from its 1995 downsizing. Apparently, 11,500 people accepted the company’s early retirement, rather than the 5,000 expected to do so. Shortly thereafter, Ameritech hired 4,000 replacement workers to fill the gap [16-25]. All in all, Business Week reports that AT&T and the RBOCs have slashed 250,000 jobs since the MFJ took effect in 1984. On the bright side, however, total telecommunications jobs reportedly have grown by 54,000, thanks to cellular and other new services and products. Further, and if one considers telecommunications, computers, entertainment, and related manufacturing and service industries as a whole, the sector has generated 400,000 new jobs during the past year [16-26].


Communications Systems and Networks:Regulation: Issues Without Answers

AT&T

AT&T announced in September 1995 its intention to break into three companies, with the reorganization planned to be complete by January 1, 1997. As we discussed in Chapter 6, the new companies will be AT&T Corp. (long distance, credit cards, cellular and PCS, and Internet access), Lucent (Bell Labs and equipment manufacturing) and NCR (computers and related services, ATMs, and electronic cash registers). AT&T Corp. likely will continue to be strong in every respect. Lucent will benefit greatly, as the RBOCs, IXCs, CAPs and others were not inclined to purchase equipment from their largest competitor. Lucent’s independence from AT&T will remove that barrier. NCR likely will benefit, as well, as AT&T proved on several occasions that it could not be successful in the computer business; the tattered remnants of NCR will have a much better chance for renewed success as an independent entity.

SBC/Pacific Telesis

SBC (Southwestern Bell) and Pacific Telesis (Pacific Bell and Nevada Bell) were the first to announce their intent to merge, subject to approvals of stockholders and regulators. SBC bid an incredible $16.7 billion for PacTel, reportedly after several other potential bidders (GTE, NYNEX, and BellSouth) turned away from the opportunity. Southwestern Bell has been strong since divestiture and has been gaining strength ever since, largely by sticking to its core business. PacTel, on the other hand, has been weakened by the loss of AirTouch, as well as by the notoriously difficult regulatory environment in California. (AirTouch, by the way, has since linked with US West Cellular, yielding a cellular offering that blankets the West Coast.)

PacTel clearly will benefit from the financial strength of SBC, although the California PUC undoubtedly will offer SBC untold exciting challenges. The combined size of the companies will make the new organization a real force in the market. SBC’s 1995 revenues were $12.7 billion and PacTel’s $9.0 billion; their subscriber base will total 25 million, including 7 of the top 10 largest metropolitan markets in the U.S. and 16 of the top 50. In addition to increased aggregate strength in their core businesses, they will leverage their individual strengths in the highly competitive long distance market, as well as the emerging PCS business. Pacific Bell Mobile Services successfully bid for the PCS license in the Los Angeles/San Diego market, which has enormous potential. Southwestern Bell Mobile Services gained three licenses, including Tulsa. On the other hand, SBC does not have a reputation as being particularly aggressive in terms of data services (e.g., ISDN and Frame Relay). As the merger is effectively a SBC takeover of PacTel, the latter company’s workforce likely will be impacted to the greater extent [16-27] through [16-30].

Immediately after The Act was signed into law, SBC filed on February 15, 1996 its intention to offer long distance service in 16 states including Connecticut, Illinois, Massachusetts, New York, Virginia, and Washington, D.C. The service initially will be marketed to the company’s cellular customers under the Cellular One brand. While SBC, for the time being, will be only a reseller of long distance service [16-31], it likely will build its own facilities-based network over time.

Bell Atlantic/NYNEX

Bell Atlantic announced in April 1996 that it will acquire NYNEX for $22.1 billion in stock, ranking as the second largest merger in U.S. history behind the RJR Nabisco union with Kohlberg Kravis Roberts & Co. in 1989. The new Bell Atlantic will boast combined assets of $51 billion, making it the second largest phone company, behind AT&T (which is splitting up, of course). Combined revenues will be $26.9 billion from a customer base of 37 million in a service territory that stretches from Maine to North Carolina.

Significantly, 45% of all U.S. long distance calls either originate or terminate in that area, thereby positioning the new company for huge long distance profits. Notably, Bell Atlantic became the first RBOC to apply for permission to offer long distance service under the terms of The Act. On February 13, 1996, Bell Atlantic filed to provide long distance service in Texas and four other states, signaling its intentions to its former colleagues, the other RBOCs [16-29], [16-32] [16-33] and [16-34].

Future of the FCC

The overall future of the FCC has been the subject of great debate for the past several years. In fact, the agency has seen its budget cut by about 10% in 1996, despite the tremendous increase in workload brought about by The Act. There continue to be discussions in the halls of Congress about paring the agency down to an administrative body of about 250 people compared to the current number of approximately 2,500 [16-35] and [16-36].

According to Victor Toth, that downsized (there’s that word again) agency would be responsible for overseeing the allocation, auctioning and licensing of radio spectrum; and ensuring that high-cost areas are served. Additional responsibilities would include overseeing industry interconnection and competition, and serving as a repository for standards information [16-35]. Someone once said that a smart man leans from his own mistakes; a wise man learns from the mistakes of others. Let us not fail in our quest for wisdom; rather, let us learn from the experiences of our friends in New Zealand.


Communications Systems and Networks:Regulation: Issues Without Answers

So, What This Means to Me Is…?

What all of this means to all of us is yet to be determined. However some things are certain. First, carrier and service options will increase as telecom carriers, ISPs, and other data service providers, CATV providers, cellular and PCS carriers, and others compete for business. Second, products, and services will be bundled in interesting ways in order to capture all of that business. Third, costs will drop, and drop again, and probably again as competition heats up. As an indication, long distance dropped about 40% in the last decade. (Note: Don’t expect further reductions in this area, but there are lots of other areas.) Fourth, there will be a major shakeout in the industry over the next five years, and another five years later. Fifth, those with the deepest pockets (read RBOCs and IXCs) will continue to invest in or acquire their weaker rivals, including CATV providers, cellular, and PCS providers, WWW content providers and Internet software developers, manufacturers of LAN internetworking products, and DBS satellite carriers. They also will continue to invest in or strike strategic alliances with large content providers, such as Hollywood studios. Finally, they will continue to acquire each other, in the vein of the SBC/PacTel and Bell Atlantic/NYNEX mergers.

As the competition heats up, bundling of products and services promise to work to the advantage of the consumer, as in the case in the cellular world. Creative packages might include CPE and a full range of such services as cellular, PCS, long distance, In-WATS, Internet access, facsimile, and local service. Also, don’t be surprised when carriers begin to offer flat-rate long distance within a given area, like a LATA. In other words, for $50 a month one might make unlimited calls within that area. Extending the area to all of California, for example, or perhaps all of the Eastern Seaboard, would be a real incentive for customers to switch carriers.

In the meantime, and quite surprisingly, some rates are going up. US West, for instance, filed (early 1996) local service rate increases. In Washington, the company proposed to increase local service rates from $10.75 to $26 over the next four years; the state attorney-general’s consumer advocate countered with a suggestion that rates should be decreased to $10 a month [16-37]. Other LECs have filed similar plans in an attempt to price local service closer to actual costs, eliminating business/residence cross subsidies in the process. The IXCs also have been busy increasing rates. AT&T and MCI both have increased (July 1996) rates on popular services utilized by large client organizations; affected at the time of this writing are VPN and certain 800 services [16-38].

The end result is impossible to predict, but it is certain that those who keep their options open will find it to have been to their advantage. As the old Chinese saying goes, “May you live in interesting times.” There is no doubt that the next few years will be very interesting, indeed!

References

[16-1] Williams, Veronica A. Wireless Computing Primer. NY: M&T Books. 1996.
[16-2] Parker, Edwin B. and Hudson, Heather E. Electronic Byways: State Policies for Rural Development through Telecommunications. Washington, DC: The Aspen Institute. 1995.
[16-3] Bates, Bud and Gregory, Donald. Voice and Data Communications Handbook. NY: McGraw-Hill Inc. 1996.
[16-4] Tunstall, W. Brooke. Disconnecting Parties. NY: McGraw-Hill. 1985
[16-5] Hudson, Heather E. Communications Satellites. The Free Press. 1990.
[16-6] Snow, Marcellus S. Marketplace for Telecommunications. NY: Longman Inc. 1996.
[16-7] Gareiss, Robin. “Telecom Reform: The Real Deal.” Data Communications. March 21, 1996.
[16-8] Toth, Victor J. “The New Act—Too Many Questions; Too Few Answers.” Business Communications Review. June 1996.
[16-9] 1996 MultiMedia Telecommunications Market Review and Forecast. MultiMedia Telecommunications Association. 1996.
[16-10] Thyfault, Mary E. “The Telecom Act’s Promise. Information Week. April 15, 1996.
[16-11] Toth, Victor J. “FCC’s Moves on Long Distance.” Business Communications Review. April 1996.
[16-12] Greene, Tim. “Rochester, N.Y.: Land of the Free Market.” Network World. May 13, 1996.
[16-13] Wilson, Carol. “Interconnection or Not? AT&T Scoffs at Bells.” Inter@ctive Week. June 17. 1996.
[16-14] Schroeder, Erica. “RBOCs Ring Up Local Competition.” PC Week. June 17, 1996.
[16-15] Rockwell, Mark. “Bells Prep for Long Haul.” Communications Week. July 15, 1996.
[16-16] Schroeder, Erica. “Telecom Act Fuels Regulatory Wars.” PC Week. April 8, 1996.
[16-17] Kuehn, Richard A. “Carriers Plan a Competitive 1996.” Business Communications Review. January 1996.
[16-18] Schroeder, Erica. “MCI Reveals Plan to Expand Local Service.” PC Week. February 19, 1996.
[16-19] Rohde, David. “Long-Distance Tariffs Face FCC Ax” Network World. March 25, 1996.
[16-20] Toth, Victor J. “FCC Spinning Wheels in Implementation of New Act.” Business Communications Review. May 1996.
[16-21] Lewen, Mark. “Showtime for the Watchdog.” Business Week. April 8, 1996.
[16-22] Thyfault, Mary E. “Net Decency Law Shot Down.” Information Week. June 17, 1996.
[16-23] Toth, Victor J. “The FCC’s Complex Plans for Number Portability.” Business Communications Review. September 1995.
[16-24] Toth, Victor J. “Winners and Losers in FCC’s New NANP System.” Business Communications Review. October 1995.
[16-25] Wilde, Candee. “Shrink Raps.” tele.com. May 1996.
[16-26] “The Coming Telescramble.” Business Week. April 8, 1996.
[16-27] Rohde, David. “Are Bigger Bells Better?” Network World. April 8, 1996.
[16-28] Buerger, Dave. “SBC Takeover of PacTel Bodes Ill for Data Service Users.” Network World. April 8, 1996.
[16-29] Thyfault, Mary E. “Merger Frenzy Grips the Bells.” Information Week. April 29, 1996.
[16-30]Schroeder, Erica. “Merger Should Benefit IS.” PC Week. April 8, 1996.
[16-31] Lee, Steven H. “SBC Seeks OK to Operate in 16 States.” The Dallas Morning News. February 16, 1996.
[16-32] Judson, David. “Telecom Deals Call for Some Answers.” The Seattle Times. April 28, 1996.
[16-33] Lee, Steven H. “Bell Atlantic Seeking to Expand.” The Dallas Morning News. February 16, 1996.
[16-34] Kramer, Farrell. “Baby Bells in Biggest Telecom Merger.” San Francisco Examiner. April 22, 1996.
[16-35] Toth, Victor J. “The Regulatory Agenda—1995.” Business Communications Review. June 1995.
[16-36] Rohde, David. “Is The FCC Up to the Job?” Network World. February 12, 1996.
[16-37] Erickson, Jim. “What’s It Going to Cost?”
Seattle Post-Intelligencer. March 25, 1996.
[16-38] Rohde, David. “AT&T, MCI Ratchet Up Rates.” Network World. July 29, 1996.