Examples from sed & awk

sed & awk

Examples for sed & awk

Chapter 2: Understanding Basic Operations
byState
list
nameState
Chapter 3: Understanding Regular Expression Syntax
bookwords
gres
Chapter 4: Writing sed Scripts
do.outline
fixquotes.sed
format
getmac1
getmac2
horsefeathers
runsed
sedscr.horsefeathers
Chapter 5: Basic sed Commands
getmac
index.edit
man.data
refpage
refsed
sedman
Chapter 6: Advanced sed Commands
index.edit
phrase
scribe.font1.sed
scribe.font2.sed
test.scribe.data
Chapter 7: Writing Scripts for awk
acro
acronyms
checkbook.awk
checks.data
filesum1
filesum2
filesum3
fls.data
fls1
grades.data
grades1.awk
grades2.awk
Chapter 8: Conditionals, Loops, and Arrays
acronyms
awkro
bitmap.awk
bitmap.test
date-month
factorial
grades.awk
grades.test
lookup
sample
Chapter 9: Functions
caps
do.outline
grade.sort.awk
lotto
lower
mandata.sort
pick1
sort.awk
sorter.awk
Chapter 10: The Bottom Drawer
addemup
getfilename.awk
invoke
mansplit.awk
orders
uucp_commands
Chapter 11: A Flock of awks
cgiformat.awk
printerr.awk
querylog
simplesed.awk
Chapter 12: Full-Featured Applications
combine.idx
format.idx
index.data
input.idx
masterindex.1
masterindex.sh
pagenums.idx
spellcheck.awk
Chapter 13: A Miscellany of Scripts
adj.nawk
adj.sh
gent.csh
m0a.awk
m0b.awk
m1.awk
m1.ps
mailavg.sh
phonebill.awk
phonebill.data
plpr.sh
readsource.sh
transpose.data
transpose.sh
uutot.awk
uutot.data
The UNIX CD Bookshelf Navigation The UNIX CD Bookshelf UNIX Power Tools UNIX in a Nutshell Learning the vi Editor sed & awk Learning the Korn Shell Learning the UNIX Operating System