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So Windows 2003 Professional turned out to be a pipe dream, faster than we could 
get used to the idea being a reality it was played down/denied by Microsoft and all 
the knowledge base articles were removed to be corrected. It turned out to be an 
oversight. Well, we aren't ones to give up so easily at Neowin, so we have put 
together a guide that turns Windows Server 2003 Enterprise Edition into what 
we would rather call Windows 2003 Professional. 
 

Why, I hear you scream?  Well, there’s only one simple answer for that, because its newer than XP!  
 
What you need to get started 
Before we start grab the following  

• Microsoft DirectX 9 Web Setup 
• The Microsoft Java VM (build 3809) 
• The latest version of Windows Messenger or MSN Messenger (your choice) 
• The latest version of Xteq XSetup (optional) 
• The Neowin uxtheme.dll Patcher for build 3765. Here is a BACK-UP uxtheme.dll 

Pre Setup Notes 
I won't go into creating a guide to setup Windows 2003 because its 
basically the same as Windows XP with a few small changes which I will 
run through here quickly. During setup you are asked to specify the 
Client Access License (CAL). If you are installing Windows Server 2003 
to use as a workstation leave this setting at its default. Like Windows XP 
Professional you are prompted for the same things like joining a Domain 
or Workgroup, if you are familiar with Windows XP Professional setup 
then Server is no different with the exception of CAL configuration and 
the setup UI is grey instead of blue. 
 
When setup completes (costing the same amount of time as a typical XP install) you will be prompted on 
first boot to activate Windows in the same manner as XP. So as you can see, many aspects of the setup 
are the same. The changes begin here... 
 
Post Setup 
The first thing you can do is disable Manage Your Server (pic). There is 
no persistent nag screen in Windows Server 2003 like there was in 
Windows 2000 Server to setup a "Server Role" which is also a direct 
result of the new Server "Lockdown" initiative where a Security 
Lockdown Wizard determines what the Server may or may not do. 
Default is as it should be, Locked down. 
 
Then you should create a user account immediately. Leave the 
Administrator account in its default state and create your user name 
using these steps: (as shown in this pic) Click Start > Run > Type 
lusrmgr.msc Select and Right Click on the "User" folder and select New User. Create your user 
account, Click OK. Double click on your new user account > Select Member of tab > Click Add > 
Advanced > Find Now > Double click the first entry, it should say Administrators > OK > OK and close 
User Management. 
 
Log out, Login to your new account. 
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Disable the Shutdown Tracker 
Before we start installing Drivers and Applications that more often than not 
require a reboot, lets  disable the Server Enabled "Shutdown Event Tracker" 
this will enable you to reboot or shut down without being asked to submit a 
reason. Which is what we want for a Workstation configuration. 
 
Click Start > Run > Type MMC File > Add/Remove Snap-in... Add > Group 
Policy Object Editor > Add > Click Finish and Close then OK 
 
Navigate through > Local Computer Policy > Computer Configuration > 
Administrative Templates > and select the System folder 
 
Double Click Display Shutdown Event Tracker and select Disabled. 
OK > File > Exit 
 
Now you won't be asked why you need to reboot or shut down the system, just like in Windows 2000 
Professional.  
 
At present there is no Fast User Switching and Welcome Screen that can be enabled or used as it was 
simply not included with Windows Server 2003. (Power users usually turn it off anyway) Maybe someone 
will make a program that emulates or adds it later. If such a program becomes available we'll update to 
reflect this. 

 
Disable Internet Explorer Hardening  

 
When you open Internet Explorer in Windows Server 2003 you will see it in a new locked 
down state called Internet Explorer Enhanced Security Configuration, (pic) set at this 
level means you can't do much at all on the Internet as everything from untrusted domains is 

blocked regardless. We can disable this so we can download the programs we need to continue. 
 
In Internet Explorer > Click Tools > Internet Options > Security Tab and move the slider from High to 
Medium. If you are an advanced user you can set this to whatever level best suits your needs, Medium 
is the default setting for IE on a workstation and sufficient for most users. 
 
You will be prompted about lowering the level of security as a precaution select Yes if you wish to be able 
to access the Internet via IE. 
 
With Internet Explorer configured for the Internet you can now download Windows Messenger that 
integrates into Windows Server 2003 in the same way as Windows Messenger does in Windows XP. Using 
Windows Messenger enables your .NET passport to be saved in your user account which in turn logs you 
onto all passport sites automatically (pic) or you can also choose to use MSN Messenger 5 if you prefer a 
more stand-alone client. Both work and see Windows Server 2003 as Windows XP (at present). 

     
(Click on a thumbnail for a larger image) 
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Enable Hardware Acceleration  

 
By default Windows Server 2003 is hardware acceleration disabled for graphics cards, 
meaning only 2D and limited 3D capability is there. We can enable all this painlessly and 

without much effort. You will still be required to install 3D enabled drivers (like ATi Catalyst or nVIDIA 
Detonator drivers) for Windows 2000/XP. These can be installed on Windows Server 2003 but only after 
hardware acceleration is enabled will they work (and display the 3D related tabs in display properties) . 
 
In this image you can see the default setting for the hardware acceleration, to change it to this follow 
these steps: 
 
Right Click on desktop > Select "Properties" > Select "Settings" tab > Click "Advanced" > 
Select "Troubleshoot" tab and move the Hardware Acceleration slider all the way to "Full" > Click 
OK > OK 
 
That’s not all, DirectX (8.1) DirectDraw, Direct3D and AGP Texture Acceleration is also disabled by 
default on Windows Server 2003. (pic) to enable: 
 
Click Start > Run > Type dxdiag & enter > Select Display tab > Click Enable on all Acceleration 
options > Click Exit 

       
(Click on a thumbnail for a larger image) 

 
The result is Hardware Acceleration and DirectX enabled for Windows Server 2003. as you can see in the 
above pic I still have the default Microsoft drivers installed for my GeForce 4 Ti4400, so unless you had 
been previously prompted to reboot now is a good time to install those Detonator drivers (version of your 
choice) for Windows 2000/XP. If you use another type of card your 3D enabled drivers can be installed 
now. (Please remember that the latest Detonator drivers require DirectX 9) 
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Enable Services and Audio  

 
Now its time to enable the Themes service which allows 
you to select the Windows XP "Luna" themes from Display 
Properties. 
 

To do this: Click Start > Run > type services.msc & Enter > Look for 
the Themes service > Double Click it > Set the Startup dropdown to 
Automatic > Press Apply > Now you can press Start > Click OK 
 
 
Themes are now enabled While we are here lets enable Windows 
Audio 
 
Look for the Windows Audio service > Double Click it > Set the 
Startup dropdown to Automatic > Press Apply > Now you can 
press Start > Click OK 
 
While we are in the Services console, here are the services I manually 
disable because I personally have no need for them.  

• Automatic Updates 
• Computer Browser 
• Nvidia Driver Helper Service 
• Remote Registry 
• Secondary Logon 
• Task Scheduler 
• Windows Time 

The annoying Messenger service (what spammers have started to use to 
relay ads to the desktop) is disabled at default already, amazing stuff! 
 
Audio is now enabled in Windows Server 2003, That just leaves us to 
enable Hardware Acceleration for Audio in Windows (used for EAX and 
A3D)  
 
Click Start > Control Panel > Sounds and Audio Devices > In the 
Speaker Settings section click Advanced > Performance tab > Move 
the Hardware Acceleration slider to Full > Click OK > OK 
 
If you still don't have sound you may have to manually update your drivers 
from the device manager. This is the best way because packaged drivers 
(like Liveware) can't be installed on Windows Server 2003 from the setup.exe 
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Advanced Configuration  
 

As you can see in the following screenshot I have now enabled Luna and am using the 
Default (Blue) theme.  
 

Like Windows XP, Windows Server 2003 is set to "Let Windows choose whats best for my 
computer" on the Visual Effects tab. I set it to "Adjust for best appearance" which looks the nicer 
and well, my PC doesn't suffer from it. To do this: 
 
Right Click My Computer > Select Properties > Select Advanced tab > Click first Settings 
button > and on the Visual Settings tab select what best suits your needs 
 
Before you click OK also configure the Processor scheduling and Memory usage options, at default 
Windows 2003 Server is configured to be just that, a Server. If we want to run applications as a 
Workstation this tab will enable that.  
 
Default options are set for Processor scheduling to Background Services and Memory usage is 
limited to System Cache, what is good for a Server but not for a Workstation. 

     
(Click on a thumbnail for a larger image) 

 
 
Change Processor scheduling to Programs > Change Memory usage to Programs > Click 
OK > 
 
While still on the Advanced tab you can also choose to disable Error Reporting. To do this: 
 
Click Error Reporting in the Startup and Recovery section of the Advanced tab and set to 
Disable error reporting (be sure that the "But notify me when critical errors occur" is checked) 
Click OK > OK 
 

 
Windows Media Player 9  

Windows Media Player (build 2991) is shipped with Windows Server 2003 but 
its hidden away in the Start menu, to enable Media Player: 
 
 
 

Click Start > Programs > Accessories > Entertainment > Windows Media Player 
 
You will be presented with the Welcome to Windows Media Player screen. When filling in the tabs 
that are displayed, don't forget to check the More Options tab that allows you to add a Quick 
Launch icon so you can access Media Player directly from the Quick Launch area. Clicking finish will 
enable Windows Media Player 9 in Windows Server 2003. 
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Installing DirectX 9  
 

Windows Server 2003 is shipped with DirectX 8.1 so to enable the latest driver and 
card potential you will need to update to DirectX 9. Microsoft have continued the 
trend from Windows 2000 Server where the DirectX runtime can be installed on both 
Client and Server versions of Windows. So using the DirectX Web Setup from 

Microsoft we can update all the components as shown in this pic. A typical update is about 8mb, 
although the name still needs to be updated on the installer the whole thing is quick and painless 
and installs without a problem. A Reboot is required which brings me to my next and final 
Workstation conversion, The Neowin uxtheme.dll patch. 

       
(Click on a thumbnail for a larger image) 

 
Neowin is proud to be able to deliver a patched uxtheme.dll that enables you to use any 3rd party 
visual style to install follow these steps:  

1. Download the Neowin uxtheme.dll Patcher for build 3765 
2. Run the Patch overwriting uxtheme.dll in dllcache. You will get an error if you attempt to 

patch the uxtheme.dll in System32. 
3. Reboot to Safe Mode Command Prompt Only (using F8 while booting) 
4. Type ren C:\WINDOWS\System32\uxtheme.dll 

C:\WINDOWS\system32\uxtheme.bak and enter 
5. Type copy C:\WINDOWS\System32\dllcache\uxtheme.dll 

C:\WINDOWS\system32 
6. Reboot Windows. 

 
Note: replace C:\WINDOWS with your drive and WINDOWS folder name where applicable. 
 
 
Conclusion 
 
With Server now looking more like Windows XP you could go on to 
apply more tweaks and enhancements which can be done using Xteq 
XSetup as shown in this pic XSetup configures Windows Server 2003 
just as it would any NT enabled Windows OS so who needs TweakUI 
for Windows XP that won't even run on Windows Server 2003 while 
we have this neat application! 
 
I hope this guide has been of some help to you and I will be sure to 
update it when I am able to easily swap the Boot screen for 
something that looks more like Windows 2003 Professional and who knows, someone might have a 
way to reactivate a Welcome Screen that we can add here in the future. For now Windows Server 
2003 is "Workstation enabled" the rest is up to you, because after all only advanced users like to 
play with Server versions right?  


